]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
Merge changes leading to 1.8.4
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform make test
4 %bcond_with     tests_cvs       # perform tests which use CVS
5 %bcond_without  tests_svn       # perform tests which use subversion
6 %bcond_without  doc             # skip building/packaging docs/manuals (takes some time)
7 %bcond_without  pcre            # perl-compatible regexes support
8
9 %include        /usr/lib/rpm/macros.perl
10 Summary:        Distributed version control system focused on speed, effectivity and usability
11 Summary(pl.UTF-8):      Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
12 Name:           git-core
13 Version:        1.8.4
14 Release:        1
15 License:        GPL v2
16 Group:          Development/Tools
17 Source0:        http://git-core.googlecode.com/files/git-%{version}.tar.gz
18 # Source0-md5:  355768a1c70d0cb4fedf4b598ac1375b
19 Source1:        %{name}-gitweb.conf
20 Source2:        %{name}-gitweb-apache.conf
21 Source3:        %{name}-gitweb-lighttpd.conf
22 Source4:        %{name}.sysconfig
23 Source5:        %{name}.inet
24 Source6:        %{name}.init
25 Source7:        %{name}-gitweb-httpd.conf
26 Patch0:         %{name}-tests.patch
27 Patch1:         %{name}-key-bindings.patch
28 Patch2:         %{name}-sysconfdir.patch
29 Patch3:         cherry-picked-commitlog.patch
30 Patch4:         %{name}-svn-serf.patch
31 Patch5:         %{name}-svn-exit-errors.patch
32 URL:            http://git-scm.com/
33 BuildRequires:  autoconf >= 2.59
34 BuildRequires:  automake
35 BuildRequires:  curl-devel
36 BuildRequires:  expat-devel
37 BuildRequires:  gettext-devel
38 BuildRequires:  openssl-devel
39 %{?with_pcre:BuildRequires:     pcre-devel}
40 BuildRequires:  perl-Error > 0.15
41 BuildRequires:  perl-base
42 BuildRequires:  python-devel
43 BuildRequires:  rpm-perlprov >= 4.1-13
44 BuildRequires:  rpm-pythonprov
45 BuildRequires:  rpmbuild(macros) >= 1.264
46 BuildRequires:  tcl
47 BuildRequires:  zlib-devel
48 %if %{with doc}
49 BuildRequires:  asciidoc >= 7.1.2-3
50 BuildRequires:  docbook-dtd45-xml
51 BuildRequires:  xmlto
52 %endif
53 %if %{with tests}
54 %if %{with tests_cvs}
55 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
56 BuildRequires:  cvs-gnu-client < 1.13
57 BuildRequires:  cvs-gnu-client >= 1.12
58 %endif
59 %{?with_tests_svn:BuildRequires:  subversion}
60 Conflicts:      pdksh < 5.2.14-46
61 %endif
62 Requires:       coreutils
63 Requires:       diffutils
64 Requires:       findutils
65 Requires:       grep
66 Requires:       openssh-clients
67 Requires:       perl-Error
68 Requires:       perl-Git = %{version}-%{release}
69 Requires:       sed
70 Suggests:       git-core-cvs
71 Suggests:       git-core-svn
72 Suggests:       less
73 Suggests:       rsync
74 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
75
76 # html docs have links to txt files
77 %define         _noautocompressdoc      *.txt
78
79 %define         webapp          gitweb
80 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
81 %define         appdir          %{_datadir}/%{webapp}
82 %define         cgibindir       %{_prefix}/lib/cgi-bin
83 %define         bash_compdir    %{_datadir}/bash-completion/completions
84
85 %description
86 "git" can mean anything, depending on your mood.
87
88 - random three-letter combination that is pronounceable, and not
89   actually used by any common UNIX command. The fact that it is a
90   mispronunciation of "get" may or may not be relevant.
91 - stupid. contemptible and despicable. simple. Take your pick from the
92   dictionary of slang.
93 - "global information tracker": you're in a good mood, and it actually
94   works for you. Angels sing, and a light suddenly fills the room.
95 - "goddamn idiotic truckload of sh*t": when it breaks
96
97 This is a stupid (but extremely fast) directory content manager. It
98 doesn't do a whole lot, but what it 'does' do is track directory
99 contents efficiently.
100
101 %description -l pl.UTF-8
102 "git" może oznaczać cokolwiek, w zależności od nastroju.
103
104 - losową kombinację trzech liter, która jest wymawialna i właściwie
105   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
106   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
107 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
108 - "global information tracker" (narzędzie do globalnego śledzenia
109   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
110   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
111 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
112   g*) - kiedy się zepsuje.
113
114 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
115 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
116 katalogu.
117
118 %package doc
119 Summary:        Documentation for git-core
120 Summary(pl.UTF-8):      Dokumentacja do git-core
121 Group:          Documentation
122
123 %description doc
124 Documentation for git-core.
125
126 %description doc -l pl.UTF-8
127 Dokumentacja do git-core.
128
129 %description doc -l fr.UTF-8
130 Javadoc pour git-core.
131
132 %package daemon-inetd
133 Summary:        Files necessary to run git-daemon as an inetd service
134 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
135 Group:          Networking/Daemons
136 Requires:       %{name} = %{version}-%{release}
137 Requires:       setup >= 2.4.11-1
138 Provides:       git-core-daemon
139 Obsoletes:      git-core-daemon
140 Obsoletes:      git-core-daemon-standalone
141
142 %description daemon-inetd
143 Git-daemon is a really simple TCP git daemon that can serve git
144 repositories. This package provides all necessarry files to run
145 git-daemon as an inetd service.
146
147 %description daemon-inetd -l pl.UTF-8
148 Git-daemon to prosty demon git korzystający z protokołu TCP do
149 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
150 do uruchomienia git-demona w trybie usługi inetd.
151
152 %package daemon-standalone
153 Summary:        Files necessary to run git-daemon as a standalone service
154 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
155 Group:          Networking/Daemons
156 Requires:       %{name} = %{version}-%{release}
157 Provides:       git-core-daemon
158 Obsoletes:      git-core-daemon
159 Obsoletes:      git-core-daemon-inetd
160
161 %description daemon-standalone
162 Git-daemon is a really simple TCP git daemon that can serve git
163 repositories. This package provides all necessarry files to run
164 git-daemon as an standalone service.
165
166 %description daemon-standalone -l pl.UTF-8
167 Git-daemon to prosty demon git korzystający z protokołu TCP do
168 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
169 do uruchomienia git-daemona w trybie usługi samodzielnej.
170
171 %package devel
172 Summary:        Git library with header files
173 Summary(pl.UTF-8):      Biblioteka Gita oraz pliki nagłówkowe
174 Group:          Development/Libraries
175 Requires:       zlib-devel
176
177 %description devel
178 Git library with header files.
179
180 %description devel -l pl.UTF-8
181 Biblioteka Gita oraz pliki nagłówkowe.
182
183 %package gitk
184 Summary:        Tcl/Tk interface to the Git version control system
185 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
186 Group:          Development/Tools
187 Requires:       %{name} = %{version}-%{release}
188 Requires:       tk
189
190 %description gitk
191 gitk displays changes in a repository or a selected set of commits.
192 This includes visualizing the commit graph, showing information
193 related to each commit, and the files in the trees of each revision.
194
195 Historically, gitk was the first repository browser. It's written in
196 Tcl/Tk and started off in a separate repository but was later merged
197 into the main git repository.
198
199 %description gitk -l pl.UTF-8
200 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
201 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
202 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
203
204 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
205 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
206 osobnym repozytorium, ale z czasem został włączony do głównego
207 repozytorium gita.
208
209 %package gitweb
210 Summary:        Web frontend to git
211 Summary(pl.UTF-8):      Frontend WWW do gita
212 Group:          Development/Tools
213 Requires:       %{name} = %{version}-%{release}
214 Requires:       webapps
215 Requires:       webserver(alias)
216 Requires:       webserver(cgi)
217 Suggests:       webserver(setenv)
218 Conflicts:      apache-base < 2.4.0-1
219
220 %description gitweb
221 This package provides a web interface for browsing git repositories.
222
223 %description gitweb -l pl.UTF-8
224 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
225
226 %package gitview
227 Summary:        A GTK+ based repository browser for git
228 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
229 Group:          Development/Tools
230 Requires:       %{name} = %{version}-%{release}
231 Requires:       python >= 1:2.4
232 Requires:       python-pycairo >= 1.0
233 Requires:       python-pygobject
234 Requires:       python-pygtk-gtk >= 2:2.8
235 Suggests:       python-gnome-desktop-gtksourceview
236
237 %description gitview
238 A GTK+ based repository browser for git.
239
240 %description gitview -l pl.UTF-8
241 Oparta na GTK+ przeglądarka repozytorium gita.
242
243 %package gui
244 Summary:        Tcl/Tk interface to the Git version control system
245 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
246 Group:          Development/Tools
247 Requires:       %{name} = %{version}-%{release}
248 Requires:       tk
249 Requires:       xdg-utils
250 Suggests:       meld
251
252 %description gui
253 Displays changes in a repository or a selected set of commits. This
254 includes visualizing the commit graph, showing information related to
255 each commit, and the files in the trees of each revision.
256
257 Historically, gitk was the first repository browser. It's written in
258 Tcl/Tk and started off in a separate repository but was later merged
259 into the main git repository.
260
261 %description gui -l pl.UTF-8
262 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
263 to wizualizację grafu commitów, wyświetlanie informacji związanych z
264 każdym z commitów oraz listę plików dla każdej rewizji.
265
266 Z punktu widzenia historii, gitk był pierwszą przeglądarką
267 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
268 osobnym repozytorium, ale z czasem został włączony do głównego
269 repozytorium gita.
270
271 %package svn
272 Summary:        Subversion support for Git
273 Summary(pl.UTF-8):      Obsługa Subversion dla Gita
274 Group:          Development/Tools
275 Requires:       %{name} = %{version}-%{release}
276 Requires:       perl-Encode
277 Requires:       perl-Term-ReadKey
278
279 %description svn
280 Subversion support for Git.
281
282 %description svn -l pl.UTF-8
283 Obsługa Subversion dla Gita.
284
285 %package cvs
286 Summary:        CVS support for Git
287 Summary(pl.UTF-8):      Obsługa CVS dla Gita
288 Group:          Development/Tools
289 Requires:       %{name} = %{version}-%{release}
290 Requires:       cvsps >= 2.1-2
291 Requires:       rcs
292
293 %description cvs
294 CVS support for Git.
295
296 %description cvs -l pl.UTF-8
297 Obsługa CVS dla Gita.
298
299 %package arch
300 Summary:        Git tools for importing Arch repositories
301 Summary(pl.UTF-8):      Narzędzia Gita do importowania repozytoriów Archa
302 Group:          Development/Tools
303 Requires:       %{name} = %{version}-%{release}
304 Requires:       tla
305
306 %description arch
307 Git tools for importing Arch repositories.
308
309 %description arch -l pl.UTF-8
310 Narzędzia Gita do importowania repozytoriów Archa.
311
312 %package email
313 Summary:        Git tools for sending email
314 Summary(pl.UTF-8):      Narzędzia Gita do wysyłania poczty
315 Group:          Development/Tools
316 Requires:       %{name} = %{version}-%{release}
317
318 %description email
319 Git tools for sending email.
320
321 %description email -l pl.UTF-8
322 Narzędzia Gita do wysyłania poczty.
323
324 %package -n bash-completion-git
325 Summary:        bash-completion for git
326 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
327 Group:          Applications/Shells
328 Requires:       %{name} = %{version}-%{release}
329 Requires:       bash-completion >= 2.0
330
331 %description -n bash-completion-git
332 This package provides bash-completion for git.
333
334 %description -n bash-completion-git -l pl.UTF-8
335 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
336
337 %package -n perl-Git
338 Summary:        Perl interface to the Git version control system
339 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
340 Group:          Development/Languages/Perl
341 Obsoletes:      perl-git-core
342
343 %description -n perl-Git
344 This module provides Perl scripts easy way to interface the Git
345 version control system. The modules have an easy and well-tested way
346 to call arbitrary Git commands; in the future, the interface will also
347 provide specialized methods for doing easily operations which are not
348 totally trivial to do over the generic command interface.
349
350 %description -n perl-Git -l pl.UTF-8
351 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
352 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
353 dowolne polecenia Gita; w przyszłości interfejs udostępni także
354 specjalne metody do łatwego wykonywania operacji nietrywialnych do
355 wykonania przy użyciu ogólnego interfejsu poleceń.
356
357 %package -n python-Git
358 Summary:        Python Git remote helpers for non-git repositories
359 Summary(pl.UTF-8):      Pythonowe zdalne moduły pomocnicze dla repozytoriów niegitowych
360 Group:          Development/Languages/Python
361 Requires:       %{name} = %{version}-%{release}
362
363 %description -n python-Git
364 This package contains Python git_repote_helpers package - Git remote
365 helpers for non-git repositories.
366
367 %description -n python-Git -l pl.UTF-8
368 Ten pakiet zawiera pakiet Pythona git_remote_helpers - zdalne moduły
369 pomocnicze Gita dla repozytoriów niegitowych.
370
371 %package -n vim-syntax-gitcommit
372 Summary:        Vim syntax: gitcommit
373 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
374 Group:          Applications/Editors/Vim
375 Requires:       %{name} = %{version}-%{release}
376 # for _vimdatadir existence
377 Requires:       vim-rt >= 4:6.3.058-3
378
379 %description -n vim-syntax-gitcommit
380 This plugin provides syntax highlighting for git's commit messages.
381
382 %description -n vim-syntax-gitcommit -l pl.UTF-8
383 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
384
385 %prep
386 %setup -q -n git-%{version}
387 %patch0 -p1
388 %patch1 -p0
389 %patch2 -p1
390 %patch3 -p1
391 %patch4 -p1
392
393 %build
394 %{__aclocal}
395 %{__autoconf}
396 %configure \
397         --sysconfdir=%{_sysconfdir}/git-core \
398         %{?with_pcre:--with-libpcre} \
399         --with-openssl
400
401 echo "BLK_SHA1=1" >> config.mak
402
403 %{__make} \
404         INSTALLDIRS=vendor \
405         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
406         GITWEB_PROJECTROOT="/var/lib/git" \
407         GITWEB_CSS="/gitweb/gitweb.css" \
408         GITWEB_LOGO="/gitweb/git-logo.png" \
409         GITWEB_FAVICON="/gitweb/git-favicon.png" \
410         V=1
411
412 %if %{with doc}
413 %{__make} -C Documentation \
414         MAN_BASE_URL=file://%{_docdir}/%{name}-doc-%{version}/ \
415         V=1
416 %endif
417
418 %if %{with tests}
419 %if %{without tests_cvs}
420 %{__rm} t/t*cvs*.sh || :
421 %endif
422 %{!?with_tests_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
423 %endif
424
425 %install
426 rm -rf $RPM_BUILD_ROOT
427 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
428 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
429 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
430 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
431 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
432 [init]
433         templatedir = %{_sysconfdir}/%{name}/templates
434 EOF
435
436 %{__make} install \
437         INSTALLDIRS=vendor \
438         DESTDIR=$RPM_BUILD_ROOT
439
440 %if %{with doc}
441 %{__make} -C Documentation install \
442         DESTDIR=$RPM_BUILD_ROOT
443 %endif
444
445 # copy templates except sample hooks
446 cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
447 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
448
449 # header files and lib
450 cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
451 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
452 cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
453 install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
454 cp -p block-sha1/sha1.h $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
455 cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
456 cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
457 cp -p {Makefile,config.mak,config.mak.autogen,config.mak.uname} $RPM_BUILD_ROOT%{_includedir}/%{name}
458
459 # bash completion
460 install -d $RPM_BUILD_ROOT%{bash_compdir}
461 cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{bash_compdir}/git
462
463 # vim syntax
464 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
465 cat > $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax/gitcommit.vim << 'EOF'
466 autocmd BufNewFile,BufRead *.git/COMMIT_EDITMSG    setf gitcommit
467 autocmd BufNewFile,BufRead *.git/config,.gitconfig setf gitconfig
468 autocmd BufNewFile,BufRead git-rebase-todo         setf gitrebase
469 autocmd BufNewFile,BufRead .msg.[0-9]*
470         \ if getline(1) =~ '^From.*# This line is ignored.$' |
471         \   setf gitsendemail |
472         \ endif
473 autocmd BufNewFile,BufRead *.git/**
474         \ if getline(1) =~ '^\x\{40\}\>\|^ref: ' |
475         \   setf git |
476         \ endif
477 EOF
478
479 # gitweb
480 mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
481 ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
482 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
483 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
484 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
485 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
486
487 # gitview
488 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
489
490 # git-daemon related files
491 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
492 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
493 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
494
495 # paths cleanup
496 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
497 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
498
499 # hardlink
500 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
501 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
502 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
503 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
504
505 # remove unneeded files
506 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
507 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
508 %py_postclean
509
510 mv $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
511 %find_lang git
512
513 %clean
514 rm -rf $RPM_BUILD_ROOT
515
516 %post daemon-inetd
517 %service -q rc-inetd reload
518
519 %postun daemon-inetd
520 if [ "$1" = "0" ]; then
521         %service -q rc-inetd reload
522 fi
523
524 %post daemon-standalone
525 /sbin/chkconfig --add git-daemon
526 %service git-daemon restart "git-daemon"
527
528 %preun daemon-standalone
529 if [ "$1" = "0" ]; then
530         %service git-daemon stop
531         /sbin/chkconfig --del git-daemon
532 fi
533
534 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
535 %webapp_register apache %{webapp}
536
537 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
538 %webapp_unregister apache %{webapp}
539
540 %triggerin gitweb -- apache-base
541 %webapp_register httpd %{webapp}
542
543 %triggerun gitweb -- apache-base
544 %webapp_unregister httpd %{webapp}
545
546 %triggerin gitweb -- lighttpd
547 %webapp_register lighttpd %{webapp}
548
549 %triggerun gitweb -- lighttpd
550 %webapp_unregister lighttpd %{webapp}
551
552 %files -f git.lang
553 %defattr(644,root,root,755)
554 %doc README contrib
555 %attr(755,root,root) %{_bindir}/git
556 %attr(755,root,root) %{_bindir}/git-receive-pack
557 %attr(755,root,root) %{_bindir}/git-shell
558 %attr(755,root,root) %{_bindir}/git-upload-archive
559 %attr(755,root,root) %{_bindir}/git-upload-pack
560 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
561
562 %if %{with doc}
563 %{_mandir}/man1/git-*.1*
564 %exclude %{_mandir}/man1/git-archimport.1*
565 %exclude %{_mandir}/man1/git-svn.1*
566 %exclude %{_mandir}/man1/git-cvs*.1*
567 %exclude %{_mandir}/man1/git-imap-send*.1*
568 %exclude %{_mandir}/man1/*email*.1*
569 %exclude %{_mandir}/man1/gitremote-helpers.1*
570 %{_mandir}/man1/git.1*
571 %{_mandir}/man5/gitattributes.5*
572 %{_mandir}/man5/githooks.5*
573 %{_mandir}/man5/gitignore.5*
574 %{_mandir}/man5/gitmodules.5*
575 %{_mandir}/man5/gitrepository-layout.5*
576 %{_mandir}/man7/gitcli.7*
577 %{_mandir}/man7/gitcore-tutorial.7*
578 %{_mandir}/man7/gitcredentials.7*
579 %{_mandir}/man7/gitdiffcore.7*
580 %{_mandir}/man7/gitglossary.7*
581 %{_mandir}/man7/gitnamespaces.7*
582 %{_mandir}/man7/gitrevisions.7*
583 %{_mandir}/man7/gittutorial-2.7*
584 %{_mandir}/man7/gittutorial.7*
585 %{_mandir}/man7/gitworkflows.7*
586 %endif
587
588 %dir %{_libdir}/%{name}
589 %attr(755,root,root) %{_libdir}/%{name}/*-*
590 %attr(755,root,root) %{_libdir}/%{name}/git
591 %{_libdir}/%{name}/mergetools
592
593 %exclude %{_libdir}/%{name}/git-gui
594 %exclude %{_libdir}/%{name}/git-svn
595 %exclude %{_libdir}/%{name}/git-archimport
596 %exclude %{_libdir}/%{name}/git-cvs*
597 %exclude %{_libdir}/%{name}/git-imap-send
598 %exclude %{_libdir}/%{name}/git-instaweb
599 %exclude %{_libdir}/%{name}/git-remote-testsvn
600 %exclude %{_libdir}/%{name}/*email*
601
602 %{_datadir}/%{name}
603
604 %{_localstatedir}/lib/git
605
606 %if %{with doc}
607 %files doc
608 %defattr(644,root,root,755)
609 %doc Documentation/RelNotes*
610 %doc Documentation/*.html Documentation/howto Documentation/technical
611 %endif
612
613 %files daemon-inetd
614 %defattr(644,root,root,755)
615 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
616
617 %files daemon-standalone
618 %defattr(644,root,root,755)
619 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
620 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
621
622 %files devel
623 %defattr(644,root,root,755)
624 %{_includedir}/%{name}
625 %{_libdir}/libgit.a
626 %{_libdir}/libgit_xdiff.a
627
628 %files gitk
629 %defattr(644,root,root,755)
630 %if %{with doc}
631 %{_mandir}/man1/gitk.1*
632 %endif
633 %attr(755,root,root) %{_bindir}/gitk
634 %dir %{_datadir}/gitk
635 %dir %{_datadir}/gitk/lib
636 %dir %{_datadir}/gitk/lib/msgs
637 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
638 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
639 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
640 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
641 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
642 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
643 %lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
644 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
645 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
646
647 %files gitweb
648 %defattr(644,root,root,755)
649 %doc gitweb/{README,INSTALL}
650 %dir %{webappdir}
651 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
652 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
653 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
654 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
655 %attr(755,root,root) %{cgibindir}/gitweb.cgi
656 %{appdir}
657 %attr(755,root,root) %{_libdir}/%{name}/git-instaweb
658 %if %{with doc}
659 %{_mandir}/man1/gitweb.1*
660 %{_mandir}/man5/gitweb.conf.5*
661 %endif
662
663 %files gitview
664 %defattr(644,root,root,755)
665 %doc contrib/gitview/gitview.txt
666 %attr(755,root,root) %{_bindir}/gitview
667
668 %files gui
669 %defattr(644,root,root,755)
670 %attr(755,root,root) %{_libdir}/%{name}/git-gui
671 %dir %{_datadir}/git-gui
672 %dir %{_datadir}/git-gui/lib
673 %dir %{_datadir}/git-gui/lib/msgs
674 %{_datadir}/git-gui/lib/git-gui.ico
675 %{_datadir}/git-gui/lib/tclIndex
676 %{_datadir}/git-gui/lib/*.js
677 %{_datadir}/git-gui/lib/*.tcl
678 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
679 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
680 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
681 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
682 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
683 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
684 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
685 %lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
686 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
687 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
688 %lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
689
690 %files svn
691 %defattr(644,root,root,755)
692 %attr(755,root,root) %{_libdir}/%{name}/git-svn
693 %attr(755,root,root) %{_libdir}/%{name}/git-remote-testsvn
694 %{perl_vendorlib}/Git/SVN
695 %{perl_vendorlib}/Git/SVN.pm
696 %if %{with doc}
697 %{_mandir}/man1/git-svn.1*
698 %endif
699
700 %files cvs
701 %defattr(644,root,root,755)
702 %attr(755,root,root) %{_bindir}/git-cvsserver
703 %attr(755,root,root) %{_libdir}/%{name}/git-cvs*
704 %if %{with doc}
705 %{_mandir}/man1/git-cvs*.1*
706 %{_mandir}/man7/gitcvs-migration.7*
707 %endif
708
709 %files arch
710 %defattr(644,root,root,755)
711 %attr(755,root,root) %{_libdir}/%{name}/git-archimport
712 %if %{with doc}
713 %{_mandir}/man1/git-archimport.1*
714 %endif
715
716 %files email
717 %defattr(644,root,root,755)
718 %attr(755,root,root) %{_libdir}/%{name}/git-imap-send
719 %attr(755,root,root) %{_libdir}/%{name}/*email*
720 %if %{with doc}
721 %{_mandir}/man1/*email*.1*
722 %{_mandir}/man1/*imap-send*.1*
723 %endif
724
725 %files -n bash-completion-git
726 %defattr(644,root,root,755)
727 %{bash_compdir}/git
728
729 %files -n perl-Git
730 %defattr(644,root,root,755)
731 %{perl_vendorlib}/Git.pm
732 %dir %{perl_vendorlib}/Git
733 %{perl_vendorlib}/Git/I18N.pm
734 %{perl_vendorlib}/Git/IndexInfo.pm
735 %{_mandir}/man3/Git*.3pm*
736
737 %files -n python-Git
738 %defattr(644,root,root,755)
739 %dir %{py_sitescriptdir}/git_remote_helpers
740 %{py_sitescriptdir}/git_remote_helpers/*.py[co]
741 %dir %{py_sitescriptdir}/git_remote_helpers/git
742 %{py_sitescriptdir}/git_remote_helpers/git/*.py[co]
743 %if "%{py_ver}" > "2.4"
744 %{py_sitescriptdir}/git_remote_helpers*.egg-info
745 %endif
746 %if %{with doc}
747 %{_mandir}/man1/gitremote-helpers.1*
748 %endif
749
750 %files -n vim-syntax-gitcommit
751 %defattr(644,root,root,755)
752 %doc contrib/vim/README
753 %{_datadir}/vim/vimfiles/syntax/gitcommit.vim
This page took 0.093701 seconds and 4 git commands to generate.