]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
- up to 1.8.2.1
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform make test
4 %bcond_with     tests_cvs       # perform tests which use CVS
5 %bcond_without  tests_svn       # perform tests which use subversion
6 %bcond_without  doc             # skip building/packaging docs/manuals (takes some time)
7 %bcond_without  pcre            # perl-compatible regexes support
8
9 %include        /usr/lib/rpm/macros.perl
10 Summary:        Distributed version control system focused on speed, effectivity and usability
11 Summary(pl.UTF-8):      Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
12 Name:           git-core
13 Version:        1.8.2.1
14 Release:        1
15 License:        GPL v2
16 Group:          Development/Tools
17 Source0:        http://git-core.googlecode.com/files/git-%{version}.tar.gz
18 # Source0-md5:  3f6ebca116c627490e4ee1f1324d5e65
19 Source1:        %{name}-gitweb.conf
20 Source2:        %{name}-gitweb-httpd.conf
21 Source3:        %{name}-gitweb-lighttpd.conf
22 Source4:        %{name}.sysconfig
23 Source5:        %{name}.inet
24 Source6:        %{name}.init
25 Patch0:         %{name}-tests.patch
26 Patch1:         %{name}-key-bindings.patch
27 Patch2:         %{name}-sysconfdir.patch
28 Patch3:         cherry-picked-commitlog.patch
29 URL:            http://git-scm.com/
30 BuildRequires:  autoconf >= 2.59
31 BuildRequires:  automake
32 BuildRequires:  curl-devel
33 BuildRequires:  expat-devel
34 BuildRequires:  gettext-devel
35 BuildRequires:  openssl-devel
36 %{?with_pcre:BuildRequires:     pcre-devel}
37 BuildRequires:  perl-Error > 0.15
38 BuildRequires:  perl-base
39 BuildRequires:  python-devel
40 BuildRequires:  rpm-perlprov >= 4.1-13
41 BuildRequires:  rpm-pythonprov
42 BuildRequires:  rpmbuild(macros) >= 1.264
43 BuildRequires:  tcl
44 BuildRequires:  zlib-devel
45 %if %{with doc}
46 BuildRequires:  asciidoc >= 7.1.2-3
47 BuildRequires:  docbook-dtd45-xml
48 BuildRequires:  xmlto
49 %endif
50 %if %{with tests}
51 %if %{with tests_cvs}
52 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
53 BuildRequires:  cvs-gnu-client < 1.13
54 BuildRequires:  cvs-gnu-client >= 1.12
55 %endif
56 %{?with_tests_svn:BuildRequires:  subversion}
57 Conflicts:      pdksh < 5.2.14-46
58 %endif
59 Requires:       coreutils
60 Requires:       diffutils
61 Requires:       findutils
62 Requires:       grep
63 Requires:       openssh-clients
64 Requires:       perl-Error
65 Requires:       perl-Git = %{version}-%{release}
66 Requires:       sed
67 Suggests:       git-core-cvs
68 Suggests:       git-core-svn
69 Suggests:       less
70 Suggests:       rsync
71 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
72
73 # html docs have links to txt files
74 %define         _noautocompressdoc      *.txt
75
76 %define         webapp          gitweb
77 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
78 %define         appdir          %{_datadir}/%{webapp}
79 %define         cgibindir       %{_prefix}/lib/cgi-bin
80
81 %description
82 "git" can mean anything, depending on your mood.
83
84 - random three-letter combination that is pronounceable, and not
85   actually used by any common UNIX command. The fact that it is a
86   mispronunciation of "get" may or may not be relevant.
87 - stupid. contemptible and despicable. simple. Take your pick from the
88   dictionary of slang.
89 - "global information tracker": you're in a good mood, and it actually
90   works for you. Angels sing, and a light suddenly fills the room.
91 - "goddamn idiotic truckload of sh*t": when it breaks
92
93 This is a stupid (but extremely fast) directory content manager. It
94 doesn't do a whole lot, but what it 'does' do is track directory
95 contents efficiently.
96
97 %description -l pl.UTF-8
98 "git" może oznaczać cokolwiek, w zależności od nastroju.
99
100 - losową kombinację trzech liter, która jest wymawialna i właściwie
101   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
102   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
103 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
104 - "global information tracker" (narzędzie do globalnego śledzenia
105   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
106   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
107 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
108   g*) - kiedy się zepsuje.
109
110 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
111 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
112 katalogu.
113
114 %package doc
115 Summary:        Documentation for git-core
116 Summary(pl.UTF-8):      Dokumentacja do git-core
117 Group:          Documentation
118
119 %description doc
120 Documentation for git-core.
121
122 %description doc -l pl.UTF-8
123 Dokumentacja do git-core.
124
125 %description doc -l fr.UTF-8
126 Javadoc pour git-core.
127
128 %package daemon-inetd
129 Summary:        Files necessary to run git-daemon as an inetd service
130 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
131 Group:          Networking/Daemons
132 Requires:       %{name} = %{version}-%{release}
133 Requires:       setup >= 2.4.11-1
134 Provides:       git-core-daemon
135 Obsoletes:      git-core-daemon
136 Obsoletes:      git-core-daemon-standalone
137
138 %description daemon-inetd
139 Git-daemon is a really simple TCP git daemon that can serve git
140 repositories. This package provides all necessarry files to run
141 git-daemon as an inetd service.
142
143 %description daemon-inetd -l pl.UTF-8
144 Git-daemon to prosty demon git korzystający z protokołu TCP do
145 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
146 do uruchomienia git-demona w trybie usługi inetd.
147
148 %package daemon-standalone
149 Summary:        Files necessary to run git-daemon as a standalone service
150 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
151 Group:          Networking/Daemons
152 Requires:       %{name} = %{version}-%{release}
153 Provides:       git-core-daemon
154 Obsoletes:      git-core-daemon
155 Obsoletes:      git-core-daemon-inetd
156
157 %description daemon-standalone
158 Git-daemon is a really simple TCP git daemon that can serve git
159 repositories. This package provides all necessarry files to run
160 git-daemon as an standalone service.
161
162 %description daemon-standalone -l pl.UTF-8
163 Git-daemon to prosty demon git korzystający z protokołu TCP do
164 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
165 do uruchomienia git-daemona w trybie usługi samodzielnej.
166
167 %package devel
168 Summary:        Git library with header files
169 Summary(pl.UTF-8):      Biblioteka Gita oraz pliki nagłówkowe
170 Group:          Development/Libraries
171 Requires:       zlib-devel
172
173 %description devel
174 Git library with header files.
175
176 %description devel -l pl.UTF-8
177 Biblioteka Gita oraz pliki nagłówkowe.
178
179 %package gitk
180 Summary:        Tcl/Tk interface to the Git version control system
181 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
182 Group:          Development/Tools
183 Requires:       %{name} = %{version}-%{release}
184 Requires:       tk
185
186 %description gitk
187 gitk displays changes in a repository or a selected set of commits.
188 This includes visualizing the commit graph, showing information
189 related to each commit, and the files in the trees of each revision.
190
191 Historically, gitk was the first repository browser. It's written in
192 Tcl/Tk and started off in a separate repository but was later merged
193 into the main git repository.
194
195 %description gitk -l pl.UTF-8
196 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
197 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
198 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
199
200 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
201 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
202 osobnym repozytorium, ale z czasem został włączony do głównego
203 repozytorium gita.
204
205 %package gitweb
206 Summary:        Web frontend to git
207 Summary(pl.UTF-8):      Frontend WWW do gita
208 Group:          Development/Tools
209 Requires:       %{name} = %{version}-%{release}
210 Requires:       webapps
211 Requires:       webserver(alias)
212 Requires:       webserver(cgi)
213 Suggests:       webserver(setenv)
214
215 %description gitweb
216 This package provides a web interface for browsing git repositories.
217
218 %description gitweb -l pl.UTF-8
219 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
220
221 %package gitview
222 Summary:        A GTK+ based repository browser for git
223 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
224 Group:          Development/Tools
225 Requires:       %{name} = %{version}-%{release}
226 Requires:       python >= 1:2.4
227 Requires:       python-pycairo >= 1.0
228 Requires:       python-pygobject
229 Requires:       python-pygtk-gtk >= 2:2.8
230 Suggests:       python-gnome-desktop-gtksourceview
231
232 %description gitview
233 A GTK+ based repository browser for git.
234
235 %description gitview -l pl.UTF-8
236 Oparta na GTK+ przeglądarka repozytorium gita.
237
238 %package gui
239 Summary:        Tcl/Tk interface to the Git version control system
240 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
241 Group:          Development/Tools
242 Requires:       %{name} = %{version}-%{release}
243 Requires:       tk
244 Requires:       xdg-utils
245 Suggests:       meld
246
247 %description gui
248 Displays changes in a repository or a selected set of commits. This
249 includes visualizing the commit graph, showing information related to
250 each commit, and the files in the trees of each revision.
251
252 Historically, gitk was the first repository browser. It's written in
253 Tcl/Tk and started off in a separate repository but was later merged
254 into the main git repository.
255
256 %description gui -l pl.UTF-8
257 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
258 to wizualizację grafu commitów, wyświetlanie informacji związanych z
259 każdym z commitów oraz listę plików dla każdej rewizji.
260
261 Z punktu widzenia historii, gitk był pierwszą przeglądarką
262 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
263 osobnym repozytorium, ale z czasem został włączony do głównego
264 repozytorium gita.
265
266 %package svn
267 Summary:        Subversion support for Git
268 Summary(pl.UTF-8):      Obsługa Subversion dla Gita
269 Group:          Development/Tools
270 Requires:       %{name} = %{version}-%{release}
271 Requires:       perl-Encode
272 Requires:       perl-Term-ReadKey
273
274 %description svn
275 Subversion support for Git.
276
277 %description svn -l pl.UTF-8
278 Obsługa Subversion dla Gita.
279
280 %package cvs
281 Summary:        CVS support for Git
282 Summary(pl.UTF-8):      Obsługa CVS dla Gita
283 Group:          Development/Tools
284 Requires:       %{name} = %{version}-%{release}
285 Requires:       cvsps >= 2.1-2
286 Requires:       rcs
287
288 %description cvs
289 CVS support for Git.
290
291 %description cvs -l pl.UTF-8
292 Obsługa CVS dla Gita.
293
294 %package arch
295 Summary:        Git tools for importing Arch repositories
296 Summary(pl.UTF-8):      Narzędzia Gita do importowania repozytoriów Archa
297 Group:          Development/Tools
298 Requires:       %{name} = %{version}-%{release}
299 Requires:       tla
300
301 %description arch
302 Git tools for importing Arch repositories.
303
304 %description arch -l pl.UTF-8
305 Narzędzia Gita do importowania repozytoriów Archa.
306
307 %package email
308 Summary:        Git tools for sending email
309 Summary(pl.UTF-8):      Narzędzia Gita do wysyłania poczty
310 Group:          Development/Tools
311 Requires:       %{name} = %{version}-%{release}
312
313 %description email
314 Git tools for sending email.
315
316 %description email -l pl.UTF-8
317 Narzędzia Gita do wysyłania poczty.
318
319 %package -n bash-completion-git
320 Summary:        bash-completion for git
321 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
322 Group:          Applications/Shells
323 Requires:       %{name} = %{version}-%{release}
324 Requires:       bash-completion
325
326 %description -n bash-completion-git
327 This package provides bash-completion for git.
328
329 %description -n bash-completion-git -l pl.UTF-8
330 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
331
332 %package -n perl-Git
333 Summary:        Perl interface to the Git version control system
334 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
335 Group:          Development/Languages/Perl
336 Obsoletes:      perl-git-core
337
338 %description -n perl-Git
339 This module provides Perl scripts easy way to interface the Git
340 version control system. The modules have an easy and well-tested way
341 to call arbitrary Git commands; in the future, the interface will also
342 provide specialized methods for doing easily operations which are not
343 totally trivial to do over the generic command interface.
344
345 %description -n perl-Git -l pl.UTF-8
346 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
347 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
348 dowolne polecenia Gita; w przyszłości interfejs udostępni także
349 specjalne metody do łatwego wykonywania operacji nietrywialnych do
350 wykonania przy użyciu ogólnego interfejsu poleceń.
351
352 %package -n python-Git
353 Summary:        Python Git remote helpers for non-git repositories
354 Summary(pl.UTF-8):      Pythonowe zdalne moduły pomocnicze dla repozytoriów niegitowych
355 Group:          Development/Languages/Python
356 Requires:       %{name} = %{version}-%{release}
357
358 %description -n python-Git
359 This package contains Python git_repote_helpers package - Git remote
360 helpers for non-git repositories.
361
362 %description -n python-Git -l pl.UTF-8
363 Ten pakiet zawiera pakiet Pythona git_remote_helpers - zdalne moduły
364 pomocnicze Gita dla repozytoriów niegitowych.
365
366 %package -n vim-syntax-gitcommit
367 Summary:        Vim syntax: gitcommit
368 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
369 Group:          Applications/Editors/Vim
370 Requires:       %{name} = %{version}-%{release}
371 # for _vimdatadir existence
372 Requires:       vim-rt >= 4:6.3.058-3
373
374 %description -n vim-syntax-gitcommit
375 This plugin provides syntax highlighting for git's commit messages.
376
377 %description -n vim-syntax-gitcommit -l pl.UTF-8
378 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
379
380 %prep
381 %setup -q -n git-%{version}
382 %patch0 -p1
383 %patch1 -p0
384 %patch2 -p1
385 %patch3 -p1
386
387 %build
388 %{__aclocal}
389 %{__autoconf}
390 %configure \
391         --sysconfdir=%{_sysconfdir}/git-core \
392         %{?with_pcre:--with-libpcre} \
393         --with-openssl
394
395 echo "BLK_SHA1=1" >> config.mak
396
397 %{__make} \
398         INSTALLDIRS=vendor \
399         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
400         GITWEB_PROJECTROOT="/var/lib/git" \
401         GITWEB_CSS="/gitweb/gitweb.css" \
402         GITWEB_LOGO="/gitweb/git-logo.png" \
403         GITWEB_FAVICON="/gitweb/git-favicon.png" \
404         V=1
405
406 %if %{with doc}
407 %{__make} -C Documentation \
408         MAN_BASE_URL=file://%{_docdir}/%{name}-doc-%{version}/ \
409         V=1
410 %endif
411
412 %if %{with tests}
413 %if %{without tests_cvs}
414 %{__rm} t/t*cvs*.sh || :
415 %endif
416 %{!?with_tests_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
417 %endif
418
419 %install
420 rm -rf $RPM_BUILD_ROOT
421 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
422 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
423 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
424 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
425 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
426 [init]
427         templatedir = %{_sysconfdir}/%{name}/templates
428 EOF
429
430 %{__make} install \
431         INSTALLDIRS=vendor \
432         DESTDIR=$RPM_BUILD_ROOT
433
434 %if %{with doc}
435 %{__make} -C Documentation install \
436         DESTDIR=$RPM_BUILD_ROOT
437 %endif
438
439 # copy templates except sample hooks
440 cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
441 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
442
443 # header files and lib
444 cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
445 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
446 cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
447 cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
448 cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
449
450 # bash completion
451 install -d $RPM_BUILD_ROOT/etc/bash_completion.d
452 cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT/etc/bash_completion.d
453
454 # vim syntax
455 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
456 cat > $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax/gitcommit.vim << 'EOF'
457 autocmd BufNewFile,BufRead *.git/COMMIT_EDITMSG    setf gitcommit
458 autocmd BufNewFile,BufRead *.git/config,.gitconfig setf gitconfig
459 autocmd BufNewFile,BufRead git-rebase-todo         setf gitrebase
460 autocmd BufNewFile,BufRead .msg.[0-9]*
461         \ if getline(1) =~ '^From.*# This line is ignored.$' |
462         \   setf gitsendemail |
463         \ endif
464 autocmd BufNewFile,BufRead *.git/**
465         \ if getline(1) =~ '^\x\{40\}\>\|^ref: ' |
466         \   setf git |
467         \ endif
468 EOF
469
470 # gitweb
471 mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
472 ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
473 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
474 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
475 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
476 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
477
478 # gitview
479 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
480
481 # git-daemon related files
482 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
483 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
484 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
485
486 # paths cleanup
487 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
488 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
489
490 # hardlink
491 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
492 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
493 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
494 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
495
496 # remove unneeded files
497 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
498 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
499 %py_postclean
500
501 mv $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
502 %find_lang git
503
504 %clean
505 rm -rf $RPM_BUILD_ROOT
506
507 %post daemon-inetd
508 %service -q rc-inetd reload
509
510 %postun daemon-inetd
511 if [ "$1" = "0" ]; then
512         %service -q rc-inetd reload
513 fi
514
515 %post daemon-standalone
516 /sbin/chkconfig --add git-daemon
517 %service git-daemon restart "git-daemon"
518
519 %preun daemon-standalone
520 if [ "$1" = "0" ]; then
521         %service git-daemon stop
522         /sbin/chkconfig --del git-daemon
523 fi
524
525 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
526 %webapp_register apache %{webapp}
527
528 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
529 %webapp_unregister apache %{webapp}
530
531 %triggerin gitweb -- apache < 2.2.0, apache-base
532 %webapp_register httpd %{webapp}
533
534 %triggerun gitweb -- apache < 2.2.0, apache-base
535 %webapp_unregister httpd %{webapp}
536
537 %triggerin gitweb -- lighttpd
538 %webapp_register lighttpd %{webapp}
539
540 %triggerun gitweb -- lighttpd
541 %webapp_unregister lighttpd %{webapp}
542
543 %files -f git.lang
544 %defattr(644,root,root,755)
545 %doc README contrib
546 %attr(755,root,root) %{_bindir}/git
547 %attr(755,root,root) %{_bindir}/git-receive-pack
548 %attr(755,root,root) %{_bindir}/git-shell
549 %attr(755,root,root) %{_bindir}/git-upload-archive
550 %attr(755,root,root) %{_bindir}/git-upload-pack
551 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
552
553 %if %{with doc}
554 %{_mandir}/man1/git-*.1*
555 %exclude %{_mandir}/man1/git-archimport.1*
556 %exclude %{_mandir}/man1/git-svn.1*
557 %exclude %{_mandir}/man1/git-cvs*.1*
558 %exclude %{_mandir}/man1/*email*.1*
559 %exclude %{_mandir}/man1/gitremote-helpers.1*
560 %{_mandir}/man1/git.1*
561 %{_mandir}/man5/gitattributes.5*
562 %{_mandir}/man5/githooks.5*
563 %{_mandir}/man5/gitignore.5*
564 %{_mandir}/man5/gitmodules.5*
565 %{_mandir}/man5/gitrepository-layout.5*
566 %{_mandir}/man7/gitcli.7*
567 %{_mandir}/man7/gitcore-tutorial.7*
568 %{_mandir}/man7/gitcredentials.7*
569 %{_mandir}/man7/gitdiffcore.7*
570 %{_mandir}/man7/gitglossary.7*
571 %{_mandir}/man7/gitnamespaces.7*
572 %{_mandir}/man7/gitrevisions.7*
573 %{_mandir}/man7/gittutorial-2.7*
574 %{_mandir}/man7/gittutorial.7*
575 %{_mandir}/man7/gitworkflows.7*
576 %endif
577
578 %dir %{_libdir}/%{name}
579 %attr(755,root,root) %{_libdir}/%{name}/*-*
580 %attr(755,root,root) %{_libdir}/%{name}/git
581 %{_libdir}/%{name}/mergetools
582
583 %exclude %{_libdir}/%{name}/git-gui
584 %exclude %{_libdir}/%{name}/git-svn
585 %exclude %{_libdir}/%{name}/git-archimport
586 %exclude %{_libdir}/%{name}/git-cvs*
587 %exclude %{_libdir}/%{name}/git-instaweb
588 %exclude %{_libdir}/%{name}/git-remote-testpy
589 %exclude %{_libdir}/%{name}/git-remote-testsvn
590 %exclude %{_libdir}/%{name}/*email*
591
592 %{_datadir}/%{name}
593
594 %{_localstatedir}/lib/git
595
596 %if %{with doc}
597 %files doc
598 %defattr(644,root,root,755)
599 %doc Documentation/RelNotes*
600 %doc Documentation/*.html Documentation/howto Documentation/technical
601 %endif
602
603 %files daemon-inetd
604 %defattr(644,root,root,755)
605 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
606
607 %files daemon-standalone
608 %defattr(644,root,root,755)
609 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
610 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
611
612 %files devel
613 %defattr(644,root,root,755)
614 %{_includedir}/%{name}
615 %{_libdir}/libgit.a
616 %{_libdir}/libgit_xdiff.a
617
618 %files gitk
619 %defattr(644,root,root,755)
620 %if %{with doc}
621 %{_mandir}/man1/gitk.1*
622 %endif
623 %attr(755,root,root) %{_bindir}/gitk
624 %dir %{_datadir}/gitk
625 %dir %{_datadir}/gitk/lib
626 %dir %{_datadir}/gitk/lib/msgs
627 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
628 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
629 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
630 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
631 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
632 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
633 %lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
634 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
635 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
636
637 %files gitweb
638 %defattr(644,root,root,755)
639 %doc gitweb/{README,INSTALL}
640 %dir %{webappdir}
641 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
642 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
643 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
644 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
645 %attr(755,root,root) %{cgibindir}/gitweb.cgi
646 %{appdir}
647 %attr(755,root,root) %{_libdir}/%{name}/git-instaweb
648 %if %{with doc}
649 %{_mandir}/man1/gitweb.1*
650 %{_mandir}/man5/gitweb.conf.5*
651 %endif
652
653 %files gitview
654 %defattr(644,root,root,755)
655 %doc contrib/gitview/gitview.txt
656 %attr(755,root,root) %{_bindir}/gitview
657
658 %files gui
659 %defattr(644,root,root,755)
660 %attr(755,root,root) %{_libdir}/%{name}/git-gui
661 %dir %{_datadir}/git-gui
662 %dir %{_datadir}/git-gui/lib
663 %dir %{_datadir}/git-gui/lib/msgs
664 %{_datadir}/git-gui/lib/git-gui.ico
665 %{_datadir}/git-gui/lib/tclIndex
666 %{_datadir}/git-gui/lib/*.js
667 %{_datadir}/git-gui/lib/*.tcl
668 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
669 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
670 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
671 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
672 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
673 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
674 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
675 %lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
676 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
677 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
678 %lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
679
680 %files svn
681 %defattr(644,root,root,755)
682 %attr(755,root,root) %{_libdir}/%{name}/git-svn
683 %attr(755,root,root) %{_libdir}/%{name}/git-remote-testsvn
684 %{perl_vendorlib}/Git/SVN
685 %{perl_vendorlib}/Git/SVN.pm
686 %if %{with doc}
687 %{_mandir}/man1/git-svn.1*
688 %endif
689
690 %files cvs
691 %defattr(644,root,root,755)
692 %attr(755,root,root) %{_bindir}/git-cvsserver
693 %attr(755,root,root) %{_libdir}/%{name}/git-cvs*
694 %if %{with doc}
695 %{_mandir}/man1/git-cvs*.1*
696 %{_mandir}/man7/gitcvs-migration.7*
697 %endif
698
699 %files arch
700 %defattr(644,root,root,755)
701 %attr(755,root,root) %{_libdir}/%{name}/git-archimport
702 %if %{with doc}
703 %{_mandir}/man1/git-archimport.1*
704 %endif
705
706 %files email
707 %defattr(644,root,root,755)
708 %attr(755,root,root) %{_libdir}/%{name}/*email*
709 %if %{with doc}
710 %{_mandir}/man1/*email*.1*
711 %endif
712
713 %files -n bash-completion-git
714 %defattr(644,root,root,755)
715 /etc/bash_completion.d/git-completion.bash
716
717 %files -n perl-Git
718 %defattr(644,root,root,755)
719 %{perl_vendorlib}/Git.pm
720 %dir %{perl_vendorlib}/Git
721 %{perl_vendorlib}/Git/I18N.pm
722 %{perl_vendorlib}/Git/IndexInfo.pm
723 %{_mandir}/man3/Git*.3pm*
724
725 %files -n python-Git
726 %defattr(644,root,root,755)
727 %attr(755,root,root) %{_libdir}/%{name}/git-remote-testpy
728 %dir %{py_sitescriptdir}/git_remote_helpers
729 %{py_sitescriptdir}/git_remote_helpers/*.py[co]
730 %dir %{py_sitescriptdir}/git_remote_helpers/git
731 %{py_sitescriptdir}/git_remote_helpers/git/*.py[co]
732 %if "%{py_ver}" > "2.4"
733 %{py_sitescriptdir}/git_remote_helpers*.egg-info
734 %endif
735 %if %{with doc}
736 %{_mandir}/man1/gitremote-helpers.1*
737 %endif
738
739 %files -n vim-syntax-gitcommit
740 %defattr(644,root,root,755)
741 %doc contrib/vim/README
742 %{_datadir}/vim/vimfiles/syntax/gitcommit.vim
This page took 0.082031 seconds and 4 git commands to generate.