]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
merge changes leading to 1.8.5
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform make test
4 %bcond_with     tests_cvs       # perform tests which use CVS
5 %bcond_without  tests_svn       # perform tests which use subversion
6 %bcond_without  doc             # skip building/packaging docs/manuals (takes some time)
7 %bcond_without  pcre            # perl-compatible regexes support
8
9 %include        /usr/lib/rpm/macros.perl
10 Summary:        Distributed version control system focused on speed, effectivity and usability
11 Summary(pl.UTF-8):      Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
12 Name:           git-core
13 Version:        1.8.5
14 Release:        1
15 License:        GPL v2
16 Group:          Development/Tools
17 Source0:        http://git-core.googlecode.com/files/git-%{version}.tar.gz
18 # Source0-md5:  16448b1cfd62fcbe738729edc6279e14
19 Source1:        %{name}-gitweb.conf
20 Source2:        %{name}-gitweb-httpd.conf
21 Source3:        %{name}-gitweb-lighttpd.conf
22 Source4:        %{name}.sysconfig
23 Source5:        %{name}.inet
24 Source6:        %{name}.init
25 Patch0:         %{name}-tests.patch
26 Patch1:         %{name}-key-bindings.patch
27 Patch2:         %{name}-sysconfdir.patch
28 Patch3:         cherry-picked-commitlog.patch
29 Patch4:         %{name}-svn-exit-errors.patch
30 URL:            http://git-scm.com/
31 BuildRequires:  autoconf >= 2.59
32 BuildRequires:  automake
33 BuildRequires:  curl-devel
34 BuildRequires:  expat-devel
35 BuildRequires:  gettext-devel
36 BuildRequires:  openssl-devel
37 %{?with_pcre:BuildRequires:     pcre-devel}
38 BuildRequires:  perl-Error > 0.15
39 BuildRequires:  perl-base
40 BuildRequires:  python-devel
41 BuildRequires:  rpm-perlprov >= 4.1-13
42 BuildRequires:  rpm-pythonprov
43 BuildRequires:  rpmbuild(macros) >= 1.264
44 BuildRequires:  tcl
45 BuildRequires:  zlib-devel
46 %if %{with doc}
47 BuildRequires:  asciidoc >= 7.1.2-3
48 BuildRequires:  docbook-dtd45-xml
49 BuildRequires:  xmlto
50 %endif
51 %if %{with tests}
52 %if %{with tests_cvs}
53 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
54 BuildRequires:  cvs-gnu-client < 1.13
55 BuildRequires:  cvs-gnu-client >= 1.12
56 %endif
57 %{?with_tests_svn:BuildRequires:  subversion}
58 Conflicts:      pdksh < 5.2.14-46
59 %endif
60 Requires:       coreutils
61 Requires:       diffutils
62 Requires:       findutils
63 Requires:       grep
64 Requires:       openssh-clients
65 Requires:       perl-Error
66 Requires:       perl-Git = %{version}-%{release}
67 Requires:       sed
68 Suggests:       git-core-cvs
69 Suggests:       git-core-svn
70 Suggests:       less
71 Suggests:       rsync
72 Obsoletes:      python-Git
73 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75 # html docs have links to txt files
76 %define         _noautocompressdoc      *.txt
77
78 %define         webapp          gitweb
79 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
80 %define         appdir          %{_datadir}/%{webapp}
81 %define         cgibindir       %{_prefix}/lib/cgi-bin
82 %define         bash_compdir    %{_datadir}/bash-completion/completions
83
84 %description
85 "git" can mean anything, depending on your mood.
86
87 - random three-letter combination that is pronounceable, and not
88   actually used by any common UNIX command. The fact that it is a
89   mispronunciation of "get" may or may not be relevant.
90 - stupid. contemptible and despicable. simple. Take your pick from the
91   dictionary of slang.
92 - "global information tracker": you're in a good mood, and it actually
93   works for you. Angels sing, and a light suddenly fills the room.
94 - "goddamn idiotic truckload of sh*t": when it breaks
95
96 This is a stupid (but extremely fast) directory content manager. It
97 doesn't do a whole lot, but what it 'does' do is track directory
98 contents efficiently.
99
100 %description -l pl.UTF-8
101 "git" może oznaczać cokolwiek, w zależności od nastroju.
102
103 - losową kombinację trzech liter, która jest wymawialna i właściwie
104   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
105   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
106 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
107 - "global information tracker" (narzędzie do globalnego śledzenia
108   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
109   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
110 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
111   g*) - kiedy się zepsuje.
112
113 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
114 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
115 katalogu.
116
117 %package doc
118 Summary:        Documentation for git-core
119 Summary(pl.UTF-8):      Dokumentacja do git-core
120 Group:          Documentation
121
122 %description doc
123 Documentation for git-core.
124
125 %description doc -l pl.UTF-8
126 Dokumentacja do git-core.
127
128 %description doc -l fr.UTF-8
129 Javadoc pour git-core.
130
131 %package daemon-inetd
132 Summary:        Files necessary to run git-daemon as an inetd service
133 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
134 Group:          Networking/Daemons
135 Requires:       %{name} = %{version}-%{release}
136 Requires:       setup >= 2.4.11-1
137 Provides:       git-core-daemon
138 Obsoletes:      git-core-daemon
139 Obsoletes:      git-core-daemon-standalone
140
141 %description daemon-inetd
142 Git-daemon is a really simple TCP git daemon that can serve git
143 repositories. This package provides all necessarry files to run
144 git-daemon as an inetd service.
145
146 %description daemon-inetd -l pl.UTF-8
147 Git-daemon to prosty demon git korzystający z protokołu TCP do
148 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
149 do uruchomienia git-demona w trybie usługi inetd.
150
151 %package daemon-standalone
152 Summary:        Files necessary to run git-daemon as a standalone service
153 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
154 Group:          Networking/Daemons
155 Requires:       %{name} = %{version}-%{release}
156 Provides:       git-core-daemon
157 Obsoletes:      git-core-daemon
158 Obsoletes:      git-core-daemon-inetd
159
160 %description daemon-standalone
161 Git-daemon is a really simple TCP git daemon that can serve git
162 repositories. This package provides all necessarry files to run
163 git-daemon as an standalone service.
164
165 %description daemon-standalone -l pl.UTF-8
166 Git-daemon to prosty demon git korzystający z protokołu TCP do
167 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
168 do uruchomienia git-daemona w trybie usługi samodzielnej.
169
170 %package devel
171 Summary:        Git library with header files
172 Summary(pl.UTF-8):      Biblioteka Gita oraz pliki nagłówkowe
173 Group:          Development/Libraries
174 Requires:       zlib-devel
175
176 %description devel
177 Git library with header files.
178
179 %description devel -l pl.UTF-8
180 Biblioteka Gita oraz pliki nagłówkowe.
181
182 %package gitk
183 Summary:        Tcl/Tk interface to the Git version control system
184 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
185 Group:          Development/Tools
186 Requires:       %{name} = %{version}-%{release}
187 Requires:       tk
188
189 %description gitk
190 gitk displays changes in a repository or a selected set of commits.
191 This includes visualizing the commit graph, showing information
192 related to each commit, and the files in the trees of each revision.
193
194 Historically, gitk was the first repository browser. It's written in
195 Tcl/Tk and started off in a separate repository but was later merged
196 into the main git repository.
197
198 %description gitk -l pl.UTF-8
199 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
200 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
201 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
202
203 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
204 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
205 osobnym repozytorium, ale z czasem został włączony do głównego
206 repozytorium gita.
207
208 %package gitweb
209 Summary:        Web frontend to git
210 Summary(pl.UTF-8):      Frontend WWW do gita
211 Group:          Development/Tools
212 Requires:       %{name} = %{version}-%{release}
213 Requires:       webapps
214 Requires:       webserver(access)
215 Requires:       webserver(alias)
216 Requires:       webserver(cgi)
217 Suggests:       webserver(setenv)
218
219 %description gitweb
220 This package provides a web interface for browsing git repositories.
221
222 %description gitweb -l pl.UTF-8
223 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
224
225 %package gitview
226 Summary:        A GTK+ based repository browser for git
227 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
228 Group:          Development/Tools
229 Requires:       %{name} = %{version}-%{release}
230 Requires:       python >= 1:2.4
231 Requires:       python-pycairo >= 1.0
232 Requires:       python-pygobject
233 Requires:       python-pygtk-gtk >= 2:2.8
234 Suggests:       python-gnome-desktop-gtksourceview
235
236 %description gitview
237 A GTK+ based repository browser for git.
238
239 %description gitview -l pl.UTF-8
240 Oparta na GTK+ przeglądarka repozytorium gita.
241
242 %package gui
243 Summary:        Tcl/Tk interface to the Git version control system
244 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
245 Group:          Development/Tools
246 Requires:       %{name} = %{version}-%{release}
247 Requires:       tk
248 Requires:       xdg-utils
249 Suggests:       meld
250
251 %description gui
252 Displays changes in a repository or a selected set of commits. This
253 includes visualizing the commit graph, showing information related to
254 each commit, and the files in the trees of each revision.
255
256 Historically, gitk was the first repository browser. It's written in
257 Tcl/Tk and started off in a separate repository but was later merged
258 into the main git repository.
259
260 %description gui -l pl.UTF-8
261 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
262 to wizualizację grafu commitów, wyświetlanie informacji związanych z
263 każdym z commitów oraz listę plików dla każdej rewizji.
264
265 Z punktu widzenia historii, gitk był pierwszą przeglądarką
266 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
267 osobnym repozytorium, ale z czasem został włączony do głównego
268 repozytorium gita.
269
270 %package svn
271 Summary:        Subversion support for Git
272 Summary(pl.UTF-8):      Obsługa Subversion dla Gita
273 Group:          Development/Tools
274 Requires:       %{name} = %{version}-%{release}
275 Requires:       perl-Encode
276 Requires:       perl-Term-ReadKey
277
278 %description svn
279 Subversion support for Git.
280
281 %description svn -l pl.UTF-8
282 Obsługa Subversion dla Gita.
283
284 %package cvs
285 Summary:        CVS support for Git
286 Summary(pl.UTF-8):      Obsługa CVS dla Gita
287 Group:          Development/Tools
288 Requires:       %{name} = %{version}-%{release}
289 Requires:       cvsps >= 2.1-2
290 Requires:       rcs
291
292 %description cvs
293 CVS support for Git.
294
295 %description cvs -l pl.UTF-8
296 Obsługa CVS dla Gita.
297
298 %package arch
299 Summary:        Git tools for importing Arch repositories
300 Summary(pl.UTF-8):      Narzędzia Gita do importowania repozytoriów Archa
301 Group:          Development/Tools
302 Requires:       %{name} = %{version}-%{release}
303 Requires:       tla
304
305 %description arch
306 Git tools for importing Arch repositories.
307
308 %description arch -l pl.UTF-8
309 Narzędzia Gita do importowania repozytoriów Archa.
310
311 %package email
312 Summary:        Git tools for sending email
313 Summary(pl.UTF-8):      Narzędzia Gita do wysyłania poczty
314 Group:          Development/Tools
315 Requires:       %{name} = %{version}-%{release}
316
317 %description email
318 Git tools for sending email.
319
320 %description email -l pl.UTF-8
321 Narzędzia Gita do wysyłania poczty.
322
323 %package -n bash-completion-git
324 Summary:        bash-completion for git
325 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
326 Group:          Applications/Shells
327 Requires:       %{name} = %{version}-%{release}
328 Requires:       bash-completion >= 2.0
329
330 %description -n bash-completion-git
331 This package provides bash-completion for git.
332
333 %description -n bash-completion-git -l pl.UTF-8
334 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
335
336 %package -n perl-Git
337 Summary:        Perl interface to the Git version control system
338 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
339 Group:          Development/Languages/Perl
340 Obsoletes:      perl-git-core
341
342 %description -n perl-Git
343 This module provides Perl scripts easy way to interface the Git
344 version control system. The modules have an easy and well-tested way
345 to call arbitrary Git commands; in the future, the interface will also
346 provide specialized methods for doing easily operations which are not
347 totally trivial to do over the generic command interface.
348
349 %description -n perl-Git -l pl.UTF-8
350 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
351 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
352 dowolne polecenia Gita; w przyszłości interfejs udostępni także
353 specjalne metody do łatwego wykonywania operacji nietrywialnych do
354 wykonania przy użyciu ogólnego interfejsu poleceń.
355
356 %package -n vim-syntax-gitcommit
357 Summary:        Vim syntax: gitcommit
358 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
359 Group:          Applications/Editors/Vim
360 Requires:       %{name} = %{version}-%{release}
361 # for _vimdatadir existence
362 Requires:       vim-rt >= 4:6.3.058-3
363
364 %description -n vim-syntax-gitcommit
365 This plugin provides syntax highlighting for git's commit messages.
366
367 %description -n vim-syntax-gitcommit -l pl.UTF-8
368 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
369
370 %prep
371 %setup -q -n git-%{version}
372 %patch0 -p1
373 %patch1 -p0
374 %patch2 -p1
375 %patch3 -p1
376 %patch4 -p1
377
378 %build
379 %{__aclocal}
380 %{__autoconf}
381 %configure \
382         --sysconfdir=%{_sysconfdir}/git-core \
383         %{?with_pcre:--with-libpcre} \
384         --with-openssl
385
386 echo "BLK_SHA1=1" >> config.mak
387
388 %{__make} \
389         INSTALLDIRS=vendor \
390         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
391         GITWEB_PROJECTROOT="/var/lib/git" \
392         GITWEB_CSS="/gitweb/gitweb.css" \
393         GITWEB_LOGO="/gitweb/git-logo.png" \
394         GITWEB_FAVICON="/gitweb/git-favicon.png" \
395         V=1
396
397 %if %{with doc}
398 %{__make} -C Documentation \
399         MAN_BASE_URL=file://%{_docdir}/%{name}-doc-%{version}/ \
400         V=1
401 %endif
402
403 %if %{with tests}
404 %if %{without tests_cvs}
405 %{__rm} t/t*cvs*.sh || :
406 %endif
407 %{!?with_tests_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
408 %endif
409
410 %install
411 rm -rf $RPM_BUILD_ROOT
412 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
413 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
414 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
415 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
416 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
417 [init]
418         templatedir = %{_sysconfdir}/%{name}/templates
419 EOF
420
421 %{__make} install \
422         INSTALLDIRS=vendor \
423         DESTDIR=$RPM_BUILD_ROOT
424
425 %if %{with doc}
426 %{__make} -C Documentation install \
427         DESTDIR=$RPM_BUILD_ROOT
428 %endif
429
430 # copy templates except sample hooks
431 cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
432 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
433
434 # header files and lib
435 cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
436 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
437 cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
438 install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
439 cp -p block-sha1/sha1.h $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
440 cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
441 cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
442 cp -p {Makefile,config.mak,config.mak.autogen,config.mak.uname} $RPM_BUILD_ROOT%{_includedir}/%{name}
443
444 # bash completion
445 install -d $RPM_BUILD_ROOT%{bash_compdir}
446 cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{bash_compdir}/git
447
448 # vim syntax
449 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
450 cat > $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax/gitcommit.vim << 'EOF'
451 autocmd BufNewFile,BufRead *.git/COMMIT_EDITMSG    setf gitcommit
452 autocmd BufNewFile,BufRead *.git/config,.gitconfig setf gitconfig
453 autocmd BufNewFile,BufRead git-rebase-todo         setf gitrebase
454 autocmd BufNewFile,BufRead .msg.[0-9]*
455         \ if getline(1) =~ '^From.*# This line is ignored.$' |
456         \   setf gitsendemail |
457         \ endif
458 autocmd BufNewFile,BufRead *.git/**
459         \ if getline(1) =~ '^\x\{40\}\>\|^ref: ' |
460         \   setf git |
461         \ endif
462 EOF
463
464 # gitweb
465 mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
466 ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
467 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
468 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
469 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
470 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
471
472 # gitview
473 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
474
475 # git-daemon related files
476 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
477 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
478 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
479
480 # paths cleanup
481 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
482 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
483
484 # hardlink
485 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
486 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
487 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
488 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
489
490 # remove unneeded files
491 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
492 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
493 %py_postclean
494
495 mv $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
496 %find_lang git
497
498 %clean
499 rm -rf $RPM_BUILD_ROOT
500
501 %post daemon-inetd
502 %service -q rc-inetd reload
503
504 %postun daemon-inetd
505 if [ "$1" = "0" ]; then
506         %service -q rc-inetd reload
507 fi
508
509 %post daemon-standalone
510 /sbin/chkconfig --add git-daemon
511 %service git-daemon restart "git-daemon"
512
513 %preun daemon-standalone
514 if [ "$1" = "0" ]; then
515         %service git-daemon stop
516         /sbin/chkconfig --del git-daemon
517 fi
518
519 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
520 %webapp_register apache %{webapp}
521
522 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
523 %webapp_unregister apache %{webapp}
524
525 %triggerin gitweb -- apache < 2.2.0, apache-base
526 %webapp_register httpd %{webapp}
527
528 %triggerun gitweb -- apache < 2.2.0, apache-base
529 %webapp_unregister httpd %{webapp}
530
531 %triggerin gitweb -- lighttpd
532 %webapp_register lighttpd %{webapp}
533
534 %triggerun gitweb -- lighttpd
535 %webapp_unregister lighttpd %{webapp}
536
537 %files -f git.lang
538 %defattr(644,root,root,755)
539 %doc README contrib
540 %attr(755,root,root) %{_bindir}/git
541 %attr(755,root,root) %{_bindir}/git-receive-pack
542 %attr(755,root,root) %{_bindir}/git-shell
543 %attr(755,root,root) %{_bindir}/git-upload-archive
544 %attr(755,root,root) %{_bindir}/git-upload-pack
545 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
546
547 %if %{with doc}
548 %{_mandir}/man1/git-*.1*
549 %exclude %{_mandir}/man1/git-archimport.1*
550 %exclude %{_mandir}/man1/git-svn.1*
551 %exclude %{_mandir}/man1/git-cvs*.1*
552 %exclude %{_mandir}/man1/git-imap-send*.1*
553 %exclude %{_mandir}/man1/*email*.1*
554 %{_mandir}/man1/git.1*
555 %{_mandir}/man1/gitremote-helpers.1*
556 %{_mandir}/man5/gitattributes.5*
557 %{_mandir}/man5/githooks.5*
558 %{_mandir}/man5/gitignore.5*
559 %{_mandir}/man5/gitmodules.5*
560 %{_mandir}/man5/gitrepository-layout.5*
561 %{_mandir}/man7/gitcli.7*
562 %{_mandir}/man7/gitcore-tutorial.7*
563 %{_mandir}/man7/gitcredentials.7*
564 %{_mandir}/man7/gitdiffcore.7*
565 %{_mandir}/man7/gitglossary.7*
566 %{_mandir}/man7/gitnamespaces.7*
567 %{_mandir}/man7/gitrevisions.7*
568 %{_mandir}/man7/gittutorial-2.7*
569 %{_mandir}/man7/gittutorial.7*
570 %{_mandir}/man7/gitworkflows.7*
571 %endif
572
573 %dir %{_libdir}/%{name}
574 %attr(755,root,root) %{_libdir}/%{name}/*-*
575 %attr(755,root,root) %{_libdir}/%{name}/git
576 %{_libdir}/%{name}/mergetools
577
578 %exclude %{_libdir}/%{name}/git-gui
579 %exclude %{_libdir}/%{name}/git-svn
580 %exclude %{_libdir}/%{name}/git-archimport
581 %exclude %{_libdir}/%{name}/git-cvs*
582 %exclude %{_libdir}/%{name}/git-imap-send
583 %exclude %{_libdir}/%{name}/git-instaweb
584 %exclude %{_libdir}/%{name}/git-remote-testsvn
585 %exclude %{_libdir}/%{name}/*email*
586
587 %{_datadir}/%{name}
588
589 %{_localstatedir}/lib/git
590
591 %if %{with doc}
592 %files doc
593 %defattr(644,root,root,755)
594 %doc Documentation/RelNotes*
595 %doc Documentation/*.html Documentation/howto Documentation/technical
596 %endif
597
598 %files daemon-inetd
599 %defattr(644,root,root,755)
600 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
601
602 %files daemon-standalone
603 %defattr(644,root,root,755)
604 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
605 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
606
607 %files devel
608 %defattr(644,root,root,755)
609 %{_includedir}/%{name}
610 %{_libdir}/libgit.a
611 %{_libdir}/libgit_xdiff.a
612
613 %files gitk
614 %defattr(644,root,root,755)
615 %if %{with doc}
616 %{_mandir}/man1/gitk.1*
617 %endif
618 %attr(755,root,root) %{_bindir}/gitk
619 %dir %{_datadir}/gitk
620 %dir %{_datadir}/gitk/lib
621 %dir %{_datadir}/gitk/lib/msgs
622 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
623 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
624 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
625 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
626 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
627 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
628 %lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
629 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
630 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
631
632 %files gitweb
633 %defattr(644,root,root,755)
634 %doc gitweb/{README,INSTALL}
635 %dir %{webappdir}
636 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
637 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
638 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
639 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
640 %attr(755,root,root) %{cgibindir}/gitweb.cgi
641 %{appdir}
642 %attr(755,root,root) %{_libdir}/%{name}/git-instaweb
643 %if %{with doc}
644 %{_mandir}/man1/gitweb.1*
645 %{_mandir}/man5/gitweb.conf.5*
646 %endif
647
648 %files gitview
649 %defattr(644,root,root,755)
650 %doc contrib/gitview/gitview.txt
651 %attr(755,root,root) %{_bindir}/gitview
652
653 %files gui
654 %defattr(644,root,root,755)
655 %attr(755,root,root) %{_libdir}/%{name}/git-gui
656 %dir %{_datadir}/git-gui
657 %dir %{_datadir}/git-gui/lib
658 %dir %{_datadir}/git-gui/lib/msgs
659 %{_datadir}/git-gui/lib/git-gui.ico
660 %{_datadir}/git-gui/lib/tclIndex
661 %{_datadir}/git-gui/lib/*.js
662 %{_datadir}/git-gui/lib/*.tcl
663 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
664 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
665 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
666 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
667 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
668 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
669 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
670 %lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
671 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
672 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
673 %lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
674
675 %files svn
676 %defattr(644,root,root,755)
677 %attr(755,root,root) %{_libdir}/%{name}/git-svn
678 %attr(755,root,root) %{_libdir}/%{name}/git-remote-testsvn
679 %{perl_vendorlib}/Git/SVN
680 %{perl_vendorlib}/Git/SVN.pm
681 %if %{with doc}
682 %{_mandir}/man1/git-svn.1*
683 %endif
684
685 %files cvs
686 %defattr(644,root,root,755)
687 %attr(755,root,root) %{_bindir}/git-cvsserver
688 %attr(755,root,root) %{_libdir}/%{name}/git-cvs*
689 %if %{with doc}
690 %{_mandir}/man1/git-cvs*.1*
691 %{_mandir}/man7/gitcvs-migration.7*
692 %endif
693
694 %files arch
695 %defattr(644,root,root,755)
696 %attr(755,root,root) %{_libdir}/%{name}/git-archimport
697 %if %{with doc}
698 %{_mandir}/man1/git-archimport.1*
699 %endif
700
701 %files email
702 %defattr(644,root,root,755)
703 %attr(755,root,root) %{_libdir}/%{name}/git-imap-send
704 %attr(755,root,root) %{_libdir}/%{name}/*email*
705 %if %{with doc}
706 %{_mandir}/man1/*email*.1*
707 %{_mandir}/man1/*imap-send*.1*
708 %endif
709
710 %files -n bash-completion-git
711 %defattr(644,root,root,755)
712 %{bash_compdir}/git
713
714 %files -n perl-Git
715 %defattr(644,root,root,755)
716 %{perl_vendorlib}/Git.pm
717 %dir %{perl_vendorlib}/Git
718 %{perl_vendorlib}/Git/I18N.pm
719 %{perl_vendorlib}/Git/IndexInfo.pm
720 %{_mandir}/man3/Git*.3pm*
721
722 %files -n vim-syntax-gitcommit
723 %defattr(644,root,root,755)
724 %doc contrib/vim/README
725 %{_datadir}/vim/vimfiles/syntax/gitcommit.vim
This page took 0.178506 seconds and 4 git commands to generate.