]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
Fix for 'break: can't break' in 'git pull'
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform make test
4 %bcond_with     tests_cvs       # perform tests which use CVS
5 %bcond_without  tests_svn       # perform tests which use subversion
6 %bcond_without  doc             # skip building/packaging docs/manuals (takes some time)
7 %bcond_without  pcre            # perl-compatible regexes support
8 %bcond_without  gnome_keyring   # build without gnome keyring support
9
10 # for AC: --without doc --without gnome_keyring --without tests
11
12 %include        /usr/lib/rpm/macros.perl
13 Summary:        Distributed version control system focused on speed, effectivity and usability
14 Summary(pl.UTF-8):      Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
15 Name:           git-core
16 Version:        2.0.0
17 Release:        2
18 License:        GPL v2
19 Group:          Development/Tools
20 Source0:        http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.gz
21 # Source0-md5:  a461ea86f5d655e449a3356ac7eb71ec
22 Source1:        %{name}-gitweb.conf
23 Source2:        %{name}-gitweb-httpd.conf
24 Source3:        %{name}-gitweb-lighttpd.conf
25 Source4:        %{name}.sysconfig
26 Source5:        %{name}.inet
27 Source6:        %{name}.init
28 Source7:        gitolite.pl
29 Patch0:         %{name}-tests.patch
30 Patch1:         %{name}-key-bindings.patch
31 Patch2:         %{name}-sysconfdir.patch
32 Patch3:         cherry-picked-commitlog.patch
33 Patch4:         %{name}-svn-exit-errors.patch
34 Patch5:         no-break-in-case.patch
35 URL:            http://git-scm.com/
36 BuildRequires:  autoconf >= 2.59
37 BuildRequires:  automake
38 BuildRequires:  curl-devel
39 BuildRequires:  expat-devel
40 BuildRequires:  gettext-devel
41 %if %{with gnome_keyring}
42 BuildRequires:  libgnome-keyring-devel
43 BuildRequires:  pkgconfig
44 %endif
45 BuildRequires:  openssl-devel
46 %{?with_pcre:BuildRequires:     pcre-devel}
47 BuildRequires:  perl-Error > 0.15
48 BuildRequires:  perl-base
49 BuildRequires:  python-devel
50 BuildRequires:  rpm-perlprov >= 4.1-13
51 BuildRequires:  rpm-pythonprov
52 BuildRequires:  rpmbuild(macros) >= 1.673
53 BuildRequires:  tcl
54 BuildRequires:  zlib-devel
55 %if %{with doc}
56 BuildRequires:  asciidoc >= 7.1.2-3
57 BuildRequires:  docbook-dtd45-xml
58 BuildRequires:  xmlto
59 %endif
60 %if %{with tests}
61 %if %{with tests_cvs}
62 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
63 BuildRequires:  cvs-gnu-client < 1.13
64 BuildRequires:  cvs-gnu-client >= 1.12
65 %endif
66 %{?with_tests_svn:BuildRequires:  subversion}
67 Conflicts:      pdksh < 5.2.14-46
68 %endif
69 # git-sh-setup: sane_grep
70 Requires:       grep
71 # git-pull: printf
72 Requires:       coreutils
73 Requires:       openssh-clients
74 Requires:       perl-Error
75 Requires:       perl-Git = %{version}-%{release}
76 Requires:       sed
77 Suggests:       git-core-bzr
78 Suggests:       git-core-cvs
79 Suggests:       git-core-hg
80 Suggests:       git-core-p4
81 Suggests:       git-core-svn
82 Suggests:       less
83 Suggests:       rsync
84 Obsoletes:      python-Git
85 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
86
87 # html docs have links to txt files
88 %define         _noautocompressdoc      *.txt
89
90 %define         webapp          gitweb
91 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
92 %define         appdir          %{_datadir}/%{webapp}
93 %define         cgibindir       %{_prefix}/lib/cgi-bin
94 %define         gitcoredir      %{_libdir}/%{name}
95
96 %description
97 "git" can mean anything, depending on your mood.
98
99 - random three-letter combination that is pronounceable, and not
100   actually used by any common UNIX command. The fact that it is a
101   mispronunciation of "get" may or may not be relevant.
102 - stupid. contemptible and despicable. simple. Take your pick from the
103   dictionary of slang.
104 - "global information tracker": you're in a good mood, and it actually
105   works for you. Angels sing, and a light suddenly fills the room.
106 - "goddamn idiotic truckload of sh*t": when it breaks
107
108 This is a stupid (but extremely fast) directory content manager. It
109 doesn't do a whole lot, but what it 'does' do is track directory
110 contents efficiently.
111
112 %description -l pl.UTF-8
113 "git" może oznaczać cokolwiek, w zależności od nastroju.
114
115 - losową kombinację trzech liter, która jest wymawialna i właściwie
116   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
117   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
118 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
119 - "global information tracker" (narzędzie do globalnego śledzenia
120   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
121   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
122 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
123   g*) - kiedy się zepsuje.
124
125 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
126 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
127 katalogu.
128
129 %package doc
130 Summary:        Documentation for git-core
131 Summary(pl.UTF-8):      Dokumentacja do git-core
132 Group:          Documentation
133
134 %description doc
135 Documentation for git-core.
136
137 %description doc -l pl.UTF-8
138 Dokumentacja do git-core.
139
140 %description doc -l fr.UTF-8
141 Javadoc pour git-core.
142
143 %package daemon-inetd
144 Summary:        Files necessary to run git-daemon as an inetd service
145 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
146 Group:          Networking/Daemons
147 Requires:       %{name} = %{version}-%{release}
148 Requires:       setup >= 2.4.11-1
149 Provides:       git-core-daemon
150 Obsoletes:      git-core-daemon
151 Obsoletes:      git-core-daemon-standalone
152
153 %description daemon-inetd
154 Git-daemon is a really simple TCP git daemon that can serve git
155 repositories. This package provides all necessarry files to run
156 git-daemon as an inetd service.
157
158 %description daemon-inetd -l pl.UTF-8
159 Git-daemon to prosty demon git korzystający z protokołu TCP do
160 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
161 do uruchomienia git-demona w trybie usługi inetd.
162
163 %package daemon-standalone
164 Summary:        Files necessary to run git-daemon as a standalone service
165 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
166 Group:          Networking/Daemons
167 Requires:       %{name} = %{version}-%{release}
168 Provides:       git-core-daemon
169 Obsoletes:      git-core-daemon
170 Obsoletes:      git-core-daemon-inetd
171
172 %description daemon-standalone
173 Git-daemon is a really simple TCP git daemon that can serve git
174 repositories. This package provides all necessarry files to run
175 git-daemon as an standalone service.
176
177 %description daemon-standalone -l pl.UTF-8
178 Git-daemon to prosty demon git korzystający z protokołu TCP do
179 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
180 do uruchomienia git-daemona w trybie usługi samodzielnej.
181
182 %package devel
183 Summary:        Git library with header files
184 Summary(pl.UTF-8):      Biblioteka Gita oraz pliki nagłówkowe
185 Group:          Development/Libraries
186 Requires:       zlib-devel
187
188 %description devel
189 Git library with header files.
190
191 %description devel -l pl.UTF-8
192 Biblioteka Gita oraz pliki nagłówkowe.
193
194 %package gitk
195 Summary:        Tcl/Tk interface to the Git version control system
196 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
197 Group:          Development/Tools
198 Requires:       %{name} = %{version}-%{release}
199 Requires:       tk
200
201 %description gitk
202 gitk displays changes in a repository or a selected set of commits.
203 This includes visualizing the commit graph, showing information
204 related to each commit, and the files in the trees of each revision.
205
206 Historically, gitk was the first repository browser. It's written in
207 Tcl/Tk and started off in a separate repository but was later merged
208 into the main git repository.
209
210 %description gitk -l pl.UTF-8
211 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
212 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
213 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
214
215 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
216 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
217 osobnym repozytorium, ale z czasem został włączony do głównego
218 repozytorium gita.
219
220 %package gitweb
221 Summary:        Web frontend to git
222 Summary(pl.UTF-8):      Frontend WWW do gita
223 Group:          Development/Tools
224 Requires:       %{name} = %{version}-%{release}
225 Requires:       webapps
226 Requires:       webserver(access)
227 Requires:       webserver(alias)
228 Requires:       webserver(cgi)
229 Suggests:       webserver(setenv)
230
231 %description gitweb
232 This package provides a web interface for browsing git repositories.
233
234 %description gitweb -l pl.UTF-8
235 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
236
237 %package gitview
238 Summary:        A GTK+ based repository browser for git
239 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
240 Group:          Development/Tools
241 Requires:       %{name} = %{version}-%{release}
242 Requires:       python >= 1:2.4
243 Requires:       python-pycairo >= 1.0
244 Requires:       python-pygobject
245 Requires:       python-pygtk-gtk >= 2:2.8
246 Suggests:       python-gnome-desktop-gtksourceview
247
248 %description gitview
249 A GTK+ based repository browser for git.
250
251 %description gitview -l pl.UTF-8
252 Oparta na GTK+ przeglądarka repozytorium gita.
253
254 %package gui
255 Summary:        Tcl/Tk interface to the Git version control system
256 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
257 Group:          Development/Tools
258 Requires:       %{name} = %{version}-%{release}
259 Requires:       tk
260 Requires:       xdg-utils
261 Suggests:       meld
262
263 %description gui
264 Displays changes in a repository or a selected set of commits. This
265 includes visualizing the commit graph, showing information related to
266 each commit, and the files in the trees of each revision.
267
268 Historically, gitk was the first repository browser. It's written in
269 Tcl/Tk and started off in a separate repository but was later merged
270 into the main git repository.
271
272 %description gui -l pl.UTF-8
273 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
274 to wizualizację grafu commitów, wyświetlanie informacji związanych z
275 każdym z commitów oraz listę plików dla każdej rewizji.
276
277 Z punktu widzenia historii, gitk był pierwszą przeglądarką
278 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
279 osobnym repozytorium, ale z czasem został włączony do głównego
280 repozytorium gita.
281
282 %package arch
283 Summary:        Git tools for importing Arch repositories
284 Summary(pl.UTF-8):      Narzędzia Gita do importowania repozytoriów Archa
285 Group:          Development/Tools
286 Requires:       %{name} = %{version}-%{release}
287 Requires:       tla
288
289 %description arch
290 Git tools for importing Arch repositories.
291
292 %description arch -l pl.UTF-8
293 Narzędzia Gita do importowania repozytoriów Archa.
294
295 %package bzr
296 Summary:        Git tools for working with bzr repositories
297 Summary(pl.UTF-8):      Narzędzia Gita do pracy z repozytoriami bzr
298 Group:          Development/Tools
299 Requires:       %{name} = %{version}-%{release}
300 Requires:       bzr
301
302 %description bzr
303 Git tools for working with bzr repositories.
304
305 %description bzr -l pl.UTF-8
306 Narzędzia Gita do pracy z repozytoriami bzr.
307
308 %package cvs
309 Summary:        CVS support for Git
310 Summary(pl.UTF-8):      Obsługa CVS dla Gita
311 Group:          Development/Tools
312 Requires:       %{name} = %{version}-%{release}
313 Requires:       cvsps >= 2.1-2
314 Requires:       rcs
315
316 %description cvs
317 CVS support for Git.
318
319 %description cvs -l pl.UTF-8
320 Obsługa CVS dla Gita.
321
322 %package hg
323 Summary:        Git tools for working with mercurial repositories
324 Summary(pl.UTF-8):      Narzędzia Gita do pracy z repozytoriami mercuriala
325 Group:          Development/Tools
326 Requires:       %{name} = %{version}-%{release}
327 Requires:       mercurial >= 1.8
328
329 %description hg
330 Git tools for working with mercurial repositories.
331
332 %description hg -l pl.UTF-8
333 Narzędzia Gita do pracy z repozytoriami mercuriala.
334
335 %package p4
336 Summary:        Git tools for working with Perforce depots
337 Summary(pl.UTF-8):      Narzędzia Gita do pracy z magazynami Perforce'a
338 Group:          Development/Tools
339 Requires:       %{name} = %{version}-%{release}
340
341 %description p4
342 Git tools for working with Perforce depots.
343
344 %description p4 -l pl.UTF-8
345 Narzędzia Gita do pracy z magazynami Perforce'a.
346
347 %package svn
348 Summary:        Subversion support for Git
349 Summary(pl.UTF-8):      Obsługa Subversion dla Gita
350 Group:          Development/Tools
351 Requires:       %{name} = %{version}-%{release}
352 Requires:       perl-Encode
353 Requires:       perl-Term-ReadKey
354
355 %description svn
356 Subversion support for Git.
357
358 %description svn -l pl.UTF-8
359 Obsługa Subversion dla Gita.
360
361 %package email
362 Summary:        Git tools for sending email
363 Summary(pl.UTF-8):      Narzędzia Gita do wysyłania poczty
364 Group:          Development/Tools
365 Requires:       %{name} = %{version}-%{release}
366
367 %description email
368 Git tools for sending email.
369
370 %description email -l pl.UTF-8
371 Narzędzia Gita do wysyłania poczty.
372
373 %package -n bash-completion-git
374 Summary:        bash-completion for git
375 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
376 Group:          Applications/Shells
377 Requires:       %{name} = %{version}-%{release}
378 Requires:       bash-completion >= 2.0
379 %if "%{_rpmversion}" >= "5"
380 BuildArch:      noarch
381 %endif
382
383 %description -n bash-completion-git
384 This package provides bash-completion for git.
385
386 %description -n bash-completion-git -l pl.UTF-8
387 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
388
389 %package -n perl-Git
390 Summary:        Perl interface to the Git version control system
391 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
392 Group:          Development/Languages/Perl
393 Obsoletes:      perl-git-core
394
395 %description -n perl-Git
396 This module provides Perl scripts easy way to interface the Git
397 version control system. The modules have an easy and well-tested way
398 to call arbitrary Git commands; in the future, the interface will also
399 provide specialized methods for doing easily operations which are not
400 totally trivial to do over the generic command interface.
401
402 %description -n perl-Git -l pl.UTF-8
403 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
404 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
405 dowolne polecenia Gita; w przyszłości interfejs udostępni także
406 specjalne metody do łatwego wykonywania operacji nietrywialnych do
407 wykonania przy użyciu ogólnego interfejsu poleceń.
408
409 %package -n gnome-keyring-git-core
410 Summary:        GNOME Keyring authentication provider for Git
411 Summary(pl.UTF-8):      Moduł uwierzytelniający GNOME Keyring dla Git
412 Group:          X11/Applications
413 URL:            http://git-scm.com/docs/gitcredentials.html
414 Requires:       %{name} = %{version}-%{release}
415
416 %description -n gnome-keyring-git-core
417 Authentication provider module for Git which allows git client to
418 authenticate using GNOME Keyring.
419
420 You need to register it with:
421 - git config --global credential.helper gnome-keyring
422
423 %description -n gnome-keyring-git-core -l pl.UTF-8
424 Moduł uwierzytelniający dla Subversion pozwalający klientom git
425 uwierzytelniać się przy użyciu mechanizmu GNOME Keyring.
426
427 Moduł trzeba zarejestrować poleceniem:
428 - git config --global credential.helper gnome-keyring
429
430 %prep
431 %setup -q -n git-%{version}
432 %patch0 -p1
433 %patch1 -p0
434 %patch2 -p1
435 %patch3 -p1
436 %patch4 -p1
437 %patch5 -p1
438
439 %{__rm} {Documentation/technical,contrib/emacs,contrib/credential/gnome-keyring}/.gitignore
440
441 %build
442 %{__aclocal}
443 %{__autoconf}
444 %configure \
445         --sysconfdir=%{_sysconfdir}/git-core \
446         %{?with_pcre:--with-libpcre} \
447         --with-openssl
448
449 echo "BLK_SHA1=1" >> config.mak
450
451 %{__make} \
452         INSTALLDIRS=vendor \
453         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
454         GITWEB_PROJECTROOT="/var/lib/git" \
455         GITWEB_CSS="/gitweb/gitweb.css" \
456         GITWEB_LOGO="/gitweb/git-logo.png" \
457         GITWEB_FAVICON="/gitweb/git-favicon.png" \
458         V=1
459
460 %{__make} -C contrib/subtree
461
462 %if %{with gnome_keyring}
463 %{__make} -C contrib/credential/gnome-keyring
464 %endif
465
466 %if %{with doc}
467 %{__make} -C Documentation \
468         MAN_BASE_URL=file://%{_docdir}/%{name}-doc-%{version}/ \
469         V=1
470 %endif
471
472 %if %{with tests}
473 %if %{without tests_cvs}
474 %{__rm} t/t*cvs*.sh || :
475 %endif
476 %{!?with_tests_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
477 %endif
478
479 %install
480 rm -rf $RPM_BUILD_ROOT
481 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
482 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
483 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
484 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
485 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
486 [init]
487         templatedir = %{_sysconfdir}/%{name}/templates
488 EOF
489
490 %{__make} install \
491         INSTALLDIRS=vendor \
492         DESTDIR=$RPM_BUILD_ROOT
493
494 %if %{with doc}
495 %{__make} -C Documentation install \
496         DESTDIR=$RPM_BUILD_ROOT
497 %endif
498
499 # copy templates except sample hooks
500 cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
501 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
502
503 # header files and lib
504 cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
505 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
506 cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
507 install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
508 cp -p block-sha1/sha1.h $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
509 cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
510 cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
511 cp -p {Makefile,config.mak,config.mak.autogen,config.mak.uname} $RPM_BUILD_ROOT%{_includedir}/%{name}
512
513 %{__make} -C contrib/subtree install \
514         libexecdir=%{gitcoredir} \
515         DESTDIR=$RPM_BUILD_ROOT
516
517 %if %{with doc}
518 %{__make} -C contrib/subtree install-doc \
519         DESTDIR=$RPM_BUILD_ROOT
520 %endif
521
522 %if %{with gnome_keyring}
523 install -p contrib/credential/gnome-keyring/git-credential-gnome-keyring $RPM_BUILD_ROOT%{gitcoredir}
524 # Remove built binary files, otherwise they will be installed in doc
525 %{__make} -C contrib/credential/gnome-keyring clean
526 %endif
527
528 # bash completion
529 install -d $RPM_BUILD_ROOT%{bash_compdir}
530 cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{bash_compdir}/git
531
532 # Install git-prompt.sh
533 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/contrib/completion
534 cp -p contrib/completion/git-prompt.sh $RPM_BUILD_ROOT%{_datadir}/%{name}/contrib/completion
535
536 # Install bzr and hg remote helpers from contrib
537 install -p contrib/remote-helpers/git-remote-{bzr,hg} $RPM_BUILD_ROOT%{gitcoredir}
538
539 # gitweb
540 mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
541 ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
542 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
543 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{webappdir}/gitolite.pl
544 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
545 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
546 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
547
548 # gitview
549 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
550
551 # git-daemon related files
552 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
553 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
554 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
555
556 # paths cleanup
557 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
558 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
559
560 # hardlink
561 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
562 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
563 ln -f $RPM_BUILD_ROOT{%{gitcoredir},%{_bindir}}/git-shell
564 ln -f $RPM_BUILD_ROOT{%{gitcoredir},%{_bindir}}/git-upload-pack
565
566 # remove unneeded files
567 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
568 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
569 %py_postclean
570
571 mv $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
572 %find_lang git
573
574 %clean
575 rm -rf $RPM_BUILD_ROOT
576
577 %post daemon-inetd
578 %service -q rc-inetd reload
579
580 %postun daemon-inetd
581 if [ "$1" = "0" ]; then
582         %service -q rc-inetd reload
583 fi
584
585 %post daemon-standalone
586 /sbin/chkconfig --add git-daemon
587 %service git-daemon restart "git-daemon"
588
589 %preun daemon-standalone
590 if [ "$1" = "0" ]; then
591         %service git-daemon stop
592         /sbin/chkconfig --del git-daemon
593 fi
594
595 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
596 %webapp_register apache %{webapp}
597
598 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
599 %webapp_unregister apache %{webapp}
600
601 %triggerin gitweb -- apache < 2.2.0, apache-base
602 %webapp_register httpd %{webapp}
603
604 %triggerun gitweb -- apache < 2.2.0, apache-base
605 %webapp_unregister httpd %{webapp}
606
607 %triggerin gitweb -- lighttpd
608 %webapp_register lighttpd %{webapp}
609
610 %triggerun gitweb -- lighttpd
611 %webapp_unregister lighttpd %{webapp}
612
613 %files -f git.lang
614 %defattr(644,root,root,755)
615 %doc README contrib
616 %attr(755,root,root) %{_bindir}/git
617 %attr(755,root,root) %{_bindir}/git-receive-pack
618 %attr(755,root,root) %{_bindir}/git-shell
619 %attr(755,root,root) %{_bindir}/git-upload-archive
620 %attr(755,root,root) %{_bindir}/git-upload-pack
621 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
622
623 %if %{with doc}
624 %{_mandir}/man1/git-*.1*
625 %exclude %{_mandir}/man1/git-archimport.1*
626 %exclude %{_mandir}/man1/git-svn.1*
627 %exclude %{_mandir}/man1/git-cvs*.1*
628 %exclude %{_mandir}/man1/git-imap-send*.1*
629 %exclude %{_mandir}/man1/*email*.1*
630 %{_mandir}/man1/git.1*
631 %{_mandir}/man1/gitremote-helpers.1*
632 %{_mandir}/man5/gitattributes.5*
633 %{_mandir}/man5/githooks.5*
634 %{_mandir}/man5/gitignore.5*
635 %{_mandir}/man5/gitmodules.5*
636 %{_mandir}/man5/gitrepository-layout.5*
637 %{_mandir}/man7/gitcli.7*
638 %{_mandir}/man7/gitcore-tutorial.7*
639 %{_mandir}/man7/gitcredentials.7*
640 %{_mandir}/man7/gitdiffcore.7*
641 %{_mandir}/man7/gitglossary.7*
642 %{_mandir}/man7/gitnamespaces.7*
643 %{_mandir}/man7/gitrevisions.7*
644 %{_mandir}/man7/gittutorial-2.7*
645 %{_mandir}/man7/gittutorial.7*
646 %{_mandir}/man7/gitworkflows.7*
647 %endif
648
649 %dir %{gitcoredir}
650 %attr(755,root,root) %{gitcoredir}/*-*
651 %attr(755,root,root) %{gitcoredir}/git
652 %dir %{gitcoredir}/mergetools
653 %{gitcoredir}/mergetools/*
654
655 %{_datadir}/%{name}
656 %{_localstatedir}/lib/git
657
658 # subpackages
659 %exclude %{gitcoredir}/*email*
660 %exclude %{gitcoredir}/*p4*
661 %exclude %{gitcoredir}/git-archimport
662 %exclude %{gitcoredir}/git-cvs*
663 %exclude %{gitcoredir}/git-gui
664 %exclude %{gitcoredir}/git-imap-send
665 %exclude %{gitcoredir}/git-instaweb
666 %exclude %{gitcoredir}/git-remote-bzr
667 %exclude %{gitcoredir}/git-remote-hg
668 %exclude %{gitcoredir}/git-remote-testsvn
669 %exclude %{gitcoredir}/git-svn
670 %exclude %{gitcoredir}/mergetools/p4merge
671 %if %{with gnome_keyring}
672 %exclude %{gitcoredir}/git-credential-gnome-keyring
673 %endif
674
675 %if %{with doc}
676 %files doc
677 %defattr(644,root,root,755)
678 %doc Documentation/RelNotes*
679 %doc Documentation/*.html Documentation/howto Documentation/technical
680 %endif
681
682 %files daemon-inetd
683 %defattr(644,root,root,755)
684 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
685
686 %files daemon-standalone
687 %defattr(644,root,root,755)
688 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
689 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
690
691 %files devel
692 %defattr(644,root,root,755)
693 %{_includedir}/%{name}
694 %{_libdir}/libgit.a
695 %{_libdir}/libgit_xdiff.a
696
697 %files gitk
698 %defattr(644,root,root,755)
699 %if %{with doc}
700 %{_mandir}/man1/gitk.1*
701 %endif
702 %attr(755,root,root) %{_bindir}/gitk
703 %dir %{_datadir}/gitk
704 %dir %{_datadir}/gitk/lib
705 %dir %{_datadir}/gitk/lib/msgs
706 %lang(bg) %{_datadir}/gitk/lib/msgs/bg.msg
707 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
708 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
709 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
710 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
711 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
712 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
713 %lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
714 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
715 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
716
717 %files gitweb
718 %defattr(644,root,root,755)
719 %doc gitweb/{README,INSTALL}
720 %dir %{webappdir}
721 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
722 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
723 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
724 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
725 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitolite.pl
726 %attr(755,root,root) %{cgibindir}/gitweb.cgi
727 %{appdir}
728 %attr(755,root,root) %{gitcoredir}/git-instaweb
729 %if %{with doc}
730 %{_mandir}/man1/gitweb.1*
731 %{_mandir}/man5/gitweb.conf.5*
732 %endif
733
734 %files gitview
735 %defattr(644,root,root,755)
736 %doc contrib/gitview/gitview.txt
737 %attr(755,root,root) %{_bindir}/gitview
738
739 %files gui
740 %defattr(644,root,root,755)
741 %attr(755,root,root) %{gitcoredir}/git-gui
742 %dir %{_datadir}/git-gui
743 %dir %{_datadir}/git-gui/lib
744 %dir %{_datadir}/git-gui/lib/msgs
745 %{_datadir}/git-gui/lib/git-gui.ico
746 %{_datadir}/git-gui/lib/tclIndex
747 %{_datadir}/git-gui/lib/*.js
748 %{_datadir}/git-gui/lib/*.tcl
749 %lang(bg) %{_datadir}/git-gui/lib/msgs/bg.msg
750 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
751 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
752 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
753 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
754 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
755 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
756 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
757 %lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
758 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
759 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
760 %lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
761
762 %files arch
763 %defattr(644,root,root,755)
764 %attr(755,root,root) %{gitcoredir}/git-archimport
765 %if %{with doc}
766 %{_mandir}/man1/git-archimport.1*
767 %endif
768
769 %files bzr
770 %defattr(644,root,root,755)
771 %attr(755,root,root) %{gitcoredir}/git-remote-bzr
772
773 %files cvs
774 %defattr(644,root,root,755)
775 %attr(755,root,root) %{_bindir}/git-cvsserver
776 %attr(755,root,root) %{gitcoredir}/git-cvs*
777 %if %{with doc}
778 %{_mandir}/man1/git-cvs*.1*
779 %{_mandir}/man7/gitcvs-migration.7*
780 %endif
781
782 %files hg
783 %defattr(644,root,root,755)
784 %attr(755,root,root) %{gitcoredir}/git-remote-hg
785
786 %files p4
787 %defattr(644,root,root,755)
788 %attr(755,root,root) %{gitcoredir}/git-p4
789 %attr(755,root,root) %{gitcoredir}/mergetools/p4merge
790
791 %files svn
792 %defattr(644,root,root,755)
793 %attr(755,root,root) %{gitcoredir}/git-svn
794 %attr(755,root,root) %{gitcoredir}/git-remote-testsvn
795 %{perl_vendorlib}/Git/SVN
796 %{perl_vendorlib}/Git/SVN.pm
797 %if %{with doc}
798 %{_mandir}/man1/git-svn.1*
799 %endif
800
801 %files email
802 %defattr(644,root,root,755)
803 %attr(755,root,root) %{gitcoredir}/git-imap-send
804 %attr(755,root,root) %{gitcoredir}/*email*
805 %if %{with doc}
806 %{_mandir}/man1/*email*.1*
807 %{_mandir}/man1/*imap-send*.1*
808 %endif
809
810 %files -n bash-completion-git
811 %defattr(644,root,root,755)
812 %{bash_compdir}/git
813
814 %files -n perl-Git
815 %defattr(644,root,root,755)
816 %{perl_vendorlib}/Git.pm
817 %dir %{perl_vendorlib}/Git
818 %{perl_vendorlib}/Git/I18N.pm
819 %{perl_vendorlib}/Git/IndexInfo.pm
820 %{_mandir}/man3/Git*.3pm*
821
822 %if %{with gnome_keyring}
823 %files -n gnome-keyring-git-core
824 %defattr(644,root,root,755)
825 %attr(755,root,root) %{gitcoredir}/git-credential-gnome-keyring
826 %endif
This page took 0.088257 seconds and 4 git commands to generate.