]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
make gitk's cherry-pick commitlog more user friendly.
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform make test
4 %bcond_with     tests_cvs       # perform tests which use CVS
5 %bcond_without  tests_svn       # perform tests which use subversion
6 %bcond_without  doc             # skip building/packaging docs/manuals (takes some time)
7
8 %include        /usr/lib/rpm/macros.perl
9 Summary:        Distributed version control system focused on speed, effectivity and usability
10 Summary(pl.UTF-8):      Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
11 Name:           git-core
12 Version:        1.8.1.4
13 Release:        1
14 License:        GPL v2
15 Group:          Development/Tools
16 Source0:        http://git-core.googlecode.com/files/git-%{version}.tar.gz
17 # Source0-md5:  60f32ef4a6b3fa2143b81a28704333ed
18 Source1:        %{name}-gitweb.conf
19 Source2:        %{name}-gitweb-httpd.conf
20 Source3:        %{name}-gitweb-lighttpd.conf
21 Source4:        %{name}.sysconfig
22 Source5:        %{name}.inet
23 Source6:        %{name}.init
24 Patch0:         %{name}-tests.patch
25 Patch1:         %{name}-key-bindings.patch
26 Patch2:         %{name}-sysconfdir.patch
27 Patch3:         cherry-picked-commitlog.patch
28 URL:            http://git-scm.com/
29 BuildRequires:  autoconf >= 2.59
30 BuildRequires:  automake
31 BuildRequires:  curl-devel
32 BuildRequires:  expat-devel
33 BuildRequires:  gettext-devel
34 BuildRequires:  openssl-devel
35 BuildRequires:  perl-Error > 0.15
36 BuildRequires:  perl-base
37 BuildRequires:  python-devel
38 BuildRequires:  rpm-perlprov >= 4.1-13
39 BuildRequires:  rpm-pythonprov
40 BuildRequires:  rpmbuild(macros) >= 1.264
41 BuildRequires:  tcl
42 BuildRequires:  zlib-devel
43 %if %{with doc}
44 BuildRequires:  asciidoc >= 7.1.2-3
45 BuildRequires:  docbook-dtd45-xml
46 BuildRequires:  xmlto
47 %endif
48 %if %{with tests}
49 %if %{with tests_cvs}
50 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
51 BuildRequires:  cvs-gnu-client < 1.13
52 BuildRequires:  cvs-gnu-client >= 1.12
53 %endif
54 %{?with_tests_svn:BuildRequires:  subversion}
55 Conflicts:      pdksh < 5.2.14-46
56 %endif
57 Requires:       coreutils
58 Requires:       diffutils
59 Requires:       findutils
60 Requires:       grep
61 Requires:       openssh-clients
62 Requires:       perl-Error
63 Requires:       perl-Git = %{version}-%{release}
64 Requires:       sed
65 Suggests:       git-core-cvs
66 Suggests:       git-core-svn
67 Suggests:       less
68 Suggests:       rsync
69 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
70
71 # html docs have links to txt files
72 %define         _noautocompressdoc      *.txt
73
74 %define         webapp          gitweb
75 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
76 %define         appdir          %{_datadir}/%{webapp}
77 %define         cgibindir       %{_prefix}/lib/cgi-bin
78
79 %description
80 "git" can mean anything, depending on your mood.
81
82 - random three-letter combination that is pronounceable, and not
83   actually used by any common UNIX command. The fact that it is a
84   mispronunciation of "get" may or may not be relevant.
85 - stupid. contemptible and despicable. simple. Take your pick from the
86   dictionary of slang.
87 - "global information tracker": you're in a good mood, and it actually
88   works for you. Angels sing, and a light suddenly fills the room.
89 - "goddamn idiotic truckload of sh*t": when it breaks
90
91 This is a stupid (but extremely fast) directory content manager. It
92 doesn't do a whole lot, but what it 'does' do is track directory
93 contents efficiently.
94
95 %description -l pl.UTF-8
96 "git" może oznaczać cokolwiek, w zależności od nastroju.
97
98 - losową kombinację trzech liter, która jest wymawialna i właściwie
99   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
100   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
101 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
102 - "global information tracker" (narzędzie do globalnego śledzenia
103   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
104   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
105 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
106   g*) - kiedy się zepsuje.
107
108 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
109 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
110 katalogu.
111
112 %package doc
113 Summary:        Documentation for git-core
114 Summary(pl.UTF-8):      Dokumentacja do git-core
115 Group:          Documentation
116
117 %description doc
118 Documentation for git-core.
119
120 %description doc -l pl.UTF-8
121 Dokumentacja do git-core.
122
123 %description doc -l fr.UTF-8
124 Javadoc pour git-core.
125
126 %package daemon-inetd
127 Summary:        Files necessary to run git-daemon as an inetd service
128 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
129 Group:          Networking/Daemons
130 Requires:       %{name} = %{version}-%{release}
131 Requires:       setup >= 2.4.11-1
132 Provides:       git-core-daemon
133 Obsoletes:      git-core-daemon
134 Obsoletes:      git-core-daemon-standalone
135
136 %description daemon-inetd
137 Git-daemon is a really simple TCP git daemon that can serve git
138 repositories. This package provides all necessarry files to run
139 git-daemon as an inetd service.
140
141 %description daemon-inetd -l pl.UTF-8
142 Git-daemon to prosty demon git korzystający z protokołu TCP do
143 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
144 do uruchomienia git-demona w trybie usługi inetd.
145
146 %package daemon-standalone
147 Summary:        Files necessary to run git-daemon as a standalone service
148 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
149 Group:          Networking/Daemons
150 Requires:       %{name} = %{version}-%{release}
151 Provides:       git-core-daemon
152 Obsoletes:      git-core-daemon
153 Obsoletes:      git-core-daemon-inetd
154
155 %description daemon-standalone
156 Git-daemon is a really simple TCP git daemon that can serve git
157 repositories. This package provides all necessarry files to run
158 git-daemon as an standalone service.
159
160 %description daemon-standalone -l pl.UTF-8
161 Git-daemon to prosty demon git korzystający z protokołu TCP do
162 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
163 do uruchomienia git-daemona w trybie usługi samodzielnej.
164
165 %package devel
166 Summary:        Git library with header files
167 Summary(pl.UTF-8):      Biblioteka Gita oraz pliki nagłówkowe
168 Group:          Development/Libraries
169 Requires:       zlib-devel
170
171 %description devel
172 Git library with header files.
173
174 %description devel -l pl.UTF-8
175 Biblioteka Gita oraz pliki nagłówkowe.
176
177 %package gitk
178 Summary:        Tcl/Tk interface to the Git version control system
179 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
180 Group:          Development/Tools
181 Requires:       %{name} = %{version}-%{release}
182 Requires:       tk
183
184 %description gitk
185 gitk displays changes in a repository or a selected set of commits.
186 This includes visualizing the commit graph, showing information
187 related to each commit, and the files in the trees of each revision.
188
189 Historically, gitk was the first repository browser. It's written in
190 Tcl/Tk and started off in a separate repository but was later merged
191 into the main git repository.
192
193 %description gitk -l pl.UTF-8
194 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
195 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
196 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
197
198 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
199 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
200 osobnym repozytorium, ale z czasem został włączony do głównego
201 repozytorium gita.
202
203 %package gitweb
204 Summary:        Web frontend to git
205 Summary(pl.UTF-8):      Frontend WWW do gita
206 Group:          Development/Tools
207 Requires:       %{name} = %{version}-%{release}
208 Requires:       webapps
209 Requires:       webserver(alias)
210 Requires:       webserver(cgi)
211 Suggests:       webserver(setenv)
212
213 %description gitweb
214 This package provides a web interface for browsing git repositories.
215
216 %description gitweb -l pl.UTF-8
217 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
218
219 %package gitview
220 Summary:        A GTK+ based repository browser for git
221 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
222 Group:          Development/Tools
223 Requires:       %{name} = %{version}-%{release}
224 Requires:       python >= 1:2.4
225 Requires:       python-pycairo >= 1.0
226 Requires:       python-pygobject
227 Requires:       python-pygtk-gtk >= 2:2.8
228 Suggests:       python-gnome-desktop-gtksourceview
229
230 %description gitview
231 A GTK+ based repository browser for git.
232
233 %description gitview -l pl.UTF-8
234 Oparta na GTK+ przeglądarka repozytorium gita.
235
236 %package gui
237 Summary:        Tcl/Tk interface to the Git version control system
238 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
239 Group:          Development/Tools
240 Requires:       %{name} = %{version}-%{release}
241 Requires:       tk
242 Requires:       xdg-utils
243 Suggests:       meld
244
245 %description gui
246 Displays changes in a repository or a selected set of commits. This
247 includes visualizing the commit graph, showing information related to
248 each commit, and the files in the trees of each revision.
249
250 Historically, gitk was the first repository browser. It's written in
251 Tcl/Tk and started off in a separate repository but was later merged
252 into the main git repository.
253
254 %description gui -l pl.UTF-8
255 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
256 to wizualizację grafu commitów, wyświetlanie informacji związanych z
257 każdym z commitów oraz listę plików dla każdej rewizji.
258
259 Z punktu widzenia historii, gitk był pierwszą przeglądarką
260 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
261 osobnym repozytorium, ale z czasem został włączony do głównego
262 repozytorium gita.
263
264 %package svn
265 Summary:        Subversion support for Git
266 Summary(pl.UTF-8):      Obsługa Subversion dla Gita
267 Group:          Development/Tools
268 Requires:       %{name} = %{version}-%{release}
269 Requires:       perl-Encode
270 Requires:       perl-Term-ReadKey
271
272 %description svn
273 Subversion support for Git.
274
275 %description svn -l pl.UTF-8
276 Obsługa Subversion dla Gita.
277
278 %package cvs
279 Summary:        CVS support for Git
280 Summary(pl.UTF-8):      Obsługa CVS dla Gita
281 Group:          Development/Tools
282 Requires:       %{name} = %{version}-%{release}
283 Requires:       cvsps >= 2.1-2
284 Requires:       rcs
285
286 %description cvs
287 CVS support for Git.
288
289 %description cvs -l pl.UTF-8
290 Obsługa CVS dla Gita.
291
292 %package arch
293 Summary:        Git tools for importing Arch repositories
294 Summary(pl.UTF-8):      Narzędzia Gita do importowania repozytoriów Archa
295 Group:          Development/Tools
296 Requires:       %{name} = %{version}-%{release}
297 Requires:       tla
298
299 %description arch
300 Git tools for importing Arch repositories.
301
302 %description arch -l pl.UTF-8
303 Narzędzia Gita do importowania repozytoriów Archa.
304
305 %package email
306 Summary:        Git tools for sending email
307 Summary(pl.UTF-8):      Narzędzia Gita do wysyłania poczty
308 Group:          Development/Tools
309 Requires:       %{name} = %{version}-%{release}
310
311 %description email
312 Git tools for sending email.
313
314 %description email -l pl.UTF-8
315 Narzędzia Gita do wysyłania poczty.
316
317 %package -n bash-completion-git
318 Summary:        bash-completion for git
319 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
320 Group:          Applications/Shells
321 Requires:       %{name} = %{version}-%{release}
322 Requires:       bash-completion
323
324 %description -n bash-completion-git
325 This package provides bash-completion for git.
326
327 %description -n bash-completion-git -l pl.UTF-8
328 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
329
330 %package -n perl-Git
331 Summary:        Perl interface to the Git version control system
332 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
333 Group:          Development/Languages/Perl
334 Obsoletes:      perl-git-core
335
336 %description -n perl-Git
337 This module provides Perl scripts easy way to interface the Git
338 version control system. The modules have an easy and well-tested way
339 to call arbitrary Git commands; in the future, the interface will also
340 provide specialized methods for doing easily operations which are not
341 totally trivial to do over the generic command interface.
342
343 %description -n perl-Git -l pl.UTF-8
344 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
345 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
346 dowolne polecenia Gita; w przyszłości interfejs udostępni także
347 specjalne metody do łatwego wykonywania operacji nietrywialnych do
348 wykonania przy użyciu ogólnego interfejsu poleceń.
349
350 %package -n python-Git
351 Summary:        Python Git remote helpers for non-git repositories
352 Summary(pl.UTF-8):      Pythonowe zdalne moduły pomocnicze dla repozytoriów niegitowych
353 Group:          Development/Languages/Python
354 Requires:       %{name} = %{version}-%{release}
355
356 %description -n python-Git
357 This package contains Python git_repote_helpers package - Git remote
358 helpers for non-git repositories.
359
360 %description -n python-Git -l pl.UTF-8
361 Ten pakiet zawiera pakiet Pythona git_remote_helpers - zdalne moduły
362 pomocnicze Gita dla repozytoriów niegitowych.
363
364 %package -n vim-syntax-gitcommit
365 Summary:        Vim syntax: gitcommit
366 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
367 Group:          Applications/Editors/Vim
368 Requires:       %{name} = %{version}-%{release}
369 # for _vimdatadir existence
370 Requires:       vim-rt >= 4:6.3.058-3
371
372 %description -n vim-syntax-gitcommit
373 This plugin provides syntax highlighting for git's commit messages.
374
375 %description -n vim-syntax-gitcommit -l pl.UTF-8
376 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
377
378 %prep
379 %setup -q -n git-%{version}
380 %patch0 -p1
381 %patch1 -p0
382 %patch2 -p1
383 %patch3 -p1
384
385 %build
386 %{__aclocal}
387 %{__autoconf}
388 %configure \
389         --sysconfdir=%{_sysconfdir}/git-core \
390         --with-openssl
391
392 echo "BLK_SHA1=1" >> config.mak
393
394 %{__make} \
395         INSTALLDIRS=vendor \
396         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
397         GITWEB_PROJECTROOT="/var/lib/git" \
398         GITWEB_CSS="/gitweb/gitweb.css" \
399         GITWEB_LOGO="/gitweb/git-logo.png" \
400         GITWEB_FAVICON="/gitweb/git-favicon.png" \
401         V=1
402
403 %if %{with doc}
404 %{__make} -C Documentation \
405         MAN_BASE_URL=file://%{_docdir}/%{name}-doc-%{version}/ \
406         V=1
407 %endif
408
409 %if %{with tests}
410 %if %{without tests_cvs}
411 %{__rm} t/t*cvs*.sh || :
412 %endif
413 %{!?with_tests_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
414 %endif
415
416 %install
417 rm -rf $RPM_BUILD_ROOT
418 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
419 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
420 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
421 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
422 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
423 [init]
424         templatedir = %{_sysconfdir}/%{name}/templates
425 EOF
426
427 %{__make} install \
428         INSTALLDIRS=vendor \
429         DESTDIR=$RPM_BUILD_ROOT
430
431 %if %{with doc}
432 %{__make} -C Documentation install \
433         DESTDIR=$RPM_BUILD_ROOT
434 %endif
435
436 # copy templates except sample hooks
437 cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
438 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
439
440 # header files and lib
441 cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
442 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
443 cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
444 cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
445 cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
446
447 # bash completion
448 install -d $RPM_BUILD_ROOT/etc/bash_completion.d
449 cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT/etc/bash_completion.d
450
451 # vim syntax
452 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
453 cat > $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax/gitcommit.vim << 'EOF'
454 autocmd BufNewFile,BufRead *.git/COMMIT_EDITMSG    setf gitcommit
455 autocmd BufNewFile,BufRead *.git/config,.gitconfig setf gitconfig
456 autocmd BufNewFile,BufRead git-rebase-todo         setf gitrebase
457 autocmd BufNewFile,BufRead .msg.[0-9]*
458         \ if getline(1) =~ '^From.*# This line is ignored.$' |
459         \   setf gitsendemail |
460         \ endif
461 autocmd BufNewFile,BufRead *.git/**
462         \ if getline(1) =~ '^\x\{40\}\>\|^ref: ' |
463         \   setf git |
464         \ endif
465 EOF
466
467 # gitweb
468 mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
469 ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
470 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
471 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
472 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
473 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
474
475 # gitview
476 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
477
478 # git-daemon related files
479 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
480 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
481 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
482
483 # paths cleanup
484 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
485 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
486
487 # hardlink
488 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
489 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
490 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
491 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
492
493 # remove unneeded files
494 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
495 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
496 %py_postclean
497
498 mv $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
499 %find_lang git
500
501 %clean
502 rm -rf $RPM_BUILD_ROOT
503
504 %post daemon-inetd
505 %service -q rc-inetd reload
506
507 %postun daemon-inetd
508 if [ "$1" = "0" ]; then
509         %service -q rc-inetd reload
510 fi
511
512 %post daemon-standalone
513 /sbin/chkconfig --add git-daemon
514 %service git-daemon restart "git-daemon"
515
516 %preun daemon-standalone
517 if [ "$1" = "0" ]; then
518         %service git-daemon stop
519         /sbin/chkconfig --del git-daemon
520 fi
521
522 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
523 %webapp_register apache %{webapp}
524
525 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
526 %webapp_unregister apache %{webapp}
527
528 %triggerin gitweb -- apache < 2.2.0, apache-base
529 %webapp_register httpd %{webapp}
530
531 %triggerun gitweb -- apache < 2.2.0, apache-base
532 %webapp_unregister httpd %{webapp}
533
534 %triggerin gitweb -- lighttpd
535 %webapp_register lighttpd %{webapp}
536
537 %triggerun gitweb -- lighttpd
538 %webapp_unregister lighttpd %{webapp}
539
540 %files -f git.lang
541 %defattr(644,root,root,755)
542 %doc README contrib
543 %attr(755,root,root) %{_bindir}/git
544 %attr(755,root,root) %{_bindir}/git-receive-pack
545 %attr(755,root,root) %{_bindir}/git-shell
546 %attr(755,root,root) %{_bindir}/git-upload-archive
547 %attr(755,root,root) %{_bindir}/git-upload-pack
548 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
549
550 %if %{with doc}
551 %{_mandir}/man1/git-*.1*
552 %exclude %{_mandir}/man1/git-archimport.1*
553 %exclude %{_mandir}/man1/git-svn.1*
554 %exclude %{_mandir}/man1/git-cvs*.1*
555 %exclude %{_mandir}/man1/*email*.1*
556 %exclude %{_mandir}/man1/git-remote-helpers.1*
557 %{_mandir}/man1/git.1*
558 %{_mandir}/man5/gitattributes.5*
559 %{_mandir}/man5/githooks.5*
560 %{_mandir}/man5/gitignore.5*
561 %{_mandir}/man5/gitmodules.5*
562 %{_mandir}/man5/gitrepository-layout.5*
563 %{_mandir}/man7/gitcli.7*
564 %{_mandir}/man7/gitcore-tutorial.7*
565 %{_mandir}/man7/gitcredentials.7*
566 %{_mandir}/man7/gitdiffcore.7*
567 %{_mandir}/man7/gitglossary.7*
568 %{_mandir}/man7/gitnamespaces.7*
569 %{_mandir}/man7/gitrevisions.7*
570 %{_mandir}/man7/gittutorial-2.7*
571 %{_mandir}/man7/gittutorial.7*
572 %{_mandir}/man7/gitworkflows.7*
573 %endif
574
575 %dir %{_libdir}/%{name}
576 %attr(755,root,root) %{_libdir}/%{name}/*-*
577 %attr(755,root,root) %{_libdir}/%{name}/git
578 %{_libdir}/%{name}/mergetools
579
580 %exclude %{_libdir}/%{name}/git-gui
581 %exclude %{_libdir}/%{name}/git-svn
582 %exclude %{_libdir}/%{name}/git-archimport
583 %exclude %{_libdir}/%{name}/git-cvs*
584 %exclude %{_libdir}/%{name}/git-instaweb
585 %exclude %{_libdir}/%{name}/git-remote-testgit
586 %exclude %{_libdir}/%{name}/*email*
587
588 %{_datadir}/%{name}
589
590 %{_localstatedir}/lib/git
591
592 %if %{with doc}
593 %files doc
594 %defattr(644,root,root,755)
595 %doc Documentation/RelNotes*
596 %doc Documentation/*.html Documentation/howto Documentation/technical
597 %endif
598
599 %files daemon-inetd
600 %defattr(644,root,root,755)
601 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
602
603 %files daemon-standalone
604 %defattr(644,root,root,755)
605 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
606 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
607
608 %files devel
609 %defattr(644,root,root,755)
610 %{_includedir}/%{name}
611 %{_libdir}/libgit.a
612 %{_libdir}/libgit_xdiff.a
613
614 %files gitk
615 %defattr(644,root,root,755)
616 %if %{with doc}
617 %{_mandir}/man1/gitk.1*
618 %endif
619 %attr(755,root,root) %{_bindir}/gitk
620 %dir %{_datadir}/gitk
621 %dir %{_datadir}/gitk/lib
622 %dir %{_datadir}/gitk/lib/msgs
623 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
624 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
625 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
626 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
627 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
628 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
629 %lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
630 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
631 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
632
633 %files gitweb
634 %defattr(644,root,root,755)
635 %doc gitweb/{README,INSTALL}
636 %dir %{webappdir}
637 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
638 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
639 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
640 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
641 %attr(755,root,root) %{cgibindir}/gitweb.cgi
642 %{appdir}
643 %attr(755,root,root) %{_libdir}/%{name}/git-instaweb
644 %if %{with doc}
645 %{_mandir}/man1/gitweb.1*
646 %{_mandir}/man5/gitweb.conf.5*
647 %endif
648
649 %files gitview
650 %defattr(644,root,root,755)
651 %doc contrib/gitview/gitview.txt
652 %attr(755,root,root) %{_bindir}/gitview
653
654 %files gui
655 %defattr(644,root,root,755)
656 %attr(755,root,root) %{_libdir}/%{name}/git-gui
657 %dir %{_datadir}/git-gui
658 %dir %{_datadir}/git-gui/lib
659 %dir %{_datadir}/git-gui/lib/msgs
660 %{_datadir}/git-gui/lib/git-gui.ico
661 %{_datadir}/git-gui/lib/tclIndex
662 %{_datadir}/git-gui/lib/*.js
663 %{_datadir}/git-gui/lib/*.tcl
664 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
665 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
666 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
667 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
668 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
669 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
670 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
671 %lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
672 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
673 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
674 %lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
675
676 %files svn
677 %defattr(644,root,root,755)
678 %attr(755,root,root) %{_libdir}/%{name}/git-svn
679 %{perl_vendorlib}/Git/SVN
680 %{perl_vendorlib}/Git/SVN.pm
681 %if %{with doc}
682 %{_mandir}/man1/git-svn.1*
683 %endif
684
685 %files cvs
686 %defattr(644,root,root,755)
687 %attr(755,root,root) %{_bindir}/git-cvsserver
688 %attr(755,root,root) %{_libdir}/%{name}/git-cvs*
689 %if %{with doc}
690 %{_mandir}/man1/git-cvs*.1*
691 %{_mandir}/man7/gitcvs-migration.7*
692 %endif
693
694 %files arch
695 %defattr(644,root,root,755)
696 %attr(755,root,root) %{_libdir}/%{name}/git-archimport
697 %if %{with doc}
698 %{_mandir}/man1/git-archimport.1*
699 %endif
700
701 %files email
702 %defattr(644,root,root,755)
703 %attr(755,root,root) %{_libdir}/%{name}/*email*
704 %if %{with doc}
705 %{_mandir}/man1/*email*.1*
706 %endif
707
708 %files -n bash-completion-git
709 %defattr(644,root,root,755)
710 /etc/bash_completion.d/git-completion.bash
711
712 %files -n perl-Git
713 %defattr(644,root,root,755)
714 %{perl_vendorlib}/Git.pm
715 %dir %{perl_vendorlib}/Git
716 %{perl_vendorlib}/Git/I18N.pm
717 %{perl_vendorlib}/Git/IndexInfo.pm
718 %{_mandir}/man3/Git*.3pm*
719
720 %files -n python-Git
721 %defattr(644,root,root,755)
722 %attr(755,root,root) %{_libdir}/%{name}/git-remote-testgit
723 %dir %{py_sitescriptdir}/git_remote_helpers
724 %{py_sitescriptdir}/git_remote_helpers/*.py[co]
725 %dir %{py_sitescriptdir}/git_remote_helpers/git
726 %{py_sitescriptdir}/git_remote_helpers/git/*.py[co]
727 %if "%{py_ver}" > "2.4"
728 %{py_sitescriptdir}/git_remote_helpers*.egg-info
729 %endif
730 %if %{with doc}
731 %{_mandir}/man1/git-remote-helpers.1*
732 %endif
733
734 %files -n vim-syntax-gitcommit
735 %defattr(644,root,root,755)
736 %doc contrib/vim/README
737 %{_datadir}/vim/vimfiles/syntax/gitcommit.vim
This page took 0.097608 seconds and 4 git commands to generate.