]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
- drop todo; add br
[packages/git-core.git] / git-core.spec
1 %include        /usr/lib/rpm/macros.perl
2 Summary:        The stupid content tracker
3 Summary(pl):    Prymitywne narzêdzie do ¶ledzenia tre¶ci
4 Name:           git-core
5 Version:        1.4.3.4
6 Release:        1
7 License:        GPL v2
8 Group:          Development/Tools
9 Source0:        http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
10 # Source0-md5:  5114c6b58329f3574697a595774df7d0
11 URL:            http://git.or.cz/
12 BuildRequires:  asciidoc
13 BuildRequires:  curl-devel
14 BuildRequires:  expat-devel
15 BuildRequires:  openssl-devel
16 BuildRequires:  perl-base
17 BuildRequires:  python
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRequires:  xmlto
20 BuildRequires:  zlib-devel
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 "git" can mean anything, depending on your mood.
25
26  - random three-letter combination that is pronounceable, and not
27    actually used by any common UNIX command. The fact that it is a
28    mispronunciation of "get" may or may not be relevant.
29  - stupid. contemptible and despicable. simple. Take your pick from the
30    dictionary of slang.
31  - "global information tracker": you're in a good mood, and it actually
32    works for you. Angels sing, and a light suddenly fills the room.
33  - "goddamn idiotic truckload of sh*t": when it breaks
34
35 This is a stupid (but extremely fast) directory content manager. It
36 doesn't do a whole lot, but what it 'does' do is track directory
37 contents efficiently.
38
39 %description -l pl
40 "git" mo¿e oznaczaæ cokolwiek, w zale¿no¶ci od nastroju.
41
42 - losow± kombinacjê trzech liter, która jest wymawialna i w³a¶ciwie
43   nie u¿ywana przez ¿adne popularne polecenie uniksowe. Fakt, ¿e jest to
44   b³êdna pisownia s³owa "get" mo¿e mieæ lub nie mieæ znaczenia.
45 - g³upi, pogardliwy, prosty. Mo¿na wybraæ ze s³ownika slangu.
46 - "global information tracker" (narzêdzie do globalnego ¶ledzenia
47   informacji) - je¶li jeste¶my w dobrym nastroju i git akurat dzia³a.
48   Anio³y ¶piewaj±, a ¶wiat³o niespodziewanie wype³nia pokój.
49 - "goddamn idiotic truckload of sh*t" (przeklêty idiotyczny ³adunek
50   g*) - kiedy siê zepsuje.
51
52 Jest to prymitywny (ale bardzo szybki) zarz±dca tre¶ci s³ownikowej.
53 Nie robi wiele, ale to, co "robi", to wydajne ¶ledzenie zawarto¶ci
54 katalogu.
55
56 %package devel
57 Summary:        Header files for git-core
58 Summary(pl):    Pliki nag³ówkowe dla git-core
59 Group:          Development/Libraries
60
61 %description devel
62 Header files for git-core.
63
64 %description devel
65 Pliki nag³ówkowe dla git-core.
66
67 %package -n perl-git-core
68 Summary:        Perl interface to the Git version control system
69 Group:          Development/Languages/Perl
70 Requires:       %{name} = %{version}-%{release}
71
72 %description -n perl-git-core
73 This module provides Perl scripts easy way to interface the Git
74 version control system. The modules have an easy and well-tested way
75 to call arbitrary Git commands; in the future, the interface will also
76 provide specialized methods for doing easily operations which are not
77 totally trivial to do over the generic command interface.
78
79 %prep
80 %setup -q -n git-%{version}
81
82 %build
83 cd perl
84 %{__perl} Makefile.PL \
85         INSTALLDIRS=vendor
86 cd ..
87
88 %{__make} \
89         prefix=%{_prefix} \
90         CC="%{__cc}" \
91         CFLAGS="%{rpmcflags}" \
92         LDFLAGS="%{rpmldflags}"
93
94 %{__make} -C Documentation
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98 install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
99
100 %{__make} install \
101         prefix=%{_prefix} \
102         CFLAGS="%{rpmcflags}" \
103         DESTDIR=$RPM_BUILD_ROOT
104
105 %{__make} -C Documentation install \
106         prefix=%{_prefix} \
107         mandir=%{_mandir} \
108         DESTDIR=$RPM_BUILD_ROOT
109
110 install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
111 install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %files
117 %defattr(644,root,root,755)
118 %doc README Documentation/*.html Documentation/howto Documentation/technical
119 %attr(755,root,root) %{_bindir}/*
120 %{_mandir}/man*/*
121 %dir %{_datadir}/%{name}
122 %{_datadir}/%{name}/*
123
124 %files devel
125 %defattr(644,root,root,755)
126 %{_includedir}/*
127
128 %files -n perl-git-core
129 %defattr(644,root,root,755)
130 %{perl_vendorlib}/*.pm
131 %{_mandir}/man3/*
This page took 0.051562 seconds and 4 git commands to generate.