]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
- svn tests now work with subversion-1.7.6
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform make test
4 %bcond_with     tests_cvs       # perform tests which use CVS
5 %bcond_without  tests_svn       # perform tests which use subversion
6 %bcond_without  doc             # skip building/packaging docs/manuals (takes some time)
7
8 %define _rc  rc2
9
10 %include        /usr/lib/rpm/macros.perl
11 Summary:        Distributed version control system focused on speed, effectivity and usability
12 Summary(pl.UTF-8):      Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
13 Name:           git-core
14 Version:        1.8.0
15 Release:        0.%{_rc}.1
16 License:        GPL v2
17 Group:          Development/Tools
18 Source0:        http://git-core.googlecode.com/files/git-%{version}.%{_rc}.tar.gz
19 # Source0-md5:  9d4d7c02b64174f5f81d314b9b4f5c54
20 Source1:        %{name}-gitweb.conf
21 Source2:        %{name}-gitweb-httpd.conf
22 Source3:        %{name}-gitweb-lighttpd.conf
23 Source4:        %{name}.sysconfig
24 Source5:        %{name}.inet
25 Source6:        %{name}.init
26 Patch0:         %{name}-tests.patch
27 Patch1:         %{name}-key-bindings.patch
28 Patch2:         %{name}-sysconfdir.patch
29 URL:            http://git-scm.com/
30 BuildRequires:  autoconf >= 2.59
31 BuildRequires:  automake
32 BuildRequires:  curl-devel
33 BuildRequires:  expat-devel
34 BuildRequires:  gettext-devel
35 BuildRequires:  openssl-devel
36 BuildRequires:  perl-Error > 0.15
37 BuildRequires:  perl-base
38 BuildRequires:  python-devel
39 BuildRequires:  rpm-perlprov >= 4.1-13
40 BuildRequires:  rpm-pythonprov
41 BuildRequires:  rpmbuild(macros) >= 1.264
42 BuildRequires:  tcl
43 BuildRequires:  zlib-devel
44 %if %{with doc}
45 BuildRequires:  asciidoc >= 7.1.2-3
46 BuildRequires:  docbook-dtd45-xml
47 BuildRequires:  xmlto
48 %endif
49 %if %{with tests}
50 %if %{with tests_cvs}
51 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
52 BuildRequires:  cvs-gnu-client < 1.13
53 BuildRequires:  cvs-gnu-client >= 1.12
54 %endif
55 %{?with_tests_svn:BuildRequires:  subversion}
56 Conflicts:      pdksh < 5.2.14-46
57 %endif
58 Requires:       coreutils
59 Requires:       diffutils
60 Requires:       findutils
61 Requires:       grep
62 Requires:       openssh-clients
63 Requires:       perl-Error
64 Requires:       perl-Git = %{version}-%{release}
65 Requires:       sed
66 Suggests:       git-core-cvs
67 Suggests:       git-core-svn
68 Suggests:       less
69 Suggests:       rsync
70 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
72 # html docs have links to txt files
73 %define         _noautocompressdoc      *.txt
74
75 %define         webapp          gitweb
76 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
77 %define         appdir          %{_datadir}/%{webapp}
78 %define         cgibindir       %{_prefix}/lib/cgi-bin
79
80 %description
81 "git" can mean anything, depending on your mood.
82
83 - random three-letter combination that is pronounceable, and not
84   actually used by any common UNIX command. The fact that it is a
85   mispronunciation of "get" may or may not be relevant.
86 - stupid. contemptible and despicable. simple. Take your pick from the
87   dictionary of slang.
88 - "global information tracker": you're in a good mood, and it actually
89   works for you. Angels sing, and a light suddenly fills the room.
90 - "goddamn idiotic truckload of sh*t": when it breaks
91
92 This is a stupid (but extremely fast) directory content manager. It
93 doesn't do a whole lot, but what it 'does' do is track directory
94 contents efficiently.
95
96 %description -l pl.UTF-8
97 "git" może oznaczać cokolwiek, w zależności od nastroju.
98
99 - losową kombinację trzech liter, która jest wymawialna i właściwie
100   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
101   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
102 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
103 - "global information tracker" (narzędzie do globalnego śledzenia
104   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
105   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
106 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
107   g*) - kiedy się zepsuje.
108
109 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
110 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
111 katalogu.
112
113 %package doc
114 Summary:        Documentation for git-core
115 Summary(pl.UTF-8):      Dokumentacja do git-core
116 Group:          Documentation
117
118 %description doc
119 Documentation for git-core.
120
121 %description doc -l pl.UTF-8
122 Dokumentacja do git-core.
123
124 %description doc -l fr.UTF-8
125 Javadoc pour git-core.
126
127 %package daemon-inetd
128 Summary:        Files necessary to run git-daemon as an inetd service
129 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
130 Group:          Networking/Daemons
131 Requires:       %{name} = %{version}-%{release}
132 Requires:       setup >= 2.4.11-1
133 Provides:       git-core-daemon
134 Obsoletes:      git-core-daemon
135 Obsoletes:      git-core-daemon-standalone
136
137 %description daemon-inetd
138 Git-daemon is a really simple TCP git daemon that can serve git
139 repositories. This package provides all necessarry files to run
140 git-daemon as an inetd service.
141
142 %description daemon-inetd -l pl.UTF-8
143 Git-daemon to prosty demon git korzystający z protokołu TCP do
144 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
145 do uruchomienia git-demona w trybie usługi inetd.
146
147 %package daemon-standalone
148 Summary:        Files necessary to run git-daemon as a standalone service
149 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
150 Group:          Networking/Daemons
151 Requires:       %{name} = %{version}-%{release}
152 Provides:       git-core-daemon
153 Obsoletes:      git-core-daemon
154 Obsoletes:      git-core-daemon-inetd
155
156 %description daemon-standalone
157 Git-daemon is a really simple TCP git daemon that can serve git
158 repositories. This package provides all necessarry files to run
159 git-daemon as an standalone service.
160
161 %description daemon-standalone -l pl.UTF-8
162 Git-daemon to prosty demon git korzystający z protokołu TCP do
163 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
164 do uruchomienia git-daemona w trybie usługi samodzielnej.
165
166 %package devel
167 Summary:        Header files for git-core
168 Summary(pl.UTF-8):      Pliki nagłówkowe dla git-core
169 Group:          Development/Libraries
170 Requires:       zlib-devel
171
172 %description devel
173 Header files for git-core.
174
175 %description devel -l pl.UTF-8
176 Pliki nagłówkowe dla git-core.
177
178 %package gitk
179 Summary:        Tcl/Tk interface to the Git version control system
180 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
181 Group:          Development/Tools
182 Requires:       %{name} = %{version}-%{release}
183 Requires:       tk
184
185 %description gitk
186 gitk displays changes in a repository or a selected set of commits.
187 This includes visualizing the commit graph, showing information
188 related to each commit, and the files in the trees of each revision.
189
190 Historically, gitk was the first repository browser. It's written in
191 Tcl/Tk and started off in a separate repository but was later merged
192 into the main git repository.
193
194 %description gitk -l pl.UTF-8
195 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
196 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
197 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
198
199 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
200 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
201 osobnym repozytorium, ale z czasem został włączony do głównego
202 repozytorium gita.
203
204 %package gitweb
205 Summary:        Web frontend to git
206 Summary(pl.UTF-8):      Frontend WWW do gita
207 Group:          Development/Tools
208 Requires:       %{name} = %{version}-%{release}
209 Requires:       webapps
210 Requires:       webserver(alias)
211 Requires:       webserver(cgi)
212 Suggests:       webserver(setenv)
213
214 %description gitweb
215 This package provides a web interface for browsing git repositories.
216
217 %description gitweb -l pl.UTF-8
218 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
219
220 %package gitview
221 Summary:        A GTK+ based repository browser for git
222 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
223 Group:          Development/Tools
224 Requires:       %{name} = %{version}-%{release}
225 Requires:       python >= 1:2.4
226 Requires:       python-pycairo >= 1.0
227 Requires:       python-pygobject
228 Requires:       python-pygtk-gtk >= 2:2.8
229 Suggests:       python-gnome-desktop-gtksourceview
230
231 %description gitview
232 A GTK+ based repository browser for git.
233
234 %description gitview -l pl.UTF-8
235 Oparta na GTK+ przeglądarka repozytorium gita.
236
237 %package gui
238 Summary:        Tcl/Tk interface to the Git version control system
239 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
240 Group:          Development/Tools
241 Requires:       %{name} = %{version}-%{release}
242 Requires:       tk
243 Requires:       xdg-utils
244 Suggests:       meld
245
246 %description gui
247 Displays changes in a repository or a selected set of commits. This
248 includes visualizing the commit graph, showing information related to
249 each commit, and the files in the trees of each revision.
250
251 Historically, gitk was the first repository browser. It's written in
252 Tcl/Tk and started off in a separate repository but was later merged
253 into the main git repository.
254
255 %description gui -l pl.UTF-8
256 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
257 to wizualizację grafu commitów, wyświetlanie informacji związanych z
258 każdym z commitów oraz listę plików dla każdej rewizji.
259
260 Z punktu widzenia historii, gitk był pierwszą przeglądarką
261 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
262 osobnym repozytorium, ale z czasem został włączony do głównego
263 repozytorium gita.
264
265 %package svn
266 Summary:        Subversion support for Git
267 Summary(pl.UTF-8):      Obsługa Subversion dla Gita
268 Group:          Development/Tools
269 Requires:       %{name} = %{version}-%{release}
270 Requires:       perl-Encode
271 Requires:       perl-Term-ReadKey
272
273 %description svn
274 Subversion support for Git.
275
276 %description svn -l pl.UTF-8
277 Obsługa Subversion dla Gita.
278
279 %package cvs
280 Summary:        CVS support for Git
281 Summary(pl.UTF-8):      Obsługa CVS dla Gita
282 Group:          Development/Tools
283 Requires:       %{name} = %{version}-%{release}
284 Requires:       cvsps >= 2.1-2
285 Requires:       rcs
286
287 %description cvs
288 CVS support for Git.
289
290 %description cvs -l pl.UTF-8
291 Obsługa CVS dla Gita.
292
293 %package arch
294 Summary:        Git tools for importing Arch repositories
295 Summary(pl.UTF-8):      Narzędzia Gita do importowania repozytoriów Archa
296 Group:          Development/Tools
297 Requires:       %{name} = %{version}-%{release}
298 Requires:       tla
299
300 %description arch
301 Git tools for importing Arch repositories.
302
303 %description arch -l pl.UTF-8
304 Narzędzia Gita do importowania repozytoriów Archa.
305
306 %package email
307 Summary:        Git tools for sending email
308 Summary(pl.UTF-8):      Narzędzia Gita do wysyłania poczty
309 Group:          Development/Tools
310 Requires:       %{name} = %{version}-%{release}
311
312 %description email
313 Git tools for sending email.
314
315 %description email -l pl.UTF-8
316 Narzędzia Gita do wysyłania poczty.
317
318 %package -n bash-completion-git
319 Summary:        bash-completion for git
320 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
321 Group:          Applications/Shells
322 Requires:       %{name} = %{version}-%{release}
323 Requires:       bash-completion
324
325 %description -n bash-completion-git
326 This package provides bash-completion for git.
327
328 %description -n bash-completion-git -l pl.UTF-8
329 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
330
331 %package -n perl-Git
332 Summary:        Perl interface to the Git version control system
333 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
334 Group:          Development/Languages/Perl
335 Obsoletes:      perl-git-core
336
337 %description -n perl-Git
338 This module provides Perl scripts easy way to interface the Git
339 version control system. The modules have an easy and well-tested way
340 to call arbitrary Git commands; in the future, the interface will also
341 provide specialized methods for doing easily operations which are not
342 totally trivial to do over the generic command interface.
343
344 %description -n perl-Git -l pl.UTF-8
345 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
346 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
347 dowolne polecenia Gita; w przyszłości interfejs udostępni także
348 specjalne metody do łatwego wykonywania operacji nietrywialnych do
349 wykonania przy użyciu ogólnego interfejsu poleceń.
350
351 %package -n python-Git
352 Summary:        Python Git remote helpers for non-git repositories
353 Summary(pl.UTF-8):      Pythonowe zdalne moduły pomocnicze dla repozytoriów niegitowych
354 Group:          Development/Languages/Python
355 Requires:       %{name} = %{version}-%{release}
356
357 %description -n python-Git
358 This package contains Python git_repote_helpers package - Git remote
359 helpers for non-git repositories.
360
361 %description -n python-Git -l pl.UTF-8
362 Ten pakiet zawiera pakiet Pythona git_remote_helpers - zdalne moduły
363 pomocnicze Gita dla repozytoriów niegitowych.
364
365 %package -n vim-syntax-gitcommit
366 Summary:        Vim syntax: gitcommit
367 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
368 Group:          Applications/Editors/Vim
369 Requires:       %{name} = %{version}-%{release}
370 # for _vimdatadir existence
371 Requires:       vim-rt >= 4:6.3.058-3
372
373 %description -n vim-syntax-gitcommit
374 This plugin provides syntax highlighting for git's commit messages.
375
376 %description -n vim-syntax-gitcommit -l pl.UTF-8
377 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
378
379 %prep
380 %setup -q -n git-%{version}.%{_rc}
381 %patch0 -p1
382 %patch1 -p0
383 %patch2 -p1
384
385 %build
386 %{__aclocal}
387 %{__autoconf}
388 %configure \
389         --sysconfdir=%{_sysconfdir}/git-core \
390         --with-openssl
391
392 echo "BLK_SHA1=1" >> config.mak
393
394 %{__make} \
395         INSTALLDIRS=vendor \
396         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
397         GITWEB_PROJECTROOT="/var/lib/git" \
398         GITWEB_CSS="/gitweb/gitweb.css" \
399         GITWEB_LOGO="/gitweb/git-logo.png" \
400         GITWEB_FAVICON="/gitweb/git-favicon.png" \
401         V=1
402
403 %{?with_doc:%{__make} -C Documentation V=1}
404
405 %if %{with tests}
406 %if %{without tests_cvs}
407 rm t/t*cvs*.sh || :
408 %endif
409 %{!?with_tests_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
410 %endif
411
412 %install
413 rm -rf $RPM_BUILD_ROOT
414 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
415 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
416 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
417 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
418 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
419 [init]
420         templatedir = %{_sysconfdir}/%{name}/templates
421 EOF
422
423 %{__make} install \
424         INSTALLDIRS=vendor \
425         DESTDIR=$RPM_BUILD_ROOT
426
427 %if %{with doc}
428 %{__make} -C Documentation install \
429         DESTDIR=$RPM_BUILD_ROOT
430 %endif
431
432 # copy templates except sample hooks
433 cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
434 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
435
436 # header files and lib
437 cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
438 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
439 cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
440 cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
441 cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
442
443 # bash completion
444 install -d $RPM_BUILD_ROOT/etc/bash_completion.d
445 cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT/etc/bash_completion.d
446
447 # vim syntax
448 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
449 cat > $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax/gitcommit.vim << 'EOF'
450 autocmd BufNewFile,BufRead *.git/COMMIT_EDITMSG    setf gitcommit
451 autocmd BufNewFile,BufRead *.git/config,.gitconfig setf gitconfig
452 autocmd BufNewFile,BufRead git-rebase-todo         setf gitrebase
453 autocmd BufNewFile,BufRead .msg.[0-9]*
454         \ if getline(1) =~ '^From.*# This line is ignored.$' |
455         \   setf gitsendemail |
456         \ endif
457 autocmd BufNewFile,BufRead *.git/**
458         \ if getline(1) =~ '^\x\{40\}\>\|^ref: ' |
459         \   setf git |
460         \ endif
461 EOF
462
463 # gitweb
464 mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
465 ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
466 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
467 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
468 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
469 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
470
471 # gitview
472 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
473
474 # git-daemon related files
475 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
476 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
477 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
478
479 # paths cleanup
480 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
481 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
482
483 # hardlink
484 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
485 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
486 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
487 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
488
489 # remove unneeded files
490 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
491 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
492 %py_postclean
493
494 mv $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
495 %find_lang git
496
497 %clean
498 rm -rf $RPM_BUILD_ROOT
499
500 %post daemon-inetd
501 %service -q rc-inetd reload
502
503 %postun daemon-inetd
504 if [ "$1" = "0" ]; then
505         %service -q rc-inetd reload
506 fi
507
508 %post daemon-standalone
509 /sbin/chkconfig --add git-daemon
510 %service git-daemon restart "git-daemon"
511
512 %preun daemon-standalone
513 if [ "$1" = "0" ]; then
514         %service git-daemon stop
515         /sbin/chkconfig --del git-daemon
516 fi
517
518 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
519 %webapp_register apache %{webapp}
520
521 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
522 %webapp_unregister apache %{webapp}
523
524 %triggerin gitweb -- apache < 2.2.0, apache-base
525 %webapp_register httpd %{webapp}
526
527 %triggerun gitweb -- apache < 2.2.0, apache-base
528 %webapp_unregister httpd %{webapp}
529
530 %triggerin gitweb -- lighttpd
531 %webapp_register lighttpd %{webapp}
532
533 %triggerun gitweb -- lighttpd
534 %webapp_unregister lighttpd %{webapp}
535
536 %files -f git.lang
537 %defattr(644,root,root,755)
538 %doc README contrib
539 %attr(755,root,root) %{_bindir}/git
540 %attr(755,root,root) %{_bindir}/git-receive-pack
541 %attr(755,root,root) %{_bindir}/git-shell
542 %attr(755,root,root) %{_bindir}/git-upload-archive
543 %attr(755,root,root) %{_bindir}/git-upload-pack
544 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
545
546 %if %{with doc}
547 %{_mandir}/man1/git-*.1*
548 %exclude %{_mandir}/man1/git-archimport.1*
549 %exclude %{_mandir}/man1/git-svn.1*
550 %exclude %{_mandir}/man1/git-cvs*.1*
551 %exclude %{_mandir}/man1/*email*.1*
552 %exclude %{_mandir}/man1/git-remote-helpers.1*
553 %{_mandir}/man1/git.1*
554 %{_mandir}/man5/gitattributes.5*
555 %{_mandir}/man5/githooks.5*
556 %{_mandir}/man5/gitignore.5*
557 %{_mandir}/man5/gitmodules.5*
558 %{_mandir}/man5/gitrepository-layout.5*
559 %{_mandir}/man7/gitcli.7*
560 %{_mandir}/man7/gitcore-tutorial.7*
561 %{_mandir}/man7/gitcredentials.7*
562 %{_mandir}/man7/gitdiffcore.7*
563 %{_mandir}/man7/gitglossary.7*
564 %{_mandir}/man7/gitnamespaces.7*
565 %{_mandir}/man7/gitrevisions.7*
566 %{_mandir}/man7/gittutorial-2.7*
567 %{_mandir}/man7/gittutorial.7*
568 %{_mandir}/man7/gitworkflows.7*
569 %endif
570
571 %dir %{_libdir}/%{name}
572 %attr(755,root,root) %{_libdir}/%{name}/*-*
573 %attr(755,root,root) %{_libdir}/%{name}/git
574 %{_libdir}/%{name}/mergetools
575
576 %exclude %{_libdir}/%{name}/git-gui
577 %exclude %{_libdir}/%{name}/git-svn
578 %exclude %{_libdir}/%{name}/git-archimport
579 %exclude %{_libdir}/%{name}/git-cvs*
580 %exclude %{_libdir}/%{name}/git-instaweb
581 %exclude %{_libdir}/%{name}/git-remote-testgit
582 %exclude %{_libdir}/%{name}/*email*
583
584 %{_datadir}/%{name}
585
586 %{_localstatedir}/lib/git
587
588 %if %{with doc}
589 %files doc
590 %defattr(644,root,root,755)
591 %doc Documentation/RelNotes*
592 %doc Documentation/*.html Documentation/howto Documentation/technical
593 %endif
594
595 %files daemon-inetd
596 %defattr(644,root,root,755)
597 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
598
599 %files daemon-standalone
600 %defattr(644,root,root,755)
601 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
602 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
603
604 %files devel
605 %defattr(644,root,root,755)
606 %{_includedir}/%{name}
607 %{_libdir}/libgit.a
608 %{_libdir}/libgit_xdiff.a
609
610 %files gitk
611 %defattr(644,root,root,755)
612 %if %{with doc}
613 %{_mandir}/man1/gitk.1*
614 %endif
615 %attr(755,root,root) %{_bindir}/gitk
616 %dir %{_datadir}/gitk
617 %dir %{_datadir}/gitk/lib
618 %dir %{_datadir}/gitk/lib/msgs
619 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
620 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
621 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
622 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
623 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
624 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
625 %lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
626 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
627 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
628
629 %files gitweb
630 %defattr(644,root,root,755)
631 %doc gitweb/{README,INSTALL}
632 %dir %{webappdir}
633 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
634 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
635 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
636 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
637 %attr(755,root,root) %{cgibindir}/gitweb.cgi
638 %{appdir}
639 %attr(755,root,root) %{_libdir}/%{name}/git-instaweb
640 %if %{with doc}
641 %{_mandir}/man1/gitweb.1*
642 %{_mandir}/man5/gitweb.conf.5*
643 %endif
644
645 %files gitview
646 %defattr(644,root,root,755)
647 %doc contrib/gitview/gitview.txt
648 %attr(755,root,root) %{_bindir}/gitview
649
650 %files gui
651 %defattr(644,root,root,755)
652 %attr(755,root,root) %{_libdir}/%{name}/git-gui
653 %dir %{_datadir}/git-gui
654 %dir %{_datadir}/git-gui/lib
655 %dir %{_datadir}/git-gui/lib/msgs
656 %{_datadir}/git-gui/lib/git-gui.ico
657 %{_datadir}/git-gui/lib/tclIndex
658 %{_datadir}/git-gui/lib/*.js
659 %{_datadir}/git-gui/lib/*.tcl
660 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
661 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
662 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
663 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
664 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
665 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
666 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
667 %lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
668 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
669 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
670 %lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
671
672 %files svn
673 %defattr(644,root,root,755)
674 %attr(755,root,root) %{_libdir}/%{name}/git-svn
675 %{perl_vendorlib}/Git/SVN
676 %{perl_vendorlib}/Git/SVN.pm
677 %if %{with doc}
678 %{_mandir}/man1/git-svn.1*
679 %endif
680
681 %files cvs
682 %defattr(644,root,root,755)
683 %attr(755,root,root) %{_bindir}/git-cvsserver
684 %attr(755,root,root) %{_libdir}/%{name}/git-cvs*
685 %if %{with doc}
686 %{_mandir}/man1/git-cvs*.1*
687 %{_mandir}/man7/gitcvs-migration.7*
688 %endif
689
690 %files arch
691 %defattr(644,root,root,755)
692 %attr(755,root,root) %{_libdir}/%{name}/git-archimport
693 %if %{with doc}
694 %{_mandir}/man1/git-archimport.1*
695 %endif
696
697 %files email
698 %defattr(644,root,root,755)
699 %attr(755,root,root) %{_libdir}/%{name}/*email*
700 %if %{with doc}
701 %{_mandir}/man1/*email*.1*
702 %endif
703
704 %files -n bash-completion-git
705 %defattr(644,root,root,755)
706 /etc/bash_completion.d/git-completion.bash
707
708 %files -n perl-Git
709 %defattr(644,root,root,755)
710 %{perl_vendorlib}/Git.pm
711 %dir %{perl_vendorlib}/Git
712 %{perl_vendorlib}/Git/I18N.pm
713 %{perl_vendorlib}/Git/IndexInfo.pm
714 %{_mandir}/man3/Git*.3pm*
715
716 %files -n python-Git
717 %defattr(644,root,root,755)
718 %attr(755,root,root) %{_libdir}/%{name}/git-remote-testgit
719 %dir %{py_sitescriptdir}/git_remote_helpers
720 %{py_sitescriptdir}/git_remote_helpers/*.py[co]
721 %dir %{py_sitescriptdir}/git_remote_helpers/git
722 %{py_sitescriptdir}/git_remote_helpers/git/*.py[co]
723 %if "%{py_ver}" > "2.4"
724 %{py_sitescriptdir}/git_remote_helpers*.egg-info
725 %endif
726 %if %{with doc}
727 %{_mandir}/man1/git-remote-helpers.1*
728 %endif
729
730 %files -n vim-syntax-gitcommit
731 %defattr(644,root,root,755)
732 %doc contrib/vim/README
733 %{_datadir}/vim/vimfiles/syntax/gitcommit.vim
This page took 0.082602 seconds and 4 git commands to generate.