]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
gitweb package Requires: webserver(access)
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform make test
4 %bcond_with     tests_cvs       # perform tests which use CVS
5 %bcond_without  tests_svn       # perform tests which use subversion
6 %bcond_without  doc             # skip building/packaging docs/manuals (takes some time)
7 %bcond_without  pcre            # perl-compatible regexes support
8
9 %include        /usr/lib/rpm/macros.perl
10 Summary:        Distributed version control system focused on speed, effectivity and usability
11 Summary(pl.UTF-8):      Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
12 Name:           git-core
13 Version:        1.8.4.1
14 Release:        2
15 License:        GPL v2
16 Group:          Development/Tools
17 Source0:        http://git-core.googlecode.com/files/git-%{version}.tar.gz
18 # Source0-md5:  5d8c89ad312ca0b0e603259c9357e6b8
19 Source1:        %{name}-gitweb.conf
20 Source2:        %{name}-gitweb-httpd.conf
21 Source3:        %{name}-gitweb-lighttpd.conf
22 Source4:        %{name}.sysconfig
23 Source5:        %{name}.inet
24 Source6:        %{name}.init
25 Patch0:         %{name}-tests.patch
26 Patch1:         %{name}-key-bindings.patch
27 Patch2:         %{name}-sysconfdir.patch
28 Patch3:         cherry-picked-commitlog.patch
29 Patch4:         %{name}-svn-exit-errors.patch
30 URL:            http://git-scm.com/
31 BuildRequires:  autoconf >= 2.59
32 BuildRequires:  automake
33 BuildRequires:  curl-devel
34 BuildRequires:  expat-devel
35 BuildRequires:  gettext-devel
36 BuildRequires:  openssl-devel
37 %{?with_pcre:BuildRequires:     pcre-devel}
38 BuildRequires:  perl-Error > 0.15
39 BuildRequires:  perl-base
40 BuildRequires:  python-devel
41 BuildRequires:  rpm-perlprov >= 4.1-13
42 BuildRequires:  rpm-pythonprov
43 BuildRequires:  rpmbuild(macros) >= 1.264
44 BuildRequires:  tcl
45 BuildRequires:  zlib-devel
46 %if %{with doc}
47 BuildRequires:  asciidoc >= 7.1.2-3
48 BuildRequires:  docbook-dtd45-xml
49 BuildRequires:  xmlto
50 %endif
51 %if %{with tests}
52 %if %{with tests_cvs}
53 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
54 BuildRequires:  cvs-gnu-client < 1.13
55 BuildRequires:  cvs-gnu-client >= 1.12
56 %endif
57 %{?with_tests_svn:BuildRequires:  subversion}
58 Conflicts:      pdksh < 5.2.14-46
59 %endif
60 Requires:       coreutils
61 Requires:       diffutils
62 Requires:       findutils
63 Requires:       grep
64 Requires:       openssh-clients
65 Requires:       perl-Error
66 Requires:       perl-Git = %{version}-%{release}
67 Requires:       sed
68 Suggests:       git-core-cvs
69 Suggests:       git-core-svn
70 Suggests:       less
71 Suggests:       rsync
72 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74 # html docs have links to txt files
75 %define         _noautocompressdoc      *.txt
76
77 %define         webapp          gitweb
78 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
79 %define         appdir          %{_datadir}/%{webapp}
80 %define         cgibindir       %{_prefix}/lib/cgi-bin
81 %define         bash_compdir    %{_datadir}/bash-completion/completions
82
83 %description
84 "git" can mean anything, depending on your mood.
85
86 - random three-letter combination that is pronounceable, and not
87   actually used by any common UNIX command. The fact that it is a
88   mispronunciation of "get" may or may not be relevant.
89 - stupid. contemptible and despicable. simple. Take your pick from the
90   dictionary of slang.
91 - "global information tracker": you're in a good mood, and it actually
92   works for you. Angels sing, and a light suddenly fills the room.
93 - "goddamn idiotic truckload of sh*t": when it breaks
94
95 This is a stupid (but extremely fast) directory content manager. It
96 doesn't do a whole lot, but what it 'does' do is track directory
97 contents efficiently.
98
99 %description -l pl.UTF-8
100 "git" może oznaczać cokolwiek, w zależności od nastroju.
101
102 - losową kombinację trzech liter, która jest wymawialna i właściwie
103   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
104   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
105 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
106 - "global information tracker" (narzędzie do globalnego śledzenia
107   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
108   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
109 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
110   g*) - kiedy się zepsuje.
111
112 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
113 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
114 katalogu.
115
116 %package doc
117 Summary:        Documentation for git-core
118 Summary(pl.UTF-8):      Dokumentacja do git-core
119 Group:          Documentation
120
121 %description doc
122 Documentation for git-core.
123
124 %description doc -l pl.UTF-8
125 Dokumentacja do git-core.
126
127 %description doc -l fr.UTF-8
128 Javadoc pour git-core.
129
130 %package daemon-inetd
131 Summary:        Files necessary to run git-daemon as an inetd service
132 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
133 Group:          Networking/Daemons
134 Requires:       %{name} = %{version}-%{release}
135 Requires:       setup >= 2.4.11-1
136 Provides:       git-core-daemon
137 Obsoletes:      git-core-daemon
138 Obsoletes:      git-core-daemon-standalone
139
140 %description daemon-inetd
141 Git-daemon is a really simple TCP git daemon that can serve git
142 repositories. This package provides all necessarry files to run
143 git-daemon as an inetd service.
144
145 %description daemon-inetd -l pl.UTF-8
146 Git-daemon to prosty demon git korzystający z protokołu TCP do
147 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
148 do uruchomienia git-demona w trybie usługi inetd.
149
150 %package daemon-standalone
151 Summary:        Files necessary to run git-daemon as a standalone service
152 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
153 Group:          Networking/Daemons
154 Requires:       %{name} = %{version}-%{release}
155 Provides:       git-core-daemon
156 Obsoletes:      git-core-daemon
157 Obsoletes:      git-core-daemon-inetd
158
159 %description daemon-standalone
160 Git-daemon is a really simple TCP git daemon that can serve git
161 repositories. This package provides all necessarry files to run
162 git-daemon as an standalone service.
163
164 %description daemon-standalone -l pl.UTF-8
165 Git-daemon to prosty demon git korzystający z protokołu TCP do
166 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
167 do uruchomienia git-daemona w trybie usługi samodzielnej.
168
169 %package devel
170 Summary:        Git library with header files
171 Summary(pl.UTF-8):      Biblioteka Gita oraz pliki nagłówkowe
172 Group:          Development/Libraries
173 Requires:       zlib-devel
174
175 %description devel
176 Git library with header files.
177
178 %description devel -l pl.UTF-8
179 Biblioteka Gita oraz pliki nagłówkowe.
180
181 %package gitk
182 Summary:        Tcl/Tk interface to the Git version control system
183 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
184 Group:          Development/Tools
185 Requires:       %{name} = %{version}-%{release}
186 Requires:       tk
187
188 %description gitk
189 gitk displays changes in a repository or a selected set of commits.
190 This includes visualizing the commit graph, showing information
191 related to each commit, and the files in the trees of each revision.
192
193 Historically, gitk was the first repository browser. It's written in
194 Tcl/Tk and started off in a separate repository but was later merged
195 into the main git repository.
196
197 %description gitk -l pl.UTF-8
198 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
199 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
200 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
201
202 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
203 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
204 osobnym repozytorium, ale z czasem został włączony do głównego
205 repozytorium gita.
206
207 %package gitweb
208 Summary:        Web frontend to git
209 Summary(pl.UTF-8):      Frontend WWW do gita
210 Group:          Development/Tools
211 Requires:       %{name} = %{version}-%{release}
212 Requires:       webapps
213 Requires:       webserver(access)
214 Requires:       webserver(alias)
215 Requires:       webserver(cgi)
216 Suggests:       webserver(setenv)
217
218 %description gitweb
219 This package provides a web interface for browsing git repositories.
220
221 %description gitweb -l pl.UTF-8
222 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
223
224 %package gitview
225 Summary:        A GTK+ based repository browser for git
226 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
227 Group:          Development/Tools
228 Requires:       %{name} = %{version}-%{release}
229 Requires:       python >= 1:2.4
230 Requires:       python-pycairo >= 1.0
231 Requires:       python-pygobject
232 Requires:       python-pygtk-gtk >= 2:2.8
233 Suggests:       python-gnome-desktop-gtksourceview
234
235 %description gitview
236 A GTK+ based repository browser for git.
237
238 %description gitview -l pl.UTF-8
239 Oparta na GTK+ przeglądarka repozytorium gita.
240
241 %package gui
242 Summary:        Tcl/Tk interface to the Git version control system
243 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
244 Group:          Development/Tools
245 Requires:       %{name} = %{version}-%{release}
246 Requires:       tk
247 Requires:       xdg-utils
248 Suggests:       meld
249
250 %description gui
251 Displays changes in a repository or a selected set of commits. This
252 includes visualizing the commit graph, showing information related to
253 each commit, and the files in the trees of each revision.
254
255 Historically, gitk was the first repository browser. It's written in
256 Tcl/Tk and started off in a separate repository but was later merged
257 into the main git repository.
258
259 %description gui -l pl.UTF-8
260 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
261 to wizualizację grafu commitów, wyświetlanie informacji związanych z
262 każdym z commitów oraz listę plików dla każdej rewizji.
263
264 Z punktu widzenia historii, gitk był pierwszą przeglądarką
265 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
266 osobnym repozytorium, ale z czasem został włączony do głównego
267 repozytorium gita.
268
269 %package svn
270 Summary:        Subversion support for Git
271 Summary(pl.UTF-8):      Obsługa Subversion dla Gita
272 Group:          Development/Tools
273 Requires:       %{name} = %{version}-%{release}
274 Requires:       perl-Encode
275 Requires:       perl-Term-ReadKey
276
277 %description svn
278 Subversion support for Git.
279
280 %description svn -l pl.UTF-8
281 Obsługa Subversion dla Gita.
282
283 %package cvs
284 Summary:        CVS support for Git
285 Summary(pl.UTF-8):      Obsługa CVS dla Gita
286 Group:          Development/Tools
287 Requires:       %{name} = %{version}-%{release}
288 Requires:       cvsps >= 2.1-2
289 Requires:       rcs
290
291 %description cvs
292 CVS support for Git.
293
294 %description cvs -l pl.UTF-8
295 Obsługa CVS dla Gita.
296
297 %package arch
298 Summary:        Git tools for importing Arch repositories
299 Summary(pl.UTF-8):      Narzędzia Gita do importowania repozytoriów Archa
300 Group:          Development/Tools
301 Requires:       %{name} = %{version}-%{release}
302 Requires:       tla
303
304 %description arch
305 Git tools for importing Arch repositories.
306
307 %description arch -l pl.UTF-8
308 Narzędzia Gita do importowania repozytoriów Archa.
309
310 %package email
311 Summary:        Git tools for sending email
312 Summary(pl.UTF-8):      Narzędzia Gita do wysyłania poczty
313 Group:          Development/Tools
314 Requires:       %{name} = %{version}-%{release}
315
316 %description email
317 Git tools for sending email.
318
319 %description email -l pl.UTF-8
320 Narzędzia Gita do wysyłania poczty.
321
322 %package -n bash-completion-git
323 Summary:        bash-completion for git
324 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
325 Group:          Applications/Shells
326 Requires:       %{name} = %{version}-%{release}
327 Requires:       bash-completion >= 2.0
328
329 %description -n bash-completion-git
330 This package provides bash-completion for git.
331
332 %description -n bash-completion-git -l pl.UTF-8
333 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
334
335 %package -n perl-Git
336 Summary:        Perl interface to the Git version control system
337 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
338 Group:          Development/Languages/Perl
339 Obsoletes:      perl-git-core
340
341 %description -n perl-Git
342 This module provides Perl scripts easy way to interface the Git
343 version control system. The modules have an easy and well-tested way
344 to call arbitrary Git commands; in the future, the interface will also
345 provide specialized methods for doing easily operations which are not
346 totally trivial to do over the generic command interface.
347
348 %description -n perl-Git -l pl.UTF-8
349 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
350 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
351 dowolne polecenia Gita; w przyszłości interfejs udostępni także
352 specjalne metody do łatwego wykonywania operacji nietrywialnych do
353 wykonania przy użyciu ogólnego interfejsu poleceń.
354
355 %package -n python-Git
356 Summary:        Python Git remote helpers for non-git repositories
357 Summary(pl.UTF-8):      Pythonowe zdalne moduły pomocnicze dla repozytoriów niegitowych
358 Group:          Development/Languages/Python
359 Requires:       %{name} = %{version}-%{release}
360
361 %description -n python-Git
362 This package contains Python git_repote_helpers package - Git remote
363 helpers for non-git repositories.
364
365 %description -n python-Git -l pl.UTF-8
366 Ten pakiet zawiera pakiet Pythona git_remote_helpers - zdalne moduły
367 pomocnicze Gita dla repozytoriów niegitowych.
368
369 %package -n vim-syntax-gitcommit
370 Summary:        Vim syntax: gitcommit
371 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
372 Group:          Applications/Editors/Vim
373 Requires:       %{name} = %{version}-%{release}
374 # for _vimdatadir existence
375 Requires:       vim-rt >= 4:6.3.058-3
376
377 %description -n vim-syntax-gitcommit
378 This plugin provides syntax highlighting for git's commit messages.
379
380 %description -n vim-syntax-gitcommit -l pl.UTF-8
381 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
382
383 %prep
384 %setup -q -n git-%{version}
385 %patch0 -p1
386 %patch1 -p0
387 %patch2 -p1
388 %patch3 -p1
389 %patch4 -p1
390
391 %build
392 %{__aclocal}
393 %{__autoconf}
394 %configure \
395         --sysconfdir=%{_sysconfdir}/git-core \
396         %{?with_pcre:--with-libpcre} \
397         --with-openssl
398
399 echo "BLK_SHA1=1" >> config.mak
400
401 %{__make} \
402         INSTALLDIRS=vendor \
403         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
404         GITWEB_PROJECTROOT="/var/lib/git" \
405         GITWEB_CSS="/gitweb/gitweb.css" \
406         GITWEB_LOGO="/gitweb/git-logo.png" \
407         GITWEB_FAVICON="/gitweb/git-favicon.png" \
408         V=1
409
410 %if %{with doc}
411 %{__make} -C Documentation \
412         MAN_BASE_URL=file://%{_docdir}/%{name}-doc-%{version}/ \
413         V=1
414 %endif
415
416 %if %{with tests}
417 %if %{without tests_cvs}
418 %{__rm} t/t*cvs*.sh || :
419 %endif
420 %{!?with_tests_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
421 %endif
422
423 %install
424 rm -rf $RPM_BUILD_ROOT
425 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
426 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
427 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
428 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
429 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
430 [init]
431         templatedir = %{_sysconfdir}/%{name}/templates
432 EOF
433
434 %{__make} install \
435         INSTALLDIRS=vendor \
436         DESTDIR=$RPM_BUILD_ROOT
437
438 %if %{with doc}
439 %{__make} -C Documentation install \
440         DESTDIR=$RPM_BUILD_ROOT
441 %endif
442
443 # copy templates except sample hooks
444 cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
445 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
446
447 # header files and lib
448 cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
449 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
450 cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
451 install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
452 cp -p block-sha1/sha1.h $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
453 cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
454 cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
455 cp -p {Makefile,config.mak,config.mak.autogen,config.mak.uname} $RPM_BUILD_ROOT%{_includedir}/%{name}
456
457 # bash completion
458 install -d $RPM_BUILD_ROOT%{bash_compdir}
459 cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{bash_compdir}/git
460
461 # vim syntax
462 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
463 cat > $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax/gitcommit.vim << 'EOF'
464 autocmd BufNewFile,BufRead *.git/COMMIT_EDITMSG    setf gitcommit
465 autocmd BufNewFile,BufRead *.git/config,.gitconfig setf gitconfig
466 autocmd BufNewFile,BufRead git-rebase-todo         setf gitrebase
467 autocmd BufNewFile,BufRead .msg.[0-9]*
468         \ if getline(1) =~ '^From.*# This line is ignored.$' |
469         \   setf gitsendemail |
470         \ endif
471 autocmd BufNewFile,BufRead *.git/**
472         \ if getline(1) =~ '^\x\{40\}\>\|^ref: ' |
473         \   setf git |
474         \ endif
475 EOF
476
477 # gitweb
478 mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
479 ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
480 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
481 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
482 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
483 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
484
485 # gitview
486 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
487
488 # git-daemon related files
489 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
490 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
491 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
492
493 # paths cleanup
494 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
495 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
496
497 # hardlink
498 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
499 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
500 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
501 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
502
503 # remove unneeded files
504 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
505 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
506 %py_postclean
507
508 mv $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
509 %find_lang git
510
511 %clean
512 rm -rf $RPM_BUILD_ROOT
513
514 %post daemon-inetd
515 %service -q rc-inetd reload
516
517 %postun daemon-inetd
518 if [ "$1" = "0" ]; then
519         %service -q rc-inetd reload
520 fi
521
522 %post daemon-standalone
523 /sbin/chkconfig --add git-daemon
524 %service git-daemon restart "git-daemon"
525
526 %preun daemon-standalone
527 if [ "$1" = "0" ]; then
528         %service git-daemon stop
529         /sbin/chkconfig --del git-daemon
530 fi
531
532 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
533 %webapp_register apache %{webapp}
534
535 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
536 %webapp_unregister apache %{webapp}
537
538 %triggerin gitweb -- apache < 2.2.0, apache-base
539 %webapp_register httpd %{webapp}
540
541 %triggerun gitweb -- apache < 2.2.0, apache-base
542 %webapp_unregister httpd %{webapp}
543
544 %triggerin gitweb -- lighttpd
545 %webapp_register lighttpd %{webapp}
546
547 %triggerun gitweb -- lighttpd
548 %webapp_unregister lighttpd %{webapp}
549
550 %files -f git.lang
551 %defattr(644,root,root,755)
552 %doc README contrib
553 %attr(755,root,root) %{_bindir}/git
554 %attr(755,root,root) %{_bindir}/git-receive-pack
555 %attr(755,root,root) %{_bindir}/git-shell
556 %attr(755,root,root) %{_bindir}/git-upload-archive
557 %attr(755,root,root) %{_bindir}/git-upload-pack
558 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
559
560 %if %{with doc}
561 %{_mandir}/man1/git-*.1*
562 %exclude %{_mandir}/man1/git-archimport.1*
563 %exclude %{_mandir}/man1/git-svn.1*
564 %exclude %{_mandir}/man1/git-cvs*.1*
565 %exclude %{_mandir}/man1/git-imap-send*.1*
566 %exclude %{_mandir}/man1/*email*.1*
567 %exclude %{_mandir}/man1/gitremote-helpers.1*
568 %{_mandir}/man1/git.1*
569 %{_mandir}/man5/gitattributes.5*
570 %{_mandir}/man5/githooks.5*
571 %{_mandir}/man5/gitignore.5*
572 %{_mandir}/man5/gitmodules.5*
573 %{_mandir}/man5/gitrepository-layout.5*
574 %{_mandir}/man7/gitcli.7*
575 %{_mandir}/man7/gitcore-tutorial.7*
576 %{_mandir}/man7/gitcredentials.7*
577 %{_mandir}/man7/gitdiffcore.7*
578 %{_mandir}/man7/gitglossary.7*
579 %{_mandir}/man7/gitnamespaces.7*
580 %{_mandir}/man7/gitrevisions.7*
581 %{_mandir}/man7/gittutorial-2.7*
582 %{_mandir}/man7/gittutorial.7*
583 %{_mandir}/man7/gitworkflows.7*
584 %endif
585
586 %dir %{_libdir}/%{name}
587 %attr(755,root,root) %{_libdir}/%{name}/*-*
588 %attr(755,root,root) %{_libdir}/%{name}/git
589 %{_libdir}/%{name}/mergetools
590
591 %exclude %{_libdir}/%{name}/git-gui
592 %exclude %{_libdir}/%{name}/git-svn
593 %exclude %{_libdir}/%{name}/git-archimport
594 %exclude %{_libdir}/%{name}/git-cvs*
595 %exclude %{_libdir}/%{name}/git-imap-send
596 %exclude %{_libdir}/%{name}/git-instaweb
597 %exclude %{_libdir}/%{name}/git-remote-testsvn
598 %exclude %{_libdir}/%{name}/*email*
599
600 %{_datadir}/%{name}
601
602 %{_localstatedir}/lib/git
603
604 %if %{with doc}
605 %files doc
606 %defattr(644,root,root,755)
607 %doc Documentation/RelNotes*
608 %doc Documentation/*.html Documentation/howto Documentation/technical
609 %endif
610
611 %files daemon-inetd
612 %defattr(644,root,root,755)
613 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
614
615 %files daemon-standalone
616 %defattr(644,root,root,755)
617 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
618 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
619
620 %files devel
621 %defattr(644,root,root,755)
622 %{_includedir}/%{name}
623 %{_libdir}/libgit.a
624 %{_libdir}/libgit_xdiff.a
625
626 %files gitk
627 %defattr(644,root,root,755)
628 %if %{with doc}
629 %{_mandir}/man1/gitk.1*
630 %endif
631 %attr(755,root,root) %{_bindir}/gitk
632 %dir %{_datadir}/gitk
633 %dir %{_datadir}/gitk/lib
634 %dir %{_datadir}/gitk/lib/msgs
635 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
636 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
637 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
638 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
639 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
640 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
641 %lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
642 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
643 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
644
645 %files gitweb
646 %defattr(644,root,root,755)
647 %doc gitweb/{README,INSTALL}
648 %dir %{webappdir}
649 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
650 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
651 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
652 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
653 %attr(755,root,root) %{cgibindir}/gitweb.cgi
654 %{appdir}
655 %attr(755,root,root) %{_libdir}/%{name}/git-instaweb
656 %if %{with doc}
657 %{_mandir}/man1/gitweb.1*
658 %{_mandir}/man5/gitweb.conf.5*
659 %endif
660
661 %files gitview
662 %defattr(644,root,root,755)
663 %doc contrib/gitview/gitview.txt
664 %attr(755,root,root) %{_bindir}/gitview
665
666 %files gui
667 %defattr(644,root,root,755)
668 %attr(755,root,root) %{_libdir}/%{name}/git-gui
669 %dir %{_datadir}/git-gui
670 %dir %{_datadir}/git-gui/lib
671 %dir %{_datadir}/git-gui/lib/msgs
672 %{_datadir}/git-gui/lib/git-gui.ico
673 %{_datadir}/git-gui/lib/tclIndex
674 %{_datadir}/git-gui/lib/*.js
675 %{_datadir}/git-gui/lib/*.tcl
676 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
677 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
678 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
679 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
680 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
681 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
682 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
683 %lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
684 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
685 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
686 %lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
687
688 %files svn
689 %defattr(644,root,root,755)
690 %attr(755,root,root) %{_libdir}/%{name}/git-svn
691 %attr(755,root,root) %{_libdir}/%{name}/git-remote-testsvn
692 %{perl_vendorlib}/Git/SVN
693 %{perl_vendorlib}/Git/SVN.pm
694 %if %{with doc}
695 %{_mandir}/man1/git-svn.1*
696 %endif
697
698 %files cvs
699 %defattr(644,root,root,755)
700 %attr(755,root,root) %{_bindir}/git-cvsserver
701 %attr(755,root,root) %{_libdir}/%{name}/git-cvs*
702 %if %{with doc}
703 %{_mandir}/man1/git-cvs*.1*
704 %{_mandir}/man7/gitcvs-migration.7*
705 %endif
706
707 %files arch
708 %defattr(644,root,root,755)
709 %attr(755,root,root) %{_libdir}/%{name}/git-archimport
710 %if %{with doc}
711 %{_mandir}/man1/git-archimport.1*
712 %endif
713
714 %files email
715 %defattr(644,root,root,755)
716 %attr(755,root,root) %{_libdir}/%{name}/git-imap-send
717 %attr(755,root,root) %{_libdir}/%{name}/*email*
718 %if %{with doc}
719 %{_mandir}/man1/*email*.1*
720 %{_mandir}/man1/*imap-send*.1*
721 %endif
722
723 %files -n bash-completion-git
724 %defattr(644,root,root,755)
725 %{bash_compdir}/git
726
727 %files -n perl-Git
728 %defattr(644,root,root,755)
729 %{perl_vendorlib}/Git.pm
730 %dir %{perl_vendorlib}/Git
731 %{perl_vendorlib}/Git/I18N.pm
732 %{perl_vendorlib}/Git/IndexInfo.pm
733 %{_mandir}/man3/Git*.3pm*
734
735 %files -n python-Git
736 %defattr(644,root,root,755)
737 %dir %{py_sitescriptdir}/git_remote_helpers
738 %{py_sitescriptdir}/git_remote_helpers/*.py[co]
739 %dir %{py_sitescriptdir}/git_remote_helpers/git
740 %{py_sitescriptdir}/git_remote_helpers/git/*.py[co]
741 %if "%{py_ver}" > "2.4"
742 %{py_sitescriptdir}/git_remote_helpers*.egg-info
743 %endif
744 %if %{with doc}
745 %{_mandir}/man1/gitremote-helpers.1*
746 %endif
747
748 %files -n vim-syntax-gitcommit
749 %defattr(644,root,root,755)
750 %doc contrib/vim/README
751 %{_datadir}/vim/vimfiles/syntax/gitcommit.vim
This page took 0.119604 seconds and 4 git commands to generate.