]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
package sample gitolite3 gitweb.conf
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform make test
4 %bcond_with     tests_cvs       # perform tests which use CVS
5 %bcond_without  tests_svn       # perform tests which use subversion
6 %bcond_without  doc             # skip building/packaging docs/manuals (takes some time)
7 %bcond_without  pcre            # perl-compatible regexes support
8
9 %include        /usr/lib/rpm/macros.perl
10 Summary:        Distributed version control system focused on speed, effectivity and usability
11 Summary(pl.UTF-8):      Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
12 Name:           git-core
13 Version:        1.8.5.3
14 Release:        3
15 License:        GPL v2
16 Group:          Development/Tools
17 Source0:        http://git-core.googlecode.com/files/git-%{version}.tar.gz
18 # Source0-md5:  57b966065882f83ef5879620a1e329ca
19 Source1:        %{name}-gitweb.conf
20 Source2:        %{name}-gitweb-httpd.conf
21 Source3:        %{name}-gitweb-lighttpd.conf
22 Source4:        %{name}.sysconfig
23 Source5:        %{name}.inet
24 Source6:        %{name}.init
25 Source7:        gitolite.pl
26 Patch0:         %{name}-tests.patch
27 Patch1:         %{name}-key-bindings.patch
28 Patch2:         %{name}-sysconfdir.patch
29 Patch3:         cherry-picked-commitlog.patch
30 Patch4:         %{name}-svn-exit-errors.patch
31 URL:            http://git-scm.com/
32 BuildRequires:  autoconf >= 2.59
33 BuildRequires:  automake
34 BuildRequires:  curl-devel
35 BuildRequires:  expat-devel
36 BuildRequires:  gettext-devel
37 BuildRequires:  openssl-devel
38 %{?with_pcre:BuildRequires:     pcre-devel}
39 BuildRequires:  perl-Error > 0.15
40 BuildRequires:  perl-base
41 BuildRequires:  python-devel
42 BuildRequires:  rpm-perlprov >= 4.1-13
43 BuildRequires:  rpm-pythonprov
44 BuildRequires:  rpmbuild(macros) >= 1.264
45 BuildRequires:  tcl
46 BuildRequires:  zlib-devel
47 %if %{with doc}
48 BuildRequires:  asciidoc >= 7.1.2-3
49 BuildRequires:  docbook-dtd45-xml
50 BuildRequires:  xmlto
51 %endif
52 %if %{with tests}
53 %if %{with tests_cvs}
54 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
55 BuildRequires:  cvs-gnu-client < 1.13
56 BuildRequires:  cvs-gnu-client >= 1.12
57 %endif
58 %{?with_tests_svn:BuildRequires:  subversion}
59 Conflicts:      pdksh < 5.2.14-46
60 %endif
61 Requires:       coreutils
62 Requires:       diffutils
63 Requires:       findutils
64 Requires:       grep
65 Requires:       openssh-clients
66 Requires:       perl-Error
67 Requires:       perl-Git = %{version}-%{release}
68 Requires:       sed
69 Suggests:       git-core-bzr
70 Suggests:       git-core-cvs
71 Suggests:       git-core-hg
72 Suggests:       git-core-p4
73 Suggests:       git-core-svn
74 Suggests:       less
75 Suggests:       rsync
76 Obsoletes:      python-Git
77 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
78
79 # html docs have links to txt files
80 %define         _noautocompressdoc      *.txt
81
82 %define         webapp          gitweb
83 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
84 %define         appdir          %{_datadir}/%{webapp}
85 %define         cgibindir       %{_prefix}/lib/cgi-bin
86 %define         bash_compdir    %{_datadir}/bash-completion/completions
87
88 %description
89 "git" can mean anything, depending on your mood.
90
91 - random three-letter combination that is pronounceable, and not
92   actually used by any common UNIX command. The fact that it is a
93   mispronunciation of "get" may or may not be relevant.
94 - stupid. contemptible and despicable. simple. Take your pick from the
95   dictionary of slang.
96 - "global information tracker": you're in a good mood, and it actually
97   works for you. Angels sing, and a light suddenly fills the room.
98 - "goddamn idiotic truckload of sh*t": when it breaks
99
100 This is a stupid (but extremely fast) directory content manager. It
101 doesn't do a whole lot, but what it 'does' do is track directory
102 contents efficiently.
103
104 %description -l pl.UTF-8
105 "git" może oznaczać cokolwiek, w zależności od nastroju.
106
107 - losową kombinację trzech liter, która jest wymawialna i właściwie
108   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
109   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
110 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
111 - "global information tracker" (narzędzie do globalnego śledzenia
112   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
113   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
114 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
115   g*) - kiedy się zepsuje.
116
117 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
118 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
119 katalogu.
120
121 %package doc
122 Summary:        Documentation for git-core
123 Summary(pl.UTF-8):      Dokumentacja do git-core
124 Group:          Documentation
125
126 %description doc
127 Documentation for git-core.
128
129 %description doc -l pl.UTF-8
130 Dokumentacja do git-core.
131
132 %description doc -l fr.UTF-8
133 Javadoc pour git-core.
134
135 %package daemon-inetd
136 Summary:        Files necessary to run git-daemon as an inetd service
137 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
138 Group:          Networking/Daemons
139 Requires:       %{name} = %{version}-%{release}
140 Requires:       setup >= 2.4.11-1
141 Provides:       git-core-daemon
142 Obsoletes:      git-core-daemon
143 Obsoletes:      git-core-daemon-standalone
144
145 %description daemon-inetd
146 Git-daemon is a really simple TCP git daemon that can serve git
147 repositories. This package provides all necessarry files to run
148 git-daemon as an inetd service.
149
150 %description daemon-inetd -l pl.UTF-8
151 Git-daemon to prosty demon git korzystający z protokołu TCP do
152 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
153 do uruchomienia git-demona w trybie usługi inetd.
154
155 %package daemon-standalone
156 Summary:        Files necessary to run git-daemon as a standalone service
157 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
158 Group:          Networking/Daemons
159 Requires:       %{name} = %{version}-%{release}
160 Provides:       git-core-daemon
161 Obsoletes:      git-core-daemon
162 Obsoletes:      git-core-daemon-inetd
163
164 %description daemon-standalone
165 Git-daemon is a really simple TCP git daemon that can serve git
166 repositories. This package provides all necessarry files to run
167 git-daemon as an standalone service.
168
169 %description daemon-standalone -l pl.UTF-8
170 Git-daemon to prosty demon git korzystający z protokołu TCP do
171 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
172 do uruchomienia git-daemona w trybie usługi samodzielnej.
173
174 %package devel
175 Summary:        Git library with header files
176 Summary(pl.UTF-8):      Biblioteka Gita oraz pliki nagłówkowe
177 Group:          Development/Libraries
178 Requires:       zlib-devel
179
180 %description devel
181 Git library with header files.
182
183 %description devel -l pl.UTF-8
184 Biblioteka Gita oraz pliki nagłówkowe.
185
186 %package gitk
187 Summary:        Tcl/Tk interface to the Git version control system
188 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
189 Group:          Development/Tools
190 Requires:       %{name} = %{version}-%{release}
191 Requires:       tk
192
193 %description gitk
194 gitk displays changes in a repository or a selected set of commits.
195 This includes visualizing the commit graph, showing information
196 related to each commit, and the files in the trees of each revision.
197
198 Historically, gitk was the first repository browser. It's written in
199 Tcl/Tk and started off in a separate repository but was later merged
200 into the main git repository.
201
202 %description gitk -l pl.UTF-8
203 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
204 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
205 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
206
207 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
208 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
209 osobnym repozytorium, ale z czasem został włączony do głównego
210 repozytorium gita.
211
212 %package gitweb
213 Summary:        Web frontend to git
214 Summary(pl.UTF-8):      Frontend WWW do gita
215 Group:          Development/Tools
216 Requires:       %{name} = %{version}-%{release}
217 Requires:       webapps
218 Requires:       webserver(access)
219 Requires:       webserver(alias)
220 Requires:       webserver(cgi)
221 Suggests:       webserver(setenv)
222
223 %description gitweb
224 This package provides a web interface for browsing git repositories.
225
226 %description gitweb -l pl.UTF-8
227 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
228
229 %package gitview
230 Summary:        A GTK+ based repository browser for git
231 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
232 Group:          Development/Tools
233 Requires:       %{name} = %{version}-%{release}
234 Requires:       python >= 1:2.4
235 Requires:       python-pycairo >= 1.0
236 Requires:       python-pygobject
237 Requires:       python-pygtk-gtk >= 2:2.8
238 Suggests:       python-gnome-desktop-gtksourceview
239
240 %description gitview
241 A GTK+ based repository browser for git.
242
243 %description gitview -l pl.UTF-8
244 Oparta na GTK+ przeglądarka repozytorium gita.
245
246 %package gui
247 Summary:        Tcl/Tk interface to the Git version control system
248 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
249 Group:          Development/Tools
250 Requires:       %{name} = %{version}-%{release}
251 Requires:       tk
252 Requires:       xdg-utils
253 Suggests:       meld
254
255 %description gui
256 Displays changes in a repository or a selected set of commits. This
257 includes visualizing the commit graph, showing information related to
258 each commit, and the files in the trees of each revision.
259
260 Historically, gitk was the first repository browser. It's written in
261 Tcl/Tk and started off in a separate repository but was later merged
262 into the main git repository.
263
264 %description gui -l pl.UTF-8
265 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
266 to wizualizację grafu commitów, wyświetlanie informacji związanych z
267 każdym z commitów oraz listę plików dla każdej rewizji.
268
269 Z punktu widzenia historii, gitk był pierwszą przeglądarką
270 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
271 osobnym repozytorium, ale z czasem został włączony do głównego
272 repozytorium gita.
273
274 %package arch
275 Summary:        Git tools for importing Arch repositories
276 Summary(pl.UTF-8):      Narzędzia Gita do importowania repozytoriów Archa
277 Group:          Development/Tools
278 Requires:       %{name} = %{version}-%{release}
279 Requires:       tla
280
281 %description arch
282 Git tools for importing Arch repositories.
283
284 %description arch -l pl.UTF-8
285 Narzędzia Gita do importowania repozytoriów Archa.
286
287 %package bzr
288 Summary:        Git tools for working with bzr repositories
289 Summary(pl.UTF-8):      Narzędzia Gita do pracy z repozytoriami bzr
290 Group:          Development/Tools
291 Requires:       %{name} = %{version}-%{release}
292 Requires:       bzr
293
294 %description bzr
295 Git tools for working with bzr repositories.
296
297 %description bzr -l pl.UTF-8
298 Narzędzia Gita do pracy z repozytoriami bzr.
299
300 %package cvs
301 Summary:        CVS support for Git
302 Summary(pl.UTF-8):      Obsługa CVS dla Gita
303 Group:          Development/Tools
304 Requires:       %{name} = %{version}-%{release}
305 Requires:       cvsps >= 2.1-2
306 Requires:       rcs
307
308 %description cvs
309 CVS support for Git.
310
311 %description cvs -l pl.UTF-8
312 Obsługa CVS dla Gita.
313
314 %package hg
315 Summary:        Git tools for working with mercurial repositories
316 Summary(pl.UTF-8):      Narzędzia Gita do pracy z repozytoriami mercuriala
317 Group:          Development/Tools
318 Requires:       %{name} = %{version}-%{release}
319 Requires:       mercurial >= 1.8
320
321 %description hg
322 Git tools for working with mercurial repositories.
323
324 %description hg -l pl.UTF-8
325 Narzędzia Gita do pracy z repozytoriami mercuriala.
326
327 %package p4
328 Summary:        Git tools for working with Perforce depots
329 Summary(pl.UTF-8):      Narzędzia Gita do pracy z magazynami Perforce'a
330 Group:          Development/Tools
331 Requires:       %{name} = %{version}-%{release}
332
333 %description p4
334 Git tools for working with Perforce depots.
335
336 %description p4 -l pl.UTF-8
337 Narzędzia Gita do pracy z magazynami Perforce'a.
338
339 %package svn
340 Summary:        Subversion support for Git
341 Summary(pl.UTF-8):      Obsługa Subversion dla Gita
342 Group:          Development/Tools
343 Requires:       %{name} = %{version}-%{release}
344 Requires:       perl-Encode
345 Requires:       perl-Term-ReadKey
346
347 %description svn
348 Subversion support for Git.
349
350 %description svn -l pl.UTF-8
351 Obsługa Subversion dla Gita.
352
353 %package email
354 Summary:        Git tools for sending email
355 Summary(pl.UTF-8):      Narzędzia Gita do wysyłania poczty
356 Group:          Development/Tools
357 Requires:       %{name} = %{version}-%{release}
358
359 %description email
360 Git tools for sending email.
361
362 %description email -l pl.UTF-8
363 Narzędzia Gita do wysyłania poczty.
364
365 %package -n bash-completion-git
366 Summary:        bash-completion for git
367 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
368 Group:          Applications/Shells
369 Requires:       %{name} = %{version}-%{release}
370 Requires:       bash-completion >= 2.0
371
372 %description -n bash-completion-git
373 This package provides bash-completion for git.
374
375 %description -n bash-completion-git -l pl.UTF-8
376 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
377
378 %package -n perl-Git
379 Summary:        Perl interface to the Git version control system
380 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
381 Group:          Development/Languages/Perl
382 Obsoletes:      perl-git-core
383
384 %description -n perl-Git
385 This module provides Perl scripts easy way to interface the Git
386 version control system. The modules have an easy and well-tested way
387 to call arbitrary Git commands; in the future, the interface will also
388 provide specialized methods for doing easily operations which are not
389 totally trivial to do over the generic command interface.
390
391 %description -n perl-Git -l pl.UTF-8
392 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
393 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
394 dowolne polecenia Gita; w przyszłości interfejs udostępni także
395 specjalne metody do łatwego wykonywania operacji nietrywialnych do
396 wykonania przy użyciu ogólnego interfejsu poleceń.
397
398 %package -n vim-syntax-gitcommit
399 Summary:        Vim syntax: gitcommit
400 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
401 Group:          Applications/Editors/Vim
402 Requires:       %{name} = %{version}-%{release}
403 # for _vimdatadir existence
404 Requires:       vim-rt >= 4:6.3.058-3
405
406 %description -n vim-syntax-gitcommit
407 This plugin provides syntax highlighting for git's commit messages.
408
409 %description -n vim-syntax-gitcommit -l pl.UTF-8
410 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
411
412 %prep
413 %setup -q -n git-%{version}
414 %patch0 -p1
415 %patch1 -p0
416 %patch2 -p1
417 %patch3 -p1
418 %patch4 -p1
419
420 %build
421 %{__aclocal}
422 %{__autoconf}
423 %configure \
424         --sysconfdir=%{_sysconfdir}/git-core \
425         %{?with_pcre:--with-libpcre} \
426         --with-openssl
427
428 echo "BLK_SHA1=1" >> config.mak
429
430 %{__make} \
431         INSTALLDIRS=vendor \
432         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
433         GITWEB_PROJECTROOT="/var/lib/git" \
434         GITWEB_CSS="/gitweb/gitweb.css" \
435         GITWEB_LOGO="/gitweb/git-logo.png" \
436         GITWEB_FAVICON="/gitweb/git-favicon.png" \
437         V=1
438
439 %if %{with doc}
440 %{__make} -C Documentation \
441         MAN_BASE_URL=file://%{_docdir}/%{name}-doc-%{version}/ \
442         V=1
443 %endif
444
445 %if %{with tests}
446 %if %{without tests_cvs}
447 %{__rm} t/t*cvs*.sh || :
448 %endif
449 %{!?with_tests_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
450 %endif
451
452 %install
453 rm -rf $RPM_BUILD_ROOT
454 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
455 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
456 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
457 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
458 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
459 [init]
460         templatedir = %{_sysconfdir}/%{name}/templates
461 EOF
462
463 %{__make} install \
464         INSTALLDIRS=vendor \
465         DESTDIR=$RPM_BUILD_ROOT
466
467 %if %{with doc}
468 %{__make} -C Documentation install \
469         DESTDIR=$RPM_BUILD_ROOT
470 %endif
471
472 # copy templates except sample hooks
473 cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
474 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
475
476 # header files and lib
477 cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
478 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
479 cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
480 install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
481 cp -p block-sha1/sha1.h $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
482 cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
483 cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
484 cp -p {Makefile,config.mak,config.mak.autogen,config.mak.uname} $RPM_BUILD_ROOT%{_includedir}/%{name}
485
486 # bash completion
487 install -d $RPM_BUILD_ROOT%{bash_compdir}
488 cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{bash_compdir}/git
489
490 # Install bzr and hg remote helpers from contrib
491 install -p contrib/remote-helpers/git-remote-{bzr,hg} $RPM_BUILD_ROOT%{_libdir}/%{name}
492
493 # vim syntax
494 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
495 cat > $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax/gitcommit.vim << 'EOF'
496 autocmd BufNewFile,BufRead *.git/COMMIT_EDITMSG    setf gitcommit
497 autocmd BufNewFile,BufRead *.git/config,.gitconfig setf gitconfig
498 autocmd BufNewFile,BufRead git-rebase-todo         setf gitrebase
499 autocmd BufNewFile,BufRead .msg.[0-9]*
500         \ if getline(1) =~ '^From.*# This line is ignored.$' |
501         \   setf gitsendemail |
502         \ endif
503 autocmd BufNewFile,BufRead *.git/**
504         \ if getline(1) =~ '^\x\{40\}\>\|^ref: ' |
505         \   setf git |
506         \ endif
507 EOF
508
509 # gitweb
510 mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
511 ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
512 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
513 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{webappdir}/gitolite.pl
514 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
515 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
516 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
517
518 # gitview
519 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
520
521 # git-daemon related files
522 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
523 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
524 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
525
526 # paths cleanup
527 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
528 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
529
530 # hardlink
531 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
532 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
533 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
534 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
535
536 # remove unneeded files
537 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
538 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
539 %py_postclean
540
541 mv $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
542 %find_lang git
543
544 %clean
545 rm -rf $RPM_BUILD_ROOT
546
547 %post daemon-inetd
548 %service -q rc-inetd reload
549
550 %postun daemon-inetd
551 if [ "$1" = "0" ]; then
552         %service -q rc-inetd reload
553 fi
554
555 %post daemon-standalone
556 /sbin/chkconfig --add git-daemon
557 %service git-daemon restart "git-daemon"
558
559 %preun daemon-standalone
560 if [ "$1" = "0" ]; then
561         %service git-daemon stop
562         /sbin/chkconfig --del git-daemon
563 fi
564
565 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
566 %webapp_register apache %{webapp}
567
568 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
569 %webapp_unregister apache %{webapp}
570
571 %triggerin gitweb -- apache < 2.2.0, apache-base
572 %webapp_register httpd %{webapp}
573
574 %triggerun gitweb -- apache < 2.2.0, apache-base
575 %webapp_unregister httpd %{webapp}
576
577 %triggerin gitweb -- lighttpd
578 %webapp_register lighttpd %{webapp}
579
580 %triggerun gitweb -- lighttpd
581 %webapp_unregister lighttpd %{webapp}
582
583 %files -f git.lang
584 %defattr(644,root,root,755)
585 %doc README contrib
586 %attr(755,root,root) %{_bindir}/git
587 %attr(755,root,root) %{_bindir}/git-receive-pack
588 %attr(755,root,root) %{_bindir}/git-shell
589 %attr(755,root,root) %{_bindir}/git-upload-archive
590 %attr(755,root,root) %{_bindir}/git-upload-pack
591 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
592
593 %if %{with doc}
594 %{_mandir}/man1/git-*.1*
595 %exclude %{_mandir}/man1/git-archimport.1*
596 %exclude %{_mandir}/man1/git-svn.1*
597 %exclude %{_mandir}/man1/git-cvs*.1*
598 %exclude %{_mandir}/man1/git-imap-send*.1*
599 %exclude %{_mandir}/man1/*email*.1*
600 %{_mandir}/man1/git.1*
601 %{_mandir}/man1/gitremote-helpers.1*
602 %{_mandir}/man5/gitattributes.5*
603 %{_mandir}/man5/githooks.5*
604 %{_mandir}/man5/gitignore.5*
605 %{_mandir}/man5/gitmodules.5*
606 %{_mandir}/man5/gitrepository-layout.5*
607 %{_mandir}/man7/gitcli.7*
608 %{_mandir}/man7/gitcore-tutorial.7*
609 %{_mandir}/man7/gitcredentials.7*
610 %{_mandir}/man7/gitdiffcore.7*
611 %{_mandir}/man7/gitglossary.7*
612 %{_mandir}/man7/gitnamespaces.7*
613 %{_mandir}/man7/gitrevisions.7*
614 %{_mandir}/man7/gittutorial-2.7*
615 %{_mandir}/man7/gittutorial.7*
616 %{_mandir}/man7/gitworkflows.7*
617 %endif
618
619 %dir %{_libdir}/%{name}
620 %attr(755,root,root) %{_libdir}/%{name}/*-*
621 %attr(755,root,root) %{_libdir}/%{name}/git
622 %dir %{_libdir}/%{name}/mergetools
623 %{_libdir}/%{name}/mergetools/*
624
625 %{_datadir}/%{name}
626 %{_localstatedir}/lib/git
627
628 # subpackages
629 %exclude %{_libdir}/%{name}/*email*
630 %exclude %{_libdir}/%{name}/*p4*
631 %exclude %{_libdir}/%{name}/git-archimport
632 %exclude %{_libdir}/%{name}/git-cvs*
633 %exclude %{_libdir}/%{name}/git-gui
634 %exclude %{_libdir}/%{name}/git-imap-send
635 %exclude %{_libdir}/%{name}/git-instaweb
636 %exclude %{_libdir}/%{name}/git-remote-bzr
637 %exclude %{_libdir}/%{name}/git-remote-hg
638 %exclude %{_libdir}/%{name}/git-remote-testsvn
639 %exclude %{_libdir}/%{name}/git-svn
640 %exclude %{_libdir}/%{name}/mergetools/p4merge
641
642 %if %{with doc}
643 %files doc
644 %defattr(644,root,root,755)
645 %doc Documentation/RelNotes*
646 %doc Documentation/*.html Documentation/howto Documentation/technical
647 %endif
648
649 %files daemon-inetd
650 %defattr(644,root,root,755)
651 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
652
653 %files daemon-standalone
654 %defattr(644,root,root,755)
655 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
656 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
657
658 %files devel
659 %defattr(644,root,root,755)
660 %{_includedir}/%{name}
661 %{_libdir}/libgit.a
662 %{_libdir}/libgit_xdiff.a
663
664 %files gitk
665 %defattr(644,root,root,755)
666 %if %{with doc}
667 %{_mandir}/man1/gitk.1*
668 %endif
669 %attr(755,root,root) %{_bindir}/gitk
670 %dir %{_datadir}/gitk
671 %dir %{_datadir}/gitk/lib
672 %dir %{_datadir}/gitk/lib/msgs
673 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
674 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
675 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
676 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
677 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
678 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
679 %lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
680 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
681 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
682
683 %files gitweb
684 %defattr(644,root,root,755)
685 %doc gitweb/{README,INSTALL}
686 %dir %{webappdir}
687 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
688 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
689 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
690 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
691 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/gitolite.pl
692 %attr(755,root,root) %{cgibindir}/gitweb.cgi
693 %{appdir}
694 %attr(755,root,root) %{_libdir}/%{name}/git-instaweb
695 %if %{with doc}
696 %{_mandir}/man1/gitweb.1*
697 %{_mandir}/man5/gitweb.conf.5*
698 %endif
699
700 %files gitview
701 %defattr(644,root,root,755)
702 %doc contrib/gitview/gitview.txt
703 %attr(755,root,root) %{_bindir}/gitview
704
705 %files gui
706 %defattr(644,root,root,755)
707 %attr(755,root,root) %{_libdir}/%{name}/git-gui
708 %dir %{_datadir}/git-gui
709 %dir %{_datadir}/git-gui/lib
710 %dir %{_datadir}/git-gui/lib/msgs
711 %{_datadir}/git-gui/lib/git-gui.ico
712 %{_datadir}/git-gui/lib/tclIndex
713 %{_datadir}/git-gui/lib/*.js
714 %{_datadir}/git-gui/lib/*.tcl
715 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
716 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
717 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
718 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
719 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
720 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
721 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
722 %lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
723 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
724 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
725 %lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
726
727 %files arch
728 %defattr(644,root,root,755)
729 %attr(755,root,root) %{_libdir}/%{name}/git-archimport
730 %if %{with doc}
731 %{_mandir}/man1/git-archimport.1*
732 %endif
733
734 %files bzr
735 %defattr(644,root,root,755)
736 %attr(755,root,root) %{_libdir}/%{name}/git-remote-bzr
737
738 %files cvs
739 %defattr(644,root,root,755)
740 %attr(755,root,root) %{_bindir}/git-cvsserver
741 %attr(755,root,root) %{_libdir}/%{name}/git-cvs*
742 %if %{with doc}
743 %{_mandir}/man1/git-cvs*.1*
744 %{_mandir}/man7/gitcvs-migration.7*
745 %endif
746
747 %files hg
748 %defattr(644,root,root,755)
749 %attr(755,root,root) %{_libdir}/%{name}/git-remote-hg
750
751 %files p4
752 %defattr(644,root,root,755)
753 %attr(755,root,root) %{_libdir}/%{name}/git-p4
754 %attr(755,root,root) %{_libdir}/%{name}/mergetools/p4merge
755
756 %files svn
757 %defattr(644,root,root,755)
758 %attr(755,root,root) %{_libdir}/%{name}/git-svn
759 %attr(755,root,root) %{_libdir}/%{name}/git-remote-testsvn
760 %{perl_vendorlib}/Git/SVN
761 %{perl_vendorlib}/Git/SVN.pm
762 %if %{with doc}
763 %{_mandir}/man1/git-svn.1*
764 %endif
765
766 %files email
767 %defattr(644,root,root,755)
768 %attr(755,root,root) %{_libdir}/%{name}/git-imap-send
769 %attr(755,root,root) %{_libdir}/%{name}/*email*
770 %if %{with doc}
771 %{_mandir}/man1/*email*.1*
772 %{_mandir}/man1/*imap-send*.1*
773 %endif
774
775 %files -n bash-completion-git
776 %defattr(644,root,root,755)
777 %{bash_compdir}/git
778
779 %files -n perl-Git
780 %defattr(644,root,root,755)
781 %{perl_vendorlib}/Git.pm
782 %dir %{perl_vendorlib}/Git
783 %{perl_vendorlib}/Git/I18N.pm
784 %{perl_vendorlib}/Git/IndexInfo.pm
785 %{_mandir}/man3/Git*.3pm*
786
787 %files -n vim-syntax-gitcommit
788 %defattr(644,root,root,755)
789 %doc contrib/vim/README
790 %{_datadir}/vim/vimfiles/syntax/gitcommit.vim
This page took 0.115292 seconds and 4 git commands to generate.