]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
R: rcs for merge binary
[packages/git-core.git] / git-core.spec
1 # TODO:
2 # - gitweb subpackage
3 %include        /usr/lib/rpm/macros.perl
4 Summary:        The stupid content tracker
5 Summary(pl):    Prymitywne narzêdzie do ¶ledzenia tre¶ci
6 Name:           git-core
7 Version:        1.4.4.2
8 Release:        1
9 License:        GPL v2
10 Group:          Development/Tools
11 Source0:        http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
12 # Source0-md5:  c4f72d96f62ae97c6e8d5cdb4afd55ca
13 URL:            http://git.or.cz/
14 BuildRequires:  asciidoc
15 BuildRequires:  curl-devel
16 BuildRequires:  expat-devel
17 BuildRequires:  openssl-devel
18 BuildRequires:  perl-Error
19 BuildRequires:  perl-base
20 BuildRequires:  python
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRequires:  xmlto
23 BuildRequires:  zlib-devel
24 Requires:       coreutils
25 Requires:       findutils
26 Requires:       grep
27 Requires:       rcs
28 Requires:       sed
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 "git" can mean anything, depending on your mood.
33
34  - random three-letter combination that is pronounceable, and not
35    actually used by any common UNIX command. The fact that it is a
36    mispronunciation of "get" may or may not be relevant.
37  - stupid. contemptible and despicable. simple. Take your pick from the
38    dictionary of slang.
39  - "global information tracker": you're in a good mood, and it actually
40    works for you. Angels sing, and a light suddenly fills the room.
41  - "goddamn idiotic truckload of sh*t": when it breaks
42
43 This is a stupid (but extremely fast) directory content manager. It
44 doesn't do a whole lot, but what it 'does' do is track directory
45 contents efficiently.
46
47 %description -l pl
48 "git" mo¿e oznaczaæ cokolwiek, w zale¿no¶ci od nastroju.
49
50 - losow± kombinacjê trzech liter, która jest wymawialna i w³a¶ciwie
51   nie u¿ywana przez ¿adne popularne polecenie uniksowe. Fakt, ¿e jest to
52   b³êdna pisownia s³owa "get" mo¿e mieæ lub nie mieæ znaczenia.
53 - g³upi, pogardliwy, prosty. Mo¿na wybraæ ze s³ownika slangu.
54 - "global information tracker" (narzêdzie do globalnego ¶ledzenia
55   informacji) - je¶li jeste¶my w dobrym nastroju i git akurat dzia³a.
56   Anio³y ¶piewaj±, a ¶wiat³o niespodziewanie wype³nia pokój.
57 - "goddamn idiotic truckload of sh*t" (przeklêty idiotyczny ³adunek
58   g*) - kiedy siê zepsuje.
59
60 Jest to prymitywny (ale bardzo szybki) zarz±dca tre¶ci s³ownikowej.
61 Nie robi wiele, ale to, co "robi", to wydajne ¶ledzenie zawarto¶ci
62 katalogu.
63
64 %package devel
65 Summary:        Header files for git-core
66 Summary(pl):    Pliki nag³ówkowe dla git-core
67 Group:          Development/Libraries
68
69 %description devel
70 Header files for git-core.
71
72 %description devel
73 Pliki nag³ówkowe dla git-core.
74
75 %package -n perl-Git
76 Summary:        Perl interface to the Git version control system
77 Summary(pl):    Perlowy interfejs do systemu kontroli wersji Git
78 Group:          Development/Languages/Perl
79 Requires:       %{name} = %{version}-%{release}
80 Obsoletes:      perl-git-core
81
82 %description -n perl-Git
83 This module provides Perl scripts easy way to interface the Git
84 version control system. The modules have an easy and well-tested way
85 to call arbitrary Git commands; in the future, the interface will also
86 provide specialized methods for doing easily operations which are not
87 totally trivial to do over the generic command interface.
88
89 %description -n perl-Git -l pl
90 Ten modu³ umo¿liwia skryptom Perla wspó³pracê z systemem kontroli
91 wersji Git. W ³atwy i dobrze przetestowany sposób pozwala wywo³ywaæ
92 dowolne polecenia Gita; w przysz³o¶ci interfejs udostêpni tak¿e
93 specjalne metody do ³atwego wykonywania operacji nietrywialnych do
94 wykonania przy u¿yciu ogólnego interfejsu poleceñ.
95
96 %prep
97 %setup -q -n git-%{version}
98
99 %build
100 %{__make} \
101         prefix=%{_prefix} \
102         CC="%{__cc}" \
103         CFLAGS="%{rpmcflags}" \
104         LDFLAGS="%{rpmldflags}"
105
106 # once again to get perl paths stright
107 cd perl
108 %{__perl} Makefile.PL \
109         INSTALLDIRS=vendor
110 %{__make}
111 cd ..
112
113 %{__make} -C Documentation
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117 install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
118
119 %{__make} install \
120         prefix=%{_prefix} \
121         CFLAGS="%{rpmcflags}" \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 %{__make} -C Documentation install \
125         prefix=%{_prefix} \
126         mandir=%{_mandir} \
127         DESTDIR=$RPM_BUILD_ROOT
128
129 install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
130 install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
131
132 rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
133 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 %files
139 %defattr(644,root,root,755)
140 %doc README Documentation/*.html Documentation/howto Documentation/technical
141 %attr(755,root,root) %{_bindir}/*
142 %{_mandir}/man*/*
143 %dir %{_datadir}/%{name}
144 %{_datadir}/%{name}/*
145
146 %files devel
147 %defattr(644,root,root,755)
148 %{_includedir}/*
149
150 %files -n perl-Git
151 %defattr(644,root,root,755)
152 %{perl_vendorlib}/Git.pm
153 %{_mandir}/man3/*
This page took 0.048107 seconds and 4 git commands to generate.