]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
apply svn-exit-errors.patch
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform make test
4 %bcond_with     tests_cvs       # perform tests which use CVS
5 %bcond_without  tests_svn       # perform tests which use subversion
6 %bcond_without  doc             # skip building/packaging docs/manuals (takes some time)
7 %bcond_without  pcre            # perl-compatible regexes support
8
9 %include        /usr/lib/rpm/macros.perl
10 Summary:        Distributed version control system focused on speed, effectivity and usability
11 Summary(pl.UTF-8):      Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
12 Name:           git-core
13 Version:        1.8.4
14 Release:        2
15 License:        GPL v2
16 Group:          Development/Tools
17 Source0:        http://git-core.googlecode.com/files/git-%{version}.tar.gz
18 # Source0-md5:  355768a1c70d0cb4fedf4b598ac1375b
19 Source1:        %{name}-gitweb.conf
20 Source2:        %{name}-gitweb-httpd.conf
21 Source3:        %{name}-gitweb-lighttpd.conf
22 Source4:        %{name}.sysconfig
23 Source5:        %{name}.inet
24 Source6:        %{name}.init
25 Patch0:         %{name}-tests.patch
26 Patch1:         %{name}-key-bindings.patch
27 Patch2:         %{name}-sysconfdir.patch
28 Patch3:         cherry-picked-commitlog.patch
29 Patch4:         %{name}-svn-serf.patch
30 Patch5:         %{name}-svn-exit-errors.patch
31 URL:            http://git-scm.com/
32 BuildRequires:  autoconf >= 2.59
33 BuildRequires:  automake
34 BuildRequires:  curl-devel
35 BuildRequires:  expat-devel
36 BuildRequires:  gettext-devel
37 BuildRequires:  openssl-devel
38 %{?with_pcre:BuildRequires:     pcre-devel}
39 BuildRequires:  perl-Error > 0.15
40 BuildRequires:  perl-base
41 BuildRequires:  python-devel
42 BuildRequires:  rpm-perlprov >= 4.1-13
43 BuildRequires:  rpm-pythonprov
44 BuildRequires:  rpmbuild(macros) >= 1.264
45 BuildRequires:  tcl
46 BuildRequires:  zlib-devel
47 %if %{with doc}
48 BuildRequires:  asciidoc >= 7.1.2-3
49 BuildRequires:  docbook-dtd45-xml
50 BuildRequires:  xmlto
51 %endif
52 %if %{with tests}
53 %if %{with tests_cvs}
54 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
55 BuildRequires:  cvs-gnu-client < 1.13
56 BuildRequires:  cvs-gnu-client >= 1.12
57 %endif
58 %{?with_tests_svn:BuildRequires:  subversion}
59 Conflicts:      pdksh < 5.2.14-46
60 %endif
61 Requires:       coreutils
62 Requires:       diffutils
63 Requires:       findutils
64 Requires:       grep
65 Requires:       openssh-clients
66 Requires:       perl-Error
67 Requires:       perl-Git = %{version}-%{release}
68 Requires:       sed
69 Suggests:       git-core-cvs
70 Suggests:       git-core-svn
71 Suggests:       less
72 Suggests:       rsync
73 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75 # html docs have links to txt files
76 %define         _noautocompressdoc      *.txt
77
78 %define         webapp          gitweb
79 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
80 %define         appdir          %{_datadir}/%{webapp}
81 %define         cgibindir       %{_prefix}/lib/cgi-bin
82 %define         bash_compdir    %{_datadir}/bash-completion/completions
83
84 %description
85 "git" can mean anything, depending on your mood.
86
87 - random three-letter combination that is pronounceable, and not
88   actually used by any common UNIX command. The fact that it is a
89   mispronunciation of "get" may or may not be relevant.
90 - stupid. contemptible and despicable. simple. Take your pick from the
91   dictionary of slang.
92 - "global information tracker": you're in a good mood, and it actually
93   works for you. Angels sing, and a light suddenly fills the room.
94 - "goddamn idiotic truckload of sh*t": when it breaks
95
96 This is a stupid (but extremely fast) directory content manager. It
97 doesn't do a whole lot, but what it 'does' do is track directory
98 contents efficiently.
99
100 %description -l pl.UTF-8
101 "git" może oznaczać cokolwiek, w zależności od nastroju.
102
103 - losową kombinację trzech liter, która jest wymawialna i właściwie
104   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
105   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
106 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
107 - "global information tracker" (narzędzie do globalnego śledzenia
108   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
109   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
110 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
111   g*) - kiedy się zepsuje.
112
113 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
114 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
115 katalogu.
116
117 %package doc
118 Summary:        Documentation for git-core
119 Summary(pl.UTF-8):      Dokumentacja do git-core
120 Group:          Documentation
121
122 %description doc
123 Documentation for git-core.
124
125 %description doc -l pl.UTF-8
126 Dokumentacja do git-core.
127
128 %description doc -l fr.UTF-8
129 Javadoc pour git-core.
130
131 %package daemon-inetd
132 Summary:        Files necessary to run git-daemon as an inetd service
133 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
134 Group:          Networking/Daemons
135 Requires:       %{name} = %{version}-%{release}
136 Requires:       setup >= 2.4.11-1
137 Provides:       git-core-daemon
138 Obsoletes:      git-core-daemon
139 Obsoletes:      git-core-daemon-standalone
140
141 %description daemon-inetd
142 Git-daemon is a really simple TCP git daemon that can serve git
143 repositories. This package provides all necessarry files to run
144 git-daemon as an inetd service.
145
146 %description daemon-inetd -l pl.UTF-8
147 Git-daemon to prosty demon git korzystający z protokołu TCP do
148 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
149 do uruchomienia git-demona w trybie usługi inetd.
150
151 %package daemon-standalone
152 Summary:        Files necessary to run git-daemon as a standalone service
153 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
154 Group:          Networking/Daemons
155 Requires:       %{name} = %{version}-%{release}
156 Provides:       git-core-daemon
157 Obsoletes:      git-core-daemon
158 Obsoletes:      git-core-daemon-inetd
159
160 %description daemon-standalone
161 Git-daemon is a really simple TCP git daemon that can serve git
162 repositories. This package provides all necessarry files to run
163 git-daemon as an standalone service.
164
165 %description daemon-standalone -l pl.UTF-8
166 Git-daemon to prosty demon git korzystający z protokołu TCP do
167 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
168 do uruchomienia git-daemona w trybie usługi samodzielnej.
169
170 %package devel
171 Summary:        Git library with header files
172 Summary(pl.UTF-8):      Biblioteka Gita oraz pliki nagłówkowe
173 Group:          Development/Libraries
174 Requires:       zlib-devel
175
176 %description devel
177 Git library with header files.
178
179 %description devel -l pl.UTF-8
180 Biblioteka Gita oraz pliki nagłówkowe.
181
182 %package gitk
183 Summary:        Tcl/Tk interface to the Git version control system
184 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
185 Group:          Development/Tools
186 Requires:       %{name} = %{version}-%{release}
187 Requires:       tk
188
189 %description gitk
190 gitk displays changes in a repository or a selected set of commits.
191 This includes visualizing the commit graph, showing information
192 related to each commit, and the files in the trees of each revision.
193
194 Historically, gitk was the first repository browser. It's written in
195 Tcl/Tk and started off in a separate repository but was later merged
196 into the main git repository.
197
198 %description gitk -l pl.UTF-8
199 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
200 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
201 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
202
203 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
204 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
205 osobnym repozytorium, ale z czasem został włączony do głównego
206 repozytorium gita.
207
208 %package gitweb
209 Summary:        Web frontend to git
210 Summary(pl.UTF-8):      Frontend WWW do gita
211 Group:          Development/Tools
212 Requires:       %{name} = %{version}-%{release}
213 Requires:       webapps
214 Requires:       webserver(alias)
215 Requires:       webserver(cgi)
216 Suggests:       webserver(setenv)
217
218 %description gitweb
219 This package provides a web interface for browsing git repositories.
220
221 %description gitweb -l pl.UTF-8
222 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
223
224 %package gitview
225 Summary:        A GTK+ based repository browser for git
226 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
227 Group:          Development/Tools
228 Requires:       %{name} = %{version}-%{release}
229 Requires:       python >= 1:2.4
230 Requires:       python-pycairo >= 1.0
231 Requires:       python-pygobject
232 Requires:       python-pygtk-gtk >= 2:2.8
233 Suggests:       python-gnome-desktop-gtksourceview
234
235 %description gitview
236 A GTK+ based repository browser for git.
237
238 %description gitview -l pl.UTF-8
239 Oparta na GTK+ przeglądarka repozytorium gita.
240
241 %package gui
242 Summary:        Tcl/Tk interface to the Git version control system
243 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
244 Group:          Development/Tools
245 Requires:       %{name} = %{version}-%{release}
246 Requires:       tk
247 Requires:       xdg-utils
248 Suggests:       meld
249
250 %description gui
251 Displays changes in a repository or a selected set of commits. This
252 includes visualizing the commit graph, showing information related to
253 each commit, and the files in the trees of each revision.
254
255 Historically, gitk was the first repository browser. It's written in
256 Tcl/Tk and started off in a separate repository but was later merged
257 into the main git repository.
258
259 %description gui -l pl.UTF-8
260 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
261 to wizualizację grafu commitów, wyświetlanie informacji związanych z
262 każdym z commitów oraz listę plików dla każdej rewizji.
263
264 Z punktu widzenia historii, gitk był pierwszą przeglądarką
265 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
266 osobnym repozytorium, ale z czasem został włączony do głównego
267 repozytorium gita.
268
269 %package svn
270 Summary:        Subversion support for Git
271 Summary(pl.UTF-8):      Obsługa Subversion dla Gita
272 Group:          Development/Tools
273 Requires:       %{name} = %{version}-%{release}
274 Requires:       perl-Encode
275 Requires:       perl-Term-ReadKey
276
277 %description svn
278 Subversion support for Git.
279
280 %description svn -l pl.UTF-8
281 Obsługa Subversion dla Gita.
282
283 %package cvs
284 Summary:        CVS support for Git
285 Summary(pl.UTF-8):      Obsługa CVS dla Gita
286 Group:          Development/Tools
287 Requires:       %{name} = %{version}-%{release}
288 Requires:       cvsps >= 2.1-2
289 Requires:       rcs
290
291 %description cvs
292 CVS support for Git.
293
294 %description cvs -l pl.UTF-8
295 Obsługa CVS dla Gita.
296
297 %package arch
298 Summary:        Git tools for importing Arch repositories
299 Summary(pl.UTF-8):      Narzędzia Gita do importowania repozytoriów Archa
300 Group:          Development/Tools
301 Requires:       %{name} = %{version}-%{release}
302 Requires:       tla
303
304 %description arch
305 Git tools for importing Arch repositories.
306
307 %description arch -l pl.UTF-8
308 Narzędzia Gita do importowania repozytoriów Archa.
309
310 %package email
311 Summary:        Git tools for sending email
312 Summary(pl.UTF-8):      Narzędzia Gita do wysyłania poczty
313 Group:          Development/Tools
314 Requires:       %{name} = %{version}-%{release}
315
316 %description email
317 Git tools for sending email.
318
319 %description email -l pl.UTF-8
320 Narzędzia Gita do wysyłania poczty.
321
322 %package -n bash-completion-git
323 Summary:        bash-completion for git
324 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
325 Group:          Applications/Shells
326 Requires:       %{name} = %{version}-%{release}
327 Requires:       bash-completion >= 2.0
328
329 %description -n bash-completion-git
330 This package provides bash-completion for git.
331
332 %description -n bash-completion-git -l pl.UTF-8
333 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
334
335 %package -n perl-Git
336 Summary:        Perl interface to the Git version control system
337 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
338 Group:          Development/Languages/Perl
339 Obsoletes:      perl-git-core
340
341 %description -n perl-Git
342 This module provides Perl scripts easy way to interface the Git
343 version control system. The modules have an easy and well-tested way
344 to call arbitrary Git commands; in the future, the interface will also
345 provide specialized methods for doing easily operations which are not
346 totally trivial to do over the generic command interface.
347
348 %description -n perl-Git -l pl.UTF-8
349 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
350 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
351 dowolne polecenia Gita; w przyszłości interfejs udostępni także
352 specjalne metody do łatwego wykonywania operacji nietrywialnych do
353 wykonania przy użyciu ogólnego interfejsu poleceń.
354
355 %package -n python-Git
356 Summary:        Python Git remote helpers for non-git repositories
357 Summary(pl.UTF-8):      Pythonowe zdalne moduły pomocnicze dla repozytoriów niegitowych
358 Group:          Development/Languages/Python
359 Requires:       %{name} = %{version}-%{release}
360
361 %description -n python-Git
362 This package contains Python git_repote_helpers package - Git remote
363 helpers for non-git repositories.
364
365 %description -n python-Git -l pl.UTF-8
366 Ten pakiet zawiera pakiet Pythona git_remote_helpers - zdalne moduły
367 pomocnicze Gita dla repozytoriów niegitowych.
368
369 %package -n vim-syntax-gitcommit
370 Summary:        Vim syntax: gitcommit
371 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
372 Group:          Applications/Editors/Vim
373 Requires:       %{name} = %{version}-%{release}
374 # for _vimdatadir existence
375 Requires:       vim-rt >= 4:6.3.058-3
376
377 %description -n vim-syntax-gitcommit
378 This plugin provides syntax highlighting for git's commit messages.
379
380 %description -n vim-syntax-gitcommit -l pl.UTF-8
381 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
382
383 %prep
384 %setup -q -n git-%{version}
385 %patch0 -p1
386 %patch1 -p0
387 %patch2 -p1
388 %patch3 -p1
389 %patch4 -p1
390 %patch5 -p1
391
392 %build
393 %{__aclocal}
394 %{__autoconf}
395 %configure \
396         --sysconfdir=%{_sysconfdir}/git-core \
397         %{?with_pcre:--with-libpcre} \
398         --with-openssl
399
400 echo "BLK_SHA1=1" >> config.mak
401
402 %{__make} \
403         INSTALLDIRS=vendor \
404         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
405         GITWEB_PROJECTROOT="/var/lib/git" \
406         GITWEB_CSS="/gitweb/gitweb.css" \
407         GITWEB_LOGO="/gitweb/git-logo.png" \
408         GITWEB_FAVICON="/gitweb/git-favicon.png" \
409         V=1
410
411 %if %{with doc}
412 %{__make} -C Documentation \
413         MAN_BASE_URL=file://%{_docdir}/%{name}-doc-%{version}/ \
414         V=1
415 %endif
416
417 %if %{with tests}
418 %if %{without tests_cvs}
419 %{__rm} t/t*cvs*.sh || :
420 %endif
421 %{!?with_tests_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
422 %endif
423
424 %install
425 rm -rf $RPM_BUILD_ROOT
426 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
427 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
428 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
429 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
430 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
431 [init]
432         templatedir = %{_sysconfdir}/%{name}/templates
433 EOF
434
435 %{__make} install \
436         INSTALLDIRS=vendor \
437         DESTDIR=$RPM_BUILD_ROOT
438
439 %if %{with doc}
440 %{__make} -C Documentation install \
441         DESTDIR=$RPM_BUILD_ROOT
442 %endif
443
444 # copy templates except sample hooks
445 cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
446 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
447
448 # header files and lib
449 cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
450 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
451 cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
452 install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
453 cp -p block-sha1/sha1.h $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
454 cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
455 cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
456 cp -p {Makefile,config.mak,config.mak.autogen,config.mak.uname} $RPM_BUILD_ROOT%{_includedir}/%{name}
457
458 # bash completion
459 install -d $RPM_BUILD_ROOT%{bash_compdir}
460 cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{bash_compdir}/git
461
462 # vim syntax
463 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
464 cat > $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax/gitcommit.vim << 'EOF'
465 autocmd BufNewFile,BufRead *.git/COMMIT_EDITMSG    setf gitcommit
466 autocmd BufNewFile,BufRead *.git/config,.gitconfig setf gitconfig
467 autocmd BufNewFile,BufRead git-rebase-todo         setf gitrebase
468 autocmd BufNewFile,BufRead .msg.[0-9]*
469         \ if getline(1) =~ '^From.*# This line is ignored.$' |
470         \   setf gitsendemail |
471         \ endif
472 autocmd BufNewFile,BufRead *.git/**
473         \ if getline(1) =~ '^\x\{40\}\>\|^ref: ' |
474         \   setf git |
475         \ endif
476 EOF
477
478 # gitweb
479 mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
480 ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
481 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
482 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
483 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
484 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
485
486 # gitview
487 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
488
489 # git-daemon related files
490 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
491 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
492 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
493
494 # paths cleanup
495 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
496 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
497
498 # hardlink
499 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
500 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
501 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
502 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
503
504 # remove unneeded files
505 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
506 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
507 %py_postclean
508
509 mv $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
510 %find_lang git
511
512 %clean
513 rm -rf $RPM_BUILD_ROOT
514
515 %post daemon-inetd
516 %service -q rc-inetd reload
517
518 %postun daemon-inetd
519 if [ "$1" = "0" ]; then
520         %service -q rc-inetd reload
521 fi
522
523 %post daemon-standalone
524 /sbin/chkconfig --add git-daemon
525 %service git-daemon restart "git-daemon"
526
527 %preun daemon-standalone
528 if [ "$1" = "0" ]; then
529         %service git-daemon stop
530         /sbin/chkconfig --del git-daemon
531 fi
532
533 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
534 %webapp_register apache %{webapp}
535
536 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
537 %webapp_unregister apache %{webapp}
538
539 %triggerin gitweb -- apache < 2.2.0, apache-base
540 %webapp_register httpd %{webapp}
541
542 %triggerun gitweb -- apache < 2.2.0, apache-base
543 %webapp_unregister httpd %{webapp}
544
545 %triggerin gitweb -- lighttpd
546 %webapp_register lighttpd %{webapp}
547
548 %triggerun gitweb -- lighttpd
549 %webapp_unregister lighttpd %{webapp}
550
551 %files -f git.lang
552 %defattr(644,root,root,755)
553 %doc README contrib
554 %attr(755,root,root) %{_bindir}/git
555 %attr(755,root,root) %{_bindir}/git-receive-pack
556 %attr(755,root,root) %{_bindir}/git-shell
557 %attr(755,root,root) %{_bindir}/git-upload-archive
558 %attr(755,root,root) %{_bindir}/git-upload-pack
559 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
560
561 %if %{with doc}
562 %{_mandir}/man1/git-*.1*
563 %exclude %{_mandir}/man1/git-archimport.1*
564 %exclude %{_mandir}/man1/git-svn.1*
565 %exclude %{_mandir}/man1/git-cvs*.1*
566 %exclude %{_mandir}/man1/git-imap-send*.1*
567 %exclude %{_mandir}/man1/*email*.1*
568 %exclude %{_mandir}/man1/gitremote-helpers.1*
569 %{_mandir}/man1/git.1*
570 %{_mandir}/man5/gitattributes.5*
571 %{_mandir}/man5/githooks.5*
572 %{_mandir}/man5/gitignore.5*
573 %{_mandir}/man5/gitmodules.5*
574 %{_mandir}/man5/gitrepository-layout.5*
575 %{_mandir}/man7/gitcli.7*
576 %{_mandir}/man7/gitcore-tutorial.7*
577 %{_mandir}/man7/gitcredentials.7*
578 %{_mandir}/man7/gitdiffcore.7*
579 %{_mandir}/man7/gitglossary.7*
580 %{_mandir}/man7/gitnamespaces.7*
581 %{_mandir}/man7/gitrevisions.7*
582 %{_mandir}/man7/gittutorial-2.7*
583 %{_mandir}/man7/gittutorial.7*
584 %{_mandir}/man7/gitworkflows.7*
585 %endif
586
587 %dir %{_libdir}/%{name}
588 %attr(755,root,root) %{_libdir}/%{name}/*-*
589 %attr(755,root,root) %{_libdir}/%{name}/git
590 %{_libdir}/%{name}/mergetools
591
592 %exclude %{_libdir}/%{name}/git-gui
593 %exclude %{_libdir}/%{name}/git-svn
594 %exclude %{_libdir}/%{name}/git-archimport
595 %exclude %{_libdir}/%{name}/git-cvs*
596 %exclude %{_libdir}/%{name}/git-imap-send
597 %exclude %{_libdir}/%{name}/git-instaweb
598 %exclude %{_libdir}/%{name}/git-remote-testsvn
599 %exclude %{_libdir}/%{name}/*email*
600
601 %{_datadir}/%{name}
602
603 %{_localstatedir}/lib/git
604
605 %if %{with doc}
606 %files doc
607 %defattr(644,root,root,755)
608 %doc Documentation/RelNotes*
609 %doc Documentation/*.html Documentation/howto Documentation/technical
610 %endif
611
612 %files daemon-inetd
613 %defattr(644,root,root,755)
614 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
615
616 %files daemon-standalone
617 %defattr(644,root,root,755)
618 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
619 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
620
621 %files devel
622 %defattr(644,root,root,755)
623 %{_includedir}/%{name}
624 %{_libdir}/libgit.a
625 %{_libdir}/libgit_xdiff.a
626
627 %files gitk
628 %defattr(644,root,root,755)
629 %if %{with doc}
630 %{_mandir}/man1/gitk.1*
631 %endif
632 %attr(755,root,root) %{_bindir}/gitk
633 %dir %{_datadir}/gitk
634 %dir %{_datadir}/gitk/lib
635 %dir %{_datadir}/gitk/lib/msgs
636 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
637 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
638 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
639 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
640 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
641 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
642 %lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
643 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
644 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
645
646 %files gitweb
647 %defattr(644,root,root,755)
648 %doc gitweb/{README,INSTALL}
649 %dir %{webappdir}
650 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
651 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
652 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
653 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
654 %attr(755,root,root) %{cgibindir}/gitweb.cgi
655 %{appdir}
656 %attr(755,root,root) %{_libdir}/%{name}/git-instaweb
657 %if %{with doc}
658 %{_mandir}/man1/gitweb.1*
659 %{_mandir}/man5/gitweb.conf.5*
660 %endif
661
662 %files gitview
663 %defattr(644,root,root,755)
664 %doc contrib/gitview/gitview.txt
665 %attr(755,root,root) %{_bindir}/gitview
666
667 %files gui
668 %defattr(644,root,root,755)
669 %attr(755,root,root) %{_libdir}/%{name}/git-gui
670 %dir %{_datadir}/git-gui
671 %dir %{_datadir}/git-gui/lib
672 %dir %{_datadir}/git-gui/lib/msgs
673 %{_datadir}/git-gui/lib/git-gui.ico
674 %{_datadir}/git-gui/lib/tclIndex
675 %{_datadir}/git-gui/lib/*.js
676 %{_datadir}/git-gui/lib/*.tcl
677 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
678 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
679 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
680 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
681 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
682 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
683 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
684 %lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
685 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
686 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
687 %lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
688
689 %files svn
690 %defattr(644,root,root,755)
691 %attr(755,root,root) %{_libdir}/%{name}/git-svn
692 %attr(755,root,root) %{_libdir}/%{name}/git-remote-testsvn
693 %{perl_vendorlib}/Git/SVN
694 %{perl_vendorlib}/Git/SVN.pm
695 %if %{with doc}
696 %{_mandir}/man1/git-svn.1*
697 %endif
698
699 %files cvs
700 %defattr(644,root,root,755)
701 %attr(755,root,root) %{_bindir}/git-cvsserver
702 %attr(755,root,root) %{_libdir}/%{name}/git-cvs*
703 %if %{with doc}
704 %{_mandir}/man1/git-cvs*.1*
705 %{_mandir}/man7/gitcvs-migration.7*
706 %endif
707
708 %files arch
709 %defattr(644,root,root,755)
710 %attr(755,root,root) %{_libdir}/%{name}/git-archimport
711 %if %{with doc}
712 %{_mandir}/man1/git-archimport.1*
713 %endif
714
715 %files email
716 %defattr(644,root,root,755)
717 %attr(755,root,root) %{_libdir}/%{name}/git-imap-send
718 %attr(755,root,root) %{_libdir}/%{name}/*email*
719 %if %{with doc}
720 %{_mandir}/man1/*email*.1*
721 %{_mandir}/man1/*imap-send*.1*
722 %endif
723
724 %files -n bash-completion-git
725 %defattr(644,root,root,755)
726 %{bash_compdir}/git
727
728 %files -n perl-Git
729 %defattr(644,root,root,755)
730 %{perl_vendorlib}/Git.pm
731 %dir %{perl_vendorlib}/Git
732 %{perl_vendorlib}/Git/I18N.pm
733 %{perl_vendorlib}/Git/IndexInfo.pm
734 %{_mandir}/man3/Git*.3pm*
735
736 %files -n python-Git
737 %defattr(644,root,root,755)
738 %dir %{py_sitescriptdir}/git_remote_helpers
739 %{py_sitescriptdir}/git_remote_helpers/*.py[co]
740 %dir %{py_sitescriptdir}/git_remote_helpers/git
741 %{py_sitescriptdir}/git_remote_helpers/git/*.py[co]
742 %if "%{py_ver}" > "2.4"
743 %{py_sitescriptdir}/git_remote_helpers*.egg-info
744 %endif
745 %if %{with doc}
746 %{_mandir}/man1/gitremote-helpers.1*
747 %endif
748
749 %files -n vim-syntax-gitcommit
750 %defattr(644,root,root,755)
751 %doc contrib/vim/README
752 %{_datadir}/vim/vimfiles/syntax/gitcommit.vim
This page took 0.075815 seconds and 4 git commands to generate.