]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
- Perl Package Naming
[packages/git-core.git] / git-core.spec
1 %include        /usr/lib/rpm/macros.perl
2 Summary:        The stupid content tracker
3 Summary(pl):    Prymitywne narzêdzie do ¶ledzenia tre¶ci
4 Name:           git-core
5 Version:        1.4.3.4
6 Release:        2
7 License:        GPL v2
8 Group:          Development/Tools
9 Source0:        http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
10 # Source0-md5:  5114c6b58329f3574697a595774df7d0
11 URL:            http://git.or.cz/
12 BuildRequires:  asciidoc
13 BuildRequires:  curl-devel
14 BuildRequires:  expat-devel
15 BuildRequires:  openssl-devel
16 BuildRequires:  perl-Error
17 BuildRequires:  perl-base
18 BuildRequires:  python
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  xmlto
21 BuildRequires:  zlib-devel
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 "git" can mean anything, depending on your mood.
26
27  - random three-letter combination that is pronounceable, and not
28    actually used by any common UNIX command. The fact that it is a
29    mispronunciation of "get" may or may not be relevant.
30  - stupid. contemptible and despicable. simple. Take your pick from the
31    dictionary of slang.
32  - "global information tracker": you're in a good mood, and it actually
33    works for you. Angels sing, and a light suddenly fills the room.
34  - "goddamn idiotic truckload of sh*t": when it breaks
35
36 This is a stupid (but extremely fast) directory content manager. It
37 doesn't do a whole lot, but what it 'does' do is track directory
38 contents efficiently.
39
40 %description -l pl
41 "git" mo¿e oznaczaæ cokolwiek, w zale¿no¶ci od nastroju.
42
43 - losow± kombinacjê trzech liter, która jest wymawialna i w³a¶ciwie
44   nie u¿ywana przez ¿adne popularne polecenie uniksowe. Fakt, ¿e jest to
45   b³êdna pisownia s³owa "get" mo¿e mieæ lub nie mieæ znaczenia.
46 - g³upi, pogardliwy, prosty. Mo¿na wybraæ ze s³ownika slangu.
47 - "global information tracker" (narzêdzie do globalnego ¶ledzenia
48   informacji) - je¶li jeste¶my w dobrym nastroju i git akurat dzia³a.
49   Anio³y ¶piewaj±, a ¶wiat³o niespodziewanie wype³nia pokój.
50 - "goddamn idiotic truckload of sh*t" (przeklêty idiotyczny ³adunek
51   g*) - kiedy siê zepsuje.
52
53 Jest to prymitywny (ale bardzo szybki) zarz±dca tre¶ci s³ownikowej.
54 Nie robi wiele, ale to, co "robi", to wydajne ¶ledzenie zawarto¶ci
55 katalogu.
56
57 %package devel
58 Summary:        Header files for git-core
59 Summary(pl):    Pliki nag³ówkowe dla git-core
60 Group:          Development/Libraries
61
62 %description devel
63 Header files for git-core.
64
65 %description devel
66 Pliki nag³ówkowe dla git-core.
67
68 %package -n perl-Git-Core
69 Summary:        Perl interface to the Git version control system
70 Group:          Development/Languages/Perl
71 Requires:       %{name} = %{version}-%{release}
72 Obsoletes:      perl-git-core
73
74 %description -n perl-Git-Core
75 This module provides Perl scripts easy way to interface the Git
76 version control system. The modules have an easy and well-tested way
77 to call arbitrary Git commands; in the future, the interface will also
78 provide specialized methods for doing easily operations which are not
79 totally trivial to do over the generic command interface.
80
81 %prep
82 %setup -q -n git-%{version}
83
84 %build
85 %{__make} \
86         prefix=%{_prefix} \
87         CC="%{__cc}" \
88         CFLAGS="%{rpmcflags}" \
89         LDFLAGS="%{rpmldflags}"
90
91 # once again to get perl paths stright
92 cd perl
93 %{__perl} Makefile.PL \
94         INSTALLDIRS=vendor
95 %{__make}
96 cd ..
97
98 %{__make} -C Documentation
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102 install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
103
104 %{__make} install \
105         prefix=%{_prefix} \
106         CFLAGS="%{rpmcflags}" \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 %{__make} -C Documentation install \
110         prefix=%{_prefix} \
111         mandir=%{_mandir} \
112         DESTDIR=$RPM_BUILD_ROOT
113
114 install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
115 install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
116
117 rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
118 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %files
124 %defattr(644,root,root,755)
125 %doc README Documentation/*.html Documentation/howto Documentation/technical
126 %attr(755,root,root) %{_bindir}/*
127 %{_mandir}/man*/*
128 %dir %{_datadir}/%{name}
129 %{_datadir}/%{name}/*
130
131 %files devel
132 %defattr(644,root,root,755)
133 %{_includedir}/*
134
135 %files -n perl-Git-Core
136 %defattr(644,root,root,755)
137 %{perl_vendorlib}/*.pm
138 %{_mandir}/man3/*
This page took 0.065652 seconds and 4 git commands to generate.