]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
- move git-remote-testgit to python subpackage as it is an example code
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform make test
4 %bcond_with     tests_cvs       # perform tests which use CVS
5 %bcond_with     tests_svn       # perform tests which use subversion
6 %bcond_without  doc             # skip building/packaging docs/manuals (takes some time)
7 #
8 %include        /usr/lib/rpm/macros.perl
9 Summary:        Distributed version control system focused on speed, effectivity and usability
10 Summary(pl.UTF-8):      Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
11 Name:           git-core
12 Version:        1.7.7.4
13 Release:        1
14 License:        GPL v2
15 Group:          Development/Tools
16 # Source0:      http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
17 Source0:        http://git-core.googlecode.com/files/git-%{version}.tar.gz
18 # Source0-md5:  2f3277475b8da2eb92cef54c4c641a2c
19 Source1:        %{name}-gitweb.conf
20 Source2:        %{name}-gitweb-httpd.conf
21 Source3:        %{name}-gitweb-lighttpd.conf
22 Source4:        %{name}.sysconfig
23 Source5:        %{name}.inet
24 Source6:        %{name}.init
25 Patch0:         %{name}-tests.patch
26 Patch1:         %{name}-key-bindings.patch
27 Patch2:         %{name}-sysconfdir.patch
28 URL:            http://git-scm.com/
29 BuildRequires:  autoconf
30 BuildRequires:  automake
31 BuildRequires:  curl-devel
32 BuildRequires:  expat-devel
33 BuildRequires:  gettext-devel
34 BuildRequires:  openssl-devel
35 BuildRequires:  perl-Error > 0.15
36 BuildRequires:  perl-base
37 BuildRequires:  python-devel
38 BuildRequires:  rpm-perlprov >= 4.1-13
39 BuildRequires:  rpm-pythonprov
40 BuildRequires:  rpmbuild(macros) >= 1.264
41 BuildRequires:  tcl
42 BuildRequires:  zlib-devel
43 %if %{with doc}
44 BuildRequires:  asciidoc >= 7.1.2-3
45 BuildRequires:  docbook-dtd45-xml
46 BuildRequires:  xmlto
47 %endif
48 %if %{with tests}
49 %if %{with tests_cvs}
50 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
51 BuildRequires:  cvs-gnu-client < 1.13
52 BuildRequires:  cvs-gnu-client >= 1.12
53 %endif
54 Conflicts:      pdksh < 5.2.14-46
55 %endif
56 Requires:       coreutils
57 Requires:       diffutils
58 Requires:       findutils
59 Requires:       grep
60 Requires:       openssh-clients
61 Requires:       perl-Error
62 Requires:       perl-Git = %{version}-%{release}
63 Requires:       sed
64 Suggests:       git-core-cvs
65 Suggests:       git-core-svn
66 Suggests:       less
67 Suggests:       rsync
68 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
70 # html docs have links to txt files
71 %define         _noautocompressdoc      *.txt
72
73 %define         webapp          gitweb
74 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
75 %define         appdir          %{_datadir}/%{webapp}
76 %define         cgibindir       %{_prefix}/lib/cgi-bin
77
78 %description
79 "git" can mean anything, depending on your mood.
80
81 - random three-letter combination that is pronounceable, and not
82   actually used by any common UNIX command. The fact that it is a
83   mispronunciation of "get" may or may not be relevant.
84 - stupid. contemptible and despicable. simple. Take your pick from the
85   dictionary of slang.
86 - "global information tracker": you're in a good mood, and it actually
87   works for you. Angels sing, and a light suddenly fills the room.
88 - "goddamn idiotic truckload of sh*t": when it breaks
89
90 This is a stupid (but extremely fast) directory content manager. It
91 doesn't do a whole lot, but what it 'does' do is track directory
92 contents efficiently.
93
94 %description -l pl.UTF-8
95 "git" może oznaczać cokolwiek, w zależności od nastroju.
96
97 - losową kombinację trzech liter, która jest wymawialna i właściwie
98   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
99   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
100 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
101 - "global information tracker" (narzędzie do globalnego śledzenia
102   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
103   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
104 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
105   g*) - kiedy się zepsuje.
106
107 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
108 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
109 katalogu.
110
111 %package doc
112 Summary:        Documentation for git-core
113 Summary(pl.UTF-8):      Dokumentacja do git-core
114 Group:          Documentation
115
116 %description doc
117 Documentation for git-core.
118
119 %description doc -l pl.UTF-8
120 Dokumentacja do git-core.
121
122 %description doc -l fr.UTF-8
123 Javadoc pour git-core.
124
125 %package daemon-inetd
126 Summary:        Files necessary to run git-daemon as an inetd service
127 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
128 Group:          Networking/Daemons
129 Requires:       %{name} = %{version}-%{release}
130 Requires:       setup >= 2.4.11-1
131 Provides:       git-core-daemon
132 Obsoletes:      git-core-daemon
133 Obsoletes:      git-core-daemon-standalone
134
135 %description daemon-inetd
136 Git-daemon is a really simple TCP git daemon that can serve git
137 repositories. This package provides all necessarry files to run
138 git-daemon as an inetd service.
139
140 %description daemon-inetd -l pl.UTF-8
141 Git-daemon to prosty demon git korzystający z protokołu TCP do
142 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
143 do uruchomienia git-demona w trybie usługi inetd.
144
145 %package daemon-standalone
146 Summary:        Files necessary to run git-daemon as a standalone service
147 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
148 Group:          Networking/Daemons
149 Requires:       %{name} = %{version}-%{release}
150 Provides:       git-core-daemon
151 Obsoletes:      git-core-daemon
152 Obsoletes:      git-core-daemon-inetd
153
154 %description daemon-standalone
155 Git-daemon is a really simple TCP git daemon that can serve git
156 repositories. This package provides all necessarry files to run
157 git-daemon as an standalone service.
158
159 %description daemon-standalone -l pl.UTF-8
160 Git-daemon to prosty demon git korzystający z protokołu TCP do
161 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
162 do uruchomienia git-daemona w trybie usługi samodzielnej.
163
164 %package devel
165 Summary:        Header files for git-core
166 Summary(pl.UTF-8):      Pliki nagłówkowe dla git-core
167 Group:          Development/Libraries
168 Requires:       zlib-devel
169
170 %description devel
171 Header files for git-core.
172
173 %description devel -l pl.UTF-8
174 Pliki nagłówkowe dla git-core.
175
176 %package gitk
177 Summary:        Tcl/Tk interface to the Git version control system
178 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
179 Group:          Development/Tools
180 Requires:       %{name} = %{version}-%{release}
181 Requires:       tk
182
183 %description gitk
184 gitk displays changes in a repository or a selected set of commits.
185 This includes visualizing the commit graph, showing information
186 related to each commit, and the files in the trees of each revision.
187
188 Historically, gitk was the first repository browser. It's written in
189 Tcl/Tk and started off in a separate repository but was later merged
190 into the main git repository.
191
192 %description gitk -l pl.UTF-8
193 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
194 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
195 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
196
197 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
198 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
199 osobnym repozytorium, ale z czasem został włączony do głównego
200 repozytorium gita.
201
202 %package gitweb
203 Summary:        Web frontend to git
204 Summary(pl.UTF-8):      Frontend WWW do gita
205 Group:          Development/Tools
206 Requires:       %{name} = %{version}-%{release}
207 Requires:       webapps
208 Requires:       webserver(alias)
209 Requires:       webserver(cgi)
210
211 %description gitweb
212 This package provides a web interface for browsing git repositories.
213
214 %description gitweb -l pl.UTF-8
215 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
216
217 %package gitview
218 Summary:        A GTK+ based repository browser for git
219 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
220 Group:          Development/Tools
221 Requires:       %{name} = %{version}-%{release}
222 Requires:       python >= 1:2.4
223 Requires:       python-pycairo >= 1.0
224 Requires:       python-pygobject
225 Requires:       python-pygtk-gtk >= 2:2.8
226 Suggests:       python-gnome-desktop-gtksourceview
227
228 %description gitview
229 A GTK+ based repository browser for git.
230
231 %description gitview -l pl.UTF-8
232 Oparta na GTK+ przeglądarka repozytorium gita.
233
234 %package gui
235 Summary:        Tcl/Tk interface to the Git version control system
236 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
237 Group:          Development/Tools
238 Requires:       %{name} = %{version}-%{release}
239 Requires:       tk
240 Requires:       xdg-utils
241 Suggests:       meld
242
243 %description gui
244 Displays changes in a repository or a selected set of commits. This
245 includes visualizing the commit graph, showing information related to
246 each commit, and the files in the trees of each revision.
247
248 Historically, gitk was the first repository browser. It's written in
249 Tcl/Tk and started off in a separate repository but was later merged
250 into the main git repository.
251
252 %description gui -l pl.UTF-8
253 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
254 to wizualizację grafu commitów, wyświetlanie informacji związanych z
255 każdym z commitów oraz listę plików dla każdej rewizji.
256
257 Z punktu widzenia historii, gitk był pierwszą przeglądarką
258 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
259 osobnym repozytorium, ale z czasem został włączony do głównego
260 repozytorium gita.
261
262 %package svn
263 Summary:        Subversion support for Git
264 Summary(pl.UTF-8):      Obsługa Subversion dla Gita
265 Group:          Development/Tools
266 Requires:       %{name} = %{version}-%{release}
267 Requires:       perl-Term-ReadKey
268
269 %description svn
270 Subversion support for Git.
271
272 %description svn -l pl.UTF-8
273 Obsługa Subversion dla Gita.
274
275 %package cvs
276 Summary:        CVS support for Git
277 Summary(pl.UTF-8):      Obsługa CVS dla Gita
278 Group:          Development/Tools
279 Requires:       %{name} = %{version}-%{release}
280 Requires:       cvsps >= 2.1-2
281 Requires:       rcs
282
283 %description cvs
284 CVS support for Git.
285
286 %description cvs -l pl.UTF-8
287 Obsługa CVS dla Gita.
288
289 %package arch
290 Summary:        Git tools for importing Arch repositories
291 Summary(pl.UTF-8):      Narzędzia Gita do importowania repozytoriów Archa
292 Group:          Development/Tools
293 Requires:       %{name} = %{version}-%{release}
294 Requires:       tla
295
296 %description arch
297 Git tools for importing Arch repositories.
298
299 %description arch -l pl.UTF-8
300 Narzędzia Gita do importowania repozytoriów Archa.
301
302 %package email
303 Summary:        Git tools for sending email
304 Summary(pl.UTF-8):      Narzędzia Gita do wysyłania poczty
305 Group:          Development/Tools
306 Requires:       %{name} = %{version}-%{release}
307
308 %description email
309 Git tools for sending email.
310
311 %description email -l pl.UTF-8
312 Narzędzia Gita do wysyłania poczty.
313
314 %package -n bash-completion-git
315 Summary:        bash-completion for git
316 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
317 Group:          Applications/Shells
318 Requires:       bash-completion
319
320 %description -n bash-completion-git
321 This package provides bash-completion for git.
322
323 %description -n bash-completion-git -l pl.UTF-8
324 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
325
326 %package -n perl-Git
327 Summary:        Perl interface to the Git version control system
328 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
329 Group:          Development/Languages/Perl
330 Obsoletes:      perl-git-core
331
332 %description -n perl-Git
333 This module provides Perl scripts easy way to interface the Git
334 version control system. The modules have an easy and well-tested way
335 to call arbitrary Git commands; in the future, the interface will also
336 provide specialized methods for doing easily operations which are not
337 totally trivial to do over the generic command interface.
338
339 %description -n perl-Git -l pl.UTF-8
340 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
341 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
342 dowolne polecenia Gita; w przyszłości interfejs udostępni także
343 specjalne metody do łatwego wykonywania operacji nietrywialnych do
344 wykonania przy użyciu ogólnego interfejsu poleceń.
345
346 %package -n python-Git
347 Summary:        Python interface to the Git version control system
348 Summary(pl.UTF-8):      Pythonowy interfejs do systemu kontroli wersji Git
349 Group:          Development/Languages/Python
350 Requires:       git-core
351
352 %description -n python-Git
353 This module provides Python scripts easy way to interface the Git
354 version control system.
355
356 %description -n python-Git -l pl.UTF-8
357 Ten moduł umożliwia skryptom Pythonowym współpracę z systemem kontroli
358 wersji Git.
359
360 %package -n vim-syntax-gitcommit
361 Summary:        Vim syntax: gitcommit
362 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
363 Group:          Applications/Editors/Vim
364 # for _vimdatadir existence
365 Requires:       vim-rt >= 4:6.3.058-3
366
367 %description -n vim-syntax-gitcommit
368 This plugin provides syntax highlighting for git's commit messages.
369
370 %description -n vim-syntax-gitcommit -l pl.UTF-8
371 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
372
373 %prep
374 %setup -q -n git-%{version}
375 %patch0 -p1
376 %patch1 -p0
377 %patch2 -p1
378
379 %build
380 %{__aclocal}
381 %{__autoconf}
382 %configure \
383         --sysconfdir=%{_sysconfdir}/git-core \
384         --with-openssl
385
386 echo "BLK_SHA1=1" >> config.mak
387
388 %{__make} \
389         INSTALLDIRS=vendor \
390         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
391         GITWEB_PROJECTROOT="/var/lib/git" \
392         GITWEB_CSS="/gitweb/gitweb.css" \
393         GITWEB_LOGO="/gitweb/git-logo.png" \
394         GITWEB_FAVICON="/gitweb/git-favicon.png" \
395         V=1
396
397 # use DOCBOOK_XSL_172=1 to fix 'the ".ft C" problem' in generated manpages.
398 %{?with_doc:%{__make} -C Documentation V=1 DOCBOOK_XSL_172=1}
399
400 %if %{with tests}
401 %if %{without tests_cvs}
402 rm t/t*cvs*.sh || :
403 %endif
404 %{!?with_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
405 %endif
406
407 %install
408 rm -rf $RPM_BUILD_ROOT
409 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
410 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
411 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
412 install -d $RPM_BUILD_ROOT%{_sysconfdir}/git-core
413 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
414 [init]
415         templatedir = /etc/git-core/templates
416 EOF
417
418 %{__make} install \
419         INSTALLDIRS=vendor \
420         DESTDIR=$RPM_BUILD_ROOT
421
422 %if %{with doc}
423 %{__make} -C Documentation install \
424         DESTDIR=$RPM_BUILD_ROOT
425 %endif
426
427 # copy templates except sample hooks
428 cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
429 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
430
431 # header files and lib
432 cp -a *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
433 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
434 cp -a xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
435 cp -a libgit.a $RPM_BUILD_ROOT%{_libdir}
436 cp -a xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
437
438 # bash completion
439 install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
440 cp -a contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
441
442 # vim syntax
443 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
444 cat > $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax/gitcommit.vim << 'EOF'
445 autocmd BufNewFile,BufRead *.git/COMMIT_EDITMSG    setf gitcommit
446 autocmd BufNewFile,BufRead *.git/config,.gitconfig setf gitconfig
447 autocmd BufNewFile,BufRead git-rebase-todo         setf gitrebase
448 autocmd BufNewFile,BufRead .msg.[0-9]*
449         \ if getline(1) =~ '^From.*# This line is ignored.$' |
450         \   setf gitsendemail |
451         \ endif
452 autocmd BufNewFile,BufRead *.git/**
453         \ if getline(1) =~ '^\x\{40\}\>\|^ref: ' |
454         \   setf git |
455         \ endif
456 EOF
457
458 # gitweb
459 mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
460 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
461 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
462 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
463 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
464
465 # gitview
466 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
467
468 # git-daemon related files
469 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
470 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
471 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
472
473 # paths cleanup
474 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
475 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
476
477 # hardlink
478 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
479 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
480 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
481 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
482
483 # remove unneeded files
484 rm $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
485 rm $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
486 %py_postclean
487
488 %clean
489 rm -rf $RPM_BUILD_ROOT
490
491 %post daemon-inetd
492 %service -q rc-inetd reload
493
494 %postun daemon-inetd
495 if [ "$1" = "0" ]; then
496         %service -q rc-inetd reload
497 fi
498
499 %post daemon-standalone
500 /sbin/chkconfig --add git-daemon
501 %service git-daemon restart "git-daemon"
502
503 %preun daemon-standalone
504 if [ "$1" = "0" ]; then
505         %service git-daemon stop
506         /sbin/chkconfig --del git-daemon
507 fi
508
509 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
510 %webapp_register apache %{webapp}
511
512 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
513 %webapp_unregister apache %{webapp}
514
515 %triggerin gitweb -- apache < 2.2.0, apache-base
516 %webapp_register httpd %{webapp}
517
518 %triggerun gitweb -- apache < 2.2.0, apache-base
519 %webapp_unregister httpd %{webapp}
520
521 %triggerin gitweb -- lighttpd
522 %webapp_register lighttpd %{webapp}
523
524 %triggerun gitweb -- lighttpd
525 %webapp_unregister lighttpd %{webapp}
526
527 %files
528 %defattr(644,root,root,755)
529 %doc README contrib
530 %attr(755,root,root) %{_bindir}/git
531 %attr(755,root,root) %{_bindir}/git-receive-pack
532 %attr(755,root,root) %{_bindir}/git-shell
533 %attr(755,root,root) %{_bindir}/git-upload-archive
534 %attr(755,root,root) %{_bindir}/git-upload-pack
535 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/git-core
536
537 %if %{with doc}
538 %{_mandir}/man1/git-*.1*
539 %exclude %{_mandir}/man1/git-svn.1*
540 %exclude %{_mandir}/man1/git-cvs*.1*
541 %exclude %{_mandir}/man1/git-remote-helpers.1*
542 %{_mandir}/man1/git.1*
543 %{_mandir}/man5/gitattributes.5*
544 %{_mandir}/man5/githooks.5*
545 %{_mandir}/man5/gitignore.5*
546 %{_mandir}/man5/gitmodules.5*
547 %{_mandir}/man5/gitrepository-layout.5*
548 %{_mandir}/man7/gitcli.7*
549 %{_mandir}/man7/gitcore-tutorial.7*
550 %{_mandir}/man7/gitdiffcore.7*
551 %{_mandir}/man7/gitglossary.7*
552 %{_mandir}/man7/gitnamespaces.7*
553 %{_mandir}/man7/gitrevisions.7*
554 %{_mandir}/man7/gittutorial-2.7*
555 %{_mandir}/man7/gittutorial.7*
556 %{_mandir}/man7/gitworkflows.7*
557 %endif
558
559 %dir %{_libdir}/%{name}
560 %attr(755,root,root) %{_libdir}/%{name}/*-*
561 %attr(755,root,root) %{_libdir}/%{name}/git
562 %{_libdir}/%{name}/mergetools
563
564 %exclude %{_libdir}/%{name}/git-gui
565 %exclude %{_libdir}/%{name}/git-svn
566 %exclude %{_libdir}/%{name}/git-archimport
567 %exclude %{_libdir}/%{name}/git-cvs*
568 %exclude %{_libdir}/%{name}/git-remote-testgit
569 %exclude %{_libdir}/%{name}/*email*
570
571 %{_datadir}/%{name}
572
573 %{_localstatedir}/lib/git
574
575 %if %{with doc}
576 %files doc
577 %defattr(644,root,root,755)
578 %doc Documentation/RelNotes*
579 %doc Documentation/*.html Documentation/howto Documentation/technical
580 %endif
581
582 %files daemon-inetd
583 %defattr(644,root,root,755)
584 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
585
586 %files daemon-standalone
587 %defattr(644,root,root,755)
588 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
589 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
590
591 %files devel
592 %defattr(644,root,root,755)
593 %{_includedir}/git-core
594 %{_libdir}/libgit.a
595 %{_libdir}/libgit_xdiff.a
596
597 %files gitk
598 %defattr(644,root,root,755)
599 %if %{with doc}
600 %{_mandir}/man1/gitk.1*
601 %endif
602 %attr(755,root,root) %{_bindir}/gitk
603 %dir %{_datadir}/gitk
604 %dir %{_datadir}/gitk/lib
605 %dir %{_datadir}/gitk/lib/msgs
606 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
607 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
608 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
609 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
610 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
611 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
612 %lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
613 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
614 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
615
616 %files gitweb
617 %defattr(644,root,root,755)
618 %doc gitweb/{README,INSTALL}
619 %dir %{webappdir}
620 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
621 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
622 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
623 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
624 %attr(755,root,root) %{cgibindir}/gitweb.cgi
625 %{appdir}
626
627 %files gitview
628 %defattr(644,root,root,755)
629 %doc contrib/gitview/gitview.txt
630 %attr(755,root,root) %{_bindir}/gitview
631
632 %files gui
633 %defattr(644,root,root,755)
634 %attr(755,root,root) %{_libdir}/%{name}/git-gui
635 %dir %{_datadir}/git-gui
636 %dir %{_datadir}/git-gui/lib
637 %dir %{_datadir}/git-gui/lib/msgs
638 %{_datadir}/git-gui/lib/git-gui.ico
639 %{_datadir}/git-gui/lib/tclIndex
640 %{_datadir}/git-gui/lib/*.js
641 %{_datadir}/git-gui/lib/*.tcl
642 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
643 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
644 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
645 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
646 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
647 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
648 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
649 %lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
650 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
651 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
652 %lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
653
654 %files svn
655 %defattr(644,root,root,755)
656 %attr(755,root,root) %{_libdir}/%{name}/git-svn
657 %if %{with doc}
658 %{_mandir}/man1/git-svn.1*
659 %endif
660
661 %files cvs
662 %defattr(644,root,root,755)
663 %attr(755,root,root) %{_bindir}/git-cvsserver
664 %attr(755,root,root) %{_libdir}/%{name}/git-cvs*
665 %if %{with doc}
666 %{_mandir}/man1/git-cvs*.1*
667 %{_mandir}/man7/gitcvs-migration.7*
668 %endif
669
670 %files arch
671 %defattr(644,root,root,755)
672 %attr(755,root,root) %{_libdir}/%{name}/git-archimport
673 %if %{with doc}
674 %{_mandir}/man1/git-archimport.1*
675 %endif
676
677 %files email
678 %defattr(644,root,root,755)
679 %attr(755,root,root) %{_libdir}/%{name}/*email*
680 %if %{with doc}
681 %{_mandir}/man1/*email*.1*
682 %endif
683
684 %files -n bash-completion-git
685 %defattr(644,root,root,755)
686 %{_sysconfdir}/bash_completion.d/*
687
688 %files -n perl-Git
689 %defattr(644,root,root,755)
690 %{perl_vendorlib}/Git.pm
691 %{_mandir}/man3/Git.3pm*
692
693 %files -n python-Git
694 %defattr(644,root,root,755)
695 %attr(755,root,root) %{_libdir}/%{name}/git-remote-testgit
696 %dir %{py_sitescriptdir}/git_remote_helpers
697 %{py_sitescriptdir}/git_remote_helpers/*.py[co]
698 %dir %{py_sitescriptdir}/git_remote_helpers/git
699 %{py_sitescriptdir}/git_remote_helpers/git/*.py[co]
700 %if "%{py_ver}" > "2.4"
701 %{py_sitescriptdir}/git_remote_helpers*.egg-info
702 %endif
703 %if %{with doc}
704 %{_mandir}/man1/git-remote-helpers.1*
705 %endif
706
707 %files -n vim-syntax-gitcommit
708 %defattr(644,root,root,755)
709 %doc contrib/vim/README
710 %{_datadir}/vim/vimfiles/syntax/*.vim
This page took 0.077457 seconds and 4 git commands to generate.