]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
- fix rev-list for coqueal commits
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform make test
4 %bcond_with     tests_cvs       # perform tests which use CVS
5 %bcond_without  tests_svn       # perform tests which use subversion
6 %bcond_without  doc             # skip building/packaging docs/manuals (takes some time)
7 %bcond_without  pcre            # perl-compatible regexes support
8
9 %include        /usr/lib/rpm/macros.perl
10 Summary:        Distributed version control system focused on speed, effectivity and usability
11 Summary(pl.UTF-8):      Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
12 Name:           git-core
13 Version:        1.8.2
14 Release:        2
15 License:        GPL v2
16 Group:          Development/Tools
17 Source0:        http://git-core.googlecode.com/files/git-%{version}.tar.gz
18 # Source0-md5:  210834d73c857931c3da34a65eb3e597
19 Source1:        %{name}-gitweb.conf
20 Source2:        %{name}-gitweb-httpd.conf
21 Source3:        %{name}-gitweb-lighttpd.conf
22 Source4:        %{name}.sysconfig
23 Source5:        %{name}.inet
24 Source6:        %{name}.init
25 Patch0:         %{name}-tests.patch
26 Patch1:         %{name}-key-bindings.patch
27 Patch2:         %{name}-sysconfdir.patch
28 Patch3:         cherry-picked-commitlog.patch
29 Patch4:         %{name}-coequal.patch
30 URL:            http://git-scm.com/
31 BuildRequires:  autoconf >= 2.59
32 BuildRequires:  automake
33 BuildRequires:  curl-devel
34 BuildRequires:  expat-devel
35 BuildRequires:  gettext-devel
36 BuildRequires:  openssl-devel
37 %{?with_pcre:BuildRequires:     pcre-devel}
38 BuildRequires:  perl-Error > 0.15
39 BuildRequires:  perl-base
40 BuildRequires:  python-devel
41 BuildRequires:  rpm-perlprov >= 4.1-13
42 BuildRequires:  rpm-pythonprov
43 BuildRequires:  rpmbuild(macros) >= 1.264
44 BuildRequires:  tcl
45 BuildRequires:  zlib-devel
46 %if %{with doc}
47 BuildRequires:  asciidoc >= 7.1.2-3
48 BuildRequires:  docbook-dtd45-xml
49 BuildRequires:  xmlto
50 %endif
51 %if %{with tests}
52 %if %{with tests_cvs}
53 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
54 BuildRequires:  cvs-gnu-client < 1.13
55 BuildRequires:  cvs-gnu-client >= 1.12
56 %endif
57 %{?with_tests_svn:BuildRequires:  subversion}
58 Conflicts:      pdksh < 5.2.14-46
59 %endif
60 Requires:       coreutils
61 Requires:       diffutils
62 Requires:       findutils
63 Requires:       grep
64 Requires:       openssh-clients
65 Requires:       perl-Error
66 Requires:       perl-Git = %{version}-%{release}
67 Requires:       sed
68 Suggests:       git-core-cvs
69 Suggests:       git-core-svn
70 Suggests:       less
71 Suggests:       rsync
72 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74 # html docs have links to txt files
75 %define         _noautocompressdoc      *.txt
76
77 %define         webapp          gitweb
78 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
79 %define         appdir          %{_datadir}/%{webapp}
80 %define         cgibindir       %{_prefix}/lib/cgi-bin
81
82 %description
83 "git" can mean anything, depending on your mood.
84
85 - random three-letter combination that is pronounceable, and not
86   actually used by any common UNIX command. The fact that it is a
87   mispronunciation of "get" may or may not be relevant.
88 - stupid. contemptible and despicable. simple. Take your pick from the
89   dictionary of slang.
90 - "global information tracker": you're in a good mood, and it actually
91   works for you. Angels sing, and a light suddenly fills the room.
92 - "goddamn idiotic truckload of sh*t": when it breaks
93
94 This is a stupid (but extremely fast) directory content manager. It
95 doesn't do a whole lot, but what it 'does' do is track directory
96 contents efficiently.
97
98 %description -l pl.UTF-8
99 "git" może oznaczać cokolwiek, w zależności od nastroju.
100
101 - losową kombinację trzech liter, która jest wymawialna i właściwie
102   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
103   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
104 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
105 - "global information tracker" (narzędzie do globalnego śledzenia
106   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
107   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
108 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
109   g*) - kiedy się zepsuje.
110
111 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
112 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
113 katalogu.
114
115 %package doc
116 Summary:        Documentation for git-core
117 Summary(pl.UTF-8):      Dokumentacja do git-core
118 Group:          Documentation
119
120 %description doc
121 Documentation for git-core.
122
123 %description doc -l pl.UTF-8
124 Dokumentacja do git-core.
125
126 %description doc -l fr.UTF-8
127 Javadoc pour git-core.
128
129 %package daemon-inetd
130 Summary:        Files necessary to run git-daemon as an inetd service
131 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
132 Group:          Networking/Daemons
133 Requires:       %{name} = %{version}-%{release}
134 Requires:       setup >= 2.4.11-1
135 Provides:       git-core-daemon
136 Obsoletes:      git-core-daemon
137 Obsoletes:      git-core-daemon-standalone
138
139 %description daemon-inetd
140 Git-daemon is a really simple TCP git daemon that can serve git
141 repositories. This package provides all necessarry files to run
142 git-daemon as an inetd service.
143
144 %description daemon-inetd -l pl.UTF-8
145 Git-daemon to prosty demon git korzystający z protokołu TCP do
146 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
147 do uruchomienia git-demona w trybie usługi inetd.
148
149 %package daemon-standalone
150 Summary:        Files necessary to run git-daemon as a standalone service
151 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
152 Group:          Networking/Daemons
153 Requires:       %{name} = %{version}-%{release}
154 Provides:       git-core-daemon
155 Obsoletes:      git-core-daemon
156 Obsoletes:      git-core-daemon-inetd
157
158 %description daemon-standalone
159 Git-daemon is a really simple TCP git daemon that can serve git
160 repositories. This package provides all necessarry files to run
161 git-daemon as an standalone service.
162
163 %description daemon-standalone -l pl.UTF-8
164 Git-daemon to prosty demon git korzystający z protokołu TCP do
165 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
166 do uruchomienia git-daemona w trybie usługi samodzielnej.
167
168 %package devel
169 Summary:        Git library with header files
170 Summary(pl.UTF-8):      Biblioteka Gita oraz pliki nagłówkowe
171 Group:          Development/Libraries
172 Requires:       zlib-devel
173
174 %description devel
175 Git library with header files.
176
177 %description devel -l pl.UTF-8
178 Biblioteka Gita oraz pliki nagłówkowe.
179
180 %package gitk
181 Summary:        Tcl/Tk interface to the Git version control system
182 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
183 Group:          Development/Tools
184 Requires:       %{name} = %{version}-%{release}
185 Requires:       tk
186
187 %description gitk
188 gitk displays changes in a repository or a selected set of commits.
189 This includes visualizing the commit graph, showing information
190 related to each commit, and the files in the trees of each revision.
191
192 Historically, gitk was the first repository browser. It's written in
193 Tcl/Tk and started off in a separate repository but was later merged
194 into the main git repository.
195
196 %description gitk -l pl.UTF-8
197 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
198 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
199 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
200
201 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
202 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
203 osobnym repozytorium, ale z czasem został włączony do głównego
204 repozytorium gita.
205
206 %package gitweb
207 Summary:        Web frontend to git
208 Summary(pl.UTF-8):      Frontend WWW do gita
209 Group:          Development/Tools
210 Requires:       %{name} = %{version}-%{release}
211 Requires:       webapps
212 Requires:       webserver(alias)
213 Requires:       webserver(cgi)
214 Suggests:       webserver(setenv)
215
216 %description gitweb
217 This package provides a web interface for browsing git repositories.
218
219 %description gitweb -l pl.UTF-8
220 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
221
222 %package gitview
223 Summary:        A GTK+ based repository browser for git
224 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
225 Group:          Development/Tools
226 Requires:       %{name} = %{version}-%{release}
227 Requires:       python >= 1:2.4
228 Requires:       python-pycairo >= 1.0
229 Requires:       python-pygobject
230 Requires:       python-pygtk-gtk >= 2:2.8
231 Suggests:       python-gnome-desktop-gtksourceview
232
233 %description gitview
234 A GTK+ based repository browser for git.
235
236 %description gitview -l pl.UTF-8
237 Oparta na GTK+ przeglądarka repozytorium gita.
238
239 %package gui
240 Summary:        Tcl/Tk interface to the Git version control system
241 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
242 Group:          Development/Tools
243 Requires:       %{name} = %{version}-%{release}
244 Requires:       tk
245 Requires:       xdg-utils
246 Suggests:       meld
247
248 %description gui
249 Displays changes in a repository or a selected set of commits. This
250 includes visualizing the commit graph, showing information related to
251 each commit, and the files in the trees of each revision.
252
253 Historically, gitk was the first repository browser. It's written in
254 Tcl/Tk and started off in a separate repository but was later merged
255 into the main git repository.
256
257 %description gui -l pl.UTF-8
258 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
259 to wizualizację grafu commitów, wyświetlanie informacji związanych z
260 każdym z commitów oraz listę plików dla każdej rewizji.
261
262 Z punktu widzenia historii, gitk był pierwszą przeglądarką
263 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
264 osobnym repozytorium, ale z czasem został włączony do głównego
265 repozytorium gita.
266
267 %package svn
268 Summary:        Subversion support for Git
269 Summary(pl.UTF-8):      Obsługa Subversion dla Gita
270 Group:          Development/Tools
271 Requires:       %{name} = %{version}-%{release}
272 Requires:       perl-Encode
273 Requires:       perl-Term-ReadKey
274
275 %description svn
276 Subversion support for Git.
277
278 %description svn -l pl.UTF-8
279 Obsługa Subversion dla Gita.
280
281 %package cvs
282 Summary:        CVS support for Git
283 Summary(pl.UTF-8):      Obsługa CVS dla Gita
284 Group:          Development/Tools
285 Requires:       %{name} = %{version}-%{release}
286 Requires:       cvsps >= 2.1-2
287 Requires:       rcs
288
289 %description cvs
290 CVS support for Git.
291
292 %description cvs -l pl.UTF-8
293 Obsługa CVS dla Gita.
294
295 %package arch
296 Summary:        Git tools for importing Arch repositories
297 Summary(pl.UTF-8):      Narzędzia Gita do importowania repozytoriów Archa
298 Group:          Development/Tools
299 Requires:       %{name} = %{version}-%{release}
300 Requires:       tla
301
302 %description arch
303 Git tools for importing Arch repositories.
304
305 %description arch -l pl.UTF-8
306 Narzędzia Gita do importowania repozytoriów Archa.
307
308 %package email
309 Summary:        Git tools for sending email
310 Summary(pl.UTF-8):      Narzędzia Gita do wysyłania poczty
311 Group:          Development/Tools
312 Requires:       %{name} = %{version}-%{release}
313
314 %description email
315 Git tools for sending email.
316
317 %description email -l pl.UTF-8
318 Narzędzia Gita do wysyłania poczty.
319
320 %package -n bash-completion-git
321 Summary:        bash-completion for git
322 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
323 Group:          Applications/Shells
324 Requires:       %{name} = %{version}-%{release}
325 Requires:       bash-completion
326
327 %description -n bash-completion-git
328 This package provides bash-completion for git.
329
330 %description -n bash-completion-git -l pl.UTF-8
331 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
332
333 %package -n perl-Git
334 Summary:        Perl interface to the Git version control system
335 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
336 Group:          Development/Languages/Perl
337 Obsoletes:      perl-git-core
338
339 %description -n perl-Git
340 This module provides Perl scripts easy way to interface the Git
341 version control system. The modules have an easy and well-tested way
342 to call arbitrary Git commands; in the future, the interface will also
343 provide specialized methods for doing easily operations which are not
344 totally trivial to do over the generic command interface.
345
346 %description -n perl-Git -l pl.UTF-8
347 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
348 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
349 dowolne polecenia Gita; w przyszłości interfejs udostępni także
350 specjalne metody do łatwego wykonywania operacji nietrywialnych do
351 wykonania przy użyciu ogólnego interfejsu poleceń.
352
353 %package -n python-Git
354 Summary:        Python Git remote helpers for non-git repositories
355 Summary(pl.UTF-8):      Pythonowe zdalne moduły pomocnicze dla repozytoriów niegitowych
356 Group:          Development/Languages/Python
357 Requires:       %{name} = %{version}-%{release}
358
359 %description -n python-Git
360 This package contains Python git_repote_helpers package - Git remote
361 helpers for non-git repositories.
362
363 %description -n python-Git -l pl.UTF-8
364 Ten pakiet zawiera pakiet Pythona git_remote_helpers - zdalne moduły
365 pomocnicze Gita dla repozytoriów niegitowych.
366
367 %package -n vim-syntax-gitcommit
368 Summary:        Vim syntax: gitcommit
369 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
370 Group:          Applications/Editors/Vim
371 Requires:       %{name} = %{version}-%{release}
372 # for _vimdatadir existence
373 Requires:       vim-rt >= 4:6.3.058-3
374
375 %description -n vim-syntax-gitcommit
376 This plugin provides syntax highlighting for git's commit messages.
377
378 %description -n vim-syntax-gitcommit -l pl.UTF-8
379 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
380
381 %prep
382 %setup -q -n git-%{version}
383 %patch0 -p1
384 %patch1 -p0
385 %patch2 -p1
386 %patch3 -p1
387 %patch4 -p1
388
389 %build
390 %{__aclocal}
391 %{__autoconf}
392 %configure \
393         --sysconfdir=%{_sysconfdir}/git-core \
394         %{?with_pcre:--with-libpcre} \
395         --with-openssl
396
397 echo "BLK_SHA1=1" >> config.mak
398
399 %{__make} \
400         INSTALLDIRS=vendor \
401         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
402         GITWEB_PROJECTROOT="/var/lib/git" \
403         GITWEB_CSS="/gitweb/gitweb.css" \
404         GITWEB_LOGO="/gitweb/git-logo.png" \
405         GITWEB_FAVICON="/gitweb/git-favicon.png" \
406         V=1
407
408 %if %{with doc}
409 %{__make} -C Documentation \
410         MAN_BASE_URL=file://%{_docdir}/%{name}-doc-%{version}/ \
411         V=1
412 %endif
413
414 %if %{with tests}
415 %if %{without tests_cvs}
416 %{__rm} t/t*cvs*.sh || :
417 %endif
418 %{!?with_tests_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
419 %endif
420
421 %install
422 rm -rf $RPM_BUILD_ROOT
423 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
424 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
425 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
426 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
427 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
428 [init]
429         templatedir = %{_sysconfdir}/%{name}/templates
430 EOF
431
432 %{__make} install \
433         INSTALLDIRS=vendor \
434         DESTDIR=$RPM_BUILD_ROOT
435
436 %if %{with doc}
437 %{__make} -C Documentation install \
438         DESTDIR=$RPM_BUILD_ROOT
439 %endif
440
441 # copy templates except sample hooks
442 cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
443 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
444
445 # header files and lib
446 cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
447 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
448 cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
449 cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
450 cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
451
452 # bash completion
453 install -d $RPM_BUILD_ROOT/etc/bash_completion.d
454 cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT/etc/bash_completion.d
455
456 # vim syntax
457 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
458 cat > $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax/gitcommit.vim << 'EOF'
459 autocmd BufNewFile,BufRead *.git/COMMIT_EDITMSG    setf gitcommit
460 autocmd BufNewFile,BufRead *.git/config,.gitconfig setf gitconfig
461 autocmd BufNewFile,BufRead git-rebase-todo         setf gitrebase
462 autocmd BufNewFile,BufRead .msg.[0-9]*
463         \ if getline(1) =~ '^From.*# This line is ignored.$' |
464         \   setf gitsendemail |
465         \ endif
466 autocmd BufNewFile,BufRead *.git/**
467         \ if getline(1) =~ '^\x\{40\}\>\|^ref: ' |
468         \   setf git |
469         \ endif
470 EOF
471
472 # gitweb
473 mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
474 ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
475 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
476 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
477 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
478 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
479
480 # gitview
481 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
482
483 # git-daemon related files
484 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
485 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
486 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
487
488 # paths cleanup
489 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
490 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
491
492 # hardlink
493 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
494 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
495 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
496 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
497
498 # remove unneeded files
499 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
500 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
501 %py_postclean
502
503 mv $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
504 %find_lang git
505
506 %clean
507 rm -rf $RPM_BUILD_ROOT
508
509 %post daemon-inetd
510 %service -q rc-inetd reload
511
512 %postun daemon-inetd
513 if [ "$1" = "0" ]; then
514         %service -q rc-inetd reload
515 fi
516
517 %post daemon-standalone
518 /sbin/chkconfig --add git-daemon
519 %service git-daemon restart "git-daemon"
520
521 %preun daemon-standalone
522 if [ "$1" = "0" ]; then
523         %service git-daemon stop
524         /sbin/chkconfig --del git-daemon
525 fi
526
527 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
528 %webapp_register apache %{webapp}
529
530 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
531 %webapp_unregister apache %{webapp}
532
533 %triggerin gitweb -- apache < 2.2.0, apache-base
534 %webapp_register httpd %{webapp}
535
536 %triggerun gitweb -- apache < 2.2.0, apache-base
537 %webapp_unregister httpd %{webapp}
538
539 %triggerin gitweb -- lighttpd
540 %webapp_register lighttpd %{webapp}
541
542 %triggerun gitweb -- lighttpd
543 %webapp_unregister lighttpd %{webapp}
544
545 %files -f git.lang
546 %defattr(644,root,root,755)
547 %doc README contrib
548 %attr(755,root,root) %{_bindir}/git
549 %attr(755,root,root) %{_bindir}/git-receive-pack
550 %attr(755,root,root) %{_bindir}/git-shell
551 %attr(755,root,root) %{_bindir}/git-upload-archive
552 %attr(755,root,root) %{_bindir}/git-upload-pack
553 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
554
555 %if %{with doc}
556 %{_mandir}/man1/git-*.1*
557 %exclude %{_mandir}/man1/git-archimport.1*
558 %exclude %{_mandir}/man1/git-svn.1*
559 %exclude %{_mandir}/man1/git-cvs*.1*
560 %exclude %{_mandir}/man1/*email*.1*
561 %exclude %{_mandir}/man1/gitremote-helpers.1*
562 %{_mandir}/man1/git.1*
563 %{_mandir}/man5/gitattributes.5*
564 %{_mandir}/man5/githooks.5*
565 %{_mandir}/man5/gitignore.5*
566 %{_mandir}/man5/gitmodules.5*
567 %{_mandir}/man5/gitrepository-layout.5*
568 %{_mandir}/man7/gitcli.7*
569 %{_mandir}/man7/gitcore-tutorial.7*
570 %{_mandir}/man7/gitcredentials.7*
571 %{_mandir}/man7/gitdiffcore.7*
572 %{_mandir}/man7/gitglossary.7*
573 %{_mandir}/man7/gitnamespaces.7*
574 %{_mandir}/man7/gitrevisions.7*
575 %{_mandir}/man7/gittutorial-2.7*
576 %{_mandir}/man7/gittutorial.7*
577 %{_mandir}/man7/gitworkflows.7*
578 %endif
579
580 %dir %{_libdir}/%{name}
581 %attr(755,root,root) %{_libdir}/%{name}/*-*
582 %attr(755,root,root) %{_libdir}/%{name}/git
583 %{_libdir}/%{name}/mergetools
584
585 %exclude %{_libdir}/%{name}/git-gui
586 %exclude %{_libdir}/%{name}/git-svn
587 %exclude %{_libdir}/%{name}/git-archimport
588 %exclude %{_libdir}/%{name}/git-cvs*
589 %exclude %{_libdir}/%{name}/git-instaweb
590 %exclude %{_libdir}/%{name}/git-remote-testpy
591 %exclude %{_libdir}/%{name}/git-remote-testsvn
592 %exclude %{_libdir}/%{name}/*email*
593
594 %{_datadir}/%{name}
595
596 %{_localstatedir}/lib/git
597
598 %if %{with doc}
599 %files doc
600 %defattr(644,root,root,755)
601 %doc Documentation/RelNotes*
602 %doc Documentation/*.html Documentation/howto Documentation/technical
603 %endif
604
605 %files daemon-inetd
606 %defattr(644,root,root,755)
607 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
608
609 %files daemon-standalone
610 %defattr(644,root,root,755)
611 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
612 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
613
614 %files devel
615 %defattr(644,root,root,755)
616 %{_includedir}/%{name}
617 %{_libdir}/libgit.a
618 %{_libdir}/libgit_xdiff.a
619
620 %files gitk
621 %defattr(644,root,root,755)
622 %if %{with doc}
623 %{_mandir}/man1/gitk.1*
624 %endif
625 %attr(755,root,root) %{_bindir}/gitk
626 %dir %{_datadir}/gitk
627 %dir %{_datadir}/gitk/lib
628 %dir %{_datadir}/gitk/lib/msgs
629 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
630 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
631 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
632 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
633 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
634 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
635 %lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
636 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
637 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
638
639 %files gitweb
640 %defattr(644,root,root,755)
641 %doc gitweb/{README,INSTALL}
642 %dir %{webappdir}
643 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
644 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
645 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
646 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
647 %attr(755,root,root) %{cgibindir}/gitweb.cgi
648 %{appdir}
649 %attr(755,root,root) %{_libdir}/%{name}/git-instaweb
650 %if %{with doc}
651 %{_mandir}/man1/gitweb.1*
652 %{_mandir}/man5/gitweb.conf.5*
653 %endif
654
655 %files gitview
656 %defattr(644,root,root,755)
657 %doc contrib/gitview/gitview.txt
658 %attr(755,root,root) %{_bindir}/gitview
659
660 %files gui
661 %defattr(644,root,root,755)
662 %attr(755,root,root) %{_libdir}/%{name}/git-gui
663 %dir %{_datadir}/git-gui
664 %dir %{_datadir}/git-gui/lib
665 %dir %{_datadir}/git-gui/lib/msgs
666 %{_datadir}/git-gui/lib/git-gui.ico
667 %{_datadir}/git-gui/lib/tclIndex
668 %{_datadir}/git-gui/lib/*.js
669 %{_datadir}/git-gui/lib/*.tcl
670 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
671 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
672 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
673 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
674 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
675 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
676 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
677 %lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
678 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
679 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
680 %lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
681
682 %files svn
683 %defattr(644,root,root,755)
684 %attr(755,root,root) %{_libdir}/%{name}/git-svn
685 %attr(755,root,root) %{_libdir}/%{name}/git-remote-testsvn
686 %{perl_vendorlib}/Git/SVN
687 %{perl_vendorlib}/Git/SVN.pm
688 %if %{with doc}
689 %{_mandir}/man1/git-svn.1*
690 %endif
691
692 %files cvs
693 %defattr(644,root,root,755)
694 %attr(755,root,root) %{_bindir}/git-cvsserver
695 %attr(755,root,root) %{_libdir}/%{name}/git-cvs*
696 %if %{with doc}
697 %{_mandir}/man1/git-cvs*.1*
698 %{_mandir}/man7/gitcvs-migration.7*
699 %endif
700
701 %files arch
702 %defattr(644,root,root,755)
703 %attr(755,root,root) %{_libdir}/%{name}/git-archimport
704 %if %{with doc}
705 %{_mandir}/man1/git-archimport.1*
706 %endif
707
708 %files email
709 %defattr(644,root,root,755)
710 %attr(755,root,root) %{_libdir}/%{name}/*email*
711 %if %{with doc}
712 %{_mandir}/man1/*email*.1*
713 %endif
714
715 %files -n bash-completion-git
716 %defattr(644,root,root,755)
717 /etc/bash_completion.d/git-completion.bash
718
719 %files -n perl-Git
720 %defattr(644,root,root,755)
721 %{perl_vendorlib}/Git.pm
722 %dir %{perl_vendorlib}/Git
723 %{perl_vendorlib}/Git/I18N.pm
724 %{perl_vendorlib}/Git/IndexInfo.pm
725 %{_mandir}/man3/Git*.3pm*
726
727 %files -n python-Git
728 %defattr(644,root,root,755)
729 %attr(755,root,root) %{_libdir}/%{name}/git-remote-testpy
730 %dir %{py_sitescriptdir}/git_remote_helpers
731 %{py_sitescriptdir}/git_remote_helpers/*.py[co]
732 %dir %{py_sitescriptdir}/git_remote_helpers/git
733 %{py_sitescriptdir}/git_remote_helpers/git/*.py[co]
734 %if "%{py_ver}" > "2.4"
735 %{py_sitescriptdir}/git_remote_helpers*.egg-info
736 %endif
737 %if %{with doc}
738 %{_mandir}/man1/gitremote-helpers.1*
739 %endif
740
741 %files -n vim-syntax-gitcommit
742 %defattr(644,root,root,755)
743 %doc contrib/vim/README
744 %{_datadir}/vim/vimfiles/syntax/gitcommit.vim
This page took 0.100157 seconds and 4 git commands to generate.