]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
- hardcode completions path to avoid bash+bash-completion BR
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform make test
4 %bcond_with     tests_cvs       # perform tests which use CVS
5 %bcond_without  tests_svn       # perform tests which use subversion
6 %bcond_without  doc             # skip building/packaging docs/manuals (takes some time)
7 %bcond_without  pcre            # perl-compatible regexes support
8
9 %include        /usr/lib/rpm/macros.perl
10 Summary:        Distributed version control system focused on speed, effectivity and usability
11 Summary(pl.UTF-8):      Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
12 Name:           git-core
13 Version:        1.8.3.1
14 Release:        1
15 License:        GPL v2
16 Group:          Development/Tools
17 Source0:        http://git-core.googlecode.com/files/git-%{version}.tar.gz
18 # Source0-md5:  35401b410e7f248b13e35a1069aca2e2
19 Source1:        %{name}-gitweb.conf
20 Source2:        %{name}-gitweb-apache.conf
21 Source3:        %{name}-gitweb-lighttpd.conf
22 Source4:        %{name}.sysconfig
23 Source5:        %{name}.inet
24 Source6:        %{name}.init
25 Source7:        %{name}-gitweb-httpd.conf
26 Patch0:         %{name}-tests.patch
27 Patch1:         %{name}-key-bindings.patch
28 Patch2:         %{name}-sysconfdir.patch
29 Patch3:         cherry-picked-commitlog.patch
30 URL:            http://git-scm.com/
31 BuildRequires:  autoconf >= 2.59
32 BuildRequires:  automake
33 BuildRequires:  curl-devel
34 BuildRequires:  expat-devel
35 BuildRequires:  gettext-devel
36 BuildRequires:  openssl-devel
37 %{?with_pcre:BuildRequires:     pcre-devel}
38 BuildRequires:  perl-Error > 0.15
39 BuildRequires:  perl-base
40 BuildRequires:  python-devel
41 BuildRequires:  rpm-perlprov >= 4.1-13
42 BuildRequires:  rpm-pythonprov
43 BuildRequires:  rpmbuild(macros) >= 1.264
44 BuildRequires:  tcl
45 BuildRequires:  zlib-devel
46 %if %{with doc}
47 BuildRequires:  asciidoc >= 7.1.2-3
48 BuildRequires:  docbook-dtd45-xml
49 BuildRequires:  xmlto
50 %endif
51 %if %{with tests}
52 %if %{with tests_cvs}
53 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
54 BuildRequires:  cvs-gnu-client < 1.13
55 BuildRequires:  cvs-gnu-client >= 1.12
56 %endif
57 %{?with_tests_svn:BuildRequires:  subversion}
58 Conflicts:      pdksh < 5.2.14-46
59 %endif
60 Requires:       coreutils
61 Requires:       diffutils
62 Requires:       findutils
63 Requires:       grep
64 Requires:       openssh-clients
65 Requires:       perl-Error
66 Requires:       perl-Git = %{version}-%{release}
67 Requires:       sed
68 Suggests:       git-core-cvs
69 Suggests:       git-core-svn
70 Suggests:       less
71 Suggests:       rsync
72 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74 # html docs have links to txt files
75 %define         _noautocompressdoc      *.txt
76
77 %define         webapp          gitweb
78 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
79 %define         appdir          %{_datadir}/%{webapp}
80 %define         cgibindir       %{_prefix}/lib/cgi-bin
81 %define         bash_compdir    %{_datadir}/bash-completion/completions
82
83 %description
84 "git" can mean anything, depending on your mood.
85
86 - random three-letter combination that is pronounceable, and not
87   actually used by any common UNIX command. The fact that it is a
88   mispronunciation of "get" may or may not be relevant.
89 - stupid. contemptible and despicable. simple. Take your pick from the
90   dictionary of slang.
91 - "global information tracker": you're in a good mood, and it actually
92   works for you. Angels sing, and a light suddenly fills the room.
93 - "goddamn idiotic truckload of sh*t": when it breaks
94
95 This is a stupid (but extremely fast) directory content manager. It
96 doesn't do a whole lot, but what it 'does' do is track directory
97 contents efficiently.
98
99 %description -l pl.UTF-8
100 "git" może oznaczać cokolwiek, w zależności od nastroju.
101
102 - losową kombinację trzech liter, która jest wymawialna i właściwie
103   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
104   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
105 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
106 - "global information tracker" (narzędzie do globalnego śledzenia
107   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
108   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
109 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
110   g*) - kiedy się zepsuje.
111
112 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
113 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
114 katalogu.
115
116 %package doc
117 Summary:        Documentation for git-core
118 Summary(pl.UTF-8):      Dokumentacja do git-core
119 Group:          Documentation
120
121 %description doc
122 Documentation for git-core.
123
124 %description doc -l pl.UTF-8
125 Dokumentacja do git-core.
126
127 %description doc -l fr.UTF-8
128 Javadoc pour git-core.
129
130 %package daemon-inetd
131 Summary:        Files necessary to run git-daemon as an inetd service
132 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
133 Group:          Networking/Daemons
134 Requires:       %{name} = %{version}-%{release}
135 Requires:       setup >= 2.4.11-1
136 Provides:       git-core-daemon
137 Obsoletes:      git-core-daemon
138 Obsoletes:      git-core-daemon-standalone
139
140 %description daemon-inetd
141 Git-daemon is a really simple TCP git daemon that can serve git
142 repositories. This package provides all necessarry files to run
143 git-daemon as an inetd service.
144
145 %description daemon-inetd -l pl.UTF-8
146 Git-daemon to prosty demon git korzystający z protokołu TCP do
147 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
148 do uruchomienia git-demona w trybie usługi inetd.
149
150 %package daemon-standalone
151 Summary:        Files necessary to run git-daemon as a standalone service
152 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
153 Group:          Networking/Daemons
154 Requires:       %{name} = %{version}-%{release}
155 Provides:       git-core-daemon
156 Obsoletes:      git-core-daemon
157 Obsoletes:      git-core-daemon-inetd
158
159 %description daemon-standalone
160 Git-daemon is a really simple TCP git daemon that can serve git
161 repositories. This package provides all necessarry files to run
162 git-daemon as an standalone service.
163
164 %description daemon-standalone -l pl.UTF-8
165 Git-daemon to prosty demon git korzystający z protokołu TCP do
166 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
167 do uruchomienia git-daemona w trybie usługi samodzielnej.
168
169 %package devel
170 Summary:        Git library with header files
171 Summary(pl.UTF-8):      Biblioteka Gita oraz pliki nagłówkowe
172 Group:          Development/Libraries
173 Requires:       zlib-devel
174
175 %description devel
176 Git library with header files.
177
178 %description devel -l pl.UTF-8
179 Biblioteka Gita oraz pliki nagłówkowe.
180
181 %package gitk
182 Summary:        Tcl/Tk interface to the Git version control system
183 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
184 Group:          Development/Tools
185 Requires:       %{name} = %{version}-%{release}
186 Requires:       tk
187
188 %description gitk
189 gitk displays changes in a repository or a selected set of commits.
190 This includes visualizing the commit graph, showing information
191 related to each commit, and the files in the trees of each revision.
192
193 Historically, gitk was the first repository browser. It's written in
194 Tcl/Tk and started off in a separate repository but was later merged
195 into the main git repository.
196
197 %description gitk -l pl.UTF-8
198 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
199 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
200 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
201
202 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
203 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
204 osobnym repozytorium, ale z czasem został włączony do głównego
205 repozytorium gita.
206
207 %package gitweb
208 Summary:        Web frontend to git
209 Summary(pl.UTF-8):      Frontend WWW do gita
210 Group:          Development/Tools
211 Requires:       %{name} = %{version}-%{release}
212 Requires:       webapps
213 Requires:       webserver(alias)
214 Requires:       webserver(cgi)
215 Suggests:       webserver(setenv)
216 Conflicts:      apache-base < 2.4.0-1
217
218 %description gitweb
219 This package provides a web interface for browsing git repositories.
220
221 %description gitweb -l pl.UTF-8
222 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
223
224 %package gitview
225 Summary:        A GTK+ based repository browser for git
226 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
227 Group:          Development/Tools
228 Requires:       %{name} = %{version}-%{release}
229 Requires:       python >= 1:2.4
230 Requires:       python-pycairo >= 1.0
231 Requires:       python-pygobject
232 Requires:       python-pygtk-gtk >= 2:2.8
233 Suggests:       python-gnome-desktop-gtksourceview
234
235 %description gitview
236 A GTK+ based repository browser for git.
237
238 %description gitview -l pl.UTF-8
239 Oparta na GTK+ przeglądarka repozytorium gita.
240
241 %package gui
242 Summary:        Tcl/Tk interface to the Git version control system
243 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
244 Group:          Development/Tools
245 Requires:       %{name} = %{version}-%{release}
246 Requires:       tk
247 Requires:       xdg-utils
248 Suggests:       meld
249
250 %description gui
251 Displays changes in a repository or a selected set of commits. This
252 includes visualizing the commit graph, showing information related to
253 each commit, and the files in the trees of each revision.
254
255 Historically, gitk was the first repository browser. It's written in
256 Tcl/Tk and started off in a separate repository but was later merged
257 into the main git repository.
258
259 %description gui -l pl.UTF-8
260 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
261 to wizualizację grafu commitów, wyświetlanie informacji związanych z
262 każdym z commitów oraz listę plików dla każdej rewizji.
263
264 Z punktu widzenia historii, gitk był pierwszą przeglądarką
265 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
266 osobnym repozytorium, ale z czasem został włączony do głównego
267 repozytorium gita.
268
269 %package svn
270 Summary:        Subversion support for Git
271 Summary(pl.UTF-8):      Obsługa Subversion dla Gita
272 Group:          Development/Tools
273 Requires:       %{name} = %{version}-%{release}
274 Requires:       perl-Encode
275 Requires:       perl-Term-ReadKey
276
277 %description svn
278 Subversion support for Git.
279
280 %description svn -l pl.UTF-8
281 Obsługa Subversion dla Gita.
282
283 %package cvs
284 Summary:        CVS support for Git
285 Summary(pl.UTF-8):      Obsługa CVS dla Gita
286 Group:          Development/Tools
287 Requires:       %{name} = %{version}-%{release}
288 Requires:       cvsps >= 2.1-2
289 Requires:       rcs
290
291 %description cvs
292 CVS support for Git.
293
294 %description cvs -l pl.UTF-8
295 Obsługa CVS dla Gita.
296
297 %package arch
298 Summary:        Git tools for importing Arch repositories
299 Summary(pl.UTF-8):      Narzędzia Gita do importowania repozytoriów Archa
300 Group:          Development/Tools
301 Requires:       %{name} = %{version}-%{release}
302 Requires:       tla
303
304 %description arch
305 Git tools for importing Arch repositories.
306
307 %description arch -l pl.UTF-8
308 Narzędzia Gita do importowania repozytoriów Archa.
309
310 %package email
311 Summary:        Git tools for sending email
312 Summary(pl.UTF-8):      Narzędzia Gita do wysyłania poczty
313 Group:          Development/Tools
314 Requires:       %{name} = %{version}-%{release}
315
316 %description email
317 Git tools for sending email.
318
319 %description email -l pl.UTF-8
320 Narzędzia Gita do wysyłania poczty.
321
322 %package -n bash-completion-git
323 Summary:        bash-completion for git
324 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
325 Group:          Applications/Shells
326 Requires:       %{name} = %{version}-%{release}
327 Requires:       bash-completion >= 2.0
328
329 %description -n bash-completion-git
330 This package provides bash-completion for git.
331
332 %description -n bash-completion-git -l pl.UTF-8
333 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
334
335 %package -n perl-Git
336 Summary:        Perl interface to the Git version control system
337 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
338 Group:          Development/Languages/Perl
339 Obsoletes:      perl-git-core
340
341 %description -n perl-Git
342 This module provides Perl scripts easy way to interface the Git
343 version control system. The modules have an easy and well-tested way
344 to call arbitrary Git commands; in the future, the interface will also
345 provide specialized methods for doing easily operations which are not
346 totally trivial to do over the generic command interface.
347
348 %description -n perl-Git -l pl.UTF-8
349 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
350 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
351 dowolne polecenia Gita; w przyszłości interfejs udostępni także
352 specjalne metody do łatwego wykonywania operacji nietrywialnych do
353 wykonania przy użyciu ogólnego interfejsu poleceń.
354
355 %package -n python-Git
356 Summary:        Python Git remote helpers for non-git repositories
357 Summary(pl.UTF-8):      Pythonowe zdalne moduły pomocnicze dla repozytoriów niegitowych
358 Group:          Development/Languages/Python
359 Requires:       %{name} = %{version}-%{release}
360
361 %description -n python-Git
362 This package contains Python git_repote_helpers package - Git remote
363 helpers for non-git repositories.
364
365 %description -n python-Git -l pl.UTF-8
366 Ten pakiet zawiera pakiet Pythona git_remote_helpers - zdalne moduły
367 pomocnicze Gita dla repozytoriów niegitowych.
368
369 %package -n vim-syntax-gitcommit
370 Summary:        Vim syntax: gitcommit
371 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
372 Group:          Applications/Editors/Vim
373 Requires:       %{name} = %{version}-%{release}
374 # for _vimdatadir existence
375 Requires:       vim-rt >= 4:6.3.058-3
376
377 %description -n vim-syntax-gitcommit
378 This plugin provides syntax highlighting for git's commit messages.
379
380 %description -n vim-syntax-gitcommit -l pl.UTF-8
381 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
382
383 %prep
384 %setup -q -n git-%{version}
385 %patch0 -p1
386 %patch1 -p0
387 %patch2 -p1
388 %patch3 -p1
389
390 %build
391 %{__aclocal}
392 %{__autoconf}
393 %configure \
394         --sysconfdir=%{_sysconfdir}/git-core \
395         %{?with_pcre:--with-libpcre} \
396         --with-openssl
397
398 echo "BLK_SHA1=1" >> config.mak
399
400 %{__make} \
401         INSTALLDIRS=vendor \
402         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
403         GITWEB_PROJECTROOT="/var/lib/git" \
404         GITWEB_CSS="/gitweb/gitweb.css" \
405         GITWEB_LOGO="/gitweb/git-logo.png" \
406         GITWEB_FAVICON="/gitweb/git-favicon.png" \
407         V=1
408
409 %if %{with doc}
410 %{__make} -C Documentation \
411         MAN_BASE_URL=file://%{_docdir}/%{name}-doc-%{version}/ \
412         V=1
413 %endif
414
415 %if %{with tests}
416 %if %{without tests_cvs}
417 %{__rm} t/t*cvs*.sh || :
418 %endif
419 %{!?with_tests_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
420 %endif
421
422 %install
423 rm -rf $RPM_BUILD_ROOT
424 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
425 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
426 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
427 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
428 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
429 [init]
430         templatedir = %{_sysconfdir}/%{name}/templates
431 EOF
432
433 %{__make} install \
434         INSTALLDIRS=vendor \
435         DESTDIR=$RPM_BUILD_ROOT
436
437 %if %{with doc}
438 %{__make} -C Documentation install \
439         DESTDIR=$RPM_BUILD_ROOT
440 %endif
441
442 # copy templates except sample hooks
443 cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
444 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
445
446 # header files and lib
447 cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
448 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
449 cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
450 cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
451 cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
452
453 # bash completion
454 install -d $RPM_BUILD_ROOT%{bash_compdir}
455 cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{bash_compdir}/git
456
457 # vim syntax
458 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
459 cat > $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax/gitcommit.vim << 'EOF'
460 autocmd BufNewFile,BufRead *.git/COMMIT_EDITMSG    setf gitcommit
461 autocmd BufNewFile,BufRead *.git/config,.gitconfig setf gitconfig
462 autocmd BufNewFile,BufRead git-rebase-todo         setf gitrebase
463 autocmd BufNewFile,BufRead .msg.[0-9]*
464         \ if getline(1) =~ '^From.*# This line is ignored.$' |
465         \   setf gitsendemail |
466         \ endif
467 autocmd BufNewFile,BufRead *.git/**
468         \ if getline(1) =~ '^\x\{40\}\>\|^ref: ' |
469         \   setf git |
470         \ endif
471 EOF
472
473 # gitweb
474 mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
475 ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
476 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
477 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
478 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
479 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
480
481 # gitview
482 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
483
484 # git-daemon related files
485 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
486 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
487 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
488
489 # paths cleanup
490 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
491 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
492
493 # hardlink
494 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
495 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
496 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
497 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
498
499 # remove unneeded files
500 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
501 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
502 %py_postclean
503
504 mv $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
505 %find_lang git
506
507 %clean
508 rm -rf $RPM_BUILD_ROOT
509
510 %post daemon-inetd
511 %service -q rc-inetd reload
512
513 %postun daemon-inetd
514 if [ "$1" = "0" ]; then
515         %service -q rc-inetd reload
516 fi
517
518 %post daemon-standalone
519 /sbin/chkconfig --add git-daemon
520 %service git-daemon restart "git-daemon"
521
522 %preun daemon-standalone
523 if [ "$1" = "0" ]; then
524         %service git-daemon stop
525         /sbin/chkconfig --del git-daemon
526 fi
527
528 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
529 %webapp_register apache %{webapp}
530
531 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
532 %webapp_unregister apache %{webapp}
533
534 %triggerin gitweb -- apache-base
535 %webapp_register httpd %{webapp}
536
537 %triggerun gitweb -- apache-base
538 %webapp_unregister httpd %{webapp}
539
540 %triggerin gitweb -- lighttpd
541 %webapp_register lighttpd %{webapp}
542
543 %triggerun gitweb -- lighttpd
544 %webapp_unregister lighttpd %{webapp}
545
546 %files -f git.lang
547 %defattr(644,root,root,755)
548 %doc README contrib
549 %attr(755,root,root) %{_bindir}/git
550 %attr(755,root,root) %{_bindir}/git-receive-pack
551 %attr(755,root,root) %{_bindir}/git-shell
552 %attr(755,root,root) %{_bindir}/git-upload-archive
553 %attr(755,root,root) %{_bindir}/git-upload-pack
554 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
555
556 %if %{with doc}
557 %{_mandir}/man1/git-*.1*
558 %exclude %{_mandir}/man1/git-archimport.1*
559 %exclude %{_mandir}/man1/git-svn.1*
560 %exclude %{_mandir}/man1/git-cvs*.1*
561 %exclude %{_mandir}/man1/*email*.1*
562 %exclude %{_mandir}/man1/gitremote-helpers.1*
563 %{_mandir}/man1/git.1*
564 %{_mandir}/man5/gitattributes.5*
565 %{_mandir}/man5/githooks.5*
566 %{_mandir}/man5/gitignore.5*
567 %{_mandir}/man5/gitmodules.5*
568 %{_mandir}/man5/gitrepository-layout.5*
569 %{_mandir}/man7/gitcli.7*
570 %{_mandir}/man7/gitcore-tutorial.7*
571 %{_mandir}/man7/gitcredentials.7*
572 %{_mandir}/man7/gitdiffcore.7*
573 %{_mandir}/man7/gitglossary.7*
574 %{_mandir}/man7/gitnamespaces.7*
575 %{_mandir}/man7/gitrevisions.7*
576 %{_mandir}/man7/gittutorial-2.7*
577 %{_mandir}/man7/gittutorial.7*
578 %{_mandir}/man7/gitworkflows.7*
579 %endif
580
581 %dir %{_libdir}/%{name}
582 %attr(755,root,root) %{_libdir}/%{name}/*-*
583 %attr(755,root,root) %{_libdir}/%{name}/git
584 %{_libdir}/%{name}/mergetools
585
586 %exclude %{_libdir}/%{name}/git-gui
587 %exclude %{_libdir}/%{name}/git-svn
588 %exclude %{_libdir}/%{name}/git-archimport
589 %exclude %{_libdir}/%{name}/git-cvs*
590 %exclude %{_libdir}/%{name}/git-instaweb
591 %exclude %{_libdir}/%{name}/git-remote-testpy
592 %exclude %{_libdir}/%{name}/git-remote-testsvn
593 %exclude %{_libdir}/%{name}/*email*
594
595 %{_datadir}/%{name}
596
597 %{_localstatedir}/lib/git
598
599 %if %{with doc}
600 %files doc
601 %defattr(644,root,root,755)
602 %doc Documentation/RelNotes*
603 %doc Documentation/*.html Documentation/howto Documentation/technical
604 %endif
605
606 %files daemon-inetd
607 %defattr(644,root,root,755)
608 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
609
610 %files daemon-standalone
611 %defattr(644,root,root,755)
612 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
613 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
614
615 %files devel
616 %defattr(644,root,root,755)
617 %{_includedir}/%{name}
618 %{_libdir}/libgit.a
619 %{_libdir}/libgit_xdiff.a
620
621 %files gitk
622 %defattr(644,root,root,755)
623 %if %{with doc}
624 %{_mandir}/man1/gitk.1*
625 %endif
626 %attr(755,root,root) %{_bindir}/gitk
627 %dir %{_datadir}/gitk
628 %dir %{_datadir}/gitk/lib
629 %dir %{_datadir}/gitk/lib/msgs
630 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
631 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
632 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
633 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
634 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
635 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
636 %lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
637 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
638 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
639
640 %files gitweb
641 %defattr(644,root,root,755)
642 %doc gitweb/{README,INSTALL}
643 %dir %{webappdir}
644 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
645 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
646 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
647 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
648 %attr(755,root,root) %{cgibindir}/gitweb.cgi
649 %{appdir}
650 %attr(755,root,root) %{_libdir}/%{name}/git-instaweb
651 %if %{with doc}
652 %{_mandir}/man1/gitweb.1*
653 %{_mandir}/man5/gitweb.conf.5*
654 %endif
655
656 %files gitview
657 %defattr(644,root,root,755)
658 %doc contrib/gitview/gitview.txt
659 %attr(755,root,root) %{_bindir}/gitview
660
661 %files gui
662 %defattr(644,root,root,755)
663 %attr(755,root,root) %{_libdir}/%{name}/git-gui
664 %dir %{_datadir}/git-gui
665 %dir %{_datadir}/git-gui/lib
666 %dir %{_datadir}/git-gui/lib/msgs
667 %{_datadir}/git-gui/lib/git-gui.ico
668 %{_datadir}/git-gui/lib/tclIndex
669 %{_datadir}/git-gui/lib/*.js
670 %{_datadir}/git-gui/lib/*.tcl
671 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
672 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
673 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
674 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
675 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
676 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
677 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
678 %lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
679 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
680 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
681 %lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
682
683 %files svn
684 %defattr(644,root,root,755)
685 %attr(755,root,root) %{_libdir}/%{name}/git-svn
686 %attr(755,root,root) %{_libdir}/%{name}/git-remote-testsvn
687 %{perl_vendorlib}/Git/SVN
688 %{perl_vendorlib}/Git/SVN.pm
689 %if %{with doc}
690 %{_mandir}/man1/git-svn.1*
691 %endif
692
693 %files cvs
694 %defattr(644,root,root,755)
695 %attr(755,root,root) %{_bindir}/git-cvsserver
696 %attr(755,root,root) %{_libdir}/%{name}/git-cvs*
697 %if %{with doc}
698 %{_mandir}/man1/git-cvs*.1*
699 %{_mandir}/man7/gitcvs-migration.7*
700 %endif
701
702 %files arch
703 %defattr(644,root,root,755)
704 %attr(755,root,root) %{_libdir}/%{name}/git-archimport
705 %if %{with doc}
706 %{_mandir}/man1/git-archimport.1*
707 %endif
708
709 %files email
710 %defattr(644,root,root,755)
711 %attr(755,root,root) %{_libdir}/%{name}/*email*
712 %if %{with doc}
713 %{_mandir}/man1/*email*.1*
714 %endif
715
716 %files -n bash-completion-git
717 %defattr(644,root,root,755)
718 %{bash_compdir}/git
719
720 %files -n perl-Git
721 %defattr(644,root,root,755)
722 %{perl_vendorlib}/Git.pm
723 %dir %{perl_vendorlib}/Git
724 %{perl_vendorlib}/Git/I18N.pm
725 %{perl_vendorlib}/Git/IndexInfo.pm
726 %{_mandir}/man3/Git*.3pm*
727
728 %files -n python-Git
729 %defattr(644,root,root,755)
730 %attr(755,root,root) %{_libdir}/%{name}/git-remote-testpy
731 %dir %{py_sitescriptdir}/git_remote_helpers
732 %{py_sitescriptdir}/git_remote_helpers/*.py[co]
733 %dir %{py_sitescriptdir}/git_remote_helpers/git
734 %{py_sitescriptdir}/git_remote_helpers/git/*.py[co]
735 %if "%{py_ver}" > "2.4"
736 %{py_sitescriptdir}/git_remote_helpers*.egg-info
737 %endif
738 %if %{with doc}
739 %{_mandir}/man1/gitremote-helpers.1*
740 %endif
741
742 %files -n vim-syntax-gitcommit
743 %defattr(644,root,root,755)
744 %doc contrib/vim/README
745 %{_datadir}/vim/vimfiles/syntax/gitcommit.vim
This page took 0.084248 seconds and 4 git commands to generate.