]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
- tcl/tk support checks for wish
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform make test
4 %bcond_with     tests_cvs       # perform tests which use CVS
5 %bcond_without  tests_svn       # perform tests which use subversion
6 %bcond_without  doc             # skip building/packaging docs/manuals (takes some time)
7 %bcond_without  pcre            # perl-compatible regexes support
8 %bcond_without  gnome_keyring   # build without gnome keyring support
9
10 # for AC: --without doc --without gnome_keyring --without tests
11
12 %include        /usr/lib/rpm/macros.perl
13 Summary:        Distributed version control system focused on speed, effectivity and usability
14 Summary(pl.UTF-8):      Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
15 Name:           git-core
16 Version:        2.9.2
17 Release:        1
18 License:        GPL v2
19 Group:          Development/Tools
20 Source0:        http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.xz
21 # Source0-md5:  dc5eb7ff2ca4641c6038f51ae49cad0f
22 Source1:        %{name}-gitweb.conf
23 Source2:        %{name}-gitweb-httpd.conf
24 Source3:        %{name}-gitweb-lighttpd.conf
25 Source4:        %{name}.sysconfig
26 Source5:        %{name}.inet
27 Source6:        %{name}.init
28 Source7:        gitolite.pl
29 Patch0:         %{name}-tests.patch
30 Patch1:         %{name}-key-bindings.patch
31 Patch2:         %{name}-sysconfdir.patch
32 Patch3:         cherry-picked-commitlog.patch
33 Patch4:         %{name}-svn-exit-errors.patch
34 URL:            http://git-scm.com/
35 BuildRequires:  autoconf >= 2.59
36 BuildRequires:  automake
37 BuildRequires:  curl-devel
38 BuildRequires:  expat-devel
39 %if "%{pld_release}" == "ac"
40 BuildRequires:  gettext-devel
41 %else
42 BuildRequires:  gettext-tools
43 %endif
44 %if %{with gnome_keyring}
45 BuildRequires:  libgnome-keyring-devel
46 BuildRequires:  pkgconfig
47 %endif
48 BuildRequires:  openssl-devel
49 %{?with_pcre:BuildRequires:     pcre-devel}
50 BuildRequires:  perl-Error > 0.15
51 BuildRequires:  perl-base
52 BuildRequires:  python-devel
53 BuildRequires:  rpm-perlprov >= 4.1-13
54 BuildRequires:  rpm-pythonprov
55 BuildRequires:  rpmbuild(macros) >= 1.673
56 # wish
57 BuildRequires:  tk
58 BuildRequires:  zlib-devel
59 %if %{with doc}
60 BuildRequires:  asciidoc >= 7.1.2-3
61 BuildRequires:  docbook-dtd45-xml
62 BuildRequires:  xmlto
63 %endif
64 %if %{with tests}
65 %if %{with tests_cvs}
66 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
67 BuildRequires:  cvs-gnu-client < 1.13
68 BuildRequires:  cvs-gnu-client >= 1.12
69 %endif
70 %if %{with tests_svn}
71 BuildRequires:  perl-subversion
72 BuildRequires:  subversion
73 %endif
74 Conflicts:      pdksh < 5.2.14-46
75 %endif
76 # git-sh-setup: sane_grep
77 Requires:       grep
78 # git-pull: printf
79 Requires:       coreutils
80 Requires:       perl-Error
81 Requires:       perl-Git = %{version}-%{release}
82 Requires:       sed
83 Suggests:       git-core-bzr
84 Suggests:       git-core-cvs
85 Suggests:       git-core-hg
86 Suggests:       git-core-p4
87 Suggests:       git-core-svn
88 Suggests:       less
89 Suggests:       openssh-clients
90 Suggests:       rsync
91 Obsoletes:      python-Git
92 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
93
94 # html docs have links to txt files
95 %define         _noautocompressdoc      *.txt
96
97 %define         webapp          gitweb
98 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
99 %define         appdir          %{_datadir}/%{webapp}
100 %define         cgibindir       %{_prefix}/lib/cgi-bin
101 %define         gitcoredir      %{_prefix}/lib/%{name}
102 %define         _libexecdir     %{_prefix}/lib
103
104 %description
105 "git" can mean anything, depending on your mood.
106
107 - random three-letter combination that is pronounceable, and not
108   actually used by any common UNIX command. The fact that it is a
109   mispronunciation of "get" may or may not be relevant.
110 - stupid. contemptible and despicable. simple. Take your pick from the
111   dictionary of slang.
112 - "global information tracker": you're in a good mood, and it actually
113   works for you. Angels sing, and a light suddenly fills the room.
114 - "goddamn idiotic truckload of sh*t": when it breaks
115
116 This is a stupid (but extremely fast) directory content manager. It
117 doesn't do a whole lot, but what it 'does' do is track directory
118 contents efficiently.
119
120 %description -l pl.UTF-8
121 "git" może oznaczać cokolwiek, w zależności od nastroju.
122
123 - losową kombinację trzech liter, która jest wymawialna i właściwie
124   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
125   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
126 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
127 - "global information tracker" (narzędzie do globalnego śledzenia
128   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
129   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
130 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
131   g*) - kiedy się zepsuje.
132
133 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
134 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
135 katalogu.
136
137 %package doc
138 Summary:        Documentation for git-core
139 Summary(pl.UTF-8):      Dokumentacja do git-core
140 Group:          Documentation
141 %if "%{_rpmversion}" >= "5"
142 BuildArch:      noarch
143 %endif
144
145 %description doc
146 Documentation for git-core.
147
148 %description doc -l pl.UTF-8
149 Dokumentacja do git-core.
150
151 %package daemon-inetd
152 Summary:        Files necessary to run git-daemon as an inetd service
153 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
154 Group:          Networking/Daemons
155 Requires:       %{name} = %{version}-%{release}
156 Requires:       setup >= 2.4.11-1
157 Provides:       git-core-daemon
158 Obsoletes:      git-core-daemon
159 Obsoletes:      git-core-daemon-standalone
160 %if "%{_rpmversion}" >= "5"
161 BuildArch:      noarch
162 %endif
163
164 %description daemon-inetd
165 Git-daemon is a really simple TCP git daemon that can serve git
166 repositories. This package provides all necessarry files to run
167 git-daemon as an inetd service.
168
169 %description daemon-inetd -l pl.UTF-8
170 Git-daemon to prosty demon git korzystający z protokołu TCP do
171 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
172 do uruchomienia git-demona w trybie usługi inetd.
173
174 %package daemon-standalone
175 Summary:        Files necessary to run git-daemon as a standalone service
176 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
177 Group:          Networking/Daemons
178 Requires:       %{name} = %{version}-%{release}
179 Provides:       git-core-daemon
180 Obsoletes:      git-core-daemon
181 Obsoletes:      git-core-daemon-inetd
182 %if "%{_rpmversion}" >= "5"
183 BuildArch:      noarch
184 %endif
185
186 %description daemon-standalone
187 Git-daemon is a really simple TCP git daemon that can serve git
188 repositories. This package provides all necessarry files to run
189 git-daemon as an standalone service.
190
191 %description daemon-standalone -l pl.UTF-8
192 Git-daemon to prosty demon git korzystający z protokołu TCP do
193 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
194 do uruchomienia git-daemona w trybie usługi samodzielnej.
195
196 %package devel
197 Summary:        Git library with header files
198 Summary(pl.UTF-8):      Biblioteka Gita oraz pliki nagłówkowe
199 Group:          Development/Libraries
200 Requires:       zlib-devel
201
202 %description devel
203 Git library with header files.
204
205 %description devel -l pl.UTF-8
206 Biblioteka Gita oraz pliki nagłówkowe.
207
208 %package gitk
209 Summary:        Tcl/Tk interface to the Git version control system
210 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
211 Group:          Development/Tools
212 Requires:       %{name} = %{version}-%{release}
213 Requires:       tk
214 %if "%{_rpmversion}" >= "5"
215 BuildArch:      noarch
216 %endif
217
218 %description gitk
219 gitk displays changes in a repository or a selected set of commits.
220 This includes visualizing the commit graph, showing information
221 related to each commit, and the files in the trees of each revision.
222
223 Historically, gitk was the first repository browser. It's written in
224 Tcl/Tk and started off in a separate repository but was later merged
225 into the main git repository.
226
227 %description gitk -l pl.UTF-8
228 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
229 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
230 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
231
232 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
233 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
234 osobnym repozytorium, ale z czasem został włączony do głównego
235 repozytorium gita.
236
237 %package gitweb
238 Summary:        Web frontend to git
239 Summary(pl.UTF-8):      Frontend WWW do gita
240 Group:          Development/Tools
241 Requires:       %{name} = %{version}-%{release}
242 Requires:       webapps
243 Requires:       webserver(access)
244 Requires:       webserver(alias)
245 Requires:       webserver(cgi)
246 Suggests:       webserver(setenv)
247 %if "%{_rpmversion}" >= "5"
248 BuildArch:      noarch
249 %endif
250
251 %description gitweb
252 This package provides a web interface for browsing git repositories.
253
254 %description gitweb -l pl.UTF-8
255 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
256
257 %package gitview
258 Summary:        A GTK+ based repository browser for git
259 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
260 Group:          Development/Tools
261 Requires:       %{name} = %{version}-%{release}
262 Requires:       python >= 1:2.4
263 Requires:       python-pycairo >= 1.0
264 Requires:       python-pygobject
265 Requires:       python-pygtk-gtk >= 2:2.8
266 Suggests:       python-gnome-desktop-gtksourceview
267 %if "%{_rpmversion}" >= "5"
268 BuildArch:      noarch
269 %endif
270
271 %description gitview
272 A GTK+ based repository browser for git.
273
274 %description gitview -l pl.UTF-8
275 Oparta na GTK+ przeglądarka repozytorium gita.
276
277 %package gui
278 Summary:        Tcl/Tk interface to the Git version control system
279 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
280 Group:          Development/Tools
281 Requires:       %{name} = %{version}-%{release}
282 Requires:       tk
283 Requires:       xdg-utils
284 Suggests:       meld
285 %if "%{_rpmversion}" >= "5"
286 BuildArch:      noarch
287 %endif
288
289 %description gui
290 Displays changes in a repository or a selected set of commits. This
291 includes visualizing the commit graph, showing information related to
292 each commit, and the files in the trees of each revision.
293
294 Historically, gitk was the first repository browser. It's written in
295 Tcl/Tk and started off in a separate repository but was later merged
296 into the main git repository.
297
298 %description gui -l pl.UTF-8
299 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
300 to wizualizację grafu commitów, wyświetlanie informacji związanych z
301 każdym z commitów oraz listę plików dla każdej rewizji.
302
303 Z punktu widzenia historii, gitk był pierwszą przeglądarką
304 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
305 osobnym repozytorium, ale z czasem został włączony do głównego
306 repozytorium gita.
307
308 %package arch
309 Summary:        Git tools for importing Arch repositories
310 Summary(pl.UTF-8):      Narzędzia Gita do importowania repozytoriów Archa
311 Group:          Development/Tools
312 Requires:       %{name} = %{version}-%{release}
313 Requires:       tla
314 %if "%{_rpmversion}" >= "5"
315 BuildArch:      noarch
316 %endif
317
318 %description arch
319 Git tools for importing Arch repositories.
320
321 %description arch -l pl.UTF-8
322 Narzędzia Gita do importowania repozytoriów Archa.
323
324 %package bzr
325 Summary:        Git tools for working with bzr repositories
326 Summary(pl.UTF-8):      Narzędzia Gita do pracy z repozytoriami bzr
327 Group:          Development/Tools
328 Requires:       %{name} = %{version}-%{release}
329 Requires:       bzr
330 %if "%{_rpmversion}" >= "5"
331 BuildArch:      noarch
332 %endif
333
334 %description bzr
335 Git tools for working with bzr repositories.
336
337 %description bzr -l pl.UTF-8
338 Narzędzia Gita do pracy z repozytoriami bzr.
339
340 %package cvs
341 Summary:        CVS support for Git
342 Summary(pl.UTF-8):      Obsługa CVS dla Gita
343 Group:          Development/Tools
344 Requires:       %{name} = %{version}-%{release}
345 Requires:       cvsps >= 2.1-2
346 Requires:       rcs
347 %if "%{_rpmversion}" >= "5"
348 BuildArch:      noarch
349 %endif
350
351 %description cvs
352 CVS support for Git.
353
354 %description cvs -l pl.UTF-8
355 Obsługa CVS dla Gita.
356
357 %package hg
358 Summary:        Git tools for working with mercurial repositories
359 Summary(pl.UTF-8):      Narzędzia Gita do pracy z repozytoriami mercuriala
360 Group:          Development/Tools
361 Requires:       %{name} = %{version}-%{release}
362 Requires:       mercurial >= 1.8
363 %if "%{_rpmversion}" >= "5"
364 BuildArch:      noarch
365 %endif
366
367 %description hg
368 Git tools for working with mercurial repositories.
369
370 %description hg -l pl.UTF-8
371 Narzędzia Gita do pracy z repozytoriami mercuriala.
372
373 %package p4
374 Summary:        Git tools for working with Perforce depots
375 Summary(pl.UTF-8):      Narzędzia Gita do pracy z magazynami Perforce'a
376 Group:          Development/Tools
377 Requires:       %{name} = %{version}-%{release}
378 %if "%{_rpmversion}" >= "5"
379 BuildArch:      noarch
380 %endif
381
382 %description p4
383 Git tools for working with Perforce depots.
384
385 %description p4 -l pl.UTF-8
386 Narzędzia Gita do pracy z magazynami Perforce'a.
387
388 %package svn
389 Summary:        Subversion support for Git
390 Summary(pl.UTF-8):      Obsługa Subversion dla Gita
391 Group:          Development/Tools
392 Requires:       %{name} = %{version}-%{release}
393 Requires:       perl-Encode
394 Requires:       perl-Term-ReadKey
395
396 %description svn
397 Subversion support for Git.
398
399 %description svn -l pl.UTF-8
400 Obsługa Subversion dla Gita.
401
402 %package email
403 Summary:        Git tools for sending email
404 Summary(pl.UTF-8):      Narzędzia Gita do wysyłania poczty
405 Group:          Development/Tools
406 Requires:       %{name} = %{version}-%{release}
407
408 %description email
409 Git tools for sending email.
410
411 %description email -l pl.UTF-8
412 Narzędzia Gita do wysyłania poczty.
413
414 %package -n bash-completion-git
415 Summary:        bash-completion for git
416 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
417 Group:          Applications/Shells
418 Requires:       %{name} = %{version}-%{release}
419 Requires:       bash-completion >= 2.0
420 %if "%{_rpmversion}" >= "5"
421 BuildArch:      noarch
422 %endif
423
424 %description -n bash-completion-git
425 This package provides bash-completion for git.
426
427 %description -n bash-completion-git -l pl.UTF-8
428 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
429
430 %package -n perl-Git
431 Summary:        Perl interface to the Git version control system
432 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
433 Group:          Development/Languages/Perl
434 Obsoletes:      perl-git-core
435 %if "%{_rpmversion}" >= "5"
436 BuildArch:      noarch
437 %endif
438
439 %description -n perl-Git
440 This module provides Perl scripts easy way to interface the Git
441 version control system. The modules have an easy and well-tested way
442 to call arbitrary Git commands; in the future, the interface will also
443 provide specialized methods for doing easily operations which are not
444 totally trivial to do over the generic command interface.
445
446 %description -n perl-Git -l pl.UTF-8
447 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
448 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
449 dowolne polecenia Gita; w przyszłości interfejs udostępni także
450 specjalne metody do łatwego wykonywania operacji nietrywialnych do
451 wykonania przy użyciu ogólnego interfejsu poleceń.
452
453 %package -n gnome-keyring-git-core
454 Summary:        GNOME Keyring authentication provider for Git
455 Summary(pl.UTF-8):      Moduł uwierzytelniający GNOME Keyring dla Git
456 Group:          X11/Applications
457 URL:            http://git-scm.com/docs/gitcredentials.html
458 Requires:       %{name} = %{version}-%{release}
459
460 %description -n gnome-keyring-git-core
461 Authentication provider module for Git which allows git client to
462 authenticate using GNOME Keyring.
463
464 You need to register it with:
465 - git config --global credential.helper gnome-keyring
466
467 %description -n gnome-keyring-git-core -l pl.UTF-8
468 Moduł uwierzytelniający dla Subversion pozwalający klientom git
469 uwierzytelniać się przy użyciu mechanizmu GNOME Keyring.
470
471 Moduł trzeba zarejestrować poleceniem:
472 - git config --global credential.helper gnome-keyring
473
474 %prep
475 %setup -q -n git-%{version}
476 %patch0 -p1
477 %patch1 -p0
478 %patch2 -p1
479 %patch3 -p1
480 %patch4 -p1
481
482 %{__rm} {Documentation/technical,contrib/emacs,contrib/credential/gnome-keyring}/.gitignore
483
484 # we build things in contrib but want to have it clean for doc purporses, too
485 cp -a contrib contrib-doc
486
487 %build
488 %{__aclocal}
489 %{__autoconf}
490 %configure \
491         --sysconfdir=%{_sysconfdir}/git-core \
492         %{?with_pcre:--with-libpcre} \
493         --with-openssl
494
495 echo "BLK_SHA1=1" >> config.mak
496
497 %{__make} \
498         INSTALLDIRS=vendor \
499         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
500         GITWEB_PROJECTROOT="/var/lib/git" \
501         GITWEB_CSS="/gitweb/gitweb.css" \
502         GITWEB_LOGO="/gitweb/git-logo.png" \
503         GITWEB_FAVICON="/gitweb/git-favicon.png" \
504         V=1
505
506 %{__make} -C contrib/subtree
507
508 %if %{with gnome_keyring}
509 %{__make} -C contrib/credential/gnome-keyring
510 %endif
511
512 %if %{with doc}
513 %{__make} -C Documentation \
514         MAN_BASE_URL=file://%{_docdir}/%{name}-doc-%{version}/ \
515         V=1
516 %endif
517
518 %if %{with tests}
519 %if %{without tests_cvs}
520 %{__rm} t/t*cvs*.sh || :
521 %endif
522 %{!?with_tests_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
523 %endif
524
525 %install
526 rm -rf $RPM_BUILD_ROOT
527 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
528 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
529 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
530 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
531 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
532 [init]
533         templatedir = %{_sysconfdir}/%{name}/templates
534 EOF
535
536 %{__make} install \
537         INSTALLDIRS=vendor \
538         DESTDIR=$RPM_BUILD_ROOT
539
540 %if %{with doc}
541 %{__make} -C Documentation install \
542         DESTDIR=$RPM_BUILD_ROOT
543 %endif
544
545 # copy templates except sample hooks
546 cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
547 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
548
549 # header files and lib
550 cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
551 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
552 cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
553 install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
554 cp -p block-sha1/sha1.h $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
555 cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
556 cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
557 cp -p {Makefile,config.mak,config.mak.autogen,config.mak.uname} $RPM_BUILD_ROOT%{_includedir}/%{name}
558
559 %{__make} -C contrib/subtree install \
560         libexecdir=%{gitcoredir} \
561         DESTDIR=$RPM_BUILD_ROOT
562
563 %if %{with doc}
564 %{__make} -C contrib/subtree install-man \
565         DESTDIR=$RPM_BUILD_ROOT
566 %endif
567
568 %if %{with gnome_keyring}
569 install -p contrib/credential/gnome-keyring/git-credential-gnome-keyring $RPM_BUILD_ROOT%{gitcoredir}
570 %endif
571
572 # bash completion
573 install -d $RPM_BUILD_ROOT%{bash_compdir}
574 cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{bash_compdir}/git
575
576 # Install git-prompt.sh
577 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/contrib/completion
578 cp -p contrib/completion/git-prompt.sh $RPM_BUILD_ROOT%{_datadir}/%{name}/contrib/completion
579
580 # Install bzr and hg remote helpers from contrib
581 install -p contrib/remote-helpers/git-remote-{bzr,hg} $RPM_BUILD_ROOT%{gitcoredir}
582
583 # gitweb
584 mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
585 ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
586 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
587 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{webappdir}/gitolite.pl
588 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
589 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
590 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
591
592 # gitview
593 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
594
595 # git-daemon related files
596 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
597 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
598 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
599
600 # paths cleanup
601 sed -e 's,@libdir@/git-core,%{gitcoredir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
602 sed -e 's,@libdir@/git-core,%{gitcoredir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
603
604 # same file, link
605 ln -sf git $RPM_BUILD_ROOT%{_bindir}/git-receive-pack
606 ln -sf git $RPM_BUILD_ROOT%{_bindir}/git-upload-archive
607 ln -sf ../..%{gitcoredir}/git-shell $RPM_BUILD_ROOT%{_bindir}/git-shell
608 ln -sf ../..%{gitcoredir}/git-upload-pack $RPM_BUILD_ROOT%{_bindir}/git-upload-pack
609 ln -sf ../..%{gitcoredir}/git $RPM_BUILD_ROOT%{_bindir}/git
610
611 # convert all hardlinks to symlinks, as rpm fails to calculate it properly
612 # requiring excessive free space when it may not be available
613 # https://bugs.launchpad.net/pld-linux/+bug/1176337
614 find $RPM_BUILD_ROOT%{gitcoredir} -samefile $RPM_BUILD_ROOT%{gitcoredir}/git > files
615 for f in $(cat files); do
616         f=${f#$RPM_BUILD_ROOT%{gitcoredir}/}
617         test $f = git && continue
618         ln -snf git $RPM_BUILD_ROOT%{gitcoredir}/$f
619 done
620
621 # few others
622 ln -snf git-gui $RPM_BUILD_ROOT%{gitcoredir}/git-citool
623 ln -snf git-remote-http $RPM_BUILD_ROOT%{gitcoredir}/git-remote-https
624 ln -snf git-remote-http $RPM_BUILD_ROOT%{gitcoredir}/git-remote-ftp
625 ln -snf git-remote-http $RPM_BUILD_ROOT%{gitcoredir}/git-remote-ftps
626
627 # remove unneeded files
628 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
629 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
630 %py_postclean
631
632 mv $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
633 %find_lang git
634
635 %clean
636 rm -rf $RPM_BUILD_ROOT
637
638 %post daemon-inetd
639 %service -q rc-inetd reload
640
641 %postun daemon-inetd
642 if [ "$1" = "0" ]; then
643         %service -q rc-inetd reload
644 fi
645
646 %post daemon-standalone
647 /sbin/chkconfig --add git-daemon
648 %service git-daemon restart "git-daemon"
649
650 %preun daemon-standalone
651 if [ "$1" = "0" ]; then
652         %service git-daemon stop
653         /sbin/chkconfig --del git-daemon
654 fi
655
656 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
657 %webapp_register apache %{webapp}
658
659 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
660 %webapp_unregister apache %{webapp}
661
662 %triggerin gitweb -- apache < 2.2.0, apache-base
663 %webapp_register httpd %{webapp}
664
665 %triggerun gitweb -- apache < 2.2.0, apache-base
666 %webapp_unregister httpd %{webapp}
667
668 %triggerin gitweb -- lighttpd
669 %webapp_register lighttpd %{webapp}
670
671 %triggerun gitweb -- lighttpd
672 %webapp_unregister lighttpd %{webapp}
673
674 %files -f git.lang
675 %defattr(644,root,root,755)
676 %doc README.md contrib-doc
677 %attr(755,root,root) %{_bindir}/git
678 %attr(755,root,root) %{_bindir}/git-receive-pack
679 %attr(755,root,root) %{_bindir}/git-shell
680 %attr(755,root,root) %{_bindir}/git-upload-archive
681 %attr(755,root,root) %{_bindir}/git-upload-pack
682 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
683
684 %if %{with doc}
685 %{_mandir}/man1/git-*.1*
686 %exclude %{_mandir}/man1/git-archimport.1*
687 %exclude %{_mandir}/man1/git-svn.1*
688 %exclude %{_mandir}/man1/git-cvs*.1*
689 %exclude %{_mandir}/man1/git-imap-send*.1*
690 %exclude %{_mandir}/man1/*email*.1*
691 %{_mandir}/man1/git.1*
692 %{_mandir}/man1/gitremote-helpers.1*
693 %{_mandir}/man5/gitattributes.5*
694 %{_mandir}/man5/githooks.5*
695 %{_mandir}/man5/gitignore.5*
696 %{_mandir}/man5/gitmodules.5*
697 %{_mandir}/man5/gitrepository-layout.5*
698 %{_mandir}/man7/gitcli.7*
699 %{_mandir}/man7/gitcore-tutorial.7*
700 %{_mandir}/man7/gitcredentials.7*
701 %{_mandir}/man7/gitdiffcore.7*
702 %{_mandir}/man7/giteveryday.7*
703 %{_mandir}/man7/gitglossary.7*
704 %{_mandir}/man7/gitnamespaces.7*
705 %{_mandir}/man7/gitrevisions.7*
706 %{_mandir}/man7/gittutorial-2.7*
707 %{_mandir}/man7/gittutorial.7*
708 %{_mandir}/man7/gitworkflows.7*
709 %endif
710
711 %dir %{gitcoredir}
712 %attr(755,root,root) %{gitcoredir}/*-*
713 %attr(755,root,root) %{gitcoredir}/git
714 %dir %{gitcoredir}/mergetools
715 %{gitcoredir}/mergetools/*
716
717 %{_datadir}/%{name}
718 %{_localstatedir}/lib/git
719
720 # subpackages
721 %exclude %{gitcoredir}/*email*
722 %exclude %{gitcoredir}/*p4*
723 %exclude %{gitcoredir}/git-archimport
724 %exclude %{gitcoredir}/git-cvs*
725 %exclude %{gitcoredir}/git-gui
726 %exclude %{gitcoredir}/git-imap-send
727 %exclude %{gitcoredir}/git-instaweb
728 %exclude %{gitcoredir}/git-remote-bzr
729 %exclude %{gitcoredir}/git-remote-hg
730 %exclude %{gitcoredir}/git-remote-testsvn
731 %exclude %{gitcoredir}/git-svn
732 %exclude %{gitcoredir}/mergetools/p4merge
733 %if %{with gnome_keyring}
734 %exclude %{gitcoredir}/git-credential-gnome-keyring
735 %endif
736
737 %if %{with doc}
738 %files doc
739 %defattr(644,root,root,755)
740 %doc Documentation/RelNotes*
741 %doc Documentation/*.html Documentation/howto Documentation/technical
742 %endif
743
744 %files daemon-inetd
745 %defattr(644,root,root,755)
746 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
747
748 %files daemon-standalone
749 %defattr(644,root,root,755)
750 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
751 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
752
753 %files devel
754 %defattr(644,root,root,755)
755 %{_includedir}/%{name}
756 %{_libdir}/libgit.a
757 %{_libdir}/libgit_xdiff.a
758
759 %files gitk
760 %defattr(644,root,root,755)
761 %if %{with doc}
762 %{_mandir}/man1/gitk.1*
763 %endif
764 %attr(755,root,root) %{_bindir}/gitk
765 %dir %{_datadir}/gitk
766 %dir %{_datadir}/gitk/lib
767 %dir %{_datadir}/gitk/lib/msgs
768 %lang(bg) %{_datadir}/gitk/lib/msgs/bg.msg
769 %lang(ca) %{_datadir}/gitk/lib/msgs/ca.msg
770 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
771 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
772 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
773 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
774 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
775 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
776 %lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
777 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
778 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
779 %lang(vi) %{_datadir}/gitk/lib/msgs/vi.msg
780
781 %files gitweb
782 %defattr(644,root,root,755)
783 %doc gitweb/{README,INSTALL}
784 %dir %{webappdir}
785 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
786 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
787 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
788 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
789 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitolite.pl
790 %attr(755,root,root) %{cgibindir}/gitweb.cgi
791 %{appdir}
792 %attr(755,root,root) %{gitcoredir}/git-instaweb
793 %if %{with doc}
794 %{_mandir}/man1/gitweb.1*
795 %{_mandir}/man5/gitweb.conf.5*
796 %endif
797
798 %files gitview
799 %defattr(644,root,root,755)
800 %doc contrib/gitview/gitview.txt
801 %attr(755,root,root) %{_bindir}/gitview
802
803 %files gui
804 %defattr(644,root,root,755)
805 %attr(755,root,root) %{gitcoredir}/git-gui
806 %dir %{_datadir}/git-gui
807 %dir %{_datadir}/git-gui/lib
808 %dir %{_datadir}/git-gui/lib/msgs
809 %{_datadir}/git-gui/lib/git-gui.ico
810 %{_datadir}/git-gui/lib/tclIndex
811 %{_datadir}/git-gui/lib/*.js
812 %{_datadir}/git-gui/lib/*.tcl
813 %lang(bg) %{_datadir}/git-gui/lib/msgs/bg.msg
814 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
815 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
816 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
817 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
818 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
819 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
820 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
821 %lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
822 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
823 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
824 %lang(vi) %{_datadir}/git-gui/lib/msgs/vi.msg
825 %lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
826
827 %files arch
828 %defattr(644,root,root,755)
829 %attr(755,root,root) %{gitcoredir}/git-archimport
830 %if %{with doc}
831 %{_mandir}/man1/git-archimport.1*
832 %endif
833
834 %files bzr
835 %defattr(644,root,root,755)
836 %attr(755,root,root) %{gitcoredir}/git-remote-bzr
837
838 %files cvs
839 %defattr(644,root,root,755)
840 %attr(755,root,root) %{_bindir}/git-cvsserver
841 %attr(755,root,root) %{gitcoredir}/git-cvs*
842 %if %{with doc}
843 %{_mandir}/man1/git-cvs*.1*
844 %{_mandir}/man7/gitcvs-migration.7*
845 %endif
846
847 %files hg
848 %defattr(644,root,root,755)
849 %attr(755,root,root) %{gitcoredir}/git-remote-hg
850
851 %files p4
852 %defattr(644,root,root,755)
853 %attr(755,root,root) %{gitcoredir}/git-p4
854 %attr(755,root,root) %{gitcoredir}/mergetools/p4merge
855
856 %files svn
857 %defattr(644,root,root,755)
858 %attr(755,root,root) %{gitcoredir}/git-svn
859 %attr(755,root,root) %{gitcoredir}/git-remote-testsvn
860 %{perl_vendorlib}/Git/SVN
861 %{perl_vendorlib}/Git/SVN.pm
862 %if %{with doc}
863 %{_mandir}/man1/git-svn.1*
864 %endif
865 %{_mandir}/man3/Git::SVN::Editor.3pm*
866 %{_mandir}/man3/Git::SVN::Fetcher.3pm*
867 %{_mandir}/man3/Git::SVN::Memoize::YAML.3pm*
868 %{_mandir}/man3/Git::SVN::Prompt.3pm*
869 %{_mandir}/man3/Git::SVN::Ra.3pm*
870 %{_mandir}/man3/Git::SVN::Utils.3pm*
871
872 %files email
873 %defattr(644,root,root,755)
874 %attr(755,root,root) %{gitcoredir}/git-imap-send
875 %attr(755,root,root) %{gitcoredir}/*email*
876 %if %{with doc}
877 %{_mandir}/man1/*email*.1*
878 %{_mandir}/man1/*imap-send*.1*
879 %endif
880
881 %files -n bash-completion-git
882 %defattr(644,root,root,755)
883 %{bash_compdir}/git
884
885 %files -n perl-Git
886 %defattr(644,root,root,755)
887 %{perl_vendorlib}/Git.pm
888 %dir %{perl_vendorlib}/Git
889 %{perl_vendorlib}/Git/I18N.pm
890 %{perl_vendorlib}/Git/IndexInfo.pm
891 %{_mandir}/man3/Git.3pm*
892 %{_mandir}/man3/Git::I18N.3pm*
893
894 %if %{with gnome_keyring}
895 %files -n gnome-keyring-git-core
896 %defattr(644,root,root,755)
897 %attr(755,root,root) %{gitcoredir}/git-credential-gnome-keyring
898 %endif
This page took 0.182351 seconds and 4 git commands to generate.