]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
updated to 1.8.4.rc1
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform make test
4 %bcond_with     tests_cvs       # perform tests which use CVS
5 %bcond_without  tests_svn       # perform tests which use subversion
6 %bcond_without  doc             # skip building/packaging docs/manuals (takes some time)
7 %bcond_without  pcre            # perl-compatible regexes support
8
9 %define _rc  rc1
10
11 %include        /usr/lib/rpm/macros.perl
12 Summary:        Distributed version control system focused on speed, effectivity and usability
13 Summary(pl.UTF-8):      Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
14 Name:           git-core
15 Version:        1.8.4
16 Release:        0.%{_rc}.1
17 License:        GPL v2
18 Group:          Development/Tools
19 Source0:        http://git-core.googlecode.com/files/git-%{version}.%{_rc}.tar.gz
20 # Source0-md5:  65764e43561bdeac488b90261d598a0f
21 Source1:        %{name}-gitweb.conf
22 Source2:        %{name}-gitweb-apache.conf
23 Source3:        %{name}-gitweb-lighttpd.conf
24 Source4:        %{name}.sysconfig
25 Source5:        %{name}.inet
26 Source6:        %{name}.init
27 Source7:        %{name}-gitweb-httpd.conf
28 Patch0:         %{name}-tests.patch
29 Patch1:         %{name}-key-bindings.patch
30 Patch2:         %{name}-sysconfdir.patch
31 Patch3:         cherry-picked-commitlog.patch
32 Patch4:         %{name}-svn-serf.patch
33 Patch5:         %{name}-svn-exit-errors.patch
34 URL:            http://git-scm.com/
35 BuildRequires:  autoconf >= 2.59
36 BuildRequires:  automake
37 BuildRequires:  curl-devel
38 BuildRequires:  expat-devel
39 BuildRequires:  gettext-devel
40 BuildRequires:  openssl-devel
41 %{?with_pcre:BuildRequires:     pcre-devel}
42 BuildRequires:  perl-Error > 0.15
43 BuildRequires:  perl-base
44 BuildRequires:  python-devel
45 BuildRequires:  rpm-perlprov >= 4.1-13
46 BuildRequires:  rpm-pythonprov
47 BuildRequires:  rpmbuild(macros) >= 1.264
48 BuildRequires:  tcl
49 BuildRequires:  zlib-devel
50 %if %{with doc}
51 BuildRequires:  asciidoc >= 7.1.2-3
52 BuildRequires:  docbook-dtd45-xml
53 BuildRequires:  xmlto
54 %endif
55 %if %{with tests}
56 %if %{with tests_cvs}
57 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
58 BuildRequires:  cvs-gnu-client < 1.13
59 BuildRequires:  cvs-gnu-client >= 1.12
60 %endif
61 %{?with_tests_svn:BuildRequires:  subversion}
62 Conflicts:      pdksh < 5.2.14-46
63 %endif
64 Requires:       coreutils
65 Requires:       diffutils
66 Requires:       findutils
67 Requires:       grep
68 Requires:       openssh-clients
69 Requires:       perl-Error
70 Requires:       perl-Git = %{version}-%{release}
71 Requires:       sed
72 Suggests:       git-core-cvs
73 Suggests:       git-core-svn
74 Suggests:       less
75 Suggests:       rsync
76 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
77
78 # html docs have links to txt files
79 %define         _noautocompressdoc      *.txt
80
81 %define         webapp          gitweb
82 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
83 %define         appdir          %{_datadir}/%{webapp}
84 %define         cgibindir       %{_prefix}/lib/cgi-bin
85 %define         bash_compdir    %{_datadir}/bash-completion/completions
86
87 %description
88 "git" can mean anything, depending on your mood.
89
90 - random three-letter combination that is pronounceable, and not
91   actually used by any common UNIX command. The fact that it is a
92   mispronunciation of "get" may or may not be relevant.
93 - stupid. contemptible and despicable. simple. Take your pick from the
94   dictionary of slang.
95 - "global information tracker": you're in a good mood, and it actually
96   works for you. Angels sing, and a light suddenly fills the room.
97 - "goddamn idiotic truckload of sh*t": when it breaks
98
99 This is a stupid (but extremely fast) directory content manager. It
100 doesn't do a whole lot, but what it 'does' do is track directory
101 contents efficiently.
102
103 %description -l pl.UTF-8
104 "git" może oznaczać cokolwiek, w zależności od nastroju.
105
106 - losową kombinację trzech liter, która jest wymawialna i właściwie
107   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
108   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
109 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
110 - "global information tracker" (narzędzie do globalnego śledzenia
111   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
112   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
113 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
114   g*) - kiedy się zepsuje.
115
116 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
117 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
118 katalogu.
119
120 %package doc
121 Summary:        Documentation for git-core
122 Summary(pl.UTF-8):      Dokumentacja do git-core
123 Group:          Documentation
124
125 %description doc
126 Documentation for git-core.
127
128 %description doc -l pl.UTF-8
129 Dokumentacja do git-core.
130
131 %description doc -l fr.UTF-8
132 Javadoc pour git-core.
133
134 %package daemon-inetd
135 Summary:        Files necessary to run git-daemon as an inetd service
136 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
137 Group:          Networking/Daemons
138 Requires:       %{name} = %{version}-%{release}
139 Requires:       setup >= 2.4.11-1
140 Provides:       git-core-daemon
141 Obsoletes:      git-core-daemon
142 Obsoletes:      git-core-daemon-standalone
143
144 %description daemon-inetd
145 Git-daemon is a really simple TCP git daemon that can serve git
146 repositories. This package provides all necessarry files to run
147 git-daemon as an inetd service.
148
149 %description daemon-inetd -l pl.UTF-8
150 Git-daemon to prosty demon git korzystający z protokołu TCP do
151 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
152 do uruchomienia git-demona w trybie usługi inetd.
153
154 %package daemon-standalone
155 Summary:        Files necessary to run git-daemon as a standalone service
156 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
157 Group:          Networking/Daemons
158 Requires:       %{name} = %{version}-%{release}
159 Provides:       git-core-daemon
160 Obsoletes:      git-core-daemon
161 Obsoletes:      git-core-daemon-inetd
162
163 %description daemon-standalone
164 Git-daemon is a really simple TCP git daemon that can serve git
165 repositories. This package provides all necessarry files to run
166 git-daemon as an standalone service.
167
168 %description daemon-standalone -l pl.UTF-8
169 Git-daemon to prosty demon git korzystający z protokołu TCP do
170 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
171 do uruchomienia git-daemona w trybie usługi samodzielnej.
172
173 %package devel
174 Summary:        Git library with header files
175 Summary(pl.UTF-8):      Biblioteka Gita oraz pliki nagłówkowe
176 Group:          Development/Libraries
177 Requires:       zlib-devel
178
179 %description devel
180 Git library with header files.
181
182 %description devel -l pl.UTF-8
183 Biblioteka Gita oraz pliki nagłówkowe.
184
185 %package gitk
186 Summary:        Tcl/Tk interface to the Git version control system
187 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
188 Group:          Development/Tools
189 Requires:       %{name} = %{version}-%{release}
190 Requires:       tk
191
192 %description gitk
193 gitk displays changes in a repository or a selected set of commits.
194 This includes visualizing the commit graph, showing information
195 related to each commit, and the files in the trees of each revision.
196
197 Historically, gitk was the first repository browser. It's written in
198 Tcl/Tk and started off in a separate repository but was later merged
199 into the main git repository.
200
201 %description gitk -l pl.UTF-8
202 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
203 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
204 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
205
206 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
207 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
208 osobnym repozytorium, ale z czasem został włączony do głównego
209 repozytorium gita.
210
211 %package gitweb
212 Summary:        Web frontend to git
213 Summary(pl.UTF-8):      Frontend WWW do gita
214 Group:          Development/Tools
215 Requires:       %{name} = %{version}-%{release}
216 Requires:       webapps
217 Requires:       webserver(alias)
218 Requires:       webserver(cgi)
219 Suggests:       webserver(setenv)
220 Conflicts:      apache-base < 2.4.0-1
221
222 %description gitweb
223 This package provides a web interface for browsing git repositories.
224
225 %description gitweb -l pl.UTF-8
226 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
227
228 %package gitview
229 Summary:        A GTK+ based repository browser for git
230 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
231 Group:          Development/Tools
232 Requires:       %{name} = %{version}-%{release}
233 Requires:       python >= 1:2.4
234 Requires:       python-pycairo >= 1.0
235 Requires:       python-pygobject
236 Requires:       python-pygtk-gtk >= 2:2.8
237 Suggests:       python-gnome-desktop-gtksourceview
238
239 %description gitview
240 A GTK+ based repository browser for git.
241
242 %description gitview -l pl.UTF-8
243 Oparta na GTK+ przeglądarka repozytorium gita.
244
245 %package gui
246 Summary:        Tcl/Tk interface to the Git version control system
247 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
248 Group:          Development/Tools
249 Requires:       %{name} = %{version}-%{release}
250 Requires:       tk
251 Requires:       xdg-utils
252 Suggests:       meld
253
254 %description gui
255 Displays changes in a repository or a selected set of commits. This
256 includes visualizing the commit graph, showing information related to
257 each commit, and the files in the trees of each revision.
258
259 Historically, gitk was the first repository browser. It's written in
260 Tcl/Tk and started off in a separate repository but was later merged
261 into the main git repository.
262
263 %description gui -l pl.UTF-8
264 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
265 to wizualizację grafu commitów, wyświetlanie informacji związanych z
266 każdym z commitów oraz listę plików dla każdej rewizji.
267
268 Z punktu widzenia historii, gitk był pierwszą przeglądarką
269 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
270 osobnym repozytorium, ale z czasem został włączony do głównego
271 repozytorium gita.
272
273 %package svn
274 Summary:        Subversion support for Git
275 Summary(pl.UTF-8):      Obsługa Subversion dla Gita
276 Group:          Development/Tools
277 Requires:       %{name} = %{version}-%{release}
278 Requires:       perl-Encode
279 Requires:       perl-Term-ReadKey
280
281 %description svn
282 Subversion support for Git.
283
284 %description svn -l pl.UTF-8
285 Obsługa Subversion dla Gita.
286
287 %package cvs
288 Summary:        CVS support for Git
289 Summary(pl.UTF-8):      Obsługa CVS dla Gita
290 Group:          Development/Tools
291 Requires:       %{name} = %{version}-%{release}
292 Requires:       cvsps >= 2.1-2
293 Requires:       rcs
294
295 %description cvs
296 CVS support for Git.
297
298 %description cvs -l pl.UTF-8
299 Obsługa CVS dla Gita.
300
301 %package arch
302 Summary:        Git tools for importing Arch repositories
303 Summary(pl.UTF-8):      Narzędzia Gita do importowania repozytoriów Archa
304 Group:          Development/Tools
305 Requires:       %{name} = %{version}-%{release}
306 Requires:       tla
307
308 %description arch
309 Git tools for importing Arch repositories.
310
311 %description arch -l pl.UTF-8
312 Narzędzia Gita do importowania repozytoriów Archa.
313
314 %package email
315 Summary:        Git tools for sending email
316 Summary(pl.UTF-8):      Narzędzia Gita do wysyłania poczty
317 Group:          Development/Tools
318 Requires:       %{name} = %{version}-%{release}
319
320 %description email
321 Git tools for sending email.
322
323 %description email -l pl.UTF-8
324 Narzędzia Gita do wysyłania poczty.
325
326 %package -n bash-completion-git
327 Summary:        bash-completion for git
328 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
329 Group:          Applications/Shells
330 Requires:       %{name} = %{version}-%{release}
331 Requires:       bash-completion >= 2.0
332
333 %description -n bash-completion-git
334 This package provides bash-completion for git.
335
336 %description -n bash-completion-git -l pl.UTF-8
337 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
338
339 %package -n perl-Git
340 Summary:        Perl interface to the Git version control system
341 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
342 Group:          Development/Languages/Perl
343 Obsoletes:      perl-git-core
344
345 %description -n perl-Git
346 This module provides Perl scripts easy way to interface the Git
347 version control system. The modules have an easy and well-tested way
348 to call arbitrary Git commands; in the future, the interface will also
349 provide specialized methods for doing easily operations which are not
350 totally trivial to do over the generic command interface.
351
352 %description -n perl-Git -l pl.UTF-8
353 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
354 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
355 dowolne polecenia Gita; w przyszłości interfejs udostępni także
356 specjalne metody do łatwego wykonywania operacji nietrywialnych do
357 wykonania przy użyciu ogólnego interfejsu poleceń.
358
359 %package -n python-Git
360 Summary:        Python Git remote helpers for non-git repositories
361 Summary(pl.UTF-8):      Pythonowe zdalne moduły pomocnicze dla repozytoriów niegitowych
362 Group:          Development/Languages/Python
363 Requires:       %{name} = %{version}-%{release}
364
365 %description -n python-Git
366 This package contains Python git_repote_helpers package - Git remote
367 helpers for non-git repositories.
368
369 %description -n python-Git -l pl.UTF-8
370 Ten pakiet zawiera pakiet Pythona git_remote_helpers - zdalne moduły
371 pomocnicze Gita dla repozytoriów niegitowych.
372
373 %package -n vim-syntax-gitcommit
374 Summary:        Vim syntax: gitcommit
375 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
376 Group:          Applications/Editors/Vim
377 Requires:       %{name} = %{version}-%{release}
378 # for _vimdatadir existence
379 Requires:       vim-rt >= 4:6.3.058-3
380
381 %description -n vim-syntax-gitcommit
382 This plugin provides syntax highlighting for git's commit messages.
383
384 %description -n vim-syntax-gitcommit -l pl.UTF-8
385 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
386
387 %prep
388 %setup -q -n git-%{version}.%{_rc}
389 %patch0 -p1
390 %patch1 -p0
391 %patch2 -p1
392 %patch3 -p1
393 %patch4 -p1
394
395 %build
396 %{__aclocal}
397 %{__autoconf}
398 %configure \
399         --sysconfdir=%{_sysconfdir}/git-core \
400         %{?with_pcre:--with-libpcre} \
401         --with-openssl
402
403 echo "BLK_SHA1=1" >> config.mak
404
405 %{__make} \
406         INSTALLDIRS=vendor \
407         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
408         GITWEB_PROJECTROOT="/var/lib/git" \
409         GITWEB_CSS="/gitweb/gitweb.css" \
410         GITWEB_LOGO="/gitweb/git-logo.png" \
411         GITWEB_FAVICON="/gitweb/git-favicon.png" \
412         V=1
413
414 %if %{with doc}
415 %{__make} -C Documentation \
416         MAN_BASE_URL=file://%{_docdir}/%{name}-doc-%{version}/ \
417         V=1
418 %endif
419
420 %if %{with tests}
421 %if %{without tests_cvs}
422 %{__rm} t/t*cvs*.sh || :
423 %endif
424 %{!?with_tests_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
425 %endif
426
427 %install
428 rm -rf $RPM_BUILD_ROOT
429 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
430 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
431 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
432 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
433 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
434 [init]
435         templatedir = %{_sysconfdir}/%{name}/templates
436 EOF
437
438 %{__make} install \
439         INSTALLDIRS=vendor \
440         DESTDIR=$RPM_BUILD_ROOT
441
442 %if %{with doc}
443 %{__make} -C Documentation install \
444         DESTDIR=$RPM_BUILD_ROOT
445 %endif
446
447 # copy templates except sample hooks
448 cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
449 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
450
451 # header files and lib
452 cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
453 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
454 cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
455 cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
456 cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
457
458 # bash completion
459 install -d $RPM_BUILD_ROOT%{bash_compdir}
460 cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{bash_compdir}/git
461
462 # vim syntax
463 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
464 cat > $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax/gitcommit.vim << 'EOF'
465 autocmd BufNewFile,BufRead *.git/COMMIT_EDITMSG    setf gitcommit
466 autocmd BufNewFile,BufRead *.git/config,.gitconfig setf gitconfig
467 autocmd BufNewFile,BufRead git-rebase-todo         setf gitrebase
468 autocmd BufNewFile,BufRead .msg.[0-9]*
469         \ if getline(1) =~ '^From.*# This line is ignored.$' |
470         \   setf gitsendemail |
471         \ endif
472 autocmd BufNewFile,BufRead *.git/**
473         \ if getline(1) =~ '^\x\{40\}\>\|^ref: ' |
474         \   setf git |
475         \ endif
476 EOF
477
478 # gitweb
479 mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
480 ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
481 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
482 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
483 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
484 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
485
486 # gitview
487 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
488
489 # git-daemon related files
490 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
491 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
492 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
493
494 # paths cleanup
495 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
496 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
497
498 # hardlink
499 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
500 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
501 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
502 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
503
504 # remove unneeded files
505 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
506 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
507 %py_postclean
508
509 mv $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
510 %find_lang git
511
512 %clean
513 rm -rf $RPM_BUILD_ROOT
514
515 %post daemon-inetd
516 %service -q rc-inetd reload
517
518 %postun daemon-inetd
519 if [ "$1" = "0" ]; then
520         %service -q rc-inetd reload
521 fi
522
523 %post daemon-standalone
524 /sbin/chkconfig --add git-daemon
525 %service git-daemon restart "git-daemon"
526
527 %preun daemon-standalone
528 if [ "$1" = "0" ]; then
529         %service git-daemon stop
530         /sbin/chkconfig --del git-daemon
531 fi
532
533 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
534 %webapp_register apache %{webapp}
535
536 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
537 %webapp_unregister apache %{webapp}
538
539 %triggerin gitweb -- apache-base
540 %webapp_register httpd %{webapp}
541
542 %triggerun gitweb -- apache-base
543 %webapp_unregister httpd %{webapp}
544
545 %triggerin gitweb -- lighttpd
546 %webapp_register lighttpd %{webapp}
547
548 %triggerun gitweb -- lighttpd
549 %webapp_unregister lighttpd %{webapp}
550
551 %files -f git.lang
552 %defattr(644,root,root,755)
553 %doc README contrib
554 %attr(755,root,root) %{_bindir}/git
555 %attr(755,root,root) %{_bindir}/git-receive-pack
556 %attr(755,root,root) %{_bindir}/git-shell
557 %attr(755,root,root) %{_bindir}/git-upload-archive
558 %attr(755,root,root) %{_bindir}/git-upload-pack
559 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
560
561 %if %{with doc}
562 %{_mandir}/man1/git-*.1*
563 %exclude %{_mandir}/man1/git-archimport.1*
564 %exclude %{_mandir}/man1/git-svn.1*
565 %exclude %{_mandir}/man1/git-cvs*.1*
566 %exclude %{_mandir}/man1/*email*.1*
567 %exclude %{_mandir}/man1/gitremote-helpers.1*
568 %{_mandir}/man1/git.1*
569 %{_mandir}/man5/gitattributes.5*
570 %{_mandir}/man5/githooks.5*
571 %{_mandir}/man5/gitignore.5*
572 %{_mandir}/man5/gitmodules.5*
573 %{_mandir}/man5/gitrepository-layout.5*
574 %{_mandir}/man7/gitcli.7*
575 %{_mandir}/man7/gitcore-tutorial.7*
576 %{_mandir}/man7/gitcredentials.7*
577 %{_mandir}/man7/gitdiffcore.7*
578 %{_mandir}/man7/gitglossary.7*
579 %{_mandir}/man7/gitnamespaces.7*
580 %{_mandir}/man7/gitrevisions.7*
581 %{_mandir}/man7/gittutorial-2.7*
582 %{_mandir}/man7/gittutorial.7*
583 %{_mandir}/man7/gitworkflows.7*
584 %endif
585
586 %dir %{_libdir}/%{name}
587 %attr(755,root,root) %{_libdir}/%{name}/*-*
588 %attr(755,root,root) %{_libdir}/%{name}/git
589 %{_libdir}/%{name}/mergetools
590
591 %exclude %{_libdir}/%{name}/git-gui
592 %exclude %{_libdir}/%{name}/git-svn
593 %exclude %{_libdir}/%{name}/git-archimport
594 %exclude %{_libdir}/%{name}/git-cvs*
595 %exclude %{_libdir}/%{name}/git-instaweb
596 %exclude %{_libdir}/%{name}/git-remote-testsvn
597 %exclude %{_libdir}/%{name}/*email*
598
599 %{_datadir}/%{name}
600
601 %{_localstatedir}/lib/git
602
603 %if %{with doc}
604 %files doc
605 %defattr(644,root,root,755)
606 %doc Documentation/RelNotes*
607 %doc Documentation/*.html Documentation/howto Documentation/technical
608 %endif
609
610 %files daemon-inetd
611 %defattr(644,root,root,755)
612 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
613
614 %files daemon-standalone
615 %defattr(644,root,root,755)
616 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
617 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
618
619 %files devel
620 %defattr(644,root,root,755)
621 %{_includedir}/%{name}
622 %{_libdir}/libgit.a
623 %{_libdir}/libgit_xdiff.a
624
625 %files gitk
626 %defattr(644,root,root,755)
627 %if %{with doc}
628 %{_mandir}/man1/gitk.1*
629 %endif
630 %attr(755,root,root) %{_bindir}/gitk
631 %dir %{_datadir}/gitk
632 %dir %{_datadir}/gitk/lib
633 %dir %{_datadir}/gitk/lib/msgs
634 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
635 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
636 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
637 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
638 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
639 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
640 %lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
641 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
642 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
643
644 %files gitweb
645 %defattr(644,root,root,755)
646 %doc gitweb/{README,INSTALL}
647 %dir %{webappdir}
648 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
649 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
650 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
651 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
652 %attr(755,root,root) %{cgibindir}/gitweb.cgi
653 %{appdir}
654 %attr(755,root,root) %{_libdir}/%{name}/git-instaweb
655 %if %{with doc}
656 %{_mandir}/man1/gitweb.1*
657 %{_mandir}/man5/gitweb.conf.5*
658 %endif
659
660 %files gitview
661 %defattr(644,root,root,755)
662 %doc contrib/gitview/gitview.txt
663 %attr(755,root,root) %{_bindir}/gitview
664
665 %files gui
666 %defattr(644,root,root,755)
667 %attr(755,root,root) %{_libdir}/%{name}/git-gui
668 %dir %{_datadir}/git-gui
669 %dir %{_datadir}/git-gui/lib
670 %dir %{_datadir}/git-gui/lib/msgs
671 %{_datadir}/git-gui/lib/git-gui.ico
672 %{_datadir}/git-gui/lib/tclIndex
673 %{_datadir}/git-gui/lib/*.js
674 %{_datadir}/git-gui/lib/*.tcl
675 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
676 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
677 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
678 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
679 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
680 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
681 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
682 %lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
683 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
684 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
685 %lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
686
687 %files svn
688 %defattr(644,root,root,755)
689 %attr(755,root,root) %{_libdir}/%{name}/git-svn
690 %attr(755,root,root) %{_libdir}/%{name}/git-remote-testsvn
691 %{perl_vendorlib}/Git/SVN
692 %{perl_vendorlib}/Git/SVN.pm
693 %if %{with doc}
694 %{_mandir}/man1/git-svn.1*
695 %endif
696
697 %files cvs
698 %defattr(644,root,root,755)
699 %attr(755,root,root) %{_bindir}/git-cvsserver
700 %attr(755,root,root) %{_libdir}/%{name}/git-cvs*
701 %if %{with doc}
702 %{_mandir}/man1/git-cvs*.1*
703 %{_mandir}/man7/gitcvs-migration.7*
704 %endif
705
706 %files arch
707 %defattr(644,root,root,755)
708 %attr(755,root,root) %{_libdir}/%{name}/git-archimport
709 %if %{with doc}
710 %{_mandir}/man1/git-archimport.1*
711 %endif
712
713 %files email
714 %defattr(644,root,root,755)
715 %attr(755,root,root) %{_libdir}/%{name}/*email*
716 %if %{with doc}
717 %{_mandir}/man1/*email*.1*
718 %endif
719
720 %files -n bash-completion-git
721 %defattr(644,root,root,755)
722 %{bash_compdir}/git
723
724 %files -n perl-Git
725 %defattr(644,root,root,755)
726 %{perl_vendorlib}/Git.pm
727 %dir %{perl_vendorlib}/Git
728 %{perl_vendorlib}/Git/I18N.pm
729 %{perl_vendorlib}/Git/IndexInfo.pm
730 %{_mandir}/man3/Git*.3pm*
731
732 %files -n python-Git
733 %defattr(644,root,root,755)
734 %dir %{py_sitescriptdir}/git_remote_helpers
735 %{py_sitescriptdir}/git_remote_helpers/*.py[co]
736 %dir %{py_sitescriptdir}/git_remote_helpers/git
737 %{py_sitescriptdir}/git_remote_helpers/git/*.py[co]
738 %if "%{py_ver}" > "2.4"
739 %{py_sitescriptdir}/git_remote_helpers*.egg-info
740 %endif
741 %if %{with doc}
742 %{_mandir}/man1/gitremote-helpers.1*
743 %endif
744
745 %files -n vim-syntax-gitcommit
746 %defattr(644,root,root,755)
747 %doc contrib/vim/README
748 %{_datadir}/vim/vimfiles/syntax/gitcommit.vim
This page took 0.107289 seconds and 4 git commands to generate.