]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
updated to 1.8.3.1
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform make test
4 %bcond_with     tests_cvs       # perform tests which use CVS
5 %bcond_without  tests_svn       # perform tests which use subversion
6 %bcond_without  doc             # skip building/packaging docs/manuals (takes some time)
7 %bcond_without  pcre            # perl-compatible regexes support
8
9 %include        /usr/lib/rpm/macros.perl
10 Summary:        Distributed version control system focused on speed, effectivity and usability
11 Summary(pl.UTF-8):      Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
12 Name:           git-core
13 Version:        1.8.3.1
14 Release:        1
15 License:        GPL v2
16 Group:          Development/Tools
17 Source0:        http://git-core.googlecode.com/files/git-%{version}.tar.gz
18 # Source0-md5:  35401b410e7f248b13e35a1069aca2e2
19 Source1:        %{name}-gitweb.conf
20 Source2:        %{name}-gitweb-apache.conf
21 Source3:        %{name}-gitweb-lighttpd.conf
22 Source4:        %{name}.sysconfig
23 Source5:        %{name}.inet
24 Source6:        %{name}.init
25 Source7:        %{name}-gitweb-httpd.conf
26 Patch0:         %{name}-tests.patch
27 Patch1:         %{name}-key-bindings.patch
28 Patch2:         %{name}-sysconfdir.patch
29 Patch3:         cherry-picked-commitlog.patch
30 URL:            http://git-scm.com/
31 BuildRequires:  autoconf >= 2.59
32 BuildRequires:  automake
33 BuildRequires:  bash-completion >= 2.0
34 BuildRequires:  curl-devel
35 BuildRequires:  expat-devel
36 BuildRequires:  gettext-devel
37 BuildRequires:  openssl-devel
38 %{?with_pcre:BuildRequires:     pcre-devel}
39 BuildRequires:  perl-Error > 0.15
40 BuildRequires:  perl-base
41 BuildRequires:  python-devel
42 BuildRequires:  rpm-perlprov >= 4.1-13
43 BuildRequires:  rpm-pythonprov
44 BuildRequires:  rpmbuild(macros) >= 1.264
45 BuildRequires:  tcl
46 BuildRequires:  zlib-devel
47 %if %{with doc}
48 BuildRequires:  asciidoc >= 7.1.2-3
49 BuildRequires:  docbook-dtd45-xml
50 BuildRequires:  xmlto
51 %endif
52 %if %{with tests}
53 %if %{with tests_cvs}
54 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
55 BuildRequires:  cvs-gnu-client < 1.13
56 BuildRequires:  cvs-gnu-client >= 1.12
57 %endif
58 %{?with_tests_svn:BuildRequires:  subversion}
59 Conflicts:      pdksh < 5.2.14-46
60 %endif
61 Requires:       coreutils
62 Requires:       diffutils
63 Requires:       findutils
64 Requires:       grep
65 Requires:       openssh-clients
66 Requires:       perl-Error
67 Requires:       perl-Git = %{version}-%{release}
68 Requires:       sed
69 Suggests:       git-core-cvs
70 Suggests:       git-core-svn
71 Suggests:       less
72 Suggests:       rsync
73 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75 # html docs have links to txt files
76 %define         _noautocompressdoc      *.txt
77
78 %define         webapp          gitweb
79 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
80 %define         appdir          %{_datadir}/%{webapp}
81 %define         cgibindir       %{_prefix}/lib/cgi-bin
82 %define         bash_compdir    %(pkg-config --variable completionsdir bash-completion || echo /etc/bash_completion.d)
83
84 %description
85 "git" can mean anything, depending on your mood.
86
87 - random three-letter combination that is pronounceable, and not
88   actually used by any common UNIX command. The fact that it is a
89   mispronunciation of "get" may or may not be relevant.
90 - stupid. contemptible and despicable. simple. Take your pick from the
91   dictionary of slang.
92 - "global information tracker": you're in a good mood, and it actually
93   works for you. Angels sing, and a light suddenly fills the room.
94 - "goddamn idiotic truckload of sh*t": when it breaks
95
96 This is a stupid (but extremely fast) directory content manager. It
97 doesn't do a whole lot, but what it 'does' do is track directory
98 contents efficiently.
99
100 %description -l pl.UTF-8
101 "git" może oznaczać cokolwiek, w zależności od nastroju.
102
103 - losową kombinację trzech liter, która jest wymawialna i właściwie
104   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
105   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
106 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
107 - "global information tracker" (narzędzie do globalnego śledzenia
108   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
109   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
110 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
111   g*) - kiedy się zepsuje.
112
113 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
114 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
115 katalogu.
116
117 %package doc
118 Summary:        Documentation for git-core
119 Summary(pl.UTF-8):      Dokumentacja do git-core
120 Group:          Documentation
121
122 %description doc
123 Documentation for git-core.
124
125 %description doc -l pl.UTF-8
126 Dokumentacja do git-core.
127
128 %description doc -l fr.UTF-8
129 Javadoc pour git-core.
130
131 %package daemon-inetd
132 Summary:        Files necessary to run git-daemon as an inetd service
133 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
134 Group:          Networking/Daemons
135 Requires:       %{name} = %{version}-%{release}
136 Requires:       setup >= 2.4.11-1
137 Provides:       git-core-daemon
138 Obsoletes:      git-core-daemon
139 Obsoletes:      git-core-daemon-standalone
140
141 %description daemon-inetd
142 Git-daemon is a really simple TCP git daemon that can serve git
143 repositories. This package provides all necessarry files to run
144 git-daemon as an inetd service.
145
146 %description daemon-inetd -l pl.UTF-8
147 Git-daemon to prosty demon git korzystający z protokołu TCP do
148 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
149 do uruchomienia git-demona w trybie usługi inetd.
150
151 %package daemon-standalone
152 Summary:        Files necessary to run git-daemon as a standalone service
153 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
154 Group:          Networking/Daemons
155 Requires:       %{name} = %{version}-%{release}
156 Provides:       git-core-daemon
157 Obsoletes:      git-core-daemon
158 Obsoletes:      git-core-daemon-inetd
159
160 %description daemon-standalone
161 Git-daemon is a really simple TCP git daemon that can serve git
162 repositories. This package provides all necessarry files to run
163 git-daemon as an standalone service.
164
165 %description daemon-standalone -l pl.UTF-8
166 Git-daemon to prosty demon git korzystający z protokołu TCP do
167 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
168 do uruchomienia git-daemona w trybie usługi samodzielnej.
169
170 %package devel
171 Summary:        Git library with header files
172 Summary(pl.UTF-8):      Biblioteka Gita oraz pliki nagłówkowe
173 Group:          Development/Libraries
174 Requires:       zlib-devel
175
176 %description devel
177 Git library with header files.
178
179 %description devel -l pl.UTF-8
180 Biblioteka Gita oraz pliki nagłówkowe.
181
182 %package gitk
183 Summary:        Tcl/Tk interface to the Git version control system
184 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
185 Group:          Development/Tools
186 Requires:       %{name} = %{version}-%{release}
187 Requires:       tk
188
189 %description gitk
190 gitk displays changes in a repository or a selected set of commits.
191 This includes visualizing the commit graph, showing information
192 related to each commit, and the files in the trees of each revision.
193
194 Historically, gitk was the first repository browser. It's written in
195 Tcl/Tk and started off in a separate repository but was later merged
196 into the main git repository.
197
198 %description gitk -l pl.UTF-8
199 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
200 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
201 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
202
203 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
204 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
205 osobnym repozytorium, ale z czasem został włączony do głównego
206 repozytorium gita.
207
208 %package gitweb
209 Summary:        Web frontend to git
210 Summary(pl.UTF-8):      Frontend WWW do gita
211 Group:          Development/Tools
212 Requires:       %{name} = %{version}-%{release}
213 Requires:       webapps
214 Requires:       webserver(alias)
215 Requires:       webserver(cgi)
216 Suggests:       webserver(setenv)
217 Conflicts:      apache-base < 2.4.0-1
218
219 %description gitweb
220 This package provides a web interface for browsing git repositories.
221
222 %description gitweb -l pl.UTF-8
223 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
224
225 %package gitview
226 Summary:        A GTK+ based repository browser for git
227 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
228 Group:          Development/Tools
229 Requires:       %{name} = %{version}-%{release}
230 Requires:       python >= 1:2.4
231 Requires:       python-pycairo >= 1.0
232 Requires:       python-pygobject
233 Requires:       python-pygtk-gtk >= 2:2.8
234 Suggests:       python-gnome-desktop-gtksourceview
235
236 %description gitview
237 A GTK+ based repository browser for git.
238
239 %description gitview -l pl.UTF-8
240 Oparta na GTK+ przeglądarka repozytorium gita.
241
242 %package gui
243 Summary:        Tcl/Tk interface to the Git version control system
244 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
245 Group:          Development/Tools
246 Requires:       %{name} = %{version}-%{release}
247 Requires:       tk
248 Requires:       xdg-utils
249 Suggests:       meld
250
251 %description gui
252 Displays changes in a repository or a selected set of commits. This
253 includes visualizing the commit graph, showing information related to
254 each commit, and the files in the trees of each revision.
255
256 Historically, gitk was the first repository browser. It's written in
257 Tcl/Tk and started off in a separate repository but was later merged
258 into the main git repository.
259
260 %description gui -l pl.UTF-8
261 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
262 to wizualizację grafu commitów, wyświetlanie informacji związanych z
263 każdym z commitów oraz listę plików dla każdej rewizji.
264
265 Z punktu widzenia historii, gitk był pierwszą przeglądarką
266 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
267 osobnym repozytorium, ale z czasem został włączony do głównego
268 repozytorium gita.
269
270 %package svn
271 Summary:        Subversion support for Git
272 Summary(pl.UTF-8):      Obsługa Subversion dla Gita
273 Group:          Development/Tools
274 Requires:       %{name} = %{version}-%{release}
275 Requires:       perl-Encode
276 Requires:       perl-Term-ReadKey
277
278 %description svn
279 Subversion support for Git.
280
281 %description svn -l pl.UTF-8
282 Obsługa Subversion dla Gita.
283
284 %package cvs
285 Summary:        CVS support for Git
286 Summary(pl.UTF-8):      Obsługa CVS dla Gita
287 Group:          Development/Tools
288 Requires:       %{name} = %{version}-%{release}
289 Requires:       cvsps >= 2.1-2
290 Requires:       rcs
291
292 %description cvs
293 CVS support for Git.
294
295 %description cvs -l pl.UTF-8
296 Obsługa CVS dla Gita.
297
298 %package arch
299 Summary:        Git tools for importing Arch repositories
300 Summary(pl.UTF-8):      Narzędzia Gita do importowania repozytoriów Archa
301 Group:          Development/Tools
302 Requires:       %{name} = %{version}-%{release}
303 Requires:       tla
304
305 %description arch
306 Git tools for importing Arch repositories.
307
308 %description arch -l pl.UTF-8
309 Narzędzia Gita do importowania repozytoriów Archa.
310
311 %package email
312 Summary:        Git tools for sending email
313 Summary(pl.UTF-8):      Narzędzia Gita do wysyłania poczty
314 Group:          Development/Tools
315 Requires:       %{name} = %{version}-%{release}
316
317 %description email
318 Git tools for sending email.
319
320 %description email -l pl.UTF-8
321 Narzędzia Gita do wysyłania poczty.
322
323 %package -n bash-completion-git
324 Summary:        bash-completion for git
325 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
326 Group:          Applications/Shells
327 Requires:       %{name} = %{version}-%{release}
328 Requires:       bash-completion >= 2.0
329
330 %description -n bash-completion-git
331 This package provides bash-completion for git.
332
333 %description -n bash-completion-git -l pl.UTF-8
334 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
335
336 %package -n perl-Git
337 Summary:        Perl interface to the Git version control system
338 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
339 Group:          Development/Languages/Perl
340 Obsoletes:      perl-git-core
341
342 %description -n perl-Git
343 This module provides Perl scripts easy way to interface the Git
344 version control system. The modules have an easy and well-tested way
345 to call arbitrary Git commands; in the future, the interface will also
346 provide specialized methods for doing easily operations which are not
347 totally trivial to do over the generic command interface.
348
349 %description -n perl-Git -l pl.UTF-8
350 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
351 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
352 dowolne polecenia Gita; w przyszłości interfejs udostępni także
353 specjalne metody do łatwego wykonywania operacji nietrywialnych do
354 wykonania przy użyciu ogólnego interfejsu poleceń.
355
356 %package -n python-Git
357 Summary:        Python Git remote helpers for non-git repositories
358 Summary(pl.UTF-8):      Pythonowe zdalne moduły pomocnicze dla repozytoriów niegitowych
359 Group:          Development/Languages/Python
360 Requires:       %{name} = %{version}-%{release}
361
362 %description -n python-Git
363 This package contains Python git_repote_helpers package - Git remote
364 helpers for non-git repositories.
365
366 %description -n python-Git -l pl.UTF-8
367 Ten pakiet zawiera pakiet Pythona git_remote_helpers - zdalne moduły
368 pomocnicze Gita dla repozytoriów niegitowych.
369
370 %package -n vim-syntax-gitcommit
371 Summary:        Vim syntax: gitcommit
372 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
373 Group:          Applications/Editors/Vim
374 Requires:       %{name} = %{version}-%{release}
375 # for _vimdatadir existence
376 Requires:       vim-rt >= 4:6.3.058-3
377
378 %description -n vim-syntax-gitcommit
379 This plugin provides syntax highlighting for git's commit messages.
380
381 %description -n vim-syntax-gitcommit -l pl.UTF-8
382 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
383
384 %prep
385 %setup -q -n git-%{version}
386 %patch0 -p1
387 %patch1 -p0
388 %patch2 -p1
389 %patch3 -p1
390
391 %build
392 %{__aclocal}
393 %{__autoconf}
394 %configure \
395         --sysconfdir=%{_sysconfdir}/git-core \
396         %{?with_pcre:--with-libpcre} \
397         --with-openssl
398
399 echo "BLK_SHA1=1" >> config.mak
400
401 %{__make} \
402         INSTALLDIRS=vendor \
403         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
404         GITWEB_PROJECTROOT="/var/lib/git" \
405         GITWEB_CSS="/gitweb/gitweb.css" \
406         GITWEB_LOGO="/gitweb/git-logo.png" \
407         GITWEB_FAVICON="/gitweb/git-favicon.png" \
408         V=1
409
410 %if %{with doc}
411 %{__make} -C Documentation \
412         MAN_BASE_URL=file://%{_docdir}/%{name}-doc-%{version}/ \
413         V=1
414 %endif
415
416 %if %{with tests}
417 %if %{without tests_cvs}
418 %{__rm} t/t*cvs*.sh || :
419 %endif
420 %{!?with_tests_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
421 %endif
422
423 %install
424 rm -rf $RPM_BUILD_ROOT
425 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
426 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
427 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
428 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
429 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
430 [init]
431         templatedir = %{_sysconfdir}/%{name}/templates
432 EOF
433
434 %{__make} install \
435         INSTALLDIRS=vendor \
436         DESTDIR=$RPM_BUILD_ROOT
437
438 %if %{with doc}
439 %{__make} -C Documentation install \
440         DESTDIR=$RPM_BUILD_ROOT
441 %endif
442
443 # copy templates except sample hooks
444 cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
445 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
446
447 # header files and lib
448 cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
449 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
450 cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
451 cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
452 cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
453
454 # bash completion
455 install -d $RPM_BUILD_ROOT%{bash_compdir}
456 cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{bash_compdir}/git
457
458 # vim syntax
459 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
460 cat > $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax/gitcommit.vim << 'EOF'
461 autocmd BufNewFile,BufRead *.git/COMMIT_EDITMSG    setf gitcommit
462 autocmd BufNewFile,BufRead *.git/config,.gitconfig setf gitconfig
463 autocmd BufNewFile,BufRead git-rebase-todo         setf gitrebase
464 autocmd BufNewFile,BufRead .msg.[0-9]*
465         \ if getline(1) =~ '^From.*# This line is ignored.$' |
466         \   setf gitsendemail |
467         \ endif
468 autocmd BufNewFile,BufRead *.git/**
469         \ if getline(1) =~ '^\x\{40\}\>\|^ref: ' |
470         \   setf git |
471         \ endif
472 EOF
473
474 # gitweb
475 mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
476 ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
477 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
478 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
479 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
480 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
481
482 # gitview
483 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
484
485 # git-daemon related files
486 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
487 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
488 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
489
490 # paths cleanup
491 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
492 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
493
494 # hardlink
495 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
496 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
497 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
498 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
499
500 # remove unneeded files
501 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
502 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
503 %py_postclean
504
505 mv $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
506 %find_lang git
507
508 %clean
509 rm -rf $RPM_BUILD_ROOT
510
511 %post daemon-inetd
512 %service -q rc-inetd reload
513
514 %postun daemon-inetd
515 if [ "$1" = "0" ]; then
516         %service -q rc-inetd reload
517 fi
518
519 %post daemon-standalone
520 /sbin/chkconfig --add git-daemon
521 %service git-daemon restart "git-daemon"
522
523 %preun daemon-standalone
524 if [ "$1" = "0" ]; then
525         %service git-daemon stop
526         /sbin/chkconfig --del git-daemon
527 fi
528
529 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
530 %webapp_register apache %{webapp}
531
532 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
533 %webapp_unregister apache %{webapp}
534
535 %triggerin gitweb -- apache-base
536 %webapp_register httpd %{webapp}
537
538 %triggerun gitweb -- apache-base
539 %webapp_unregister httpd %{webapp}
540
541 %triggerin gitweb -- lighttpd
542 %webapp_register lighttpd %{webapp}
543
544 %triggerun gitweb -- lighttpd
545 %webapp_unregister lighttpd %{webapp}
546
547 %files -f git.lang
548 %defattr(644,root,root,755)
549 %doc README contrib
550 %attr(755,root,root) %{_bindir}/git
551 %attr(755,root,root) %{_bindir}/git-receive-pack
552 %attr(755,root,root) %{_bindir}/git-shell
553 %attr(755,root,root) %{_bindir}/git-upload-archive
554 %attr(755,root,root) %{_bindir}/git-upload-pack
555 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
556
557 %if %{with doc}
558 %{_mandir}/man1/git-*.1*
559 %exclude %{_mandir}/man1/git-archimport.1*
560 %exclude %{_mandir}/man1/git-svn.1*
561 %exclude %{_mandir}/man1/git-cvs*.1*
562 %exclude %{_mandir}/man1/*email*.1*
563 %exclude %{_mandir}/man1/gitremote-helpers.1*
564 %{_mandir}/man1/git.1*
565 %{_mandir}/man5/gitattributes.5*
566 %{_mandir}/man5/githooks.5*
567 %{_mandir}/man5/gitignore.5*
568 %{_mandir}/man5/gitmodules.5*
569 %{_mandir}/man5/gitrepository-layout.5*
570 %{_mandir}/man7/gitcli.7*
571 %{_mandir}/man7/gitcore-tutorial.7*
572 %{_mandir}/man7/gitcredentials.7*
573 %{_mandir}/man7/gitdiffcore.7*
574 %{_mandir}/man7/gitglossary.7*
575 %{_mandir}/man7/gitnamespaces.7*
576 %{_mandir}/man7/gitrevisions.7*
577 %{_mandir}/man7/gittutorial-2.7*
578 %{_mandir}/man7/gittutorial.7*
579 %{_mandir}/man7/gitworkflows.7*
580 %endif
581
582 %dir %{_libdir}/%{name}
583 %attr(755,root,root) %{_libdir}/%{name}/*-*
584 %attr(755,root,root) %{_libdir}/%{name}/git
585 %{_libdir}/%{name}/mergetools
586
587 %exclude %{_libdir}/%{name}/git-gui
588 %exclude %{_libdir}/%{name}/git-svn
589 %exclude %{_libdir}/%{name}/git-archimport
590 %exclude %{_libdir}/%{name}/git-cvs*
591 %exclude %{_libdir}/%{name}/git-instaweb
592 %exclude %{_libdir}/%{name}/git-remote-testpy
593 %exclude %{_libdir}/%{name}/git-remote-testsvn
594 %exclude %{_libdir}/%{name}/*email*
595
596 %{_datadir}/%{name}
597
598 %{_localstatedir}/lib/git
599
600 %if %{with doc}
601 %files doc
602 %defattr(644,root,root,755)
603 %doc Documentation/RelNotes*
604 %doc Documentation/*.html Documentation/howto Documentation/technical
605 %endif
606
607 %files daemon-inetd
608 %defattr(644,root,root,755)
609 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
610
611 %files daemon-standalone
612 %defattr(644,root,root,755)
613 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
614 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
615
616 %files devel
617 %defattr(644,root,root,755)
618 %{_includedir}/%{name}
619 %{_libdir}/libgit.a
620 %{_libdir}/libgit_xdiff.a
621
622 %files gitk
623 %defattr(644,root,root,755)
624 %if %{with doc}
625 %{_mandir}/man1/gitk.1*
626 %endif
627 %attr(755,root,root) %{_bindir}/gitk
628 %dir %{_datadir}/gitk
629 %dir %{_datadir}/gitk/lib
630 %dir %{_datadir}/gitk/lib/msgs
631 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
632 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
633 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
634 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
635 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
636 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
637 %lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
638 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
639 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
640
641 %files gitweb
642 %defattr(644,root,root,755)
643 %doc gitweb/{README,INSTALL}
644 %dir %{webappdir}
645 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
646 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
647 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
648 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
649 %attr(755,root,root) %{cgibindir}/gitweb.cgi
650 %{appdir}
651 %attr(755,root,root) %{_libdir}/%{name}/git-instaweb
652 %if %{with doc}
653 %{_mandir}/man1/gitweb.1*
654 %{_mandir}/man5/gitweb.conf.5*
655 %endif
656
657 %files gitview
658 %defattr(644,root,root,755)
659 %doc contrib/gitview/gitview.txt
660 %attr(755,root,root) %{_bindir}/gitview
661
662 %files gui
663 %defattr(644,root,root,755)
664 %attr(755,root,root) %{_libdir}/%{name}/git-gui
665 %dir %{_datadir}/git-gui
666 %dir %{_datadir}/git-gui/lib
667 %dir %{_datadir}/git-gui/lib/msgs
668 %{_datadir}/git-gui/lib/git-gui.ico
669 %{_datadir}/git-gui/lib/tclIndex
670 %{_datadir}/git-gui/lib/*.js
671 %{_datadir}/git-gui/lib/*.tcl
672 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
673 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
674 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
675 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
676 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
677 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
678 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
679 %lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
680 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
681 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
682 %lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
683
684 %files svn
685 %defattr(644,root,root,755)
686 %attr(755,root,root) %{_libdir}/%{name}/git-svn
687 %attr(755,root,root) %{_libdir}/%{name}/git-remote-testsvn
688 %{perl_vendorlib}/Git/SVN
689 %{perl_vendorlib}/Git/SVN.pm
690 %if %{with doc}
691 %{_mandir}/man1/git-svn.1*
692 %endif
693
694 %files cvs
695 %defattr(644,root,root,755)
696 %attr(755,root,root) %{_bindir}/git-cvsserver
697 %attr(755,root,root) %{_libdir}/%{name}/git-cvs*
698 %if %{with doc}
699 %{_mandir}/man1/git-cvs*.1*
700 %{_mandir}/man7/gitcvs-migration.7*
701 %endif
702
703 %files arch
704 %defattr(644,root,root,755)
705 %attr(755,root,root) %{_libdir}/%{name}/git-archimport
706 %if %{with doc}
707 %{_mandir}/man1/git-archimport.1*
708 %endif
709
710 %files email
711 %defattr(644,root,root,755)
712 %attr(755,root,root) %{_libdir}/%{name}/*email*
713 %if %{with doc}
714 %{_mandir}/man1/*email*.1*
715 %endif
716
717 %files -n bash-completion-git
718 %defattr(644,root,root,755)
719 %{bash_compdir}/git
720
721 %files -n perl-Git
722 %defattr(644,root,root,755)
723 %{perl_vendorlib}/Git.pm
724 %dir %{perl_vendorlib}/Git
725 %{perl_vendorlib}/Git/I18N.pm
726 %{perl_vendorlib}/Git/IndexInfo.pm
727 %{_mandir}/man3/Git*.3pm*
728
729 %files -n python-Git
730 %defattr(644,root,root,755)
731 %attr(755,root,root) %{_libdir}/%{name}/git-remote-testpy
732 %dir %{py_sitescriptdir}/git_remote_helpers
733 %{py_sitescriptdir}/git_remote_helpers/*.py[co]
734 %dir %{py_sitescriptdir}/git_remote_helpers/git
735 %{py_sitescriptdir}/git_remote_helpers/git/*.py[co]
736 %if "%{py_ver}" > "2.4"
737 %{py_sitescriptdir}/git_remote_helpers*.egg-info
738 %endif
739 %if %{with doc}
740 %{_mandir}/man1/gitremote-helpers.1*
741 %endif
742
743 %files -n vim-syntax-gitcommit
744 %defattr(644,root,root,755)
745 %doc contrib/vim/README
746 %{_datadir}/vim/vimfiles/syntax/gitcommit.vim
This page took 0.074784 seconds and 4 git commands to generate.