]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
build and package gnome keyring integration
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform make test
4 %bcond_with     tests_cvs       # perform tests which use CVS
5 %bcond_without  tests_svn       # perform tests which use subversion
6 %bcond_without  doc             # skip building/packaging docs/manuals (takes some time)
7 %bcond_without  pcre            # perl-compatible regexes support
8 %bcond_without  gnome_keyring   # build without gnome keyring support
9
10 %include        /usr/lib/rpm/macros.perl
11 Summary:        Distributed version control system focused on speed, effectivity and usability
12 Summary(pl.UTF-8):      Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
13 Name:           git-core
14 Version:        1.9.0
15 Release:        3
16 License:        GPL v2
17 Group:          Development/Tools
18 Source0:        http://git-core.googlecode.com/files/git-%{version}.tar.gz
19 # Source0-md5:  e16c14b27c644b8e0dd72bdb5ff77450
20 Source1:        %{name}-gitweb.conf
21 Source2:        %{name}-gitweb-httpd.conf
22 Source3:        %{name}-gitweb-lighttpd.conf
23 Source4:        %{name}.sysconfig
24 Source5:        %{name}.inet
25 Source6:        %{name}.init
26 Source7:        gitolite.pl
27 Patch0:         %{name}-tests.patch
28 Patch1:         %{name}-key-bindings.patch
29 Patch2:         %{name}-sysconfdir.patch
30 Patch3:         cherry-picked-commitlog.patch
31 Patch4:         %{name}-svn-exit-errors.patch
32 URL:            http://git-scm.com/
33 BuildRequires:  autoconf >= 2.59
34 BuildRequires:  automake
35 BuildRequires:  curl-devel
36 BuildRequires:  expat-devel
37 BuildRequires:  gettext-devel
38 %{?with_gnome_keyring:BuildRequires:  libgnome-keyring-devel}
39 BuildRequires:  openssl-devel
40 %{?with_pcre:BuildRequires:     pcre-devel}
41 BuildRequires:  perl-Error > 0.15
42 BuildRequires:  perl-base
43 BuildRequires:  python-devel
44 BuildRequires:  rpm-perlprov >= 4.1-13
45 BuildRequires:  rpm-pythonprov
46 BuildRequires:  rpmbuild(macros) >= 1.673
47 BuildRequires:  tcl
48 BuildRequires:  zlib-devel
49 %if %{with doc}
50 BuildRequires:  asciidoc >= 7.1.2-3
51 BuildRequires:  docbook-dtd45-xml
52 BuildRequires:  xmlto
53 %endif
54 %if %{with tests}
55 %if %{with tests_cvs}
56 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
57 BuildRequires:  cvs-gnu-client < 1.13
58 BuildRequires:  cvs-gnu-client >= 1.12
59 %endif
60 %{?with_tests_svn:BuildRequires:  subversion}
61 Conflicts:      pdksh < 5.2.14-46
62 %endif
63 Requires:       coreutils
64 Requires:       diffutils
65 Requires:       findutils
66 Requires:       grep
67 Requires:       openssh-clients
68 Requires:       perl-Error
69 Requires:       perl-Git = %{version}-%{release}
70 Requires:       sed
71 Suggests:       git-core-bzr
72 Suggests:       git-core-cvs
73 Suggests:       git-core-hg
74 Suggests:       git-core-p4
75 Suggests:       git-core-svn
76 Suggests:       less
77 Suggests:       rsync
78 Obsoletes:      python-Git
79 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80
81 # html docs have links to txt files
82 %define         _noautocompressdoc      *.txt
83
84 %define         webapp          gitweb
85 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
86 %define         appdir          %{_datadir}/%{webapp}
87 %define         cgibindir       %{_prefix}/lib/cgi-bin
88
89 %description
90 "git" can mean anything, depending on your mood.
91
92 - random three-letter combination that is pronounceable, and not
93   actually used by any common UNIX command. The fact that it is a
94   mispronunciation of "get" may or may not be relevant.
95 - stupid. contemptible and despicable. simple. Take your pick from the
96   dictionary of slang.
97 - "global information tracker": you're in a good mood, and it actually
98   works for you. Angels sing, and a light suddenly fills the room.
99 - "goddamn idiotic truckload of sh*t": when it breaks
100
101 This is a stupid (but extremely fast) directory content manager. It
102 doesn't do a whole lot, but what it 'does' do is track directory
103 contents efficiently.
104
105 %description -l pl.UTF-8
106 "git" może oznaczać cokolwiek, w zależności od nastroju.
107
108 - losową kombinację trzech liter, która jest wymawialna i właściwie
109   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
110   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
111 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
112 - "global information tracker" (narzędzie do globalnego śledzenia
113   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
114   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
115 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
116   g*) - kiedy się zepsuje.
117
118 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
119 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
120 katalogu.
121
122 %package doc
123 Summary:        Documentation for git-core
124 Summary(pl.UTF-8):      Dokumentacja do git-core
125 Group:          Documentation
126
127 %description doc
128 Documentation for git-core.
129
130 %description doc -l pl.UTF-8
131 Dokumentacja do git-core.
132
133 %description doc -l fr.UTF-8
134 Javadoc pour git-core.
135
136 %package daemon-inetd
137 Summary:        Files necessary to run git-daemon as an inetd service
138 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
139 Group:          Networking/Daemons
140 Requires:       %{name} = %{version}-%{release}
141 Requires:       setup >= 2.4.11-1
142 Provides:       git-core-daemon
143 Obsoletes:      git-core-daemon
144 Obsoletes:      git-core-daemon-standalone
145
146 %description daemon-inetd
147 Git-daemon is a really simple TCP git daemon that can serve git
148 repositories. This package provides all necessarry files to run
149 git-daemon as an inetd service.
150
151 %description daemon-inetd -l pl.UTF-8
152 Git-daemon to prosty demon git korzystający z protokołu TCP do
153 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
154 do uruchomienia git-demona w trybie usługi inetd.
155
156 %package daemon-standalone
157 Summary:        Files necessary to run git-daemon as a standalone service
158 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
159 Group:          Networking/Daemons
160 Requires:       %{name} = %{version}-%{release}
161 Provides:       git-core-daemon
162 Obsoletes:      git-core-daemon
163 Obsoletes:      git-core-daemon-inetd
164
165 %description daemon-standalone
166 Git-daemon is a really simple TCP git daemon that can serve git
167 repositories. This package provides all necessarry files to run
168 git-daemon as an standalone service.
169
170 %description daemon-standalone -l pl.UTF-8
171 Git-daemon to prosty demon git korzystający z protokołu TCP do
172 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
173 do uruchomienia git-daemona w trybie usługi samodzielnej.
174
175 %package devel
176 Summary:        Git library with header files
177 Summary(pl.UTF-8):      Biblioteka Gita oraz pliki nagłówkowe
178 Group:          Development/Libraries
179 Requires:       zlib-devel
180
181 %description devel
182 Git library with header files.
183
184 %description devel -l pl.UTF-8
185 Biblioteka Gita oraz pliki nagłówkowe.
186
187 %package gitk
188 Summary:        Tcl/Tk interface to the Git version control system
189 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
190 Group:          Development/Tools
191 Requires:       %{name} = %{version}-%{release}
192 Requires:       tk
193
194 %description gitk
195 gitk displays changes in a repository or a selected set of commits.
196 This includes visualizing the commit graph, showing information
197 related to each commit, and the files in the trees of each revision.
198
199 Historically, gitk was the first repository browser. It's written in
200 Tcl/Tk and started off in a separate repository but was later merged
201 into the main git repository.
202
203 %description gitk -l pl.UTF-8
204 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
205 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
206 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
207
208 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
209 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
210 osobnym repozytorium, ale z czasem został włączony do głównego
211 repozytorium gita.
212
213 %package gitweb
214 Summary:        Web frontend to git
215 Summary(pl.UTF-8):      Frontend WWW do gita
216 Group:          Development/Tools
217 Requires:       %{name} = %{version}-%{release}
218 Requires:       webapps
219 Requires:       webserver(access)
220 Requires:       webserver(alias)
221 Requires:       webserver(cgi)
222 Suggests:       webserver(setenv)
223
224 %description gitweb
225 This package provides a web interface for browsing git repositories.
226
227 %description gitweb -l pl.UTF-8
228 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
229
230 %package gitview
231 Summary:        A GTK+ based repository browser for git
232 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
233 Group:          Development/Tools
234 Requires:       %{name} = %{version}-%{release}
235 Requires:       python >= 1:2.4
236 Requires:       python-pycairo >= 1.0
237 Requires:       python-pygobject
238 Requires:       python-pygtk-gtk >= 2:2.8
239 Suggests:       python-gnome-desktop-gtksourceview
240
241 %description gitview
242 A GTK+ based repository browser for git.
243
244 %description gitview -l pl.UTF-8
245 Oparta na GTK+ przeglądarka repozytorium gita.
246
247 %package gui
248 Summary:        Tcl/Tk interface to the Git version control system
249 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
250 Group:          Development/Tools
251 Requires:       %{name} = %{version}-%{release}
252 Requires:       tk
253 Requires:       xdg-utils
254 Suggests:       meld
255
256 %description gui
257 Displays changes in a repository or a selected set of commits. This
258 includes visualizing the commit graph, showing information related to
259 each commit, and the files in the trees of each revision.
260
261 Historically, gitk was the first repository browser. It's written in
262 Tcl/Tk and started off in a separate repository but was later merged
263 into the main git repository.
264
265 %description gui -l pl.UTF-8
266 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
267 to wizualizację grafu commitów, wyświetlanie informacji związanych z
268 każdym z commitów oraz listę plików dla każdej rewizji.
269
270 Z punktu widzenia historii, gitk był pierwszą przeglądarką
271 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
272 osobnym repozytorium, ale z czasem został włączony do głównego
273 repozytorium gita.
274
275 %package arch
276 Summary:        Git tools for importing Arch repositories
277 Summary(pl.UTF-8):      Narzędzia Gita do importowania repozytoriów Archa
278 Group:          Development/Tools
279 Requires:       %{name} = %{version}-%{release}
280 Requires:       tla
281
282 %description arch
283 Git tools for importing Arch repositories.
284
285 %description arch -l pl.UTF-8
286 Narzędzia Gita do importowania repozytoriów Archa.
287
288 %package bzr
289 Summary:        Git tools for working with bzr repositories
290 Summary(pl.UTF-8):      Narzędzia Gita do pracy z repozytoriami bzr
291 Group:          Development/Tools
292 Requires:       %{name} = %{version}-%{release}
293 Requires:       bzr
294
295 %description bzr
296 Git tools for working with bzr repositories.
297
298 %description bzr -l pl.UTF-8
299 Narzędzia Gita do pracy z repozytoriami bzr.
300
301 %package cvs
302 Summary:        CVS support for Git
303 Summary(pl.UTF-8):      Obsługa CVS dla Gita
304 Group:          Development/Tools
305 Requires:       %{name} = %{version}-%{release}
306 Requires:       cvsps >= 2.1-2
307 Requires:       rcs
308
309 %description cvs
310 CVS support for Git.
311
312 %description cvs -l pl.UTF-8
313 Obsługa CVS dla Gita.
314
315 %package hg
316 Summary:        Git tools for working with mercurial repositories
317 Summary(pl.UTF-8):      Narzędzia Gita do pracy z repozytoriami mercuriala
318 Group:          Development/Tools
319 Requires:       %{name} = %{version}-%{release}
320 Requires:       mercurial >= 1.8
321
322 %description hg
323 Git tools for working with mercurial repositories.
324
325 %description hg -l pl.UTF-8
326 Narzędzia Gita do pracy z repozytoriami mercuriala.
327
328 %package p4
329 Summary:        Git tools for working with Perforce depots
330 Summary(pl.UTF-8):      Narzędzia Gita do pracy z magazynami Perforce'a
331 Group:          Development/Tools
332 Requires:       %{name} = %{version}-%{release}
333
334 %description p4
335 Git tools for working with Perforce depots.
336
337 %description p4 -l pl.UTF-8
338 Narzędzia Gita do pracy z magazynami Perforce'a.
339
340 %package svn
341 Summary:        Subversion support for Git
342 Summary(pl.UTF-8):      Obsługa Subversion dla Gita
343 Group:          Development/Tools
344 Requires:       %{name} = %{version}-%{release}
345 Requires:       perl-Encode
346 Requires:       perl-Term-ReadKey
347
348 %description svn
349 Subversion support for Git.
350
351 %description svn -l pl.UTF-8
352 Obsługa Subversion dla Gita.
353
354 %package email
355 Summary:        Git tools for sending email
356 Summary(pl.UTF-8):      Narzędzia Gita do wysyłania poczty
357 Group:          Development/Tools
358 Requires:       %{name} = %{version}-%{release}
359
360 %description email
361 Git tools for sending email.
362
363 %description email -l pl.UTF-8
364 Narzędzia Gita do wysyłania poczty.
365
366 %package -n bash-completion-git
367 Summary:        bash-completion for git
368 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
369 Group:          Applications/Shells
370 Requires:       %{name} = %{version}-%{release}
371 Requires:       bash-completion >= 2.0
372 %if "%{_rpmversion}" >= "5"
373 BuildArch:      noarch
374 %endif
375
376 %description -n bash-completion-git
377 This package provides bash-completion for git.
378
379 %description -n bash-completion-git -l pl.UTF-8
380 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
381
382 %package -n perl-Git
383 Summary:        Perl interface to the Git version control system
384 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
385 Group:          Development/Languages/Perl
386 Obsoletes:      perl-git-core
387
388 %description -n perl-Git
389 This module provides Perl scripts easy way to interface the Git
390 version control system. The modules have an easy and well-tested way
391 to call arbitrary Git commands; in the future, the interface will also
392 provide specialized methods for doing easily operations which are not
393 totally trivial to do over the generic command interface.
394
395 %description -n perl-Git -l pl.UTF-8
396 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
397 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
398 dowolne polecenia Gita; w przyszłości interfejs udostępni także
399 specjalne metody do łatwego wykonywania operacji nietrywialnych do
400 wykonania przy użyciu ogólnego interfejsu poleceń.
401
402 %package -n gnome-keyring-git-core
403 Summary:        GNOME Keyring authentication provider for Git
404 Summary(pl.UTF-8):      Moduł uwierzytelniający GNOME Keyring dla Git
405 Group:          X11/Applications
406 Requires:       %{name} = %{version}-%{release}
407
408 %description -n gnome-keyring-git-core
409 Authentication provider module for Git which allows git client to
410 authenticate using GNOME Keyring.
411
412 %description -n gnome-keyring-git-core -l pl.UTF-8
413 Moduł uwierzytelniający dla Subversion pozwalający klientom git
414 uwierzytelniać się przy użyciu mechanizmu GNOME Keyring.
415
416 %prep
417 %setup -q -n git-%{version}
418 %patch0 -p1
419 %patch1 -p0
420 %patch2 -p1
421 %patch3 -p1
422 %patch4 -p1
423
424 %{__rm} {Documentation/technical,contrib/emacs,contrib/credential/gnome-keyring}/.gitignore
425
426 %build
427 %{__aclocal}
428 %{__autoconf}
429 %configure \
430         --sysconfdir=%{_sysconfdir}/git-core \
431         %{?with_pcre:--with-libpcre} \
432         --with-openssl
433
434 echo "BLK_SHA1=1" >> config.mak
435
436 %{__make} \
437         INSTALLDIRS=vendor \
438         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
439         GITWEB_PROJECTROOT="/var/lib/git" \
440         GITWEB_CSS="/gitweb/gitweb.css" \
441         GITWEB_LOGO="/gitweb/git-logo.png" \
442         GITWEB_FAVICON="/gitweb/git-favicon.png" \
443         V=1
444
445 %{__make} -C contrib/subtree
446
447 %if %{with gnome_keyring}
448 %{__make} -C contrib/credential/gnome-keyring
449 %endif
450
451 %if %{with doc}
452 %{__make} -C Documentation \
453         MAN_BASE_URL=file://%{_docdir}/%{name}-doc-%{version}/ \
454         V=1
455 %endif
456
457 %if %{with tests}
458 %if %{without tests_cvs}
459 %{__rm} t/t*cvs*.sh || :
460 %endif
461 %{!?with_tests_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
462 %endif
463
464 %install
465 rm -rf $RPM_BUILD_ROOT
466 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
467 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
468 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
469 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
470 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
471 [init]
472         templatedir = %{_sysconfdir}/%{name}/templates
473 EOF
474
475 %{__make} install \
476         INSTALLDIRS=vendor \
477         DESTDIR=$RPM_BUILD_ROOT
478
479 %if %{with doc}
480 %{__make} -C Documentation install \
481         DESTDIR=$RPM_BUILD_ROOT
482 %endif
483
484 # copy templates except sample hooks
485 cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
486 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
487
488 # header files and lib
489 cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
490 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
491 cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
492 install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
493 cp -p block-sha1/sha1.h $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
494 cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
495 cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
496 cp -p {Makefile,config.mak,config.mak.autogen,config.mak.uname} $RPM_BUILD_ROOT%{_includedir}/%{name}
497
498 %{__make} -C contrib/subtree install \
499         libexecdir=%{_libdir}/%{name} \
500         DESTDIR=$RPM_BUILD_ROOT
501
502 %if %{with doc}
503 %{__make} -C contrib/subtree install-doc \
504         DESTDIR=$RPM_BUILD_ROOT
505 %endif
506
507 %if %{with gnome_keyring}
508 install -p contrib/credential/gnome-keyring/git-credential-gnome-keyring $RPM_BUILD_ROOT%{_libdir}/%{name}
509 # Remove built binary files, otherwise they will be installed in doc
510 %{__make} -C contrib/credential/gnome-keyring clean
511 %endif
512
513 # bash completion
514 install -d $RPM_BUILD_ROOT%{bash_compdir}
515 cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{bash_compdir}/git
516
517 # Install git-prompt.sh
518 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/contrib/completion
519 cp -p contrib/completion/git-prompt.sh $RPM_BUILD_ROOT%{_datadir}/%{name}/contrib/completion
520
521 # Install bzr and hg remote helpers from contrib
522 install -p contrib/remote-helpers/git-remote-{bzr,hg} $RPM_BUILD_ROOT%{_libdir}/%{name}
523
524 # gitweb
525 mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
526 ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
527 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
528 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{webappdir}/gitolite.pl
529 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
530 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
531 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
532
533 # gitview
534 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
535
536 # git-daemon related files
537 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
538 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
539 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
540
541 # paths cleanup
542 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
543 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
544
545 # hardlink
546 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
547 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
548 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
549 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
550
551 # remove unneeded files
552 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
553 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
554 %py_postclean
555
556 mv $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
557 %find_lang git
558
559 %clean
560 rm -rf $RPM_BUILD_ROOT
561
562 %post daemon-inetd
563 %service -q rc-inetd reload
564
565 %postun daemon-inetd
566 if [ "$1" = "0" ]; then
567         %service -q rc-inetd reload
568 fi
569
570 %post daemon-standalone
571 /sbin/chkconfig --add git-daemon
572 %service git-daemon restart "git-daemon"
573
574 %preun daemon-standalone
575 if [ "$1" = "0" ]; then
576         %service git-daemon stop
577         /sbin/chkconfig --del git-daemon
578 fi
579
580 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
581 %webapp_register apache %{webapp}
582
583 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
584 %webapp_unregister apache %{webapp}
585
586 %triggerin gitweb -- apache < 2.2.0, apache-base
587 %webapp_register httpd %{webapp}
588
589 %triggerun gitweb -- apache < 2.2.0, apache-base
590 %webapp_unregister httpd %{webapp}
591
592 %triggerin gitweb -- lighttpd
593 %webapp_register lighttpd %{webapp}
594
595 %triggerun gitweb -- lighttpd
596 %webapp_unregister lighttpd %{webapp}
597
598 %files -f git.lang
599 %defattr(644,root,root,755)
600 %doc README contrib
601 %attr(755,root,root) %{_bindir}/git
602 %attr(755,root,root) %{_bindir}/git-receive-pack
603 %attr(755,root,root) %{_bindir}/git-shell
604 %attr(755,root,root) %{_bindir}/git-upload-archive
605 %attr(755,root,root) %{_bindir}/git-upload-pack
606 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
607
608 %if %{with doc}
609 %{_mandir}/man1/git-*.1*
610 %exclude %{_mandir}/man1/git-archimport.1*
611 %exclude %{_mandir}/man1/git-svn.1*
612 %exclude %{_mandir}/man1/git-cvs*.1*
613 %exclude %{_mandir}/man1/git-imap-send*.1*
614 %exclude %{_mandir}/man1/*email*.1*
615 %{_mandir}/man1/git.1*
616 %{_mandir}/man1/gitremote-helpers.1*
617 %{_mandir}/man5/gitattributes.5*
618 %{_mandir}/man5/githooks.5*
619 %{_mandir}/man5/gitignore.5*
620 %{_mandir}/man5/gitmodules.5*
621 %{_mandir}/man5/gitrepository-layout.5*
622 %{_mandir}/man7/gitcli.7*
623 %{_mandir}/man7/gitcore-tutorial.7*
624 %{_mandir}/man7/gitcredentials.7*
625 %{_mandir}/man7/gitdiffcore.7*
626 %{_mandir}/man7/gitglossary.7*
627 %{_mandir}/man7/gitnamespaces.7*
628 %{_mandir}/man7/gitrevisions.7*
629 %{_mandir}/man7/gittutorial-2.7*
630 %{_mandir}/man7/gittutorial.7*
631 %{_mandir}/man7/gitworkflows.7*
632 %endif
633
634 %dir %{_libdir}/%{name}
635 %attr(755,root,root) %{_libdir}/%{name}/*-*
636 %attr(755,root,root) %{_libdir}/%{name}/git
637 %dir %{_libdir}/%{name}/mergetools
638 %{_libdir}/%{name}/mergetools/*
639
640 %{_datadir}/%{name}
641 %{_localstatedir}/lib/git
642
643 # subpackages
644 %exclude %{_libdir}/%{name}/*email*
645 %exclude %{_libdir}/%{name}/*p4*
646 %exclude %{_libdir}/%{name}/git-archimport
647 %exclude %{_libdir}/%{name}/git-cvs*
648 %exclude %{_libdir}/%{name}/git-gui
649 %exclude %{_libdir}/%{name}/git-imap-send
650 %exclude %{_libdir}/%{name}/git-instaweb
651 %exclude %{_libdir}/%{name}/git-remote-bzr
652 %exclude %{_libdir}/%{name}/git-remote-hg
653 %exclude %{_libdir}/%{name}/git-remote-testsvn
654 %exclude %{_libdir}/%{name}/git-svn
655 %exclude %{_libdir}/%{name}/mergetools/p4merge
656 %exclude %{_libdir}/%{name}/git-credential-gnome-keyring
657
658 %if %{with doc}
659 %files doc
660 %defattr(644,root,root,755)
661 %doc Documentation/RelNotes*
662 %doc Documentation/*.html Documentation/howto Documentation/technical
663 %endif
664
665 %files daemon-inetd
666 %defattr(644,root,root,755)
667 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
668
669 %files daemon-standalone
670 %defattr(644,root,root,755)
671 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
672 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
673
674 %files devel
675 %defattr(644,root,root,755)
676 %{_includedir}/%{name}
677 %{_libdir}/libgit.a
678 %{_libdir}/libgit_xdiff.a
679
680 %files gitk
681 %defattr(644,root,root,755)
682 %if %{with doc}
683 %{_mandir}/man1/gitk.1*
684 %endif
685 %attr(755,root,root) %{_bindir}/gitk
686 %dir %{_datadir}/gitk
687 %dir %{_datadir}/gitk/lib
688 %dir %{_datadir}/gitk/lib/msgs
689 %lang(bg) %{_datadir}/gitk/lib/msgs/bg.msg
690 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
691 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
692 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
693 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
694 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
695 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
696 %lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
697 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
698 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
699
700 %files gitweb
701 %defattr(644,root,root,755)
702 %doc gitweb/{README,INSTALL}
703 %dir %{webappdir}
704 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
705 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
706 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
707 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
708 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitolite.pl
709 %attr(755,root,root) %{cgibindir}/gitweb.cgi
710 %{appdir}
711 %attr(755,root,root) %{_libdir}/%{name}/git-instaweb
712 %if %{with doc}
713 %{_mandir}/man1/gitweb.1*
714 %{_mandir}/man5/gitweb.conf.5*
715 %endif
716
717 %files gitview
718 %defattr(644,root,root,755)
719 %doc contrib/gitview/gitview.txt
720 %attr(755,root,root) %{_bindir}/gitview
721
722 %files gui
723 %defattr(644,root,root,755)
724 %attr(755,root,root) %{_libdir}/%{name}/git-gui
725 %dir %{_datadir}/git-gui
726 %dir %{_datadir}/git-gui/lib
727 %dir %{_datadir}/git-gui/lib/msgs
728 %{_datadir}/git-gui/lib/git-gui.ico
729 %{_datadir}/git-gui/lib/tclIndex
730 %{_datadir}/git-gui/lib/*.js
731 %{_datadir}/git-gui/lib/*.tcl
732 %lang(bg) %{_datadir}/git-gui/lib/msgs/bg.msg
733 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
734 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
735 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
736 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
737 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
738 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
739 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
740 %lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
741 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
742 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
743 %lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
744
745 %files arch
746 %defattr(644,root,root,755)
747 %attr(755,root,root) %{_libdir}/%{name}/git-archimport
748 %if %{with doc}
749 %{_mandir}/man1/git-archimport.1*
750 %endif
751
752 %files bzr
753 %defattr(644,root,root,755)
754 %attr(755,root,root) %{_libdir}/%{name}/git-remote-bzr
755
756 %files cvs
757 %defattr(644,root,root,755)
758 %attr(755,root,root) %{_bindir}/git-cvsserver
759 %attr(755,root,root) %{_libdir}/%{name}/git-cvs*
760 %if %{with doc}
761 %{_mandir}/man1/git-cvs*.1*
762 %{_mandir}/man7/gitcvs-migration.7*
763 %endif
764
765 %files hg
766 %defattr(644,root,root,755)
767 %attr(755,root,root) %{_libdir}/%{name}/git-remote-hg
768
769 %files p4
770 %defattr(644,root,root,755)
771 %attr(755,root,root) %{_libdir}/%{name}/git-p4
772 %attr(755,root,root) %{_libdir}/%{name}/mergetools/p4merge
773
774 %files svn
775 %defattr(644,root,root,755)
776 %attr(755,root,root) %{_libdir}/%{name}/git-svn
777 %attr(755,root,root) %{_libdir}/%{name}/git-remote-testsvn
778 %{perl_vendorlib}/Git/SVN
779 %{perl_vendorlib}/Git/SVN.pm
780 %if %{with doc}
781 %{_mandir}/man1/git-svn.1*
782 %endif
783
784 %files email
785 %defattr(644,root,root,755)
786 %attr(755,root,root) %{_libdir}/%{name}/git-imap-send
787 %attr(755,root,root) %{_libdir}/%{name}/*email*
788 %if %{with doc}
789 %{_mandir}/man1/*email*.1*
790 %{_mandir}/man1/*imap-send*.1*
791 %endif
792
793 %files -n bash-completion-git
794 %defattr(644,root,root,755)
795 %{bash_compdir}/git
796
797 %files -n perl-Git
798 %defattr(644,root,root,755)
799 %{perl_vendorlib}/Git.pm
800 %dir %{perl_vendorlib}/Git
801 %{perl_vendorlib}/Git/I18N.pm
802 %{perl_vendorlib}/Git/IndexInfo.pm
803 %{_mandir}/man3/Git*.3pm*
804
805 %if %{with gnome_keyring}
806 %files -n gnome-keyring-git-core
807 %defattr(644,root,root,755)
808 %attr(755,root,root) %{_libdir}/%{name}/git-credential-gnome-keyring
809 %endif
This page took 0.10995 seconds and 4 git commands to generate.