]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
- typo
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform make test
4 #
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        The stupid content tracker
7 Summary(pl.UTF-8):      Prymitywne narzędzie do śledzenia treści
8 Name:           git-core
9 Version:        1.5.3.5
10 Release:        1
11 License:        GPL v2
12 Group:          Development/Tools
13 Source0:        http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
14 # Source0-md5:  3fdff0bdb3638fce1c4bc6795ed81fb3
15 Source1:        %{name}-gitweb.conf
16 Source2:        %{name}-gitweb-httpd.conf
17 URL:            http://git.or.cz/
18 BuildRequires:  asciidoc >= 7.1.2-3
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  curl-devel
22 BuildRequires:  expat-devel
23 BuildRequires:  openssl-devel
24 BuildRequires:  perl-Error
25 BuildRequires:  perl-base
26 BuildRequires:  python
27 BuildRequires:  rpm-perlprov >= 4.1-13
28 BuildRequires:  rpmbuild(macros) >= 1.264
29 BuildRequires:  xmlto
30 BuildRequires:  zlib-devel
31 %if %{with tests}
32 BuildRequires:  pdksh >= 5.2.14-46
33 BuildRequires:  cvs
34 %endif
35 Requires:       coreutils
36 Requires:       cpio
37 Requires:       curl
38 Requires:       diffutils
39 Requires:       findutils
40 Requires:       grep
41 Requires:       openssh-clients
42 Requires:       perl-Error
43 Requires:       rcs
44 Requires:       sed
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 # html docs have links to txt files
48 %define         _noautocompressdoc      *.txt
49
50 %define         webapp          gitweb
51 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
52 %define         appdir          %{_datadir}/%{webapp}
53 %define         cgibindir       %{_prefix}/lib/cgi-bin
54
55 %description
56 "git" can mean anything, depending on your mood.
57
58  - random three-letter combination that is pronounceable, and not
59    actually used by any common UNIX command. The fact that it is a
60    mispronunciation of "get" may or may not be relevant.
61  - stupid. contemptible and despicable. simple. Take your pick from the
62    dictionary of slang.
63  - "global information tracker": you're in a good mood, and it actually
64    works for you. Angels sing, and a light suddenly fills the room.
65  - "goddamn idiotic truckload of sh*t": when it breaks
66
67 This is a stupid (but extremely fast) directory content manager. It
68 doesn't do a whole lot, but what it 'does' do is track directory
69 contents efficiently.
70
71 %description -l pl.UTF-8
72 "git" może oznaczać cokolwiek, w zależności od nastroju.
73
74 - losową kombinację trzech liter, która jest wymawialna i
75   właściwie nie używana przez żadne popularne polecenie uniksowe.
76   Fakt, że jest to błędna pisownia słowa "get" może mieć lub nie
77   mieć znaczenia.
78 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
79 - "global information tracker" (narzędzie do globalnego śledzenia
80   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
81   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
82 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
83   g*) - kiedy się zepsuje.
84
85 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
86 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
87 katalogu.
88
89 %package devel
90 Summary:        Header files for git-core
91 Summary(pl.UTF-8):      Pliki nagłówkowe dla git-core
92 Group:          Development/Libraries
93
94 %description devel
95 Header files for git-core.
96
97 %description devel -l pl.UTF-8
98 Pliki nagłówkowe dla git-core.
99
100 %package gitk
101 Summary:        Tcl/Tk interface to the Git version control system
102 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
103 Group:          Development/Tools
104 Requires:       %{name} = %{version}-%{release}
105 Requires:       tk
106
107 %description gitk
108 Displays changes in a repository or a selected set of commits. This
109 includes visualizing the commit graph, showing information related to
110 each commit, and the files in the trees of each revision.
111
112 Historically, gitk was the first repository browser. It's written in
113 Tcl/Tk and started off in a separate repository but was later merged
114 into the main git repository.
115
116 %description gitk -l pl.UTF-8
117 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
118 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
119 związanych z każdym z commitów oraz listę plików dla każdej
120 rewizji.
121
122 Z punktu widzenia historii, gitk był pierwszą przeglądarką
123 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany
124 w osobnym repozytorium, ale z czasem został włączony do głównego
125 repozytorium gita.
126
127 %package gitweb
128 Summary:        Web frontend to git
129 Summary(pl.UTF-8):      Webowy frontend do git
130 Group:          Development/Tools
131 Requires:       %{name} = %{version}-%{release}
132 Requires:       webapps
133
134 %description gitweb
135 This package provides a web interface for browsing git repositories.
136
137 %description gitweb -l pl.UTF-8
138 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
139
140 %package gitview
141 Summary:        A GTK+ based repository browser for git
142 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
143 Group:          Development/Tools
144 Requires:       %{name} = %{version}-%{release}
145 #Requires:      pytongowe mambo dżambo
146
147 %description gitview
148 A GTK+ based repository browser for git.
149
150 %description gitview -l pl.UTF-8
151 Oparta na GTK+ przeglądarka repozytorium gita.
152
153 %package -n bash-completion-git
154 Summary:        bash-completion for git
155 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
156 Group:          Applications/Shell
157 Requires:       bash-completion
158
159 %description -n bash-completion-git
160 This package provides bash-completion for git.
161
162 %description -n bash-completion-git -l pl.UTF-8
163 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
164
165 %package -n perl-Git
166 Summary:        Perl interface to the Git version control system
167 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
168 Group:          Development/Languages/Perl
169 Requires:       %{name} = %{version}-%{release}
170 Obsoletes:      perl-git-core
171
172 %description -n perl-Git
173 This module provides Perl scripts easy way to interface the Git
174 version control system. The modules have an easy and well-tested way
175 to call arbitrary Git commands; in the future, the interface will also
176 provide specialized methods for doing easily operations which are not
177 totally trivial to do over the generic command interface.
178
179 %description -n perl-Git -l pl.UTF-8
180 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
181 wersji Git. W łatwy i dobrze przetestowany sposób pozwala
182 wywoływać dowolne polecenia Gita; w przyszłości interfejs
183 udostępni także specjalne metody do łatwego wykonywania operacji
184 nietrywialnych do wykonania przy użyciu ogólnego interfejsu
185 poleceń.
186
187 %package -n vim-syntax-gitcommit
188 Summary:        Vim syntax: gitcommit
189 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
190 Group:          Applications/Editors/Vim
191 # for _vimdatadir existence
192 Requires:       vim >= 4:6.3.058-3
193
194 %description -n vim-syntax-gitcommit
195 This plugin provides syntax highlighting for git's commit messages.
196
197 %description -n vim-syntax-gitcommit -l pl.UTF-8
198 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
199
200 %prep
201 %setup -q -n git-%{version}
202
203 %build
204 %{__aclocal}
205 %{__autoconf}
206 %configure \
207         --with-openssl
208
209 %{__make} \
210         INSTALLDIRS=vendor \
211         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
212         GITWEB_PROJECTROOT="/var/lib/git" \
213         GITWEB_CSS="/gitweb/gitweb.css" \
214         GITWEB_LOGO="/gitweb/git-logo.png" \
215         GITWEB_FAVICON="/gitweb/git-favicon.png"
216
217 %{__make} -C Documentation
218
219 %{?with_tests:%{__make} test}
220
221 %install
222 rm -rf $RPM_BUILD_ROOT
223 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_sharedstatedir}/git}
224 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
225 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
226 install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
227
228 %{__make} install \
229         INSTALLDIRS=vendor \
230         DESTDIR=$RPM_BUILD_ROOT
231
232 %{__make} -C Documentation install \
233         DESTDIR=$RPM_BUILD_ROOT
234
235 # header files and lib
236 install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
237 install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
238 install libgit.a $RPM_BUILD_ROOT%{_libdir}
239
240 # bash completion
241 install contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
242
243 # vim syntax
244 install contrib/vim/syntax/gitcommit.vim $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
245
246 # gitweb
247 install gitweb/*.css gitweb/*.png $RPM_BUILD_ROOT%{appdir}
248 install gitweb/gitweb.cgi $RPM_BUILD_ROOT%{cgibindir}
249 install %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
250 install %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
251 install %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
252
253 # gitview
254 install contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
255
256 # remove unneeded files
257 rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
258 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
259
260 %clean
261 rm -rf $RPM_BUILD_ROOT
262
263 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
264 %webapp_register apache %{webapp}
265
266 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
267 %webapp_unregister apache %{webapp}
268
269 %triggerin gitweb -- apache < 2.2.0, apache-base
270 %webapp_register httpd %{webapp}
271
272 %triggerun gitweb -- apache < 2.2.0, apache-base
273 %webapp_unregister httpd %{webapp}
274
275 %files
276 %defattr(644,root,root,755)
277 %doc README Documentation/{[!g]*,g[!i]*,git,git[!k]*}.html Documentation/howto Documentation/technical contrib
278 %attr(755,root,root) %{_bindir}/git
279 %attr(755,root,root) %{_bindir}/git-*
280 %{_mandir}/man1/git-*.1*
281 %{_mandir}/man5/gitattributes.5*
282 %{_mandir}/man5/gitignore.5*
283 %{_mandir}/man5/gitmodules.5*
284 %{_mandir}/man7/git.7*
285 %{_datadir}/%{name}
286 %{_datadir}/git-gui
287 %{_sharedstatedir}/git
288
289 %files devel
290 %defattr(644,root,root,755)
291 %{_includedir}/*
292 %{_libdir}/*.a
293
294 %files gitk
295 %defattr(644,root,root,755)
296 %doc Documentation/gitk.html
297 %attr(755,root,root) %{_bindir}/gitk
298 %{_mandir}/man1/gitk.1*
299
300 %files gitweb
301 %defattr(644,root,root,755)
302 %doc gitweb/{README,INSTALL}
303 %dir %{webappdir}
304 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
305 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
306 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
307 %attr(755,root,root) %{cgibindir}/gitweb.cgi
308 %{appdir}
309
310 %files gitview
311 %defattr(644,root,root,755)
312 %doc contrib/gitview/gitview.txt
313 %attr(755,root,root) %{_bindir}/gitview
314
315 %files -n bash-completion-git
316 %defattr(644,root,root,755)
317 %{_sysconfdir}/bash_completion.d/*
318
319 %files -n perl-Git
320 %defattr(644,root,root,755)
321 %{perl_vendorlib}/Git.pm
322 %{_mandir}/man3/Git.3pm*
323
324 %files -n vim-syntax-gitcommit
325 %defattr(644,root,root,755)
326 %doc contrib/vim/README
327 %{_datadir}/vim/vimfiles/syntax/*
This page took 0.047462 seconds and 4 git commands to generate.