]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
noarch packages
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform make test
4 %bcond_with     tests_cvs       # perform tests which use CVS
5 %bcond_without  tests_svn       # perform tests which use subversion
6 %bcond_without  doc             # skip building/packaging docs/manuals (takes some time)
7 %bcond_without  pcre            # perl-compatible regexes support
8 %bcond_without  gnome_keyring   # build without gnome keyring support
9
10 # for AC: --without doc --without gnome_keyring --without tests
11
12 %include        /usr/lib/rpm/macros.perl
13 Summary:        Distributed version control system focused on speed, effectivity and usability
14 Summary(pl.UTF-8):      Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
15 Name:           git-core
16 Version:        2.7.1
17 Release:        3
18 License:        GPL v2
19 Group:          Development/Tools
20 Source0:        http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.gz
21 # Source0-md5:  846ac45a1638e9a6ff3a9b790f6c8d99
22 Source1:        %{name}-gitweb.conf
23 Source2:        %{name}-gitweb-httpd.conf
24 Source3:        %{name}-gitweb-lighttpd.conf
25 Source4:        %{name}.sysconfig
26 Source5:        %{name}.inet
27 Source6:        %{name}.init
28 Source7:        gitolite.pl
29 Patch0:         %{name}-tests.patch
30 Patch1:         %{name}-key-bindings.patch
31 Patch2:         %{name}-sysconfdir.patch
32 Patch3:         cherry-picked-commitlog.patch
33 Patch4:         %{name}-svn-exit-errors.patch
34 Patch5:         %{name}-test-grep.patch
35 URL:            http://git-scm.com/
36 BuildRequires:  autoconf >= 2.59
37 BuildRequires:  automake
38 BuildRequires:  curl-devel
39 BuildRequires:  expat-devel
40 BuildRequires:  gettext-tools
41 %if %{with gnome_keyring}
42 BuildRequires:  libgnome-keyring-devel
43 BuildRequires:  pkgconfig
44 %endif
45 BuildRequires:  openssl-devel
46 %{?with_pcre:BuildRequires:     pcre-devel}
47 BuildRequires:  perl-Error > 0.15
48 BuildRequires:  perl-base
49 BuildRequires:  python-devel
50 BuildRequires:  rpm-perlprov >= 4.1-13
51 BuildRequires:  rpm-pythonprov
52 BuildRequires:  rpmbuild(macros) >= 1.673
53 BuildRequires:  tcl
54 BuildRequires:  zlib-devel
55 %if %{with doc}
56 BuildRequires:  asciidoc >= 7.1.2-3
57 BuildRequires:  docbook-dtd45-xml
58 BuildRequires:  xmlto
59 %endif
60 %if %{with tests}
61 %if %{with tests_cvs}
62 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
63 BuildRequires:  cvs-gnu-client < 1.13
64 BuildRequires:  cvs-gnu-client >= 1.12
65 %endif
66 %if %{with tests_svn}
67 BuildRequires:  perl-subversion
68 BuildRequires:  subversion
69 %endif
70 Conflicts:      pdksh < 5.2.14-46
71 %endif
72 # git-sh-setup: sane_grep
73 Requires:       grep
74 # git-pull: printf
75 Requires:       coreutils
76 Requires:       openssh-clients
77 Requires:       perl-Error
78 Requires:       perl-Git = %{version}-%{release}
79 Requires:       sed
80 Suggests:       git-core-bzr
81 Suggests:       git-core-cvs
82 Suggests:       git-core-hg
83 Suggests:       git-core-p4
84 Suggests:       git-core-svn
85 Suggests:       less
86 Suggests:       rsync
87 Obsoletes:      python-Git
88 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
89
90 # html docs have links to txt files
91 %define         _noautocompressdoc      *.txt
92
93 %define         webapp          gitweb
94 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
95 %define         appdir          %{_datadir}/%{webapp}
96 %define         cgibindir       %{_prefix}/lib/cgi-bin
97 %define         gitcoredir      %{_prefix}/lib/%{name}
98 %define         _libexecdir     %{_prefix}/lib
99
100 %description
101 "git" can mean anything, depending on your mood.
102
103 - random three-letter combination that is pronounceable, and not
104   actually used by any common UNIX command. The fact that it is a
105   mispronunciation of "get" may or may not be relevant.
106 - stupid. contemptible and despicable. simple. Take your pick from the
107   dictionary of slang.
108 - "global information tracker": you're in a good mood, and it actually
109   works for you. Angels sing, and a light suddenly fills the room.
110 - "goddamn idiotic truckload of sh*t": when it breaks
111
112 This is a stupid (but extremely fast) directory content manager. It
113 doesn't do a whole lot, but what it 'does' do is track directory
114 contents efficiently.
115
116 %description -l pl.UTF-8
117 "git" może oznaczać cokolwiek, w zależności od nastroju.
118
119 - losową kombinację trzech liter, która jest wymawialna i właściwie
120   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
121   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
122 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
123 - "global information tracker" (narzędzie do globalnego śledzenia
124   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
125   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
126 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
127   g*) - kiedy się zepsuje.
128
129 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
130 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
131 katalogu.
132
133 %package doc
134 Summary:        Documentation for git-core
135 Summary(pl.UTF-8):      Dokumentacja do git-core
136 Group:          Documentation
137 %if "%{_rpmversion}" >= "5"
138 BuildArch:      noarch
139 %endif
140
141 %description doc
142 Documentation for git-core.
143
144 %description doc -l pl.UTF-8
145 Dokumentacja do git-core.
146
147 %package daemon-inetd
148 Summary:        Files necessary to run git-daemon as an inetd service
149 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
150 Group:          Networking/Daemons
151 Requires:       %{name} = %{version}-%{release}
152 Requires:       setup >= 2.4.11-1
153 Provides:       git-core-daemon
154 Obsoletes:      git-core-daemon
155 Obsoletes:      git-core-daemon-standalone
156 %if "%{_rpmversion}" >= "5"
157 BuildArch:      noarch
158 %endif
159
160 %description daemon-inetd
161 Git-daemon is a really simple TCP git daemon that can serve git
162 repositories. This package provides all necessarry files to run
163 git-daemon as an inetd service.
164
165 %description daemon-inetd -l pl.UTF-8
166 Git-daemon to prosty demon git korzystający z protokołu TCP do
167 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
168 do uruchomienia git-demona w trybie usługi inetd.
169
170 %package daemon-standalone
171 Summary:        Files necessary to run git-daemon as a standalone service
172 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
173 Group:          Networking/Daemons
174 Requires:       %{name} = %{version}-%{release}
175 Provides:       git-core-daemon
176 Obsoletes:      git-core-daemon
177 Obsoletes:      git-core-daemon-inetd
178 %if "%{_rpmversion}" >= "5"
179 BuildArch:      noarch
180 %endif
181
182 %description daemon-standalone
183 Git-daemon is a really simple TCP git daemon that can serve git
184 repositories. This package provides all necessarry files to run
185 git-daemon as an standalone service.
186
187 %description daemon-standalone -l pl.UTF-8
188 Git-daemon to prosty demon git korzystający z protokołu TCP do
189 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
190 do uruchomienia git-daemona w trybie usługi samodzielnej.
191
192 %package devel
193 Summary:        Git library with header files
194 Summary(pl.UTF-8):      Biblioteka Gita oraz pliki nagłówkowe
195 Group:          Development/Libraries
196 Requires:       zlib-devel
197
198 %description devel
199 Git library with header files.
200
201 %description devel -l pl.UTF-8
202 Biblioteka Gita oraz pliki nagłówkowe.
203
204 %package gitk
205 Summary:        Tcl/Tk interface to the Git version control system
206 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
207 Group:          Development/Tools
208 Requires:       %{name} = %{version}-%{release}
209 Requires:       tk
210 %if "%{_rpmversion}" >= "5"
211 BuildArch:      noarch
212 %endif
213
214 %description gitk
215 gitk displays changes in a repository or a selected set of commits.
216 This includes visualizing the commit graph, showing information
217 related to each commit, and the files in the trees of each revision.
218
219 Historically, gitk was the first repository browser. It's written in
220 Tcl/Tk and started off in a separate repository but was later merged
221 into the main git repository.
222
223 %description gitk -l pl.UTF-8
224 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
225 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
226 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
227
228 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
229 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
230 osobnym repozytorium, ale z czasem został włączony do głównego
231 repozytorium gita.
232
233 %package gitweb
234 Summary:        Web frontend to git
235 Summary(pl.UTF-8):      Frontend WWW do gita
236 Group:          Development/Tools
237 Requires:       %{name} = %{version}-%{release}
238 Requires:       webapps
239 Requires:       webserver(access)
240 Requires:       webserver(alias)
241 Requires:       webserver(cgi)
242 Suggests:       webserver(setenv)
243 %if "%{_rpmversion}" >= "5"
244 BuildArch:      noarch
245 %endif
246
247 %description gitweb
248 This package provides a web interface for browsing git repositories.
249
250 %description gitweb -l pl.UTF-8
251 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
252
253 %package gitview
254 Summary:        A GTK+ based repository browser for git
255 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
256 Group:          Development/Tools
257 Requires:       %{name} = %{version}-%{release}
258 Requires:       python >= 1:2.4
259 Requires:       python-pycairo >= 1.0
260 Requires:       python-pygobject
261 Requires:       python-pygtk-gtk >= 2:2.8
262 Suggests:       python-gnome-desktop-gtksourceview
263 %if "%{_rpmversion}" >= "5"
264 BuildArch:      noarch
265 %endif
266
267 %description gitview
268 A GTK+ based repository browser for git.
269
270 %description gitview -l pl.UTF-8
271 Oparta na GTK+ przeglądarka repozytorium gita.
272
273 %package gui
274 Summary:        Tcl/Tk interface to the Git version control system
275 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
276 Group:          Development/Tools
277 Requires:       %{name} = %{version}-%{release}
278 Requires:       tk
279 Requires:       xdg-utils
280 Suggests:       meld
281 %if "%{_rpmversion}" >= "5"
282 BuildArch:      noarch
283 %endif
284
285 %description gui
286 Displays changes in a repository or a selected set of commits. This
287 includes visualizing the commit graph, showing information related to
288 each commit, and the files in the trees of each revision.
289
290 Historically, gitk was the first repository browser. It's written in
291 Tcl/Tk and started off in a separate repository but was later merged
292 into the main git repository.
293
294 %description gui -l pl.UTF-8
295 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
296 to wizualizację grafu commitów, wyświetlanie informacji związanych z
297 każdym z commitów oraz listę plików dla każdej rewizji.
298
299 Z punktu widzenia historii, gitk był pierwszą przeglądarką
300 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
301 osobnym repozytorium, ale z czasem został włączony do głównego
302 repozytorium gita.
303
304 %package arch
305 Summary:        Git tools for importing Arch repositories
306 Summary(pl.UTF-8):      Narzędzia Gita do importowania repozytoriów Archa
307 Group:          Development/Tools
308 Requires:       %{name} = %{version}-%{release}
309 Requires:       tla
310 %if "%{_rpmversion}" >= "5"
311 BuildArch:      noarch
312 %endif
313
314 %description arch
315 Git tools for importing Arch repositories.
316
317 %description arch -l pl.UTF-8
318 Narzędzia Gita do importowania repozytoriów Archa.
319
320 %package bzr
321 Summary:        Git tools for working with bzr repositories
322 Summary(pl.UTF-8):      Narzędzia Gita do pracy z repozytoriami bzr
323 Group:          Development/Tools
324 Requires:       %{name} = %{version}-%{release}
325 Requires:       bzr
326 %if "%{_rpmversion}" >= "5"
327 BuildArch:      noarch
328 %endif
329
330 %description bzr
331 Git tools for working with bzr repositories.
332
333 %description bzr -l pl.UTF-8
334 Narzędzia Gita do pracy z repozytoriami bzr.
335
336 %package cvs
337 Summary:        CVS support for Git
338 Summary(pl.UTF-8):      Obsługa CVS dla Gita
339 Group:          Development/Tools
340 Requires:       %{name} = %{version}-%{release}
341 Requires:       cvsps >= 2.1-2
342 Requires:       rcs
343 %if "%{_rpmversion}" >= "5"
344 BuildArch:      noarch
345 %endif
346
347 %description cvs
348 CVS support for Git.
349
350 %description cvs -l pl.UTF-8
351 Obsługa CVS dla Gita.
352
353 %package hg
354 Summary:        Git tools for working with mercurial repositories
355 Summary(pl.UTF-8):      Narzędzia Gita do pracy z repozytoriami mercuriala
356 Group:          Development/Tools
357 Requires:       %{name} = %{version}-%{release}
358 Requires:       mercurial >= 1.8
359 %if "%{_rpmversion}" >= "5"
360 BuildArch:      noarch
361 %endif
362
363 %description hg
364 Git tools for working with mercurial repositories.
365
366 %description hg -l pl.UTF-8
367 Narzędzia Gita do pracy z repozytoriami mercuriala.
368
369 %package p4
370 Summary:        Git tools for working with Perforce depots
371 Summary(pl.UTF-8):      Narzędzia Gita do pracy z magazynami Perforce'a
372 Group:          Development/Tools
373 Requires:       %{name} = %{version}-%{release}
374 %if "%{_rpmversion}" >= "5"
375 BuildArch:      noarch
376 %endif
377
378 %description p4
379 Git tools for working with Perforce depots.
380
381 %description p4 -l pl.UTF-8
382 Narzędzia Gita do pracy z magazynami Perforce'a.
383
384 %package svn
385 Summary:        Subversion support for Git
386 Summary(pl.UTF-8):      Obsługa Subversion dla Gita
387 Group:          Development/Tools
388 Requires:       %{name} = %{version}-%{release}
389 Requires:       perl-Encode
390 Requires:       perl-Term-ReadKey
391
392 %description svn
393 Subversion support for Git.
394
395 %description svn -l pl.UTF-8
396 Obsługa Subversion dla Gita.
397
398 %package email
399 Summary:        Git tools for sending email
400 Summary(pl.UTF-8):      Narzędzia Gita do wysyłania poczty
401 Group:          Development/Tools
402 Requires:       %{name} = %{version}-%{release}
403
404 %description email
405 Git tools for sending email.
406
407 %description email -l pl.UTF-8
408 Narzędzia Gita do wysyłania poczty.
409
410 %package -n bash-completion-git
411 Summary:        bash-completion for git
412 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
413 Group:          Applications/Shells
414 Requires:       %{name} = %{version}-%{release}
415 Requires:       bash-completion >= 2.0
416 %if "%{_rpmversion}" >= "5"
417 BuildArch:      noarch
418 %endif
419
420 %description -n bash-completion-git
421 This package provides bash-completion for git.
422
423 %description -n bash-completion-git -l pl.UTF-8
424 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
425
426 %package -n perl-Git
427 Summary:        Perl interface to the Git version control system
428 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
429 Group:          Development/Languages/Perl
430 Obsoletes:      perl-git-core
431
432 %description -n perl-Git
433 This module provides Perl scripts easy way to interface the Git
434 version control system. The modules have an easy and well-tested way
435 to call arbitrary Git commands; in the future, the interface will also
436 provide specialized methods for doing easily operations which are not
437 totally trivial to do over the generic command interface.
438
439 %description -n perl-Git -l pl.UTF-8
440 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
441 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
442 dowolne polecenia Gita; w przyszłości interfejs udostępni także
443 specjalne metody do łatwego wykonywania operacji nietrywialnych do
444 wykonania przy użyciu ogólnego interfejsu poleceń.
445
446 %package -n gnome-keyring-git-core
447 Summary:        GNOME Keyring authentication provider for Git
448 Summary(pl.UTF-8):      Moduł uwierzytelniający GNOME Keyring dla Git
449 Group:          X11/Applications
450 URL:            http://git-scm.com/docs/gitcredentials.html
451 Requires:       %{name} = %{version}-%{release}
452
453 %description -n gnome-keyring-git-core
454 Authentication provider module for Git which allows git client to
455 authenticate using GNOME Keyring.
456
457 You need to register it with:
458 - git config --global credential.helper gnome-keyring
459
460 %description -n gnome-keyring-git-core -l pl.UTF-8
461 Moduł uwierzytelniający dla Subversion pozwalający klientom git
462 uwierzytelniać się przy użyciu mechanizmu GNOME Keyring.
463
464 Moduł trzeba zarejestrować poleceniem:
465 - git config --global credential.helper gnome-keyring
466
467 %prep
468 %setup -q -n git-%{version}
469 %patch0 -p1
470 %patch1 -p0
471 %patch2 -p1
472 %patch3 -p1
473 %patch4 -p1
474 %patch5 -p0
475
476 %{__rm} {Documentation/technical,contrib/emacs,contrib/credential/gnome-keyring}/.gitignore
477
478 # we build things in contrib but want to have it clean for doc purporses, too
479 cp -a contrib contrib-doc
480
481 %build
482 %{__aclocal}
483 %{__autoconf}
484 %configure \
485         --sysconfdir=%{_sysconfdir}/git-core \
486         %{?with_pcre:--with-libpcre} \
487         --with-openssl
488
489 echo "BLK_SHA1=1" >> config.mak
490
491 %{__make} \
492         INSTALLDIRS=vendor \
493         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
494         GITWEB_PROJECTROOT="/var/lib/git" \
495         GITWEB_CSS="/gitweb/gitweb.css" \
496         GITWEB_LOGO="/gitweb/git-logo.png" \
497         GITWEB_FAVICON="/gitweb/git-favicon.png" \
498         V=1
499
500 %{__make} -C contrib/subtree
501
502 %if %{with gnome_keyring}
503 %{__make} -C contrib/credential/gnome-keyring
504 %endif
505
506 %if %{with doc}
507 %{__make} -C Documentation \
508         MAN_BASE_URL=file://%{_docdir}/%{name}-doc-%{version}/ \
509         V=1
510 %endif
511
512 %if %{with tests}
513 %if %{without tests_cvs}
514 %{__rm} t/t*cvs*.sh || :
515 %endif
516 %{!?with_tests_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
517 %endif
518
519 %install
520 rm -rf $RPM_BUILD_ROOT
521 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
522 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
523 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
524 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
525 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
526 [init]
527         templatedir = %{_sysconfdir}/%{name}/templates
528 EOF
529
530 %{__make} install \
531         INSTALLDIRS=vendor \
532         DESTDIR=$RPM_BUILD_ROOT
533
534 %if %{with doc}
535 %{__make} -C Documentation install \
536         DESTDIR=$RPM_BUILD_ROOT
537 %endif
538
539 # copy templates except sample hooks
540 cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
541 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
542
543 # header files and lib
544 cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
545 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
546 cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
547 install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
548 cp -p block-sha1/sha1.h $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
549 cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
550 cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
551 cp -p {Makefile,config.mak,config.mak.autogen,config.mak.uname} $RPM_BUILD_ROOT%{_includedir}/%{name}
552
553 %{__make} -C contrib/subtree install \
554         libexecdir=%{gitcoredir} \
555         DESTDIR=$RPM_BUILD_ROOT
556
557 %if %{with doc}
558 %{__make} -C contrib/subtree install-man \
559         DESTDIR=$RPM_BUILD_ROOT
560 %endif
561
562 %if %{with gnome_keyring}
563 install -p contrib/credential/gnome-keyring/git-credential-gnome-keyring $RPM_BUILD_ROOT%{gitcoredir}
564 %endif
565
566 # bash completion
567 install -d $RPM_BUILD_ROOT%{bash_compdir}
568 cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{bash_compdir}/git
569
570 # Install git-prompt.sh
571 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/contrib/completion
572 cp -p contrib/completion/git-prompt.sh $RPM_BUILD_ROOT%{_datadir}/%{name}/contrib/completion
573
574 # Install bzr and hg remote helpers from contrib
575 install -p contrib/remote-helpers/git-remote-{bzr,hg} $RPM_BUILD_ROOT%{gitcoredir}
576
577 # gitweb
578 mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
579 ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
580 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
581 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{webappdir}/gitolite.pl
582 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
583 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
584 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
585
586 # gitview
587 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
588
589 # git-daemon related files
590 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
591 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
592 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
593
594 # paths cleanup
595 sed -e 's,@libdir@/git-core,%{gitcoredir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
596 sed -e 's,@libdir@/git-core,%{gitcoredir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
597
598 # hardlink
599 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
600 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
601 ln -f $RPM_BUILD_ROOT{%{gitcoredir},%{_bindir}}/git-shell
602 ln -f $RPM_BUILD_ROOT{%{gitcoredir},%{_bindir}}/git-upload-pack
603
604 # remove unneeded files
605 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
606 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
607 %py_postclean
608
609 mv $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
610 %find_lang git
611
612 %clean
613 rm -rf $RPM_BUILD_ROOT
614
615 %post daemon-inetd
616 %service -q rc-inetd reload
617
618 %postun daemon-inetd
619 if [ "$1" = "0" ]; then
620         %service -q rc-inetd reload
621 fi
622
623 %post daemon-standalone
624 /sbin/chkconfig --add git-daemon
625 %service git-daemon restart "git-daemon"
626
627 %preun daemon-standalone
628 if [ "$1" = "0" ]; then
629         %service git-daemon stop
630         /sbin/chkconfig --del git-daemon
631 fi
632
633 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
634 %webapp_register apache %{webapp}
635
636 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
637 %webapp_unregister apache %{webapp}
638
639 %triggerin gitweb -- apache < 2.2.0, apache-base
640 %webapp_register httpd %{webapp}
641
642 %triggerun gitweb -- apache < 2.2.0, apache-base
643 %webapp_unregister httpd %{webapp}
644
645 %triggerin gitweb -- lighttpd
646 %webapp_register lighttpd %{webapp}
647
648 %triggerun gitweb -- lighttpd
649 %webapp_unregister lighttpd %{webapp}
650
651 %files -f git.lang
652 %defattr(644,root,root,755)
653 %doc README contrib-doc
654 %attr(755,root,root) %{_bindir}/git
655 %attr(755,root,root) %{_bindir}/git-receive-pack
656 %attr(755,root,root) %{_bindir}/git-shell
657 %attr(755,root,root) %{_bindir}/git-upload-archive
658 %attr(755,root,root) %{_bindir}/git-upload-pack
659 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
660
661 %if %{with doc}
662 %{_mandir}/man1/git-*.1*
663 %exclude %{_mandir}/man1/git-archimport.1*
664 %exclude %{_mandir}/man1/git-svn.1*
665 %exclude %{_mandir}/man1/git-cvs*.1*
666 %exclude %{_mandir}/man1/git-imap-send*.1*
667 %exclude %{_mandir}/man1/*email*.1*
668 %{_mandir}/man1/git.1*
669 %{_mandir}/man1/gitremote-helpers.1*
670 %{_mandir}/man5/gitattributes.5*
671 %{_mandir}/man5/githooks.5*
672 %{_mandir}/man5/gitignore.5*
673 %{_mandir}/man5/gitmodules.5*
674 %{_mandir}/man5/gitrepository-layout.5*
675 %{_mandir}/man7/gitcli.7*
676 %{_mandir}/man7/gitcore-tutorial.7*
677 %{_mandir}/man7/gitcredentials.7*
678 %{_mandir}/man7/gitdiffcore.7*
679 %{_mandir}/man7/giteveryday.7*
680 %{_mandir}/man7/gitglossary.7*
681 %{_mandir}/man7/gitnamespaces.7*
682 %{_mandir}/man7/gitrevisions.7*
683 %{_mandir}/man7/gittutorial-2.7*
684 %{_mandir}/man7/gittutorial.7*
685 %{_mandir}/man7/gitworkflows.7*
686 %endif
687
688 %dir %{gitcoredir}
689 %attr(755,root,root) %{gitcoredir}/*-*
690 %attr(755,root,root) %{gitcoredir}/git
691 %dir %{gitcoredir}/mergetools
692 %{gitcoredir}/mergetools/*
693
694 %{_datadir}/%{name}
695 %{_localstatedir}/lib/git
696
697 # subpackages
698 %exclude %{gitcoredir}/*email*
699 %exclude %{gitcoredir}/*p4*
700 %exclude %{gitcoredir}/git-archimport
701 %exclude %{gitcoredir}/git-cvs*
702 %exclude %{gitcoredir}/git-gui
703 %exclude %{gitcoredir}/git-imap-send
704 %exclude %{gitcoredir}/git-instaweb
705 %exclude %{gitcoredir}/git-remote-bzr
706 %exclude %{gitcoredir}/git-remote-hg
707 %exclude %{gitcoredir}/git-remote-testsvn
708 %exclude %{gitcoredir}/git-svn
709 %exclude %{gitcoredir}/mergetools/p4merge
710 %if %{with gnome_keyring}
711 %exclude %{gitcoredir}/git-credential-gnome-keyring
712 %endif
713
714 %if %{with doc}
715 %files doc
716 %defattr(644,root,root,755)
717 %doc Documentation/RelNotes*
718 %doc Documentation/*.html Documentation/howto Documentation/technical
719 %endif
720
721 %files daemon-inetd
722 %defattr(644,root,root,755)
723 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
724
725 %files daemon-standalone
726 %defattr(644,root,root,755)
727 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
728 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
729
730 %files devel
731 %defattr(644,root,root,755)
732 %{_includedir}/%{name}
733 %{_libdir}/libgit.a
734 %{_libdir}/libgit_xdiff.a
735
736 %files gitk
737 %defattr(644,root,root,755)
738 %if %{with doc}
739 %{_mandir}/man1/gitk.1*
740 %endif
741 %attr(755,root,root) %{_bindir}/gitk
742 %dir %{_datadir}/gitk
743 %dir %{_datadir}/gitk/lib
744 %dir %{_datadir}/gitk/lib/msgs
745 %lang(bg) %{_datadir}/gitk/lib/msgs/bg.msg
746 %lang(ca) %{_datadir}/gitk/lib/msgs/ca.msg
747 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
748 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
749 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
750 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
751 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
752 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
753 %lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
754 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
755 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
756 %lang(vi) %{_datadir}/gitk/lib/msgs/vi.msg
757
758 %files gitweb
759 %defattr(644,root,root,755)
760 %doc gitweb/{README,INSTALL}
761 %dir %{webappdir}
762 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
763 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
764 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
765 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
766 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitolite.pl
767 %attr(755,root,root) %{cgibindir}/gitweb.cgi
768 %{appdir}
769 %attr(755,root,root) %{gitcoredir}/git-instaweb
770 %if %{with doc}
771 %{_mandir}/man1/gitweb.1*
772 %{_mandir}/man5/gitweb.conf.5*
773 %endif
774
775 %files gitview
776 %defattr(644,root,root,755)
777 %doc contrib/gitview/gitview.txt
778 %attr(755,root,root) %{_bindir}/gitview
779
780 %files gui
781 %defattr(644,root,root,755)
782 %attr(755,root,root) %{gitcoredir}/git-gui
783 %dir %{_datadir}/git-gui
784 %dir %{_datadir}/git-gui/lib
785 %dir %{_datadir}/git-gui/lib/msgs
786 %{_datadir}/git-gui/lib/git-gui.ico
787 %{_datadir}/git-gui/lib/tclIndex
788 %{_datadir}/git-gui/lib/*.js
789 %{_datadir}/git-gui/lib/*.tcl
790 %lang(bg) %{_datadir}/git-gui/lib/msgs/bg.msg
791 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
792 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
793 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
794 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
795 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
796 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
797 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
798 %lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
799 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
800 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
801 %lang(vi) %{_datadir}/git-gui/lib/msgs/vi.msg
802 %lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
803
804 %files arch
805 %defattr(644,root,root,755)
806 %attr(755,root,root) %{gitcoredir}/git-archimport
807 %if %{with doc}
808 %{_mandir}/man1/git-archimport.1*
809 %endif
810
811 %files bzr
812 %defattr(644,root,root,755)
813 %attr(755,root,root) %{gitcoredir}/git-remote-bzr
814
815 %files cvs
816 %defattr(644,root,root,755)
817 %attr(755,root,root) %{_bindir}/git-cvsserver
818 %attr(755,root,root) %{gitcoredir}/git-cvs*
819 %if %{with doc}
820 %{_mandir}/man1/git-cvs*.1*
821 %{_mandir}/man7/gitcvs-migration.7*
822 %endif
823
824 %files hg
825 %defattr(644,root,root,755)
826 %attr(755,root,root) %{gitcoredir}/git-remote-hg
827
828 %files p4
829 %defattr(644,root,root,755)
830 %attr(755,root,root) %{gitcoredir}/git-p4
831 %attr(755,root,root) %{gitcoredir}/mergetools/p4merge
832
833 %files svn
834 %defattr(644,root,root,755)
835 %attr(755,root,root) %{gitcoredir}/git-svn
836 %attr(755,root,root) %{gitcoredir}/git-remote-testsvn
837 %{perl_vendorlib}/Git/SVN
838 %{perl_vendorlib}/Git/SVN.pm
839 %if %{with doc}
840 %{_mandir}/man1/git-svn.1*
841 %endif
842
843 %files email
844 %defattr(644,root,root,755)
845 %attr(755,root,root) %{gitcoredir}/git-imap-send
846 %attr(755,root,root) %{gitcoredir}/*email*
847 %if %{with doc}
848 %{_mandir}/man1/*email*.1*
849 %{_mandir}/man1/*imap-send*.1*
850 %endif
851
852 %files -n bash-completion-git
853 %defattr(644,root,root,755)
854 %{bash_compdir}/git
855
856 %files -n perl-Git
857 %defattr(644,root,root,755)
858 %{perl_vendorlib}/Git.pm
859 %dir %{perl_vendorlib}/Git
860 %{perl_vendorlib}/Git/I18N.pm
861 %{perl_vendorlib}/Git/IndexInfo.pm
862 %{_mandir}/man3/Git*.3pm*
863
864 %if %{with gnome_keyring}
865 %files -n gnome-keyring-git-core
866 %defattr(644,root,root,755)
867 %attr(755,root,root) %{gitcoredir}/git-credential-gnome-keyring
868 %endif
This page took 0.1801 seconds and 3 git commands to generate.