]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
70f4b23453fc54983219358b9b6ef2fbf4d2ac56
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform make test
4 %bcond_with     tests_cvs       # perform tests which use CVS
5 %bcond_with     tests_svn       # perform tests which use subversion
6 %bcond_without  doc             # skip building/packaging docs/manuals (takes some time)
7
8 %include        /usr/lib/rpm/macros.perl
9 Summary:        Distributed version control system focused on speed, effectivity and usability
10 Summary(pl.UTF-8):      Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
11 Name:           git-core
12 Version:        1.7.9.4
13 Release:        1
14 License:        GPL v2
15 Group:          Development/Tools
16 # Source0:      http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
17 Source0:        http://git-core.googlecode.com/files/git-%{version}.tar.gz
18 # Source0-md5:  f1e32b2ec841219e442db9c9ef21c252
19 Source1:        %{name}-gitweb.conf
20 Source2:        %{name}-gitweb-httpd.conf
21 Source3:        %{name}-gitweb-lighttpd.conf
22 Source4:        %{name}.sysconfig
23 Source5:        %{name}.inet
24 Source6:        %{name}.init
25 Patch0:         %{name}-tests.patch
26 Patch1:         %{name}-key-bindings.patch
27 Patch2:         %{name}-sysconfdir.patch
28 URL:            http://git-scm.com/
29 BuildRequires:  autoconf >= 2.59
30 BuildRequires:  automake
31 BuildRequires:  curl-devel
32 BuildRequires:  expat-devel
33 BuildRequires:  gettext-devel
34 BuildRequires:  openssl-devel
35 BuildRequires:  perl-Error > 0.15
36 BuildRequires:  perl-base
37 BuildRequires:  python-devel
38 BuildRequires:  rpm-perlprov >= 4.1-13
39 BuildRequires:  rpm-pythonprov
40 BuildRequires:  rpmbuild(macros) >= 1.264
41 BuildRequires:  tcl
42 BuildRequires:  zlib-devel
43 %if %{with doc}
44 BuildRequires:  asciidoc >= 7.1.2-3
45 BuildRequires:  docbook-dtd45-xml
46 BuildRequires:  xmlto
47 %endif
48 %if %{with tests}
49 %if %{with tests_cvs}
50 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
51 BuildRequires:  cvs-gnu-client < 1.13
52 BuildRequires:  cvs-gnu-client >= 1.12
53 %endif
54 Conflicts:      pdksh < 5.2.14-46
55 %endif
56 Requires:       coreutils
57 Requires:       diffutils
58 Requires:       findutils
59 Requires:       grep
60 Requires:       openssh-clients
61 Requires:       perl-Error
62 Requires:       perl-Git = %{version}-%{release}
63 Requires:       sed
64 Suggests:       git-core-cvs
65 Suggests:       git-core-svn
66 Suggests:       less
67 Suggests:       rsync
68 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
70 # html docs have links to txt files
71 %define         _noautocompressdoc      *.txt
72
73 %define         webapp          gitweb
74 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
75 %define         appdir          %{_datadir}/%{webapp}
76 %define         cgibindir       %{_prefix}/lib/cgi-bin
77
78 %description
79 "git" can mean anything, depending on your mood.
80
81 - random three-letter combination that is pronounceable, and not
82   actually used by any common UNIX command. The fact that it is a
83   mispronunciation of "get" may or may not be relevant.
84 - stupid. contemptible and despicable. simple. Take your pick from the
85   dictionary of slang.
86 - "global information tracker": you're in a good mood, and it actually
87   works for you. Angels sing, and a light suddenly fills the room.
88 - "goddamn idiotic truckload of sh*t": when it breaks
89
90 This is a stupid (but extremely fast) directory content manager. It
91 doesn't do a whole lot, but what it 'does' do is track directory
92 contents efficiently.
93
94 %description -l pl.UTF-8
95 "git" może oznaczać cokolwiek, w zależności od nastroju.
96
97 - losową kombinację trzech liter, która jest wymawialna i właściwie
98   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
99   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
100 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
101 - "global information tracker" (narzędzie do globalnego śledzenia
102   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
103   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
104 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
105   g*) - kiedy się zepsuje.
106
107 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
108 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
109 katalogu.
110
111 %package doc
112 Summary:        Documentation for git-core
113 Summary(pl.UTF-8):      Dokumentacja do git-core
114 Group:          Documentation
115
116 %description doc
117 Documentation for git-core.
118
119 %description doc -l pl.UTF-8
120 Dokumentacja do git-core.
121
122 %description doc -l fr.UTF-8
123 Javadoc pour git-core.
124
125 %package daemon-inetd
126 Summary:        Files necessary to run git-daemon as an inetd service
127 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
128 Group:          Networking/Daemons
129 Requires:       %{name} = %{version}-%{release}
130 Requires:       setup >= 2.4.11-1
131 Provides:       git-core-daemon
132 Obsoletes:      git-core-daemon
133 Obsoletes:      git-core-daemon-standalone
134
135 %description daemon-inetd
136 Git-daemon is a really simple TCP git daemon that can serve git
137 repositories. This package provides all necessarry files to run
138 git-daemon as an inetd service.
139
140 %description daemon-inetd -l pl.UTF-8
141 Git-daemon to prosty demon git korzystający z protokołu TCP do
142 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
143 do uruchomienia git-demona w trybie usługi inetd.
144
145 %package daemon-standalone
146 Summary:        Files necessary to run git-daemon as a standalone service
147 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
148 Group:          Networking/Daemons
149 Requires:       %{name} = %{version}-%{release}
150 Provides:       git-core-daemon
151 Obsoletes:      git-core-daemon
152 Obsoletes:      git-core-daemon-inetd
153
154 %description daemon-standalone
155 Git-daemon is a really simple TCP git daemon that can serve git
156 repositories. This package provides all necessarry files to run
157 git-daemon as an standalone service.
158
159 %description daemon-standalone -l pl.UTF-8
160 Git-daemon to prosty demon git korzystający z protokołu TCP do
161 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
162 do uruchomienia git-daemona w trybie usługi samodzielnej.
163
164 %package devel
165 Summary:        Header files for git-core
166 Summary(pl.UTF-8):      Pliki nagłówkowe dla git-core
167 Group:          Development/Libraries
168 Requires:       zlib-devel
169
170 %description devel
171 Header files for git-core.
172
173 %description devel -l pl.UTF-8
174 Pliki nagłówkowe dla git-core.
175
176 %package gitk
177 Summary:        Tcl/Tk interface to the Git version control system
178 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
179 Group:          Development/Tools
180 Requires:       %{name} = %{version}-%{release}
181 Requires:       tk
182
183 %description gitk
184 gitk displays changes in a repository or a selected set of commits.
185 This includes visualizing the commit graph, showing information
186 related to each commit, and the files in the trees of each revision.
187
188 Historically, gitk was the first repository browser. It's written in
189 Tcl/Tk and started off in a separate repository but was later merged
190 into the main git repository.
191
192 %description gitk -l pl.UTF-8
193 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
194 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
195 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
196
197 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
198 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
199 osobnym repozytorium, ale z czasem został włączony do głównego
200 repozytorium gita.
201
202 %package gitweb
203 Summary:        Web frontend to git
204 Summary(pl.UTF-8):      Frontend WWW do gita
205 Group:          Development/Tools
206 Requires:       %{name} = %{version}-%{release}
207 Requires:       webapps
208 Requires:       webserver(alias)
209 Requires:       webserver(cgi)
210
211 %description gitweb
212 This package provides a web interface for browsing git repositories.
213
214 %description gitweb -l pl.UTF-8
215 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
216
217 %package gitview
218 Summary:        A GTK+ based repository browser for git
219 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
220 Group:          Development/Tools
221 Requires:       %{name} = %{version}-%{release}
222 Requires:       python >= 1:2.4
223 Requires:       python-pycairo >= 1.0
224 Requires:       python-pygobject
225 Requires:       python-pygtk-gtk >= 2:2.8
226 Suggests:       python-gnome-desktop-gtksourceview
227
228 %description gitview
229 A GTK+ based repository browser for git.
230
231 %description gitview -l pl.UTF-8
232 Oparta na GTK+ przeglądarka repozytorium gita.
233
234 %package gui
235 Summary:        Tcl/Tk interface to the Git version control system
236 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
237 Group:          Development/Tools
238 Requires:       %{name} = %{version}-%{release}
239 Requires:       tk
240 Requires:       xdg-utils
241 Suggests:       meld
242
243 %description gui
244 Displays changes in a repository or a selected set of commits. This
245 includes visualizing the commit graph, showing information related to
246 each commit, and the files in the trees of each revision.
247
248 Historically, gitk was the first repository browser. It's written in
249 Tcl/Tk and started off in a separate repository but was later merged
250 into the main git repository.
251
252 %description gui -l pl.UTF-8
253 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
254 to wizualizację grafu commitów, wyświetlanie informacji związanych z
255 każdym z commitów oraz listę plików dla każdej rewizji.
256
257 Z punktu widzenia historii, gitk był pierwszą przeglądarką
258 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
259 osobnym repozytorium, ale z czasem został włączony do głównego
260 repozytorium gita.
261
262 %package svn
263 Summary:        Subversion support for Git
264 Summary(pl.UTF-8):      Obsługa Subversion dla Gita
265 Group:          Development/Tools
266 Requires:       %{name} = %{version}-%{release}
267 Requires:       perl-Encode
268 Requires:       perl-Term-ReadKey
269
270 %description svn
271 Subversion support for Git.
272
273 %description svn -l pl.UTF-8
274 Obsługa Subversion dla Gita.
275
276 %package cvs
277 Summary:        CVS support for Git
278 Summary(pl.UTF-8):      Obsługa CVS dla Gita
279 Group:          Development/Tools
280 Requires:       %{name} = %{version}-%{release}
281 Requires:       cvsps >= 2.1-2
282 Requires:       rcs
283
284 %description cvs
285 CVS support for Git.
286
287 %description cvs -l pl.UTF-8
288 Obsługa CVS dla Gita.
289
290 %package arch
291 Summary:        Git tools for importing Arch repositories
292 Summary(pl.UTF-8):      Narzędzia Gita do importowania repozytoriów Archa
293 Group:          Development/Tools
294 Requires:       %{name} = %{version}-%{release}
295 Requires:       tla
296
297 %description arch
298 Git tools for importing Arch repositories.
299
300 %description arch -l pl.UTF-8
301 Narzędzia Gita do importowania repozytoriów Archa.
302
303 %package email
304 Summary:        Git tools for sending email
305 Summary(pl.UTF-8):      Narzędzia Gita do wysyłania poczty
306 Group:          Development/Tools
307 Requires:       %{name} = %{version}-%{release}
308
309 %description email
310 Git tools for sending email.
311
312 %description email -l pl.UTF-8
313 Narzędzia Gita do wysyłania poczty.
314
315 %package -n bash-completion-git
316 Summary:        bash-completion for git
317 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
318 Group:          Applications/Shells
319 Requires:       %{name} = %{version}-%{release}
320 Requires:       bash-completion
321
322 %description -n bash-completion-git
323 This package provides bash-completion for git.
324
325 %description -n bash-completion-git -l pl.UTF-8
326 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
327
328 %package -n perl-Git
329 Summary:        Perl interface to the Git version control system
330 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
331 Group:          Development/Languages/Perl
332 Obsoletes:      perl-git-core
333
334 %description -n perl-Git
335 This module provides Perl scripts easy way to interface the Git
336 version control system. The modules have an easy and well-tested way
337 to call arbitrary Git commands; in the future, the interface will also
338 provide specialized methods for doing easily operations which are not
339 totally trivial to do over the generic command interface.
340
341 %description -n perl-Git -l pl.UTF-8
342 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
343 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
344 dowolne polecenia Gita; w przyszłości interfejs udostępni także
345 specjalne metody do łatwego wykonywania operacji nietrywialnych do
346 wykonania przy użyciu ogólnego interfejsu poleceń.
347
348 %package -n python-Git
349 Summary:        Python Git remote helpers for non-git repositories
350 Summary(pl.UTF-8):      Pythonowe zdalne moduły pomocnicze dla repozytoriów niegitowych
351 Group:          Development/Languages/Python
352 Requires:       %{name} = %{version}-%{release}
353
354 %description -n python-Git
355 This package contains Python git_repote_helpers package - Git remote
356 helpers for non-git repositories.
357
358 %description -n python-Git -l pl.UTF-8
359 Ten pakiet zawiera pakiet Pythona git_remote_helpers - zdalne moduły
360 pomocnicze Gita dla repozytoriów niegitowych.
361
362 %package -n vim-syntax-gitcommit
363 Summary:        Vim syntax: gitcommit
364 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
365 Group:          Applications/Editors/Vim
366 Requires:       %{name} = %{version}-%{release}
367 # for _vimdatadir existence
368 Requires:       vim-rt >= 4:6.3.058-3
369
370 %description -n vim-syntax-gitcommit
371 This plugin provides syntax highlighting for git's commit messages.
372
373 %description -n vim-syntax-gitcommit -l pl.UTF-8
374 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
375
376 %prep
377 %setup -q -n git-%{version}
378 %patch0 -p1
379 %patch1 -p0
380 %patch2 -p1
381
382 %build
383 %{__aclocal}
384 %{__autoconf}
385 %configure \
386         --sysconfdir=%{_sysconfdir}/git-core \
387         --with-openssl
388
389 echo "BLK_SHA1=1" >> config.mak
390
391 %{__make} \
392         INSTALLDIRS=vendor \
393         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
394         GITWEB_PROJECTROOT="/var/lib/git" \
395         GITWEB_CSS="/gitweb/gitweb.css" \
396         GITWEB_LOGO="/gitweb/git-logo.png" \
397         GITWEB_FAVICON="/gitweb/git-favicon.png" \
398         V=1
399
400 # use DOCBOOK_XSL_172=1 to fix 'the ".ft C" problem' in generated manpages.
401 %{?with_doc:%{__make} -C Documentation V=1 DOCBOOK_XSL_172=1}
402
403 %if %{with tests}
404 %if %{without tests_cvs}
405 rm t/t*cvs*.sh || :
406 %endif
407 %{!?with_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
408 %endif
409
410 %install
411 rm -rf $RPM_BUILD_ROOT
412 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
413 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
414 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
415 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
416 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
417 [init]
418         templatedir = %{_sysconfdir}/%{name}/templates
419 EOF
420
421 %{__make} install \
422         INSTALLDIRS=vendor \
423         DESTDIR=$RPM_BUILD_ROOT
424
425 %if %{with doc}
426 %{__make} -C Documentation install \
427         DESTDIR=$RPM_BUILD_ROOT
428 %endif
429
430 # copy templates except sample hooks
431 cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
432 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
433
434 # header files and lib
435 cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
436 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
437 cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
438 cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
439 cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
440
441 # bash completion
442 install -d $RPM_BUILD_ROOT/etc/bash_completion.d
443 cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT/etc/bash_completion.d
444
445 # vim syntax
446 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
447 cat > $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax/gitcommit.vim << 'EOF'
448 autocmd BufNewFile,BufRead *.git/COMMIT_EDITMSG    setf gitcommit
449 autocmd BufNewFile,BufRead *.git/config,.gitconfig setf gitconfig
450 autocmd BufNewFile,BufRead git-rebase-todo         setf gitrebase
451 autocmd BufNewFile,BufRead .msg.[0-9]*
452         \ if getline(1) =~ '^From.*# This line is ignored.$' |
453         \   setf gitsendemail |
454         \ endif
455 autocmd BufNewFile,BufRead *.git/**
456         \ if getline(1) =~ '^\x\{40\}\>\|^ref: ' |
457         \   setf git |
458         \ endif
459 EOF
460
461 # gitweb
462 mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
463 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
464 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
465 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
466 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
467
468 # gitview
469 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
470
471 # git-daemon related files
472 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
473 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
474 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
475
476 # paths cleanup
477 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
478 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
479
480 # hardlink
481 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
482 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
483 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
484 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
485
486 # remove unneeded files
487 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
488 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
489 %py_postclean
490
491 %find_lang git
492
493 %clean
494 rm -rf $RPM_BUILD_ROOT
495
496 %post daemon-inetd
497 %service -q rc-inetd reload
498
499 %postun daemon-inetd
500 if [ "$1" = "0" ]; then
501         %service -q rc-inetd reload
502 fi
503
504 %post daemon-standalone
505 /sbin/chkconfig --add git-daemon
506 %service git-daemon restart "git-daemon"
507
508 %preun daemon-standalone
509 if [ "$1" = "0" ]; then
510         %service git-daemon stop
511         /sbin/chkconfig --del git-daemon
512 fi
513
514 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
515 %webapp_register apache %{webapp}
516
517 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
518 %webapp_unregister apache %{webapp}
519
520 %triggerin gitweb -- apache < 2.2.0, apache-base
521 %webapp_register httpd %{webapp}
522
523 %triggerun gitweb -- apache < 2.2.0, apache-base
524 %webapp_unregister httpd %{webapp}
525
526 %triggerin gitweb -- lighttpd
527 %webapp_register lighttpd %{webapp}
528
529 %triggerun gitweb -- lighttpd
530 %webapp_unregister lighttpd %{webapp}
531
532 %files -f git.lang
533 %defattr(644,root,root,755)
534 %doc README contrib
535 %attr(755,root,root) %{_bindir}/git
536 %attr(755,root,root) %{_bindir}/git-receive-pack
537 %attr(755,root,root) %{_bindir}/git-shell
538 %attr(755,root,root) %{_bindir}/git-upload-archive
539 %attr(755,root,root) %{_bindir}/git-upload-pack
540 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
541
542 %if %{with doc}
543 %{_mandir}/man1/git-*.1*
544 %exclude %{_mandir}/man1/git-svn.1*
545 %exclude %{_mandir}/man1/git-cvs*.1*
546 %exclude %{_mandir}/man1/git-remote-helpers.1*
547 %{_mandir}/man1/git.1*
548 %{_mandir}/man5/gitattributes.5*
549 %{_mandir}/man5/githooks.5*
550 %{_mandir}/man5/gitignore.5*
551 %{_mandir}/man5/gitmodules.5*
552 %{_mandir}/man5/gitrepository-layout.5*
553 %{_mandir}/man7/gitcli.7*
554 %{_mandir}/man7/gitcore-tutorial.7*
555 %{_mandir}/man7/gitcredentials.7*
556 %{_mandir}/man7/gitdiffcore.7*
557 %{_mandir}/man7/gitglossary.7*
558 %{_mandir}/man7/gitnamespaces.7*
559 %{_mandir}/man7/gitrevisions.7*
560 %{_mandir}/man7/gittutorial-2.7*
561 %{_mandir}/man7/gittutorial.7*
562 %{_mandir}/man7/gitworkflows.7*
563 %endif
564
565 %dir %{_libdir}/%{name}
566 %attr(755,root,root) %{_libdir}/%{name}/*-*
567 %attr(755,root,root) %{_libdir}/%{name}/git
568 %{_libdir}/%{name}/mergetools
569
570 %exclude %{_libdir}/%{name}/git-gui
571 %exclude %{_libdir}/%{name}/git-svn
572 %exclude %{_libdir}/%{name}/git-archimport
573 %exclude %{_libdir}/%{name}/git-cvs*
574 %exclude %{_libdir}/%{name}/git-remote-testgit
575 %exclude %{_libdir}/%{name}/*email*
576
577 %{_datadir}/%{name}
578
579 %{_localstatedir}/lib/git
580
581 %if %{with doc}
582 %files doc
583 %defattr(644,root,root,755)
584 %doc Documentation/RelNotes*
585 %doc Documentation/*.html Documentation/howto Documentation/technical
586 %endif
587
588 %files daemon-inetd
589 %defattr(644,root,root,755)
590 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
591
592 %files daemon-standalone
593 %defattr(644,root,root,755)
594 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
595 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
596
597 %files devel
598 %defattr(644,root,root,755)
599 %{_includedir}/%{name}
600 %{_libdir}/libgit.a
601 %{_libdir}/libgit_xdiff.a
602
603 %files gitk
604 %defattr(644,root,root,755)
605 %if %{with doc}
606 %{_mandir}/man1/gitk.1*
607 %endif
608 %attr(755,root,root) %{_bindir}/gitk
609 %dir %{_datadir}/gitk
610 %dir %{_datadir}/gitk/lib
611 %dir %{_datadir}/gitk/lib/msgs
612 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
613 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
614 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
615 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
616 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
617 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
618 %lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
619 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
620 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
621
622 %files gitweb
623 %defattr(644,root,root,755)
624 %doc gitweb/{README,INSTALL}
625 %dir %{webappdir}
626 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
627 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
628 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
629 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
630 %attr(755,root,root) %{cgibindir}/gitweb.cgi
631 %{appdir}
632 %{_mandir}/man1/gitweb.1*
633 %{_mandir}/man5/gitweb.conf.5*
634
635 %files gitview
636 %defattr(644,root,root,755)
637 %doc contrib/gitview/gitview.txt
638 %attr(755,root,root) %{_bindir}/gitview
639
640 %files gui
641 %defattr(644,root,root,755)
642 %attr(755,root,root) %{_libdir}/%{name}/git-gui
643 %dir %{_datadir}/git-gui
644 %dir %{_datadir}/git-gui/lib
645 %dir %{_datadir}/git-gui/lib/msgs
646 %{_datadir}/git-gui/lib/git-gui.ico
647 %{_datadir}/git-gui/lib/tclIndex
648 %{_datadir}/git-gui/lib/*.js
649 %{_datadir}/git-gui/lib/*.tcl
650 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
651 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
652 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
653 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
654 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
655 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
656 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
657 %lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
658 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
659 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
660 %lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
661
662 %files svn
663 %defattr(644,root,root,755)
664 %attr(755,root,root) %{_libdir}/%{name}/git-svn
665 %if %{with doc}
666 %{_mandir}/man1/git-svn.1*
667 %endif
668
669 %files cvs
670 %defattr(644,root,root,755)
671 %attr(755,root,root) %{_bindir}/git-cvsserver
672 %attr(755,root,root) %{_libdir}/%{name}/git-cvs*
673 %if %{with doc}
674 %{_mandir}/man1/git-cvs*.1*
675 %{_mandir}/man7/gitcvs-migration.7*
676 %endif
677
678 %files arch
679 %defattr(644,root,root,755)
680 %attr(755,root,root) %{_libdir}/%{name}/git-archimport
681 %if %{with doc}
682 %{_mandir}/man1/git-archimport.1*
683 %endif
684
685 %files email
686 %defattr(644,root,root,755)
687 %attr(755,root,root) %{_libdir}/%{name}/*email*
688 %if %{with doc}
689 %{_mandir}/man1/*email*.1*
690 %endif
691
692 %files -n bash-completion-git
693 %defattr(644,root,root,755)
694 /etc/bash_completion.d/git-completion.bash
695
696 %files -n perl-Git
697 %defattr(644,root,root,755)
698 %{perl_vendorlib}/Git.pm
699 %{perl_vendorlib}/Git
700 %{_mandir}/man3/Git*.3pm*
701
702 %files -n python-Git
703 %defattr(644,root,root,755)
704 %attr(755,root,root) %{_libdir}/%{name}/git-remote-testgit
705 %dir %{py_sitescriptdir}/git_remote_helpers
706 %{py_sitescriptdir}/git_remote_helpers/*.py[co]
707 %dir %{py_sitescriptdir}/git_remote_helpers/git
708 %{py_sitescriptdir}/git_remote_helpers/git/*.py[co]
709 %if "%{py_ver}" > "2.4"
710 %{py_sitescriptdir}/git_remote_helpers*.egg-info
711 %endif
712 %if %{with doc}
713 %{_mandir}/man1/git-remote-helpers.1*
714 %endif
715
716 %files -n vim-syntax-gitcommit
717 %defattr(644,root,root,755)
718 %doc contrib/vim/README
719 %{_datadir}/vim/vimfiles/syntax/gitcommit.vim
This page took 0.062869 seconds and 2 git commands to generate.