]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
- fix for key bindings in SHA1 bar
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform make test
4 %bcond_with     tests_cvs       # perform tests which use CVS
5 %bcond_without  doc             # skip building/packaging docs/manuals (takes some time)
6 #
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        The stupid content tracker
9 Summary(pl.UTF-8):      Prymitywne narzędzie do śledzenia treści
10 Name:           git-core
11 Version:        1.7.4
12 Release:        1
13 License:        GPL v2
14 Group:          Development/Tools
15 Source0:        http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
16 # Source0-md5:  fa24dc1ef0b663327ea0fe1981365b39
17 Source1:        %{name}-gitweb.conf
18 Source2:        %{name}-gitweb-httpd.conf
19 Source3:        %{name}-gitweb-lighttpd.conf
20 Source4:        %{name}.sysconfig
21 Source5:        %{name}.inet
22 Source6:        %{name}.init
23 Patch0:         %{name}-tests.patch
24 Patch1:         %{name}-key-bindings.patch
25 URL:            http://git-scm.com/
26 BuildRequires:  autoconf
27 BuildRequires:  automake
28 BuildRequires:  curl-devel
29 BuildRequires:  expat-devel
30 BuildRequires:  gettext-devel
31 BuildRequires:  openssl-devel
32 BuildRequires:  perl-Error > 0.15
33 BuildRequires:  perl-base
34 BuildRequires:  python-devel
35 BuildRequires:  rpm-perlprov >= 4.1-13
36 BuildRequires:  rpm-pythonprov
37 BuildRequires:  rpmbuild(macros) >= 1.264
38 BuildRequires:  tcl
39 BuildRequires:  zlib-devel
40 %if %{with doc}
41 BuildRequires:  asciidoc >= 7.1.2-3
42 BuildRequires:  docbook-dtd45-xml
43 BuildRequires:  xmlto
44 %endif
45 %if %{with tests}
46 %if %{with tests_cvs}
47 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
48 BuildRequires:  cvs-gnu-client < 1.13
49 BuildRequires:  cvs-gnu-client >= 1.12
50 %endif
51 BuildRequires:  pdksh >= 5.2.14-46
52 %endif
53 Requires:       coreutils
54 Requires:       diffutils
55 Requires:       findutils
56 Requires:       grep
57 Requires:       openssh-clients
58 Requires:       perl-Error
59 Requires:       perl-Git = %{version}-%{release}
60 Requires:       sed
61 Suggests:       git-core-cvs
62 Suggests:       git-core-svn
63 Suggests:       less
64 Suggests:       rsync
65 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
66
67 # html docs have links to txt files
68 %define         _noautocompressdoc      *.txt
69
70 %define         webapp          gitweb
71 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
72 %define         appdir          %{_datadir}/%{webapp}
73 %define         cgibindir       %{_prefix}/lib/cgi-bin
74
75 %description
76 "git" can mean anything, depending on your mood.
77
78 - random three-letter combination that is pronounceable, and not
79   actually used by any common UNIX command. The fact that it is a
80   mispronunciation of "get" may or may not be relevant.
81 - stupid. contemptible and despicable. simple. Take your pick from the
82   dictionary of slang.
83 - "global information tracker": you're in a good mood, and it actually
84   works for you. Angels sing, and a light suddenly fills the room.
85 - "goddamn idiotic truckload of sh*t": when it breaks
86
87 This is a stupid (but extremely fast) directory content manager. It
88 doesn't do a whole lot, but what it 'does' do is track directory
89 contents efficiently.
90
91 %description -l pl.UTF-8
92 "git" może oznaczać cokolwiek, w zależności od nastroju.
93
94 - losową kombinację trzech liter, która jest wymawialna i właściwie
95   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
96   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
97 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
98 - "global information tracker" (narzędzie do globalnego śledzenia
99   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
100   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
101 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
102   g*) - kiedy się zepsuje.
103
104 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
105 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
106 katalogu.
107
108 %package doc
109 Summary:        Documentation for git-core
110 Summary(pl.UTF-8):      Dokumentacja do git-core
111 Group:          Documentation
112
113 %description doc
114 Documentation for git-core.
115
116 %description doc -l pl.UTF-8
117 Dokumentacja do git-core.
118
119 %description doc -l fr.UTF-8
120 Javadoc pour git-core.
121
122 %package daemon-inetd
123 Summary:        Files necessary to run git-daemon as an inetd service
124 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
125 Group:          Networking/Daemons
126 Requires:       %{name} = %{version}-%{release}
127 Requires:       setup >= 2.4.11-1
128 Provides:       git-core-daemon
129 Obsoletes:      git-core-daemon
130 Obsoletes:      git-core-daemon-standalone
131
132 %description daemon-inetd
133 Git-daemon is a really simple TCP git daemon that can serve git
134 repositories. This package provides all necessarry files to run
135 git-daemon as an inetd service.
136
137 %description daemon-inetd -l pl.UTF-8
138 Git-daemon to prosty demon git korzystający z protokołu TCP do
139 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
140 do uruchomienia git-demona w trybie usługi inetd.
141
142 %package daemon-standalone
143 Summary:        Files necessary to run git-daemon as a standalone service
144 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
145 Group:          Networking/Daemons
146 Requires:       %{name} = %{version}-%{release}
147 Provides:       git-core-daemon
148 Obsoletes:      git-core-daemon
149 Obsoletes:      git-core-daemon-inetd
150
151 %description daemon-standalone
152 Git-daemon is a really simple TCP git daemon that can serve git
153 repositories. This package provides all necessarry files to run
154 git-daemon as an standalone service.
155
156 %description daemon-standalone -l pl.UTF-8
157 Git-daemon to prosty demon git korzystający z protokołu TCP do
158 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
159 do uruchomienia git-daemona w trybie usługi samodzielnej.
160
161 %package devel
162 Summary:        Header files for git-core
163 Summary(pl.UTF-8):      Pliki nagłówkowe dla git-core
164 Group:          Development/Libraries
165 Requires:       zlib-devel
166
167 %description devel
168 Header files for git-core.
169
170 %description devel -l pl.UTF-8
171 Pliki nagłówkowe dla git-core.
172
173 %package gitk
174 Summary:        Tcl/Tk interface to the Git version control system
175 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
176 Group:          Development/Tools
177 Requires:       %{name} = %{version}-%{release}
178 Requires:       tk
179
180 %description gitk
181 gitk displays changes in a repository or a selected set of commits.
182 This includes visualizing the commit graph, showing information
183 related to each commit, and the files in the trees of each revision.
184
185 Historically, gitk was the first repository browser. It's written in
186 Tcl/Tk and started off in a separate repository but was later merged
187 into the main git repository.
188
189 %description gitk -l pl.UTF-8
190 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
191 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
192 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
193
194 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
195 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
196 osobnym repozytorium, ale z czasem został włączony do głównego
197 repozytorium gita.
198
199 %package gitweb
200 Summary:        Web frontend to git
201 Summary(pl.UTF-8):      Frontend WWW do gita
202 Group:          Development/Tools
203 Requires:       %{name} = %{version}-%{release}
204 Requires:       webapps
205 Requires:       webserver(alias)
206 Requires:       webserver(cgi)
207
208 %description gitweb
209 This package provides a web interface for browsing git repositories.
210
211 %description gitweb -l pl.UTF-8
212 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
213
214 %package gitview
215 Summary:        A GTK+ based repository browser for git
216 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
217 Group:          Development/Tools
218 Requires:       %{name} = %{version}-%{release}
219 Requires:       python >= 1:2.4
220 Requires:       python-pycairo >= 1.0
221 Requires:       python-pygobject
222 Requires:       python-pygtk-gtk >= 2:2.8
223 Suggests:       python-gnome-desktop-gtksourceview
224
225 %description gitview
226 A GTK+ based repository browser for git.
227
228 %description gitview -l pl.UTF-8
229 Oparta na GTK+ przeglądarka repozytorium gita.
230
231 %package gui
232 Summary:        Tcl/Tk interface to the Git version control system
233 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
234 Group:          Development/Tools
235 Requires:       %{name} = %{version}-%{release}
236 Requires:       tk
237 Requires:       xdg-utils
238 Suggests:       meld
239
240 %description gui
241 Displays changes in a repository or a selected set of commits. This
242 includes visualizing the commit graph, showing information related to
243 each commit, and the files in the trees of each revision.
244
245 Historically, gitk was the first repository browser. It's written in
246 Tcl/Tk and started off in a separate repository but was later merged
247 into the main git repository.
248
249 %description gui -l pl.UTF-8
250 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
251 to wizualizację grafu commitów, wyświetlanie informacji związanych z
252 każdym z commitów oraz listę plików dla każdej rewizji.
253
254 Z punktu widzenia historii, gitk był pierwszą przeglądarką
255 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
256 osobnym repozytorium, ale z czasem został włączony do głównego
257 repozytorium gita.
258
259 %package svn
260 Summary:        Subversion support for Git
261 Summary(pl.UTF-8):      Obsługa Subversion dla Gita
262 Group:          Development/Tools
263 Requires:       %{name} = %{version}-%{release}
264 Requires:       perl-Term-ReadKey
265
266 %description svn
267 Subversion support for Git.
268
269 %description svn -l pl.UTF-8
270 Obsługa Subversion dla Gita.
271
272 %package cvs
273 Summary:        CVS support for Git
274 Summary(pl.UTF-8):      Obsługa CVS dla Gita
275 Group:          Development/Tools
276 Requires:       %{name} = %{version}-%{release}
277 Requires:       cvsps >= 2.1-2
278 Requires:       rcs
279
280 %description cvs
281 CVS support for Git.
282
283 %description cvs -l pl.UTF-8
284 Obsługa CVS dla Gita.
285
286 %package arch
287 Summary:        Git tools for importing Arch repositories
288 Summary(pl.UTF-8):      Narzędzia Gita do importowania repozytoriów Archa
289 Group:          Development/Tools
290 Requires:       %{name} = %{version}-%{release}
291 Requires:       tla
292
293 %description arch
294 Git tools for importing Arch repositories.
295
296 %description arch -l pl.UTF-8
297 Narzędzia Gita do importowania repozytoriów Archa.
298
299 %package email
300 Summary:        Git tools for sending email
301 Summary(pl.UTF-8):      Narzędzia Gita do wysyłania poczty
302 Group:          Development/Tools
303 Requires:       %{name} = %{version}-%{release}
304
305 %description email
306 Git tools for sending email.
307
308 %description email -l pl.UTF-8
309 Narzędzia Gita do wysyłania poczty.
310
311 %package -n bash-completion-git
312 Summary:        bash-completion for git
313 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
314 Group:          Applications/Shells
315 Requires:       bash-completion
316
317 %description -n bash-completion-git
318 This package provides bash-completion for git.
319
320 %description -n bash-completion-git -l pl.UTF-8
321 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
322
323 %package -n perl-Git
324 Summary:        Perl interface to the Git version control system
325 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
326 Group:          Development/Languages/Perl
327 Obsoletes:      perl-git-core
328
329 %description -n perl-Git
330 This module provides Perl scripts easy way to interface the Git
331 version control system. The modules have an easy and well-tested way
332 to call arbitrary Git commands; in the future, the interface will also
333 provide specialized methods for doing easily operations which are not
334 totally trivial to do over the generic command interface.
335
336 %description -n perl-Git -l pl.UTF-8
337 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
338 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
339 dowolne polecenia Gita; w przyszłości interfejs udostępni także
340 specjalne metody do łatwego wykonywania operacji nietrywialnych do
341 wykonania przy użyciu ogólnego interfejsu poleceń.
342
343 %package -n python-Git
344 Summary:        Python interface to the Git version control system
345 Summary(pl.UTF-8):      Pythonowy interfejs do systemu kontroli wersji Git
346 Group:          Development/Languages/Python
347
348 %description -n python-Git
349 This module provides Python scripts easy way to interface the Git
350 version control system.
351
352 %description -n python-Git -l pl.UTF-8
353 Ten moduł umożliwia skryptom Pythonowym współpracę z systemem kontroli
354 wersji Git.
355
356 %package -n vim-syntax-gitcommit
357 Summary:        Vim syntax: gitcommit
358 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
359 Group:          Applications/Editors/Vim
360 # for _vimdatadir existence
361 Requires:       vim-rt >= 4:6.3.058-3
362
363 %description -n vim-syntax-gitcommit
364 This plugin provides syntax highlighting for git's commit messages.
365
366 %description -n vim-syntax-gitcommit -l pl.UTF-8
367 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
368
369 %prep
370 %setup -q -n git-%{version}
371 %patch0 -p1
372 %patch1 -p0
373
374 %build
375 %{__aclocal}
376 %{__autoconf}
377 %configure \
378         --with-openssl
379
380 echo "BLK_SHA1=1" >> config.mak
381
382 %{__make} \
383         INSTALLDIRS=vendor \
384         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
385         GITWEB_PROJECTROOT="/var/lib/git" \
386         GITWEB_CSS="/gitweb/gitweb.css" \
387         GITWEB_LOGO="/gitweb/git-logo.png" \
388         GITWEB_FAVICON="/gitweb/git-favicon.png" \
389         V=1
390
391 # use DOCBOOK_XSL_172=1 to fix 'the ".ft C" problem' in generated manpages.
392 %{?with_doc:%{__make} -C Documentation V=1 DOCBOOK_XSL_172=1}
393
394 %if %{with tests}
395 %if %{without tests_cvs}
396 rm t/t*cvs*.sh || :
397 %endif
398 %{__make} test
399 %endif
400
401 %install
402 rm -rf $RPM_BUILD_ROOT
403 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
404 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
405 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
406
407 %{__make} install \
408         INSTALLDIRS=vendor \
409         DESTDIR=$RPM_BUILD_ROOT
410
411 %if %{with doc}
412 %{__make} -C Documentation install \
413         DESTDIR=$RPM_BUILD_ROOT
414 %endif
415
416 # header files and lib
417 cp -a *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
418 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
419 cp -a xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
420 cp -a libgit.a $RPM_BUILD_ROOT%{_libdir}
421 cp -a xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
422
423 # bash completion
424 install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
425 cp -a contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
426
427 # vim syntax
428 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
429 cat > $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax/gitcommit.vim << 'EOF'
430 autocmd BufNewFile,BufRead *.git/COMMIT_EDITMSG    setf gitcommit
431 autocmd BufNewFile,BufRead *.git/config,.gitconfig setf gitconfig
432 autocmd BufNewFile,BufRead git-rebase-todo         setf gitrebase
433 autocmd BufNewFile,BufRead .msg.[0-9]*
434         \ if getline(1) =~ '^From.*# This line is ignored.$' |
435         \   setf gitsendemail |
436         \ endif
437 autocmd BufNewFile,BufRead *.git/**
438         \ if getline(1) =~ '^\x\{40\}\>\|^ref: ' |
439         \   setf git |
440         \ endif
441 EOF
442
443 # gitweb
444 mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
445 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
446 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
447 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
448 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
449
450 # gitview
451 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
452
453 # git-daemon related files
454 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
455 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
456 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
457
458 # paths cleanup
459 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
460 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
461
462 # hardlink
463 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
464 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
465 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
466 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
467
468 # remove unneeded files
469 rm $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
470 rm $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
471 %py_postclean
472
473 %clean
474 rm -rf $RPM_BUILD_ROOT
475
476 %post daemon-inetd
477 %service -q rc-inetd reload
478
479 %postun daemon-inetd
480 if [ "$1" = "0" ]; then
481         %service -q rc-inetd reload
482 fi
483
484 %post daemon-standalone
485 /sbin/chkconfig --add git-daemon
486 %service git-daemon restart "git-daemon"
487
488 %preun daemon-standalone
489 if [ "$1" = "0" ]; then
490         %service git-daemon stop
491         /sbin/chkconfig --del git-daemon
492 fi
493
494 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
495 %webapp_register apache %{webapp}
496
497 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
498 %webapp_unregister apache %{webapp}
499
500 %triggerin gitweb -- apache < 2.2.0, apache-base
501 %webapp_register httpd %{webapp}
502
503 %triggerun gitweb -- apache < 2.2.0, apache-base
504 %webapp_unregister httpd %{webapp}
505
506 %triggerin gitweb -- lighttpd
507 %webapp_register lighttpd %{webapp}
508
509 %triggerun gitweb -- lighttpd
510 %webapp_unregister lighttpd %{webapp}
511
512 %files
513 %defattr(644,root,root,755)
514 %doc README contrib
515 %attr(755,root,root) %{_bindir}/git
516 %attr(755,root,root) %{_bindir}/git-receive-pack
517 %attr(755,root,root) %{_bindir}/git-shell
518 %attr(755,root,root) %{_bindir}/git-upload-archive
519 %attr(755,root,root) %{_bindir}/git-upload-pack
520
521 %if %{with doc}
522 %{_mandir}/man1/git-*.1*
523 %exclude %{_mandir}/man1/git-svn.1*
524 %exclude %{_mandir}/man1/git-cvs*.1*
525 %{_mandir}/man1/git.1*
526 %{_mandir}/man5/gitattributes.5*
527 %{_mandir}/man5/githooks.5*
528 %{_mandir}/man5/gitignore.5*
529 %{_mandir}/man5/gitmodules.5*
530 %{_mandir}/man5/gitrepository-layout.5*
531 %{_mandir}/man7/gitcli.7*
532 %{_mandir}/man7/gitcore-tutorial.7*
533 %{_mandir}/man7/gitdiffcore.7*
534 %{_mandir}/man7/gitglossary.7*
535 %{_mandir}/man7/gitrevisions.7*
536 %{_mandir}/man7/gittutorial-2.7*
537 %{_mandir}/man7/gittutorial.7*
538 %{_mandir}/man7/gitworkflows.7*
539 %endif
540
541 %dir %{_libdir}/%{name}
542 %attr(755,root,root) %{_libdir}/%{name}/*-*
543 %attr(755,root,root) %{_libdir}/%{name}/git
544
545 %exclude %{_libdir}/%{name}/git-gui
546 %exclude %{_libdir}/%{name}/git-svn
547 %exclude %{_libdir}/%{name}/git-archimport
548 %exclude %{_libdir}/%{name}/git-cvs*
549 %exclude %{_libdir}/%{name}/*email*
550
551 %{_datadir}/%{name}
552
553 %{_localstatedir}/lib/git
554
555 %if %{with doc}
556 %files doc
557 %defattr(644,root,root,755)
558 %doc Documentation/RelNotes*
559 %doc Documentation/*.html Documentation/howto Documentation/technical
560 %endif
561
562 %files daemon-inetd
563 %defattr(644,root,root,755)
564 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
565
566 %files daemon-standalone
567 %defattr(644,root,root,755)
568 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
569 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
570
571 %files devel
572 %defattr(644,root,root,755)
573 %{_includedir}/git-core
574 %{_libdir}/libgit.a
575 %{_libdir}/libgit_xdiff.a
576
577 %files gitk
578 %defattr(644,root,root,755)
579 %if %{with doc}
580 %{_mandir}/man1/gitk.1*
581 %endif
582 %attr(755,root,root) %{_bindir}/gitk
583 %dir %{_datadir}/gitk
584 %dir %{_datadir}/gitk/lib
585 %dir %{_datadir}/gitk/lib/msgs
586 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
587 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
588 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
589 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
590 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
591 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
592 %lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
593 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
594 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
595
596 %files gitweb
597 %defattr(644,root,root,755)
598 %doc gitweb/{README,INSTALL}
599 %dir %{webappdir}
600 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
601 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
602 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
603 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
604 %attr(755,root,root) %{cgibindir}/gitweb.cgi
605 %{appdir}
606
607 %files gitview
608 %defattr(644,root,root,755)
609 %doc contrib/gitview/gitview.txt
610 %attr(755,root,root) %{_bindir}/gitview
611
612 %files gui
613 %defattr(644,root,root,755)
614 %attr(755,root,root) %{_libdir}/%{name}/git-gui
615 %dir %{_datadir}/git-gui
616 %dir %{_datadir}/git-gui/lib
617 %dir %{_datadir}/git-gui/lib/msgs
618 %{_datadir}/git-gui/lib/git-gui.ico
619 %{_datadir}/git-gui/lib/tclIndex
620 %{_datadir}/git-gui/lib/*.js
621 %{_datadir}/git-gui/lib/*.tcl
622 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
623 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
624 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
625 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
626 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
627 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
628 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
629 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
630 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
631 %lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
632
633 %files svn
634 %defattr(644,root,root,755)
635 %attr(755,root,root) %{_libdir}/%{name}/git-svn
636 %if %{with doc}
637 %{_mandir}/man1/git-svn.1*
638 %endif
639
640 %files cvs
641 %defattr(644,root,root,755)
642 %attr(755,root,root) %{_bindir}/git-cvsserver
643 %attr(755,root,root) %{_libdir}/%{name}/git-cvs*
644 %if %{with doc}
645 %{_mandir}/man1/git-cvs*.1*
646 %{_mandir}/man7/gitcvs-migration.7*
647 %endif
648
649 %files arch
650 %defattr(644,root,root,755)
651 %attr(755,root,root) %{_libdir}/%{name}/git-archimport
652 %if %{with doc}
653 %{_mandir}/man1/git-archimport.1*
654 %endif
655
656 %files email
657 %defattr(644,root,root,755)
658 %attr(755,root,root) %{_libdir}/%{name}/*email*
659 %if %{with doc}
660 %{_mandir}/man1/*email*.1*
661 %endif
662
663 %files -n bash-completion-git
664 %defattr(644,root,root,755)
665 %{_sysconfdir}/bash_completion.d/*
666
667 %files -n perl-Git
668 %defattr(644,root,root,755)
669 %{perl_vendorlib}/Git.pm
670 %{_mandir}/man3/Git.3pm*
671
672 %files -n python-Git
673 %defattr(644,root,root,755)
674 %dir %{py_sitescriptdir}/git_remote_helpers
675 %{py_sitescriptdir}/git_remote_helpers/*.py[co]
676 %dir %{py_sitescriptdir}/git_remote_helpers/git
677 %{py_sitescriptdir}/git_remote_helpers/git/*.py[co]
678 %if "%{py_ver}" > "2.4"
679 %{py_sitescriptdir}/git_remote_helpers*.egg-info
680 %endif
681
682 %files -n vim-syntax-gitcommit
683 %defattr(644,root,root,755)
684 %doc contrib/vim/README
685 %{_datadir}/vim/vimfiles/syntax/*.vim
This page took 0.072905 seconds and 3 git commands to generate.