]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
- allow for git-daemon to restart without waiting for old connections
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform make test
4 %bcond_with     tests_cvs       # perform tests which use CVS
5 %bcond_without  tests_svn       # perform tests which use subversion
6 %bcond_without  doc             # skip building/packaging docs/manuals (takes some time)
7
8 %include        /usr/lib/rpm/macros.perl
9 Summary:        Distributed version control system focused on speed, effectivity and usability
10 Summary(pl.UTF-8):      Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
11 Name:           git-core
12 Version:        1.8.1.1
13 Release:        2
14 License:        GPL v2
15 Group:          Development/Tools
16 Source0:        http://git-core.googlecode.com/files/git-%{version}.tar.gz
17 # Source0-md5:  2bf7fd005ecf2e0a311b849e6add7994
18 Source1:        %{name}-gitweb.conf
19 Source2:        %{name}-gitweb-httpd.conf
20 Source3:        %{name}-gitweb-lighttpd.conf
21 Source4:        %{name}.sysconfig
22 Source5:        %{name}.inet
23 Source6:        %{name}.init
24 Patch0:         %{name}-tests.patch
25 Patch1:         %{name}-key-bindings.patch
26 Patch2:         %{name}-sysconfdir.patch
27 URL:            http://git-scm.com/
28 BuildRequires:  autoconf >= 2.59
29 BuildRequires:  automake
30 BuildRequires:  curl-devel
31 BuildRequires:  expat-devel
32 BuildRequires:  gettext-devel
33 BuildRequires:  openssl-devel
34 BuildRequires:  perl-Error > 0.15
35 BuildRequires:  perl-base
36 BuildRequires:  python-devel
37 BuildRequires:  rpm-perlprov >= 4.1-13
38 BuildRequires:  rpm-pythonprov
39 BuildRequires:  rpmbuild(macros) >= 1.264
40 BuildRequires:  tcl
41 BuildRequires:  zlib-devel
42 %if %{with doc}
43 BuildRequires:  asciidoc >= 7.1.2-3
44 BuildRequires:  docbook-dtd45-xml
45 BuildRequires:  xmlto
46 %endif
47 %if %{with tests}
48 %if %{with tests_cvs}
49 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
50 BuildRequires:  cvs-gnu-client < 1.13
51 BuildRequires:  cvs-gnu-client >= 1.12
52 %endif
53 %{?with_tests_svn:BuildRequires:  subversion}
54 Conflicts:      pdksh < 5.2.14-46
55 %endif
56 Requires:       coreutils
57 Requires:       diffutils
58 Requires:       findutils
59 Requires:       grep
60 Requires:       openssh-clients
61 Requires:       perl-Error
62 Requires:       perl-Git = %{version}-%{release}
63 Requires:       sed
64 Suggests:       git-core-cvs
65 Suggests:       git-core-svn
66 Suggests:       less
67 Suggests:       rsync
68 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
70 # html docs have links to txt files
71 %define         _noautocompressdoc      *.txt
72
73 %define         webapp          gitweb
74 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
75 %define         appdir          %{_datadir}/%{webapp}
76 %define         cgibindir       %{_prefix}/lib/cgi-bin
77
78 %description
79 "git" can mean anything, depending on your mood.
80
81 - random three-letter combination that is pronounceable, and not
82   actually used by any common UNIX command. The fact that it is a
83   mispronunciation of "get" may or may not be relevant.
84 - stupid. contemptible and despicable. simple. Take your pick from the
85   dictionary of slang.
86 - "global information tracker": you're in a good mood, and it actually
87   works for you. Angels sing, and a light suddenly fills the room.
88 - "goddamn idiotic truckload of sh*t": when it breaks
89
90 This is a stupid (but extremely fast) directory content manager. It
91 doesn't do a whole lot, but what it 'does' do is track directory
92 contents efficiently.
93
94 %description -l pl.UTF-8
95 "git" może oznaczać cokolwiek, w zależności od nastroju.
96
97 - losową kombinację trzech liter, która jest wymawialna i właściwie
98   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
99   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
100 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
101 - "global information tracker" (narzędzie do globalnego śledzenia
102   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
103   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
104 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
105   g*) - kiedy się zepsuje.
106
107 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
108 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
109 katalogu.
110
111 %package doc
112 Summary:        Documentation for git-core
113 Summary(pl.UTF-8):      Dokumentacja do git-core
114 Group:          Documentation
115
116 %description doc
117 Documentation for git-core.
118
119 %description doc -l pl.UTF-8
120 Dokumentacja do git-core.
121
122 %description doc -l fr.UTF-8
123 Javadoc pour git-core.
124
125 %package daemon-inetd
126 Summary:        Files necessary to run git-daemon as an inetd service
127 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
128 Group:          Networking/Daemons
129 Requires:       %{name} = %{version}-%{release}
130 Requires:       setup >= 2.4.11-1
131 Provides:       git-core-daemon
132 Obsoletes:      git-core-daemon
133 Obsoletes:      git-core-daemon-standalone
134
135 %description daemon-inetd
136 Git-daemon is a really simple TCP git daemon that can serve git
137 repositories. This package provides all necessarry files to run
138 git-daemon as an inetd service.
139
140 %description daemon-inetd -l pl.UTF-8
141 Git-daemon to prosty demon git korzystający z protokołu TCP do
142 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
143 do uruchomienia git-demona w trybie usługi inetd.
144
145 %package daemon-standalone
146 Summary:        Files necessary to run git-daemon as a standalone service
147 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
148 Group:          Networking/Daemons
149 Requires:       %{name} = %{version}-%{release}
150 Provides:       git-core-daemon
151 Obsoletes:      git-core-daemon
152 Obsoletes:      git-core-daemon-inetd
153
154 %description daemon-standalone
155 Git-daemon is a really simple TCP git daemon that can serve git
156 repositories. This package provides all necessarry files to run
157 git-daemon as an standalone service.
158
159 %description daemon-standalone -l pl.UTF-8
160 Git-daemon to prosty demon git korzystający z protokołu TCP do
161 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
162 do uruchomienia git-daemona w trybie usługi samodzielnej.
163
164 %package devel
165 Summary:        Git library with header files
166 Summary(pl.UTF-8):      Biblioteka Gita oraz pliki nagłówkowe
167 Group:          Development/Libraries
168 Requires:       zlib-devel
169
170 %description devel
171 Git library with header files.
172
173 %description devel -l pl.UTF-8
174 Biblioteka Gita oraz pliki nagłówkowe.
175
176 %package gitk
177 Summary:        Tcl/Tk interface to the Git version control system
178 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
179 Group:          Development/Tools
180 Requires:       %{name} = %{version}-%{release}
181 Requires:       tk
182
183 %description gitk
184 gitk displays changes in a repository or a selected set of commits.
185 This includes visualizing the commit graph, showing information
186 related to each commit, and the files in the trees of each revision.
187
188 Historically, gitk was the first repository browser. It's written in
189 Tcl/Tk and started off in a separate repository but was later merged
190 into the main git repository.
191
192 %description gitk -l pl.UTF-8
193 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
194 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
195 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
196
197 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
198 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
199 osobnym repozytorium, ale z czasem został włączony do głównego
200 repozytorium gita.
201
202 %package gitweb
203 Summary:        Web frontend to git
204 Summary(pl.UTF-8):      Frontend WWW do gita
205 Group:          Development/Tools
206 Requires:       %{name} = %{version}-%{release}
207 Requires:       webapps
208 Requires:       webserver(alias)
209 Requires:       webserver(cgi)
210 Suggests:       webserver(setenv)
211
212 %description gitweb
213 This package provides a web interface for browsing git repositories.
214
215 %description gitweb -l pl.UTF-8
216 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
217
218 %package gitview
219 Summary:        A GTK+ based repository browser for git
220 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
221 Group:          Development/Tools
222 Requires:       %{name} = %{version}-%{release}
223 Requires:       python >= 1:2.4
224 Requires:       python-pycairo >= 1.0
225 Requires:       python-pygobject
226 Requires:       python-pygtk-gtk >= 2:2.8
227 Suggests:       python-gnome-desktop-gtksourceview
228
229 %description gitview
230 A GTK+ based repository browser for git.
231
232 %description gitview -l pl.UTF-8
233 Oparta na GTK+ przeglądarka repozytorium gita.
234
235 %package gui
236 Summary:        Tcl/Tk interface to the Git version control system
237 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
238 Group:          Development/Tools
239 Requires:       %{name} = %{version}-%{release}
240 Requires:       tk
241 Requires:       xdg-utils
242 Suggests:       meld
243
244 %description gui
245 Displays changes in a repository or a selected set of commits. This
246 includes visualizing the commit graph, showing information related to
247 each commit, and the files in the trees of each revision.
248
249 Historically, gitk was the first repository browser. It's written in
250 Tcl/Tk and started off in a separate repository but was later merged
251 into the main git repository.
252
253 %description gui -l pl.UTF-8
254 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
255 to wizualizację grafu commitów, wyświetlanie informacji związanych z
256 każdym z commitów oraz listę plików dla każdej rewizji.
257
258 Z punktu widzenia historii, gitk był pierwszą przeglądarką
259 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
260 osobnym repozytorium, ale z czasem został włączony do głównego
261 repozytorium gita.
262
263 %package svn
264 Summary:        Subversion support for Git
265 Summary(pl.UTF-8):      Obsługa Subversion dla Gita
266 Group:          Development/Tools
267 Requires:       %{name} = %{version}-%{release}
268 Requires:       perl-Encode
269 Requires:       perl-Term-ReadKey
270
271 %description svn
272 Subversion support for Git.
273
274 %description svn -l pl.UTF-8
275 Obsługa Subversion dla Gita.
276
277 %package cvs
278 Summary:        CVS support for Git
279 Summary(pl.UTF-8):      Obsługa CVS dla Gita
280 Group:          Development/Tools
281 Requires:       %{name} = %{version}-%{release}
282 Requires:       cvsps >= 2.1-2
283 Requires:       rcs
284
285 %description cvs
286 CVS support for Git.
287
288 %description cvs -l pl.UTF-8
289 Obsługa CVS dla Gita.
290
291 %package arch
292 Summary:        Git tools for importing Arch repositories
293 Summary(pl.UTF-8):      Narzędzia Gita do importowania repozytoriów Archa
294 Group:          Development/Tools
295 Requires:       %{name} = %{version}-%{release}
296 Requires:       tla
297
298 %description arch
299 Git tools for importing Arch repositories.
300
301 %description arch -l pl.UTF-8
302 Narzędzia Gita do importowania repozytoriów Archa.
303
304 %package email
305 Summary:        Git tools for sending email
306 Summary(pl.UTF-8):      Narzędzia Gita do wysyłania poczty
307 Group:          Development/Tools
308 Requires:       %{name} = %{version}-%{release}
309
310 %description email
311 Git tools for sending email.
312
313 %description email -l pl.UTF-8
314 Narzędzia Gita do wysyłania poczty.
315
316 %package -n bash-completion-git
317 Summary:        bash-completion for git
318 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
319 Group:          Applications/Shells
320 Requires:       %{name} = %{version}-%{release}
321 Requires:       bash-completion
322
323 %description -n bash-completion-git
324 This package provides bash-completion for git.
325
326 %description -n bash-completion-git -l pl.UTF-8
327 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
328
329 %package -n perl-Git
330 Summary:        Perl interface to the Git version control system
331 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
332 Group:          Development/Languages/Perl
333 Obsoletes:      perl-git-core
334
335 %description -n perl-Git
336 This module provides Perl scripts easy way to interface the Git
337 version control system. The modules have an easy and well-tested way
338 to call arbitrary Git commands; in the future, the interface will also
339 provide specialized methods for doing easily operations which are not
340 totally trivial to do over the generic command interface.
341
342 %description -n perl-Git -l pl.UTF-8
343 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
344 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
345 dowolne polecenia Gita; w przyszłości interfejs udostępni także
346 specjalne metody do łatwego wykonywania operacji nietrywialnych do
347 wykonania przy użyciu ogólnego interfejsu poleceń.
348
349 %package -n python-Git
350 Summary:        Python Git remote helpers for non-git repositories
351 Summary(pl.UTF-8):      Pythonowe zdalne moduły pomocnicze dla repozytoriów niegitowych
352 Group:          Development/Languages/Python
353 Requires:       %{name} = %{version}-%{release}
354
355 %description -n python-Git
356 This package contains Python git_repote_helpers package - Git remote
357 helpers for non-git repositories.
358
359 %description -n python-Git -l pl.UTF-8
360 Ten pakiet zawiera pakiet Pythona git_remote_helpers - zdalne moduły
361 pomocnicze Gita dla repozytoriów niegitowych.
362
363 %package -n vim-syntax-gitcommit
364 Summary:        Vim syntax: gitcommit
365 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
366 Group:          Applications/Editors/Vim
367 Requires:       %{name} = %{version}-%{release}
368 # for _vimdatadir existence
369 Requires:       vim-rt >= 4:6.3.058-3
370
371 %description -n vim-syntax-gitcommit
372 This plugin provides syntax highlighting for git's commit messages.
373
374 %description -n vim-syntax-gitcommit -l pl.UTF-8
375 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
376
377 %prep
378 %setup -q -n git-%{version}
379 %patch0 -p1
380 %patch1 -p0
381 %patch2 -p1
382
383 %build
384 %{__aclocal}
385 %{__autoconf}
386 %configure \
387         --sysconfdir=%{_sysconfdir}/git-core \
388         --with-openssl
389
390 echo "BLK_SHA1=1" >> config.mak
391
392 %{__make} \
393         INSTALLDIRS=vendor \
394         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
395         GITWEB_PROJECTROOT="/var/lib/git" \
396         GITWEB_CSS="/gitweb/gitweb.css" \
397         GITWEB_LOGO="/gitweb/git-logo.png" \
398         GITWEB_FAVICON="/gitweb/git-favicon.png" \
399         V=1
400
401 %if %{with doc}
402 %{__make} -C Documentation \
403         MAN_BASE_URL=file://%{_docdir}/%{name}-doc-%{version}/ \
404         V=1
405 %endif
406
407 %if %{with tests}
408 %if %{without tests_cvs}
409 %{__rm} t/t*cvs*.sh || :
410 %endif
411 %{!?with_tests_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
412 %endif
413
414 %install
415 rm -rf $RPM_BUILD_ROOT
416 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
417 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
418 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
419 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
420 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
421 [init]
422         templatedir = %{_sysconfdir}/%{name}/templates
423 EOF
424
425 %{__make} install \
426         INSTALLDIRS=vendor \
427         DESTDIR=$RPM_BUILD_ROOT
428
429 %if %{with doc}
430 %{__make} -C Documentation install \
431         DESTDIR=$RPM_BUILD_ROOT
432 %endif
433
434 # copy templates except sample hooks
435 cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
436 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
437
438 # header files and lib
439 cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
440 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
441 cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
442 cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
443 cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
444
445 # bash completion
446 install -d $RPM_BUILD_ROOT/etc/bash_completion.d
447 cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT/etc/bash_completion.d
448
449 # vim syntax
450 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
451 cat > $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax/gitcommit.vim << 'EOF'
452 autocmd BufNewFile,BufRead *.git/COMMIT_EDITMSG    setf gitcommit
453 autocmd BufNewFile,BufRead *.git/config,.gitconfig setf gitconfig
454 autocmd BufNewFile,BufRead git-rebase-todo         setf gitrebase
455 autocmd BufNewFile,BufRead .msg.[0-9]*
456         \ if getline(1) =~ '^From.*# This line is ignored.$' |
457         \   setf gitsendemail |
458         \ endif
459 autocmd BufNewFile,BufRead *.git/**
460         \ if getline(1) =~ '^\x\{40\}\>\|^ref: ' |
461         \   setf git |
462         \ endif
463 EOF
464
465 # gitweb
466 mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
467 ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
468 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
469 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
470 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
471 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
472
473 # gitview
474 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
475
476 # git-daemon related files
477 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
478 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
479 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
480
481 # paths cleanup
482 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
483 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
484
485 # hardlink
486 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
487 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
488 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
489 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
490
491 # remove unneeded files
492 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
493 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
494 %py_postclean
495
496 mv $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
497 %find_lang git
498
499 %clean
500 rm -rf $RPM_BUILD_ROOT
501
502 %post daemon-inetd
503 %service -q rc-inetd reload
504
505 %postun daemon-inetd
506 if [ "$1" = "0" ]; then
507         %service -q rc-inetd reload
508 fi
509
510 %post daemon-standalone
511 /sbin/chkconfig --add git-daemon
512 %service git-daemon restart "git-daemon"
513
514 %preun daemon-standalone
515 if [ "$1" = "0" ]; then
516         %service git-daemon stop
517         /sbin/chkconfig --del git-daemon
518 fi
519
520 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
521 %webapp_register apache %{webapp}
522
523 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
524 %webapp_unregister apache %{webapp}
525
526 %triggerin gitweb -- apache < 2.2.0, apache-base
527 %webapp_register httpd %{webapp}
528
529 %triggerun gitweb -- apache < 2.2.0, apache-base
530 %webapp_unregister httpd %{webapp}
531
532 %triggerin gitweb -- lighttpd
533 %webapp_register lighttpd %{webapp}
534
535 %triggerun gitweb -- lighttpd
536 %webapp_unregister lighttpd %{webapp}
537
538 %files -f git.lang
539 %defattr(644,root,root,755)
540 %doc README contrib
541 %attr(755,root,root) %{_bindir}/git
542 %attr(755,root,root) %{_bindir}/git-receive-pack
543 %attr(755,root,root) %{_bindir}/git-shell
544 %attr(755,root,root) %{_bindir}/git-upload-archive
545 %attr(755,root,root) %{_bindir}/git-upload-pack
546 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
547
548 %if %{with doc}
549 %{_mandir}/man1/git-*.1*
550 %exclude %{_mandir}/man1/git-archimport.1*
551 %exclude %{_mandir}/man1/git-svn.1*
552 %exclude %{_mandir}/man1/git-cvs*.1*
553 %exclude %{_mandir}/man1/*email*.1*
554 %exclude %{_mandir}/man1/git-remote-helpers.1*
555 %{_mandir}/man1/git.1*
556 %{_mandir}/man5/gitattributes.5*
557 %{_mandir}/man5/githooks.5*
558 %{_mandir}/man5/gitignore.5*
559 %{_mandir}/man5/gitmodules.5*
560 %{_mandir}/man5/gitrepository-layout.5*
561 %{_mandir}/man7/gitcli.7*
562 %{_mandir}/man7/gitcore-tutorial.7*
563 %{_mandir}/man7/gitcredentials.7*
564 %{_mandir}/man7/gitdiffcore.7*
565 %{_mandir}/man7/gitglossary.7*
566 %{_mandir}/man7/gitnamespaces.7*
567 %{_mandir}/man7/gitrevisions.7*
568 %{_mandir}/man7/gittutorial-2.7*
569 %{_mandir}/man7/gittutorial.7*
570 %{_mandir}/man7/gitworkflows.7*
571 %endif
572
573 %dir %{_libdir}/%{name}
574 %attr(755,root,root) %{_libdir}/%{name}/*-*
575 %attr(755,root,root) %{_libdir}/%{name}/git
576 %{_libdir}/%{name}/mergetools
577
578 %exclude %{_libdir}/%{name}/git-gui
579 %exclude %{_libdir}/%{name}/git-svn
580 %exclude %{_libdir}/%{name}/git-archimport
581 %exclude %{_libdir}/%{name}/git-cvs*
582 %exclude %{_libdir}/%{name}/git-instaweb
583 %exclude %{_libdir}/%{name}/git-remote-testgit
584 %exclude %{_libdir}/%{name}/*email*
585
586 %{_datadir}/%{name}
587
588 %{_localstatedir}/lib/git
589
590 %if %{with doc}
591 %files doc
592 %defattr(644,root,root,755)
593 %doc Documentation/RelNotes*
594 %doc Documentation/*.html Documentation/howto Documentation/technical
595 %endif
596
597 %files daemon-inetd
598 %defattr(644,root,root,755)
599 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
600
601 %files daemon-standalone
602 %defattr(644,root,root,755)
603 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
604 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
605
606 %files devel
607 %defattr(644,root,root,755)
608 %{_includedir}/%{name}
609 %{_libdir}/libgit.a
610 %{_libdir}/libgit_xdiff.a
611
612 %files gitk
613 %defattr(644,root,root,755)
614 %if %{with doc}
615 %{_mandir}/man1/gitk.1*
616 %endif
617 %attr(755,root,root) %{_bindir}/gitk
618 %dir %{_datadir}/gitk
619 %dir %{_datadir}/gitk/lib
620 %dir %{_datadir}/gitk/lib/msgs
621 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
622 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
623 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
624 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
625 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
626 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
627 %lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
628 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
629 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
630
631 %files gitweb
632 %defattr(644,root,root,755)
633 %doc gitweb/{README,INSTALL}
634 %dir %{webappdir}
635 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
636 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
637 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
638 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
639 %attr(755,root,root) %{cgibindir}/gitweb.cgi
640 %{appdir}
641 %attr(755,root,root) %{_libdir}/%{name}/git-instaweb
642 %if %{with doc}
643 %{_mandir}/man1/gitweb.1*
644 %{_mandir}/man5/gitweb.conf.5*
645 %endif
646
647 %files gitview
648 %defattr(644,root,root,755)
649 %doc contrib/gitview/gitview.txt
650 %attr(755,root,root) %{_bindir}/gitview
651
652 %files gui
653 %defattr(644,root,root,755)
654 %attr(755,root,root) %{_libdir}/%{name}/git-gui
655 %dir %{_datadir}/git-gui
656 %dir %{_datadir}/git-gui/lib
657 %dir %{_datadir}/git-gui/lib/msgs
658 %{_datadir}/git-gui/lib/git-gui.ico
659 %{_datadir}/git-gui/lib/tclIndex
660 %{_datadir}/git-gui/lib/*.js
661 %{_datadir}/git-gui/lib/*.tcl
662 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
663 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
664 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
665 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
666 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
667 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
668 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
669 %lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
670 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
671 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
672 %lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
673
674 %files svn
675 %defattr(644,root,root,755)
676 %attr(755,root,root) %{_libdir}/%{name}/git-svn
677 %{perl_vendorlib}/Git/SVN
678 %{perl_vendorlib}/Git/SVN.pm
679 %if %{with doc}
680 %{_mandir}/man1/git-svn.1*
681 %endif
682
683 %files cvs
684 %defattr(644,root,root,755)
685 %attr(755,root,root) %{_bindir}/git-cvsserver
686 %attr(755,root,root) %{_libdir}/%{name}/git-cvs*
687 %if %{with doc}
688 %{_mandir}/man1/git-cvs*.1*
689 %{_mandir}/man7/gitcvs-migration.7*
690 %endif
691
692 %files arch
693 %defattr(644,root,root,755)
694 %attr(755,root,root) %{_libdir}/%{name}/git-archimport
695 %if %{with doc}
696 %{_mandir}/man1/git-archimport.1*
697 %endif
698
699 %files email
700 %defattr(644,root,root,755)
701 %attr(755,root,root) %{_libdir}/%{name}/*email*
702 %if %{with doc}
703 %{_mandir}/man1/*email*.1*
704 %endif
705
706 %files -n bash-completion-git
707 %defattr(644,root,root,755)
708 /etc/bash_completion.d/git-completion.bash
709
710 %files -n perl-Git
711 %defattr(644,root,root,755)
712 %{perl_vendorlib}/Git.pm
713 %dir %{perl_vendorlib}/Git
714 %{perl_vendorlib}/Git/I18N.pm
715 %{perl_vendorlib}/Git/IndexInfo.pm
716 %{_mandir}/man3/Git*.3pm*
717
718 %files -n python-Git
719 %defattr(644,root,root,755)
720 %attr(755,root,root) %{_libdir}/%{name}/git-remote-testgit
721 %dir %{py_sitescriptdir}/git_remote_helpers
722 %{py_sitescriptdir}/git_remote_helpers/*.py[co]
723 %dir %{py_sitescriptdir}/git_remote_helpers/git
724 %{py_sitescriptdir}/git_remote_helpers/git/*.py[co]
725 %if "%{py_ver}" > "2.4"
726 %{py_sitescriptdir}/git_remote_helpers*.egg-info
727 %endif
728 %if %{with doc}
729 %{_mandir}/man1/git-remote-helpers.1*
730 %endif
731
732 %files -n vim-syntax-gitcommit
733 %defattr(644,root,root,755)
734 %doc contrib/vim/README
735 %{_datadir}/vim/vimfiles/syntax/gitcommit.vim
This page took 0.089681 seconds and 3 git commands to generate.