]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
105e0b27ec5fa4bb4ad0b31c332d5a1ecc6d2a9f
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform make test
4 %bcond_with     tests_cvs       # perform tests which use CVS
5 %bcond_without  tests_svn       # perform tests which use subversion
6 %bcond_without  doc             # skip building/packaging docs/manuals (takes some time)
7 %bcond_without  pcre            # perl-compatible regexes support
8 %bcond_without  gnome_keyring   # build without gnome keyring support
9
10 # for AC: --without doc --without gnome_keyring --without tests
11
12 %include        /usr/lib/rpm/macros.perl
13 Summary:        Distributed version control system focused on speed, effectivity and usability
14 Summary(pl.UTF-8):      Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
15 Name:           git-core
16 Version:        2.7.1
17 Release:        2
18 License:        GPL v2
19 Group:          Development/Tools
20 Source0:        http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.gz
21 # Source0-md5:  846ac45a1638e9a6ff3a9b790f6c8d99
22 Source1:        %{name}-gitweb.conf
23 Source2:        %{name}-gitweb-httpd.conf
24 Source3:        %{name}-gitweb-lighttpd.conf
25 Source4:        %{name}.sysconfig
26 Source5:        %{name}.inet
27 Source6:        %{name}.init
28 Source7:        gitolite.pl
29 Patch0:         %{name}-tests.patch
30 Patch1:         %{name}-key-bindings.patch
31 Patch2:         %{name}-sysconfdir.patch
32 Patch3:         cherry-picked-commitlog.patch
33 Patch4:         %{name}-svn-exit-errors.patch
34 Patch5:         %{name}-test-grep.patch
35 URL:            http://git-scm.com/
36 BuildRequires:  autoconf >= 2.59
37 BuildRequires:  automake
38 BuildRequires:  curl-devel
39 BuildRequires:  expat-devel
40 BuildRequires:  gettext-tools
41 %if %{with gnome_keyring}
42 BuildRequires:  libgnome-keyring-devel
43 BuildRequires:  pkgconfig
44 %endif
45 BuildRequires:  openssl-devel
46 %{?with_pcre:BuildRequires:     pcre-devel}
47 BuildRequires:  perl-Error > 0.15
48 BuildRequires:  perl-base
49 BuildRequires:  python-devel
50 BuildRequires:  rpm-perlprov >= 4.1-13
51 BuildRequires:  rpm-pythonprov
52 BuildRequires:  rpmbuild(macros) >= 1.673
53 BuildRequires:  tcl
54 BuildRequires:  zlib-devel
55 %if %{with doc}
56 BuildRequires:  asciidoc >= 7.1.2-3
57 BuildRequires:  docbook-dtd45-xml
58 BuildRequires:  xmlto
59 %endif
60 %if %{with tests}
61 %if %{with tests_cvs}
62 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
63 BuildRequires:  cvs-gnu-client < 1.13
64 BuildRequires:  cvs-gnu-client >= 1.12
65 %endif
66 %if %{with tests_svn}
67 BuildRequires:  perl-subversion
68 BuildRequires:  subversion
69 %endif
70 Conflicts:      pdksh < 5.2.14-46
71 %endif
72 # git-sh-setup: sane_grep
73 Requires:       grep
74 # git-pull: printf
75 Requires:       coreutils
76 Requires:       openssh-clients
77 Requires:       perl-Error
78 Requires:       perl-Git = %{version}-%{release}
79 Requires:       sed
80 Suggests:       git-core-bzr
81 Suggests:       git-core-cvs
82 Suggests:       git-core-hg
83 Suggests:       git-core-p4
84 Suggests:       git-core-svn
85 Suggests:       less
86 Suggests:       rsync
87 Obsoletes:      python-Git
88 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
89
90 # html docs have links to txt files
91 %define         _noautocompressdoc      *.txt
92
93 %define         webapp          gitweb
94 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
95 %define         appdir          %{_datadir}/%{webapp}
96 %define         cgibindir       %{_prefix}/lib/cgi-bin
97 %define         gitcoredir      %{_libdir}/%{name}
98
99 %description
100 "git" can mean anything, depending on your mood.
101
102 - random three-letter combination that is pronounceable, and not
103   actually used by any common UNIX command. The fact that it is a
104   mispronunciation of "get" may or may not be relevant.
105 - stupid. contemptible and despicable. simple. Take your pick from the
106   dictionary of slang.
107 - "global information tracker": you're in a good mood, and it actually
108   works for you. Angels sing, and a light suddenly fills the room.
109 - "goddamn idiotic truckload of sh*t": when it breaks
110
111 This is a stupid (but extremely fast) directory content manager. It
112 doesn't do a whole lot, but what it 'does' do is track directory
113 contents efficiently.
114
115 %description -l pl.UTF-8
116 "git" może oznaczać cokolwiek, w zależności od nastroju.
117
118 - losową kombinację trzech liter, która jest wymawialna i właściwie
119   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
120   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
121 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
122 - "global information tracker" (narzędzie do globalnego śledzenia
123   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
124   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
125 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
126   g*) - kiedy się zepsuje.
127
128 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
129 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
130 katalogu.
131
132 %package doc
133 Summary:        Documentation for git-core
134 Summary(pl.UTF-8):      Dokumentacja do git-core
135 Group:          Documentation
136
137 %description doc
138 Documentation for git-core.
139
140 %description doc -l pl.UTF-8
141 Dokumentacja do git-core.
142
143 %description doc -l fr.UTF-8
144 Javadoc pour git-core.
145
146 %package daemon-inetd
147 Summary:        Files necessary to run git-daemon as an inetd service
148 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
149 Group:          Networking/Daemons
150 Requires:       %{name} = %{version}-%{release}
151 Requires:       setup >= 2.4.11-1
152 Provides:       git-core-daemon
153 Obsoletes:      git-core-daemon
154 Obsoletes:      git-core-daemon-standalone
155
156 %description daemon-inetd
157 Git-daemon is a really simple TCP git daemon that can serve git
158 repositories. This package provides all necessarry files to run
159 git-daemon as an inetd service.
160
161 %description daemon-inetd -l pl.UTF-8
162 Git-daemon to prosty demon git korzystający z protokołu TCP do
163 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
164 do uruchomienia git-demona w trybie usługi inetd.
165
166 %package daemon-standalone
167 Summary:        Files necessary to run git-daemon as a standalone service
168 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
169 Group:          Networking/Daemons
170 Requires:       %{name} = %{version}-%{release}
171 Provides:       git-core-daemon
172 Obsoletes:      git-core-daemon
173 Obsoletes:      git-core-daemon-inetd
174
175 %description daemon-standalone
176 Git-daemon is a really simple TCP git daemon that can serve git
177 repositories. This package provides all necessarry files to run
178 git-daemon as an standalone service.
179
180 %description daemon-standalone -l pl.UTF-8
181 Git-daemon to prosty demon git korzystający z protokołu TCP do
182 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
183 do uruchomienia git-daemona w trybie usługi samodzielnej.
184
185 %package devel
186 Summary:        Git library with header files
187 Summary(pl.UTF-8):      Biblioteka Gita oraz pliki nagłówkowe
188 Group:          Development/Libraries
189 Requires:       zlib-devel
190
191 %description devel
192 Git library with header files.
193
194 %description devel -l pl.UTF-8
195 Biblioteka Gita oraz pliki nagłówkowe.
196
197 %package gitk
198 Summary:        Tcl/Tk interface to the Git version control system
199 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
200 Group:          Development/Tools
201 Requires:       %{name} = %{version}-%{release}
202 Requires:       tk
203
204 %description gitk
205 gitk displays changes in a repository or a selected set of commits.
206 This includes visualizing the commit graph, showing information
207 related to each commit, and the files in the trees of each revision.
208
209 Historically, gitk was the first repository browser. It's written in
210 Tcl/Tk and started off in a separate repository but was later merged
211 into the main git repository.
212
213 %description gitk -l pl.UTF-8
214 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
215 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
216 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
217
218 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
219 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
220 osobnym repozytorium, ale z czasem został włączony do głównego
221 repozytorium gita.
222
223 %package gitweb
224 Summary:        Web frontend to git
225 Summary(pl.UTF-8):      Frontend WWW do gita
226 Group:          Development/Tools
227 Requires:       %{name} = %{version}-%{release}
228 Requires:       webapps
229 Requires:       webserver(access)
230 Requires:       webserver(alias)
231 Requires:       webserver(cgi)
232 Suggests:       webserver(setenv)
233
234 %description gitweb
235 This package provides a web interface for browsing git repositories.
236
237 %description gitweb -l pl.UTF-8
238 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
239
240 %package gitview
241 Summary:        A GTK+ based repository browser for git
242 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
243 Group:          Development/Tools
244 Requires:       %{name} = %{version}-%{release}
245 Requires:       python >= 1:2.4
246 Requires:       python-pycairo >= 1.0
247 Requires:       python-pygobject
248 Requires:       python-pygtk-gtk >= 2:2.8
249 Suggests:       python-gnome-desktop-gtksourceview
250
251 %description gitview
252 A GTK+ based repository browser for git.
253
254 %description gitview -l pl.UTF-8
255 Oparta na GTK+ przeglądarka repozytorium gita.
256
257 %package gui
258 Summary:        Tcl/Tk interface to the Git version control system
259 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
260 Group:          Development/Tools
261 Requires:       %{name} = %{version}-%{release}
262 Requires:       tk
263 Requires:       xdg-utils
264 Suggests:       meld
265
266 %description gui
267 Displays changes in a repository or a selected set of commits. This
268 includes visualizing the commit graph, showing information related to
269 each commit, and the files in the trees of each revision.
270
271 Historically, gitk was the first repository browser. It's written in
272 Tcl/Tk and started off in a separate repository but was later merged
273 into the main git repository.
274
275 %description gui -l pl.UTF-8
276 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
277 to wizualizację grafu commitów, wyświetlanie informacji związanych z
278 każdym z commitów oraz listę plików dla każdej rewizji.
279
280 Z punktu widzenia historii, gitk był pierwszą przeglądarką
281 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
282 osobnym repozytorium, ale z czasem został włączony do głównego
283 repozytorium gita.
284
285 %package arch
286 Summary:        Git tools for importing Arch repositories
287 Summary(pl.UTF-8):      Narzędzia Gita do importowania repozytoriów Archa
288 Group:          Development/Tools
289 Requires:       %{name} = %{version}-%{release}
290 Requires:       tla
291
292 %description arch
293 Git tools for importing Arch repositories.
294
295 %description arch -l pl.UTF-8
296 Narzędzia Gita do importowania repozytoriów Archa.
297
298 %package bzr
299 Summary:        Git tools for working with bzr repositories
300 Summary(pl.UTF-8):      Narzędzia Gita do pracy z repozytoriami bzr
301 Group:          Development/Tools
302 Requires:       %{name} = %{version}-%{release}
303 Requires:       bzr
304
305 %description bzr
306 Git tools for working with bzr repositories.
307
308 %description bzr -l pl.UTF-8
309 Narzędzia Gita do pracy z repozytoriami bzr.
310
311 %package cvs
312 Summary:        CVS support for Git
313 Summary(pl.UTF-8):      Obsługa CVS dla Gita
314 Group:          Development/Tools
315 Requires:       %{name} = %{version}-%{release}
316 Requires:       cvsps >= 2.1-2
317 Requires:       rcs
318
319 %description cvs
320 CVS support for Git.
321
322 %description cvs -l pl.UTF-8
323 Obsługa CVS dla Gita.
324
325 %package hg
326 Summary:        Git tools for working with mercurial repositories
327 Summary(pl.UTF-8):      Narzędzia Gita do pracy z repozytoriami mercuriala
328 Group:          Development/Tools
329 Requires:       %{name} = %{version}-%{release}
330 Requires:       mercurial >= 1.8
331
332 %description hg
333 Git tools for working with mercurial repositories.
334
335 %description hg -l pl.UTF-8
336 Narzędzia Gita do pracy z repozytoriami mercuriala.
337
338 %package p4
339 Summary:        Git tools for working with Perforce depots
340 Summary(pl.UTF-8):      Narzędzia Gita do pracy z magazynami Perforce'a
341 Group:          Development/Tools
342 Requires:       %{name} = %{version}-%{release}
343
344 %description p4
345 Git tools for working with Perforce depots.
346
347 %description p4 -l pl.UTF-8
348 Narzędzia Gita do pracy z magazynami Perforce'a.
349
350 %package svn
351 Summary:        Subversion support for Git
352 Summary(pl.UTF-8):      Obsługa Subversion dla Gita
353 Group:          Development/Tools
354 Requires:       %{name} = %{version}-%{release}
355 Requires:       perl-Encode
356 Requires:       perl-Term-ReadKey
357
358 %description svn
359 Subversion support for Git.
360
361 %description svn -l pl.UTF-8
362 Obsługa Subversion dla Gita.
363
364 %package email
365 Summary:        Git tools for sending email
366 Summary(pl.UTF-8):      Narzędzia Gita do wysyłania poczty
367 Group:          Development/Tools
368 Requires:       %{name} = %{version}-%{release}
369
370 %description email
371 Git tools for sending email.
372
373 %description email -l pl.UTF-8
374 Narzędzia Gita do wysyłania poczty.
375
376 %package -n bash-completion-git
377 Summary:        bash-completion for git
378 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
379 Group:          Applications/Shells
380 Requires:       %{name} = %{version}-%{release}
381 Requires:       bash-completion >= 2.0
382 %if "%{_rpmversion}" >= "5"
383 BuildArch:      noarch
384 %endif
385
386 %description -n bash-completion-git
387 This package provides bash-completion for git.
388
389 %description -n bash-completion-git -l pl.UTF-8
390 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
391
392 %package -n perl-Git
393 Summary:        Perl interface to the Git version control system
394 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
395 Group:          Development/Languages/Perl
396 Obsoletes:      perl-git-core
397
398 %description -n perl-Git
399 This module provides Perl scripts easy way to interface the Git
400 version control system. The modules have an easy and well-tested way
401 to call arbitrary Git commands; in the future, the interface will also
402 provide specialized methods for doing easily operations which are not
403 totally trivial to do over the generic command interface.
404
405 %description -n perl-Git -l pl.UTF-8
406 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
407 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
408 dowolne polecenia Gita; w przyszłości interfejs udostępni także
409 specjalne metody do łatwego wykonywania operacji nietrywialnych do
410 wykonania przy użyciu ogólnego interfejsu poleceń.
411
412 %package -n gnome-keyring-git-core
413 Summary:        GNOME Keyring authentication provider for Git
414 Summary(pl.UTF-8):      Moduł uwierzytelniający GNOME Keyring dla Git
415 Group:          X11/Applications
416 URL:            http://git-scm.com/docs/gitcredentials.html
417 Requires:       %{name} = %{version}-%{release}
418
419 %description -n gnome-keyring-git-core
420 Authentication provider module for Git which allows git client to
421 authenticate using GNOME Keyring.
422
423 You need to register it with:
424 - git config --global credential.helper gnome-keyring
425
426 %description -n gnome-keyring-git-core -l pl.UTF-8
427 Moduł uwierzytelniający dla Subversion pozwalający klientom git
428 uwierzytelniać się przy użyciu mechanizmu GNOME Keyring.
429
430 Moduł trzeba zarejestrować poleceniem:
431 - git config --global credential.helper gnome-keyring
432
433 %prep
434 %setup -q -n git-%{version}
435 %patch0 -p1
436 %patch1 -p0
437 %patch2 -p1
438 %patch3 -p1
439 %patch4 -p1
440 %patch5 -p0
441
442 %{__rm} {Documentation/technical,contrib/emacs,contrib/credential/gnome-keyring}/.gitignore
443
444 # we build things in contrib but want to have it clean for doc purporses, too
445 cp -a contrib contrib-doc
446
447 %build
448 %{__aclocal}
449 %{__autoconf}
450 %configure \
451         --sysconfdir=%{_sysconfdir}/git-core \
452         %{?with_pcre:--with-libpcre} \
453         --with-openssl
454
455 echo "BLK_SHA1=1" >> config.mak
456
457 %{__make} \
458         INSTALLDIRS=vendor \
459         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
460         GITWEB_PROJECTROOT="/var/lib/git" \
461         GITWEB_CSS="/gitweb/gitweb.css" \
462         GITWEB_LOGO="/gitweb/git-logo.png" \
463         GITWEB_FAVICON="/gitweb/git-favicon.png" \
464         V=1
465
466 %{__make} -C contrib/subtree
467
468 %if %{with gnome_keyring}
469 %{__make} -C contrib/credential/gnome-keyring
470 %endif
471
472 %if %{with doc}
473 %{__make} -C Documentation \
474         MAN_BASE_URL=file://%{_docdir}/%{name}-doc-%{version}/ \
475         V=1
476 %endif
477
478 %if %{with tests}
479 %if %{without tests_cvs}
480 %{__rm} t/t*cvs*.sh || :
481 %endif
482 %{!?with_tests_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
483 %endif
484
485 %install
486 rm -rf $RPM_BUILD_ROOT
487 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
488 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
489 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
490 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
491 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
492 [init]
493         templatedir = %{_sysconfdir}/%{name}/templates
494 EOF
495
496 %{__make} install \
497         INSTALLDIRS=vendor \
498         DESTDIR=$RPM_BUILD_ROOT
499
500 %if %{with doc}
501 %{__make} -C Documentation install \
502         DESTDIR=$RPM_BUILD_ROOT
503 %endif
504
505 # copy templates except sample hooks
506 cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
507 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
508
509 # header files and lib
510 cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
511 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
512 cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
513 install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
514 cp -p block-sha1/sha1.h $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
515 cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
516 cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
517 cp -p {Makefile,config.mak,config.mak.autogen,config.mak.uname} $RPM_BUILD_ROOT%{_includedir}/%{name}
518
519 %{__make} -C contrib/subtree install \
520         libexecdir=%{gitcoredir} \
521         DESTDIR=$RPM_BUILD_ROOT
522
523 %if %{with doc}
524 %{__make} -C contrib/subtree install-man \
525         DESTDIR=$RPM_BUILD_ROOT
526 %endif
527
528 %if %{with gnome_keyring}
529 install -p contrib/credential/gnome-keyring/git-credential-gnome-keyring $RPM_BUILD_ROOT%{gitcoredir}
530 %endif
531
532 # bash completion
533 install -d $RPM_BUILD_ROOT%{bash_compdir}
534 cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{bash_compdir}/git
535
536 # Install git-prompt.sh
537 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/contrib/completion
538 cp -p contrib/completion/git-prompt.sh $RPM_BUILD_ROOT%{_datadir}/%{name}/contrib/completion
539
540 # Install bzr and hg remote helpers from contrib
541 install -p contrib/remote-helpers/git-remote-{bzr,hg} $RPM_BUILD_ROOT%{gitcoredir}
542
543 # gitweb
544 mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
545 ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
546 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
547 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{webappdir}/gitolite.pl
548 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
549 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
550 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
551
552 # gitview
553 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
554
555 # git-daemon related files
556 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
557 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
558 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
559
560 # paths cleanup
561 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
562 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
563
564 # hardlink
565 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
566 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
567 ln -f $RPM_BUILD_ROOT{%{gitcoredir},%{_bindir}}/git-shell
568 ln -f $RPM_BUILD_ROOT{%{gitcoredir},%{_bindir}}/git-upload-pack
569
570 # remove unneeded files
571 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
572 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
573 %py_postclean
574
575 mv $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
576 %find_lang git
577
578 %clean
579 rm -rf $RPM_BUILD_ROOT
580
581 %post daemon-inetd
582 %service -q rc-inetd reload
583
584 %postun daemon-inetd
585 if [ "$1" = "0" ]; then
586         %service -q rc-inetd reload
587 fi
588
589 %post daemon-standalone
590 /sbin/chkconfig --add git-daemon
591 %service git-daemon restart "git-daemon"
592
593 %preun daemon-standalone
594 if [ "$1" = "0" ]; then
595         %service git-daemon stop
596         /sbin/chkconfig --del git-daemon
597 fi
598
599 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
600 %webapp_register apache %{webapp}
601
602 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
603 %webapp_unregister apache %{webapp}
604
605 %triggerin gitweb -- apache < 2.2.0, apache-base
606 %webapp_register httpd %{webapp}
607
608 %triggerun gitweb -- apache < 2.2.0, apache-base
609 %webapp_unregister httpd %{webapp}
610
611 %triggerin gitweb -- lighttpd
612 %webapp_register lighttpd %{webapp}
613
614 %triggerun gitweb -- lighttpd
615 %webapp_unregister lighttpd %{webapp}
616
617 %files -f git.lang
618 %defattr(644,root,root,755)
619 %doc README contrib-doc
620 %attr(755,root,root) %{_bindir}/git
621 %attr(755,root,root) %{_bindir}/git-receive-pack
622 %attr(755,root,root) %{_bindir}/git-shell
623 %attr(755,root,root) %{_bindir}/git-upload-archive
624 %attr(755,root,root) %{_bindir}/git-upload-pack
625 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
626
627 %if %{with doc}
628 %{_mandir}/man1/git-*.1*
629 %exclude %{_mandir}/man1/git-archimport.1*
630 %exclude %{_mandir}/man1/git-svn.1*
631 %exclude %{_mandir}/man1/git-cvs*.1*
632 %exclude %{_mandir}/man1/git-imap-send*.1*
633 %exclude %{_mandir}/man1/*email*.1*
634 %{_mandir}/man1/git.1*
635 %{_mandir}/man1/gitremote-helpers.1*
636 %{_mandir}/man5/gitattributes.5*
637 %{_mandir}/man5/githooks.5*
638 %{_mandir}/man5/gitignore.5*
639 %{_mandir}/man5/gitmodules.5*
640 %{_mandir}/man5/gitrepository-layout.5*
641 %{_mandir}/man7/gitcli.7*
642 %{_mandir}/man7/gitcore-tutorial.7*
643 %{_mandir}/man7/gitcredentials.7*
644 %{_mandir}/man7/gitdiffcore.7*
645 %{_mandir}/man7/giteveryday.7*
646 %{_mandir}/man7/gitglossary.7*
647 %{_mandir}/man7/gitnamespaces.7*
648 %{_mandir}/man7/gitrevisions.7*
649 %{_mandir}/man7/gittutorial-2.7*
650 %{_mandir}/man7/gittutorial.7*
651 %{_mandir}/man7/gitworkflows.7*
652 %endif
653
654 %dir %{gitcoredir}
655 %attr(755,root,root) %{gitcoredir}/*-*
656 %attr(755,root,root) %{gitcoredir}/git
657 %dir %{gitcoredir}/mergetools
658 %{gitcoredir}/mergetools/*
659
660 %{_datadir}/%{name}
661 %{_localstatedir}/lib/git
662
663 # subpackages
664 %exclude %{gitcoredir}/*email*
665 %exclude %{gitcoredir}/*p4*
666 %exclude %{gitcoredir}/git-archimport
667 %exclude %{gitcoredir}/git-cvs*
668 %exclude %{gitcoredir}/git-gui
669 %exclude %{gitcoredir}/git-imap-send
670 %exclude %{gitcoredir}/git-instaweb
671 %exclude %{gitcoredir}/git-remote-bzr
672 %exclude %{gitcoredir}/git-remote-hg
673 %exclude %{gitcoredir}/git-remote-testsvn
674 %exclude %{gitcoredir}/git-svn
675 %exclude %{gitcoredir}/mergetools/p4merge
676 %if %{with gnome_keyring}
677 %exclude %{gitcoredir}/git-credential-gnome-keyring
678 %endif
679
680 %if %{with doc}
681 %files doc
682 %defattr(644,root,root,755)
683 %doc Documentation/RelNotes*
684 %doc Documentation/*.html Documentation/howto Documentation/technical
685 %endif
686
687 %files daemon-inetd
688 %defattr(644,root,root,755)
689 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
690
691 %files daemon-standalone
692 %defattr(644,root,root,755)
693 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
694 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
695
696 %files devel
697 %defattr(644,root,root,755)
698 %{_includedir}/%{name}
699 %{_libdir}/libgit.a
700 %{_libdir}/libgit_xdiff.a
701
702 %files gitk
703 %defattr(644,root,root,755)
704 %if %{with doc}
705 %{_mandir}/man1/gitk.1*
706 %endif
707 %attr(755,root,root) %{_bindir}/gitk
708 %dir %{_datadir}/gitk
709 %dir %{_datadir}/gitk/lib
710 %dir %{_datadir}/gitk/lib/msgs
711 %lang(bg) %{_datadir}/gitk/lib/msgs/bg.msg
712 %lang(ca) %{_datadir}/gitk/lib/msgs/ca.msg
713 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
714 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
715 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
716 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
717 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
718 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
719 %lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
720 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
721 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
722 %lang(vi) %{_datadir}/gitk/lib/msgs/vi.msg
723
724 %files gitweb
725 %defattr(644,root,root,755)
726 %doc gitweb/{README,INSTALL}
727 %dir %{webappdir}
728 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
729 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
730 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
731 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
732 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitolite.pl
733 %attr(755,root,root) %{cgibindir}/gitweb.cgi
734 %{appdir}
735 %attr(755,root,root) %{gitcoredir}/git-instaweb
736 %if %{with doc}
737 %{_mandir}/man1/gitweb.1*
738 %{_mandir}/man5/gitweb.conf.5*
739 %endif
740
741 %files gitview
742 %defattr(644,root,root,755)
743 %doc contrib/gitview/gitview.txt
744 %attr(755,root,root) %{_bindir}/gitview
745
746 %files gui
747 %defattr(644,root,root,755)
748 %attr(755,root,root) %{gitcoredir}/git-gui
749 %dir %{_datadir}/git-gui
750 %dir %{_datadir}/git-gui/lib
751 %dir %{_datadir}/git-gui/lib/msgs
752 %{_datadir}/git-gui/lib/git-gui.ico
753 %{_datadir}/git-gui/lib/tclIndex
754 %{_datadir}/git-gui/lib/*.js
755 %{_datadir}/git-gui/lib/*.tcl
756 %lang(bg) %{_datadir}/git-gui/lib/msgs/bg.msg
757 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
758 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
759 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
760 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
761 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
762 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
763 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
764 %lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
765 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
766 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
767 %lang(vi) %{_datadir}/git-gui/lib/msgs/vi.msg
768 %lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
769
770 %files arch
771 %defattr(644,root,root,755)
772 %attr(755,root,root) %{gitcoredir}/git-archimport
773 %if %{with doc}
774 %{_mandir}/man1/git-archimport.1*
775 %endif
776
777 %files bzr
778 %defattr(644,root,root,755)
779 %attr(755,root,root) %{gitcoredir}/git-remote-bzr
780
781 %files cvs
782 %defattr(644,root,root,755)
783 %attr(755,root,root) %{_bindir}/git-cvsserver
784 %attr(755,root,root) %{gitcoredir}/git-cvs*
785 %if %{with doc}
786 %{_mandir}/man1/git-cvs*.1*
787 %{_mandir}/man7/gitcvs-migration.7*
788 %endif
789
790 %files hg
791 %defattr(644,root,root,755)
792 %attr(755,root,root) %{gitcoredir}/git-remote-hg
793
794 %files p4
795 %defattr(644,root,root,755)
796 %attr(755,root,root) %{gitcoredir}/git-p4
797 %attr(755,root,root) %{gitcoredir}/mergetools/p4merge
798
799 %files svn
800 %defattr(644,root,root,755)
801 %attr(755,root,root) %{gitcoredir}/git-svn
802 %attr(755,root,root) %{gitcoredir}/git-remote-testsvn
803 %{perl_vendorlib}/Git/SVN
804 %{perl_vendorlib}/Git/SVN.pm
805 %if %{with doc}
806 %{_mandir}/man1/git-svn.1*
807 %endif
808
809 %files email
810 %defattr(644,root,root,755)
811 %attr(755,root,root) %{gitcoredir}/git-imap-send
812 %attr(755,root,root) %{gitcoredir}/*email*
813 %if %{with doc}
814 %{_mandir}/man1/*email*.1*
815 %{_mandir}/man1/*imap-send*.1*
816 %endif
817
818 %files -n bash-completion-git
819 %defattr(644,root,root,755)
820 %{bash_compdir}/git
821
822 %files -n perl-Git
823 %defattr(644,root,root,755)
824 %{perl_vendorlib}/Git.pm
825 %dir %{perl_vendorlib}/Git
826 %{perl_vendorlib}/Git/I18N.pm
827 %{perl_vendorlib}/Git/IndexInfo.pm
828 %{_mandir}/man3/Git*.3pm*
829
830 %if %{with gnome_keyring}
831 %files -n gnome-keyring-git-core
832 %defattr(644,root,root,755)
833 %attr(755,root,root) %{gitcoredir}/git-credential-gnome-keyring
834 %endif
This page took 0.07052 seconds and 2 git commands to generate.