]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
05acd2abb2026d68bdb4fcf57bdcac7985639413
[packages/git-core.git] / git-core.spec
1 # TODO:
2 # - gitweb subpackage
3 # - gitk subpackage?
4 %include        /usr/lib/rpm/macros.perl
5 Summary:        The stupid content tracker
6 Summary(pl):    Prymitywne narzêdzie do ¶ledzenia tre¶ci
7 Name:           git-core
8 Version:        1.4.4.4
9 Release:        1
10 License:        GPL v2
11 Group:          Development/Tools
12 Source0:        http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
13 # Source0-md5:  970aceba959e7fe92f065d7509e6db51
14 Patch0:         %{name}-build.patch
15 URL:            http://git.or.cz/
16 BuildRequires:  asciidoc
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  curl-devel
20 BuildRequires:  expat-devel
21 BuildRequires:  openssl-devel
22 BuildRequires:  perl-Error
23 BuildRequires:  perl-base
24 BuildRequires:  python
25 BuildRequires:  rpm-perlprov >= 4.1-13
26 BuildRequires:  xmlto
27 BuildRequires:  zlib-devel
28 Requires:       coreutils
29 Requires:       curl
30 Requires:       diffutils
31 Requires:       findutils
32 Requires:       grep
33 Requires:       openssh-clients
34 Requires:       rcs
35 Requires:       sed
36 Requires:       tk
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 "git" can mean anything, depending on your mood.
41
42  - random three-letter combination that is pronounceable, and not
43    actually used by any common UNIX command. The fact that it is a
44    mispronunciation of "get" may or may not be relevant.
45  - stupid. contemptible and despicable. simple. Take your pick from the
46    dictionary of slang.
47  - "global information tracker": you're in a good mood, and it actually
48    works for you. Angels sing, and a light suddenly fills the room.
49  - "goddamn idiotic truckload of sh*t": when it breaks
50
51 This is a stupid (but extremely fast) directory content manager. It
52 doesn't do a whole lot, but what it 'does' do is track directory
53 contents efficiently.
54
55 %description -l pl
56 "git" mo¿e oznaczaæ cokolwiek, w zale¿no¶ci od nastroju.
57
58 - losow± kombinacjê trzech liter, która jest wymawialna i w³a¶ciwie
59   nie u¿ywana przez ¿adne popularne polecenie uniksowe. Fakt, ¿e jest to
60   b³êdna pisownia s³owa "get" mo¿e mieæ lub nie mieæ znaczenia.
61 - g³upi, pogardliwy, prosty. Mo¿na wybraæ ze s³ownika slangu.
62 - "global information tracker" (narzêdzie do globalnego ¶ledzenia
63   informacji) - je¶li jeste¶my w dobrym nastroju i git akurat dzia³a.
64   Anio³y ¶piewaj±, a ¶wiat³o niespodziewanie wype³nia pokój.
65 - "goddamn idiotic truckload of sh*t" (przeklêty idiotyczny ³adunek
66   g*) - kiedy siê zepsuje.
67
68 Jest to prymitywny (ale bardzo szybki) zarz±dca tre¶ci s³ownikowej.
69 Nie robi wiele, ale to, co "robi", to wydajne ¶ledzenie zawarto¶ci
70 katalogu.
71
72 %package devel
73 Summary:        Header files for git-core
74 Summary(pl):    Pliki nag³ówkowe dla git-core
75 Group:          Development/Libraries
76
77 %description devel
78 Header files for git-core.
79
80 %description devel -l pl
81 Pliki nag³ówkowe dla git-core.
82
83 %package -n perl-Git
84 Summary:        Perl interface to the Git version control system
85 Summary(pl):    Perlowy interfejs do systemu kontroli wersji Git
86 Group:          Development/Languages/Perl
87 Requires:       %{name} = %{version}-%{release}
88 Obsoletes:      perl-git-core
89
90 %description -n perl-Git
91 This module provides Perl scripts easy way to interface the Git
92 version control system. The modules have an easy and well-tested way
93 to call arbitrary Git commands; in the future, the interface will also
94 provide specialized methods for doing easily operations which are not
95 totally trivial to do over the generic command interface.
96
97 %description -n perl-Git -l pl
98 Ten modu³ umo¿liwia skryptom Perla wspó³pracê z systemem kontroli
99 wersji Git. W ³atwy i dobrze przetestowany sposób pozwala wywo³ywaæ
100 dowolne polecenia Gita; w przysz³o¶ci interfejs udostêpni tak¿e
101 specjalne metody do ³atwego wykonywania operacji nietrywialnych do
102 wykonania przy u¿yciu ogólnego interfejsu poleceñ.
103
104 %prep
105 %setup -q -n git-%{version}
106 %patch0 -p1
107
108 %build
109 %{__aclocal}
110 %{__autoconf}
111 %configure \
112         --with-openssl
113
114 %{__make} \
115         INSTALLDIRS=vendor
116
117 %{__make} -C Documentation
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121 install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
122
123 %{__make} install \
124         DESTDIR=$RPM_BUILD_ROOT
125
126 %{__make} -C Documentation install \
127         DESTDIR=$RPM_BUILD_ROOT
128
129 install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
130 install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
131
132 rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
133 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 %files
139 %defattr(644,root,root,755)
140 %doc README Documentation/*.html Documentation/howto Documentation/technical
141 %attr(755,root,root) %{_bindir}/*
142 %{_mandir}/man*/*
143 %dir %{_datadir}/%{name}
144 %{_datadir}/%{name}/*
145
146 %files devel
147 %defattr(644,root,root,755)
148 %{_includedir}/*
149
150 %files -n perl-Git
151 %defattr(644,root,root,755)
152 %{perl_vendorlib}/Git.pm
153 %{_mandir}/man3/*
This page took 0.030129 seconds and 3 git commands to generate.