]> git.pld-linux.org Git - packages/git-core.git/blame_incremental - git-core.spec
add missing BR: pkgconfig for building of gnome keyring
[packages/git-core.git] / git-core.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without tests # don't perform make test
4%bcond_with tests_cvs # perform tests which use CVS
5%bcond_without tests_svn # perform tests which use subversion
6%bcond_without doc # skip building/packaging docs/manuals (takes some time)
7%bcond_without pcre # perl-compatible regexes support
8%bcond_without gnome_keyring # build without gnome keyring support
9
10%include /usr/lib/rpm/macros.perl
11Summary: Distributed version control system focused on speed, effectivity and usability
12Summary(pl.UTF-8): Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
13Name: git-core
14Version: 1.9.0
15Release: 3
16License: GPL v2
17Group: Development/Tools
18Source0: http://git-core.googlecode.com/files/git-%{version}.tar.gz
19# Source0-md5: e16c14b27c644b8e0dd72bdb5ff77450
20Source1: %{name}-gitweb.conf
21Source2: %{name}-gitweb-httpd.conf
22Source3: %{name}-gitweb-lighttpd.conf
23Source4: %{name}.sysconfig
24Source5: %{name}.inet
25Source6: %{name}.init
26Source7: gitolite.pl
27Patch0: %{name}-tests.patch
28Patch1: %{name}-key-bindings.patch
29Patch2: %{name}-sysconfdir.patch
30Patch3: cherry-picked-commitlog.patch
31Patch4: %{name}-svn-exit-errors.patch
32URL: http://git-scm.com/
33BuildRequires: autoconf >= 2.59
34BuildRequires: automake
35BuildRequires: curl-devel
36BuildRequires: expat-devel
37BuildRequires: gettext-devel
38%if %{with gnome_keyring}
39BuildRequires: libgnome-keyring-devel
40BuildRequires: pkgconfig
41%endif
42BuildRequires: openssl-devel
43%{?with_pcre:BuildRequires: pcre-devel}
44BuildRequires: perl-Error > 0.15
45BuildRequires: perl-base
46BuildRequires: python-devel
47BuildRequires: rpm-perlprov >= 4.1-13
48BuildRequires: rpm-pythonprov
49BuildRequires: rpmbuild(macros) >= 1.673
50BuildRequires: tcl
51BuildRequires: zlib-devel
52%if %{with doc}
53BuildRequires: asciidoc >= 7.1.2-3
54BuildRequires: docbook-dtd45-xml
55BuildRequires: xmlto
56%endif
57%if %{with tests}
58%if %{with tests_cvs}
59# tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
60BuildRequires: cvs-gnu-client < 1.13
61BuildRequires: cvs-gnu-client >= 1.12
62%endif
63%{?with_tests_svn:BuildRequires: subversion}
64Conflicts: pdksh < 5.2.14-46
65%endif
66Requires: coreutils
67Requires: diffutils
68Requires: findutils
69Requires: grep
70Requires: openssh-clients
71Requires: perl-Error
72Requires: perl-Git = %{version}-%{release}
73Requires: sed
74Suggests: git-core-bzr
75Suggests: git-core-cvs
76Suggests: git-core-hg
77Suggests: git-core-p4
78Suggests: git-core-svn
79Suggests: less
80Suggests: rsync
81Obsoletes: python-Git
82BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
83
84# html docs have links to txt files
85%define _noautocompressdoc *.txt
86
87%define webapp gitweb
88%define webappdir %{_sysconfdir}/webapps/%{webapp}
89%define appdir %{_datadir}/%{webapp}
90%define cgibindir %{_prefix}/lib/cgi-bin
91
92%description
93"git" can mean anything, depending on your mood.
94
95- random three-letter combination that is pronounceable, and not
96 actually used by any common UNIX command. The fact that it is a
97 mispronunciation of "get" may or may not be relevant.
98- stupid. contemptible and despicable. simple. Take your pick from the
99 dictionary of slang.
100- "global information tracker": you're in a good mood, and it actually
101 works for you. Angels sing, and a light suddenly fills the room.
102- "goddamn idiotic truckload of sh*t": when it breaks
103
104This is a stupid (but extremely fast) directory content manager. It
105doesn't do a whole lot, but what it 'does' do is track directory
106contents efficiently.
107
108%description -l pl.UTF-8
109"git" może oznaczać cokolwiek, w zależności od nastroju.
110
111- losową kombinację trzech liter, która jest wymawialna i właściwie
112 nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
113 błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
114- głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
115- "global information tracker" (narzędzie do globalnego śledzenia
116 informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
117 Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
118- "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
119 g*) - kiedy się zepsuje.
120
121Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
122Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
123katalogu.
124
125%package doc
126Summary: Documentation for git-core
127Summary(pl.UTF-8): Dokumentacja do git-core
128Group: Documentation
129
130%description doc
131Documentation for git-core.
132
133%description doc -l pl.UTF-8
134Dokumentacja do git-core.
135
136%description doc -l fr.UTF-8
137Javadoc pour git-core.
138
139%package daemon-inetd
140Summary: Files necessary to run git-daemon as an inetd service
141Summary(pl.UTF-8): Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
142Group: Networking/Daemons
143Requires: %{name} = %{version}-%{release}
144Requires: setup >= 2.4.11-1
145Provides: git-core-daemon
146Obsoletes: git-core-daemon
147Obsoletes: git-core-daemon-standalone
148
149%description daemon-inetd
150Git-daemon is a really simple TCP git daemon that can serve git
151repositories. This package provides all necessarry files to run
152git-daemon as an inetd service.
153
154%description daemon-inetd -l pl.UTF-8
155Git-daemon to prosty demon git korzystający z protokołu TCP do
156udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
157do uruchomienia git-demona w trybie usługi inetd.
158
159%package daemon-standalone
160Summary: Files necessary to run git-daemon as a standalone service
161Summary(pl.UTF-8): Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
162Group: Networking/Daemons
163Requires: %{name} = %{version}-%{release}
164Provides: git-core-daemon
165Obsoletes: git-core-daemon
166Obsoletes: git-core-daemon-inetd
167
168%description daemon-standalone
169Git-daemon is a really simple TCP git daemon that can serve git
170repositories. This package provides all necessarry files to run
171git-daemon as an standalone service.
172
173%description daemon-standalone -l pl.UTF-8
174Git-daemon to prosty demon git korzystający z protokołu TCP do
175udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
176do uruchomienia git-daemona w trybie usługi samodzielnej.
177
178%package devel
179Summary: Git library with header files
180Summary(pl.UTF-8): Biblioteka Gita oraz pliki nagłówkowe
181Group: Development/Libraries
182Requires: zlib-devel
183
184%description devel
185Git library with header files.
186
187%description devel -l pl.UTF-8
188Biblioteka Gita oraz pliki nagłówkowe.
189
190%package gitk
191Summary: Tcl/Tk interface to the Git version control system
192Summary(pl.UTF-8): Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
193Group: Development/Tools
194Requires: %{name} = %{version}-%{release}
195Requires: tk
196
197%description gitk
198gitk displays changes in a repository or a selected set of commits.
199This includes visualizing the commit graph, showing information
200related to each commit, and the files in the trees of each revision.
201
202Historically, gitk was the first repository browser. It's written in
203Tcl/Tk and started off in a separate repository but was later merged
204into the main git repository.
205
206%description gitk -l pl.UTF-8
207gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
208Oznacza to wizualizację grafu commitów, wyświetlanie informacji
209związanych z każdym z commitów oraz listę plików dla każdej rewizji.
210
211Z historycznego punktu widzenia gitk był pierwszą przeglądarką
212repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
213osobnym repozytorium, ale z czasem został włączony do głównego
214repozytorium gita.
215
216%package gitweb
217Summary: Web frontend to git
218Summary(pl.UTF-8): Frontend WWW do gita
219Group: Development/Tools
220Requires: %{name} = %{version}-%{release}
221Requires: webapps
222Requires: webserver(access)
223Requires: webserver(alias)
224Requires: webserver(cgi)
225Suggests: webserver(setenv)
226
227%description gitweb
228This package provides a web interface for browsing git repositories.
229
230%description gitweb -l pl.UTF-8
231Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
232
233%package gitview
234Summary: A GTK+ based repository browser for git
235Summary(pl.UTF-8): Oparta na GTK+ przeglądarka repozytorium gita
236Group: Development/Tools
237Requires: %{name} = %{version}-%{release}
238Requires: python >= 1:2.4
239Requires: python-pycairo >= 1.0
240Requires: python-pygobject
241Requires: python-pygtk-gtk >= 2:2.8
242Suggests: python-gnome-desktop-gtksourceview
243
244%description gitview
245A GTK+ based repository browser for git.
246
247%description gitview -l pl.UTF-8
248Oparta na GTK+ przeglądarka repozytorium gita.
249
250%package gui
251Summary: Tcl/Tk interface to the Git version control system
252Summary(pl.UTF-8): Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
253Group: Development/Tools
254Requires: %{name} = %{version}-%{release}
255Requires: tk
256Requires: xdg-utils
257Suggests: meld
258
259%description gui
260Displays changes in a repository or a selected set of commits. This
261includes visualizing the commit graph, showing information related to
262each commit, and the files in the trees of each revision.
263
264Historically, gitk was the first repository browser. It's written in
265Tcl/Tk and started off in a separate repository but was later merged
266into the main git repository.
267
268%description gui -l pl.UTF-8
269Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
270to wizualizację grafu commitów, wyświetlanie informacji związanych z
271każdym z commitów oraz listę plików dla każdej rewizji.
272
273Z punktu widzenia historii, gitk był pierwszą przeglądarką
274repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
275osobnym repozytorium, ale z czasem został włączony do głównego
276repozytorium gita.
277
278%package arch
279Summary: Git tools for importing Arch repositories
280Summary(pl.UTF-8): Narzędzia Gita do importowania repozytoriów Archa
281Group: Development/Tools
282Requires: %{name} = %{version}-%{release}
283Requires: tla
284
285%description arch
286Git tools for importing Arch repositories.
287
288%description arch -l pl.UTF-8
289Narzędzia Gita do importowania repozytoriów Archa.
290
291%package bzr
292Summary: Git tools for working with bzr repositories
293Summary(pl.UTF-8): Narzędzia Gita do pracy z repozytoriami bzr
294Group: Development/Tools
295Requires: %{name} = %{version}-%{release}
296Requires: bzr
297
298%description bzr
299Git tools for working with bzr repositories.
300
301%description bzr -l pl.UTF-8
302Narzędzia Gita do pracy z repozytoriami bzr.
303
304%package cvs
305Summary: CVS support for Git
306Summary(pl.UTF-8): Obsługa CVS dla Gita
307Group: Development/Tools
308Requires: %{name} = %{version}-%{release}
309Requires: cvsps >= 2.1-2
310Requires: rcs
311
312%description cvs
313CVS support for Git.
314
315%description cvs -l pl.UTF-8
316Obsługa CVS dla Gita.
317
318%package hg
319Summary: Git tools for working with mercurial repositories
320Summary(pl.UTF-8): Narzędzia Gita do pracy z repozytoriami mercuriala
321Group: Development/Tools
322Requires: %{name} = %{version}-%{release}
323Requires: mercurial >= 1.8
324
325%description hg
326Git tools for working with mercurial repositories.
327
328%description hg -l pl.UTF-8
329Narzędzia Gita do pracy z repozytoriami mercuriala.
330
331%package p4
332Summary: Git tools for working with Perforce depots
333Summary(pl.UTF-8): Narzędzia Gita do pracy z magazynami Perforce'a
334Group: Development/Tools
335Requires: %{name} = %{version}-%{release}
336
337%description p4
338Git tools for working with Perforce depots.
339
340%description p4 -l pl.UTF-8
341Narzędzia Gita do pracy z magazynami Perforce'a.
342
343%package svn
344Summary: Subversion support for Git
345Summary(pl.UTF-8): Obsługa Subversion dla Gita
346Group: Development/Tools
347Requires: %{name} = %{version}-%{release}
348Requires: perl-Encode
349Requires: perl-Term-ReadKey
350
351%description svn
352Subversion support for Git.
353
354%description svn -l pl.UTF-8
355Obsługa Subversion dla Gita.
356
357%package email
358Summary: Git tools for sending email
359Summary(pl.UTF-8): Narzędzia Gita do wysyłania poczty
360Group: Development/Tools
361Requires: %{name} = %{version}-%{release}
362
363%description email
364Git tools for sending email.
365
366%description email -l pl.UTF-8
367Narzędzia Gita do wysyłania poczty.
368
369%package -n bash-completion-git
370Summary: bash-completion for git
371Summary(pl.UTF-8): bashowe uzupełnianie nazw dla gita
372Group: Applications/Shells
373Requires: %{name} = %{version}-%{release}
374Requires: bash-completion >= 2.0
375%if "%{_rpmversion}" >= "5"
376BuildArch: noarch
377%endif
378
379%description -n bash-completion-git
380This package provides bash-completion for git.
381
382%description -n bash-completion-git -l pl.UTF-8
383Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
384
385%package -n perl-Git
386Summary: Perl interface to the Git version control system
387Summary(pl.UTF-8): Perlowy interfejs do systemu kontroli wersji Git
388Group: Development/Languages/Perl
389Obsoletes: perl-git-core
390
391%description -n perl-Git
392This module provides Perl scripts easy way to interface the Git
393version control system. The modules have an easy and well-tested way
394to call arbitrary Git commands; in the future, the interface will also
395provide specialized methods for doing easily operations which are not
396totally trivial to do over the generic command interface.
397
398%description -n perl-Git -l pl.UTF-8
399Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
400wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
401dowolne polecenia Gita; w przyszłości interfejs udostępni także
402specjalne metody do łatwego wykonywania operacji nietrywialnych do
403wykonania przy użyciu ogólnego interfejsu poleceń.
404
405%package -n gnome-keyring-git-core
406Summary: GNOME Keyring authentication provider for Git
407Summary(pl.UTF-8): Moduł uwierzytelniający GNOME Keyring dla Git
408Group: X11/Applications
409Requires: %{name} = %{version}-%{release}
410
411%description -n gnome-keyring-git-core
412Authentication provider module for Git which allows git client to
413authenticate using GNOME Keyring.
414
415%description -n gnome-keyring-git-core -l pl.UTF-8
416Moduł uwierzytelniający dla Subversion pozwalający klientom git
417uwierzytelniać się przy użyciu mechanizmu GNOME Keyring.
418
419%prep
420%setup -q -n git-%{version}
421%patch0 -p1
422%patch1 -p0
423%patch2 -p1
424%patch3 -p1
425%patch4 -p1
426
427%{__rm} {Documentation/technical,contrib/emacs,contrib/credential/gnome-keyring}/.gitignore
428
429%build
430%{__aclocal}
431%{__autoconf}
432%configure \
433 --sysconfdir=%{_sysconfdir}/git-core \
434 %{?with_pcre:--with-libpcre} \
435 --with-openssl
436
437echo "BLK_SHA1=1" >> config.mak
438
439%{__make} \
440 INSTALLDIRS=vendor \
441 GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
442 GITWEB_PROJECTROOT="/var/lib/git" \
443 GITWEB_CSS="/gitweb/gitweb.css" \
444 GITWEB_LOGO="/gitweb/git-logo.png" \
445 GITWEB_FAVICON="/gitweb/git-favicon.png" \
446 V=1
447
448%{__make} -C contrib/subtree
449
450%if %{with gnome_keyring}
451%{__make} -C contrib/credential/gnome-keyring
452%endif
453
454%if %{with doc}
455%{__make} -C Documentation \
456 MAN_BASE_URL=file://%{_docdir}/%{name}-doc-%{version}/ \
457 V=1
458%endif
459
460%if %{with tests}
461%if %{without tests_cvs}
462%{__rm} t/t*cvs*.sh || :
463%endif
464%{!?with_tests_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
465%endif
466
467%install
468rm -rf $RPM_BUILD_ROOT
469install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
470install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
471install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
472install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
473cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
474[init]
475 templatedir = %{_sysconfdir}/%{name}/templates
476EOF
477
478%{__make} install \
479 INSTALLDIRS=vendor \
480 DESTDIR=$RPM_BUILD_ROOT
481
482%if %{with doc}
483%{__make} -C Documentation install \
484 DESTDIR=$RPM_BUILD_ROOT
485%endif
486
487# copy templates except sample hooks
488cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
489%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
490
491# header files and lib
492cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
493cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
494cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
495install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
496cp -p block-sha1/sha1.h $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
497cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
498cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
499cp -p {Makefile,config.mak,config.mak.autogen,config.mak.uname} $RPM_BUILD_ROOT%{_includedir}/%{name}
500
501%{__make} -C contrib/subtree install \
502 libexecdir=%{_libdir}/%{name} \
503 DESTDIR=$RPM_BUILD_ROOT
504
505%if %{with doc}
506%{__make} -C contrib/subtree install-doc \
507 DESTDIR=$RPM_BUILD_ROOT
508%endif
509
510%if %{with gnome_keyring}
511install -p contrib/credential/gnome-keyring/git-credential-gnome-keyring $RPM_BUILD_ROOT%{_libdir}/%{name}
512# Remove built binary files, otherwise they will be installed in doc
513%{__make} -C contrib/credential/gnome-keyring clean
514%endif
515
516# bash completion
517install -d $RPM_BUILD_ROOT%{bash_compdir}
518cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{bash_compdir}/git
519
520# Install git-prompt.sh
521install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/contrib/completion
522cp -p contrib/completion/git-prompt.sh $RPM_BUILD_ROOT%{_datadir}/%{name}/contrib/completion
523
524# Install bzr and hg remote helpers from contrib
525install -p contrib/remote-helpers/git-remote-{bzr,hg} $RPM_BUILD_ROOT%{_libdir}/%{name}
526
527# gitweb
528mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
529ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
530cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
531cp -p %{SOURCE7} $RPM_BUILD_ROOT%{webappdir}/gitolite.pl
532cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
533cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
534cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
535
536# gitview
537install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
538
539# git-daemon related files
540cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
541cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
542install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
543
544# paths cleanup
545sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
546sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
547
548# hardlink
549ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
550ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
551ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
552ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
553
554# remove unneeded files
555%{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
556%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
557%py_postclean
558
559mv $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
560%find_lang git
561
562%clean
563rm -rf $RPM_BUILD_ROOT
564
565%post daemon-inetd
566%service -q rc-inetd reload
567
568%postun daemon-inetd
569if [ "$1" = "0" ]; then
570 %service -q rc-inetd reload
571fi
572
573%post daemon-standalone
574/sbin/chkconfig --add git-daemon
575%service git-daemon restart "git-daemon"
576
577%preun daemon-standalone
578if [ "$1" = "0" ]; then
579 %service git-daemon stop
580 /sbin/chkconfig --del git-daemon
581fi
582
583%triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
584%webapp_register apache %{webapp}
585
586%triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
587%webapp_unregister apache %{webapp}
588
589%triggerin gitweb -- apache < 2.2.0, apache-base
590%webapp_register httpd %{webapp}
591
592%triggerun gitweb -- apache < 2.2.0, apache-base
593%webapp_unregister httpd %{webapp}
594
595%triggerin gitweb -- lighttpd
596%webapp_register lighttpd %{webapp}
597
598%triggerun gitweb -- lighttpd
599%webapp_unregister lighttpd %{webapp}
600
601%files -f git.lang
602%defattr(644,root,root,755)
603%doc README contrib
604%attr(755,root,root) %{_bindir}/git
605%attr(755,root,root) %{_bindir}/git-receive-pack
606%attr(755,root,root) %{_bindir}/git-shell
607%attr(755,root,root) %{_bindir}/git-upload-archive
608%attr(755,root,root) %{_bindir}/git-upload-pack
609%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
610
611%if %{with doc}
612%{_mandir}/man1/git-*.1*
613%exclude %{_mandir}/man1/git-archimport.1*
614%exclude %{_mandir}/man1/git-svn.1*
615%exclude %{_mandir}/man1/git-cvs*.1*
616%exclude %{_mandir}/man1/git-imap-send*.1*
617%exclude %{_mandir}/man1/*email*.1*
618%{_mandir}/man1/git.1*
619%{_mandir}/man1/gitremote-helpers.1*
620%{_mandir}/man5/gitattributes.5*
621%{_mandir}/man5/githooks.5*
622%{_mandir}/man5/gitignore.5*
623%{_mandir}/man5/gitmodules.5*
624%{_mandir}/man5/gitrepository-layout.5*
625%{_mandir}/man7/gitcli.7*
626%{_mandir}/man7/gitcore-tutorial.7*
627%{_mandir}/man7/gitcredentials.7*
628%{_mandir}/man7/gitdiffcore.7*
629%{_mandir}/man7/gitglossary.7*
630%{_mandir}/man7/gitnamespaces.7*
631%{_mandir}/man7/gitrevisions.7*
632%{_mandir}/man7/gittutorial-2.7*
633%{_mandir}/man7/gittutorial.7*
634%{_mandir}/man7/gitworkflows.7*
635%endif
636
637%dir %{_libdir}/%{name}
638%attr(755,root,root) %{_libdir}/%{name}/*-*
639%attr(755,root,root) %{_libdir}/%{name}/git
640%dir %{_libdir}/%{name}/mergetools
641%{_libdir}/%{name}/mergetools/*
642
643%{_datadir}/%{name}
644%{_localstatedir}/lib/git
645
646# subpackages
647%exclude %{_libdir}/%{name}/*email*
648%exclude %{_libdir}/%{name}/*p4*
649%exclude %{_libdir}/%{name}/git-archimport
650%exclude %{_libdir}/%{name}/git-cvs*
651%exclude %{_libdir}/%{name}/git-gui
652%exclude %{_libdir}/%{name}/git-imap-send
653%exclude %{_libdir}/%{name}/git-instaweb
654%exclude %{_libdir}/%{name}/git-remote-bzr
655%exclude %{_libdir}/%{name}/git-remote-hg
656%exclude %{_libdir}/%{name}/git-remote-testsvn
657%exclude %{_libdir}/%{name}/git-svn
658%exclude %{_libdir}/%{name}/mergetools/p4merge
659%if %{with gnome_keyring}
660%exclude %{_libdir}/%{name}/git-credential-gnome-keyring
661%endif
662
663%if %{with doc}
664%files doc
665%defattr(644,root,root,755)
666%doc Documentation/RelNotes*
667%doc Documentation/*.html Documentation/howto Documentation/technical
668%endif
669
670%files daemon-inetd
671%defattr(644,root,root,755)
672%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
673
674%files daemon-standalone
675%defattr(644,root,root,755)
676%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
677%attr(754,root, root) /etc/rc.d/init.d/git-daemon
678
679%files devel
680%defattr(644,root,root,755)
681%{_includedir}/%{name}
682%{_libdir}/libgit.a
683%{_libdir}/libgit_xdiff.a
684
685%files gitk
686%defattr(644,root,root,755)
687%if %{with doc}
688%{_mandir}/man1/gitk.1*
689%endif
690%attr(755,root,root) %{_bindir}/gitk
691%dir %{_datadir}/gitk
692%dir %{_datadir}/gitk/lib
693%dir %{_datadir}/gitk/lib/msgs
694%lang(bg) %{_datadir}/gitk/lib/msgs/bg.msg
695%lang(de) %{_datadir}/gitk/lib/msgs/de.msg
696%lang(es) %{_datadir}/gitk/lib/msgs/es.msg
697%lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
698%lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
699%lang(it) %{_datadir}/gitk/lib/msgs/it.msg
700%lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
701%lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
702%lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
703%lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
704
705%files gitweb
706%defattr(644,root,root,755)
707%doc gitweb/{README,INSTALL}
708%dir %{webappdir}
709%config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
710%config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
711%config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
712%config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
713%config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitolite.pl
714%attr(755,root,root) %{cgibindir}/gitweb.cgi
715%{appdir}
716%attr(755,root,root) %{_libdir}/%{name}/git-instaweb
717%if %{with doc}
718%{_mandir}/man1/gitweb.1*
719%{_mandir}/man5/gitweb.conf.5*
720%endif
721
722%files gitview
723%defattr(644,root,root,755)
724%doc contrib/gitview/gitview.txt
725%attr(755,root,root) %{_bindir}/gitview
726
727%files gui
728%defattr(644,root,root,755)
729%attr(755,root,root) %{_libdir}/%{name}/git-gui
730%dir %{_datadir}/git-gui
731%dir %{_datadir}/git-gui/lib
732%dir %{_datadir}/git-gui/lib/msgs
733%{_datadir}/git-gui/lib/git-gui.ico
734%{_datadir}/git-gui/lib/tclIndex
735%{_datadir}/git-gui/lib/*.js
736%{_datadir}/git-gui/lib/*.tcl
737%lang(bg) %{_datadir}/git-gui/lib/msgs/bg.msg
738%lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
739%lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
740%lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
741%lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
742%lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
743%lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
744%lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
745%lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
746%lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
747%lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
748%lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
749
750%files arch
751%defattr(644,root,root,755)
752%attr(755,root,root) %{_libdir}/%{name}/git-archimport
753%if %{with doc}
754%{_mandir}/man1/git-archimport.1*
755%endif
756
757%files bzr
758%defattr(644,root,root,755)
759%attr(755,root,root) %{_libdir}/%{name}/git-remote-bzr
760
761%files cvs
762%defattr(644,root,root,755)
763%attr(755,root,root) %{_bindir}/git-cvsserver
764%attr(755,root,root) %{_libdir}/%{name}/git-cvs*
765%if %{with doc}
766%{_mandir}/man1/git-cvs*.1*
767%{_mandir}/man7/gitcvs-migration.7*
768%endif
769
770%files hg
771%defattr(644,root,root,755)
772%attr(755,root,root) %{_libdir}/%{name}/git-remote-hg
773
774%files p4
775%defattr(644,root,root,755)
776%attr(755,root,root) %{_libdir}/%{name}/git-p4
777%attr(755,root,root) %{_libdir}/%{name}/mergetools/p4merge
778
779%files svn
780%defattr(644,root,root,755)
781%attr(755,root,root) %{_libdir}/%{name}/git-svn
782%attr(755,root,root) %{_libdir}/%{name}/git-remote-testsvn
783%{perl_vendorlib}/Git/SVN
784%{perl_vendorlib}/Git/SVN.pm
785%if %{with doc}
786%{_mandir}/man1/git-svn.1*
787%endif
788
789%files email
790%defattr(644,root,root,755)
791%attr(755,root,root) %{_libdir}/%{name}/git-imap-send
792%attr(755,root,root) %{_libdir}/%{name}/*email*
793%if %{with doc}
794%{_mandir}/man1/*email*.1*
795%{_mandir}/man1/*imap-send*.1*
796%endif
797
798%files -n bash-completion-git
799%defattr(644,root,root,755)
800%{bash_compdir}/git
801
802%files -n perl-Git
803%defattr(644,root,root,755)
804%{perl_vendorlib}/Git.pm
805%dir %{perl_vendorlib}/Git
806%{perl_vendorlib}/Git/I18N.pm
807%{perl_vendorlib}/Git/IndexInfo.pm
808%{_mandir}/man3/Git*.3pm*
809
810%if %{with gnome_keyring}
811%files -n gnome-keyring-git-core
812%defattr(644,root,root,755)
813%attr(755,root,root) %{_libdir}/%{name}/git-credential-gnome-keyring
814%endif
This page took 0.14578 seconds and 4 git commands to generate.