]> git.pld-linux.org Git - packages/git-core.git/blame_incremental - git-core.spec
noarch bash completions
[packages/git-core.git] / git-core.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without tests # don't perform make test
4%bcond_with tests_cvs # perform tests which use CVS
5%bcond_without tests_svn # perform tests which use subversion
6%bcond_without doc # skip building/packaging docs/manuals (takes some time)
7%bcond_without pcre # perl-compatible regexes support
8
9%include /usr/lib/rpm/macros.perl
10Summary: Distributed version control system focused on speed, effectivity and usability
11Summary(pl.UTF-8): Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
12Name: git-core
13Version: 1.9.0
14Release: 2
15License: GPL v2
16Group: Development/Tools
17Source0: http://git-core.googlecode.com/files/git-%{version}.tar.gz
18# Source0-md5: e16c14b27c644b8e0dd72bdb5ff77450
19Source1: %{name}-gitweb.conf
20Source2: %{name}-gitweb-httpd.conf
21Source3: %{name}-gitweb-lighttpd.conf
22Source4: %{name}.sysconfig
23Source5: %{name}.inet
24Source6: %{name}.init
25Source7: gitolite.pl
26Patch0: %{name}-tests.patch
27Patch1: %{name}-key-bindings.patch
28Patch2: %{name}-sysconfdir.patch
29Patch3: cherry-picked-commitlog.patch
30Patch4: %{name}-svn-exit-errors.patch
31URL: http://git-scm.com/
32BuildRequires: autoconf >= 2.59
33BuildRequires: automake
34BuildRequires: curl-devel
35BuildRequires: expat-devel
36BuildRequires: gettext-devel
37BuildRequires: openssl-devel
38%{?with_pcre:BuildRequires: pcre-devel}
39BuildRequires: perl-Error > 0.15
40BuildRequires: perl-base
41BuildRequires: python-devel
42BuildRequires: rpm-perlprov >= 4.1-13
43BuildRequires: rpm-pythonprov
44BuildRequires: rpmbuild(macros) >= 1.673
45BuildRequires: tcl
46BuildRequires: zlib-devel
47%if %{with doc}
48BuildRequires: asciidoc >= 7.1.2-3
49BuildRequires: docbook-dtd45-xml
50BuildRequires: xmlto
51%endif
52%if %{with tests}
53%if %{with tests_cvs}
54# tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
55BuildRequires: cvs-gnu-client < 1.13
56BuildRequires: cvs-gnu-client >= 1.12
57%endif
58%{?with_tests_svn:BuildRequires: subversion}
59Conflicts: pdksh < 5.2.14-46
60%endif
61Requires: coreutils
62Requires: diffutils
63Requires: findutils
64Requires: grep
65Requires: openssh-clients
66Requires: perl-Error
67Requires: perl-Git = %{version}-%{release}
68Requires: sed
69Suggests: git-core-bzr
70Suggests: git-core-cvs
71Suggests: git-core-hg
72Suggests: git-core-p4
73Suggests: git-core-svn
74Suggests: less
75Suggests: rsync
76Obsoletes: python-Git
77BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
78
79# html docs have links to txt files
80%define _noautocompressdoc *.txt
81
82%define webapp gitweb
83%define webappdir %{_sysconfdir}/webapps/%{webapp}
84%define appdir %{_datadir}/%{webapp}
85%define cgibindir %{_prefix}/lib/cgi-bin
86
87%description
88"git" can mean anything, depending on your mood.
89
90- random three-letter combination that is pronounceable, and not
91 actually used by any common UNIX command. The fact that it is a
92 mispronunciation of "get" may or may not be relevant.
93- stupid. contemptible and despicable. simple. Take your pick from the
94 dictionary of slang.
95- "global information tracker": you're in a good mood, and it actually
96 works for you. Angels sing, and a light suddenly fills the room.
97- "goddamn idiotic truckload of sh*t": when it breaks
98
99This is a stupid (but extremely fast) directory content manager. It
100doesn't do a whole lot, but what it 'does' do is track directory
101contents efficiently.
102
103%description -l pl.UTF-8
104"git" może oznaczać cokolwiek, w zależności od nastroju.
105
106- losową kombinację trzech liter, która jest wymawialna i właściwie
107 nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
108 błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
109- głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
110- "global information tracker" (narzędzie do globalnego śledzenia
111 informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
112 Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
113- "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
114 g*) - kiedy się zepsuje.
115
116Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
117Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
118katalogu.
119
120%package doc
121Summary: Documentation for git-core
122Summary(pl.UTF-8): Dokumentacja do git-core
123Group: Documentation
124
125%description doc
126Documentation for git-core.
127
128%description doc -l pl.UTF-8
129Dokumentacja do git-core.
130
131%description doc -l fr.UTF-8
132Javadoc pour git-core.
133
134%package daemon-inetd
135Summary: Files necessary to run git-daemon as an inetd service
136Summary(pl.UTF-8): Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
137Group: Networking/Daemons
138Requires: %{name} = %{version}-%{release}
139Requires: setup >= 2.4.11-1
140Provides: git-core-daemon
141Obsoletes: git-core-daemon
142Obsoletes: git-core-daemon-standalone
143
144%description daemon-inetd
145Git-daemon is a really simple TCP git daemon that can serve git
146repositories. This package provides all necessarry files to run
147git-daemon as an inetd service.
148
149%description daemon-inetd -l pl.UTF-8
150Git-daemon to prosty demon git korzystający z protokołu TCP do
151udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
152do uruchomienia git-demona w trybie usługi inetd.
153
154%package daemon-standalone
155Summary: Files necessary to run git-daemon as a standalone service
156Summary(pl.UTF-8): Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
157Group: Networking/Daemons
158Requires: %{name} = %{version}-%{release}
159Provides: git-core-daemon
160Obsoletes: git-core-daemon
161Obsoletes: git-core-daemon-inetd
162
163%description daemon-standalone
164Git-daemon is a really simple TCP git daemon that can serve git
165repositories. This package provides all necessarry files to run
166git-daemon as an standalone service.
167
168%description daemon-standalone -l pl.UTF-8
169Git-daemon to prosty demon git korzystający z protokołu TCP do
170udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
171do uruchomienia git-daemona w trybie usługi samodzielnej.
172
173%package devel
174Summary: Git library with header files
175Summary(pl.UTF-8): Biblioteka Gita oraz pliki nagłówkowe
176Group: Development/Libraries
177Requires: zlib-devel
178
179%description devel
180Git library with header files.
181
182%description devel -l pl.UTF-8
183Biblioteka Gita oraz pliki nagłówkowe.
184
185%package gitk
186Summary: Tcl/Tk interface to the Git version control system
187Summary(pl.UTF-8): Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
188Group: Development/Tools
189Requires: %{name} = %{version}-%{release}
190Requires: tk
191
192%description gitk
193gitk displays changes in a repository or a selected set of commits.
194This includes visualizing the commit graph, showing information
195related to each commit, and the files in the trees of each revision.
196
197Historically, gitk was the first repository browser. It's written in
198Tcl/Tk and started off in a separate repository but was later merged
199into the main git repository.
200
201%description gitk -l pl.UTF-8
202gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
203Oznacza to wizualizację grafu commitów, wyświetlanie informacji
204związanych z każdym z commitów oraz listę plików dla każdej rewizji.
205
206Z historycznego punktu widzenia gitk był pierwszą przeglądarką
207repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
208osobnym repozytorium, ale z czasem został włączony do głównego
209repozytorium gita.
210
211%package gitweb
212Summary: Web frontend to git
213Summary(pl.UTF-8): Frontend WWW do gita
214Group: Development/Tools
215Requires: %{name} = %{version}-%{release}
216Requires: webapps
217Requires: webserver(access)
218Requires: webserver(alias)
219Requires: webserver(cgi)
220Suggests: webserver(setenv)
221
222%description gitweb
223This package provides a web interface for browsing git repositories.
224
225%description gitweb -l pl.UTF-8
226Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
227
228%package gitview
229Summary: A GTK+ based repository browser for git
230Summary(pl.UTF-8): Oparta na GTK+ przeglądarka repozytorium gita
231Group: Development/Tools
232Requires: %{name} = %{version}-%{release}
233Requires: python >= 1:2.4
234Requires: python-pycairo >= 1.0
235Requires: python-pygobject
236Requires: python-pygtk-gtk >= 2:2.8
237Suggests: python-gnome-desktop-gtksourceview
238
239%description gitview
240A GTK+ based repository browser for git.
241
242%description gitview -l pl.UTF-8
243Oparta na GTK+ przeglądarka repozytorium gita.
244
245%package gui
246Summary: Tcl/Tk interface to the Git version control system
247Summary(pl.UTF-8): Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
248Group: Development/Tools
249Requires: %{name} = %{version}-%{release}
250Requires: tk
251Requires: xdg-utils
252Suggests: meld
253
254%description gui
255Displays changes in a repository or a selected set of commits. This
256includes visualizing the commit graph, showing information related to
257each commit, and the files in the trees of each revision.
258
259Historically, gitk was the first repository browser. It's written in
260Tcl/Tk and started off in a separate repository but was later merged
261into the main git repository.
262
263%description gui -l pl.UTF-8
264Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
265to wizualizację grafu commitów, wyświetlanie informacji związanych z
266każdym z commitów oraz listę plików dla każdej rewizji.
267
268Z punktu widzenia historii, gitk był pierwszą przeglądarką
269repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
270osobnym repozytorium, ale z czasem został włączony do głównego
271repozytorium gita.
272
273%package arch
274Summary: Git tools for importing Arch repositories
275Summary(pl.UTF-8): Narzędzia Gita do importowania repozytoriów Archa
276Group: Development/Tools
277Requires: %{name} = %{version}-%{release}
278Requires: tla
279
280%description arch
281Git tools for importing Arch repositories.
282
283%description arch -l pl.UTF-8
284Narzędzia Gita do importowania repozytoriów Archa.
285
286%package bzr
287Summary: Git tools for working with bzr repositories
288Summary(pl.UTF-8): Narzędzia Gita do pracy z repozytoriami bzr
289Group: Development/Tools
290Requires: %{name} = %{version}-%{release}
291Requires: bzr
292
293%description bzr
294Git tools for working with bzr repositories.
295
296%description bzr -l pl.UTF-8
297Narzędzia Gita do pracy z repozytoriami bzr.
298
299%package cvs
300Summary: CVS support for Git
301Summary(pl.UTF-8): Obsługa CVS dla Gita
302Group: Development/Tools
303Requires: %{name} = %{version}-%{release}
304Requires: cvsps >= 2.1-2
305Requires: rcs
306
307%description cvs
308CVS support for Git.
309
310%description cvs -l pl.UTF-8
311Obsługa CVS dla Gita.
312
313%package hg
314Summary: Git tools for working with mercurial repositories
315Summary(pl.UTF-8): Narzędzia Gita do pracy z repozytoriami mercuriala
316Group: Development/Tools
317Requires: %{name} = %{version}-%{release}
318Requires: mercurial >= 1.8
319
320%description hg
321Git tools for working with mercurial repositories.
322
323%description hg -l pl.UTF-8
324Narzędzia Gita do pracy z repozytoriami mercuriala.
325
326%package p4
327Summary: Git tools for working with Perforce depots
328Summary(pl.UTF-8): Narzędzia Gita do pracy z magazynami Perforce'a
329Group: Development/Tools
330Requires: %{name} = %{version}-%{release}
331
332%description p4
333Git tools for working with Perforce depots.
334
335%description p4 -l pl.UTF-8
336Narzędzia Gita do pracy z magazynami Perforce'a.
337
338%package svn
339Summary: Subversion support for Git
340Summary(pl.UTF-8): Obsługa Subversion dla Gita
341Group: Development/Tools
342Requires: %{name} = %{version}-%{release}
343Requires: perl-Encode
344Requires: perl-Term-ReadKey
345
346%description svn
347Subversion support for Git.
348
349%description svn -l pl.UTF-8
350Obsługa Subversion dla Gita.
351
352%package email
353Summary: Git tools for sending email
354Summary(pl.UTF-8): Narzędzia Gita do wysyłania poczty
355Group: Development/Tools
356Requires: %{name} = %{version}-%{release}
357
358%description email
359Git tools for sending email.
360
361%description email -l pl.UTF-8
362Narzędzia Gita do wysyłania poczty.
363
364%package -n bash-completion-git
365Summary: bash-completion for git
366Summary(pl.UTF-8): bashowe uzupełnianie nazw dla gita
367Group: Applications/Shells
368Requires: %{name} = %{version}-%{release}
369Requires: bash-completion >= 2.0
370%if "%{_rpmversion}" >= "5"
371BuildArch: noarch
372%endif
373
374%description -n bash-completion-git
375This package provides bash-completion for git.
376
377%description -n bash-completion-git -l pl.UTF-8
378Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
379
380%package -n perl-Git
381Summary: Perl interface to the Git version control system
382Summary(pl.UTF-8): Perlowy interfejs do systemu kontroli wersji Git
383Group: Development/Languages/Perl
384Obsoletes: perl-git-core
385
386%description -n perl-Git
387This module provides Perl scripts easy way to interface the Git
388version control system. The modules have an easy and well-tested way
389to call arbitrary Git commands; in the future, the interface will also
390provide specialized methods for doing easily operations which are not
391totally trivial to do over the generic command interface.
392
393%description -n perl-Git -l pl.UTF-8
394Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
395wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
396dowolne polecenia Gita; w przyszłości interfejs udostępni także
397specjalne metody do łatwego wykonywania operacji nietrywialnych do
398wykonania przy użyciu ogólnego interfejsu poleceń.
399
400%prep
401%setup -q -n git-%{version}
402%patch0 -p1
403%patch1 -p0
404%patch2 -p1
405%patch3 -p1
406%patch4 -p1
407
408%build
409%{__aclocal}
410%{__autoconf}
411%configure \
412 --sysconfdir=%{_sysconfdir}/git-core \
413 %{?with_pcre:--with-libpcre} \
414 --with-openssl
415
416echo "BLK_SHA1=1" >> config.mak
417
418%{__make} \
419 INSTALLDIRS=vendor \
420 GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
421 GITWEB_PROJECTROOT="/var/lib/git" \
422 GITWEB_CSS="/gitweb/gitweb.css" \
423 GITWEB_LOGO="/gitweb/git-logo.png" \
424 GITWEB_FAVICON="/gitweb/git-favicon.png" \
425 V=1
426
427%{__make} -C contrib/subtree
428
429%if %{with doc}
430%{__make} -C Documentation \
431 MAN_BASE_URL=file://%{_docdir}/%{name}-doc-%{version}/ \
432 V=1
433%endif
434
435%if %{with tests}
436%if %{without tests_cvs}
437%{__rm} t/t*cvs*.sh || :
438%endif
439%{!?with_tests_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
440%endif
441
442%install
443rm -rf $RPM_BUILD_ROOT
444install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
445install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
446install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
447install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
448cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
449[init]
450 templatedir = %{_sysconfdir}/%{name}/templates
451EOF
452
453%{__make} install \
454 INSTALLDIRS=vendor \
455 DESTDIR=$RPM_BUILD_ROOT
456
457%if %{with doc}
458%{__make} -C Documentation install \
459 DESTDIR=$RPM_BUILD_ROOT
460%endif
461
462# copy templates except sample hooks
463cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
464%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
465
466# header files and lib
467cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
468cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
469cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
470install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
471cp -p block-sha1/sha1.h $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
472cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
473cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
474cp -p {Makefile,config.mak,config.mak.autogen,config.mak.uname} $RPM_BUILD_ROOT%{_includedir}/%{name}
475
476%{__make} -C contrib/subtree install \
477 libexecdir=%{_libdir}/%{name} \
478 DESTDIR=$RPM_BUILD_ROOT
479
480%if %{with doc}
481%{__make} -C contrib/subtree install-doc \
482 DESTDIR=$RPM_BUILD_ROOT
483%endif
484
485# bash completion
486install -d $RPM_BUILD_ROOT%{bash_compdir}
487cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{bash_compdir}/git
488
489# Install git-prompt.sh
490install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/contrib/completion
491cp -p contrib/completion/git-prompt.sh $RPM_BUILD_ROOT%{_datadir}/%{name}/contrib/completion
492
493# Install bzr and hg remote helpers from contrib
494install -p contrib/remote-helpers/git-remote-{bzr,hg} $RPM_BUILD_ROOT%{_libdir}/%{name}
495
496# gitweb
497mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
498ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
499cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
500cp -p %{SOURCE7} $RPM_BUILD_ROOT%{webappdir}/gitolite.pl
501cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
502cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
503cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
504
505# gitview
506install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
507
508# git-daemon related files
509cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
510cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
511install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
512
513# paths cleanup
514sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
515sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
516
517# hardlink
518ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
519ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
520ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
521ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
522
523# remove unneeded files
524%{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
525%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
526%py_postclean
527
528mv $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
529%find_lang git
530
531%clean
532rm -rf $RPM_BUILD_ROOT
533
534%post daemon-inetd
535%service -q rc-inetd reload
536
537%postun daemon-inetd
538if [ "$1" = "0" ]; then
539 %service -q rc-inetd reload
540fi
541
542%post daemon-standalone
543/sbin/chkconfig --add git-daemon
544%service git-daemon restart "git-daemon"
545
546%preun daemon-standalone
547if [ "$1" = "0" ]; then
548 %service git-daemon stop
549 /sbin/chkconfig --del git-daemon
550fi
551
552%triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
553%webapp_register apache %{webapp}
554
555%triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
556%webapp_unregister apache %{webapp}
557
558%triggerin gitweb -- apache < 2.2.0, apache-base
559%webapp_register httpd %{webapp}
560
561%triggerun gitweb -- apache < 2.2.0, apache-base
562%webapp_unregister httpd %{webapp}
563
564%triggerin gitweb -- lighttpd
565%webapp_register lighttpd %{webapp}
566
567%triggerun gitweb -- lighttpd
568%webapp_unregister lighttpd %{webapp}
569
570%files -f git.lang
571%defattr(644,root,root,755)
572%doc README contrib
573%attr(755,root,root) %{_bindir}/git
574%attr(755,root,root) %{_bindir}/git-receive-pack
575%attr(755,root,root) %{_bindir}/git-shell
576%attr(755,root,root) %{_bindir}/git-upload-archive
577%attr(755,root,root) %{_bindir}/git-upload-pack
578%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
579
580%if %{with doc}
581%{_mandir}/man1/git-*.1*
582%exclude %{_mandir}/man1/git-archimport.1*
583%exclude %{_mandir}/man1/git-svn.1*
584%exclude %{_mandir}/man1/git-cvs*.1*
585%exclude %{_mandir}/man1/git-imap-send*.1*
586%exclude %{_mandir}/man1/*email*.1*
587%{_mandir}/man1/git.1*
588%{_mandir}/man1/gitremote-helpers.1*
589%{_mandir}/man5/gitattributes.5*
590%{_mandir}/man5/githooks.5*
591%{_mandir}/man5/gitignore.5*
592%{_mandir}/man5/gitmodules.5*
593%{_mandir}/man5/gitrepository-layout.5*
594%{_mandir}/man7/gitcli.7*
595%{_mandir}/man7/gitcore-tutorial.7*
596%{_mandir}/man7/gitcredentials.7*
597%{_mandir}/man7/gitdiffcore.7*
598%{_mandir}/man7/gitglossary.7*
599%{_mandir}/man7/gitnamespaces.7*
600%{_mandir}/man7/gitrevisions.7*
601%{_mandir}/man7/gittutorial-2.7*
602%{_mandir}/man7/gittutorial.7*
603%{_mandir}/man7/gitworkflows.7*
604%endif
605
606%dir %{_libdir}/%{name}
607%attr(755,root,root) %{_libdir}/%{name}/*-*
608%attr(755,root,root) %{_libdir}/%{name}/git
609%dir %{_libdir}/%{name}/mergetools
610%{_libdir}/%{name}/mergetools/*
611
612%{_datadir}/%{name}
613%{_localstatedir}/lib/git
614
615# subpackages
616%exclude %{_libdir}/%{name}/*email*
617%exclude %{_libdir}/%{name}/*p4*
618%exclude %{_libdir}/%{name}/git-archimport
619%exclude %{_libdir}/%{name}/git-cvs*
620%exclude %{_libdir}/%{name}/git-gui
621%exclude %{_libdir}/%{name}/git-imap-send
622%exclude %{_libdir}/%{name}/git-instaweb
623%exclude %{_libdir}/%{name}/git-remote-bzr
624%exclude %{_libdir}/%{name}/git-remote-hg
625%exclude %{_libdir}/%{name}/git-remote-testsvn
626%exclude %{_libdir}/%{name}/git-svn
627%exclude %{_libdir}/%{name}/mergetools/p4merge
628
629%if %{with doc}
630%files doc
631%defattr(644,root,root,755)
632%doc Documentation/RelNotes*
633%doc Documentation/*.html Documentation/howto Documentation/technical
634%endif
635
636%files daemon-inetd
637%defattr(644,root,root,755)
638%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
639
640%files daemon-standalone
641%defattr(644,root,root,755)
642%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
643%attr(754,root, root) /etc/rc.d/init.d/git-daemon
644
645%files devel
646%defattr(644,root,root,755)
647%{_includedir}/%{name}
648%{_libdir}/libgit.a
649%{_libdir}/libgit_xdiff.a
650
651%files gitk
652%defattr(644,root,root,755)
653%if %{with doc}
654%{_mandir}/man1/gitk.1*
655%endif
656%attr(755,root,root) %{_bindir}/gitk
657%dir %{_datadir}/gitk
658%dir %{_datadir}/gitk/lib
659%dir %{_datadir}/gitk/lib/msgs
660%lang(bg) %{_datadir}/gitk/lib/msgs/bg.msg
661%lang(de) %{_datadir}/gitk/lib/msgs/de.msg
662%lang(es) %{_datadir}/gitk/lib/msgs/es.msg
663%lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
664%lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
665%lang(it) %{_datadir}/gitk/lib/msgs/it.msg
666%lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
667%lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
668%lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
669%lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
670
671%files gitweb
672%defattr(644,root,root,755)
673%doc gitweb/{README,INSTALL}
674%dir %{webappdir}
675%config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
676%config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
677%config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
678%config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
679%config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitolite.pl
680%attr(755,root,root) %{cgibindir}/gitweb.cgi
681%{appdir}
682%attr(755,root,root) %{_libdir}/%{name}/git-instaweb
683%if %{with doc}
684%{_mandir}/man1/gitweb.1*
685%{_mandir}/man5/gitweb.conf.5*
686%endif
687
688%files gitview
689%defattr(644,root,root,755)
690%doc contrib/gitview/gitview.txt
691%attr(755,root,root) %{_bindir}/gitview
692
693%files gui
694%defattr(644,root,root,755)
695%attr(755,root,root) %{_libdir}/%{name}/git-gui
696%dir %{_datadir}/git-gui
697%dir %{_datadir}/git-gui/lib
698%dir %{_datadir}/git-gui/lib/msgs
699%{_datadir}/git-gui/lib/git-gui.ico
700%{_datadir}/git-gui/lib/tclIndex
701%{_datadir}/git-gui/lib/*.js
702%{_datadir}/git-gui/lib/*.tcl
703%lang(bg) %{_datadir}/git-gui/lib/msgs/bg.msg
704%lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
705%lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
706%lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
707%lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
708%lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
709%lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
710%lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
711%lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
712%lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
713%lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
714%lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
715
716%files arch
717%defattr(644,root,root,755)
718%attr(755,root,root) %{_libdir}/%{name}/git-archimport
719%if %{with doc}
720%{_mandir}/man1/git-archimport.1*
721%endif
722
723%files bzr
724%defattr(644,root,root,755)
725%attr(755,root,root) %{_libdir}/%{name}/git-remote-bzr
726
727%files cvs
728%defattr(644,root,root,755)
729%attr(755,root,root) %{_bindir}/git-cvsserver
730%attr(755,root,root) %{_libdir}/%{name}/git-cvs*
731%if %{with doc}
732%{_mandir}/man1/git-cvs*.1*
733%{_mandir}/man7/gitcvs-migration.7*
734%endif
735
736%files hg
737%defattr(644,root,root,755)
738%attr(755,root,root) %{_libdir}/%{name}/git-remote-hg
739
740%files p4
741%defattr(644,root,root,755)
742%attr(755,root,root) %{_libdir}/%{name}/git-p4
743%attr(755,root,root) %{_libdir}/%{name}/mergetools/p4merge
744
745%files svn
746%defattr(644,root,root,755)
747%attr(755,root,root) %{_libdir}/%{name}/git-svn
748%attr(755,root,root) %{_libdir}/%{name}/git-remote-testsvn
749%{perl_vendorlib}/Git/SVN
750%{perl_vendorlib}/Git/SVN.pm
751%if %{with doc}
752%{_mandir}/man1/git-svn.1*
753%endif
754
755%files email
756%defattr(644,root,root,755)
757%attr(755,root,root) %{_libdir}/%{name}/git-imap-send
758%attr(755,root,root) %{_libdir}/%{name}/*email*
759%if %{with doc}
760%{_mandir}/man1/*email*.1*
761%{_mandir}/man1/*imap-send*.1*
762%endif
763
764%files -n bash-completion-git
765%defattr(644,root,root,755)
766%{bash_compdir}/git
767
768%files -n perl-Git
769%defattr(644,root,root,755)
770%{perl_vendorlib}/Git.pm
771%dir %{perl_vendorlib}/Git
772%{perl_vendorlib}/Git/I18N.pm
773%{perl_vendorlib}/Git/IndexInfo.pm
774%{_mandir}/man3/Git*.3pm*
This page took 0.067577 seconds and 4 git commands to generate.