]> git.pld-linux.org Git - packages/git-core.git/blame_incremental - git-core.spec
up to 2.30.1
[packages/git-core.git] / git-core.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without tests # test suite
4%bcond_with tests_cvs # tests which use CVS
5%bcond_without tests_svn # tests which use subversion
6%bcond_without doc # building/packaging docs/manuals (takes some time)
7%bcond_without pcre # perl-compatible regexes support
8%bcond_without gnome_keyring # gnome keyring credentials support
9%bcond_without libsecret # libsecret credentials support
10%bcond_without tk # Tcl/Tk interface
11
12# for AC: --without doc --without gnome_keyring --without tests
13
14Summary: Distributed version control system focused on speed, effectivity and usability
15Summary(pl.UTF-8): Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
16Name: git-core
17Version: 2.30.1
18Release: 1
19License: GPL v2
20Group: Development/Tools
21Source0: http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.xz
22# Source0-md5: 6f63eb0cc94f52e865fbd90ffb0ecb5c
23Source1: %{name}-gitweb.conf
24Source2: %{name}-gitweb-httpd.conf
25Source3: %{name}-gitweb-lighttpd.conf
26Source4: %{name}.sysconfig
27Source5: %{name}.inet
28Source6: %{name}.init
29Source7: gitolite.pl
30Patch0: %{name}-key-bindings.patch
31Patch1: %{name}-sysconfdir.patch
32Patch2: cherry-picked-commitlog.patch
33URL: http://git-scm.com/
34BuildRequires: autoconf >= 2.59
35BuildRequires: automake
36BuildRequires: curl-devel
37BuildRequires: expat-devel
38%if "%{pld_release}" == "ac"
39BuildRequires: gettext-devel
40%else
41BuildRequires: gettext-tools
42%endif
43%if %{with gnome_keyring} || %{with libsecret}
44BuildRequires: glib2-devel >= 2.0
45%endif
46%if %{with gnome_keyring}
47BuildRequires: libgnome-keyring-devel
48%endif
49%if %{with libsecret}
50BuildRequires: libsecret-devel
51%endif
52BuildRequires: openssl-devel
53%{?with_pcre:BuildRequires: pcre2-8-devel}
54BuildRequires: perl-Error > 0.15
55BuildRequires: perl-MailTools
56BuildRequires: perl-base
57%if %{with gnome_keyring} || %{with libsecret}
58BuildRequires: pkgconfig
59%endif
60BuildRequires: python-devel
61BuildRequires: rpm-perlprov >= 4.1-13
62BuildRequires: rpm-pythonprov
63BuildRequires: rpmbuild(macros) >= 1.752
64BuildRequires: tar >= 1:1.22
65%if %{with tk}
66# wish
67BuildRequires: tk
68BuildRequires: xz
69%endif
70BuildRequires: zlib-devel
71%if %{with doc}
72BuildRequires: asciidoc >= 7.1.2-3
73BuildRequires: docbook-dtd45-xml
74BuildRequires: xmlto
75%endif
76%if %{with tests}
77BuildRequires: perl-CGI
78BuildRequires: perl-Digest-MD5
79BuildRequires: perl-Encode
80BuildRequires: perl-Time-HiRes
81%if %{with tests_cvs}
82# tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
83BuildRequires: cvs-gnu-client < 1.13
84BuildRequires: cvs-gnu-client >= 1.12
85%endif
86%if %{with tests_svn}
87BuildRequires: perl-subversion
88BuildRequires: subversion
89%endif
90Conflicts: pdksh < 5.2.14-46
91%endif
92# git-sh-setup: sane_grep
93Requires: grep
94# git-pull: printf
95Requires: coreutils
96Requires: sed
97Suggests: git-core-bzr
98Suggests: git-core-cvs
99Suggests: git-core-hg
100Suggests: git-core-p4
101Suggests: git-core-svn
102Suggests: less
103Suggests: openssh-clients
104Suggests: perl-Git = %{version}-%{release}
105Suggests: rsync
106Obsoletes: git-core-gitview
107Obsoletes: python-Git
108Conflicts: perl-Git < %{version}
109BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
110
111# html docs have links to txt files
112%define _noautocompressdoc *.txt
113
114# do not generate perl dependency, git add -p support is optional
115# skip dependency generation from templates
116%define _noautoreqfiles %{_libexecdir}/%{name}/git-add--interactive %{_datadir}/%{name}/templates
117
118%define webapp gitweb
119%define webappdir %{_sysconfdir}/webapps/%{webapp}
120%define appdir %{_datadir}/%{webapp}
121%define cgibindir %{_prefix}/lib/cgi-bin
122%define gitcoredir %{_libexecdir}/%{name}
123
124%description
125"git" can mean anything, depending on your mood.
126
127- random three-letter combination that is pronounceable, and not
128 actually used by any common UNIX command. The fact that it is a
129 mispronunciation of "get" may or may not be relevant.
130- stupid. contemptible and despicable. simple. Take your pick from the
131 dictionary of slang.
132- "global information tracker": you're in a good mood, and it actually
133 works for you. Angels sing, and a light suddenly fills the room.
134- "goddamn idiotic truckload of sh*t": when it breaks
135
136This is a stupid (but extremely fast) directory content manager. It
137doesn't do a whole lot, but what it 'does' do is track directory
138contents efficiently.
139
140%description -l pl.UTF-8
141"git" może oznaczać cokolwiek, w zależności od nastroju.
142
143- losową kombinację trzech liter, która jest wymawialna i właściwie
144 nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
145 błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
146- głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
147- "global information tracker" (narzędzie do globalnego śledzenia
148 informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
149 Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
150- "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
151 g*) - kiedy się zepsuje.
152
153Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
154Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
155katalogu.
156
157%package doc
158Summary: Documentation for git-core
159Summary(pl.UTF-8): Dokumentacja do git-core
160Group: Documentation
161%{?noarchpackage}
162
163%description doc
164Documentation for git-core.
165
166%description doc -l pl.UTF-8
167Dokumentacja do git-core.
168
169%package daemon-inetd
170Summary: Files necessary to run git-daemon as an inetd service
171Summary(pl.UTF-8): Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
172Group: Networking/Daemons
173Requires: %{name} = %{version}-%{release}
174Requires: setup >= 2.4.11-1
175Provides: git-core-daemon
176Obsoletes: git-core-daemon
177Obsoletes: git-core-daemon-standalone
178
179%description daemon-inetd
180Git-daemon is a really simple TCP git daemon that can serve git
181repositories. This package provides all necessarry files to run
182git-daemon as an inetd service.
183
184%description daemon-inetd -l pl.UTF-8
185Git-daemon to prosty demon git korzystający z protokołu TCP do
186udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
187do uruchomienia git-demona w trybie usługi inetd.
188
189%package daemon-standalone
190Summary: Files necessary to run git-daemon as a standalone service
191Summary(pl.UTF-8): Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
192Group: Networking/Daemons
193Requires: %{name} = %{version}-%{release}
194Provides: git-core-daemon
195Obsoletes: git-core-daemon
196Obsoletes: git-core-daemon-inetd
197
198%description daemon-standalone
199Git-daemon is a really simple TCP git daemon that can serve git
200repositories. This package provides all necessarry files to run
201git-daemon as an standalone service.
202
203%description daemon-standalone -l pl.UTF-8
204Git-daemon to prosty demon git korzystający z protokołu TCP do
205udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
206do uruchomienia git-daemona w trybie usługi samodzielnej.
207
208%package devel
209Summary: Git library with header files
210Summary(pl.UTF-8): Biblioteka Gita oraz pliki nagłówkowe
211Group: Development/Libraries
212Requires: zlib-devel
213
214%description devel
215Git library with header files.
216
217%description devel -l pl.UTF-8
218Biblioteka Gita oraz pliki nagłówkowe.
219
220%package gitk
221Summary: Tcl/Tk interface to the Git version control system
222Summary(pl.UTF-8): Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
223Group: Development/Tools
224Requires: %{name} = %{version}-%{release}
225Requires: tk
226%{?noarchpackage}
227
228%description gitk
229gitk displays changes in a repository or a selected set of commits.
230This includes visualizing the commit graph, showing information
231related to each commit, and the files in the trees of each revision.
232
233Historically, gitk was the first repository browser. It's written in
234Tcl/Tk and started off in a separate repository but was later merged
235into the main git repository.
236
237%description gitk -l pl.UTF-8
238gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
239Oznacza to wizualizację grafu commitów, wyświetlanie informacji
240związanych z każdym z commitów oraz listę plików dla każdej rewizji.
241
242Z historycznego punktu widzenia gitk był pierwszą przeglądarką
243repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
244osobnym repozytorium, ale z czasem został włączony do głównego
245repozytorium gita.
246
247%package gitweb
248Summary: Web frontend to git
249Summary(pl.UTF-8): Frontend WWW do gita
250Group: Development/Tools
251Requires: %{name} = %{version}-%{release}
252Requires: webapps
253Requires: webserver(access)
254Requires: webserver(alias)
255Requires: webserver(cgi)
256Suggests: webserver(setenv)
257
258%description gitweb
259This package provides a web interface for browsing git repositories.
260
261%description gitweb -l pl.UTF-8
262Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
263
264%package gui
265Summary: Tcl/Tk interface to the Git version control system
266Summary(pl.UTF-8): Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
267Group: Development/Tools
268Requires: %{name} = %{version}-%{release}
269Requires: tk
270Requires: xdg-utils
271Suggests: meld
272
273%description gui
274Displays changes in a repository or a selected set of commits. This
275includes visualizing the commit graph, showing information related to
276each commit, and the files in the trees of each revision.
277
278Historically, gitk was the first repository browser. It's written in
279Tcl/Tk and started off in a separate repository but was later merged
280into the main git repository.
281
282%description gui -l pl.UTF-8
283Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
284to wizualizację grafu commitów, wyświetlanie informacji związanych z
285każdym z commitów oraz listę plików dla każdej rewizji.
286
287Z punktu widzenia historii, gitk był pierwszą przeglądarką
288repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
289osobnym repozytorium, ale z czasem został włączony do głównego
290repozytorium gita.
291
292%package arch
293Summary: Git tools for importing Arch repositories
294Summary(pl.UTF-8): Narzędzia Gita do importowania repozytoriów Archa
295Group: Development/Tools
296Requires: %{name} = %{version}-%{release}
297Requires: tla
298
299%description arch
300Git tools for importing Arch repositories.
301
302%description arch -l pl.UTF-8
303Narzędzia Gita do importowania repozytoriów Archa.
304
305%package bzr
306Summary: Git tools for working with bzr repositories
307Summary(pl.UTF-8): Narzędzia Gita do pracy z repozytoriami bzr
308Group: Development/Tools
309Requires: %{name} = %{version}-%{release}
310Requires: bzr
311
312%description bzr
313Git tools for working with bzr repositories.
314
315%description bzr -l pl.UTF-8
316Narzędzia Gita do pracy z repozytoriami bzr.
317
318%package cvs
319Summary: CVS support for Git
320Summary(pl.UTF-8): Obsługa CVS dla Gita
321Group: Development/Tools
322Requires: %{name} = %{version}-%{release}
323Requires: cvsps >= 2.1-2
324Requires: rcs
325
326%description cvs
327CVS support for Git.
328
329%description cvs -l pl.UTF-8
330Obsługa CVS dla Gita.
331
332%package hg
333Summary: Git tools for working with mercurial repositories
334Summary(pl.UTF-8): Narzędzia Gita do pracy z repozytoriami mercuriala
335Group: Development/Tools
336Requires: %{name} = %{version}-%{release}
337Requires: mercurial >= 1.8
338
339%description hg
340Git tools for working with mercurial repositories.
341
342%description hg -l pl.UTF-8
343Narzędzia Gita do pracy z repozytoriami mercuriala.
344
345%package p4
346Summary: Git tools for working with Perforce depots
347Summary(pl.UTF-8): Narzędzia Gita do pracy z magazynami Perforce'a
348Group: Development/Tools
349Requires: %{name} = %{version}-%{release}
350
351%description p4
352Git tools for working with Perforce depots.
353
354%description p4 -l pl.UTF-8
355Narzędzia Gita do pracy z magazynami Perforce'a.
356
357%package svn
358Summary: Subversion support for Git
359Summary(pl.UTF-8): Obsługa Subversion dla Gita
360Group: Development/Tools
361Requires: %{name} = %{version}-%{release}
362Requires: perl-Encode
363Requires: perl-Term-ReadKey
364
365%description svn
366Subversion support for Git.
367
368%description svn -l pl.UTF-8
369Obsługa Subversion dla Gita.
370
371%package email
372Summary: Git tools for sending email
373Summary(pl.UTF-8): Narzędzia Gita do wysyłania poczty
374Group: Development/Tools
375Requires: %{name} = %{version}-%{release}
376Requires: perl-Error
377Requires: perl-MailTools
378Suggests: perl-Net-SMTP-SSL
379
380%description email
381Git tools for sending email.
382
383%description email -l pl.UTF-8
384Narzędzia Gita do wysyłania poczty.
385
386%package -n bash-completion-git
387Summary: bash-completion for git
388Summary(pl.UTF-8): bashowe uzupełnianie nazw dla gita
389Group: Applications/Shells
390Requires: %{name} = %{version}-%{release}
391Requires: bash-completion >= 2.0
392%{?noarchpackage}
393
394%description -n bash-completion-git
395This package provides bash-completion for git.
396
397%description -n bash-completion-git -l pl.UTF-8
398Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
399
400%package -n perl-Git
401Summary: Perl interface to the Git version control system
402Summary(pl.UTF-8): Perlowy interfejs do systemu kontroli wersji Git
403Group: Development/Languages/Perl
404Obsoletes: perl-git-core
405%{?noarchpackage}
406
407%description -n perl-Git
408This module provides Perl scripts easy way to interface the Git
409version control system. The modules have an easy and well-tested way
410to call arbitrary Git commands; in the future, the interface will also
411provide specialized methods for doing easily operations which are not
412totally trivial to do over the generic command interface.
413
414%description -n perl-Git -l pl.UTF-8
415Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
416wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
417dowolne polecenia Gita; w przyszłości interfejs udostępni także
418specjalne metody do łatwego wykonywania operacji nietrywialnych do
419wykonania przy użyciu ogólnego interfejsu poleceń.
420
421%package -n gnome-keyring-git-core
422Summary: GNOME Keyring authentication provider for Git
423Summary(pl.UTF-8): Moduł uwierzytelniający GNOME Keyring dla Gita
424Group: X11/Applications
425URL: http://git-scm.com/docs/gitcredentials.html
426Requires: %{name} = %{version}-%{release}
427
428%description -n gnome-keyring-git-core
429Authentication provider module for Git which allows git client to
430authenticate using GNOME Keyring.
431
432You need to register it with:
433- git config --global credential.helper gnome-keyring
434
435%description -n gnome-keyring-git-core -l pl.UTF-8
436Moduł uwierzytelniający dla Gita pozwalający klientom git
437uwierzytelniać się przy użyciu mechanizmu GNOME Keyring.
438
439Moduł trzeba zarejestrować poleceniem:
440- git config --global credential.helper gnome-keyring
441
442%package credential-libsecret
443Summary: GNOME authentication provider for Git using libsecret
444Summary(pl.UTF-8): Moduł uwierzytelniający GNOME dla Gita wykorzystujący libsecret
445Group: X11/Applications
446URL: http://git-scm.com/docs/gitcredentials.html
447Requires: %{name} = %{version}-%{release}
448
449%description credential-libsecret
450Authentication provider module for Git which allows git client to
451authenticate using GNOME libsecret.
452
453You need to register it with:
454- git config --global credential.helper libsecret
455
456%description credential-libsecret -l pl.UTF-8
457Moduł uwierzytelniający dla Gita pozwalający klientom git
458uwierzytelniać się przy użyciu mechanizmu GNOME libsecret.
459
460Moduł trzeba zarejestrować poleceniem:
461- git config --global credential.helper libsecret
462
463%prep
464%setup -q -n git-%{version}
465%patch0 -p0
466%patch1 -p1
467%patch2 -p1
468
469%{__rm} {Documentation/technical,contrib/credential/gnome-keyring}/.gitignore
470
471# we build things in contrib but want to have it clean for doc purporses, too
472cp -a contrib contrib-doc
473
474%{__sed} -i -e '1s|#!/usr/bin/env python$|#!%{__python}|' git-p4.py
475
476%build
477%{__aclocal}
478%{__autoconf}
479%configure \
480 --sysconfdir=%{_sysconfdir}/git-core \
481 %{?with_pcre:--with-libpcre2} \
482 --with-openssl
483
484echo "BLK_SHA1=1" >> config.mak
485
486%{__make} \
487 GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
488 GITWEB_PROJECTROOT="/var/lib/git" \
489 GITWEB_CSS="/gitweb/gitweb.css" \
490 GITWEB_LOGO="/gitweb/git-logo.png" \
491 GITWEB_FAVICON="/gitweb/git-favicon.png" \
492 NO_PERL_CPAN_FALLBACKS=1 \
493 perllibdir=%{perl_vendorlib} \
494 V=1
495
496%{__make} -C contrib/subtree
497
498%if %{with gnome_keyring}
499%{__make} -C contrib/credential/gnome-keyring \
500 CC="%{__cc}" \
501 CFLAGS="%{rpmcflags} -Wall" \
502 LDFLAGS="%{rpmldflags}"
503%endif
504
505%if %{with libsecret}
506%{__make} -C contrib/credential/libsecret \
507 CC="%{__cc}" \
508 CFLAGS="%{rpmcflags} -Wall" \
509 LDFLAGS="%{rpmldflags}"
510%endif
511
512%if %{with doc}
513%{__make} doc \
514 MAN_BASE_URL=file://%{_docdir}/%{name}-doc-%{version}/ \
515 V=1
516%endif
517
518%if %{with tests}
519%if %{without tests_cvs}
520%{__rm} t/t*cvs*.sh || :
521%endif
522%if %{without tests_svn}
523GIT_SKIP_TESTS="$GIT_SKIP_TESTS t91??"
524%endif
525export GIT_SKIP_TESTS
526%{__make} test \
527 NO_PERL_CPAN_FALLBACKS=1
528%endif
529
530%install
531rm -rf $RPM_BUILD_ROOT
532install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_libdir},%{_localstatedir}/lib/git}
533install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
534install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
535install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
536cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
537[init]
538 templatedir = %{_sysconfdir}/%{name}/templates
539EOF
540
541%{__make} install \
542 DESTDIR=$RPM_BUILD_ROOT \
543 NO_PERL_CPAN_FALLBACKS=1 \
544 perllibdir=%{perl_vendorlib}
545
546%if %{with doc}
547%{__make} install-doc \
548 DESTDIR=$RPM_BUILD_ROOT
549%endif
550
551# copy templates except sample hooks
552cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
553%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
554
555# header files and lib
556cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
557cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
558cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
559install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
560cp -p block-sha1/sha1.h $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
561cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
562cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
563cp -p {Makefile,config.mak,config.mak.autogen,config.mak.uname} $RPM_BUILD_ROOT%{_includedir}/%{name}
564
565%{__make} -C contrib/subtree install \
566 libexecdir=%{gitcoredir} \
567 DESTDIR=$RPM_BUILD_ROOT
568
569%if %{with doc}
570%{__make} -C contrib/subtree install-man \
571 DESTDIR=$RPM_BUILD_ROOT
572%endif
573
574%if %{with gnome_keyring}
575install -p contrib/credential/gnome-keyring/git-credential-gnome-keyring $RPM_BUILD_ROOT%{gitcoredir}
576%endif
577
578%if %{with libsecret}
579install -p contrib/credential/libsecret/git-credential-libsecret $RPM_BUILD_ROOT%{gitcoredir}
580%endif
581
582# bash completion
583install -d $RPM_BUILD_ROOT%{bash_compdir}
584cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{bash_compdir}/git
585
586# Install git-prompt.sh
587install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/contrib/completion
588cp -p contrib/completion/git-prompt.sh $RPM_BUILD_ROOT%{_datadir}/%{name}/contrib/completion
589
590# Install bzr and hg remote helpers from contrib
591install -p contrib/remote-helpers/git-remote-{bzr,hg} $RPM_BUILD_ROOT%{gitcoredir}
592
593# gitweb
594%{__mv} $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
595ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
596cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
597cp -p %{SOURCE7} $RPM_BUILD_ROOT%{webappdir}/gitolite.pl
598cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
599cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
600cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
601
602# git-daemon related files
603cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
604cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
605install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
606
607# paths cleanup
608sed -e 's,@libdir@/git-core,%{gitcoredir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
609sed -e 's,@libdir@/git-core,%{gitcoredir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
610
611# same file, link
612ln -sf git $RPM_BUILD_ROOT%{_bindir}/git-receive-pack
613ln -sf git $RPM_BUILD_ROOT%{_bindir}/git-upload-archive
614ln -sf ../..%{gitcoredir}/git-shell $RPM_BUILD_ROOT%{_bindir}/git-shell
615ln -sf ../..%{gitcoredir}/git-upload-pack $RPM_BUILD_ROOT%{_bindir}/git-upload-pack
616ln -sf ../..%{gitcoredir}/git $RPM_BUILD_ROOT%{_bindir}/git
617
618# convert all hardlinks to symlinks, as rpm fails to calculate it properly
619# requiring excessive free space when it may not be available
620# https://bugs.launchpad.net/pld-linux/+bug/1176337
621find $RPM_BUILD_ROOT%{gitcoredir} -samefile $RPM_BUILD_ROOT%{gitcoredir}/git > files
622for f in $(cat files); do
623 f=${f#$RPM_BUILD_ROOT%{gitcoredir}/}
624 test $f = git && continue
625 ln -snf git $RPM_BUILD_ROOT%{gitcoredir}/$f
626done
627
628# few others
629ln -snf git-gui $RPM_BUILD_ROOT%{gitcoredir}/git-citool
630ln -snf git-remote-http $RPM_BUILD_ROOT%{gitcoredir}/git-remote-https
631ln -snf git-remote-http $RPM_BUILD_ROOT%{gitcoredir}/git-remote-ftp
632ln -snf git-remote-http $RPM_BUILD_ROOT%{gitcoredir}/git-remote-ftps
633
634# remove unneeded files
635%py_postclean
636
637%{__mv} $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
638%find_lang git
639
640%clean
641rm -rf $RPM_BUILD_ROOT
642
643%post
644if [ ! -f /etc/shells ]; then
645 echo "%{_bindir}/git-shell" >> /etc/shells
646else
647 grep -q '^%{_bindir}/git-shell$' /etc/shells || echo "%{_bindir}/git-shell" >> /etc/shells
648fi
649
650%preun
651if [ "$1" = "0" ]; then
652 umask 022
653 grep -v '^%{_bindir}/git-shell$' /etc/shells > /etc/shells.new
654 mv -f /etc/shells.new /etc/shells
655fi
656
657%post daemon-inetd
658%service -q rc-inetd reload
659
660%postun daemon-inetd
661if [ "$1" = "0" ]; then
662 %service -q rc-inetd reload
663fi
664
665%post daemon-standalone
666/sbin/chkconfig --add git-daemon
667%service git-daemon restart "git-daemon"
668
669%preun daemon-standalone
670if [ "$1" = "0" ]; then
671 %service git-daemon stop
672 /sbin/chkconfig --del git-daemon
673fi
674
675%triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
676%webapp_register apache %{webapp}
677
678%triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
679%webapp_unregister apache %{webapp}
680
681%triggerin gitweb -- apache < 2.2.0, apache-base
682%webapp_register httpd %{webapp}
683
684%triggerun gitweb -- apache < 2.2.0, apache-base
685%webapp_unregister httpd %{webapp}
686
687%triggerin gitweb -- lighttpd
688%webapp_register lighttpd %{webapp}
689
690%triggerun gitweb -- lighttpd
691%webapp_unregister lighttpd %{webapp}
692
693%files -f git.lang
694%defattr(644,root,root,755)
695%doc README.md contrib-doc
696%attr(755,root,root) %{_bindir}/git
697%attr(755,root,root) %{_bindir}/git-receive-pack
698%attr(755,root,root) %{_bindir}/git-shell
699%attr(755,root,root) %{_bindir}/git-upload-archive
700%attr(755,root,root) %{_bindir}/git-upload-pack
701%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
702
703%if %{with doc}
704%{_mandir}/man1/git-*.1*
705%exclude %{_mandir}/man1/git-archimport.1*
706%exclude %{_mandir}/man1/git-svn.1*
707%exclude %{_mandir}/man1/git-cvs*.1*
708%exclude %{_mandir}/man1/git-imap-send.1*
709%exclude %{_mandir}/man1/git-p4.1*
710%exclude %{_mandir}/man1/git-send-email.1*
711%{_mandir}/man1/git.1*
712%{_mandir}/man5/gitattributes.5*
713%{_mandir}/man5/githooks.5*
714%{_mandir}/man5/gitignore.5*
715%{_mandir}/man5/gitmodules.5*
716%{_mandir}/man5/gitrepository-layout.5*
717%{_mandir}/man7/gitcli.7*
718%{_mandir}/man7/gitcore-tutorial.7*
719%{_mandir}/man7/gitcredentials.7*
720%{_mandir}/man7/gitdiffcore.7*
721%{_mandir}/man7/giteveryday.7*
722%{_mandir}/man7/gitfaq.7*
723%{_mandir}/man7/gitglossary.7*
724%{_mandir}/man7/gitnamespaces.7*
725%{_mandir}/man7/gitremote-helpers.7*
726%{_mandir}/man7/gitrevisions.7*
727%{_mandir}/man7/gitsubmodules.7*
728%{_mandir}/man7/gittutorial-2.7*
729%{_mandir}/man7/gittutorial.7*
730%{_mandir}/man7/gitworkflows.7*
731%endif
732
733%dir %{gitcoredir}
734%attr(755,root,root) %{gitcoredir}/*-*
735%attr(755,root,root) %{gitcoredir}/git
736%dir %{gitcoredir}/mergetools
737%{gitcoredir}/mergetools/*
738
739%{_datadir}/%{name}
740%{_localstatedir}/lib/git
741
742# subpackages
743%exclude %{gitcoredir}/*email*
744%exclude %{gitcoredir}/*p4*
745%exclude %{gitcoredir}/git-archimport
746%exclude %{gitcoredir}/git-citool
747%exclude %{gitcoredir}/git-cvs*
748%exclude %{gitcoredir}/git-gui
749%exclude %{gitcoredir}/git-imap-send
750%exclude %{gitcoredir}/git-instaweb
751%exclude %{gitcoredir}/git-remote-bzr
752%exclude %{gitcoredir}/git-remote-hg
753%exclude %{gitcoredir}/git-svn
754%exclude %{gitcoredir}/mergetools/p4merge
755%if %{with gnome_keyring}
756%exclude %{gitcoredir}/git-credential-gnome-keyring
757%endif
758%if %{with libsecret}
759%exclude %{gitcoredir}/git-credential-libsecret
760%endif
761
762%if %{with doc}
763%files doc
764%defattr(644,root,root,755)
765%doc Documentation/RelNotes*
766%doc Documentation/*.html Documentation/howto Documentation/technical
767%endif
768
769%files daemon-inetd
770%defattr(644,root,root,755)
771%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
772
773%files daemon-standalone
774%defattr(644,root,root,755)
775%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
776%attr(754,root, root) /etc/rc.d/init.d/git-daemon
777
778%files devel
779%defattr(644,root,root,755)
780%{_includedir}/%{name}
781%{_libdir}/libgit.a
782%{_libdir}/libgit_xdiff.a
783
784%if %{with tk}
785%files gitk
786%defattr(644,root,root,755)
787%if %{with doc}
788%{_mandir}/man1/gitk.1*
789%endif
790%attr(755,root,root) %{_bindir}/gitk
791%dir %{_datadir}/gitk
792%dir %{_datadir}/gitk/lib
793%dir %{_datadir}/gitk/lib/msgs
794%lang(bg) %{_datadir}/gitk/lib/msgs/bg.msg
795%lang(ca) %{_datadir}/gitk/lib/msgs/ca.msg
796%lang(de) %{_datadir}/gitk/lib/msgs/de.msg
797%lang(es) %{_datadir}/gitk/lib/msgs/es.msg
798%lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
799%lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
800%lang(it) %{_datadir}/gitk/lib/msgs/it.msg
801%lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
802%lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
803%lang(pt_PT) %{_datadir}/gitk/lib/msgs/pt_pt.msg
804%lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
805%lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
806%lang(vi) %{_datadir}/gitk/lib/msgs/vi.msg
807%lang(zh_CN) %{_datadir}/gitk/lib/msgs/zh_cn.msg
808%endif
809
810%files gitweb
811%defattr(644,root,root,755)
812%doc gitweb/{README,INSTALL}
813%dir %{webappdir}
814%config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
815%config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
816%config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
817%config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
818%config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitolite.pl
819%attr(755,root,root) %{cgibindir}/gitweb.cgi
820%{appdir}
821%attr(755,root,root) %{gitcoredir}/git-instaweb
822%if %{with doc}
823%{_mandir}/man1/gitweb.1*
824%{_mandir}/man5/gitweb.conf.5*
825%endif
826
827%if %{with tk}
828%files gui
829%defattr(644,root,root,755)
830%attr(755,root,root) %{gitcoredir}/git-citool
831%attr(755,root,root) %{gitcoredir}/git-gui
832%dir %{_datadir}/git-gui
833%dir %{_datadir}/git-gui/lib
834%dir %{_datadir}/git-gui/lib/msgs
835%{_datadir}/git-gui/lib/git-gui.ico
836%{_datadir}/git-gui/lib/tclIndex
837%{_datadir}/git-gui/lib/*.js
838%{_datadir}/git-gui/lib/*.tcl
839%lang(bg) %{_datadir}/git-gui/lib/msgs/bg.msg
840%lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
841%lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
842%lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
843%lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
844%lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
845%lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
846%lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
847%lang(pt) %{_datadir}/git-gui/lib/msgs/pt_pt.msg
848%lang(pt_BR) %{_datadir}/git-gui/lib/msgs/pt_br.msg
849%lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
850%lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
851%lang(vi) %{_datadir}/git-gui/lib/msgs/vi.msg
852%lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
853%endif
854
855%files arch
856%defattr(644,root,root,755)
857%attr(755,root,root) %{gitcoredir}/git-archimport
858%if %{with doc}
859%{_mandir}/man1/git-archimport.1*
860%endif
861
862%files bzr
863%defattr(644,root,root,755)
864%attr(755,root,root) %{gitcoredir}/git-remote-bzr
865
866%files cvs
867%defattr(644,root,root,755)
868%attr(755,root,root) %{_bindir}/git-cvsserver
869%attr(755,root,root) %{gitcoredir}/git-cvs*
870%if %{with doc}
871%{_mandir}/man1/git-cvs*.1*
872%{_mandir}/man7/gitcvs-migration.7*
873%endif
874
875%files hg
876%defattr(644,root,root,755)
877%attr(755,root,root) %{gitcoredir}/git-remote-hg
878
879%files p4
880%defattr(644,root,root,755)
881%attr(755,root,root) %{gitcoredir}/git-p4
882%attr(755,root,root) %{gitcoredir}/mergetools/p4merge
883%if %{with doc}
884%{_mandir}/man1/git-p4.1*
885%endif
886
887%files svn
888%defattr(644,root,root,755)
889%attr(755,root,root) %{gitcoredir}/git-svn
890%{perl_vendorlib}/Git/SVN
891%{perl_vendorlib}/Git/SVN.pm
892%if %{with doc}
893%{_mandir}/man1/git-svn.1*
894%endif
895
896%files email
897%defattr(644,root,root,755)
898%attr(755,root,root) %{gitcoredir}/git-imap-send
899%attr(755,root,root) %{gitcoredir}/git-send-email
900%if %{with doc}
901%{_mandir}/man1/git-imap-send.1*
902%{_mandir}/man1/git-send-email.1*
903%endif
904
905%files -n bash-completion-git
906%defattr(644,root,root,755)
907%{bash_compdir}/git
908
909%files -n perl-Git
910%defattr(644,root,root,755)
911%{perl_vendorlib}/Git.pm
912%dir %{perl_vendorlib}/Git
913%{perl_vendorlib}/Git/I18N.pm
914%{perl_vendorlib}/Git/IndexInfo.pm
915%{perl_vendorlib}/Git/LoadCPAN.pm
916%{perl_vendorlib}/Git/Packet.pm
917%dir %{perl_vendorlib}/Git/LoadCPAN
918%{perl_vendorlib}/Git/LoadCPAN/Error.pm
919%dir %{perl_vendorlib}/Git/LoadCPAN/Mail
920%{perl_vendorlib}/Git/LoadCPAN/Mail/Address.pm
921%{?with_doc:%{_mandir}/man3/Git.3pm*}
922
923%if %{with gnome_keyring}
924%files -n gnome-keyring-git-core
925%defattr(644,root,root,755)
926%attr(755,root,root) %{gitcoredir}/git-credential-gnome-keyring
927%endif
928
929%if %{with libsecret}
930%files credential-libsecret
931%defattr(644,root,root,755)
932%attr(755,root,root) %{gitcoredir}/git-credential-libsecret
933%endif
This page took 0.055915 seconds and 4 git commands to generate.