]> git.pld-linux.org Git - packages/git-core.git/blame_incremental - git-core.spec
- merge final 1.8.0 to master
[packages/git-core.git] / git-core.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without tests # don't perform make test
4%bcond_with tests_cvs # perform tests which use CVS
5%bcond_without tests_svn # perform tests which use subversion
6%bcond_without doc # skip building/packaging docs/manuals (takes some time)
7
8%include /usr/lib/rpm/macros.perl
9Summary: Distributed version control system focused on speed, effectivity and usability
10Summary(pl.UTF-8): Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
11Name: git-core
12Version: 1.8.0
13Release: 1
14License: GPL v2
15Group: Development/Tools
16Source0: http://git-core.googlecode.com/files/git-%{version}.tar.gz
17# Source0-md5: 12f4d20f34ae37086d86dd3b9d037bba
18Source1: %{name}-gitweb.conf
19Source2: %{name}-gitweb-httpd.conf
20Source3: %{name}-gitweb-lighttpd.conf
21Source4: %{name}.sysconfig
22Source5: %{name}.inet
23Source6: %{name}.init
24Patch0: %{name}-tests.patch
25Patch1: %{name}-key-bindings.patch
26Patch2: %{name}-sysconfdir.patch
27URL: http://git-scm.com/
28BuildRequires: autoconf >= 2.59
29BuildRequires: automake
30BuildRequires: curl-devel
31BuildRequires: expat-devel
32BuildRequires: gettext-devel
33BuildRequires: openssl-devel
34BuildRequires: perl-Error > 0.15
35BuildRequires: perl-base
36BuildRequires: python-devel
37BuildRequires: rpm-perlprov >= 4.1-13
38BuildRequires: rpm-pythonprov
39BuildRequires: rpmbuild(macros) >= 1.264
40BuildRequires: tcl
41BuildRequires: zlib-devel
42%if %{with doc}
43BuildRequires: asciidoc >= 7.1.2-3
44BuildRequires: docbook-dtd45-xml
45BuildRequires: xmlto
46%endif
47%if %{with tests}
48%if %{with tests_cvs}
49# tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
50BuildRequires: cvs-gnu-client < 1.13
51BuildRequires: cvs-gnu-client >= 1.12
52%endif
53%{?with_tests_svn:BuildRequires: subversion}
54Conflicts: pdksh < 5.2.14-46
55%endif
56Requires: coreutils
57Requires: diffutils
58Requires: findutils
59Requires: grep
60Requires: openssh-clients
61Requires: perl-Error
62Requires: perl-Git = %{version}-%{release}
63Requires: sed
64Suggests: git-core-cvs
65Suggests: git-core-svn
66Suggests: less
67Suggests: rsync
68BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
70# html docs have links to txt files
71%define _noautocompressdoc *.txt
72
73%define webapp gitweb
74%define webappdir %{_sysconfdir}/webapps/%{webapp}
75%define appdir %{_datadir}/%{webapp}
76%define cgibindir %{_prefix}/lib/cgi-bin
77
78%description
79"git" can mean anything, depending on your mood.
80
81- random three-letter combination that is pronounceable, and not
82 actually used by any common UNIX command. The fact that it is a
83 mispronunciation of "get" may or may not be relevant.
84- stupid. contemptible and despicable. simple. Take your pick from the
85 dictionary of slang.
86- "global information tracker": you're in a good mood, and it actually
87 works for you. Angels sing, and a light suddenly fills the room.
88- "goddamn idiotic truckload of sh*t": when it breaks
89
90This is a stupid (but extremely fast) directory content manager. It
91doesn't do a whole lot, but what it 'does' do is track directory
92contents efficiently.
93
94%description -l pl.UTF-8
95"git" może oznaczać cokolwiek, w zależności od nastroju.
96
97- losową kombinację trzech liter, która jest wymawialna i właściwie
98 nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
99 błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
100- głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
101- "global information tracker" (narzędzie do globalnego śledzenia
102 informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
103 Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
104- "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
105 g*) - kiedy się zepsuje.
106
107Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
108Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
109katalogu.
110
111%package doc
112Summary: Documentation for git-core
113Summary(pl.UTF-8): Dokumentacja do git-core
114Group: Documentation
115
116%description doc
117Documentation for git-core.
118
119%description doc -l pl.UTF-8
120Dokumentacja do git-core.
121
122%description doc -l fr.UTF-8
123Javadoc pour git-core.
124
125%package daemon-inetd
126Summary: Files necessary to run git-daemon as an inetd service
127Summary(pl.UTF-8): Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
128Group: Networking/Daemons
129Requires: %{name} = %{version}-%{release}
130Requires: setup >= 2.4.11-1
131Provides: git-core-daemon
132Obsoletes: git-core-daemon
133Obsoletes: git-core-daemon-standalone
134
135%description daemon-inetd
136Git-daemon is a really simple TCP git daemon that can serve git
137repositories. This package provides all necessarry files to run
138git-daemon as an inetd service.
139
140%description daemon-inetd -l pl.UTF-8
141Git-daemon to prosty demon git korzystający z protokołu TCP do
142udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
143do uruchomienia git-demona w trybie usługi inetd.
144
145%package daemon-standalone
146Summary: Files necessary to run git-daemon as a standalone service
147Summary(pl.UTF-8): Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
148Group: Networking/Daemons
149Requires: %{name} = %{version}-%{release}
150Provides: git-core-daemon
151Obsoletes: git-core-daemon
152Obsoletes: git-core-daemon-inetd
153
154%description daemon-standalone
155Git-daemon is a really simple TCP git daemon that can serve git
156repositories. This package provides all necessarry files to run
157git-daemon as an standalone service.
158
159%description daemon-standalone -l pl.UTF-8
160Git-daemon to prosty demon git korzystający z protokołu TCP do
161udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
162do uruchomienia git-daemona w trybie usługi samodzielnej.
163
164%package devel
165Summary: Header files for git-core
166Summary(pl.UTF-8): Pliki nagłówkowe dla git-core
167Group: Development/Libraries
168Requires: zlib-devel
169
170%description devel
171Header files for git-core.
172
173%description devel -l pl.UTF-8
174Pliki nagłówkowe dla git-core.
175
176%package gitk
177Summary: Tcl/Tk interface to the Git version control system
178Summary(pl.UTF-8): Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
179Group: Development/Tools
180Requires: %{name} = %{version}-%{release}
181Requires: tk
182
183%description gitk
184gitk displays changes in a repository or a selected set of commits.
185This includes visualizing the commit graph, showing information
186related to each commit, and the files in the trees of each revision.
187
188Historically, gitk was the first repository browser. It's written in
189Tcl/Tk and started off in a separate repository but was later merged
190into the main git repository.
191
192%description gitk -l pl.UTF-8
193gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
194Oznacza to wizualizację grafu commitów, wyświetlanie informacji
195związanych z każdym z commitów oraz listę plików dla każdej rewizji.
196
197Z historycznego punktu widzenia gitk był pierwszą przeglądarką
198repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
199osobnym repozytorium, ale z czasem został włączony do głównego
200repozytorium gita.
201
202%package gitweb
203Summary: Web frontend to git
204Summary(pl.UTF-8): Frontend WWW do gita
205Group: Development/Tools
206Requires: %{name} = %{version}-%{release}
207Requires: webapps
208Requires: webserver(alias)
209Requires: webserver(cgi)
210Suggests: webserver(setenv)
211
212%description gitweb
213This package provides a web interface for browsing git repositories.
214
215%description gitweb -l pl.UTF-8
216Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
217
218%package gitview
219Summary: A GTK+ based repository browser for git
220Summary(pl.UTF-8): Oparta na GTK+ przeglądarka repozytorium gita
221Group: Development/Tools
222Requires: %{name} = %{version}-%{release}
223Requires: python >= 1:2.4
224Requires: python-pycairo >= 1.0
225Requires: python-pygobject
226Requires: python-pygtk-gtk >= 2:2.8
227Suggests: python-gnome-desktop-gtksourceview
228
229%description gitview
230A GTK+ based repository browser for git.
231
232%description gitview -l pl.UTF-8
233Oparta na GTK+ przeglądarka repozytorium gita.
234
235%package gui
236Summary: Tcl/Tk interface to the Git version control system
237Summary(pl.UTF-8): Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
238Group: Development/Tools
239Requires: %{name} = %{version}-%{release}
240Requires: tk
241Requires: xdg-utils
242Suggests: meld
243
244%description gui
245Displays changes in a repository or a selected set of commits. This
246includes visualizing the commit graph, showing information related to
247each commit, and the files in the trees of each revision.
248
249Historically, gitk was the first repository browser. It's written in
250Tcl/Tk and started off in a separate repository but was later merged
251into the main git repository.
252
253%description gui -l pl.UTF-8
254Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
255to wizualizację grafu commitów, wyświetlanie informacji związanych z
256każdym z commitów oraz listę plików dla każdej rewizji.
257
258Z punktu widzenia historii, gitk był pierwszą przeglądarką
259repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
260osobnym repozytorium, ale z czasem został włączony do głównego
261repozytorium gita.
262
263%package svn
264Summary: Subversion support for Git
265Summary(pl.UTF-8): Obsługa Subversion dla Gita
266Group: Development/Tools
267Requires: %{name} = %{version}-%{release}
268Requires: perl-Encode
269Requires: perl-Term-ReadKey
270
271%description svn
272Subversion support for Git.
273
274%description svn -l pl.UTF-8
275Obsługa Subversion dla Gita.
276
277%package cvs
278Summary: CVS support for Git
279Summary(pl.UTF-8): Obsługa CVS dla Gita
280Group: Development/Tools
281Requires: %{name} = %{version}-%{release}
282Requires: cvsps >= 2.1-2
283Requires: rcs
284
285%description cvs
286CVS support for Git.
287
288%description cvs -l pl.UTF-8
289Obsługa CVS dla Gita.
290
291%package arch
292Summary: Git tools for importing Arch repositories
293Summary(pl.UTF-8): Narzędzia Gita do importowania repozytoriów Archa
294Group: Development/Tools
295Requires: %{name} = %{version}-%{release}
296Requires: tla
297
298%description arch
299Git tools for importing Arch repositories.
300
301%description arch -l pl.UTF-8
302Narzędzia Gita do importowania repozytoriów Archa.
303
304%package email
305Summary: Git tools for sending email
306Summary(pl.UTF-8): Narzędzia Gita do wysyłania poczty
307Group: Development/Tools
308Requires: %{name} = %{version}-%{release}
309
310%description email
311Git tools for sending email.
312
313%description email -l pl.UTF-8
314Narzędzia Gita do wysyłania poczty.
315
316%package -n bash-completion-git
317Summary: bash-completion for git
318Summary(pl.UTF-8): bashowe uzupełnianie nazw dla gita
319Group: Applications/Shells
320Requires: %{name} = %{version}-%{release}
321Requires: bash-completion
322
323%description -n bash-completion-git
324This package provides bash-completion for git.
325
326%description -n bash-completion-git -l pl.UTF-8
327Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
328
329%package -n perl-Git
330Summary: Perl interface to the Git version control system
331Summary(pl.UTF-8): Perlowy interfejs do systemu kontroli wersji Git
332Group: Development/Languages/Perl
333Obsoletes: perl-git-core
334
335%description -n perl-Git
336This module provides Perl scripts easy way to interface the Git
337version control system. The modules have an easy and well-tested way
338to call arbitrary Git commands; in the future, the interface will also
339provide specialized methods for doing easily operations which are not
340totally trivial to do over the generic command interface.
341
342%description -n perl-Git -l pl.UTF-8
343Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
344wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
345dowolne polecenia Gita; w przyszłości interfejs udostępni także
346specjalne metody do łatwego wykonywania operacji nietrywialnych do
347wykonania przy użyciu ogólnego interfejsu poleceń.
348
349%package -n python-Git
350Summary: Python Git remote helpers for non-git repositories
351Summary(pl.UTF-8): Pythonowe zdalne moduły pomocnicze dla repozytoriów niegitowych
352Group: Development/Languages/Python
353Requires: %{name} = %{version}-%{release}
354
355%description -n python-Git
356This package contains Python git_repote_helpers package - Git remote
357helpers for non-git repositories.
358
359%description -n python-Git -l pl.UTF-8
360Ten pakiet zawiera pakiet Pythona git_remote_helpers - zdalne moduły
361pomocnicze Gita dla repozytoriów niegitowych.
362
363%package -n vim-syntax-gitcommit
364Summary: Vim syntax: gitcommit
365Summary(pl.UTF-8): Składnia dla Vima: gitcommit
366Group: Applications/Editors/Vim
367Requires: %{name} = %{version}-%{release}
368# for _vimdatadir existence
369Requires: vim-rt >= 4:6.3.058-3
370
371%description -n vim-syntax-gitcommit
372This plugin provides syntax highlighting for git's commit messages.
373
374%description -n vim-syntax-gitcommit -l pl.UTF-8
375Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
376
377%prep
378%setup -q -n git-%{version}
379%patch0 -p1
380%patch1 -p0
381%patch2 -p1
382
383%build
384%{__aclocal}
385%{__autoconf}
386%configure \
387 --sysconfdir=%{_sysconfdir}/git-core \
388 --with-openssl
389
390echo "BLK_SHA1=1" >> config.mak
391
392%{__make} \
393 INSTALLDIRS=vendor \
394 GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
395 GITWEB_PROJECTROOT="/var/lib/git" \
396 GITWEB_CSS="/gitweb/gitweb.css" \
397 GITWEB_LOGO="/gitweb/git-logo.png" \
398 GITWEB_FAVICON="/gitweb/git-favicon.png" \
399 V=1
400
401%{?with_doc:%{__make} -C Documentation V=1}
402
403%if %{with tests}
404%if %{without tests_cvs}
405rm t/t*cvs*.sh || :
406%endif
407%{!?with_tests_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
408%endif
409
410%install
411rm -rf $RPM_BUILD_ROOT
412install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
413install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
414install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
415install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
416cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
417[init]
418 templatedir = %{_sysconfdir}/%{name}/templates
419EOF
420
421%{__make} install \
422 INSTALLDIRS=vendor \
423 DESTDIR=$RPM_BUILD_ROOT
424
425%if %{with doc}
426%{__make} -C Documentation install \
427 DESTDIR=$RPM_BUILD_ROOT
428%endif
429
430# copy templates except sample hooks
431cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
432%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
433
434# header files and lib
435cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
436cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
437cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
438cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
439cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
440
441# bash completion
442install -d $RPM_BUILD_ROOT/etc/bash_completion.d
443cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT/etc/bash_completion.d
444
445# vim syntax
446install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
447cat > $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax/gitcommit.vim << 'EOF'
448autocmd BufNewFile,BufRead *.git/COMMIT_EDITMSG setf gitcommit
449autocmd BufNewFile,BufRead *.git/config,.gitconfig setf gitconfig
450autocmd BufNewFile,BufRead git-rebase-todo setf gitrebase
451autocmd BufNewFile,BufRead .msg.[0-9]*
452 \ if getline(1) =~ '^From.*# This line is ignored.$' |
453 \ setf gitsendemail |
454 \ endif
455autocmd BufNewFile,BufRead *.git/**
456 \ if getline(1) =~ '^\x\{40\}\>\|^ref: ' |
457 \ setf git |
458 \ endif
459EOF
460
461# gitweb
462mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
463ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
464cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
465cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
466cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
467cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
468
469# gitview
470install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
471
472# git-daemon related files
473cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
474cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
475install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
476
477# paths cleanup
478sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
479sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
480
481# hardlink
482ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
483ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
484ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
485ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
486
487# remove unneeded files
488%{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
489%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
490%py_postclean
491
492mv $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
493%find_lang git
494
495%clean
496rm -rf $RPM_BUILD_ROOT
497
498%post daemon-inetd
499%service -q rc-inetd reload
500
501%postun daemon-inetd
502if [ "$1" = "0" ]; then
503 %service -q rc-inetd reload
504fi
505
506%post daemon-standalone
507/sbin/chkconfig --add git-daemon
508%service git-daemon restart "git-daemon"
509
510%preun daemon-standalone
511if [ "$1" = "0" ]; then
512 %service git-daemon stop
513 /sbin/chkconfig --del git-daemon
514fi
515
516%triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
517%webapp_register apache %{webapp}
518
519%triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
520%webapp_unregister apache %{webapp}
521
522%triggerin gitweb -- apache < 2.2.0, apache-base
523%webapp_register httpd %{webapp}
524
525%triggerun gitweb -- apache < 2.2.0, apache-base
526%webapp_unregister httpd %{webapp}
527
528%triggerin gitweb -- lighttpd
529%webapp_register lighttpd %{webapp}
530
531%triggerun gitweb -- lighttpd
532%webapp_unregister lighttpd %{webapp}
533
534%files -f git.lang
535%defattr(644,root,root,755)
536%doc README contrib
537%attr(755,root,root) %{_bindir}/git
538%attr(755,root,root) %{_bindir}/git-receive-pack
539%attr(755,root,root) %{_bindir}/git-shell
540%attr(755,root,root) %{_bindir}/git-upload-archive
541%attr(755,root,root) %{_bindir}/git-upload-pack
542%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
543
544%if %{with doc}
545%{_mandir}/man1/git-*.1*
546%exclude %{_mandir}/man1/git-archimport.1*
547%exclude %{_mandir}/man1/git-svn.1*
548%exclude %{_mandir}/man1/git-cvs*.1*
549%exclude %{_mandir}/man1/*email*.1*
550%exclude %{_mandir}/man1/git-remote-helpers.1*
551%{_mandir}/man1/git.1*
552%{_mandir}/man5/gitattributes.5*
553%{_mandir}/man5/githooks.5*
554%{_mandir}/man5/gitignore.5*
555%{_mandir}/man5/gitmodules.5*
556%{_mandir}/man5/gitrepository-layout.5*
557%{_mandir}/man7/gitcli.7*
558%{_mandir}/man7/gitcore-tutorial.7*
559%{_mandir}/man7/gitcredentials.7*
560%{_mandir}/man7/gitdiffcore.7*
561%{_mandir}/man7/gitglossary.7*
562%{_mandir}/man7/gitnamespaces.7*
563%{_mandir}/man7/gitrevisions.7*
564%{_mandir}/man7/gittutorial-2.7*
565%{_mandir}/man7/gittutorial.7*
566%{_mandir}/man7/gitworkflows.7*
567%endif
568
569%dir %{_libdir}/%{name}
570%attr(755,root,root) %{_libdir}/%{name}/*-*
571%attr(755,root,root) %{_libdir}/%{name}/git
572%{_libdir}/%{name}/mergetools
573
574%exclude %{_libdir}/%{name}/git-gui
575%exclude %{_libdir}/%{name}/git-svn
576%exclude %{_libdir}/%{name}/git-archimport
577%exclude %{_libdir}/%{name}/git-cvs*
578%exclude %{_libdir}/%{name}/git-instaweb
579%exclude %{_libdir}/%{name}/git-remote-testgit
580%exclude %{_libdir}/%{name}/*email*
581
582%{_datadir}/%{name}
583
584%{_localstatedir}/lib/git
585
586%if %{with doc}
587%files doc
588%defattr(644,root,root,755)
589%doc Documentation/RelNotes*
590%doc Documentation/*.html Documentation/howto Documentation/technical
591%endif
592
593%files daemon-inetd
594%defattr(644,root,root,755)
595%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
596
597%files daemon-standalone
598%defattr(644,root,root,755)
599%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
600%attr(754,root, root) /etc/rc.d/init.d/git-daemon
601
602%files devel
603%defattr(644,root,root,755)
604%{_includedir}/%{name}
605%{_libdir}/libgit.a
606%{_libdir}/libgit_xdiff.a
607
608%files gitk
609%defattr(644,root,root,755)
610%if %{with doc}
611%{_mandir}/man1/gitk.1*
612%endif
613%attr(755,root,root) %{_bindir}/gitk
614%dir %{_datadir}/gitk
615%dir %{_datadir}/gitk/lib
616%dir %{_datadir}/gitk/lib/msgs
617%lang(de) %{_datadir}/gitk/lib/msgs/de.msg
618%lang(es) %{_datadir}/gitk/lib/msgs/es.msg
619%lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
620%lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
621%lang(it) %{_datadir}/gitk/lib/msgs/it.msg
622%lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
623%lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
624%lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
625%lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
626
627%files gitweb
628%defattr(644,root,root,755)
629%doc gitweb/{README,INSTALL}
630%dir %{webappdir}
631%config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
632%config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
633%config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
634%config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
635%attr(755,root,root) %{cgibindir}/gitweb.cgi
636%{appdir}
637%attr(755,root,root) %{_libdir}/%{name}/git-instaweb
638%if %{with doc}
639%{_mandir}/man1/gitweb.1*
640%{_mandir}/man5/gitweb.conf.5*
641%endif
642
643%files gitview
644%defattr(644,root,root,755)
645%doc contrib/gitview/gitview.txt
646%attr(755,root,root) %{_bindir}/gitview
647
648%files gui
649%defattr(644,root,root,755)
650%attr(755,root,root) %{_libdir}/%{name}/git-gui
651%dir %{_datadir}/git-gui
652%dir %{_datadir}/git-gui/lib
653%dir %{_datadir}/git-gui/lib/msgs
654%{_datadir}/git-gui/lib/git-gui.ico
655%{_datadir}/git-gui/lib/tclIndex
656%{_datadir}/git-gui/lib/*.js
657%{_datadir}/git-gui/lib/*.tcl
658%lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
659%lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
660%lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
661%lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
662%lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
663%lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
664%lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
665%lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
666%lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
667%lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
668%lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
669
670%files svn
671%defattr(644,root,root,755)
672%attr(755,root,root) %{_libdir}/%{name}/git-svn
673%{perl_vendorlib}/Git/SVN
674%{perl_vendorlib}/Git/SVN.pm
675%if %{with doc}
676%{_mandir}/man1/git-svn.1*
677%endif
678
679%files cvs
680%defattr(644,root,root,755)
681%attr(755,root,root) %{_bindir}/git-cvsserver
682%attr(755,root,root) %{_libdir}/%{name}/git-cvs*
683%if %{with doc}
684%{_mandir}/man1/git-cvs*.1*
685%{_mandir}/man7/gitcvs-migration.7*
686%endif
687
688%files arch
689%defattr(644,root,root,755)
690%attr(755,root,root) %{_libdir}/%{name}/git-archimport
691%if %{with doc}
692%{_mandir}/man1/git-archimport.1*
693%endif
694
695%files email
696%defattr(644,root,root,755)
697%attr(755,root,root) %{_libdir}/%{name}/*email*
698%if %{with doc}
699%{_mandir}/man1/*email*.1*
700%endif
701
702%files -n bash-completion-git
703%defattr(644,root,root,755)
704/etc/bash_completion.d/git-completion.bash
705
706%files -n perl-Git
707%defattr(644,root,root,755)
708%{perl_vendorlib}/Git.pm
709%dir %{perl_vendorlib}/Git
710%{perl_vendorlib}/Git/I18N.pm
711%{perl_vendorlib}/Git/IndexInfo.pm
712%{_mandir}/man3/Git*.3pm*
713
714%files -n python-Git
715%defattr(644,root,root,755)
716%attr(755,root,root) %{_libdir}/%{name}/git-remote-testgit
717%dir %{py_sitescriptdir}/git_remote_helpers
718%{py_sitescriptdir}/git_remote_helpers/*.py[co]
719%dir %{py_sitescriptdir}/git_remote_helpers/git
720%{py_sitescriptdir}/git_remote_helpers/git/*.py[co]
721%if "%{py_ver}" > "2.4"
722%{py_sitescriptdir}/git_remote_helpers*.egg-info
723%endif
724%if %{with doc}
725%{_mandir}/man1/git-remote-helpers.1*
726%endif
727
728%files -n vim-syntax-gitcommit
729%defattr(644,root,root,755)
730%doc contrib/vim/README
731%{_datadir}/vim/vimfiles/syntax/gitcommit.vim
This page took 0.079747 seconds and 4 git commands to generate.