]> git.pld-linux.org Git - packages/git-core.git/blame_incremental - git-core.spec
- updated to 1.8.3
[packages/git-core.git] / git-core.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without tests # don't perform make test
4%bcond_with tests_cvs # perform tests which use CVS
5%bcond_without tests_svn # perform tests which use subversion
6%bcond_without doc # skip building/packaging docs/manuals (takes some time)
7%bcond_without pcre # perl-compatible regexes support
8
9%include /usr/lib/rpm/macros.perl
10Summary: Distributed version control system focused on speed, effectivity and usability
11Summary(pl.UTF-8): Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
12Name: git-core
13Version: 1.8.3
14Release: 1
15License: GPL v2
16Group: Development/Tools
17Source0: http://git-core.googlecode.com/files/git-%{version}.tar.gz
18# Source0-md5: d91b6099fb6763cf92c696977a247060
19Source1: %{name}-gitweb.conf
20Source2: %{name}-gitweb-apache.conf
21Source3: %{name}-gitweb-lighttpd.conf
22Source4: %{name}.sysconfig
23Source5: %{name}.inet
24Source6: %{name}.init
25Source7: %{name}-gitweb-httpd.conf
26Patch0: %{name}-tests.patch
27Patch1: %{name}-key-bindings.patch
28Patch2: %{name}-sysconfdir.patch
29Patch3: cherry-picked-commitlog.patch
30URL: http://git-scm.com/
31BuildRequires: autoconf >= 2.59
32BuildRequires: automake
33BuildRequires: curl-devel
34BuildRequires: expat-devel
35BuildRequires: gettext-devel
36BuildRequires: openssl-devel
37%{?with_pcre:BuildRequires: pcre-devel}
38BuildRequires: perl-Error > 0.15
39BuildRequires: perl-base
40BuildRequires: python-devel
41BuildRequires: rpm-perlprov >= 4.1-13
42BuildRequires: rpm-pythonprov
43BuildRequires: rpmbuild(macros) >= 1.264
44BuildRequires: tcl
45BuildRequires: zlib-devel
46%if %{with doc}
47BuildRequires: asciidoc >= 7.1.2-3
48BuildRequires: docbook-dtd45-xml
49BuildRequires: xmlto
50%endif
51%if %{with tests}
52%if %{with tests_cvs}
53# tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
54BuildRequires: cvs-gnu-client < 1.13
55BuildRequires: cvs-gnu-client >= 1.12
56%endif
57%{?with_tests_svn:BuildRequires: subversion}
58Conflicts: pdksh < 5.2.14-46
59%endif
60Requires: coreutils
61Requires: diffutils
62Requires: findutils
63Requires: grep
64Requires: openssh-clients
65Requires: perl-Error
66Requires: perl-Git = %{version}-%{release}
67Requires: sed
68Suggests: git-core-cvs
69Suggests: git-core-svn
70Suggests: less
71Suggests: rsync
72BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74# html docs have links to txt files
75%define _noautocompressdoc *.txt
76
77%define webapp gitweb
78%define webappdir %{_sysconfdir}/webapps/%{webapp}
79%define appdir %{_datadir}/%{webapp}
80%define cgibindir %{_prefix}/lib/cgi-bin
81
82%description
83"git" can mean anything, depending on your mood.
84
85- random three-letter combination that is pronounceable, and not
86 actually used by any common UNIX command. The fact that it is a
87 mispronunciation of "get" may or may not be relevant.
88- stupid. contemptible and despicable. simple. Take your pick from the
89 dictionary of slang.
90- "global information tracker": you're in a good mood, and it actually
91 works for you. Angels sing, and a light suddenly fills the room.
92- "goddamn idiotic truckload of sh*t": when it breaks
93
94This is a stupid (but extremely fast) directory content manager. It
95doesn't do a whole lot, but what it 'does' do is track directory
96contents efficiently.
97
98%description -l pl.UTF-8
99"git" może oznaczać cokolwiek, w zależności od nastroju.
100
101- losową kombinację trzech liter, która jest wymawialna i właściwie
102 nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
103 błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
104- głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
105- "global information tracker" (narzędzie do globalnego śledzenia
106 informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
107 Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
108- "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
109 g*) - kiedy się zepsuje.
110
111Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
112Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
113katalogu.
114
115%package doc
116Summary: Documentation for git-core
117Summary(pl.UTF-8): Dokumentacja do git-core
118Group: Documentation
119
120%description doc
121Documentation for git-core.
122
123%description doc -l pl.UTF-8
124Dokumentacja do git-core.
125
126%description doc -l fr.UTF-8
127Javadoc pour git-core.
128
129%package daemon-inetd
130Summary: Files necessary to run git-daemon as an inetd service
131Summary(pl.UTF-8): Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
132Group: Networking/Daemons
133Requires: %{name} = %{version}-%{release}
134Requires: setup >= 2.4.11-1
135Provides: git-core-daemon
136Obsoletes: git-core-daemon
137Obsoletes: git-core-daemon-standalone
138
139%description daemon-inetd
140Git-daemon is a really simple TCP git daemon that can serve git
141repositories. This package provides all necessarry files to run
142git-daemon as an inetd service.
143
144%description daemon-inetd -l pl.UTF-8
145Git-daemon to prosty demon git korzystający z protokołu TCP do
146udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
147do uruchomienia git-demona w trybie usługi inetd.
148
149%package daemon-standalone
150Summary: Files necessary to run git-daemon as a standalone service
151Summary(pl.UTF-8): Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
152Group: Networking/Daemons
153Requires: %{name} = %{version}-%{release}
154Provides: git-core-daemon
155Obsoletes: git-core-daemon
156Obsoletes: git-core-daemon-inetd
157
158%description daemon-standalone
159Git-daemon is a really simple TCP git daemon that can serve git
160repositories. This package provides all necessarry files to run
161git-daemon as an standalone service.
162
163%description daemon-standalone -l pl.UTF-8
164Git-daemon to prosty demon git korzystający z protokołu TCP do
165udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
166do uruchomienia git-daemona w trybie usługi samodzielnej.
167
168%package devel
169Summary: Git library with header files
170Summary(pl.UTF-8): Biblioteka Gita oraz pliki nagłówkowe
171Group: Development/Libraries
172Requires: zlib-devel
173
174%description devel
175Git library with header files.
176
177%description devel -l pl.UTF-8
178Biblioteka Gita oraz pliki nagłówkowe.
179
180%package gitk
181Summary: Tcl/Tk interface to the Git version control system
182Summary(pl.UTF-8): Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
183Group: Development/Tools
184Requires: %{name} = %{version}-%{release}
185Requires: tk
186
187%description gitk
188gitk displays changes in a repository or a selected set of commits.
189This includes visualizing the commit graph, showing information
190related to each commit, and the files in the trees of each revision.
191
192Historically, gitk was the first repository browser. It's written in
193Tcl/Tk and started off in a separate repository but was later merged
194into the main git repository.
195
196%description gitk -l pl.UTF-8
197gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
198Oznacza to wizualizację grafu commitów, wyświetlanie informacji
199związanych z każdym z commitów oraz listę plików dla każdej rewizji.
200
201Z historycznego punktu widzenia gitk był pierwszą przeglądarką
202repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
203osobnym repozytorium, ale z czasem został włączony do głównego
204repozytorium gita.
205
206%package gitweb
207Summary: Web frontend to git
208Summary(pl.UTF-8): Frontend WWW do gita
209Group: Development/Tools
210Requires: %{name} = %{version}-%{release}
211Requires: webapps
212Requires: webserver(alias)
213Requires: webserver(cgi)
214Suggests: webserver(setenv)
215Conflicts: apache-base < 2.4.0-1
216
217%description gitweb
218This package provides a web interface for browsing git repositories.
219
220%description gitweb -l pl.UTF-8
221Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
222
223%package gitview
224Summary: A GTK+ based repository browser for git
225Summary(pl.UTF-8): Oparta na GTK+ przeglądarka repozytorium gita
226Group: Development/Tools
227Requires: %{name} = %{version}-%{release}
228Requires: python >= 1:2.4
229Requires: python-pycairo >= 1.0
230Requires: python-pygobject
231Requires: python-pygtk-gtk >= 2:2.8
232Suggests: python-gnome-desktop-gtksourceview
233
234%description gitview
235A GTK+ based repository browser for git.
236
237%description gitview -l pl.UTF-8
238Oparta na GTK+ przeglądarka repozytorium gita.
239
240%package gui
241Summary: Tcl/Tk interface to the Git version control system
242Summary(pl.UTF-8): Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
243Group: Development/Tools
244Requires: %{name} = %{version}-%{release}
245Requires: tk
246Requires: xdg-utils
247Suggests: meld
248
249%description gui
250Displays changes in a repository or a selected set of commits. This
251includes visualizing the commit graph, showing information related to
252each commit, and the files in the trees of each revision.
253
254Historically, gitk was the first repository browser. It's written in
255Tcl/Tk and started off in a separate repository but was later merged
256into the main git repository.
257
258%description gui -l pl.UTF-8
259Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
260to wizualizację grafu commitów, wyświetlanie informacji związanych z
261każdym z commitów oraz listę plików dla każdej rewizji.
262
263Z punktu widzenia historii, gitk był pierwszą przeglądarką
264repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
265osobnym repozytorium, ale z czasem został włączony do głównego
266repozytorium gita.
267
268%package svn
269Summary: Subversion support for Git
270Summary(pl.UTF-8): Obsługa Subversion dla Gita
271Group: Development/Tools
272Requires: %{name} = %{version}-%{release}
273Requires: perl-Encode
274Requires: perl-Term-ReadKey
275
276%description svn
277Subversion support for Git.
278
279%description svn -l pl.UTF-8
280Obsługa Subversion dla Gita.
281
282%package cvs
283Summary: CVS support for Git
284Summary(pl.UTF-8): Obsługa CVS dla Gita
285Group: Development/Tools
286Requires: %{name} = %{version}-%{release}
287Requires: cvsps >= 2.1-2
288Requires: rcs
289
290%description cvs
291CVS support for Git.
292
293%description cvs -l pl.UTF-8
294Obsługa CVS dla Gita.
295
296%package arch
297Summary: Git tools for importing Arch repositories
298Summary(pl.UTF-8): Narzędzia Gita do importowania repozytoriów Archa
299Group: Development/Tools
300Requires: %{name} = %{version}-%{release}
301Requires: tla
302
303%description arch
304Git tools for importing Arch repositories.
305
306%description arch -l pl.UTF-8
307Narzędzia Gita do importowania repozytoriów Archa.
308
309%package email
310Summary: Git tools for sending email
311Summary(pl.UTF-8): Narzędzia Gita do wysyłania poczty
312Group: Development/Tools
313Requires: %{name} = %{version}-%{release}
314
315%description email
316Git tools for sending email.
317
318%description email -l pl.UTF-8
319Narzędzia Gita do wysyłania poczty.
320
321%package -n bash-completion-git
322Summary: bash-completion for git
323Summary(pl.UTF-8): bashowe uzupełnianie nazw dla gita
324Group: Applications/Shells
325Requires: %{name} = %{version}-%{release}
326Requires: bash-completion
327
328%description -n bash-completion-git
329This package provides bash-completion for git.
330
331%description -n bash-completion-git -l pl.UTF-8
332Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
333
334%package -n perl-Git
335Summary: Perl interface to the Git version control system
336Summary(pl.UTF-8): Perlowy interfejs do systemu kontroli wersji Git
337Group: Development/Languages/Perl
338Obsoletes: perl-git-core
339
340%description -n perl-Git
341This module provides Perl scripts easy way to interface the Git
342version control system. The modules have an easy and well-tested way
343to call arbitrary Git commands; in the future, the interface will also
344provide specialized methods for doing easily operations which are not
345totally trivial to do over the generic command interface.
346
347%description -n perl-Git -l pl.UTF-8
348Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
349wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
350dowolne polecenia Gita; w przyszłości interfejs udostępni także
351specjalne metody do łatwego wykonywania operacji nietrywialnych do
352wykonania przy użyciu ogólnego interfejsu poleceń.
353
354%package -n python-Git
355Summary: Python Git remote helpers for non-git repositories
356Summary(pl.UTF-8): Pythonowe zdalne moduły pomocnicze dla repozytoriów niegitowych
357Group: Development/Languages/Python
358Requires: %{name} = %{version}-%{release}
359
360%description -n python-Git
361This package contains Python git_repote_helpers package - Git remote
362helpers for non-git repositories.
363
364%description -n python-Git -l pl.UTF-8
365Ten pakiet zawiera pakiet Pythona git_remote_helpers - zdalne moduły
366pomocnicze Gita dla repozytoriów niegitowych.
367
368%package -n vim-syntax-gitcommit
369Summary: Vim syntax: gitcommit
370Summary(pl.UTF-8): Składnia dla Vima: gitcommit
371Group: Applications/Editors/Vim
372Requires: %{name} = %{version}-%{release}
373# for _vimdatadir existence
374Requires: vim-rt >= 4:6.3.058-3
375
376%description -n vim-syntax-gitcommit
377This plugin provides syntax highlighting for git's commit messages.
378
379%description -n vim-syntax-gitcommit -l pl.UTF-8
380Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
381
382%prep
383%setup -q -n git-%{version}
384%patch0 -p1
385%patch1 -p0
386%patch2 -p1
387%patch3 -p1
388
389%build
390%{__aclocal}
391%{__autoconf}
392%configure \
393 --sysconfdir=%{_sysconfdir}/git-core \
394 %{?with_pcre:--with-libpcre} \
395 --with-openssl
396
397echo "BLK_SHA1=1" >> config.mak
398
399%{__make} \
400 INSTALLDIRS=vendor \
401 GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
402 GITWEB_PROJECTROOT="/var/lib/git" \
403 GITWEB_CSS="/gitweb/gitweb.css" \
404 GITWEB_LOGO="/gitweb/git-logo.png" \
405 GITWEB_FAVICON="/gitweb/git-favicon.png" \
406 V=1
407
408%if %{with doc}
409%{__make} -C Documentation \
410 MAN_BASE_URL=file://%{_docdir}/%{name}-doc-%{version}/ \
411 V=1
412%endif
413
414%if %{with tests}
415%if %{without tests_cvs}
416%{__rm} t/t*cvs*.sh || :
417%endif
418%{!?with_tests_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
419%endif
420
421%install
422rm -rf $RPM_BUILD_ROOT
423install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
424install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
425install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
426install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
427cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
428[init]
429 templatedir = %{_sysconfdir}/%{name}/templates
430EOF
431
432%{__make} install \
433 INSTALLDIRS=vendor \
434 DESTDIR=$RPM_BUILD_ROOT
435
436%if %{with doc}
437%{__make} -C Documentation install \
438 DESTDIR=$RPM_BUILD_ROOT
439%endif
440
441# copy templates except sample hooks
442cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
443%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
444
445# header files and lib
446cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
447cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
448cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
449cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
450cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
451
452# bash completion
453install -d $RPM_BUILD_ROOT/etc/bash_completion.d
454cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT/etc/bash_completion.d
455
456# vim syntax
457install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
458cat > $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax/gitcommit.vim << 'EOF'
459autocmd BufNewFile,BufRead *.git/COMMIT_EDITMSG setf gitcommit
460autocmd BufNewFile,BufRead *.git/config,.gitconfig setf gitconfig
461autocmd BufNewFile,BufRead git-rebase-todo setf gitrebase
462autocmd BufNewFile,BufRead .msg.[0-9]*
463 \ if getline(1) =~ '^From.*# This line is ignored.$' |
464 \ setf gitsendemail |
465 \ endif
466autocmd BufNewFile,BufRead *.git/**
467 \ if getline(1) =~ '^\x\{40\}\>\|^ref: ' |
468 \ setf git |
469 \ endif
470EOF
471
472# gitweb
473mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
474ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
475cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
476cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
477cp -p %{SOURCE7} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
478cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
479
480# gitview
481install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
482
483# git-daemon related files
484cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
485cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
486install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
487
488# paths cleanup
489sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
490sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
491
492# hardlink
493ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
494ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
495ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
496ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
497
498# remove unneeded files
499%{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
500%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
501%py_postclean
502
503mv $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
504%find_lang git
505
506%clean
507rm -rf $RPM_BUILD_ROOT
508
509%post daemon-inetd
510%service -q rc-inetd reload
511
512%postun daemon-inetd
513if [ "$1" = "0" ]; then
514 %service -q rc-inetd reload
515fi
516
517%post daemon-standalone
518/sbin/chkconfig --add git-daemon
519%service git-daemon restart "git-daemon"
520
521%preun daemon-standalone
522if [ "$1" = "0" ]; then
523 %service git-daemon stop
524 /sbin/chkconfig --del git-daemon
525fi
526
527%triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
528%webapp_register apache %{webapp}
529
530%triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
531%webapp_unregister apache %{webapp}
532
533%triggerin gitweb -- apache-base
534%webapp_register httpd %{webapp}
535
536%triggerun gitweb -- apache-base
537%webapp_unregister httpd %{webapp}
538
539%triggerin gitweb -- lighttpd
540%webapp_register lighttpd %{webapp}
541
542%triggerun gitweb -- lighttpd
543%webapp_unregister lighttpd %{webapp}
544
545%files -f git.lang
546%defattr(644,root,root,755)
547%doc README contrib
548%attr(755,root,root) %{_bindir}/git
549%attr(755,root,root) %{_bindir}/git-receive-pack
550%attr(755,root,root) %{_bindir}/git-shell
551%attr(755,root,root) %{_bindir}/git-upload-archive
552%attr(755,root,root) %{_bindir}/git-upload-pack
553%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
554
555%if %{with doc}
556%{_mandir}/man1/git-*.1*
557%exclude %{_mandir}/man1/git-archimport.1*
558%exclude %{_mandir}/man1/git-svn.1*
559%exclude %{_mandir}/man1/git-cvs*.1*
560%exclude %{_mandir}/man1/*email*.1*
561%exclude %{_mandir}/man1/gitremote-helpers.1*
562%{_mandir}/man1/git.1*
563%{_mandir}/man5/gitattributes.5*
564%{_mandir}/man5/githooks.5*
565%{_mandir}/man5/gitignore.5*
566%{_mandir}/man5/gitmodules.5*
567%{_mandir}/man5/gitrepository-layout.5*
568%{_mandir}/man7/gitcli.7*
569%{_mandir}/man7/gitcore-tutorial.7*
570%{_mandir}/man7/gitcredentials.7*
571%{_mandir}/man7/gitdiffcore.7*
572%{_mandir}/man7/gitglossary.7*
573%{_mandir}/man7/gitnamespaces.7*
574%{_mandir}/man7/gitrevisions.7*
575%{_mandir}/man7/gittutorial-2.7*
576%{_mandir}/man7/gittutorial.7*
577%{_mandir}/man7/gitworkflows.7*
578%endif
579
580%dir %{_libdir}/%{name}
581%attr(755,root,root) %{_libdir}/%{name}/*-*
582%attr(755,root,root) %{_libdir}/%{name}/git
583%{_libdir}/%{name}/mergetools
584
585%exclude %{_libdir}/%{name}/git-gui
586%exclude %{_libdir}/%{name}/git-svn
587%exclude %{_libdir}/%{name}/git-archimport
588%exclude %{_libdir}/%{name}/git-cvs*
589%exclude %{_libdir}/%{name}/git-instaweb
590%exclude %{_libdir}/%{name}/git-remote-testpy
591%exclude %{_libdir}/%{name}/git-remote-testsvn
592%exclude %{_libdir}/%{name}/*email*
593
594%{_datadir}/%{name}
595
596%{_localstatedir}/lib/git
597
598%if %{with doc}
599%files doc
600%defattr(644,root,root,755)
601%doc Documentation/RelNotes*
602%doc Documentation/*.html Documentation/howto Documentation/technical
603%endif
604
605%files daemon-inetd
606%defattr(644,root,root,755)
607%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
608
609%files daemon-standalone
610%defattr(644,root,root,755)
611%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
612%attr(754,root, root) /etc/rc.d/init.d/git-daemon
613
614%files devel
615%defattr(644,root,root,755)
616%{_includedir}/%{name}
617%{_libdir}/libgit.a
618%{_libdir}/libgit_xdiff.a
619
620%files gitk
621%defattr(644,root,root,755)
622%if %{with doc}
623%{_mandir}/man1/gitk.1*
624%endif
625%attr(755,root,root) %{_bindir}/gitk
626%dir %{_datadir}/gitk
627%dir %{_datadir}/gitk/lib
628%dir %{_datadir}/gitk/lib/msgs
629%lang(de) %{_datadir}/gitk/lib/msgs/de.msg
630%lang(es) %{_datadir}/gitk/lib/msgs/es.msg
631%lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
632%lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
633%lang(it) %{_datadir}/gitk/lib/msgs/it.msg
634%lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
635%lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
636%lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
637%lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
638
639%files gitweb
640%defattr(644,root,root,755)
641%doc gitweb/{README,INSTALL}
642%dir %{webappdir}
643%config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
644%config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
645%config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
646%config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
647%attr(755,root,root) %{cgibindir}/gitweb.cgi
648%{appdir}
649%attr(755,root,root) %{_libdir}/%{name}/git-instaweb
650%if %{with doc}
651%{_mandir}/man1/gitweb.1*
652%{_mandir}/man5/gitweb.conf.5*
653%endif
654
655%files gitview
656%defattr(644,root,root,755)
657%doc contrib/gitview/gitview.txt
658%attr(755,root,root) %{_bindir}/gitview
659
660%files gui
661%defattr(644,root,root,755)
662%attr(755,root,root) %{_libdir}/%{name}/git-gui
663%dir %{_datadir}/git-gui
664%dir %{_datadir}/git-gui/lib
665%dir %{_datadir}/git-gui/lib/msgs
666%{_datadir}/git-gui/lib/git-gui.ico
667%{_datadir}/git-gui/lib/tclIndex
668%{_datadir}/git-gui/lib/*.js
669%{_datadir}/git-gui/lib/*.tcl
670%lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
671%lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
672%lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
673%lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
674%lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
675%lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
676%lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
677%lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
678%lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
679%lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
680%lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
681
682%files svn
683%defattr(644,root,root,755)
684%attr(755,root,root) %{_libdir}/%{name}/git-svn
685%attr(755,root,root) %{_libdir}/%{name}/git-remote-testsvn
686%{perl_vendorlib}/Git/SVN
687%{perl_vendorlib}/Git/SVN.pm
688%if %{with doc}
689%{_mandir}/man1/git-svn.1*
690%endif
691
692%files cvs
693%defattr(644,root,root,755)
694%attr(755,root,root) %{_bindir}/git-cvsserver
695%attr(755,root,root) %{_libdir}/%{name}/git-cvs*
696%if %{with doc}
697%{_mandir}/man1/git-cvs*.1*
698%{_mandir}/man7/gitcvs-migration.7*
699%endif
700
701%files arch
702%defattr(644,root,root,755)
703%attr(755,root,root) %{_libdir}/%{name}/git-archimport
704%if %{with doc}
705%{_mandir}/man1/git-archimport.1*
706%endif
707
708%files email
709%defattr(644,root,root,755)
710%attr(755,root,root) %{_libdir}/%{name}/*email*
711%if %{with doc}
712%{_mandir}/man1/*email*.1*
713%endif
714
715%files -n bash-completion-git
716%defattr(644,root,root,755)
717/etc/bash_completion.d/git-completion.bash
718
719%files -n perl-Git
720%defattr(644,root,root,755)
721%{perl_vendorlib}/Git.pm
722%dir %{perl_vendorlib}/Git
723%{perl_vendorlib}/Git/I18N.pm
724%{perl_vendorlib}/Git/IndexInfo.pm
725%{_mandir}/man3/Git*.3pm*
726
727%files -n python-Git
728%defattr(644,root,root,755)
729%attr(755,root,root) %{_libdir}/%{name}/git-remote-testpy
730%dir %{py_sitescriptdir}/git_remote_helpers
731%{py_sitescriptdir}/git_remote_helpers/*.py[co]
732%dir %{py_sitescriptdir}/git_remote_helpers/git
733%{py_sitescriptdir}/git_remote_helpers/git/*.py[co]
734%if "%{py_ver}" > "2.4"
735%{py_sitescriptdir}/git_remote_helpers*.egg-info
736%endif
737%if %{with doc}
738%{_mandir}/man1/gitremote-helpers.1*
739%endif
740
741%files -n vim-syntax-gitcommit
742%defattr(644,root,root,755)
743%doc contrib/vim/README
744%{_datadir}/vim/vimfiles/syntax/gitcommit.vim
This page took 0.039752 seconds and 4 git commands to generate.