]> git.pld-linux.org Git - packages/git-core.git/blame_incremental - git-core.spec
up to 2.3.3
[packages/git-core.git] / git-core.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without tests # don't perform make test
4%bcond_with tests_cvs # perform tests which use CVS
5%bcond_without tests_svn # perform tests which use subversion
6%bcond_without doc # skip building/packaging docs/manuals (takes some time)
7%bcond_without pcre # perl-compatible regexes support
8%bcond_without gnome_keyring # build without gnome keyring support
9
10# for AC: --without doc --without gnome_keyring --without tests
11
12%include /usr/lib/rpm/macros.perl
13Summary: Distributed version control system focused on speed, effectivity and usability
14Summary(pl.UTF-8): Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
15Name: git-core
16Version: 2.3.3
17Release: 1
18License: GPL v2
19Group: Development/Tools
20Source0: http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.gz
21# Source0-md5: 65e102c9a3209ec3e241cc398f865da3
22Source1: %{name}-gitweb.conf
23Source2: %{name}-gitweb-httpd.conf
24Source3: %{name}-gitweb-lighttpd.conf
25Source4: %{name}.sysconfig
26Source5: %{name}.inet
27Source6: %{name}.init
28Source7: gitolite.pl
29Patch0: %{name}-tests.patch
30Patch1: %{name}-key-bindings.patch
31Patch2: %{name}-sysconfdir.patch
32Patch3: cherry-picked-commitlog.patch
33Patch4: %{name}-svn-exit-errors.patch
34URL: http://git-scm.com/
35BuildRequires: autoconf >= 2.59
36BuildRequires: automake
37BuildRequires: curl-devel
38BuildRequires: expat-devel
39BuildRequires: gettext-tools
40%if %{with gnome_keyring}
41BuildRequires: libgnome-keyring-devel
42BuildRequires: pkgconfig
43%endif
44BuildRequires: openssl-devel
45%{?with_pcre:BuildRequires: pcre-devel}
46BuildRequires: perl-Error > 0.15
47BuildRequires: perl-base
48BuildRequires: python-devel
49BuildRequires: rpm-perlprov >= 4.1-13
50BuildRequires: rpm-pythonprov
51BuildRequires: rpmbuild(macros) >= 1.673
52BuildRequires: tcl
53BuildRequires: zlib-devel
54%if %{with doc}
55BuildRequires: asciidoc >= 7.1.2-3
56BuildRequires: docbook-dtd45-xml
57BuildRequires: xmlto
58%endif
59%if %{with tests}
60%if %{with tests_cvs}
61# tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
62BuildRequires: cvs-gnu-client < 1.13
63BuildRequires: cvs-gnu-client >= 1.12
64%endif
65%{?with_tests_svn:BuildRequires: subversion}
66Conflicts: pdksh < 5.2.14-46
67%endif
68# git-sh-setup: sane_grep
69Requires: grep
70# git-pull: printf
71Requires: coreutils
72Requires: openssh-clients
73Requires: perl-Error
74Requires: perl-Git = %{version}-%{release}
75Requires: sed
76Suggests: git-core-bzr
77Suggests: git-core-cvs
78Suggests: git-core-hg
79Suggests: git-core-p4
80Suggests: git-core-svn
81Suggests: less
82Suggests: rsync
83Obsoletes: python-Git
84BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
85
86# html docs have links to txt files
87%define _noautocompressdoc *.txt
88
89%define webapp gitweb
90%define webappdir %{_sysconfdir}/webapps/%{webapp}
91%define appdir %{_datadir}/%{webapp}
92%define cgibindir %{_prefix}/lib/cgi-bin
93%define gitcoredir %{_libdir}/%{name}
94
95%description
96"git" can mean anything, depending on your mood.
97
98- random three-letter combination that is pronounceable, and not
99 actually used by any common UNIX command. The fact that it is a
100 mispronunciation of "get" may or may not be relevant.
101- stupid. contemptible and despicable. simple. Take your pick from the
102 dictionary of slang.
103- "global information tracker": you're in a good mood, and it actually
104 works for you. Angels sing, and a light suddenly fills the room.
105- "goddamn idiotic truckload of sh*t": when it breaks
106
107This is a stupid (but extremely fast) directory content manager. It
108doesn't do a whole lot, but what it 'does' do is track directory
109contents efficiently.
110
111%description -l pl.UTF-8
112"git" może oznaczać cokolwiek, w zależności od nastroju.
113
114- losową kombinację trzech liter, która jest wymawialna i właściwie
115 nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
116 błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
117- głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
118- "global information tracker" (narzędzie do globalnego śledzenia
119 informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
120 Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
121- "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
122 g*) - kiedy się zepsuje.
123
124Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
125Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
126katalogu.
127
128%package doc
129Summary: Documentation for git-core
130Summary(pl.UTF-8): Dokumentacja do git-core
131Group: Documentation
132
133%description doc
134Documentation for git-core.
135
136%description doc -l pl.UTF-8
137Dokumentacja do git-core.
138
139%description doc -l fr.UTF-8
140Javadoc pour git-core.
141
142%package daemon-inetd
143Summary: Files necessary to run git-daemon as an inetd service
144Summary(pl.UTF-8): Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
145Group: Networking/Daemons
146Requires: %{name} = %{version}-%{release}
147Requires: setup >= 2.4.11-1
148Provides: git-core-daemon
149Obsoletes: git-core-daemon
150Obsoletes: git-core-daemon-standalone
151
152%description daemon-inetd
153Git-daemon is a really simple TCP git daemon that can serve git
154repositories. This package provides all necessarry files to run
155git-daemon as an inetd service.
156
157%description daemon-inetd -l pl.UTF-8
158Git-daemon to prosty demon git korzystający z protokołu TCP do
159udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
160do uruchomienia git-demona w trybie usługi inetd.
161
162%package daemon-standalone
163Summary: Files necessary to run git-daemon as a standalone service
164Summary(pl.UTF-8): Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
165Group: Networking/Daemons
166Requires: %{name} = %{version}-%{release}
167Provides: git-core-daemon
168Obsoletes: git-core-daemon
169Obsoletes: git-core-daemon-inetd
170
171%description daemon-standalone
172Git-daemon is a really simple TCP git daemon that can serve git
173repositories. This package provides all necessarry files to run
174git-daemon as an standalone service.
175
176%description daemon-standalone -l pl.UTF-8
177Git-daemon to prosty demon git korzystający z protokołu TCP do
178udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
179do uruchomienia git-daemona w trybie usługi samodzielnej.
180
181%package devel
182Summary: Git library with header files
183Summary(pl.UTF-8): Biblioteka Gita oraz pliki nagłówkowe
184Group: Development/Libraries
185Requires: zlib-devel
186
187%description devel
188Git library with header files.
189
190%description devel -l pl.UTF-8
191Biblioteka Gita oraz pliki nagłówkowe.
192
193%package gitk
194Summary: Tcl/Tk interface to the Git version control system
195Summary(pl.UTF-8): Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
196Group: Development/Tools
197Requires: %{name} = %{version}-%{release}
198Requires: tk
199
200%description gitk
201gitk displays changes in a repository or a selected set of commits.
202This includes visualizing the commit graph, showing information
203related to each commit, and the files in the trees of each revision.
204
205Historically, gitk was the first repository browser. It's written in
206Tcl/Tk and started off in a separate repository but was later merged
207into the main git repository.
208
209%description gitk -l pl.UTF-8
210gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
211Oznacza to wizualizację grafu commitów, wyświetlanie informacji
212związanych z każdym z commitów oraz listę plików dla każdej rewizji.
213
214Z historycznego punktu widzenia gitk był pierwszą przeglądarką
215repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
216osobnym repozytorium, ale z czasem został włączony do głównego
217repozytorium gita.
218
219%package gitweb
220Summary: Web frontend to git
221Summary(pl.UTF-8): Frontend WWW do gita
222Group: Development/Tools
223Requires: %{name} = %{version}-%{release}
224Requires: webapps
225Requires: webserver(access)
226Requires: webserver(alias)
227Requires: webserver(cgi)
228Suggests: webserver(setenv)
229
230%description gitweb
231This package provides a web interface for browsing git repositories.
232
233%description gitweb -l pl.UTF-8
234Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
235
236%package gitview
237Summary: A GTK+ based repository browser for git
238Summary(pl.UTF-8): Oparta na GTK+ przeglądarka repozytorium gita
239Group: Development/Tools
240Requires: %{name} = %{version}-%{release}
241Requires: python >= 1:2.4
242Requires: python-pycairo >= 1.0
243Requires: python-pygobject
244Requires: python-pygtk-gtk >= 2:2.8
245Suggests: python-gnome-desktop-gtksourceview
246
247%description gitview
248A GTK+ based repository browser for git.
249
250%description gitview -l pl.UTF-8
251Oparta na GTK+ przeglądarka repozytorium gita.
252
253%package gui
254Summary: Tcl/Tk interface to the Git version control system
255Summary(pl.UTF-8): Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
256Group: Development/Tools
257Requires: %{name} = %{version}-%{release}
258Requires: tk
259Requires: xdg-utils
260Suggests: meld
261
262%description gui
263Displays changes in a repository or a selected set of commits. This
264includes visualizing the commit graph, showing information related to
265each commit, and the files in the trees of each revision.
266
267Historically, gitk was the first repository browser. It's written in
268Tcl/Tk and started off in a separate repository but was later merged
269into the main git repository.
270
271%description gui -l pl.UTF-8
272Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
273to wizualizację grafu commitów, wyświetlanie informacji związanych z
274każdym z commitów oraz listę plików dla każdej rewizji.
275
276Z punktu widzenia historii, gitk był pierwszą przeglądarką
277repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
278osobnym repozytorium, ale z czasem został włączony do głównego
279repozytorium gita.
280
281%package arch
282Summary: Git tools for importing Arch repositories
283Summary(pl.UTF-8): Narzędzia Gita do importowania repozytoriów Archa
284Group: Development/Tools
285Requires: %{name} = %{version}-%{release}
286Requires: tla
287
288%description arch
289Git tools for importing Arch repositories.
290
291%description arch -l pl.UTF-8
292Narzędzia Gita do importowania repozytoriów Archa.
293
294%package bzr
295Summary: Git tools for working with bzr repositories
296Summary(pl.UTF-8): Narzędzia Gita do pracy z repozytoriami bzr
297Group: Development/Tools
298Requires: %{name} = %{version}-%{release}
299Requires: bzr
300
301%description bzr
302Git tools for working with bzr repositories.
303
304%description bzr -l pl.UTF-8
305Narzędzia Gita do pracy z repozytoriami bzr.
306
307%package cvs
308Summary: CVS support for Git
309Summary(pl.UTF-8): Obsługa CVS dla Gita
310Group: Development/Tools
311Requires: %{name} = %{version}-%{release}
312Requires: cvsps >= 2.1-2
313Requires: rcs
314
315%description cvs
316CVS support for Git.
317
318%description cvs -l pl.UTF-8
319Obsługa CVS dla Gita.
320
321%package hg
322Summary: Git tools for working with mercurial repositories
323Summary(pl.UTF-8): Narzędzia Gita do pracy z repozytoriami mercuriala
324Group: Development/Tools
325Requires: %{name} = %{version}-%{release}
326Requires: mercurial >= 1.8
327
328%description hg
329Git tools for working with mercurial repositories.
330
331%description hg -l pl.UTF-8
332Narzędzia Gita do pracy z repozytoriami mercuriala.
333
334%package p4
335Summary: Git tools for working with Perforce depots
336Summary(pl.UTF-8): Narzędzia Gita do pracy z magazynami Perforce'a
337Group: Development/Tools
338Requires: %{name} = %{version}-%{release}
339
340%description p4
341Git tools for working with Perforce depots.
342
343%description p4 -l pl.UTF-8
344Narzędzia Gita do pracy z magazynami Perforce'a.
345
346%package svn
347Summary: Subversion support for Git
348Summary(pl.UTF-8): Obsługa Subversion dla Gita
349Group: Development/Tools
350Requires: %{name} = %{version}-%{release}
351Requires: perl-Encode
352Requires: perl-Term-ReadKey
353
354%description svn
355Subversion support for Git.
356
357%description svn -l pl.UTF-8
358Obsługa Subversion dla Gita.
359
360%package email
361Summary: Git tools for sending email
362Summary(pl.UTF-8): Narzędzia Gita do wysyłania poczty
363Group: Development/Tools
364Requires: %{name} = %{version}-%{release}
365
366%description email
367Git tools for sending email.
368
369%description email -l pl.UTF-8
370Narzędzia Gita do wysyłania poczty.
371
372%package -n bash-completion-git
373Summary: bash-completion for git
374Summary(pl.UTF-8): bashowe uzupełnianie nazw dla gita
375Group: Applications/Shells
376Requires: %{name} = %{version}-%{release}
377Requires: bash-completion >= 2.0
378%if "%{_rpmversion}" >= "5"
379BuildArch: noarch
380%endif
381
382%description -n bash-completion-git
383This package provides bash-completion for git.
384
385%description -n bash-completion-git -l pl.UTF-8
386Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
387
388%package -n perl-Git
389Summary: Perl interface to the Git version control system
390Summary(pl.UTF-8): Perlowy interfejs do systemu kontroli wersji Git
391Group: Development/Languages/Perl
392Obsoletes: perl-git-core
393
394%description -n perl-Git
395This module provides Perl scripts easy way to interface the Git
396version control system. The modules have an easy and well-tested way
397to call arbitrary Git commands; in the future, the interface will also
398provide specialized methods for doing easily operations which are not
399totally trivial to do over the generic command interface.
400
401%description -n perl-Git -l pl.UTF-8
402Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
403wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
404dowolne polecenia Gita; w przyszłości interfejs udostępni także
405specjalne metody do łatwego wykonywania operacji nietrywialnych do
406wykonania przy użyciu ogólnego interfejsu poleceń.
407
408%package -n gnome-keyring-git-core
409Summary: GNOME Keyring authentication provider for Git
410Summary(pl.UTF-8): Moduł uwierzytelniający GNOME Keyring dla Git
411Group: X11/Applications
412URL: http://git-scm.com/docs/gitcredentials.html
413Requires: %{name} = %{version}-%{release}
414
415%description -n gnome-keyring-git-core
416Authentication provider module for Git which allows git client to
417authenticate using GNOME Keyring.
418
419You need to register it with:
420- git config --global credential.helper gnome-keyring
421
422%description -n gnome-keyring-git-core -l pl.UTF-8
423Moduł uwierzytelniający dla Subversion pozwalający klientom git
424uwierzytelniać się przy użyciu mechanizmu GNOME Keyring.
425
426Moduł trzeba zarejestrować poleceniem:
427- git config --global credential.helper gnome-keyring
428
429%prep
430%setup -q -n git-%{version}
431%patch0 -p1
432%patch1 -p0
433%patch2 -p1
434%patch3 -p1
435%patch4 -p1
436
437%{__rm} {Documentation/technical,contrib/emacs,contrib/credential/gnome-keyring}/.gitignore
438
439# we build things in contrib but want to have it clean for doc purporses, too
440cp -a contrib contrib-doc
441
442%build
443%{__aclocal}
444%{__autoconf}
445%configure \
446 --sysconfdir=%{_sysconfdir}/git-core \
447 %{?with_pcre:--with-libpcre} \
448 --with-openssl
449
450echo "BLK_SHA1=1" >> config.mak
451
452%{__make} \
453 INSTALLDIRS=vendor \
454 GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
455 GITWEB_PROJECTROOT="/var/lib/git" \
456 GITWEB_CSS="/gitweb/gitweb.css" \
457 GITWEB_LOGO="/gitweb/git-logo.png" \
458 GITWEB_FAVICON="/gitweb/git-favicon.png" \
459 V=1
460
461%{__make} -C contrib/subtree
462
463%if %{with gnome_keyring}
464%{__make} -C contrib/credential/gnome-keyring
465%endif
466
467%if %{with doc}
468%{__make} -C Documentation \
469 MAN_BASE_URL=file://%{_docdir}/%{name}-doc-%{version}/ \
470 V=1
471%endif
472
473%if %{with tests}
474%if %{without tests_cvs}
475%{__rm} t/t*cvs*.sh || :
476%endif
477%{!?with_tests_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
478%endif
479
480%install
481rm -rf $RPM_BUILD_ROOT
482install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
483install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
484install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
485install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
486cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
487[init]
488 templatedir = %{_sysconfdir}/%{name}/templates
489EOF
490
491%{__make} install \
492 INSTALLDIRS=vendor \
493 DESTDIR=$RPM_BUILD_ROOT
494
495%if %{with doc}
496%{__make} -C Documentation install \
497 DESTDIR=$RPM_BUILD_ROOT
498%endif
499
500# copy templates except sample hooks
501cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
502%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
503
504# header files and lib
505cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
506cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
507cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
508install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
509cp -p block-sha1/sha1.h $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
510cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
511cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
512cp -p {Makefile,config.mak,config.mak.autogen,config.mak.uname} $RPM_BUILD_ROOT%{_includedir}/%{name}
513
514%{__make} -C contrib/subtree install \
515 libexecdir=%{gitcoredir} \
516 DESTDIR=$RPM_BUILD_ROOT
517
518%if %{with doc}
519%{__make} -C contrib/subtree install-man \
520 DESTDIR=$RPM_BUILD_ROOT
521%endif
522
523%if %{with gnome_keyring}
524install -p contrib/credential/gnome-keyring/git-credential-gnome-keyring $RPM_BUILD_ROOT%{gitcoredir}
525%endif
526
527# bash completion
528install -d $RPM_BUILD_ROOT%{bash_compdir}
529cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{bash_compdir}/git
530
531# Install git-prompt.sh
532install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/contrib/completion
533cp -p contrib/completion/git-prompt.sh $RPM_BUILD_ROOT%{_datadir}/%{name}/contrib/completion
534
535# Install bzr and hg remote helpers from contrib
536install -p contrib/remote-helpers/git-remote-{bzr,hg} $RPM_BUILD_ROOT%{gitcoredir}
537
538# gitweb
539mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
540ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
541cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
542cp -p %{SOURCE7} $RPM_BUILD_ROOT%{webappdir}/gitolite.pl
543cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
544cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
545cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
546
547# gitview
548install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
549
550# git-daemon related files
551cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
552cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
553install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
554
555# paths cleanup
556sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
557sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
558
559# hardlink
560ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
561ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
562ln -f $RPM_BUILD_ROOT{%{gitcoredir},%{_bindir}}/git-shell
563ln -f $RPM_BUILD_ROOT{%{gitcoredir},%{_bindir}}/git-upload-pack
564
565# remove unneeded files
566%{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
567%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
568%py_postclean
569
570mv $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
571%find_lang git
572
573%clean
574rm -rf $RPM_BUILD_ROOT
575
576%post daemon-inetd
577%service -q rc-inetd reload
578
579%postun daemon-inetd
580if [ "$1" = "0" ]; then
581 %service -q rc-inetd reload
582fi
583
584%post daemon-standalone
585/sbin/chkconfig --add git-daemon
586%service git-daemon restart "git-daemon"
587
588%preun daemon-standalone
589if [ "$1" = "0" ]; then
590 %service git-daemon stop
591 /sbin/chkconfig --del git-daemon
592fi
593
594%triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
595%webapp_register apache %{webapp}
596
597%triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
598%webapp_unregister apache %{webapp}
599
600%triggerin gitweb -- apache < 2.2.0, apache-base
601%webapp_register httpd %{webapp}
602
603%triggerun gitweb -- apache < 2.2.0, apache-base
604%webapp_unregister httpd %{webapp}
605
606%triggerin gitweb -- lighttpd
607%webapp_register lighttpd %{webapp}
608
609%triggerun gitweb -- lighttpd
610%webapp_unregister lighttpd %{webapp}
611
612%files -f git.lang
613%defattr(644,root,root,755)
614%doc README contrib-doc
615%attr(755,root,root) %{_bindir}/git
616%attr(755,root,root) %{_bindir}/git-receive-pack
617%attr(755,root,root) %{_bindir}/git-shell
618%attr(755,root,root) %{_bindir}/git-upload-archive
619%attr(755,root,root) %{_bindir}/git-upload-pack
620%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
621
622%if %{with doc}
623%{_mandir}/man1/git-*.1*
624%exclude %{_mandir}/man1/git-archimport.1*
625%exclude %{_mandir}/man1/git-svn.1*
626%exclude %{_mandir}/man1/git-cvs*.1*
627%exclude %{_mandir}/man1/git-imap-send*.1*
628%exclude %{_mandir}/man1/*email*.1*
629%{_mandir}/man1/git.1*
630%{_mandir}/man1/gitremote-helpers.1*
631%{_mandir}/man5/gitattributes.5*
632%{_mandir}/man5/githooks.5*
633%{_mandir}/man5/gitignore.5*
634%{_mandir}/man5/gitmodules.5*
635%{_mandir}/man5/gitrepository-layout.5*
636%{_mandir}/man7/gitcli.7*
637%{_mandir}/man7/gitcore-tutorial.7*
638%{_mandir}/man7/gitcredentials.7*
639%{_mandir}/man7/gitdiffcore.7*
640%{_mandir}/man7/giteveryday.7*
641%{_mandir}/man7/gitglossary.7*
642%{_mandir}/man7/gitnamespaces.7*
643%{_mandir}/man7/gitrevisions.7*
644%{_mandir}/man7/gittutorial-2.7*
645%{_mandir}/man7/gittutorial.7*
646%{_mandir}/man7/gitworkflows.7*
647%endif
648
649%dir %{gitcoredir}
650%attr(755,root,root) %{gitcoredir}/*-*
651%attr(755,root,root) %{gitcoredir}/git
652%dir %{gitcoredir}/mergetools
653%{gitcoredir}/mergetools/*
654
655%{_datadir}/%{name}
656%{_localstatedir}/lib/git
657
658# subpackages
659%exclude %{gitcoredir}/*email*
660%exclude %{gitcoredir}/*p4*
661%exclude %{gitcoredir}/git-archimport
662%exclude %{gitcoredir}/git-cvs*
663%exclude %{gitcoredir}/git-gui
664%exclude %{gitcoredir}/git-imap-send
665%exclude %{gitcoredir}/git-instaweb
666%exclude %{gitcoredir}/git-remote-bzr
667%exclude %{gitcoredir}/git-remote-hg
668%exclude %{gitcoredir}/git-remote-testsvn
669%exclude %{gitcoredir}/git-svn
670%exclude %{gitcoredir}/mergetools/p4merge
671%if %{with gnome_keyring}
672%exclude %{gitcoredir}/git-credential-gnome-keyring
673%endif
674
675%if %{with doc}
676%files doc
677%defattr(644,root,root,755)
678%doc Documentation/RelNotes*
679%doc Documentation/*.html Documentation/howto Documentation/technical
680%endif
681
682%files daemon-inetd
683%defattr(644,root,root,755)
684%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
685
686%files daemon-standalone
687%defattr(644,root,root,755)
688%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
689%attr(754,root, root) /etc/rc.d/init.d/git-daemon
690
691%files devel
692%defattr(644,root,root,755)
693%{_includedir}/%{name}
694%{_libdir}/libgit.a
695%{_libdir}/libgit_xdiff.a
696
697%files gitk
698%defattr(644,root,root,755)
699%if %{with doc}
700%{_mandir}/man1/gitk.1*
701%endif
702%attr(755,root,root) %{_bindir}/gitk
703%dir %{_datadir}/gitk
704%dir %{_datadir}/gitk/lib
705%dir %{_datadir}/gitk/lib/msgs
706%lang(bg) %{_datadir}/gitk/lib/msgs/bg.msg
707%lang(de) %{_datadir}/gitk/lib/msgs/de.msg
708%lang(es) %{_datadir}/gitk/lib/msgs/es.msg
709%lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
710%lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
711%lang(it) %{_datadir}/gitk/lib/msgs/it.msg
712%lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
713%lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
714%lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
715%lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
716%lang(vi) %{_datadir}/gitk/lib/msgs/vi.msg
717
718%files gitweb
719%defattr(644,root,root,755)
720%doc gitweb/{README,INSTALL}
721%dir %{webappdir}
722%config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
723%config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
724%config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
725%config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
726%config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitolite.pl
727%attr(755,root,root) %{cgibindir}/gitweb.cgi
728%{appdir}
729%attr(755,root,root) %{gitcoredir}/git-instaweb
730%if %{with doc}
731%{_mandir}/man1/gitweb.1*
732%{_mandir}/man5/gitweb.conf.5*
733%endif
734
735%files gitview
736%defattr(644,root,root,755)
737%doc contrib/gitview/gitview.txt
738%attr(755,root,root) %{_bindir}/gitview
739
740%files gui
741%defattr(644,root,root,755)
742%attr(755,root,root) %{gitcoredir}/git-gui
743%dir %{_datadir}/git-gui
744%dir %{_datadir}/git-gui/lib
745%dir %{_datadir}/git-gui/lib/msgs
746%{_datadir}/git-gui/lib/git-gui.ico
747%{_datadir}/git-gui/lib/tclIndex
748%{_datadir}/git-gui/lib/*.js
749%{_datadir}/git-gui/lib/*.tcl
750%lang(bg) %{_datadir}/git-gui/lib/msgs/bg.msg
751%lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
752%lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
753%lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
754%lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
755%lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
756%lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
757%lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
758%lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
759%lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
760%lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
761%lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
762
763%files arch
764%defattr(644,root,root,755)
765%attr(755,root,root) %{gitcoredir}/git-archimport
766%if %{with doc}
767%{_mandir}/man1/git-archimport.1*
768%endif
769
770%files bzr
771%defattr(644,root,root,755)
772%attr(755,root,root) %{gitcoredir}/git-remote-bzr
773
774%files cvs
775%defattr(644,root,root,755)
776%attr(755,root,root) %{_bindir}/git-cvsserver
777%attr(755,root,root) %{gitcoredir}/git-cvs*
778%if %{with doc}
779%{_mandir}/man1/git-cvs*.1*
780%{_mandir}/man7/gitcvs-migration.7*
781%endif
782
783%files hg
784%defattr(644,root,root,755)
785%attr(755,root,root) %{gitcoredir}/git-remote-hg
786
787%files p4
788%defattr(644,root,root,755)
789%attr(755,root,root) %{gitcoredir}/git-p4
790%attr(755,root,root) %{gitcoredir}/mergetools/p4merge
791
792%files svn
793%defattr(644,root,root,755)
794%attr(755,root,root) %{gitcoredir}/git-svn
795%attr(755,root,root) %{gitcoredir}/git-remote-testsvn
796%{perl_vendorlib}/Git/SVN
797%{perl_vendorlib}/Git/SVN.pm
798%if %{with doc}
799%{_mandir}/man1/git-svn.1*
800%endif
801
802%files email
803%defattr(644,root,root,755)
804%attr(755,root,root) %{gitcoredir}/git-imap-send
805%attr(755,root,root) %{gitcoredir}/*email*
806%if %{with doc}
807%{_mandir}/man1/*email*.1*
808%{_mandir}/man1/*imap-send*.1*
809%endif
810
811%files -n bash-completion-git
812%defattr(644,root,root,755)
813%{bash_compdir}/git
814
815%files -n perl-Git
816%defattr(644,root,root,755)
817%{perl_vendorlib}/Git.pm
818%dir %{perl_vendorlib}/Git
819%{perl_vendorlib}/Git/I18N.pm
820%{perl_vendorlib}/Git/IndexInfo.pm
821%{_mandir}/man3/Git*.3pm*
822
823%if %{with gnome_keyring}
824%files -n gnome-keyring-git-core
825%defattr(644,root,root,755)
826%attr(755,root,root) %{gitcoredir}/git-credential-gnome-keyring
827%endif
This page took 0.166313 seconds and 4 git commands to generate.