]> git.pld-linux.org Git - packages/git-core.git/blame_incremental - git-core.spec
- added try-restart action to init script
[packages/git-core.git] / git-core.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without tests # don't perform make test
4%bcond_without doc # skip building/packaging docs/manuals (takes some time)
5#
6%include /usr/lib/rpm/macros.perl
7Summary: The stupid content tracker
8Summary(pl.UTF-8): Prymitywne narzędzie do śledzenia treści
9Name: git-core
10Version: 1.5.3.7
11Release: 2
12License: GPL v2
13Group: Development/Tools
14Source0: http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
15# Source0-md5: a114cbf532ff627698a031a66d072173
16Source1: %{name}-gitweb.conf
17Source2: %{name}-gitweb-httpd.conf
18Source3: %{name}.sysconfig
19Source4: %{name}.inet
20Source5: %{name}.init
21URL: http://git.or.cz/
22BuildRequires: autoconf
23BuildRequires: automake
24BuildRequires: curl-devel
25BuildRequires: expat-devel
26BuildRequires: openssl-devel
27BuildRequires: perl-Error
28BuildRequires: perl-base
29BuildRequires: python
30BuildRequires: rpm-perlprov >= 4.1-13
31BuildRequires: rpmbuild(macros) >= 1.264
32BuildRequires: zlib-devel
33%if %{with doc}
34BuildRequires: asciidoc >= 7.1.2-3
35BuildRequires: xmlto
36%endif
37%if %{with tests}
38# tests failed sometimes when using nserver client 1.11(?)
39BuildRequires: cvs-client >= 1.12
40BuildRequires: pdksh >= 5.2.14-46
41%endif
42Requires: coreutils
43Requires: cpio
44Requires: curl
45Requires: diffutils
46Requires: findutils
47Requires: grep
48Requires: openssh-clients
49Requires: perl-Error
50Requires: rcs
51Requires: sed
52BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54# html docs have links to txt files
55%define _noautocompressdoc *.txt
56
57%define webapp gitweb
58%define webappdir %{_sysconfdir}/webapps/%{webapp}
59%define appdir %{_datadir}/%{webapp}
60%define cgibindir %{_prefix}/lib/cgi-bin
61
62%description
63"git" can mean anything, depending on your mood.
64
65 - random three-letter combination that is pronounceable, and not
66 actually used by any common UNIX command. The fact that it is a
67 mispronunciation of "get" may or may not be relevant.
68 - stupid. contemptible and despicable. simple. Take your pick from the
69 dictionary of slang.
70 - "global information tracker": you're in a good mood, and it actually
71 works for you. Angels sing, and a light suddenly fills the room.
72 - "goddamn idiotic truckload of sh*t": when it breaks
73
74This is a stupid (but extremely fast) directory content manager. It
75doesn't do a whole lot, but what it 'does' do is track directory
76contents efficiently.
77
78%description -l pl.UTF-8
79"git" może oznaczać cokolwiek, w zależności od nastroju.
80
81 - losową kombinację trzech liter, która jest wymawialna i właściwie
82 nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
83 błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
84 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
85 - "global information tracker" (narzędzie do globalnego śledzenia
86 informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
87 Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
88 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
89 g*) - kiedy się zepsuje.
90
91Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
92Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
93katalogu.
94
95%package daemon-inetd
96Summary: Files necessary to run git-daemon as an inetd service
97Summary(pl.UTF-8): Pliki niezbędne do uruchomienia git-daemon w trybie usługi inetd
98Group: Networking/Daemons
99Requires: %{name} = %{version}-%{release}
100Requires: setup >= 2.4.11-1
101Provides: git-core-daemon
102Obsoletes: git-core-daemon
103Obsoletes: git-core-daemon-standalone
104
105%description daemon-inetd
106Git-daemon is a really simple TCP git daemon that can serve git
107repositories. This package provides all necessarry files to run
108git-daemon as an inetd service.
109
110%description daemon-inetd -l pl.UTF-8
111Git-daemon to prosty daemon git korzystający z protokołu TCP do
112udostępnienia repozytoriów git. Pakiet ten dostarcza potrzebnych
113plików do uruchomienia git-daemon w trybie usługi inetd.
114
115%package daemon-standalone
116Summary: Files necessary to run git-daemon as a standalone service
117Summary(pl.UTF-8): Pliki niezbędne do uruchomienia git-daemon w trybie usługi standalone
118Group: Networking/Daemons
119Requires: %{name} = %{version}-%{release}
120Provides: git-core-daemon
121Obsoletes: git-core-daemon
122Obsoletes: git-core-daemon-inetd
123
124%description daemon-standalone
125Git-daemon is a really simple TCP git daemon that can serve git
126repositories. This package provides all necessarry files to run
127git-daemon as an standalone service.
128
129%description daemon-standalone -l pl.UTF-8
130Git-daemon to prosty daemon git korzystający z protokołu TCP do
131udostępnienia repozytoriów git. Pakiet ten dostarcza potrzebnych
132plików do uruchomienia git-daemon w trybie usługi standalone.
133
134%package devel
135Summary: Header files for git-core
136Summary(pl.UTF-8): Pliki nagłówkowe dla git-core
137Group: Development/Libraries
138
139%description devel
140Header files for git-core.
141
142%description devel -l pl.UTF-8
143Pliki nagłówkowe dla git-core.
144
145%package gitk
146Summary: Tcl/Tk interface to the Git version control system
147Summary(pl.UTF-8): Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
148Group: Development/Tools
149Requires: %{name} = %{version}-%{release}
150Requires: tk
151
152%description gitk
153Displays changes in a repository or a selected set of commits. This
154includes visualizing the commit graph, showing information related to
155each commit, and the files in the trees of each revision.
156
157Historically, gitk was the first repository browser. It's written in
158Tcl/Tk and started off in a separate repository but was later merged
159into the main git repository.
160
161%description gitk -l pl.UTF-8
162Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
163to wizualizację grafu commitów, wyświetlanie informacji związanych z
164każdym z commitów oraz listę plików dla każdej rewizji.
165
166Z punktu widzenia historii, gitk był pierwszą przeglądarką
167repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
168osobnym repozytorium, ale z czasem został włączony do głównego
169repozytorium gita.
170
171%package gitweb
172Summary: Web frontend to git
173Summary(pl.UTF-8): Webowy frontend do git
174Group: Development/Tools
175Requires: %{name} = %{version}-%{release}
176Requires: webapps
177
178%description gitweb
179This package provides a web interface for browsing git repositories.
180
181%description gitweb -l pl.UTF-8
182Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
183
184%package gitview
185Summary: A GTK+ based repository browser for git
186Summary(pl.UTF-8): Oparta na GTK+ przeglądarka repozytorium gita
187Group: Development/Tools
188Requires: %{name} = %{version}-%{release}
189Requires: python >= 1:2.4
190Requires: python-pycairo >= 1.0
191Requires: python-pygobject
192Requires: python-pygtk-gtk >= 2:2.8
193Suggests: python-gnome-desktop-gtksourceview
194
195%description gitview
196A GTK+ based repository browser for git.
197
198%description gitview -l pl.UTF-8
199Oparta na GTK+ przeglądarka repozytorium gita.
200
201%package -n bash-completion-git
202Summary: bash-completion for git
203Summary(pl.UTF-8): bashowe uzupełnianie nazw dla gita
204Group: Applications/Shells
205Requires: bash-completion
206
207%description -n bash-completion-git
208This package provides bash-completion for git.
209
210%description -n bash-completion-git -l pl.UTF-8
211Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
212
213%package -n perl-Git
214Summary: Perl interface to the Git version control system
215Summary(pl.UTF-8): Perlowy interfejs do systemu kontroli wersji Git
216Group: Development/Languages/Perl
217Requires: %{name} = %{version}-%{release}
218Obsoletes: perl-git-core
219
220%description -n perl-Git
221This module provides Perl scripts easy way to interface the Git
222version control system. The modules have an easy and well-tested way
223to call arbitrary Git commands; in the future, the interface will also
224provide specialized methods for doing easily operations which are not
225totally trivial to do over the generic command interface.
226
227%description -n perl-Git -l pl.UTF-8
228Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
229wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
230dowolne polecenia Gita; w przyszłości interfejs udostępni także
231specjalne metody do łatwego wykonywania operacji nietrywialnych do
232wykonania przy użyciu ogólnego interfejsu poleceń.
233
234%package -n vim-syntax-gitcommit
235Summary: Vim syntax: gitcommit
236Summary(pl.UTF-8): Składnia dla Vima: gitcommit
237Group: Applications/Editors/Vim
238# for _vimdatadir existence
239Requires: vim >= 4:6.3.058-3
240
241%description -n vim-syntax-gitcommit
242This plugin provides syntax highlighting for git's commit messages.
243
244%description -n vim-syntax-gitcommit -l pl.UTF-8
245Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
246
247%prep
248%setup -q -n git-%{version}
249
250%build
251%{__aclocal}
252%{__autoconf}
253%configure \
254 --with-openssl
255
256%{__make} \
257 INSTALLDIRS=vendor \
258 GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
259 GITWEB_PROJECTROOT="/var/lib/git" \
260 GITWEB_CSS="/gitweb/gitweb.css" \
261 GITWEB_LOGO="/gitweb/git-logo.png" \
262 GITWEB_FAVICON="/gitweb/git-favicon.png"
263
264%{?with_doc:%{__make} -C Documentation}
265
266%{?with_tests:%{__make} test}
267
268%install
269rm -rf $RPM_BUILD_ROOT
270install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_sharedstatedir}/git}
271install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
272install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
273install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
274install -d $RPM_BUILD_ROOT%{_sysconfdir}/{sysconfig/rc-inetd,rc.d/init.d}
275
276%{__make} install \
277 INSTALLDIRS=vendor \
278 DESTDIR=$RPM_BUILD_ROOT
279
280%if %{with doc}
281%{__make} -C Documentation install \
282 DESTDIR=$RPM_BUILD_ROOT
283%endif
284
285# header files and lib
286install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
287install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
288install libgit.a $RPM_BUILD_ROOT%{_libdir}
289
290# bash completion
291install contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
292
293# vim syntax
294install contrib/vim/syntax/gitcommit.vim $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
295
296# gitweb
297install gitweb/*.css gitweb/*.png $RPM_BUILD_ROOT%{appdir}
298install gitweb/gitweb.cgi $RPM_BUILD_ROOT%{cgibindir}
299install %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
300install %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
301install %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
302
303# gitview
304install contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
305
306# git-daemon related files
307install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/git-daemon
308install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/rc-inetd/git-daemon
309install %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/git-daemon
310
311# remove unneeded files
312rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
313rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
314rm -f $RPM_BUILD_ROOT%{perl_vendorlib}/Error.pm
315rm -f $RPM_BUILD_ROOT%{_mandir}/man3/private-Error.3*
316
317%clean
318rm -rf $RPM_BUILD_ROOT
319
320%post daemon-inetd
321%service -q rc-inetd reload
322
323%postun daemon-inetd
324if [ "$1" = "0" ]; then
325 %service -q rc-inetd reload
326fi
327
328%post daemon-standalone
329/sbin/chkconfig --add git-daemon
330%service git-daemon restart "git-daemon"
331
332%preun daemon-standalone
333if [ "$1" = "0" ]; then
334 %service git-daemon stop
335 /sbin/chkconfig --del git-daemon
336fi
337
338%triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
339%webapp_register apache %{webapp}
340
341%triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
342%webapp_unregister apache %{webapp}
343
344%triggerin gitweb -- apache < 2.2.0, apache-base
345%webapp_register httpd %{webapp}
346
347%triggerun gitweb -- apache < 2.2.0, apache-base
348%webapp_unregister httpd %{webapp}
349
350%files
351%defattr(644,root,root,755)
352%doc README contrib
353%if %{with doc}
354%doc Documentation/{[!g]*,g[!i]*,git,git[!k]*}.html Documentation/howto Documentation/technical
355%{_mandir}/man1/git-*.1*
356%{_mandir}/man5/gitattributes.5*
357%{_mandir}/man5/gitignore.5*
358%{_mandir}/man5/gitmodules.5*
359%{_mandir}/man7/git.7*
360%endif
361%attr(755,root,root) %{_bindir}/git
362%attr(755,root,root) %{_bindir}/git-*
363%{_datadir}/%{name}
364%{_datadir}/git-gui
365%{_sharedstatedir}/git
366
367%files daemon-inetd
368%defattr(644,root,root,755)
369%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
370
371%files daemon-standalone
372%defattr(644,root,root,755)
373%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
374%attr(754,root, root) /etc/rc.d/init.d/git-daemon
375
376%files devel
377%defattr(644,root,root,755)
378%{_includedir}/*
379%{_libdir}/*.a
380
381%files gitk
382%defattr(644,root,root,755)
383%if %{with doc}
384%doc Documentation/gitk.html
385%{_mandir}/man1/gitk.1*
386%endif
387%attr(755,root,root) %{_bindir}/gitk
388
389%files gitweb
390%defattr(644,root,root,755)
391%doc gitweb/{README,INSTALL}
392%dir %{webappdir}
393%config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
394%config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
395%config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
396%attr(755,root,root) %{cgibindir}/gitweb.cgi
397%{appdir}
398
399%files gitview
400%defattr(644,root,root,755)
401%doc contrib/gitview/gitview.txt
402%attr(755,root,root) %{_bindir}/gitview
403
404%files -n bash-completion-git
405%defattr(644,root,root,755)
406%{_sysconfdir}/bash_completion.d/*
407
408%files -n perl-Git
409%defattr(644,root,root,755)
410%{perl_vendorlib}/Git.pm
411%{_mandir}/man3/Git.3pm*
412
413%files -n vim-syntax-gitcommit
414%defattr(644,root,root,755)
415%doc contrib/vim/README
416%{_datadir}/vim/vimfiles/syntax/*
This page took 0.035446 seconds and 4 git commands to generate.