]> git.pld-linux.org Git - packages/git-core.git/blame_incremental - git-core.spec
- enable tests
[packages/git-core.git] / git-core.spec
... / ...
CommitLineData
1# TODO:
2# - gitweb subpackage
3# - gitk subpackage?
4%bcond_without tests
5%include /usr/lib/rpm/macros.perl
6Summary: The stupid content tracker
7Summary(pl.UTF-8): Prymitywne narzędzie do śledzenia treści
8Name: git-core
9Version: 1.5.2.1
10Release: 1
11License: GPL v2
12Group: Development/Tools
13Source0: http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
14# Source0-md5: 0a39e786a12974cbe7b14f2fe92dc163
15URL: http://git.or.cz/
16BuildRequires: asciidoc
17BuildRequires: autoconf
18BuildRequires: automake
19BuildRequires: curl-devel
20BuildRequires: expat-devel
21BuildRequires: openssl-devel
22BuildRequires: perl-Error
23BuildRequires: perl-base
24BuildRequires: python
25BuildRequires: rpm-perlprov >= 4.1-13
26BuildRequires: xmlto
27BuildRequires: zlib-devel
28Requires: coreutils
29Requires: curl
30Requires: diffutils
31Requires: findutils
32Requires: grep
33Requires: openssh-clients
34Requires: perl-Error
35Requires: rcs
36Requires: sed
37Requires: tk
38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40%description
41"git" can mean anything, depending on your mood.
42
43 - random three-letter combination that is pronounceable, and not
44 actually used by any common UNIX command. The fact that it is a
45 mispronunciation of "get" may or may not be relevant.
46 - stupid. contemptible and despicable. simple. Take your pick from the
47 dictionary of slang.
48 - "global information tracker": you're in a good mood, and it actually
49 works for you. Angels sing, and a light suddenly fills the room.
50 - "goddamn idiotic truckload of sh*t": when it breaks
51
52This is a stupid (but extremely fast) directory content manager. It
53doesn't do a whole lot, but what it 'does' do is track directory
54contents efficiently.
55
56%description -l pl.UTF-8
57"git" może oznaczać cokolwiek, w zależności od nastroju.
58
59- losową kombinację trzech liter, która jest wymawialna i właściwie
60 nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
61 błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
62- głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
63- "global information tracker" (narzędzie do globalnego śledzenia
64 informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
65 Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
66- "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
67 g*) - kiedy się zepsuje.
68
69Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
70Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
71katalogu.
72
73%package devel
74Summary: Header files for git-core
75Summary(pl.UTF-8): Pliki nagłówkowe dla git-core
76Group: Development/Libraries
77
78%description devel
79Header files for git-core.
80
81%description devel -l pl.UTF-8
82Pliki nagłówkowe dla git-core.
83
84%package -n perl-Git
85Summary: Perl interface to the Git version control system
86Summary(pl.UTF-8): Perlowy interfejs do systemu kontroli wersji Git
87Group: Development/Languages/Perl
88Requires: %{name} = %{version}-%{release}
89Obsoletes: perl-git-core
90
91%description -n perl-Git
92This module provides Perl scripts easy way to interface the Git
93version control system. The modules have an easy and well-tested way
94to call arbitrary Git commands; in the future, the interface will also
95provide specialized methods for doing easily operations which are not
96totally trivial to do over the generic command interface.
97
98%description -n perl-Git -l pl.UTF-8
99Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
100wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
101dowolne polecenia Gita; w przyszłości interfejs udostępni także
102specjalne metody do łatwego wykonywania operacji nietrywialnych do
103wykonania przy użyciu ogólnego interfejsu poleceń.
104
105%prep
106%setup -q -n git-%{version}
107
108%build
109%{__aclocal}
110%{__autoconf}
111%configure \
112 --with-openssl
113
114%{__make} \
115 INSTALLDIRS=vendor
116
117%{__make} -C Documentation
118
119%{?with_tests:%{__make} test}
120
121%install
122rm -rf $RPM_BUILD_ROOT
123install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
124
125%{__make} install \
126 INSTALLDIRS=vendor \
127 DESTDIR=$RPM_BUILD_ROOT
128
129%{__make} -C Documentation install \
130 DESTDIR=$RPM_BUILD_ROOT
131
132install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
133install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
134
135rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
136rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
137
138%clean
139rm -rf $RPM_BUILD_ROOT
140
141%files
142%defattr(644,root,root,755)
143%doc README Documentation/*.html Documentation/howto Documentation/technical
144%attr(755,root,root) %{_bindir}/*
145%{_mandir}/man*/*
146%{_datadir}/%{name}
147%{_datadir}/git-gui
148
149%files devel
150%defattr(644,root,root,755)
151%{_includedir}/*
152
153%files -n perl-Git
154%defattr(644,root,root,755)
155%{perl_vendorlib}/Git.pm
156%{_mandir}/man3/*
This page took 0.030235 seconds and 4 git commands to generate.