]> git.pld-linux.org Git - packages/git-core.git/blame_incremental - git-core.spec
- up to 2.0.3
[packages/git-core.git] / git-core.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without tests # don't perform make test
4%bcond_with tests_cvs # perform tests which use CVS
5%bcond_without tests_svn # perform tests which use subversion
6%bcond_without doc # skip building/packaging docs/manuals (takes some time)
7%bcond_without pcre # perl-compatible regexes support
8%bcond_without gnome_keyring # build without gnome keyring support
9
10# for AC: --without doc --without gnome_keyring --without tests
11
12%include /usr/lib/rpm/macros.perl
13Summary: Distributed version control system focused on speed, effectivity and usability
14Summary(pl.UTF-8): Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
15Name: git-core
16Version: 2.0.3
17Release: 1
18License: GPL v2
19Group: Development/Tools
20Source0: http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.gz
21# Source0-md5: c549f5df737c0a559df0e911c8e1b7e5
22Source1: %{name}-gitweb.conf
23Source2: %{name}-gitweb-httpd.conf
24Source3: %{name}-gitweb-lighttpd.conf
25Source4: %{name}.sysconfig
26Source5: %{name}.inet
27Source6: %{name}.init
28Source7: gitolite.pl
29Patch0: %{name}-tests.patch
30Patch1: %{name}-key-bindings.patch
31Patch2: %{name}-sysconfdir.patch
32Patch3: cherry-picked-commitlog.patch
33Patch4: %{name}-svn-exit-errors.patch
34URL: http://git-scm.com/
35BuildRequires: autoconf >= 2.59
36BuildRequires: automake
37BuildRequires: curl-devel
38BuildRequires: expat-devel
39BuildRequires: gettext-devel
40%if %{with gnome_keyring}
41BuildRequires: libgnome-keyring-devel
42BuildRequires: pkgconfig
43%endif
44BuildRequires: openssl-devel
45%{?with_pcre:BuildRequires: pcre-devel}
46BuildRequires: perl-Error > 0.15
47BuildRequires: perl-base
48BuildRequires: python-devel
49BuildRequires: rpm-perlprov >= 4.1-13
50BuildRequires: rpm-pythonprov
51BuildRequires: rpmbuild(macros) >= 1.673
52BuildRequires: tcl
53BuildRequires: zlib-devel
54%if %{with doc}
55BuildRequires: asciidoc >= 7.1.2-3
56BuildRequires: docbook-dtd45-xml
57BuildRequires: xmlto
58%endif
59%if %{with tests}
60%if %{with tests_cvs}
61# tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
62BuildRequires: cvs-gnu-client < 1.13
63BuildRequires: cvs-gnu-client >= 1.12
64%endif
65%{?with_tests_svn:BuildRequires: subversion}
66Conflicts: pdksh < 5.2.14-46
67%endif
68# git-sh-setup: sane_grep
69Requires: grep
70# git-pull: printf
71Requires: coreutils
72Requires: openssh-clients
73Requires: perl-Error
74Requires: perl-Git = %{version}-%{release}
75Requires: sed
76Suggests: git-core-bzr
77Suggests: git-core-cvs
78Suggests: git-core-hg
79Suggests: git-core-p4
80Suggests: git-core-svn
81Suggests: less
82Suggests: rsync
83Obsoletes: python-Git
84BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
85
86# html docs have links to txt files
87%define _noautocompressdoc *.txt
88
89%define webapp gitweb
90%define webappdir %{_sysconfdir}/webapps/%{webapp}
91%define appdir %{_datadir}/%{webapp}
92%define cgibindir %{_prefix}/lib/cgi-bin
93%define gitcoredir %{_libdir}/%{name}
94
95%description
96"git" can mean anything, depending on your mood.
97
98- random three-letter combination that is pronounceable, and not
99 actually used by any common UNIX command. The fact that it is a
100 mispronunciation of "get" may or may not be relevant.
101- stupid. contemptible and despicable. simple. Take your pick from the
102 dictionary of slang.
103- "global information tracker": you're in a good mood, and it actually
104 works for you. Angels sing, and a light suddenly fills the room.
105- "goddamn idiotic truckload of sh*t": when it breaks
106
107This is a stupid (but extremely fast) directory content manager. It
108doesn't do a whole lot, but what it 'does' do is track directory
109contents efficiently.
110
111%description -l pl.UTF-8
112"git" może oznaczać cokolwiek, w zależności od nastroju.
113
114- losową kombinację trzech liter, która jest wymawialna i właściwie
115 nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
116 błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
117- głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
118- "global information tracker" (narzędzie do globalnego śledzenia
119 informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
120 Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
121- "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
122 g*) - kiedy się zepsuje.
123
124Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
125Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
126katalogu.
127
128%package doc
129Summary: Documentation for git-core
130Summary(pl.UTF-8): Dokumentacja do git-core
131Group: Documentation
132
133%description doc
134Documentation for git-core.
135
136%description doc -l pl.UTF-8
137Dokumentacja do git-core.
138
139%description doc -l fr.UTF-8
140Javadoc pour git-core.
141
142%package daemon-inetd
143Summary: Files necessary to run git-daemon as an inetd service
144Summary(pl.UTF-8): Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
145Group: Networking/Daemons
146Requires: %{name} = %{version}-%{release}
147Requires: setup >= 2.4.11-1
148Provides: git-core-daemon
149Obsoletes: git-core-daemon
150Obsoletes: git-core-daemon-standalone
151
152%description daemon-inetd
153Git-daemon is a really simple TCP git daemon that can serve git
154repositories. This package provides all necessarry files to run
155git-daemon as an inetd service.
156
157%description daemon-inetd -l pl.UTF-8
158Git-daemon to prosty demon git korzystający z protokołu TCP do
159udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
160do uruchomienia git-demona w trybie usługi inetd.
161
162%package daemon-standalone
163Summary: Files necessary to run git-daemon as a standalone service
164Summary(pl.UTF-8): Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
165Group: Networking/Daemons
166Requires: %{name} = %{version}-%{release}
167Provides: git-core-daemon
168Obsoletes: git-core-daemon
169Obsoletes: git-core-daemon-inetd
170
171%description daemon-standalone
172Git-daemon is a really simple TCP git daemon that can serve git
173repositories. This package provides all necessarry files to run
174git-daemon as an standalone service.
175
176%description daemon-standalone -l pl.UTF-8
177Git-daemon to prosty demon git korzystający z protokołu TCP do
178udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
179do uruchomienia git-daemona w trybie usługi samodzielnej.
180
181%package devel
182Summary: Git library with header files
183Summary(pl.UTF-8): Biblioteka Gita oraz pliki nagłówkowe
184Group: Development/Libraries
185Requires: zlib-devel
186
187%description devel
188Git library with header files.
189
190%description devel -l pl.UTF-8
191Biblioteka Gita oraz pliki nagłówkowe.
192
193%package gitk
194Summary: Tcl/Tk interface to the Git version control system
195Summary(pl.UTF-8): Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
196Group: Development/Tools
197Requires: %{name} = %{version}-%{release}
198Requires: tk
199
200%description gitk
201gitk displays changes in a repository or a selected set of commits.
202This includes visualizing the commit graph, showing information
203related to each commit, and the files in the trees of each revision.
204
205Historically, gitk was the first repository browser. It's written in
206Tcl/Tk and started off in a separate repository but was later merged
207into the main git repository.
208
209%description gitk -l pl.UTF-8
210gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
211Oznacza to wizualizację grafu commitów, wyświetlanie informacji
212związanych z każdym z commitów oraz listę plików dla każdej rewizji.
213
214Z historycznego punktu widzenia gitk był pierwszą przeglądarką
215repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
216osobnym repozytorium, ale z czasem został włączony do głównego
217repozytorium gita.
218
219%package gitweb
220Summary: Web frontend to git
221Summary(pl.UTF-8): Frontend WWW do gita
222Group: Development/Tools
223Requires: %{name} = %{version}-%{release}
224Requires: webapps
225Requires: webserver(access)
226Requires: webserver(alias)
227Requires: webserver(cgi)
228Suggests: webserver(setenv)
229
230%description gitweb
231This package provides a web interface for browsing git repositories.
232
233%description gitweb -l pl.UTF-8
234Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
235
236%package gitview
237Summary: A GTK+ based repository browser for git
238Summary(pl.UTF-8): Oparta na GTK+ przeglądarka repozytorium gita
239Group: Development/Tools
240Requires: %{name} = %{version}-%{release}
241Requires: python >= 1:2.4
242Requires: python-pycairo >= 1.0
243Requires: python-pygobject
244Requires: python-pygtk-gtk >= 2:2.8
245Suggests: python-gnome-desktop-gtksourceview
246
247%description gitview
248A GTK+ based repository browser for git.
249
250%description gitview -l pl.UTF-8
251Oparta na GTK+ przeglądarka repozytorium gita.
252
253%package gui
254Summary: Tcl/Tk interface to the Git version control system
255Summary(pl.UTF-8): Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
256Group: Development/Tools
257Requires: %{name} = %{version}-%{release}
258Requires: tk
259Requires: xdg-utils
260Suggests: meld
261
262%description gui
263Displays changes in a repository or a selected set of commits. This
264includes visualizing the commit graph, showing information related to
265each commit, and the files in the trees of each revision.
266
267Historically, gitk was the first repository browser. It's written in
268Tcl/Tk and started off in a separate repository but was later merged
269into the main git repository.
270
271%description gui -l pl.UTF-8
272Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
273to wizualizację grafu commitów, wyświetlanie informacji związanych z
274każdym z commitów oraz listę plików dla każdej rewizji.
275
276Z punktu widzenia historii, gitk był pierwszą przeglądarką
277repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
278osobnym repozytorium, ale z czasem został włączony do głównego
279repozytorium gita.
280
281%package arch
282Summary: Git tools for importing Arch repositories
283Summary(pl.UTF-8): Narzędzia Gita do importowania repozytoriów Archa
284Group: Development/Tools
285Requires: %{name} = %{version}-%{release}
286Requires: tla
287
288%description arch
289Git tools for importing Arch repositories.
290
291%description arch -l pl.UTF-8
292Narzędzia Gita do importowania repozytoriów Archa.
293
294%package bzr
295Summary: Git tools for working with bzr repositories
296Summary(pl.UTF-8): Narzędzia Gita do pracy z repozytoriami bzr
297Group: Development/Tools
298Requires: %{name} = %{version}-%{release}
299Requires: bzr
300
301%description bzr
302Git tools for working with bzr repositories.
303
304%description bzr -l pl.UTF-8
305Narzędzia Gita do pracy z repozytoriami bzr.
306
307%package cvs
308Summary: CVS support for Git
309Summary(pl.UTF-8): Obsługa CVS dla Gita
310Group: Development/Tools
311Requires: %{name} = %{version}-%{release}
312Requires: cvsps >= 2.1-2
313Requires: rcs
314
315%description cvs
316CVS support for Git.
317
318%description cvs -l pl.UTF-8
319Obsługa CVS dla Gita.
320
321%package hg
322Summary: Git tools for working with mercurial repositories
323Summary(pl.UTF-8): Narzędzia Gita do pracy z repozytoriami mercuriala
324Group: Development/Tools
325Requires: %{name} = %{version}-%{release}
326Requires: mercurial >= 1.8
327
328%description hg
329Git tools for working with mercurial repositories.
330
331%description hg -l pl.UTF-8
332Narzędzia Gita do pracy z repozytoriami mercuriala.
333
334%package p4
335Summary: Git tools for working with Perforce depots
336Summary(pl.UTF-8): Narzędzia Gita do pracy z magazynami Perforce'a
337Group: Development/Tools
338Requires: %{name} = %{version}-%{release}
339
340%description p4
341Git tools for working with Perforce depots.
342
343%description p4 -l pl.UTF-8
344Narzędzia Gita do pracy z magazynami Perforce'a.
345
346%package svn
347Summary: Subversion support for Git
348Summary(pl.UTF-8): Obsługa Subversion dla Gita
349Group: Development/Tools
350Requires: %{name} = %{version}-%{release}
351Requires: perl-Encode
352Requires: perl-Term-ReadKey
353
354%description svn
355Subversion support for Git.
356
357%description svn -l pl.UTF-8
358Obsługa Subversion dla Gita.
359
360%package email
361Summary: Git tools for sending email
362Summary(pl.UTF-8): Narzędzia Gita do wysyłania poczty
363Group: Development/Tools
364Requires: %{name} = %{version}-%{release}
365
366%description email
367Git tools for sending email.
368
369%description email -l pl.UTF-8
370Narzędzia Gita do wysyłania poczty.
371
372%package -n bash-completion-git
373Summary: bash-completion for git
374Summary(pl.UTF-8): bashowe uzupełnianie nazw dla gita
375Group: Applications/Shells
376Requires: %{name} = %{version}-%{release}
377Requires: bash-completion >= 2.0
378%if "%{_rpmversion}" >= "5"
379BuildArch: noarch
380%endif
381
382%description -n bash-completion-git
383This package provides bash-completion for git.
384
385%description -n bash-completion-git -l pl.UTF-8
386Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
387
388%package -n perl-Git
389Summary: Perl interface to the Git version control system
390Summary(pl.UTF-8): Perlowy interfejs do systemu kontroli wersji Git
391Group: Development/Languages/Perl
392Obsoletes: perl-git-core
393
394%description -n perl-Git
395This module provides Perl scripts easy way to interface the Git
396version control system. The modules have an easy and well-tested way
397to call arbitrary Git commands; in the future, the interface will also
398provide specialized methods for doing easily operations which are not
399totally trivial to do over the generic command interface.
400
401%description -n perl-Git -l pl.UTF-8
402Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
403wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
404dowolne polecenia Gita; w przyszłości interfejs udostępni także
405specjalne metody do łatwego wykonywania operacji nietrywialnych do
406wykonania przy użyciu ogólnego interfejsu poleceń.
407
408%package -n gnome-keyring-git-core
409Summary: GNOME Keyring authentication provider for Git
410Summary(pl.UTF-8): Moduł uwierzytelniający GNOME Keyring dla Git
411Group: X11/Applications
412URL: http://git-scm.com/docs/gitcredentials.html
413Requires: %{name} = %{version}-%{release}
414
415%description -n gnome-keyring-git-core
416Authentication provider module for Git which allows git client to
417authenticate using GNOME Keyring.
418
419You need to register it with:
420- git config --global credential.helper gnome-keyring
421
422%description -n gnome-keyring-git-core -l pl.UTF-8
423Moduł uwierzytelniający dla Subversion pozwalający klientom git
424uwierzytelniać się przy użyciu mechanizmu GNOME Keyring.
425
426Moduł trzeba zarejestrować poleceniem:
427- git config --global credential.helper gnome-keyring
428
429%prep
430%setup -q -n git-%{version}
431%patch0 -p1
432%patch1 -p0
433%patch2 -p1
434%patch3 -p1
435%patch4 -p1
436
437%{__rm} {Documentation/technical,contrib/emacs,contrib/credential/gnome-keyring}/.gitignore
438
439%build
440%{__aclocal}
441%{__autoconf}
442%configure \
443 --sysconfdir=%{_sysconfdir}/git-core \
444 %{?with_pcre:--with-libpcre} \
445 --with-openssl
446
447echo "BLK_SHA1=1" >> config.mak
448
449%{__make} \
450 INSTALLDIRS=vendor \
451 GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
452 GITWEB_PROJECTROOT="/var/lib/git" \
453 GITWEB_CSS="/gitweb/gitweb.css" \
454 GITWEB_LOGO="/gitweb/git-logo.png" \
455 GITWEB_FAVICON="/gitweb/git-favicon.png" \
456 V=1
457
458%{__make} -C contrib/subtree
459
460%if %{with gnome_keyring}
461%{__make} -C contrib/credential/gnome-keyring
462%endif
463
464%if %{with doc}
465%{__make} -C Documentation \
466 MAN_BASE_URL=file://%{_docdir}/%{name}-doc-%{version}/ \
467 V=1
468%endif
469
470%if %{with tests}
471%if %{without tests_cvs}
472%{__rm} t/t*cvs*.sh || :
473%endif
474%{!?with_tests_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
475%endif
476
477%install
478rm -rf $RPM_BUILD_ROOT
479install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
480install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
481install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
482install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
483cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
484[init]
485 templatedir = %{_sysconfdir}/%{name}/templates
486EOF
487
488%{__make} install \
489 INSTALLDIRS=vendor \
490 DESTDIR=$RPM_BUILD_ROOT
491
492%if %{with doc}
493%{__make} -C Documentation install \
494 DESTDIR=$RPM_BUILD_ROOT
495%endif
496
497# copy templates except sample hooks
498cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
499%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
500
501# header files and lib
502cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
503cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
504cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
505install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
506cp -p block-sha1/sha1.h $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
507cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
508cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
509cp -p {Makefile,config.mak,config.mak.autogen,config.mak.uname} $RPM_BUILD_ROOT%{_includedir}/%{name}
510
511%{__make} -C contrib/subtree install \
512 libexecdir=%{gitcoredir} \
513 DESTDIR=$RPM_BUILD_ROOT
514
515%if %{with doc}
516%{__make} -C contrib/subtree install-doc \
517 DESTDIR=$RPM_BUILD_ROOT
518%endif
519
520%if %{with gnome_keyring}
521install -p contrib/credential/gnome-keyring/git-credential-gnome-keyring $RPM_BUILD_ROOT%{gitcoredir}
522# Remove built binary files, otherwise they will be installed in doc
523%{__make} -C contrib/credential/gnome-keyring clean
524%endif
525
526# bash completion
527install -d $RPM_BUILD_ROOT%{bash_compdir}
528cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{bash_compdir}/git
529
530# Install git-prompt.sh
531install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/contrib/completion
532cp -p contrib/completion/git-prompt.sh $RPM_BUILD_ROOT%{_datadir}/%{name}/contrib/completion
533
534# Install bzr and hg remote helpers from contrib
535install -p contrib/remote-helpers/git-remote-{bzr,hg} $RPM_BUILD_ROOT%{gitcoredir}
536
537# gitweb
538mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
539ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
540cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
541cp -p %{SOURCE7} $RPM_BUILD_ROOT%{webappdir}/gitolite.pl
542cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
543cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
544cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
545
546# gitview
547install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
548
549# git-daemon related files
550cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
551cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
552install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
553
554# paths cleanup
555sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
556sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
557
558# hardlink
559ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
560ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
561ln -f $RPM_BUILD_ROOT{%{gitcoredir},%{_bindir}}/git-shell
562ln -f $RPM_BUILD_ROOT{%{gitcoredir},%{_bindir}}/git-upload-pack
563
564# remove unneeded files
565%{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
566%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
567%py_postclean
568
569mv $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
570%find_lang git
571
572%clean
573rm -rf $RPM_BUILD_ROOT
574
575%post daemon-inetd
576%service -q rc-inetd reload
577
578%postun daemon-inetd
579if [ "$1" = "0" ]; then
580 %service -q rc-inetd reload
581fi
582
583%post daemon-standalone
584/sbin/chkconfig --add git-daemon
585%service git-daemon restart "git-daemon"
586
587%preun daemon-standalone
588if [ "$1" = "0" ]; then
589 %service git-daemon stop
590 /sbin/chkconfig --del git-daemon
591fi
592
593%triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
594%webapp_register apache %{webapp}
595
596%triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
597%webapp_unregister apache %{webapp}
598
599%triggerin gitweb -- apache < 2.2.0, apache-base
600%webapp_register httpd %{webapp}
601
602%triggerun gitweb -- apache < 2.2.0, apache-base
603%webapp_unregister httpd %{webapp}
604
605%triggerin gitweb -- lighttpd
606%webapp_register lighttpd %{webapp}
607
608%triggerun gitweb -- lighttpd
609%webapp_unregister lighttpd %{webapp}
610
611%files -f git.lang
612%defattr(644,root,root,755)
613%doc README contrib
614%attr(755,root,root) %{_bindir}/git
615%attr(755,root,root) %{_bindir}/git-receive-pack
616%attr(755,root,root) %{_bindir}/git-shell
617%attr(755,root,root) %{_bindir}/git-upload-archive
618%attr(755,root,root) %{_bindir}/git-upload-pack
619%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
620
621%if %{with doc}
622%{_mandir}/man1/git-*.1*
623%exclude %{_mandir}/man1/git-archimport.1*
624%exclude %{_mandir}/man1/git-svn.1*
625%exclude %{_mandir}/man1/git-cvs*.1*
626%exclude %{_mandir}/man1/git-imap-send*.1*
627%exclude %{_mandir}/man1/*email*.1*
628%{_mandir}/man1/git.1*
629%{_mandir}/man1/gitremote-helpers.1*
630%{_mandir}/man5/gitattributes.5*
631%{_mandir}/man5/githooks.5*
632%{_mandir}/man5/gitignore.5*
633%{_mandir}/man5/gitmodules.5*
634%{_mandir}/man5/gitrepository-layout.5*
635%{_mandir}/man7/gitcli.7*
636%{_mandir}/man7/gitcore-tutorial.7*
637%{_mandir}/man7/gitcredentials.7*
638%{_mandir}/man7/gitdiffcore.7*
639%{_mandir}/man7/gitglossary.7*
640%{_mandir}/man7/gitnamespaces.7*
641%{_mandir}/man7/gitrevisions.7*
642%{_mandir}/man7/gittutorial-2.7*
643%{_mandir}/man7/gittutorial.7*
644%{_mandir}/man7/gitworkflows.7*
645%endif
646
647%dir %{gitcoredir}
648%attr(755,root,root) %{gitcoredir}/*-*
649%attr(755,root,root) %{gitcoredir}/git
650%dir %{gitcoredir}/mergetools
651%{gitcoredir}/mergetools/*
652
653%{_datadir}/%{name}
654%{_localstatedir}/lib/git
655
656# subpackages
657%exclude %{gitcoredir}/*email*
658%exclude %{gitcoredir}/*p4*
659%exclude %{gitcoredir}/git-archimport
660%exclude %{gitcoredir}/git-cvs*
661%exclude %{gitcoredir}/git-gui
662%exclude %{gitcoredir}/git-imap-send
663%exclude %{gitcoredir}/git-instaweb
664%exclude %{gitcoredir}/git-remote-bzr
665%exclude %{gitcoredir}/git-remote-hg
666%exclude %{gitcoredir}/git-remote-testsvn
667%exclude %{gitcoredir}/git-svn
668%exclude %{gitcoredir}/mergetools/p4merge
669%if %{with gnome_keyring}
670%exclude %{gitcoredir}/git-credential-gnome-keyring
671%endif
672
673%if %{with doc}
674%files doc
675%defattr(644,root,root,755)
676%doc Documentation/RelNotes*
677%doc Documentation/*.html Documentation/howto Documentation/technical
678%endif
679
680%files daemon-inetd
681%defattr(644,root,root,755)
682%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
683
684%files daemon-standalone
685%defattr(644,root,root,755)
686%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
687%attr(754,root, root) /etc/rc.d/init.d/git-daemon
688
689%files devel
690%defattr(644,root,root,755)
691%{_includedir}/%{name}
692%{_libdir}/libgit.a
693%{_libdir}/libgit_xdiff.a
694
695%files gitk
696%defattr(644,root,root,755)
697%if %{with doc}
698%{_mandir}/man1/gitk.1*
699%endif
700%attr(755,root,root) %{_bindir}/gitk
701%dir %{_datadir}/gitk
702%dir %{_datadir}/gitk/lib
703%dir %{_datadir}/gitk/lib/msgs
704%lang(bg) %{_datadir}/gitk/lib/msgs/bg.msg
705%lang(de) %{_datadir}/gitk/lib/msgs/de.msg
706%lang(es) %{_datadir}/gitk/lib/msgs/es.msg
707%lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
708%lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
709%lang(it) %{_datadir}/gitk/lib/msgs/it.msg
710%lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
711%lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
712%lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
713%lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
714
715%files gitweb
716%defattr(644,root,root,755)
717%doc gitweb/{README,INSTALL}
718%dir %{webappdir}
719%config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
720%config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
721%config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
722%config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
723%config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitolite.pl
724%attr(755,root,root) %{cgibindir}/gitweb.cgi
725%{appdir}
726%attr(755,root,root) %{gitcoredir}/git-instaweb
727%if %{with doc}
728%{_mandir}/man1/gitweb.1*
729%{_mandir}/man5/gitweb.conf.5*
730%endif
731
732%files gitview
733%defattr(644,root,root,755)
734%doc contrib/gitview/gitview.txt
735%attr(755,root,root) %{_bindir}/gitview
736
737%files gui
738%defattr(644,root,root,755)
739%attr(755,root,root) %{gitcoredir}/git-gui
740%dir %{_datadir}/git-gui
741%dir %{_datadir}/git-gui/lib
742%dir %{_datadir}/git-gui/lib/msgs
743%{_datadir}/git-gui/lib/git-gui.ico
744%{_datadir}/git-gui/lib/tclIndex
745%{_datadir}/git-gui/lib/*.js
746%{_datadir}/git-gui/lib/*.tcl
747%lang(bg) %{_datadir}/git-gui/lib/msgs/bg.msg
748%lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
749%lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
750%lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
751%lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
752%lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
753%lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
754%lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
755%lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
756%lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
757%lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
758%lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
759
760%files arch
761%defattr(644,root,root,755)
762%attr(755,root,root) %{gitcoredir}/git-archimport
763%if %{with doc}
764%{_mandir}/man1/git-archimport.1*
765%endif
766
767%files bzr
768%defattr(644,root,root,755)
769%attr(755,root,root) %{gitcoredir}/git-remote-bzr
770
771%files cvs
772%defattr(644,root,root,755)
773%attr(755,root,root) %{_bindir}/git-cvsserver
774%attr(755,root,root) %{gitcoredir}/git-cvs*
775%if %{with doc}
776%{_mandir}/man1/git-cvs*.1*
777%{_mandir}/man7/gitcvs-migration.7*
778%endif
779
780%files hg
781%defattr(644,root,root,755)
782%attr(755,root,root) %{gitcoredir}/git-remote-hg
783
784%files p4
785%defattr(644,root,root,755)
786%attr(755,root,root) %{gitcoredir}/git-p4
787%attr(755,root,root) %{gitcoredir}/mergetools/p4merge
788
789%files svn
790%defattr(644,root,root,755)
791%attr(755,root,root) %{gitcoredir}/git-svn
792%attr(755,root,root) %{gitcoredir}/git-remote-testsvn
793%{perl_vendorlib}/Git/SVN
794%{perl_vendorlib}/Git/SVN.pm
795%if %{with doc}
796%{_mandir}/man1/git-svn.1*
797%endif
798
799%files email
800%defattr(644,root,root,755)
801%attr(755,root,root) %{gitcoredir}/git-imap-send
802%attr(755,root,root) %{gitcoredir}/*email*
803%if %{with doc}
804%{_mandir}/man1/*email*.1*
805%{_mandir}/man1/*imap-send*.1*
806%endif
807
808%files -n bash-completion-git
809%defattr(644,root,root,755)
810%{bash_compdir}/git
811
812%files -n perl-Git
813%defattr(644,root,root,755)
814%{perl_vendorlib}/Git.pm
815%dir %{perl_vendorlib}/Git
816%{perl_vendorlib}/Git/I18N.pm
817%{perl_vendorlib}/Git/IndexInfo.pm
818%{_mandir}/man3/Git*.3pm*
819
820%if %{with gnome_keyring}
821%files -n gnome-keyring-git-core
822%defattr(644,root,root,755)
823%attr(755,root,root) %{gitcoredir}/git-credential-gnome-keyring
824%endif
This page took 0.060214 seconds and 4 git commands to generate.