]> git.pld-linux.org Git - packages/git-core.git/blame_incremental - git-core.spec
- tests fail with cvs-nserver-client; BC it
[packages/git-core.git] / git-core.spec
... / ...
CommitLineData
1
2# Conditional build:
3%bcond_without tests # don't perform make test
4%bcond_without doc # skip building/packaging docs/manuals (takes some time)
5#
6%include /usr/lib/rpm/macros.perl
7Summary: The stupid content tracker
8Summary(pl.UTF-8): Prymitywne narzędzie do śledzenia treści
9Name: git-core
10Version: 1.5.3.6
11Release: 1
12License: GPL v2
13Group: Development/Tools
14Source0: http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
15# Source0-md5: 9b0a6cea7b084f3fc78f264cd2fb49bd
16Source1: %{name}-gitweb.conf
17Source2: %{name}-gitweb-httpd.conf
18URL: http://git.or.cz/
19BuildRequires: autoconf
20BuildRequires: automake
21BuildRequires: curl-devel
22BuildRequires: expat-devel
23BuildRequires: openssl-devel
24BuildRequires: perl-Error
25BuildRequires: perl-base
26BuildRequires: python
27BuildRequires: rpm-perlprov >= 4.1-13
28BuildRequires: rpmbuild(macros) >= 1.264
29BuildRequires: zlib-devel
30%if %{with doc}
31BuildRequires: asciidoc >= 7.1.2-3
32BuildRequires: xmlto
33%endif
34%if %{with tests}
35BuildRequires: cvs
36# tests fail when using this client
37BuildConflicts: cvs-nserver-client
38BuildRequires: pdksh >= 5.2.14-46
39%endif
40Requires: coreutils
41Requires: cpio
42Requires: curl
43Requires: diffutils
44Requires: findutils
45Requires: grep
46Requires: openssh-clients
47Requires: perl-Error
48Requires: rcs
49Requires: sed
50BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52# html docs have links to txt files
53%define _noautocompressdoc *.txt
54
55%define webapp gitweb
56%define webappdir %{_sysconfdir}/webapps/%{webapp}
57%define appdir %{_datadir}/%{webapp}
58%define cgibindir %{_prefix}/lib/cgi-bin
59
60%description
61"git" can mean anything, depending on your mood.
62
63 - random three-letter combination that is pronounceable, and not
64 actually used by any common UNIX command. The fact that it is a
65 mispronunciation of "get" may or may not be relevant.
66 - stupid. contemptible and despicable. simple. Take your pick from the
67 dictionary of slang.
68 - "global information tracker": you're in a good mood, and it actually
69 works for you. Angels sing, and a light suddenly fills the room.
70 - "goddamn idiotic truckload of sh*t": when it breaks
71
72This is a stupid (but extremely fast) directory content manager. It
73doesn't do a whole lot, but what it 'does' do is track directory
74contents efficiently.
75
76%description -l pl.UTF-8
77"git" może oznaczać cokolwiek, w zależności od nastroju.
78
79- losową kombinację trzech liter, która jest wymawialna i
80 właściwie nie używana przez żadne popularne polecenie uniksowe.
81 Fakt, że jest to błędna pisownia słowa "get" może mieć lub nie
82 mieć znaczenia.
83- głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
84- "global information tracker" (narzędzie do globalnego śledzenia
85 informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
86 Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
87- "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
88 g*) - kiedy się zepsuje.
89
90Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
91Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
92katalogu.
93
94%package devel
95Summary: Header files for git-core
96Summary(pl.UTF-8): Pliki nagłówkowe dla git-core
97Group: Development/Libraries
98
99%description devel
100Header files for git-core.
101
102%description devel -l pl.UTF-8
103Pliki nagłówkowe dla git-core.
104
105%package gitk
106Summary: Tcl/Tk interface to the Git version control system
107Summary(pl.UTF-8): Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
108Group: Development/Tools
109Requires: %{name} = %{version}-%{release}
110Requires: tk
111
112%description gitk
113Displays changes in a repository or a selected set of commits. This
114includes visualizing the commit graph, showing information related to
115each commit, and the files in the trees of each revision.
116
117Historically, gitk was the first repository browser. It's written in
118Tcl/Tk and started off in a separate repository but was later merged
119into the main git repository.
120
121%description gitk -l pl.UTF-8
122Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
123to wizualizację grafu commitów, wyświetlanie informacji związanych z
124każdym z commitów oraz listę plików dla każdej rewizji.
125
126Z punktu widzenia historii, gitk był pierwszą przeglądarką
127repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
128osobnym repozytorium, ale z czasem został włączony do głównego
129repozytorium gita.
130
131%package gitweb
132Summary: Web frontend to git
133Summary(pl.UTF-8): Webowy frontend do git
134Group: Development/Tools
135Requires: %{name} = %{version}-%{release}
136Requires: webapps
137
138%description gitweb
139This package provides a web interface for browsing git repositories.
140
141%description gitweb -l pl.UTF-8
142Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
143
144%package gitview
145Summary: A GTK+ based repository browser for git
146Summary(pl.UTF-8): Oparta na GTK+ przeglądarka repozytorium gita
147Group: Development/Tools
148Requires: %{name} = %{version}-%{release}
149#Requires: pytongowe mambo dżambo
150
151%description gitview
152A GTK+ based repository browser for git.
153
154%description gitview -l pl.UTF-8
155Oparta na GTK+ przeglądarka repozytorium gita.
156
157%package -n bash-completion-git
158Summary: bash-completion for git
159Summary(pl.UTF-8): bashowe uzupełnianie nazw dla gita
160Group: Applications/Shells
161Requires: bash-completion
162
163%description -n bash-completion-git
164This package provides bash-completion for git.
165
166%description -n bash-completion-git -l pl.UTF-8
167Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
168
169%package -n perl-Git
170Summary: Perl interface to the Git version control system
171Summary(pl.UTF-8): Perlowy interfejs do systemu kontroli wersji Git
172Group: Development/Languages/Perl
173Requires: %{name} = %{version}-%{release}
174Obsoletes: perl-git-core
175
176%description -n perl-Git
177This module provides Perl scripts easy way to interface the Git
178version control system. The modules have an easy and well-tested way
179to call arbitrary Git commands; in the future, the interface will also
180provide specialized methods for doing easily operations which are not
181totally trivial to do over the generic command interface.
182
183%description -n perl-Git -l pl.UTF-8
184Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
185wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
186dowolne polecenia Gita; w przyszłości interfejs udostępni także
187specjalne metody do łatwego wykonywania operacji nietrywialnych do
188wykonania przy użyciu ogólnego interfejsu poleceń.
189
190%package -n vim-syntax-gitcommit
191Summary: Vim syntax: gitcommit
192Summary(pl.UTF-8): Składnia dla Vima: gitcommit
193Group: Applications/Editors/Vim
194# for _vimdatadir existence
195Requires: vim >= 4:6.3.058-3
196
197%description -n vim-syntax-gitcommit
198This plugin provides syntax highlighting for git's commit messages.
199
200%description -n vim-syntax-gitcommit -l pl.UTF-8
201Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
202
203%prep
204%setup -q -n git-%{version}
205
206%build
207%{__aclocal}
208%{__autoconf}
209%configure \
210 --with-openssl
211
212%{__make} \
213 INSTALLDIRS=vendor \
214 GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
215 GITWEB_PROJECTROOT="/var/lib/git" \
216 GITWEB_CSS="/gitweb/gitweb.css" \
217 GITWEB_LOGO="/gitweb/git-logo.png" \
218 GITWEB_FAVICON="/gitweb/git-favicon.png"
219
220%{?with_doc:%{__make} -C Documentation}
221
222%{?with_tests:%{__make} test}
223
224%install
225rm -rf $RPM_BUILD_ROOT
226install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_sharedstatedir}/git}
227install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
228install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
229install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
230
231%{__make} install \
232 INSTALLDIRS=vendor \
233 DESTDIR=$RPM_BUILD_ROOT
234
235%if %{with doc}
236%{__make} -C Documentation install \
237 DESTDIR=$RPM_BUILD_ROOT
238%endif
239
240# header files and lib
241install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
242install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
243install libgit.a $RPM_BUILD_ROOT%{_libdir}
244
245# bash completion
246install contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
247
248# vim syntax
249install contrib/vim/syntax/gitcommit.vim $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
250
251# gitweb
252install gitweb/*.css gitweb/*.png $RPM_BUILD_ROOT%{appdir}
253install gitweb/gitweb.cgi $RPM_BUILD_ROOT%{cgibindir}
254install %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
255install %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
256install %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
257
258# gitview
259install contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
260
261# remove unneeded files
262rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
263rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
264
265%clean
266rm -rf $RPM_BUILD_ROOT
267
268%triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
269%webapp_register apache %{webapp}
270
271%triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
272%webapp_unregister apache %{webapp}
273
274%triggerin gitweb -- apache < 2.2.0, apache-base
275%webapp_register httpd %{webapp}
276
277%triggerun gitweb -- apache < 2.2.0, apache-base
278%webapp_unregister httpd %{webapp}
279
280%files
281%defattr(644,root,root,755)
282%doc README contrib
283%if %{with doc}
284%doc Documentation/{[!g]*,g[!i]*,git,git[!k]*}.html Documentation/howto Documentation/technical
285%{_mandir}/man1/git-*.1*
286%{_mandir}/man5/gitattributes.5*
287%{_mandir}/man5/gitignore.5*
288%{_mandir}/man5/gitmodules.5*
289%{_mandir}/man7/git.7*
290%endif
291%attr(755,root,root) %{_bindir}/git
292%attr(755,root,root) %{_bindir}/git-*
293%{_datadir}/%{name}
294%{_datadir}/git-gui
295%{_sharedstatedir}/git
296
297%files devel
298%defattr(644,root,root,755)
299%{_includedir}/*
300%{_libdir}/*.a
301
302%files gitk
303%defattr(644,root,root,755)
304%if %{with doc}
305%doc Documentation/gitk.html
306%{_mandir}/man1/gitk.1*
307%endif
308%attr(755,root,root) %{_bindir}/gitk
309
310%files gitweb
311%defattr(644,root,root,755)
312%doc gitweb/{README,INSTALL}
313%dir %{webappdir}
314%config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
315%config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
316%config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
317%attr(755,root,root) %{cgibindir}/gitweb.cgi
318%{appdir}
319
320%files gitview
321%defattr(644,root,root,755)
322%doc contrib/gitview/gitview.txt
323%attr(755,root,root) %{_bindir}/gitview
324
325%files -n bash-completion-git
326%defattr(644,root,root,755)
327%{_sysconfdir}/bash_completion.d/*
328
329%files -n perl-Git
330%defattr(644,root,root,755)
331%{perl_vendorlib}/Git.pm
332%{_mandir}/man3/Git.3pm*
333
334%files -n vim-syntax-gitcommit
335%defattr(644,root,root,755)
336%doc contrib/vim/README
337%{_datadir}/vim/vimfiles/syntax/*
This page took 0.029284 seconds and 4 git commands to generate.