]> git.pld-linux.org Git - packages/git-core.git/blame_incremental - git-core.spec
up to 2.7.2
[packages/git-core.git] / git-core.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without tests # don't perform make test
4%bcond_with tests_cvs # perform tests which use CVS
5%bcond_without tests_svn # perform tests which use subversion
6%bcond_without doc # skip building/packaging docs/manuals (takes some time)
7%bcond_without pcre # perl-compatible regexes support
8%bcond_without gnome_keyring # build without gnome keyring support
9
10# for AC: --without doc --without gnome_keyring --without tests
11
12%include /usr/lib/rpm/macros.perl
13Summary: Distributed version control system focused on speed, effectivity and usability
14Summary(pl.UTF-8): Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
15Name: git-core
16Version: 2.7.2
17Release: 1
18License: GPL v2
19Group: Development/Tools
20Source0: http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.gz
21# Source0-md5: 162ddc6c9b243899ad67ebd6b1c166b1
22Source1: %{name}-gitweb.conf
23Source2: %{name}-gitweb-httpd.conf
24Source3: %{name}-gitweb-lighttpd.conf
25Source4: %{name}.sysconfig
26Source5: %{name}.inet
27Source6: %{name}.init
28Source7: gitolite.pl
29Patch0: %{name}-tests.patch
30Patch1: %{name}-key-bindings.patch
31Patch2: %{name}-sysconfdir.patch
32Patch3: cherry-picked-commitlog.patch
33Patch4: %{name}-svn-exit-errors.patch
34Patch5: %{name}-test-grep.patch
35URL: http://git-scm.com/
36BuildRequires: autoconf >= 2.59
37BuildRequires: automake
38BuildRequires: curl-devel
39BuildRequires: expat-devel
40BuildRequires: gettext-tools
41%if %{with gnome_keyring}
42BuildRequires: libgnome-keyring-devel
43BuildRequires: pkgconfig
44%endif
45BuildRequires: openssl-devel
46%{?with_pcre:BuildRequires: pcre-devel}
47BuildRequires: perl-Error > 0.15
48BuildRequires: perl-base
49BuildRequires: python-devel
50BuildRequires: rpm-perlprov >= 4.1-13
51BuildRequires: rpm-pythonprov
52BuildRequires: rpmbuild(macros) >= 1.673
53BuildRequires: tcl
54BuildRequires: zlib-devel
55%if %{with doc}
56BuildRequires: asciidoc >= 7.1.2-3
57BuildRequires: docbook-dtd45-xml
58BuildRequires: xmlto
59%endif
60%if %{with tests}
61%if %{with tests_cvs}
62# tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
63BuildRequires: cvs-gnu-client < 1.13
64BuildRequires: cvs-gnu-client >= 1.12
65%endif
66%if %{with tests_svn}
67BuildRequires: perl-subversion
68BuildRequires: subversion
69%endif
70Conflicts: pdksh < 5.2.14-46
71%endif
72# git-sh-setup: sane_grep
73Requires: grep
74# git-pull: printf
75Requires: coreutils
76Requires: openssh-clients
77Requires: perl-Error
78Requires: perl-Git = %{version}-%{release}
79Requires: sed
80Suggests: git-core-bzr
81Suggests: git-core-cvs
82Suggests: git-core-hg
83Suggests: git-core-p4
84Suggests: git-core-svn
85Suggests: less
86Suggests: rsync
87Obsoletes: python-Git
88BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
89
90# html docs have links to txt files
91%define _noautocompressdoc *.txt
92
93%define webapp gitweb
94%define webappdir %{_sysconfdir}/webapps/%{webapp}
95%define appdir %{_datadir}/%{webapp}
96%define cgibindir %{_prefix}/lib/cgi-bin
97%define gitcoredir %{_prefix}/lib/%{name}
98%define _libexecdir %{_prefix}/lib
99
100%description
101"git" can mean anything, depending on your mood.
102
103- random three-letter combination that is pronounceable, and not
104 actually used by any common UNIX command. The fact that it is a
105 mispronunciation of "get" may or may not be relevant.
106- stupid. contemptible and despicable. simple. Take your pick from the
107 dictionary of slang.
108- "global information tracker": you're in a good mood, and it actually
109 works for you. Angels sing, and a light suddenly fills the room.
110- "goddamn idiotic truckload of sh*t": when it breaks
111
112This is a stupid (but extremely fast) directory content manager. It
113doesn't do a whole lot, but what it 'does' do is track directory
114contents efficiently.
115
116%description -l pl.UTF-8
117"git" może oznaczać cokolwiek, w zależności od nastroju.
118
119- losową kombinację trzech liter, która jest wymawialna i właściwie
120 nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
121 błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
122- głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
123- "global information tracker" (narzędzie do globalnego śledzenia
124 informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
125 Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
126- "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
127 g*) - kiedy się zepsuje.
128
129Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
130Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
131katalogu.
132
133%package doc
134Summary: Documentation for git-core
135Summary(pl.UTF-8): Dokumentacja do git-core
136Group: Documentation
137%if "%{_rpmversion}" >= "5"
138BuildArch: noarch
139%endif
140
141%description doc
142Documentation for git-core.
143
144%description doc -l pl.UTF-8
145Dokumentacja do git-core.
146
147%package daemon-inetd
148Summary: Files necessary to run git-daemon as an inetd service
149Summary(pl.UTF-8): Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
150Group: Networking/Daemons
151Requires: %{name} = %{version}-%{release}
152Requires: setup >= 2.4.11-1
153Provides: git-core-daemon
154Obsoletes: git-core-daemon
155Obsoletes: git-core-daemon-standalone
156%if "%{_rpmversion}" >= "5"
157BuildArch: noarch
158%endif
159
160%description daemon-inetd
161Git-daemon is a really simple TCP git daemon that can serve git
162repositories. This package provides all necessarry files to run
163git-daemon as an inetd service.
164
165%description daemon-inetd -l pl.UTF-8
166Git-daemon to prosty demon git korzystający z protokołu TCP do
167udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
168do uruchomienia git-demona w trybie usługi inetd.
169
170%package daemon-standalone
171Summary: Files necessary to run git-daemon as a standalone service
172Summary(pl.UTF-8): Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
173Group: Networking/Daemons
174Requires: %{name} = %{version}-%{release}
175Provides: git-core-daemon
176Obsoletes: git-core-daemon
177Obsoletes: git-core-daemon-inetd
178%if "%{_rpmversion}" >= "5"
179BuildArch: noarch
180%endif
181
182%description daemon-standalone
183Git-daemon is a really simple TCP git daemon that can serve git
184repositories. This package provides all necessarry files to run
185git-daemon as an standalone service.
186
187%description daemon-standalone -l pl.UTF-8
188Git-daemon to prosty demon git korzystający z protokołu TCP do
189udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
190do uruchomienia git-daemona w trybie usługi samodzielnej.
191
192%package devel
193Summary: Git library with header files
194Summary(pl.UTF-8): Biblioteka Gita oraz pliki nagłówkowe
195Group: Development/Libraries
196Requires: zlib-devel
197
198%description devel
199Git library with header files.
200
201%description devel -l pl.UTF-8
202Biblioteka Gita oraz pliki nagłówkowe.
203
204%package gitk
205Summary: Tcl/Tk interface to the Git version control system
206Summary(pl.UTF-8): Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
207Group: Development/Tools
208Requires: %{name} = %{version}-%{release}
209Requires: tk
210%if "%{_rpmversion}" >= "5"
211BuildArch: noarch
212%endif
213
214%description gitk
215gitk displays changes in a repository or a selected set of commits.
216This includes visualizing the commit graph, showing information
217related to each commit, and the files in the trees of each revision.
218
219Historically, gitk was the first repository browser. It's written in
220Tcl/Tk and started off in a separate repository but was later merged
221into the main git repository.
222
223%description gitk -l pl.UTF-8
224gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
225Oznacza to wizualizację grafu commitów, wyświetlanie informacji
226związanych z każdym z commitów oraz listę plików dla każdej rewizji.
227
228Z historycznego punktu widzenia gitk był pierwszą przeglądarką
229repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
230osobnym repozytorium, ale z czasem został włączony do głównego
231repozytorium gita.
232
233%package gitweb
234Summary: Web frontend to git
235Summary(pl.UTF-8): Frontend WWW do gita
236Group: Development/Tools
237Requires: %{name} = %{version}-%{release}
238Requires: webapps
239Requires: webserver(access)
240Requires: webserver(alias)
241Requires: webserver(cgi)
242Suggests: webserver(setenv)
243%if "%{_rpmversion}" >= "5"
244BuildArch: noarch
245%endif
246
247%description gitweb
248This package provides a web interface for browsing git repositories.
249
250%description gitweb -l pl.UTF-8
251Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
252
253%package gitview
254Summary: A GTK+ based repository browser for git
255Summary(pl.UTF-8): Oparta na GTK+ przeglądarka repozytorium gita
256Group: Development/Tools
257Requires: %{name} = %{version}-%{release}
258Requires: python >= 1:2.4
259Requires: python-pycairo >= 1.0
260Requires: python-pygobject
261Requires: python-pygtk-gtk >= 2:2.8
262Suggests: python-gnome-desktop-gtksourceview
263%if "%{_rpmversion}" >= "5"
264BuildArch: noarch
265%endif
266
267%description gitview
268A GTK+ based repository browser for git.
269
270%description gitview -l pl.UTF-8
271Oparta na GTK+ przeglądarka repozytorium gita.
272
273%package gui
274Summary: Tcl/Tk interface to the Git version control system
275Summary(pl.UTF-8): Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
276Group: Development/Tools
277Requires: %{name} = %{version}-%{release}
278Requires: tk
279Requires: xdg-utils
280Suggests: meld
281%if "%{_rpmversion}" >= "5"
282BuildArch: noarch
283%endif
284
285%description gui
286Displays changes in a repository or a selected set of commits. This
287includes visualizing the commit graph, showing information related to
288each commit, and the files in the trees of each revision.
289
290Historically, gitk was the first repository browser. It's written in
291Tcl/Tk and started off in a separate repository but was later merged
292into the main git repository.
293
294%description gui -l pl.UTF-8
295Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
296to wizualizację grafu commitów, wyświetlanie informacji związanych z
297każdym z commitów oraz listę plików dla każdej rewizji.
298
299Z punktu widzenia historii, gitk był pierwszą przeglądarką
300repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
301osobnym repozytorium, ale z czasem został włączony do głównego
302repozytorium gita.
303
304%package arch
305Summary: Git tools for importing Arch repositories
306Summary(pl.UTF-8): Narzędzia Gita do importowania repozytoriów Archa
307Group: Development/Tools
308Requires: %{name} = %{version}-%{release}
309Requires: tla
310%if "%{_rpmversion}" >= "5"
311BuildArch: noarch
312%endif
313
314%description arch
315Git tools for importing Arch repositories.
316
317%description arch -l pl.UTF-8
318Narzędzia Gita do importowania repozytoriów Archa.
319
320%package bzr
321Summary: Git tools for working with bzr repositories
322Summary(pl.UTF-8): Narzędzia Gita do pracy z repozytoriami bzr
323Group: Development/Tools
324Requires: %{name} = %{version}-%{release}
325Requires: bzr
326%if "%{_rpmversion}" >= "5"
327BuildArch: noarch
328%endif
329
330%description bzr
331Git tools for working with bzr repositories.
332
333%description bzr -l pl.UTF-8
334Narzędzia Gita do pracy z repozytoriami bzr.
335
336%package cvs
337Summary: CVS support for Git
338Summary(pl.UTF-8): Obsługa CVS dla Gita
339Group: Development/Tools
340Requires: %{name} = %{version}-%{release}
341Requires: cvsps >= 2.1-2
342Requires: rcs
343%if "%{_rpmversion}" >= "5"
344BuildArch: noarch
345%endif
346
347%description cvs
348CVS support for Git.
349
350%description cvs -l pl.UTF-8
351Obsługa CVS dla Gita.
352
353%package hg
354Summary: Git tools for working with mercurial repositories
355Summary(pl.UTF-8): Narzędzia Gita do pracy z repozytoriami mercuriala
356Group: Development/Tools
357Requires: %{name} = %{version}-%{release}
358Requires: mercurial >= 1.8
359%if "%{_rpmversion}" >= "5"
360BuildArch: noarch
361%endif
362
363%description hg
364Git tools for working with mercurial repositories.
365
366%description hg -l pl.UTF-8
367Narzędzia Gita do pracy z repozytoriami mercuriala.
368
369%package p4
370Summary: Git tools for working with Perforce depots
371Summary(pl.UTF-8): Narzędzia Gita do pracy z magazynami Perforce'a
372Group: Development/Tools
373Requires: %{name} = %{version}-%{release}
374%if "%{_rpmversion}" >= "5"
375BuildArch: noarch
376%endif
377
378%description p4
379Git tools for working with Perforce depots.
380
381%description p4 -l pl.UTF-8
382Narzędzia Gita do pracy z magazynami Perforce'a.
383
384%package svn
385Summary: Subversion support for Git
386Summary(pl.UTF-8): Obsługa Subversion dla Gita
387Group: Development/Tools
388Requires: %{name} = %{version}-%{release}
389Requires: perl-Encode
390Requires: perl-Term-ReadKey
391
392%description svn
393Subversion support for Git.
394
395%description svn -l pl.UTF-8
396Obsługa Subversion dla Gita.
397
398%package email
399Summary: Git tools for sending email
400Summary(pl.UTF-8): Narzędzia Gita do wysyłania poczty
401Group: Development/Tools
402Requires: %{name} = %{version}-%{release}
403
404%description email
405Git tools for sending email.
406
407%description email -l pl.UTF-8
408Narzędzia Gita do wysyłania poczty.
409
410%package -n bash-completion-git
411Summary: bash-completion for git
412Summary(pl.UTF-8): bashowe uzupełnianie nazw dla gita
413Group: Applications/Shells
414Requires: %{name} = %{version}-%{release}
415Requires: bash-completion >= 2.0
416%if "%{_rpmversion}" >= "5"
417BuildArch: noarch
418%endif
419
420%description -n bash-completion-git
421This package provides bash-completion for git.
422
423%description -n bash-completion-git -l pl.UTF-8
424Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
425
426%package -n perl-Git
427Summary: Perl interface to the Git version control system
428Summary(pl.UTF-8): Perlowy interfejs do systemu kontroli wersji Git
429Group: Development/Languages/Perl
430Obsoletes: perl-git-core
431
432%description -n perl-Git
433This module provides Perl scripts easy way to interface the Git
434version control system. The modules have an easy and well-tested way
435to call arbitrary Git commands; in the future, the interface will also
436provide specialized methods for doing easily operations which are not
437totally trivial to do over the generic command interface.
438
439%description -n perl-Git -l pl.UTF-8
440Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
441wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
442dowolne polecenia Gita; w przyszłości interfejs udostępni także
443specjalne metody do łatwego wykonywania operacji nietrywialnych do
444wykonania przy użyciu ogólnego interfejsu poleceń.
445
446%package -n gnome-keyring-git-core
447Summary: GNOME Keyring authentication provider for Git
448Summary(pl.UTF-8): Moduł uwierzytelniający GNOME Keyring dla Git
449Group: X11/Applications
450URL: http://git-scm.com/docs/gitcredentials.html
451Requires: %{name} = %{version}-%{release}
452
453%description -n gnome-keyring-git-core
454Authentication provider module for Git which allows git client to
455authenticate using GNOME Keyring.
456
457You need to register it with:
458- git config --global credential.helper gnome-keyring
459
460%description -n gnome-keyring-git-core -l pl.UTF-8
461Moduł uwierzytelniający dla Subversion pozwalający klientom git
462uwierzytelniać się przy użyciu mechanizmu GNOME Keyring.
463
464Moduł trzeba zarejestrować poleceniem:
465- git config --global credential.helper gnome-keyring
466
467%prep
468%setup -q -n git-%{version}
469%patch0 -p1
470%patch1 -p0
471%patch2 -p1
472%patch3 -p1
473%patch4 -p1
474%patch5 -p0
475
476%{__rm} {Documentation/technical,contrib/emacs,contrib/credential/gnome-keyring}/.gitignore
477
478# we build things in contrib but want to have it clean for doc purporses, too
479cp -a contrib contrib-doc
480
481%build
482%{__aclocal}
483%{__autoconf}
484%configure \
485 --sysconfdir=%{_sysconfdir}/git-core \
486 %{?with_pcre:--with-libpcre} \
487 --with-openssl
488
489echo "BLK_SHA1=1" >> config.mak
490
491%{__make} \
492 INSTALLDIRS=vendor \
493 GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
494 GITWEB_PROJECTROOT="/var/lib/git" \
495 GITWEB_CSS="/gitweb/gitweb.css" \
496 GITWEB_LOGO="/gitweb/git-logo.png" \
497 GITWEB_FAVICON="/gitweb/git-favicon.png" \
498 V=1
499
500%{__make} -C contrib/subtree
501
502%if %{with gnome_keyring}
503%{__make} -C contrib/credential/gnome-keyring
504%endif
505
506%if %{with doc}
507%{__make} -C Documentation \
508 MAN_BASE_URL=file://%{_docdir}/%{name}-doc-%{version}/ \
509 V=1
510%endif
511
512%if %{with tests}
513%if %{without tests_cvs}
514%{__rm} t/t*cvs*.sh || :
515%endif
516%{!?with_tests_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
517%endif
518
519%install
520rm -rf $RPM_BUILD_ROOT
521install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
522install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
523install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
524install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
525cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
526[init]
527 templatedir = %{_sysconfdir}/%{name}/templates
528EOF
529
530%{__make} install \
531 INSTALLDIRS=vendor \
532 DESTDIR=$RPM_BUILD_ROOT
533
534%if %{with doc}
535%{__make} -C Documentation install \
536 DESTDIR=$RPM_BUILD_ROOT
537%endif
538
539# copy templates except sample hooks
540cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
541%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
542
543# header files and lib
544cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
545cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
546cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
547install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
548cp -p block-sha1/sha1.h $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
549cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
550cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
551cp -p {Makefile,config.mak,config.mak.autogen,config.mak.uname} $RPM_BUILD_ROOT%{_includedir}/%{name}
552
553%{__make} -C contrib/subtree install \
554 libexecdir=%{gitcoredir} \
555 DESTDIR=$RPM_BUILD_ROOT
556
557%if %{with doc}
558%{__make} -C contrib/subtree install-man \
559 DESTDIR=$RPM_BUILD_ROOT
560%endif
561
562%if %{with gnome_keyring}
563install -p contrib/credential/gnome-keyring/git-credential-gnome-keyring $RPM_BUILD_ROOT%{gitcoredir}
564%endif
565
566# bash completion
567install -d $RPM_BUILD_ROOT%{bash_compdir}
568cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{bash_compdir}/git
569
570# Install git-prompt.sh
571install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/contrib/completion
572cp -p contrib/completion/git-prompt.sh $RPM_BUILD_ROOT%{_datadir}/%{name}/contrib/completion
573
574# Install bzr and hg remote helpers from contrib
575install -p contrib/remote-helpers/git-remote-{bzr,hg} $RPM_BUILD_ROOT%{gitcoredir}
576
577# gitweb
578mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
579ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
580cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
581cp -p %{SOURCE7} $RPM_BUILD_ROOT%{webappdir}/gitolite.pl
582cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
583cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
584cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
585
586# gitview
587install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
588
589# git-daemon related files
590cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
591cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
592install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
593
594# paths cleanup
595sed -e 's,@libdir@/git-core,%{gitcoredir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
596sed -e 's,@libdir@/git-core,%{gitcoredir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
597
598# hardlink
599ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
600ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
601ln -f $RPM_BUILD_ROOT{%{gitcoredir},%{_bindir}}/git-shell
602ln -f $RPM_BUILD_ROOT{%{gitcoredir},%{_bindir}}/git-upload-pack
603
604# remove unneeded files
605%{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
606%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
607%py_postclean
608
609mv $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
610%find_lang git
611
612%clean
613rm -rf $RPM_BUILD_ROOT
614
615%post daemon-inetd
616%service -q rc-inetd reload
617
618%postun daemon-inetd
619if [ "$1" = "0" ]; then
620 %service -q rc-inetd reload
621fi
622
623%post daemon-standalone
624/sbin/chkconfig --add git-daemon
625%service git-daemon restart "git-daemon"
626
627%preun daemon-standalone
628if [ "$1" = "0" ]; then
629 %service git-daemon stop
630 /sbin/chkconfig --del git-daemon
631fi
632
633%triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
634%webapp_register apache %{webapp}
635
636%triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
637%webapp_unregister apache %{webapp}
638
639%triggerin gitweb -- apache < 2.2.0, apache-base
640%webapp_register httpd %{webapp}
641
642%triggerun gitweb -- apache < 2.2.0, apache-base
643%webapp_unregister httpd %{webapp}
644
645%triggerin gitweb -- lighttpd
646%webapp_register lighttpd %{webapp}
647
648%triggerun gitweb -- lighttpd
649%webapp_unregister lighttpd %{webapp}
650
651%files -f git.lang
652%defattr(644,root,root,755)
653%doc README contrib-doc
654%attr(755,root,root) %{_bindir}/git
655%attr(755,root,root) %{_bindir}/git-receive-pack
656%attr(755,root,root) %{_bindir}/git-shell
657%attr(755,root,root) %{_bindir}/git-upload-archive
658%attr(755,root,root) %{_bindir}/git-upload-pack
659%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
660
661%if %{with doc}
662%{_mandir}/man1/git-*.1*
663%exclude %{_mandir}/man1/git-archimport.1*
664%exclude %{_mandir}/man1/git-svn.1*
665%exclude %{_mandir}/man1/git-cvs*.1*
666%exclude %{_mandir}/man1/git-imap-send*.1*
667%exclude %{_mandir}/man1/*email*.1*
668%{_mandir}/man1/git.1*
669%{_mandir}/man1/gitremote-helpers.1*
670%{_mandir}/man5/gitattributes.5*
671%{_mandir}/man5/githooks.5*
672%{_mandir}/man5/gitignore.5*
673%{_mandir}/man5/gitmodules.5*
674%{_mandir}/man5/gitrepository-layout.5*
675%{_mandir}/man7/gitcli.7*
676%{_mandir}/man7/gitcore-tutorial.7*
677%{_mandir}/man7/gitcredentials.7*
678%{_mandir}/man7/gitdiffcore.7*
679%{_mandir}/man7/giteveryday.7*
680%{_mandir}/man7/gitglossary.7*
681%{_mandir}/man7/gitnamespaces.7*
682%{_mandir}/man7/gitrevisions.7*
683%{_mandir}/man7/gittutorial-2.7*
684%{_mandir}/man7/gittutorial.7*
685%{_mandir}/man7/gitworkflows.7*
686%endif
687
688%dir %{gitcoredir}
689%attr(755,root,root) %{gitcoredir}/*-*
690%attr(755,root,root) %{gitcoredir}/git
691%dir %{gitcoredir}/mergetools
692%{gitcoredir}/mergetools/*
693
694%{_datadir}/%{name}
695%{_localstatedir}/lib/git
696
697# subpackages
698%exclude %{gitcoredir}/*email*
699%exclude %{gitcoredir}/*p4*
700%exclude %{gitcoredir}/git-archimport
701%exclude %{gitcoredir}/git-cvs*
702%exclude %{gitcoredir}/git-gui
703%exclude %{gitcoredir}/git-imap-send
704%exclude %{gitcoredir}/git-instaweb
705%exclude %{gitcoredir}/git-remote-bzr
706%exclude %{gitcoredir}/git-remote-hg
707%exclude %{gitcoredir}/git-remote-testsvn
708%exclude %{gitcoredir}/git-svn
709%exclude %{gitcoredir}/mergetools/p4merge
710%if %{with gnome_keyring}
711%exclude %{gitcoredir}/git-credential-gnome-keyring
712%endif
713
714%if %{with doc}
715%files doc
716%defattr(644,root,root,755)
717%doc Documentation/RelNotes*
718%doc Documentation/*.html Documentation/howto Documentation/technical
719%endif
720
721%files daemon-inetd
722%defattr(644,root,root,755)
723%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
724
725%files daemon-standalone
726%defattr(644,root,root,755)
727%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
728%attr(754,root, root) /etc/rc.d/init.d/git-daemon
729
730%files devel
731%defattr(644,root,root,755)
732%{_includedir}/%{name}
733%{_libdir}/libgit.a
734%{_libdir}/libgit_xdiff.a
735
736%files gitk
737%defattr(644,root,root,755)
738%if %{with doc}
739%{_mandir}/man1/gitk.1*
740%endif
741%attr(755,root,root) %{_bindir}/gitk
742%dir %{_datadir}/gitk
743%dir %{_datadir}/gitk/lib
744%dir %{_datadir}/gitk/lib/msgs
745%lang(bg) %{_datadir}/gitk/lib/msgs/bg.msg
746%lang(ca) %{_datadir}/gitk/lib/msgs/ca.msg
747%lang(de) %{_datadir}/gitk/lib/msgs/de.msg
748%lang(es) %{_datadir}/gitk/lib/msgs/es.msg
749%lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
750%lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
751%lang(it) %{_datadir}/gitk/lib/msgs/it.msg
752%lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
753%lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
754%lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
755%lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
756%lang(vi) %{_datadir}/gitk/lib/msgs/vi.msg
757
758%files gitweb
759%defattr(644,root,root,755)
760%doc gitweb/{README,INSTALL}
761%dir %{webappdir}
762%config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
763%config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
764%config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
765%config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
766%config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitolite.pl
767%attr(755,root,root) %{cgibindir}/gitweb.cgi
768%{appdir}
769%attr(755,root,root) %{gitcoredir}/git-instaweb
770%if %{with doc}
771%{_mandir}/man1/gitweb.1*
772%{_mandir}/man5/gitweb.conf.5*
773%endif
774
775%files gitview
776%defattr(644,root,root,755)
777%doc contrib/gitview/gitview.txt
778%attr(755,root,root) %{_bindir}/gitview
779
780%files gui
781%defattr(644,root,root,755)
782%attr(755,root,root) %{gitcoredir}/git-gui
783%dir %{_datadir}/git-gui
784%dir %{_datadir}/git-gui/lib
785%dir %{_datadir}/git-gui/lib/msgs
786%{_datadir}/git-gui/lib/git-gui.ico
787%{_datadir}/git-gui/lib/tclIndex
788%{_datadir}/git-gui/lib/*.js
789%{_datadir}/git-gui/lib/*.tcl
790%lang(bg) %{_datadir}/git-gui/lib/msgs/bg.msg
791%lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
792%lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
793%lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
794%lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
795%lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
796%lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
797%lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
798%lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
799%lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
800%lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
801%lang(vi) %{_datadir}/git-gui/lib/msgs/vi.msg
802%lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
803
804%files arch
805%defattr(644,root,root,755)
806%attr(755,root,root) %{gitcoredir}/git-archimport
807%if %{with doc}
808%{_mandir}/man1/git-archimport.1*
809%endif
810
811%files bzr
812%defattr(644,root,root,755)
813%attr(755,root,root) %{gitcoredir}/git-remote-bzr
814
815%files cvs
816%defattr(644,root,root,755)
817%attr(755,root,root) %{_bindir}/git-cvsserver
818%attr(755,root,root) %{gitcoredir}/git-cvs*
819%if %{with doc}
820%{_mandir}/man1/git-cvs*.1*
821%{_mandir}/man7/gitcvs-migration.7*
822%endif
823
824%files hg
825%defattr(644,root,root,755)
826%attr(755,root,root) %{gitcoredir}/git-remote-hg
827
828%files p4
829%defattr(644,root,root,755)
830%attr(755,root,root) %{gitcoredir}/git-p4
831%attr(755,root,root) %{gitcoredir}/mergetools/p4merge
832
833%files svn
834%defattr(644,root,root,755)
835%attr(755,root,root) %{gitcoredir}/git-svn
836%attr(755,root,root) %{gitcoredir}/git-remote-testsvn
837%{perl_vendorlib}/Git/SVN
838%{perl_vendorlib}/Git/SVN.pm
839%if %{with doc}
840%{_mandir}/man1/git-svn.1*
841%endif
842
843%files email
844%defattr(644,root,root,755)
845%attr(755,root,root) %{gitcoredir}/git-imap-send
846%attr(755,root,root) %{gitcoredir}/*email*
847%if %{with doc}
848%{_mandir}/man1/*email*.1*
849%{_mandir}/man1/*imap-send*.1*
850%endif
851
852%files -n bash-completion-git
853%defattr(644,root,root,755)
854%{bash_compdir}/git
855
856%files -n perl-Git
857%defattr(644,root,root,755)
858%{perl_vendorlib}/Git.pm
859%dir %{perl_vendorlib}/Git
860%{perl_vendorlib}/Git/I18N.pm
861%{perl_vendorlib}/Git/IndexInfo.pm
862%{_mandir}/man3/Git*.3pm*
863
864%if %{with gnome_keyring}
865%files -n gnome-keyring-git-core
866%defattr(644,root,root,755)
867%attr(755,root,root) %{gitcoredir}/git-credential-gnome-keyring
868%endif
This page took 0.03508 seconds and 4 git commands to generate.