]> git.pld-linux.org Git - packages/git-core.git/blame_incremental - git-core.spec
up to 2.5.1
[packages/git-core.git] / git-core.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without tests # don't perform make test
4%bcond_with tests_cvs # perform tests which use CVS
5%bcond_without tests_svn # perform tests which use subversion
6%bcond_without doc # skip building/packaging docs/manuals (takes some time)
7%bcond_without pcre # perl-compatible regexes support
8%bcond_without gnome_keyring # build without gnome keyring support
9
10# for AC: --without doc --without gnome_keyring --without tests
11
12%include /usr/lib/rpm/macros.perl
13Summary: Distributed version control system focused on speed, effectivity and usability
14Summary(pl.UTF-8): Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
15Name: git-core
16Version: 2.5.1
17Release: 1
18License: GPL v2
19Group: Development/Tools
20Source0: http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.gz
21# Source0-md5: 196d3de058d9ba5808a5e608b3af8076
22Source1: %{name}-gitweb.conf
23Source2: %{name}-gitweb-httpd.conf
24Source3: %{name}-gitweb-lighttpd.conf
25Source4: %{name}.sysconfig
26Source5: %{name}.inet
27Source6: %{name}.init
28Source7: gitolite.pl
29Patch0: %{name}-tests.patch
30Patch1: %{name}-key-bindings.patch
31Patch2: %{name}-sysconfdir.patch
32Patch3: cherry-picked-commitlog.patch
33Patch4: %{name}-svn-exit-errors.patch
34URL: http://git-scm.com/
35BuildRequires: autoconf >= 2.59
36BuildRequires: automake
37BuildRequires: curl-devel
38BuildRequires: expat-devel
39BuildRequires: gettext-tools
40%if %{with gnome_keyring}
41BuildRequires: libgnome-keyring-devel
42BuildRequires: pkgconfig
43%endif
44BuildRequires: openssl-devel
45%{?with_pcre:BuildRequires: pcre-devel}
46BuildRequires: perl-Error > 0.15
47BuildRequires: perl-base
48BuildRequires: python-devel
49BuildRequires: rpm-perlprov >= 4.1-13
50BuildRequires: rpm-pythonprov
51BuildRequires: rpmbuild(macros) >= 1.673
52BuildRequires: tcl
53BuildRequires: zlib-devel
54%if %{with doc}
55BuildRequires: asciidoc >= 7.1.2-3
56BuildRequires: docbook-dtd45-xml
57BuildRequires: xmlto
58%endif
59%if %{with tests}
60%if %{with tests_cvs}
61# tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
62BuildRequires: cvs-gnu-client < 1.13
63BuildRequires: cvs-gnu-client >= 1.12
64%endif
65%if %{with tests_svn}
66BuildRequires: perl-subversion
67BuildRequires: subversion
68%endif
69Conflicts: pdksh < 5.2.14-46
70%endif
71# git-sh-setup: sane_grep
72Requires: grep
73# git-pull: printf
74Requires: coreutils
75Requires: openssh-clients
76Requires: perl-Error
77Requires: perl-Git = %{version}-%{release}
78Requires: sed
79Suggests: git-core-bzr
80Suggests: git-core-cvs
81Suggests: git-core-hg
82Suggests: git-core-p4
83Suggests: git-core-svn
84Suggests: less
85Suggests: rsync
86Obsoletes: python-Git
87BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
88
89# html docs have links to txt files
90%define _noautocompressdoc *.txt
91
92%define webapp gitweb
93%define webappdir %{_sysconfdir}/webapps/%{webapp}
94%define appdir %{_datadir}/%{webapp}
95%define cgibindir %{_prefix}/lib/cgi-bin
96%define gitcoredir %{_libdir}/%{name}
97
98%description
99"git" can mean anything, depending on your mood.
100
101- random three-letter combination that is pronounceable, and not
102 actually used by any common UNIX command. The fact that it is a
103 mispronunciation of "get" may or may not be relevant.
104- stupid. contemptible and despicable. simple. Take your pick from the
105 dictionary of slang.
106- "global information tracker": you're in a good mood, and it actually
107 works for you. Angels sing, and a light suddenly fills the room.
108- "goddamn idiotic truckload of sh*t": when it breaks
109
110This is a stupid (but extremely fast) directory content manager. It
111doesn't do a whole lot, but what it 'does' do is track directory
112contents efficiently.
113
114%description -l pl.UTF-8
115"git" może oznaczać cokolwiek, w zależności od nastroju.
116
117- losową kombinację trzech liter, która jest wymawialna i właściwie
118 nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
119 błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
120- głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
121- "global information tracker" (narzędzie do globalnego śledzenia
122 informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
123 Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
124- "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
125 g*) - kiedy się zepsuje.
126
127Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
128Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
129katalogu.
130
131%package doc
132Summary: Documentation for git-core
133Summary(pl.UTF-8): Dokumentacja do git-core
134Group: Documentation
135
136%description doc
137Documentation for git-core.
138
139%description doc -l pl.UTF-8
140Dokumentacja do git-core.
141
142%description doc -l fr.UTF-8
143Javadoc pour git-core.
144
145%package daemon-inetd
146Summary: Files necessary to run git-daemon as an inetd service
147Summary(pl.UTF-8): Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
148Group: Networking/Daemons
149Requires: %{name} = %{version}-%{release}
150Requires: setup >= 2.4.11-1
151Provides: git-core-daemon
152Obsoletes: git-core-daemon
153Obsoletes: git-core-daemon-standalone
154
155%description daemon-inetd
156Git-daemon is a really simple TCP git daemon that can serve git
157repositories. This package provides all necessarry files to run
158git-daemon as an inetd service.
159
160%description daemon-inetd -l pl.UTF-8
161Git-daemon to prosty demon git korzystający z protokołu TCP do
162udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
163do uruchomienia git-demona w trybie usługi inetd.
164
165%package daemon-standalone
166Summary: Files necessary to run git-daemon as a standalone service
167Summary(pl.UTF-8): Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
168Group: Networking/Daemons
169Requires: %{name} = %{version}-%{release}
170Provides: git-core-daemon
171Obsoletes: git-core-daemon
172Obsoletes: git-core-daemon-inetd
173
174%description daemon-standalone
175Git-daemon is a really simple TCP git daemon that can serve git
176repositories. This package provides all necessarry files to run
177git-daemon as an standalone service.
178
179%description daemon-standalone -l pl.UTF-8
180Git-daemon to prosty demon git korzystający z protokołu TCP do
181udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
182do uruchomienia git-daemona w trybie usługi samodzielnej.
183
184%package devel
185Summary: Git library with header files
186Summary(pl.UTF-8): Biblioteka Gita oraz pliki nagłówkowe
187Group: Development/Libraries
188Requires: zlib-devel
189
190%description devel
191Git library with header files.
192
193%description devel -l pl.UTF-8
194Biblioteka Gita oraz pliki nagłówkowe.
195
196%package gitk
197Summary: Tcl/Tk interface to the Git version control system
198Summary(pl.UTF-8): Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
199Group: Development/Tools
200Requires: %{name} = %{version}-%{release}
201Requires: tk
202
203%description gitk
204gitk displays changes in a repository or a selected set of commits.
205This includes visualizing the commit graph, showing information
206related to each commit, and the files in the trees of each revision.
207
208Historically, gitk was the first repository browser. It's written in
209Tcl/Tk and started off in a separate repository but was later merged
210into the main git repository.
211
212%description gitk -l pl.UTF-8
213gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
214Oznacza to wizualizację grafu commitów, wyświetlanie informacji
215związanych z każdym z commitów oraz listę plików dla każdej rewizji.
216
217Z historycznego punktu widzenia gitk był pierwszą przeglądarką
218repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
219osobnym repozytorium, ale z czasem został włączony do głównego
220repozytorium gita.
221
222%package gitweb
223Summary: Web frontend to git
224Summary(pl.UTF-8): Frontend WWW do gita
225Group: Development/Tools
226Requires: %{name} = %{version}-%{release}
227Requires: webapps
228Requires: webserver(access)
229Requires: webserver(alias)
230Requires: webserver(cgi)
231Suggests: webserver(setenv)
232
233%description gitweb
234This package provides a web interface for browsing git repositories.
235
236%description gitweb -l pl.UTF-8
237Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
238
239%package gitview
240Summary: A GTK+ based repository browser for git
241Summary(pl.UTF-8): Oparta na GTK+ przeglądarka repozytorium gita
242Group: Development/Tools
243Requires: %{name} = %{version}-%{release}
244Requires: python >= 1:2.4
245Requires: python-pycairo >= 1.0
246Requires: python-pygobject
247Requires: python-pygtk-gtk >= 2:2.8
248Suggests: python-gnome-desktop-gtksourceview
249
250%description gitview
251A GTK+ based repository browser for git.
252
253%description gitview -l pl.UTF-8
254Oparta na GTK+ przeglądarka repozytorium gita.
255
256%package gui
257Summary: Tcl/Tk interface to the Git version control system
258Summary(pl.UTF-8): Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
259Group: Development/Tools
260Requires: %{name} = %{version}-%{release}
261Requires: tk
262Requires: xdg-utils
263Suggests: meld
264
265%description gui
266Displays changes in a repository or a selected set of commits. This
267includes visualizing the commit graph, showing information related to
268each commit, and the files in the trees of each revision.
269
270Historically, gitk was the first repository browser. It's written in
271Tcl/Tk and started off in a separate repository but was later merged
272into the main git repository.
273
274%description gui -l pl.UTF-8
275Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
276to wizualizację grafu commitów, wyświetlanie informacji związanych z
277każdym z commitów oraz listę plików dla każdej rewizji.
278
279Z punktu widzenia historii, gitk był pierwszą przeglądarką
280repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
281osobnym repozytorium, ale z czasem został włączony do głównego
282repozytorium gita.
283
284%package arch
285Summary: Git tools for importing Arch repositories
286Summary(pl.UTF-8): Narzędzia Gita do importowania repozytoriów Archa
287Group: Development/Tools
288Requires: %{name} = %{version}-%{release}
289Requires: tla
290
291%description arch
292Git tools for importing Arch repositories.
293
294%description arch -l pl.UTF-8
295Narzędzia Gita do importowania repozytoriów Archa.
296
297%package bzr
298Summary: Git tools for working with bzr repositories
299Summary(pl.UTF-8): Narzędzia Gita do pracy z repozytoriami bzr
300Group: Development/Tools
301Requires: %{name} = %{version}-%{release}
302Requires: bzr
303
304%description bzr
305Git tools for working with bzr repositories.
306
307%description bzr -l pl.UTF-8
308Narzędzia Gita do pracy z repozytoriami bzr.
309
310%package cvs
311Summary: CVS support for Git
312Summary(pl.UTF-8): Obsługa CVS dla Gita
313Group: Development/Tools
314Requires: %{name} = %{version}-%{release}
315Requires: cvsps >= 2.1-2
316Requires: rcs
317
318%description cvs
319CVS support for Git.
320
321%description cvs -l pl.UTF-8
322Obsługa CVS dla Gita.
323
324%package hg
325Summary: Git tools for working with mercurial repositories
326Summary(pl.UTF-8): Narzędzia Gita do pracy z repozytoriami mercuriala
327Group: Development/Tools
328Requires: %{name} = %{version}-%{release}
329Requires: mercurial >= 1.8
330
331%description hg
332Git tools for working with mercurial repositories.
333
334%description hg -l pl.UTF-8
335Narzędzia Gita do pracy z repozytoriami mercuriala.
336
337%package p4
338Summary: Git tools for working with Perforce depots
339Summary(pl.UTF-8): Narzędzia Gita do pracy z magazynami Perforce'a
340Group: Development/Tools
341Requires: %{name} = %{version}-%{release}
342
343%description p4
344Git tools for working with Perforce depots.
345
346%description p4 -l pl.UTF-8
347Narzędzia Gita do pracy z magazynami Perforce'a.
348
349%package svn
350Summary: Subversion support for Git
351Summary(pl.UTF-8): Obsługa Subversion dla Gita
352Group: Development/Tools
353Requires: %{name} = %{version}-%{release}
354Requires: perl-Encode
355Requires: perl-Term-ReadKey
356
357%description svn
358Subversion support for Git.
359
360%description svn -l pl.UTF-8
361Obsługa Subversion dla Gita.
362
363%package email
364Summary: Git tools for sending email
365Summary(pl.UTF-8): Narzędzia Gita do wysyłania poczty
366Group: Development/Tools
367Requires: %{name} = %{version}-%{release}
368
369%description email
370Git tools for sending email.
371
372%description email -l pl.UTF-8
373Narzędzia Gita do wysyłania poczty.
374
375%package -n bash-completion-git
376Summary: bash-completion for git
377Summary(pl.UTF-8): bashowe uzupełnianie nazw dla gita
378Group: Applications/Shells
379Requires: %{name} = %{version}-%{release}
380Requires: bash-completion >= 2.0
381%if "%{_rpmversion}" >= "5"
382BuildArch: noarch
383%endif
384
385%description -n bash-completion-git
386This package provides bash-completion for git.
387
388%description -n bash-completion-git -l pl.UTF-8
389Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
390
391%package -n perl-Git
392Summary: Perl interface to the Git version control system
393Summary(pl.UTF-8): Perlowy interfejs do systemu kontroli wersji Git
394Group: Development/Languages/Perl
395Obsoletes: perl-git-core
396
397%description -n perl-Git
398This module provides Perl scripts easy way to interface the Git
399version control system. The modules have an easy and well-tested way
400to call arbitrary Git commands; in the future, the interface will also
401provide specialized methods for doing easily operations which are not
402totally trivial to do over the generic command interface.
403
404%description -n perl-Git -l pl.UTF-8
405Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
406wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
407dowolne polecenia Gita; w przyszłości interfejs udostępni także
408specjalne metody do łatwego wykonywania operacji nietrywialnych do
409wykonania przy użyciu ogólnego interfejsu poleceń.
410
411%package -n gnome-keyring-git-core
412Summary: GNOME Keyring authentication provider for Git
413Summary(pl.UTF-8): Moduł uwierzytelniający GNOME Keyring dla Git
414Group: X11/Applications
415URL: http://git-scm.com/docs/gitcredentials.html
416Requires: %{name} = %{version}-%{release}
417
418%description -n gnome-keyring-git-core
419Authentication provider module for Git which allows git client to
420authenticate using GNOME Keyring.
421
422You need to register it with:
423- git config --global credential.helper gnome-keyring
424
425%description -n gnome-keyring-git-core -l pl.UTF-8
426Moduł uwierzytelniający dla Subversion pozwalający klientom git
427uwierzytelniać się przy użyciu mechanizmu GNOME Keyring.
428
429Moduł trzeba zarejestrować poleceniem:
430- git config --global credential.helper gnome-keyring
431
432%prep
433%setup -q -n git-%{version}
434%patch0 -p1
435%patch1 -p0
436%patch2 -p1
437%patch3 -p1
438%patch4 -p1
439
440%{__rm} {Documentation/technical,contrib/emacs,contrib/credential/gnome-keyring}/.gitignore
441
442# we build things in contrib but want to have it clean for doc purporses, too
443cp -a contrib contrib-doc
444
445%build
446%{__aclocal}
447%{__autoconf}
448%configure \
449 --sysconfdir=%{_sysconfdir}/git-core \
450 %{?with_pcre:--with-libpcre} \
451 --with-openssl
452
453echo "BLK_SHA1=1" >> config.mak
454
455%{__make} \
456 INSTALLDIRS=vendor \
457 GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
458 GITWEB_PROJECTROOT="/var/lib/git" \
459 GITWEB_CSS="/gitweb/gitweb.css" \
460 GITWEB_LOGO="/gitweb/git-logo.png" \
461 GITWEB_FAVICON="/gitweb/git-favicon.png" \
462 V=1
463
464%{__make} -C contrib/subtree
465
466%if %{with gnome_keyring}
467%{__make} -C contrib/credential/gnome-keyring
468%endif
469
470%if %{with doc}
471%{__make} -C Documentation \
472 MAN_BASE_URL=file://%{_docdir}/%{name}-doc-%{version}/ \
473 V=1
474%endif
475
476%if %{with tests}
477%if %{without tests_cvs}
478%{__rm} t/t*cvs*.sh || :
479%endif
480%{!?with_tests_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
481%endif
482
483%install
484rm -rf $RPM_BUILD_ROOT
485install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
486install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
487install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
488install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
489cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
490[init]
491 templatedir = %{_sysconfdir}/%{name}/templates
492EOF
493
494%{__make} install \
495 INSTALLDIRS=vendor \
496 DESTDIR=$RPM_BUILD_ROOT
497
498%if %{with doc}
499%{__make} -C Documentation install \
500 DESTDIR=$RPM_BUILD_ROOT
501%endif
502
503# copy templates except sample hooks
504cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
505%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
506
507# header files and lib
508cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
509cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
510cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
511install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
512cp -p block-sha1/sha1.h $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
513cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
514cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
515cp -p {Makefile,config.mak,config.mak.autogen,config.mak.uname} $RPM_BUILD_ROOT%{_includedir}/%{name}
516
517%{__make} -C contrib/subtree install \
518 libexecdir=%{gitcoredir} \
519 DESTDIR=$RPM_BUILD_ROOT
520
521%if %{with doc}
522%{__make} -C contrib/subtree install-man \
523 DESTDIR=$RPM_BUILD_ROOT
524%endif
525
526%if %{with gnome_keyring}
527install -p contrib/credential/gnome-keyring/git-credential-gnome-keyring $RPM_BUILD_ROOT%{gitcoredir}
528%endif
529
530# bash completion
531install -d $RPM_BUILD_ROOT%{bash_compdir}
532cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{bash_compdir}/git
533
534# Install git-prompt.sh
535install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/contrib/completion
536cp -p contrib/completion/git-prompt.sh $RPM_BUILD_ROOT%{_datadir}/%{name}/contrib/completion
537
538# Install bzr and hg remote helpers from contrib
539install -p contrib/remote-helpers/git-remote-{bzr,hg} $RPM_BUILD_ROOT%{gitcoredir}
540
541# gitweb
542mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
543ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
544cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
545cp -p %{SOURCE7} $RPM_BUILD_ROOT%{webappdir}/gitolite.pl
546cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
547cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
548cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
549
550# gitview
551install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
552
553# git-daemon related files
554cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
555cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
556install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
557
558# paths cleanup
559sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
560sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
561
562# hardlink
563ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
564ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
565ln -f $RPM_BUILD_ROOT{%{gitcoredir},%{_bindir}}/git-shell
566ln -f $RPM_BUILD_ROOT{%{gitcoredir},%{_bindir}}/git-upload-pack
567
568# remove unneeded files
569%{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
570%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
571%py_postclean
572
573mv $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
574%find_lang git
575
576%clean
577rm -rf $RPM_BUILD_ROOT
578
579%post daemon-inetd
580%service -q rc-inetd reload
581
582%postun daemon-inetd
583if [ "$1" = "0" ]; then
584 %service -q rc-inetd reload
585fi
586
587%post daemon-standalone
588/sbin/chkconfig --add git-daemon
589%service git-daemon restart "git-daemon"
590
591%preun daemon-standalone
592if [ "$1" = "0" ]; then
593 %service git-daemon stop
594 /sbin/chkconfig --del git-daemon
595fi
596
597%triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
598%webapp_register apache %{webapp}
599
600%triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
601%webapp_unregister apache %{webapp}
602
603%triggerin gitweb -- apache < 2.2.0, apache-base
604%webapp_register httpd %{webapp}
605
606%triggerun gitweb -- apache < 2.2.0, apache-base
607%webapp_unregister httpd %{webapp}
608
609%triggerin gitweb -- lighttpd
610%webapp_register lighttpd %{webapp}
611
612%triggerun gitweb -- lighttpd
613%webapp_unregister lighttpd %{webapp}
614
615%files -f git.lang
616%defattr(644,root,root,755)
617%doc README contrib-doc
618%attr(755,root,root) %{_bindir}/git
619%attr(755,root,root) %{_bindir}/git-receive-pack
620%attr(755,root,root) %{_bindir}/git-shell
621%attr(755,root,root) %{_bindir}/git-upload-archive
622%attr(755,root,root) %{_bindir}/git-upload-pack
623%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
624
625%if %{with doc}
626%{_mandir}/man1/git-*.1*
627%exclude %{_mandir}/man1/git-archimport.1*
628%exclude %{_mandir}/man1/git-svn.1*
629%exclude %{_mandir}/man1/git-cvs*.1*
630%exclude %{_mandir}/man1/git-imap-send*.1*
631%exclude %{_mandir}/man1/*email*.1*
632%{_mandir}/man1/git.1*
633%{_mandir}/man1/gitremote-helpers.1*
634%{_mandir}/man5/gitattributes.5*
635%{_mandir}/man5/githooks.5*
636%{_mandir}/man5/gitignore.5*
637%{_mandir}/man5/gitmodules.5*
638%{_mandir}/man5/gitrepository-layout.5*
639%{_mandir}/man7/gitcli.7*
640%{_mandir}/man7/gitcore-tutorial.7*
641%{_mandir}/man7/gitcredentials.7*
642%{_mandir}/man7/gitdiffcore.7*
643%{_mandir}/man7/giteveryday.7*
644%{_mandir}/man7/gitglossary.7*
645%{_mandir}/man7/gitnamespaces.7*
646%{_mandir}/man7/gitrevisions.7*
647%{_mandir}/man7/gittutorial-2.7*
648%{_mandir}/man7/gittutorial.7*
649%{_mandir}/man7/gitworkflows.7*
650%endif
651
652%dir %{gitcoredir}
653%attr(755,root,root) %{gitcoredir}/*-*
654%attr(755,root,root) %{gitcoredir}/git
655%dir %{gitcoredir}/mergetools
656%{gitcoredir}/mergetools/*
657
658%{_datadir}/%{name}
659%{_localstatedir}/lib/git
660
661# subpackages
662%exclude %{gitcoredir}/*email*
663%exclude %{gitcoredir}/*p4*
664%exclude %{gitcoredir}/git-archimport
665%exclude %{gitcoredir}/git-cvs*
666%exclude %{gitcoredir}/git-gui
667%exclude %{gitcoredir}/git-imap-send
668%exclude %{gitcoredir}/git-instaweb
669%exclude %{gitcoredir}/git-remote-bzr
670%exclude %{gitcoredir}/git-remote-hg
671%exclude %{gitcoredir}/git-remote-testsvn
672%exclude %{gitcoredir}/git-svn
673%exclude %{gitcoredir}/mergetools/p4merge
674%if %{with gnome_keyring}
675%exclude %{gitcoredir}/git-credential-gnome-keyring
676%endif
677
678%if %{with doc}
679%files doc
680%defattr(644,root,root,755)
681%doc Documentation/RelNotes*
682%doc Documentation/*.html Documentation/howto Documentation/technical
683%endif
684
685%files daemon-inetd
686%defattr(644,root,root,755)
687%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
688
689%files daemon-standalone
690%defattr(644,root,root,755)
691%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
692%attr(754,root, root) /etc/rc.d/init.d/git-daemon
693
694%files devel
695%defattr(644,root,root,755)
696%{_includedir}/%{name}
697%{_libdir}/libgit.a
698%{_libdir}/libgit_xdiff.a
699
700%files gitk
701%defattr(644,root,root,755)
702%if %{with doc}
703%{_mandir}/man1/gitk.1*
704%endif
705%attr(755,root,root) %{_bindir}/gitk
706%dir %{_datadir}/gitk
707%dir %{_datadir}/gitk/lib
708%dir %{_datadir}/gitk/lib/msgs
709%lang(bg) %{_datadir}/gitk/lib/msgs/bg.msg
710%lang(ca) %{_datadir}/gitk/lib/msgs/ca.msg
711%lang(de) %{_datadir}/gitk/lib/msgs/de.msg
712%lang(es) %{_datadir}/gitk/lib/msgs/es.msg
713%lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
714%lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
715%lang(it) %{_datadir}/gitk/lib/msgs/it.msg
716%lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
717%lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
718%lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
719%lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
720%lang(vi) %{_datadir}/gitk/lib/msgs/vi.msg
721
722%files gitweb
723%defattr(644,root,root,755)
724%doc gitweb/{README,INSTALL}
725%dir %{webappdir}
726%config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
727%config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
728%config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
729%config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
730%config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitolite.pl
731%attr(755,root,root) %{cgibindir}/gitweb.cgi
732%{appdir}
733%attr(755,root,root) %{gitcoredir}/git-instaweb
734%if %{with doc}
735%{_mandir}/man1/gitweb.1*
736%{_mandir}/man5/gitweb.conf.5*
737%endif
738
739%files gitview
740%defattr(644,root,root,755)
741%doc contrib/gitview/gitview.txt
742%attr(755,root,root) %{_bindir}/gitview
743
744%files gui
745%defattr(644,root,root,755)
746%attr(755,root,root) %{gitcoredir}/git-gui
747%dir %{_datadir}/git-gui
748%dir %{_datadir}/git-gui/lib
749%dir %{_datadir}/git-gui/lib/msgs
750%{_datadir}/git-gui/lib/git-gui.ico
751%{_datadir}/git-gui/lib/tclIndex
752%{_datadir}/git-gui/lib/*.js
753%{_datadir}/git-gui/lib/*.tcl
754%lang(bg) %{_datadir}/git-gui/lib/msgs/bg.msg
755%lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
756%lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
757%lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
758%lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
759%lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
760%lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
761%lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
762%lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
763%lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
764%lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
765%lang(vi) %{_datadir}/git-gui/lib/msgs/vi.msg
766%lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
767
768%files arch
769%defattr(644,root,root,755)
770%attr(755,root,root) %{gitcoredir}/git-archimport
771%if %{with doc}
772%{_mandir}/man1/git-archimport.1*
773%endif
774
775%files bzr
776%defattr(644,root,root,755)
777%attr(755,root,root) %{gitcoredir}/git-remote-bzr
778
779%files cvs
780%defattr(644,root,root,755)
781%attr(755,root,root) %{_bindir}/git-cvsserver
782%attr(755,root,root) %{gitcoredir}/git-cvs*
783%if %{with doc}
784%{_mandir}/man1/git-cvs*.1*
785%{_mandir}/man7/gitcvs-migration.7*
786%endif
787
788%files hg
789%defattr(644,root,root,755)
790%attr(755,root,root) %{gitcoredir}/git-remote-hg
791
792%files p4
793%defattr(644,root,root,755)
794%attr(755,root,root) %{gitcoredir}/git-p4
795%attr(755,root,root) %{gitcoredir}/mergetools/p4merge
796
797%files svn
798%defattr(644,root,root,755)
799%attr(755,root,root) %{gitcoredir}/git-svn
800%attr(755,root,root) %{gitcoredir}/git-remote-testsvn
801%{perl_vendorlib}/Git/SVN
802%{perl_vendorlib}/Git/SVN.pm
803%if %{with doc}
804%{_mandir}/man1/git-svn.1*
805%endif
806
807%files email
808%defattr(644,root,root,755)
809%attr(755,root,root) %{gitcoredir}/git-imap-send
810%attr(755,root,root) %{gitcoredir}/*email*
811%if %{with doc}
812%{_mandir}/man1/*email*.1*
813%{_mandir}/man1/*imap-send*.1*
814%endif
815
816%files -n bash-completion-git
817%defattr(644,root,root,755)
818%{bash_compdir}/git
819
820%files -n perl-Git
821%defattr(644,root,root,755)
822%{perl_vendorlib}/Git.pm
823%dir %{perl_vendorlib}/Git
824%{perl_vendorlib}/Git/I18N.pm
825%{perl_vendorlib}/Git/IndexInfo.pm
826%{_mandir}/man3/Git*.3pm*
827
828%if %{with gnome_keyring}
829%files -n gnome-keyring-git-core
830%defattr(644,root,root,755)
831%attr(755,root,root) %{gitcoredir}/git-credential-gnome-keyring
832%endif
This page took 0.030089 seconds and 4 git commands to generate.