]> git.pld-linux.org Git - packages/git-core.git/blame_incremental - git-core.spec
bzr, hg, p4 subpackages
[packages/git-core.git] / git-core.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without tests # don't perform make test
4%bcond_with tests_cvs # perform tests which use CVS
5%bcond_without tests_svn # perform tests which use subversion
6%bcond_without doc # skip building/packaging docs/manuals (takes some time)
7%bcond_without pcre # perl-compatible regexes support
8
9%include /usr/lib/rpm/macros.perl
10Summary: Distributed version control system focused on speed, effectivity and usability
11Summary(pl.UTF-8): Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
12Name: git-core
13Version: 1.8.5.3
14Release: 2
15License: GPL v2
16Group: Development/Tools
17Source0: http://git-core.googlecode.com/files/git-%{version}.tar.gz
18# Source0-md5: 57b966065882f83ef5879620a1e329ca
19Source1: %{name}-gitweb.conf
20Source2: %{name}-gitweb-httpd.conf
21Source3: %{name}-gitweb-lighttpd.conf
22Source4: %{name}.sysconfig
23Source5: %{name}.inet
24Source6: %{name}.init
25Patch0: %{name}-tests.patch
26Patch1: %{name}-key-bindings.patch
27Patch2: %{name}-sysconfdir.patch
28Patch3: cherry-picked-commitlog.patch
29Patch4: %{name}-svn-exit-errors.patch
30URL: http://git-scm.com/
31BuildRequires: autoconf >= 2.59
32BuildRequires: automake
33BuildRequires: curl-devel
34BuildRequires: expat-devel
35BuildRequires: gettext-devel
36BuildRequires: openssl-devel
37%{?with_pcre:BuildRequires: pcre-devel}
38BuildRequires: perl-Error > 0.15
39BuildRequires: perl-base
40BuildRequires: python-devel
41BuildRequires: rpm-perlprov >= 4.1-13
42BuildRequires: rpm-pythonprov
43BuildRequires: rpmbuild(macros) >= 1.264
44BuildRequires: tcl
45BuildRequires: zlib-devel
46%if %{with doc}
47BuildRequires: asciidoc >= 7.1.2-3
48BuildRequires: docbook-dtd45-xml
49BuildRequires: xmlto
50%endif
51%if %{with tests}
52%if %{with tests_cvs}
53# tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
54BuildRequires: cvs-gnu-client < 1.13
55BuildRequires: cvs-gnu-client >= 1.12
56%endif
57%{?with_tests_svn:BuildRequires: subversion}
58Conflicts: pdksh < 5.2.14-46
59%endif
60Requires: coreutils
61Requires: diffutils
62Requires: findutils
63Requires: grep
64Requires: openssh-clients
65Requires: perl-Error
66Requires: perl-Git = %{version}-%{release}
67Requires: sed
68Suggests: git-core-bzr
69Suggests: git-core-cvs
70Suggests: git-core-hg
71Suggests: git-core-p4
72Suggests: git-core-svn
73Suggests: less
74Suggests: rsync
75Obsoletes: python-Git
76BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
77
78# html docs have links to txt files
79%define _noautocompressdoc *.txt
80
81%define webapp gitweb
82%define webappdir %{_sysconfdir}/webapps/%{webapp}
83%define appdir %{_datadir}/%{webapp}
84%define cgibindir %{_prefix}/lib/cgi-bin
85%define bash_compdir %{_datadir}/bash-completion/completions
86
87%description
88"git" can mean anything, depending on your mood.
89
90- random three-letter combination that is pronounceable, and not
91 actually used by any common UNIX command. The fact that it is a
92 mispronunciation of "get" may or may not be relevant.
93- stupid. contemptible and despicable. simple. Take your pick from the
94 dictionary of slang.
95- "global information tracker": you're in a good mood, and it actually
96 works for you. Angels sing, and a light suddenly fills the room.
97- "goddamn idiotic truckload of sh*t": when it breaks
98
99This is a stupid (but extremely fast) directory content manager. It
100doesn't do a whole lot, but what it 'does' do is track directory
101contents efficiently.
102
103%description -l pl.UTF-8
104"git" może oznaczać cokolwiek, w zależności od nastroju.
105
106- losową kombinację trzech liter, która jest wymawialna i właściwie
107 nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
108 błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
109- głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
110- "global information tracker" (narzędzie do globalnego śledzenia
111 informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
112 Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
113- "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
114 g*) - kiedy się zepsuje.
115
116Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
117Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
118katalogu.
119
120%package doc
121Summary: Documentation for git-core
122Summary(pl.UTF-8): Dokumentacja do git-core
123Group: Documentation
124
125%description doc
126Documentation for git-core.
127
128%description doc -l pl.UTF-8
129Dokumentacja do git-core.
130
131%description doc -l fr.UTF-8
132Javadoc pour git-core.
133
134%package daemon-inetd
135Summary: Files necessary to run git-daemon as an inetd service
136Summary(pl.UTF-8): Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
137Group: Networking/Daemons
138Requires: %{name} = %{version}-%{release}
139Requires: setup >= 2.4.11-1
140Provides: git-core-daemon
141Obsoletes: git-core-daemon
142Obsoletes: git-core-daemon-standalone
143
144%description daemon-inetd
145Git-daemon is a really simple TCP git daemon that can serve git
146repositories. This package provides all necessarry files to run
147git-daemon as an inetd service.
148
149%description daemon-inetd -l pl.UTF-8
150Git-daemon to prosty demon git korzystający z protokołu TCP do
151udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
152do uruchomienia git-demona w trybie usługi inetd.
153
154%package daemon-standalone
155Summary: Files necessary to run git-daemon as a standalone service
156Summary(pl.UTF-8): Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
157Group: Networking/Daemons
158Requires: %{name} = %{version}-%{release}
159Provides: git-core-daemon
160Obsoletes: git-core-daemon
161Obsoletes: git-core-daemon-inetd
162
163%description daemon-standalone
164Git-daemon is a really simple TCP git daemon that can serve git
165repositories. This package provides all necessarry files to run
166git-daemon as an standalone service.
167
168%description daemon-standalone -l pl.UTF-8
169Git-daemon to prosty demon git korzystający z protokołu TCP do
170udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
171do uruchomienia git-daemona w trybie usługi samodzielnej.
172
173%package devel
174Summary: Git library with header files
175Summary(pl.UTF-8): Biblioteka Gita oraz pliki nagłówkowe
176Group: Development/Libraries
177Requires: zlib-devel
178
179%description devel
180Git library with header files.
181
182%description devel -l pl.UTF-8
183Biblioteka Gita oraz pliki nagłówkowe.
184
185%package gitk
186Summary: Tcl/Tk interface to the Git version control system
187Summary(pl.UTF-8): Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
188Group: Development/Tools
189Requires: %{name} = %{version}-%{release}
190Requires: tk
191
192%description gitk
193gitk displays changes in a repository or a selected set of commits.
194This includes visualizing the commit graph, showing information
195related to each commit, and the files in the trees of each revision.
196
197Historically, gitk was the first repository browser. It's written in
198Tcl/Tk and started off in a separate repository but was later merged
199into the main git repository.
200
201%description gitk -l pl.UTF-8
202gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
203Oznacza to wizualizację grafu commitów, wyświetlanie informacji
204związanych z każdym z commitów oraz listę plików dla każdej rewizji.
205
206Z historycznego punktu widzenia gitk był pierwszą przeglądarką
207repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
208osobnym repozytorium, ale z czasem został włączony do głównego
209repozytorium gita.
210
211%package gitweb
212Summary: Web frontend to git
213Summary(pl.UTF-8): Frontend WWW do gita
214Group: Development/Tools
215Requires: %{name} = %{version}-%{release}
216Requires: webapps
217Requires: webserver(access)
218Requires: webserver(alias)
219Requires: webserver(cgi)
220Suggests: webserver(setenv)
221
222%description gitweb
223This package provides a web interface for browsing git repositories.
224
225%description gitweb -l pl.UTF-8
226Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
227
228%package gitview
229Summary: A GTK+ based repository browser for git
230Summary(pl.UTF-8): Oparta na GTK+ przeglądarka repozytorium gita
231Group: Development/Tools
232Requires: %{name} = %{version}-%{release}
233Requires: python >= 1:2.4
234Requires: python-pycairo >= 1.0
235Requires: python-pygobject
236Requires: python-pygtk-gtk >= 2:2.8
237Suggests: python-gnome-desktop-gtksourceview
238
239%description gitview
240A GTK+ based repository browser for git.
241
242%description gitview -l pl.UTF-8
243Oparta na GTK+ przeglądarka repozytorium gita.
244
245%package gui
246Summary: Tcl/Tk interface to the Git version control system
247Summary(pl.UTF-8): Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
248Group: Development/Tools
249Requires: %{name} = %{version}-%{release}
250Requires: tk
251Requires: xdg-utils
252Suggests: meld
253
254%description gui
255Displays changes in a repository or a selected set of commits. This
256includes visualizing the commit graph, showing information related to
257each commit, and the files in the trees of each revision.
258
259Historically, gitk was the first repository browser. It's written in
260Tcl/Tk and started off in a separate repository but was later merged
261into the main git repository.
262
263%description gui -l pl.UTF-8
264Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
265to wizualizację grafu commitów, wyświetlanie informacji związanych z
266każdym z commitów oraz listę plików dla każdej rewizji.
267
268Z punktu widzenia historii, gitk był pierwszą przeglądarką
269repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
270osobnym repozytorium, ale z czasem został włączony do głównego
271repozytorium gita.
272
273%package bzr
274Summary: Git tools for working with bzr repositories
275Group: Development/Tools
276Requires: %{name} = %{version}-%{release}
277Requires: bzr
278
279%description bzr
280Git tools for working with bzr repositories.
281
282%package hg
283Summary: Git tools for working with mercurial repositories
284Group: Development/Tools
285Requires: %{name} = %{version}-%{release}
286Requires: mercurial >= 1.8
287
288%description hg
289Git tools for working with mercurial repositories.
290
291%package p4
292Summary: Git tools for working with Perforce depots
293Group: Development/Tools
294Requires: %{name} = %{version}-%{release}
295
296%description p4
297Git tools for working with Perforce depots.
298
299%package svn
300Summary: Subversion support for Git
301Summary(pl.UTF-8): Obsługa Subversion dla Gita
302Group: Development/Tools
303Requires: %{name} = %{version}-%{release}
304Requires: perl-Encode
305Requires: perl-Term-ReadKey
306
307%description svn
308Subversion support for Git.
309
310%description svn -l pl.UTF-8
311Obsługa Subversion dla Gita.
312
313%package cvs
314Summary: CVS support for Git
315Summary(pl.UTF-8): Obsługa CVS dla Gita
316Group: Development/Tools
317Requires: %{name} = %{version}-%{release}
318Requires: cvsps >= 2.1-2
319Requires: rcs
320
321%description cvs
322CVS support for Git.
323
324%description cvs -l pl.UTF-8
325Obsługa CVS dla Gita.
326
327%package arch
328Summary: Git tools for importing Arch repositories
329Summary(pl.UTF-8): Narzędzia Gita do importowania repozytoriów Archa
330Group: Development/Tools
331Requires: %{name} = %{version}-%{release}
332Requires: tla
333
334%description arch
335Git tools for importing Arch repositories.
336
337%description arch -l pl.UTF-8
338Narzędzia Gita do importowania repozytoriów Archa.
339
340%package email
341Summary: Git tools for sending email
342Summary(pl.UTF-8): Narzędzia Gita do wysyłania poczty
343Group: Development/Tools
344Requires: %{name} = %{version}-%{release}
345
346%description email
347Git tools for sending email.
348
349%description email -l pl.UTF-8
350Narzędzia Gita do wysyłania poczty.
351
352%package -n bash-completion-git
353Summary: bash-completion for git
354Summary(pl.UTF-8): bashowe uzupełnianie nazw dla gita
355Group: Applications/Shells
356Requires: %{name} = %{version}-%{release}
357Requires: bash-completion >= 2.0
358
359%description -n bash-completion-git
360This package provides bash-completion for git.
361
362%description -n bash-completion-git -l pl.UTF-8
363Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
364
365%package -n perl-Git
366Summary: Perl interface to the Git version control system
367Summary(pl.UTF-8): Perlowy interfejs do systemu kontroli wersji Git
368Group: Development/Languages/Perl
369Obsoletes: perl-git-core
370
371%description -n perl-Git
372This module provides Perl scripts easy way to interface the Git
373version control system. The modules have an easy and well-tested way
374to call arbitrary Git commands; in the future, the interface will also
375provide specialized methods for doing easily operations which are not
376totally trivial to do over the generic command interface.
377
378%description -n perl-Git -l pl.UTF-8
379Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
380wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
381dowolne polecenia Gita; w przyszłości interfejs udostępni także
382specjalne metody do łatwego wykonywania operacji nietrywialnych do
383wykonania przy użyciu ogólnego interfejsu poleceń.
384
385%package -n vim-syntax-gitcommit
386Summary: Vim syntax: gitcommit
387Summary(pl.UTF-8): Składnia dla Vima: gitcommit
388Group: Applications/Editors/Vim
389Requires: %{name} = %{version}-%{release}
390# for _vimdatadir existence
391Requires: vim-rt >= 4:6.3.058-3
392
393%description -n vim-syntax-gitcommit
394This plugin provides syntax highlighting for git's commit messages.
395
396%description -n vim-syntax-gitcommit -l pl.UTF-8
397Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
398
399%prep
400%setup -q -n git-%{version}
401%patch0 -p1
402%patch1 -p0
403%patch2 -p1
404%patch3 -p1
405%patch4 -p1
406
407%build
408%{__aclocal}
409%{__autoconf}
410%configure \
411 --sysconfdir=%{_sysconfdir}/git-core \
412 %{?with_pcre:--with-libpcre} \
413 --with-openssl
414
415echo "BLK_SHA1=1" >> config.mak
416
417%{__make} \
418 INSTALLDIRS=vendor \
419 GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
420 GITWEB_PROJECTROOT="/var/lib/git" \
421 GITWEB_CSS="/gitweb/gitweb.css" \
422 GITWEB_LOGO="/gitweb/git-logo.png" \
423 GITWEB_FAVICON="/gitweb/git-favicon.png" \
424 V=1
425
426%if %{with doc}
427%{__make} -C Documentation \
428 MAN_BASE_URL=file://%{_docdir}/%{name}-doc-%{version}/ \
429 V=1
430%endif
431
432%if %{with tests}
433%if %{without tests_cvs}
434%{__rm} t/t*cvs*.sh || :
435%endif
436%{!?with_tests_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
437%endif
438
439%install
440rm -rf $RPM_BUILD_ROOT
441install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
442install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
443install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
444install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
445cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
446[init]
447 templatedir = %{_sysconfdir}/%{name}/templates
448EOF
449
450%{__make} install \
451 INSTALLDIRS=vendor \
452 DESTDIR=$RPM_BUILD_ROOT
453
454%if %{with doc}
455%{__make} -C Documentation install \
456 DESTDIR=$RPM_BUILD_ROOT
457%endif
458
459# copy templates except sample hooks
460cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
461%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
462
463# header files and lib
464cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
465cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
466cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
467install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
468cp -p block-sha1/sha1.h $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
469cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
470cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
471cp -p {Makefile,config.mak,config.mak.autogen,config.mak.uname} $RPM_BUILD_ROOT%{_includedir}/%{name}
472
473# bash completion
474install -d $RPM_BUILD_ROOT%{bash_compdir}
475cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{bash_compdir}/git
476
477# Install bzr and hg remote helpers from contrib
478install -p contrib/remote-helpers/git-remote-{bzr,hg} $RPM_BUILD_ROOT%{_libdir}/%{name}
479
480# vim syntax
481install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
482cat > $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax/gitcommit.vim << 'EOF'
483autocmd BufNewFile,BufRead *.git/COMMIT_EDITMSG setf gitcommit
484autocmd BufNewFile,BufRead *.git/config,.gitconfig setf gitconfig
485autocmd BufNewFile,BufRead git-rebase-todo setf gitrebase
486autocmd BufNewFile,BufRead .msg.[0-9]*
487 \ if getline(1) =~ '^From.*# This line is ignored.$' |
488 \ setf gitsendemail |
489 \ endif
490autocmd BufNewFile,BufRead *.git/**
491 \ if getline(1) =~ '^\x\{40\}\>\|^ref: ' |
492 \ setf git |
493 \ endif
494EOF
495
496# gitweb
497mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
498ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
499cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
500cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
501cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
502cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
503
504# gitview
505install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
506
507# git-daemon related files
508cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
509cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
510install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
511
512# paths cleanup
513sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
514sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
515
516# hardlink
517ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
518ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
519ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
520ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
521
522# remove unneeded files
523%{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
524%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
525%py_postclean
526
527mv $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
528%find_lang git
529
530%clean
531rm -rf $RPM_BUILD_ROOT
532
533%post daemon-inetd
534%service -q rc-inetd reload
535
536%postun daemon-inetd
537if [ "$1" = "0" ]; then
538 %service -q rc-inetd reload
539fi
540
541%post daemon-standalone
542/sbin/chkconfig --add git-daemon
543%service git-daemon restart "git-daemon"
544
545%preun daemon-standalone
546if [ "$1" = "0" ]; then
547 %service git-daemon stop
548 /sbin/chkconfig --del git-daemon
549fi
550
551%triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
552%webapp_register apache %{webapp}
553
554%triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
555%webapp_unregister apache %{webapp}
556
557%triggerin gitweb -- apache < 2.2.0, apache-base
558%webapp_register httpd %{webapp}
559
560%triggerun gitweb -- apache < 2.2.0, apache-base
561%webapp_unregister httpd %{webapp}
562
563%triggerin gitweb -- lighttpd
564%webapp_register lighttpd %{webapp}
565
566%triggerun gitweb -- lighttpd
567%webapp_unregister lighttpd %{webapp}
568
569%files -f git.lang
570%defattr(644,root,root,755)
571%doc README contrib
572%attr(755,root,root) %{_bindir}/git
573%attr(755,root,root) %{_bindir}/git-receive-pack
574%attr(755,root,root) %{_bindir}/git-shell
575%attr(755,root,root) %{_bindir}/git-upload-archive
576%attr(755,root,root) %{_bindir}/git-upload-pack
577%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
578
579%if %{with doc}
580%{_mandir}/man1/git-*.1*
581%exclude %{_mandir}/man1/git-archimport.1*
582%exclude %{_mandir}/man1/git-svn.1*
583%exclude %{_mandir}/man1/git-cvs*.1*
584%exclude %{_mandir}/man1/git-imap-send*.1*
585%exclude %{_mandir}/man1/*email*.1*
586%{_mandir}/man1/git.1*
587%{_mandir}/man1/gitremote-helpers.1*
588%{_mandir}/man5/gitattributes.5*
589%{_mandir}/man5/githooks.5*
590%{_mandir}/man5/gitignore.5*
591%{_mandir}/man5/gitmodules.5*
592%{_mandir}/man5/gitrepository-layout.5*
593%{_mandir}/man7/gitcli.7*
594%{_mandir}/man7/gitcore-tutorial.7*
595%{_mandir}/man7/gitcredentials.7*
596%{_mandir}/man7/gitdiffcore.7*
597%{_mandir}/man7/gitglossary.7*
598%{_mandir}/man7/gitnamespaces.7*
599%{_mandir}/man7/gitrevisions.7*
600%{_mandir}/man7/gittutorial-2.7*
601%{_mandir}/man7/gittutorial.7*
602%{_mandir}/man7/gitworkflows.7*
603%endif
604
605%dir %{_libdir}/%{name}
606%attr(755,root,root) %{_libdir}/%{name}/*-*
607%attr(755,root,root) %{_libdir}/%{name}/git
608%dir %{_libdir}/%{name}/mergetools
609%{_libdir}/%{name}/mergetools/*
610
611%{_datadir}/%{name}
612%{_localstatedir}/lib/git
613
614# subpackages
615%exclude %{_libdir}/%{name}/*email*
616%exclude %{_libdir}/%{name}/*p4*
617%exclude %{_libdir}/%{name}/git-archimport
618%exclude %{_libdir}/%{name}/git-cvs*
619%exclude %{_libdir}/%{name}/git-gui
620%exclude %{_libdir}/%{name}/git-imap-send
621%exclude %{_libdir}/%{name}/git-instaweb
622%exclude %{_libdir}/%{name}/git-remote-bzr
623%exclude %{_libdir}/%{name}/git-remote-hg
624%exclude %{_libdir}/%{name}/git-remote-testsvn
625%exclude %{_libdir}/%{name}/git-svn
626%exclude %{_libdir}/%{name}/mergetools/p4merge
627
628%if %{with doc}
629%files doc
630%defattr(644,root,root,755)
631%doc Documentation/RelNotes*
632%doc Documentation/*.html Documentation/howto Documentation/technical
633%endif
634
635%files daemon-inetd
636%defattr(644,root,root,755)
637%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
638
639%files daemon-standalone
640%defattr(644,root,root,755)
641%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
642%attr(754,root, root) /etc/rc.d/init.d/git-daemon
643
644%files devel
645%defattr(644,root,root,755)
646%{_includedir}/%{name}
647%{_libdir}/libgit.a
648%{_libdir}/libgit_xdiff.a
649
650%files gitk
651%defattr(644,root,root,755)
652%if %{with doc}
653%{_mandir}/man1/gitk.1*
654%endif
655%attr(755,root,root) %{_bindir}/gitk
656%dir %{_datadir}/gitk
657%dir %{_datadir}/gitk/lib
658%dir %{_datadir}/gitk/lib/msgs
659%lang(de) %{_datadir}/gitk/lib/msgs/de.msg
660%lang(es) %{_datadir}/gitk/lib/msgs/es.msg
661%lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
662%lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
663%lang(it) %{_datadir}/gitk/lib/msgs/it.msg
664%lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
665%lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
666%lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
667%lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
668
669%files gitweb
670%defattr(644,root,root,755)
671%doc gitweb/{README,INSTALL}
672%dir %{webappdir}
673%config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
674%config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
675%config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
676%config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
677%attr(755,root,root) %{cgibindir}/gitweb.cgi
678%{appdir}
679%attr(755,root,root) %{_libdir}/%{name}/git-instaweb
680%if %{with doc}
681%{_mandir}/man1/gitweb.1*
682%{_mandir}/man5/gitweb.conf.5*
683%endif
684
685%files gitview
686%defattr(644,root,root,755)
687%doc contrib/gitview/gitview.txt
688%attr(755,root,root) %{_bindir}/gitview
689
690%files gui
691%defattr(644,root,root,755)
692%attr(755,root,root) %{_libdir}/%{name}/git-gui
693%dir %{_datadir}/git-gui
694%dir %{_datadir}/git-gui/lib
695%dir %{_datadir}/git-gui/lib/msgs
696%{_datadir}/git-gui/lib/git-gui.ico
697%{_datadir}/git-gui/lib/tclIndex
698%{_datadir}/git-gui/lib/*.js
699%{_datadir}/git-gui/lib/*.tcl
700%lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
701%lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
702%lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
703%lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
704%lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
705%lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
706%lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
707%lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
708%lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
709%lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
710%lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
711
712%files bzr
713%defattr(644,root,root,755)
714%attr(755,root,root) %{_libdir}/%{name}/git-remote-bzr
715
716%files hg
717%defattr(644,root,root,755)
718%attr(755,root,root) %{_libdir}/%{name}/git-remote-hg
719
720%files p4
721%defattr(644,root,root,755)
722%attr(755,root,root) %{_libdir}/%{name}/git-p4
723%attr(755,root,root) %{_libdir}/%{name}/mergetools/p4merge
724
725%files svn
726%defattr(644,root,root,755)
727%attr(755,root,root) %{_libdir}/%{name}/git-svn
728%attr(755,root,root) %{_libdir}/%{name}/git-remote-testsvn
729%{perl_vendorlib}/Git/SVN
730%{perl_vendorlib}/Git/SVN.pm
731%if %{with doc}
732%{_mandir}/man1/git-svn.1*
733%endif
734
735%files cvs
736%defattr(644,root,root,755)
737%attr(755,root,root) %{_bindir}/git-cvsserver
738%attr(755,root,root) %{_libdir}/%{name}/git-cvs*
739%if %{with doc}
740%{_mandir}/man1/git-cvs*.1*
741%{_mandir}/man7/gitcvs-migration.7*
742%endif
743
744%files arch
745%defattr(644,root,root,755)
746%attr(755,root,root) %{_libdir}/%{name}/git-archimport
747%if %{with doc}
748%{_mandir}/man1/git-archimport.1*
749%endif
750
751%files email
752%defattr(644,root,root,755)
753%attr(755,root,root) %{_libdir}/%{name}/git-imap-send
754%attr(755,root,root) %{_libdir}/%{name}/*email*
755%if %{with doc}
756%{_mandir}/man1/*email*.1*
757%{_mandir}/man1/*imap-send*.1*
758%endif
759
760%files -n bash-completion-git
761%defattr(644,root,root,755)
762%{bash_compdir}/git
763
764%files -n perl-Git
765%defattr(644,root,root,755)
766%{perl_vendorlib}/Git.pm
767%dir %{perl_vendorlib}/Git
768%{perl_vendorlib}/Git/I18N.pm
769%{perl_vendorlib}/Git/IndexInfo.pm
770%{_mandir}/man3/Git*.3pm*
771
772%files -n vim-syntax-gitcommit
773%defattr(644,root,root,755)
774%doc contrib/vim/README
775%{_datadir}/vim/vimfiles/syntax/gitcommit.vim
This page took 0.033261 seconds and 4 git commands to generate.