]> git.pld-linux.org Git - packages/git-core.git/blame_incremental - git-core.spec
up to 2.17.0
[packages/git-core.git] / git-core.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without tests # don't perform make test
4%bcond_with tests_cvs # perform tests which use CVS
5%bcond_without tests_svn # perform tests which use subversion
6%bcond_without doc # skip building/packaging docs/manuals (takes some time)
7%bcond_without pcre # perl-compatible regexes support
8%bcond_without gnome_keyring # build without gnome keyring support
9%bcond_without tk # build without the Tcl/Tk interface
10
11# for AC: --without doc --without gnome_keyring --without tests
12
13%include /usr/lib/rpm/macros.perl
14Summary: Distributed version control system focused on speed, effectivity and usability
15Summary(pl.UTF-8): Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
16Name: git-core
17Version: 2.17.0
18Release: 1
19License: GPL v2
20Group: Development/Tools
21Source0: http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.xz
22# Source0-md5: 371985891f467969802fe1c7584a45bf
23Source1: %{name}-gitweb.conf
24Source2: %{name}-gitweb-httpd.conf
25Source3: %{name}-gitweb-lighttpd.conf
26Source4: %{name}.sysconfig
27Source5: %{name}.inet
28Source6: %{name}.init
29Source7: gitolite.pl
30Patch0: %{name}-key-bindings.patch
31Patch1: %{name}-sysconfdir.patch
32Patch2: cherry-picked-commitlog.patch
33URL: http://git-scm.com/
34BuildRequires: autoconf >= 2.59
35BuildRequires: automake
36BuildRequires: curl-devel
37BuildRequires: expat-devel
38%if "%{pld_release}" == "ac"
39BuildRequires: gettext-devel
40%else
41BuildRequires: gettext-tools
42%endif
43%if %{with gnome_keyring}
44BuildRequires: libgnome-keyring-devel
45BuildRequires: pkgconfig
46%endif
47BuildRequires: openssl-devel
48%{?with_pcre:BuildRequires: pcre2-8-devel}
49BuildRequires: perl-Error > 0.15
50BuildRequires: perl-base
51BuildRequires: python-devel
52BuildRequires: rpm-perlprov >= 4.1-13
53BuildRequires: rpm-pythonprov
54BuildRequires: rpmbuild(macros) >= 1.673
55%if %{with tk}
56# wish
57BuildRequires: tk
58%endif
59BuildRequires: zlib-devel
60%if %{with doc}
61BuildRequires: asciidoc >= 7.1.2-3
62BuildRequires: docbook-dtd45-xml
63BuildRequires: xmlto
64%endif
65%if %{with tests}
66%if %{with tests_cvs}
67# tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
68BuildRequires: cvs-gnu-client < 1.13
69BuildRequires: cvs-gnu-client >= 1.12
70%endif
71%if %{with tests_svn}
72BuildRequires: perl-subversion
73BuildRequires: subversion
74%endif
75Conflicts: pdksh < 5.2.14-46
76%endif
77# git-sh-setup: sane_grep
78Requires: grep
79# git-pull: printf
80Requires: coreutils
81Requires: sed
82Suggests: git-core-bzr
83Suggests: git-core-cvs
84Suggests: git-core-hg
85Suggests: git-core-p4
86Suggests: git-core-svn
87Suggests: less
88Suggests: openssh-clients
89Suggests: perl-Git = %{version}-%{release}
90Suggests: rsync
91Obsoletes: git-core-gitview
92Obsoletes: python-Git
93Conflicts: perl-Git < %{version}
94BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
95
96# html docs have links to txt files
97%define _noautocompressdoc *.txt
98
99# do not generate perl dependency, git add -p support is optional
100# skip dependency generation from templates
101%define _noautoreqfiles %{_libexecdir}/%{name}/git-add--interactive %{_datadir}/%{name}/templates
102
103%define webapp gitweb
104%define webappdir %{_sysconfdir}/webapps/%{webapp}
105%define appdir %{_datadir}/%{webapp}
106%define cgibindir %{_prefix}/lib/cgi-bin
107%define gitcoredir %{_libexecdir}/%{name}
108
109%description
110"git" can mean anything, depending on your mood.
111
112- random three-letter combination that is pronounceable, and not
113 actually used by any common UNIX command. The fact that it is a
114 mispronunciation of "get" may or may not be relevant.
115- stupid. contemptible and despicable. simple. Take your pick from the
116 dictionary of slang.
117- "global information tracker": you're in a good mood, and it actually
118 works for you. Angels sing, and a light suddenly fills the room.
119- "goddamn idiotic truckload of sh*t": when it breaks
120
121This is a stupid (but extremely fast) directory content manager. It
122doesn't do a whole lot, but what it 'does' do is track directory
123contents efficiently.
124
125%description -l pl.UTF-8
126"git" może oznaczać cokolwiek, w zależności od nastroju.
127
128- losową kombinację trzech liter, która jest wymawialna i właściwie
129 nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
130 błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
131- głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
132- "global information tracker" (narzędzie do globalnego śledzenia
133 informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
134 Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
135- "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
136 g*) - kiedy się zepsuje.
137
138Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
139Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
140katalogu.
141
142%package doc
143Summary: Documentation for git-core
144Summary(pl.UTF-8): Dokumentacja do git-core
145Group: Documentation
146%if "%{_rpmversion}" >= "5"
147BuildArch: noarch
148%endif
149
150%description doc
151Documentation for git-core.
152
153%description doc -l pl.UTF-8
154Dokumentacja do git-core.
155
156%package daemon-inetd
157Summary: Files necessary to run git-daemon as an inetd service
158Summary(pl.UTF-8): Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
159Group: Networking/Daemons
160Requires: %{name} = %{version}-%{release}
161Requires: setup >= 2.4.11-1
162Provides: git-core-daemon
163Obsoletes: git-core-daemon
164Obsoletes: git-core-daemon-standalone
165
166%description daemon-inetd
167Git-daemon is a really simple TCP git daemon that can serve git
168repositories. This package provides all necessarry files to run
169git-daemon as an inetd service.
170
171%description daemon-inetd -l pl.UTF-8
172Git-daemon to prosty demon git korzystający z protokołu TCP do
173udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
174do uruchomienia git-demona w trybie usługi inetd.
175
176%package daemon-standalone
177Summary: Files necessary to run git-daemon as a standalone service
178Summary(pl.UTF-8): Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
179Group: Networking/Daemons
180Requires: %{name} = %{version}-%{release}
181Provides: git-core-daemon
182Obsoletes: git-core-daemon
183Obsoletes: git-core-daemon-inetd
184
185%description daemon-standalone
186Git-daemon is a really simple TCP git daemon that can serve git
187repositories. This package provides all necessarry files to run
188git-daemon as an standalone service.
189
190%description daemon-standalone -l pl.UTF-8
191Git-daemon to prosty demon git korzystający z protokołu TCP do
192udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
193do uruchomienia git-daemona w trybie usługi samodzielnej.
194
195%package devel
196Summary: Git library with header files
197Summary(pl.UTF-8): Biblioteka Gita oraz pliki nagłówkowe
198Group: Development/Libraries
199Requires: zlib-devel
200
201%description devel
202Git library with header files.
203
204%description devel -l pl.UTF-8
205Biblioteka Gita oraz pliki nagłówkowe.
206
207%package gitk
208Summary: Tcl/Tk interface to the Git version control system
209Summary(pl.UTF-8): Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
210Group: Development/Tools
211Requires: %{name} = %{version}-%{release}
212Requires: tk
213%if "%{_rpmversion}" >= "5"
214BuildArch: noarch
215%endif
216
217%description gitk
218gitk displays changes in a repository or a selected set of commits.
219This includes visualizing the commit graph, showing information
220related to each commit, and the files in the trees of each revision.
221
222Historically, gitk was the first repository browser. It's written in
223Tcl/Tk and started off in a separate repository but was later merged
224into the main git repository.
225
226%description gitk -l pl.UTF-8
227gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
228Oznacza to wizualizację grafu commitów, wyświetlanie informacji
229związanych z każdym z commitów oraz listę plików dla każdej rewizji.
230
231Z historycznego punktu widzenia gitk był pierwszą przeglądarką
232repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
233osobnym repozytorium, ale z czasem został włączony do głównego
234repozytorium gita.
235
236%package gitweb
237Summary: Web frontend to git
238Summary(pl.UTF-8): Frontend WWW do gita
239Group: Development/Tools
240Requires: %{name} = %{version}-%{release}
241Requires: webapps
242Requires: webserver(access)
243Requires: webserver(alias)
244Requires: webserver(cgi)
245Suggests: webserver(setenv)
246
247%description gitweb
248This package provides a web interface for browsing git repositories.
249
250%description gitweb -l pl.UTF-8
251Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
252
253%package gui
254Summary: Tcl/Tk interface to the Git version control system
255Summary(pl.UTF-8): Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
256Group: Development/Tools
257Requires: %{name} = %{version}-%{release}
258Requires: tk
259Requires: xdg-utils
260Suggests: meld
261
262%description gui
263Displays changes in a repository or a selected set of commits. This
264includes visualizing the commit graph, showing information related to
265each commit, and the files in the trees of each revision.
266
267Historically, gitk was the first repository browser. It's written in
268Tcl/Tk and started off in a separate repository but was later merged
269into the main git repository.
270
271%description gui -l pl.UTF-8
272Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
273to wizualizację grafu commitów, wyświetlanie informacji związanych z
274każdym z commitów oraz listę plików dla każdej rewizji.
275
276Z punktu widzenia historii, gitk był pierwszą przeglądarką
277repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
278osobnym repozytorium, ale z czasem został włączony do głównego
279repozytorium gita.
280
281%package arch
282Summary: Git tools for importing Arch repositories
283Summary(pl.UTF-8): Narzędzia Gita do importowania repozytoriów Archa
284Group: Development/Tools
285Requires: %{name} = %{version}-%{release}
286Requires: tla
287
288%description arch
289Git tools for importing Arch repositories.
290
291%description arch -l pl.UTF-8
292Narzędzia Gita do importowania repozytoriów Archa.
293
294%package bzr
295Summary: Git tools for working with bzr repositories
296Summary(pl.UTF-8): Narzędzia Gita do pracy z repozytoriami bzr
297Group: Development/Tools
298Requires: %{name} = %{version}-%{release}
299Requires: bzr
300
301%description bzr
302Git tools for working with bzr repositories.
303
304%description bzr -l pl.UTF-8
305Narzędzia Gita do pracy z repozytoriami bzr.
306
307%package cvs
308Summary: CVS support for Git
309Summary(pl.UTF-8): Obsługa CVS dla Gita
310Group: Development/Tools
311Requires: %{name} = %{version}-%{release}
312Requires: cvsps >= 2.1-2
313Requires: rcs
314
315%description cvs
316CVS support for Git.
317
318%description cvs -l pl.UTF-8
319Obsługa CVS dla Gita.
320
321%package hg
322Summary: Git tools for working with mercurial repositories
323Summary(pl.UTF-8): Narzędzia Gita do pracy z repozytoriami mercuriala
324Group: Development/Tools
325Requires: %{name} = %{version}-%{release}
326Requires: mercurial >= 1.8
327
328%description hg
329Git tools for working with mercurial repositories.
330
331%description hg -l pl.UTF-8
332Narzędzia Gita do pracy z repozytoriami mercuriala.
333
334%package p4
335Summary: Git tools for working with Perforce depots
336Summary(pl.UTF-8): Narzędzia Gita do pracy z magazynami Perforce'a
337Group: Development/Tools
338Requires: %{name} = %{version}-%{release}
339
340%description p4
341Git tools for working with Perforce depots.
342
343%description p4 -l pl.UTF-8
344Narzędzia Gita do pracy z magazynami Perforce'a.
345
346%package svn
347Summary: Subversion support for Git
348Summary(pl.UTF-8): Obsługa Subversion dla Gita
349Group: Development/Tools
350Requires: %{name} = %{version}-%{release}
351Requires: perl-Encode
352Requires: perl-Term-ReadKey
353
354%description svn
355Subversion support for Git.
356
357%description svn -l pl.UTF-8
358Obsługa Subversion dla Gita.
359
360%package email
361Summary: Git tools for sending email
362Summary(pl.UTF-8): Narzędzia Gita do wysyłania poczty
363Group: Development/Tools
364Requires: %{name} = %{version}-%{release}
365Suggests: perl-Net-SMTP-SSL
366
367%description email
368Git tools for sending email.
369
370%description email -l pl.UTF-8
371Narzędzia Gita do wysyłania poczty.
372
373%package -n bash-completion-git
374Summary: bash-completion for git
375Summary(pl.UTF-8): bashowe uzupełnianie nazw dla gita
376Group: Applications/Shells
377Requires: %{name} = %{version}-%{release}
378Requires: bash-completion >= 2.0
379%if "%{_rpmversion}" >= "5"
380BuildArch: noarch
381%endif
382
383%description -n bash-completion-git
384This package provides bash-completion for git.
385
386%description -n bash-completion-git -l pl.UTF-8
387Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
388
389%package -n perl-Git
390Summary: Perl interface to the Git version control system
391Summary(pl.UTF-8): Perlowy interfejs do systemu kontroli wersji Git
392Group: Development/Languages/Perl
393Obsoletes: perl-git-core
394%if "%{_rpmversion}" >= "5"
395BuildArch: noarch
396%endif
397
398%description -n perl-Git
399This module provides Perl scripts easy way to interface the Git
400version control system. The modules have an easy and well-tested way
401to call arbitrary Git commands; in the future, the interface will also
402provide specialized methods for doing easily operations which are not
403totally trivial to do over the generic command interface.
404
405%description -n perl-Git -l pl.UTF-8
406Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
407wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
408dowolne polecenia Gita; w przyszłości interfejs udostępni także
409specjalne metody do łatwego wykonywania operacji nietrywialnych do
410wykonania przy użyciu ogólnego interfejsu poleceń.
411
412%package -n gnome-keyring-git-core
413Summary: GNOME Keyring authentication provider for Git
414Summary(pl.UTF-8): Moduł uwierzytelniający GNOME Keyring dla Git
415Group: X11/Applications
416URL: http://git-scm.com/docs/gitcredentials.html
417Requires: %{name} = %{version}-%{release}
418
419%description -n gnome-keyring-git-core
420Authentication provider module for Git which allows git client to
421authenticate using GNOME Keyring.
422
423You need to register it with:
424- git config --global credential.helper gnome-keyring
425
426%description -n gnome-keyring-git-core -l pl.UTF-8
427Moduł uwierzytelniający dla Subversion pozwalający klientom git
428uwierzytelniać się przy użyciu mechanizmu GNOME Keyring.
429
430Moduł trzeba zarejestrować poleceniem:
431- git config --global credential.helper gnome-keyring
432
433%prep
434%setup -q -n git-%{version}
435%patch0 -p0
436%patch1 -p1
437%patch2 -p1
438
439%{__rm} {Documentation/technical,contrib/emacs,contrib/credential/gnome-keyring}/.gitignore
440
441# we build things in contrib but want to have it clean for doc purporses, too
442cp -a contrib contrib-doc
443
444%build
445%{__aclocal}
446%{__autoconf}
447%configure \
448 --sysconfdir=%{_sysconfdir}/git-core \
449 %{?with_pcre:--with-libpcre2} \
450 --with-openssl
451
452echo "BLK_SHA1=1" >> config.mak
453
454%{__make} \
455 GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
456 GITWEB_PROJECTROOT="/var/lib/git" \
457 GITWEB_CSS="/gitweb/gitweb.css" \
458 GITWEB_LOGO="/gitweb/git-logo.png" \
459 GITWEB_FAVICON="/gitweb/git-favicon.png" \
460 NO_PERL_CPAN_FALLBACKS=1 \
461 perllibdir=%{perl_vendorlib} \
462 V=1
463
464%{__make} -C contrib/subtree
465
466%if %{with gnome_keyring}
467%{__make} -C contrib/credential/gnome-keyring
468%endif
469
470%if %{with doc}
471%{__make} doc \
472 MAN_BASE_URL=file://%{_docdir}/%{name}-doc-%{version}/ \
473 V=1
474%endif
475
476%if %{with tests}
477%if %{without tests_cvs}
478%{__rm} t/t*cvs*.sh || :
479%endif
480%{!?with_tests_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
481%endif
482
483%install
484rm -rf $RPM_BUILD_ROOT
485install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_libdir},%{_localstatedir}/lib/git}
486install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
487install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
488install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
489cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
490[init]
491 templatedir = %{_sysconfdir}/%{name}/templates
492EOF
493
494%{__make} install \
495 DESTDIR=$RPM_BUILD_ROOT \
496 NO_PERL_CPAN_FALLBACKS=1 \
497 perllibdir=%{perl_vendorlib}
498
499%if %{with doc}
500%{__make} install-doc \
501 DESTDIR=$RPM_BUILD_ROOT
502%endif
503
504# copy templates except sample hooks
505cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
506%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
507
508# header files and lib
509cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
510cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
511cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
512install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
513cp -p block-sha1/sha1.h $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
514cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
515cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
516cp -p {Makefile,config.mak,config.mak.autogen,config.mak.uname} $RPM_BUILD_ROOT%{_includedir}/%{name}
517
518%{__make} -C contrib/subtree install \
519 libexecdir=%{gitcoredir} \
520 DESTDIR=$RPM_BUILD_ROOT
521
522%if %{with doc}
523%{__make} -C contrib/subtree install-man \
524 DESTDIR=$RPM_BUILD_ROOT
525%endif
526
527%if %{with gnome_keyring}
528install -p contrib/credential/gnome-keyring/git-credential-gnome-keyring $RPM_BUILD_ROOT%{gitcoredir}
529%endif
530
531# bash completion
532install -d $RPM_BUILD_ROOT%{bash_compdir}
533cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{bash_compdir}/git
534
535# Install git-prompt.sh
536install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/contrib/completion
537cp -p contrib/completion/git-prompt.sh $RPM_BUILD_ROOT%{_datadir}/%{name}/contrib/completion
538
539# Install bzr and hg remote helpers from contrib
540install -p contrib/remote-helpers/git-remote-{bzr,hg} $RPM_BUILD_ROOT%{gitcoredir}
541
542# gitweb
543mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
544ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
545cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
546cp -p %{SOURCE7} $RPM_BUILD_ROOT%{webappdir}/gitolite.pl
547cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
548cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
549cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
550
551# git-daemon related files
552cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
553cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
554install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
555
556# paths cleanup
557sed -e 's,@libdir@/git-core,%{gitcoredir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
558sed -e 's,@libdir@/git-core,%{gitcoredir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
559
560# same file, link
561ln -sf git $RPM_BUILD_ROOT%{_bindir}/git-receive-pack
562ln -sf git $RPM_BUILD_ROOT%{_bindir}/git-upload-archive
563ln -sf ../..%{gitcoredir}/git-shell $RPM_BUILD_ROOT%{_bindir}/git-shell
564ln -sf ../..%{gitcoredir}/git-upload-pack $RPM_BUILD_ROOT%{_bindir}/git-upload-pack
565ln -sf ../..%{gitcoredir}/git $RPM_BUILD_ROOT%{_bindir}/git
566
567# convert all hardlinks to symlinks, as rpm fails to calculate it properly
568# requiring excessive free space when it may not be available
569# https://bugs.launchpad.net/pld-linux/+bug/1176337
570find $RPM_BUILD_ROOT%{gitcoredir} -samefile $RPM_BUILD_ROOT%{gitcoredir}/git > files
571for f in $(cat files); do
572 f=${f#$RPM_BUILD_ROOT%{gitcoredir}/}
573 test $f = git && continue
574 ln -snf git $RPM_BUILD_ROOT%{gitcoredir}/$f
575done
576
577# few others
578ln -snf git-gui $RPM_BUILD_ROOT%{gitcoredir}/git-citool
579ln -snf git-remote-http $RPM_BUILD_ROOT%{gitcoredir}/git-remote-https
580ln -snf git-remote-http $RPM_BUILD_ROOT%{gitcoredir}/git-remote-ftp
581ln -snf git-remote-http $RPM_BUILD_ROOT%{gitcoredir}/git-remote-ftps
582
583# remove unneeded files
584%py_postclean
585
586mv $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
587%find_lang git
588
589%clean
590rm -rf $RPM_BUILD_ROOT
591
592%post daemon-inetd
593%service -q rc-inetd reload
594
595%postun daemon-inetd
596if [ "$1" = "0" ]; then
597 %service -q rc-inetd reload
598fi
599
600%post daemon-standalone
601/sbin/chkconfig --add git-daemon
602%service git-daemon restart "git-daemon"
603
604%preun daemon-standalone
605if [ "$1" = "0" ]; then
606 %service git-daemon stop
607 /sbin/chkconfig --del git-daemon
608fi
609
610%triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
611%webapp_register apache %{webapp}
612
613%triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
614%webapp_unregister apache %{webapp}
615
616%triggerin gitweb -- apache < 2.2.0, apache-base
617%webapp_register httpd %{webapp}
618
619%triggerun gitweb -- apache < 2.2.0, apache-base
620%webapp_unregister httpd %{webapp}
621
622%triggerin gitweb -- lighttpd
623%webapp_register lighttpd %{webapp}
624
625%triggerun gitweb -- lighttpd
626%webapp_unregister lighttpd %{webapp}
627
628%files -f git.lang
629%defattr(644,root,root,755)
630%doc README.md contrib-doc
631%attr(755,root,root) %{_bindir}/git
632%attr(755,root,root) %{_bindir}/git-receive-pack
633%attr(755,root,root) %{_bindir}/git-shell
634%attr(755,root,root) %{_bindir}/git-upload-archive
635%attr(755,root,root) %{_bindir}/git-upload-pack
636%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
637
638%if %{with doc}
639%{_mandir}/man1/git-*.1*
640%exclude %{_mandir}/man1/git-archimport.1*
641%exclude %{_mandir}/man1/git-svn.1*
642%exclude %{_mandir}/man1/git-cvs*.1*
643%exclude %{_mandir}/man1/git-imap-send*.1*
644%exclude %{_mandir}/man1/*email*.1*
645%{_mandir}/man1/git.1*
646%{_mandir}/man1/gitremote-helpers.1*
647%{_mandir}/man5/gitattributes.5*
648%{_mandir}/man5/githooks.5*
649%{_mandir}/man5/gitignore.5*
650%{_mandir}/man5/gitmodules.5*
651%{_mandir}/man5/gitrepository-layout.5*
652%{_mandir}/man7/gitcli.7*
653%{_mandir}/man7/gitcore-tutorial.7*
654%{_mandir}/man7/gitcredentials.7*
655%{_mandir}/man7/gitdiffcore.7*
656%{_mandir}/man7/giteveryday.7*
657%{_mandir}/man7/gitglossary.7*
658%{_mandir}/man7/gitnamespaces.7*
659%{_mandir}/man7/gitrevisions.7*
660%{_mandir}/man7/gitsubmodules.7*
661%{_mandir}/man7/gittutorial-2.7*
662%{_mandir}/man7/gittutorial.7*
663%{_mandir}/man7/gitworkflows.7*
664%endif
665
666%dir %{gitcoredir}
667%attr(755,root,root) %{gitcoredir}/*-*
668%attr(755,root,root) %{gitcoredir}/git
669%dir %{gitcoredir}/mergetools
670%{gitcoredir}/mergetools/*
671
672%{_datadir}/%{name}
673%{_localstatedir}/lib/git
674
675# subpackages
676%exclude %{gitcoredir}/*email*
677%exclude %{gitcoredir}/*p4*
678%exclude %{gitcoredir}/git-archimport
679%exclude %{gitcoredir}/git-citool
680%exclude %{gitcoredir}/git-cvs*
681%exclude %{gitcoredir}/git-gui
682%exclude %{gitcoredir}/git-imap-send
683%exclude %{gitcoredir}/git-instaweb
684%exclude %{gitcoredir}/git-remote-bzr
685%exclude %{gitcoredir}/git-remote-hg
686%exclude %{gitcoredir}/git-remote-testsvn
687%exclude %{gitcoredir}/git-svn
688%exclude %{gitcoredir}/mergetools/p4merge
689%if %{with gnome_keyring}
690%exclude %{gitcoredir}/git-credential-gnome-keyring
691%endif
692
693%if %{with doc}
694%files doc
695%defattr(644,root,root,755)
696%doc Documentation/RelNotes*
697%doc Documentation/*.html Documentation/howto Documentation/technical
698%endif
699
700%files daemon-inetd
701%defattr(644,root,root,755)
702%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
703
704%files daemon-standalone
705%defattr(644,root,root,755)
706%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
707%attr(754,root, root) /etc/rc.d/init.d/git-daemon
708
709%files devel
710%defattr(644,root,root,755)
711%{_includedir}/%{name}
712%{_libdir}/libgit.a
713%{_libdir}/libgit_xdiff.a
714
715%if %{with tk}
716%files gitk
717%defattr(644,root,root,755)
718%if %{with doc}
719%{_mandir}/man1/gitk.1*
720%endif
721%attr(755,root,root) %{_bindir}/gitk
722%dir %{_datadir}/gitk
723%dir %{_datadir}/gitk/lib
724%dir %{_datadir}/gitk/lib/msgs
725%lang(bg) %{_datadir}/gitk/lib/msgs/bg.msg
726%lang(ca) %{_datadir}/gitk/lib/msgs/ca.msg
727%lang(de) %{_datadir}/gitk/lib/msgs/de.msg
728%lang(es) %{_datadir}/gitk/lib/msgs/es.msg
729%lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
730%lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
731%lang(it) %{_datadir}/gitk/lib/msgs/it.msg
732%lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
733%lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
734%lang(pt_PT) %{_datadir}/gitk/lib/msgs/pt_pt.msg
735%lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
736%lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
737%lang(vi) %{_datadir}/gitk/lib/msgs/vi.msg
738%endif
739
740%files gitweb
741%defattr(644,root,root,755)
742%doc gitweb/{README,INSTALL}
743%dir %{webappdir}
744%config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
745%config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
746%config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
747%config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
748%config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitolite.pl
749%attr(755,root,root) %{cgibindir}/gitweb.cgi
750%{appdir}
751%attr(755,root,root) %{gitcoredir}/git-instaweb
752%if %{with doc}
753%{_mandir}/man1/gitweb.1*
754%{_mandir}/man5/gitweb.conf.5*
755%endif
756
757%if %{with tk}
758%files gui
759%defattr(644,root,root,755)
760%attr(755,root,root) %{gitcoredir}/git-citool
761%attr(755,root,root) %{gitcoredir}/git-gui
762%dir %{_datadir}/git-gui
763%dir %{_datadir}/git-gui/lib
764%dir %{_datadir}/git-gui/lib/msgs
765%{_datadir}/git-gui/lib/git-gui.ico
766%{_datadir}/git-gui/lib/tclIndex
767%{_datadir}/git-gui/lib/*.js
768%{_datadir}/git-gui/lib/*.tcl
769%lang(bg) %{_datadir}/git-gui/lib/msgs/bg.msg
770%lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
771%lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
772%lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
773%lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
774%lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
775%lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
776%lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
777%lang(pt) %{_datadir}/git-gui/lib/msgs/pt_pt.msg
778%lang(pt_BR) %{_datadir}/git-gui/lib/msgs/pt_br.msg
779%lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
780%lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
781%lang(vi) %{_datadir}/git-gui/lib/msgs/vi.msg
782%lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
783%endif
784
785%files arch
786%defattr(644,root,root,755)
787%attr(755,root,root) %{gitcoredir}/git-archimport
788%if %{with doc}
789%{_mandir}/man1/git-archimport.1*
790%endif
791
792%files bzr
793%defattr(644,root,root,755)
794%attr(755,root,root) %{gitcoredir}/git-remote-bzr
795
796%files cvs
797%defattr(644,root,root,755)
798%attr(755,root,root) %{_bindir}/git-cvsserver
799%attr(755,root,root) %{gitcoredir}/git-cvs*
800%if %{with doc}
801%{_mandir}/man1/git-cvs*.1*
802%{_mandir}/man7/gitcvs-migration.7*
803%endif
804
805%files hg
806%defattr(644,root,root,755)
807%attr(755,root,root) %{gitcoredir}/git-remote-hg
808
809%files p4
810%defattr(644,root,root,755)
811%attr(755,root,root) %{gitcoredir}/git-p4
812%attr(755,root,root) %{gitcoredir}/mergetools/p4merge
813
814%files svn
815%defattr(644,root,root,755)
816%attr(755,root,root) %{gitcoredir}/git-svn
817%attr(755,root,root) %{gitcoredir}/git-remote-testsvn
818%{perl_vendorlib}/Git/SVN
819%{perl_vendorlib}/Git/SVN.pm
820%if %{with doc}
821%{_mandir}/man1/git-svn.1*
822%endif
823
824%files email
825%defattr(644,root,root,755)
826%attr(755,root,root) %{gitcoredir}/git-imap-send
827%attr(755,root,root) %{gitcoredir}/*email*
828%if %{with doc}
829%{_mandir}/man1/*email*.1*
830%{_mandir}/man1/*imap-send*.1*
831%endif
832
833%files -n bash-completion-git
834%defattr(644,root,root,755)
835%{bash_compdir}/git
836
837%files -n perl-Git
838%defattr(644,root,root,755)
839%{perl_vendorlib}/Git.pm
840%dir %{perl_vendorlib}/Git
841%{perl_vendorlib}/Git/I18N.pm
842%{perl_vendorlib}/Git/IndexInfo.pm
843%{perl_vendorlib}/Git/LoadCPAN.pm
844%{perl_vendorlib}/Git/Packet.pm
845%dir %{perl_vendorlib}/Git/LoadCPAN
846%{perl_vendorlib}/Git/LoadCPAN/Error.pm
847%dir %{perl_vendorlib}/Git/LoadCPAN/Mail
848%{perl_vendorlib}/Git/LoadCPAN/Mail/Address.pm
849%{_mandir}/man3/Git.3pm*
850
851%if %{with gnome_keyring}
852%files -n gnome-keyring-git-core
853%defattr(644,root,root,755)
854%attr(755,root,root) %{gitcoredir}/git-credential-gnome-keyring
855%endif
This page took 0.041573 seconds and 4 git commands to generate.