]> git.pld-linux.org Git - packages/ghostscript.git/commitdiff
- up to 9.22 auto/th/ghostscript-9.22-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 28 Oct 2017 22:58:09 +0000 (00:58 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 28 Oct 2017 22:58:09 +0000 (00:58 +0200)
ghostscript-setuid.patch
ghostscript-svga-shared.patch [deleted file]
ghostscript.spec

index bca1571582849c395c2f5b4c88108e398ed440fc..4fa64a6c8ea5295deb398e45fc34a810406dee45 100644 (file)
  
      gs_get_real_stdio(stdfiles);
      arg_init(&args, (const char **)argv, argc,
---- gs/devices/gdevl256.c.orig Mon Jan 11 07:38:07 1999
-+++ gs/devices/gdevl256.c      Thu Mar 30 23:03:57 2000
-@@ -38,6 +38,17 @@
- #include <vga.h>
- #include <vgagl.h>
-+/* Change by Torsten Landschoff <torsten@debian.org>:
-+ * I changed imainarg.c to drop privileges as soon as possible when 
-+ * running setuid. We need to get back elevated rights when we want 
-+ * to open the vga library. Declare the two variables from imainarg.c
-+ * holding the privileges and include unistd.h for user management.
-+ *  -- Thu, 30 Mar 2000 22:59:53 +0200 */
-+
-+#include <unistd.h>
-+extern uid_t privileged_uid;
-+extern gid_t privileged_gid;
-+
- /* The color map for dynamically assignable colors. */
- #define first_dc_index 64
- private int next_dc_index;
-@@ -107,7 +118,19 @@
-     int vgamode;
-     int width, height;
-+    /* Change by Torsten Landschoff <torsten@debian.org>:
-+     * We need to restore the privileges we gave up in imainarg.c to open
-+     * the vga device. 
-+     * -- Thu, 30 Mar 2000 23:03:12 +0200 */
-+
-+    /* re-obtain privileges */
-+    seteuid( privileged_uid );        setegid( privileged_gid );
-     vga_init();
-+    /* give away privileges */
-+    seteuid( getuid() );      setegid( getgid() );
-+
-+    /* --- end change --- */
-+
-     vgamode = vga_getdefaultmode();
-     if (vgamode == -1)
-       vgamode = G320x200x256;
+
diff --git a/ghostscript-svga-shared.patch b/ghostscript-svga-shared.patch
deleted file mode 100644 (file)
index a600428..0000000
+++ /dev/null
@@ -1,62 +0,0 @@
---- ghostscript-9.18/configure.ac.orig 2016-01-06 21:16:43.016302214 +0100
-+++ ghostscript-9.18/configure.ac      2016-01-06 21:35:06.882922225 +0100
-@@ -1811,6 +1811,7 @@
- PS_DEVS='psdf psdcmyk psdrgb pdfwrite ps2write eps2write bbox txtwrite inkcov ink_cov psdcmykog fpng'
- MISC_FDEVS='ccr cif inferno mag16 mag256 mgr4 mgr8 mgrgray2 mgrgray4 mgrgray8 mgrmono miff24 plan9bm sgirgb sunhmono bit bitrgb bitrgbtags bitcmyk devicen spotcmyk xcf plib plibg plibm plibc plibk gprf'
- XPSDEV=$XPSWRITEDEVICE
-+SVGA_DEVS=
- while test -n "$drivers"; do
-         if echo $drivers |grep "," >/dev/null; then
-@@ -1950,6 +1951,9 @@
-                         AC_MSG_WARN(Unable to include opvp/oprp driver due to missing or disabled prerequisites...)
-                 fi
-                 ;;
-+      svga)
-+              SVGA_DEVS="vgalib.dev lvga256.dev"
-+              ;;
-         *)
-                 # It's a driver name (or a user messup)
-                 P_DEVS0="$P_DEVS0 `echo $THIS |sed -e 's,\.dev$,,'`"
-@@ -2047,6 +2051,7 @@
- AC_SUBST(JBIG2_DEVS)
- AC_SUBST(IJS_DEVS)
- AC_SUBST(PNG_DEVS)
-+AC_SUBST(SVGA_DEVS)
- # This now gets done after handling --enable-dynamic
- # AC_SUBST(X11_DEVS)
-@@ -2129,6 +2134,10 @@
-                         else
-                                 DYNAMIC_DEVS=""
-                         fi
-+                      if test "x$SVGA_DEVS" != x; then
-+                              DYNAMIC_DEVS="$DYNAMIC_DEVS \$(GLOBJDIR)/lvga256.so \$(GLOBJDIR)/vgalib.so"
-+                              SVGA_DEVS=
-+                      fi
-                         DYNAMIC_FLAGS="-DGS_DEVS_SHARED -DGS_DEVS_SHARED_DIR=\\\"\$(gssharedir)\\\""
-                         X11_DEVS=""
-                         OPT_CFLAGS="$DYNAMIC_CFLAGS $OPT_CFLAGS"
---- ghostscript-9.18/Makefile.in.orig  2016-01-06 21:16:43.029635544 +0100
-+++ ghostscript-9.18/Makefile.in       2016-01-06 21:36:00.216253925 +0100
-@@ -594,7 +594,7 @@
- DEVICE_DEVS7=@JBIG2_DEVS@
- DEVICE_DEVS8=
- DEVICE_DEVS9=@XPS_DEVS@
--DEVICE_DEVS10=
-+DEVICE_DEVS10=@SVGA_DEVS@
- DEVICE_DEVS11=
- DEVICE_DEVS12=
- DEVICE_DEVS13=
---- ghostscript-9.18/devices/gdevl256.c.orig   2016-01-06 21:36:44.772918446 +0100
-+++ ghostscript-9.18/devices/gdevl256.c        2016-01-07 16:17:39.900096231 +0100
-@@ -169,8 +169,7 @@
- gx_color_index
- lvga256_map_rgb_color(gx_device * dev, const gx_color_value cv[])
- {
--    gx_color_value r, g, b;
--    r = cv[0]; g = cv[1]; b = cv[2];
-+    gx_color_value r = cv[0], g = cv[1], b = cv[2];
- #define cv_bits(v,n) (v >> (gx_color_value_bits - n))
-     ushort r5 = cv_bits(r, 5), g5 = cv_bits(g, 5), b5 = cv_bits(b, 5);
-     static const byte cube_bits[32] =
index 5496d0f9d768b2c68362e621a26d7c63974ff5a3..94c718682cb951ed16ecc2eb414d9541a815422c 100644 (file)
@@ -18,19 +18,19 @@ Summary(ja.UTF-8):  PostScript インタープリタ・レンダラー
 Summary(pl.UTF-8):     Bezpłatny interpreter i renderer PostScriptu i PDF
 Summary(tr.UTF-8):     PostScript & PDF yorumlayıcı ve gösterici
 Name:          ghostscript
-Version:       9.20
-Release:       2
+Version:       9.22
+Release:       1
 License:       AGPL v3+
 Group:         Applications/Graphics
 #Source0Download: https://github.com/ArtifexSoftware/ghostpdl-downloads/releases
-Source0:       https://github.com/ArtifexSoftware/ghostpdl-downloads/releases/download/gs920/%{name}-%{version}.tar.xz
-# Source0-md5: 8f3d383d48da22345937b66b01ab2960
+Source0:       https://github.com/ArtifexSoftware/ghostpdl-downloads/releases/download/gs922/%{name}-%{version}.tar.xz
+# Source0-md5: 684c5371e52215f7289d2c32737e4def
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: 9b5953aa0cc155f4364f20036b848585
 Patch0:                %{name}-missquotes.patch
 Patch1:                %{name}-setuid.patch
 Patch2:                ijs-pkgconfig.patch
-Patch3:                %{name}-svga-shared.patch
+
 Patch6:                %{name}-gdevcd8-fixes.patch
 Patch8:                %{name}-zlib.patch
 
@@ -221,7 +221,6 @@ Statyczna wersja biblioteki IJS.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
-%patch3 -p1
 
 %patch6 -p1
 %patch8 -p1
@@ -328,7 +327,6 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/dvipdf
 %attr(755,root,root) %{_bindir}/eps2eps
-%attr(755,root,root) %{_bindir}/font2c
 %attr(755,root,root) %{_bindir}/ghostscript
 %attr(755,root,root) %{_bindir}/gs
 %attr(755,root,root) %{_bindir}/gsbj
@@ -353,7 +351,6 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/ps2ps
 %attr(755,root,root) %{_bindir}/ps2ps2
 %attr(755,root,root) %{_bindir}/pphs
-%attr(755,root,root) %{_bindir}/wftopfa
 %attr(755,root,root) %{_libdir}/libgs.so.*.*
 %attr(755,root,root) %ghost %{_libdir}/libgs.so.9
 %dir %{_libdir}/%{name}
@@ -372,7 +369,6 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/%{name}/%{version}/lib/*.x[bp]m
 %{_mandir}/man1/dvipdf.1*
 %{_mandir}/man1/eps2eps.1*
-%{_mandir}/man1/font2c.1*
 %{_mandir}/man1/ghostscript.1*
 %{_mandir}/man1/gs.1*
 %{_mandir}/man1/gsbj.1*
@@ -394,7 +390,6 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/ps2pdf14.1*
 %{_mandir}/man1/ps2pdfwr.1*
 %{_mandir}/man1/ps2ps.1*
-%{_mandir}/man1/wftopfa.1*
 %lang(cs) %{_mandir}/cs/man1/*
 %lang(de) %{_mandir}/de/man1/*
 %lang(es) %{_mandir}/es/man1/*
This page took 0.202676 seconds and 4 git commands to generate.