]> git.pld-linux.org Git - packages/ghostscript.git/commitdiff
fix build with freetype >= 2.10.3
authorJan Palus <atler@pld-linux.org>
Fri, 20 Nov 2020 18:57:13 +0000 (19:57 +0100)
committerJan Palus <atler@pld-linux.org>
Fri, 20 Nov 2020 18:57:13 +0000 (19:57 +0100)
ghostscript-9.53.3-drop-ft-callback-def.patch [new file with mode: 0644]
ghostscript.spec

diff --git a/ghostscript-9.53.3-drop-ft-callback-def.patch b/ghostscript-9.53.3-drop-ft-callback-def.patch
new file mode 100644 (file)
index 0000000..7801466
--- /dev/null
@@ -0,0 +1,50 @@
+From 41ef9a0bc36b9db7115fbe9623f989bfb47bbade Mon Sep 17 00:00:00 2001
+From: Chris Liddell <chris.liddell@artifex.com>
+Date: Tue, 20 Oct 2020 09:49:45 +0100
+Subject: [PATCH] Bug 702985: drop use of FT_CALLBACK_DEF() def
+
+From 2.10.3, Freetype disappeared the FT_CALLBACK_DEF() macro, which is what
+we used when defining our callbacks from Freetype.
+
+No guidance forthcoming from the Freetype developer who made those changes,
+so change to explicitly declaring the callbacks file static.
+
+Should fix the reported build failures.
+---
+ base/fapi_ft.c | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/base/fapi_ft.c b/base/fapi_ft.c
+index 65fa6dcf4..21aef2f06 100644
+--- a/base/fapi_ft.c
++++ b/base/fapi_ft.c
+@@ -125,7 +125,7 @@ static void
+ delete_inc_int_info(gs_fapi_server * a_server,
+                     FT_IncrementalRec * a_inc_int_info);
+-FT_CALLBACK_DEF(void *)
++static void *
+ FF_alloc(FT_Memory memory, long size)
+ {
+     gs_memory_t *mem = (gs_memory_t *) memory->user;
+@@ -133,7 +133,7 @@ FF_alloc(FT_Memory memory, long size)
+     return (gs_malloc(mem, size, 1, "FF_alloc"));
+ }
+-FT_CALLBACK_DEF(void *)
++static void *
+     FF_realloc(FT_Memory memory, long cur_size, long new_size, void *block)
+ {
+     gs_memory_t *mem = (gs_memory_t *) memory->user;
+@@ -153,7 +153,7 @@ FT_CALLBACK_DEF(void *)
+     return (tmp);
+ }
+-FT_CALLBACK_DEF(void)
++static void
+     FF_free(FT_Memory memory, void *block)
+ {
+     gs_memory_t *mem = (gs_memory_t *) memory->user;
+-- 
+2.17.1
+
index 856161f6e09f8e4be7fd0140883e45aa158c40b2..9562ad5003103e4794869a401b2b770da4880dc6 100644 (file)
@@ -37,6 +37,7 @@ Patch8:               %{name}-zlib.patch
 
 # fedora
 Patch20:       %{name}-scripts.patch
+Patch21:       %{name}-9.53.3-drop-ft-callback-def.patch
 
 Patch28:       %{name}-iccprofiles-initdir.patch
 
@@ -220,6 +221,7 @@ Statyczna wersja biblioteki IJS.
 %patch8 -p1
 
 %patch20 -p1
+%patch21 -p1
 
 %patch28 -p1
 
This page took 0.177916 seconds and 4 git commands to generate.