]> git.pld-linux.org Git - packages/ggz-python.git/commitdiff
- new, NFY, just saving work master
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 7 Feb 2013 06:49:36 +0000 (07:49 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Thu, 7 Feb 2013 06:49:36 +0000 (07:49 +0100)
ggz-python-install.patch [new file with mode: 0644]
ggz-python-rsvg.patch [new file with mode: 0644]
ggz-python.spec [new file with mode: 0644]

diff --git a/ggz-python-install.patch b/ggz-python-install.patch
new file mode 100644 (file)
index 0000000..117f6bb
--- /dev/null
@@ -0,0 +1,11 @@
+--- ggz-python-0.0.14.1/Makefile.in.orig       2008-02-16 22:13:50.000000000 +0100
++++ ggz-python-0.0.14.1/Makefile.in    2013-02-06 21:54:01.974943564 +0100
+@@ -122,7 +122,7 @@
+ po-install:
+       @echo Installing internationalization files
+-      cd po && make install prefix=$(DESTDIR)$(prefix)
++      cd po && make install prefix=$(prefix) DESTDIR=$(DESTDIR)
+ man-install:
+       @echo Installing manual pages
diff --git a/ggz-python-rsvg.patch b/ggz-python-rsvg.patch
new file mode 100644 (file)
index 0000000..ed698a7
--- /dev/null
@@ -0,0 +1,56 @@
+--- ggz-python-0.0.14.1/configure.ac.orig      2013-02-05 21:21:20.893451952 +0100
++++ ggz-python-0.0.14.1/configure.ac   2013-02-05 21:26:53.023445028 +0100
+@@ -80,8 +80,8 @@
+       if test "x$rsvgprefix" = "x"; then
+               rsvgprefix=/usr
+-              rsvg_libraries="$rsvgprefix/lib"
+-              rsvg_includes="$rsvgprefix/include"
++              rsvg_libraries="$(pkg-config --libs librsvg-2.0)"
++              rsvg_includes="$(pkg-config --cflags librsvg-2.0)"
+       else
+               rsvg_libraries="$rsvgprefix/lib"
+               rsvg_includes="$rsvgprefix/include"
+@@ -91,8 +91,8 @@
+       save_cppflags=$CPPFLAGS
+       save_ldflags=$LDFLAGS
+-      CPPFLAGS="$CPPFLAGS -I $rsvg_includes"
+-      LDFLAGS="$LDFLAGS -L $rsvg_libraries"
++      CPPFLAGS="$CPPFLAGS $rsvg_includes"
++      LDFLAGS="$LDFLAGS $rsvg_libraries"
+       AC_CHECK_LIB(
+               [rsvg-2],
+@@ -102,7 +102,7 @@
+       )
+       if test "$rsvg_found" = "yes"; then
+               AC_CHECK_HEADER(
+-                      [librsvg-2/librsvg/librsvg-features.h],
++                      [librsvg/rsvg.h],
+                       [rsvg_found=yes],
+                       [rsvg_found=no]
+               )
+--- ggz-python-0.0.14.1/pyrsvgsdl/setup.py.in.orig     2008-02-16 22:13:50.000000000 +0100
++++ ggz-python-0.0.14.1/pyrsvgsdl/setup.py.in  2013-02-05 21:29:29.770108427 +0100
+@@ -16,13 +16,15 @@
+         Extension('rsvgsdl',
+         ['src/pyrsvgsdl.c'],
+               include_dirs = [
+-                      '@rsvg_includes@/librsvg-2',
+-                      '@rsvg_includes@/gtk-2.0',
+-                      '@rsvg_includes@/glib-2.0',
+-                      '@rsvg_libraries@/glib-2.0/include'
++                      '/usr/include/cairo',
++                      '/usr/include/librsvg-2.0',
++                      '/usr/include/gdk-pixbuf-2.0',
++                      '/usr/include/gtk-2.0',
++                      '/usr/include/glib-2.0',
++                      '@libdir@/glib-2.0/include'
+               ],
+         libraries = ['rsvg-2'],
+-        library_dirs = ["@rsvg_libraries@"])
++        library_dirs = ["@libdir@"])
+     ]
+ )
diff --git a/ggz-python.spec b/ggz-python.spec
new file mode 100644 (file)
index 0000000..f0ca012
--- /dev/null
@@ -0,0 +1,119 @@
+# TODO:
+# - register client *.dsc in /etc/ggz.modules
+# - ggzdmod?
+# - subpackages? (client/games, server, python-* with client/server modules?)
+Summary:       GGZ Gaming Zone - Python libraries and Games
+Summary(pl.UTF-8):     GGZ Gaming Zone - biblioteki i gry w Pythonie
+Name:          ggz-python
+Version:       0.0.14.1
+Release:       0.1
+License:       LGPL v2.1+
+Group:         Applications/Games
+Source0:       http://mirrors.dotsrc.org/ggzgamingzone/ggz/%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: 0103b0a6a95623109625212ccf1137ef
+Patch0:                %{name}-rsvg.patch
+Patch1:                %{name}-install.patch
+URL:           http://www.ggzgamingzone.org/
+BuildRequires: autoconf >= 2.50
+BuildRequires: automake
+BuildRequires: ggz-client-libs-devel >= 0.0.14
+BuildRequires: libggz-devel >= 0.0.14
+BuildRequires: librsvg-devel >= 2.0
+BuildRequires: pkgconfig
+BuildRequires: rpm-pythonprov
+BuildRequires: rpmbuild(macros) >= 1.234
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+For people not liking C or C++, the GGZ Python package provides
+everything they need to start hacking on GGZ.
+
+Players will love the elegance and flexibility of games written in a
+scripting language.
+
+#%description -l pl.UTF-8
+
+%prep
+%setup -q
+%patch0 -p1
+%patch1 -p1
+
+%build
+%{__aclocal}
+%{__autoconf}
+%configure \
+       ggzd_confdir=%{_sysconfdir}/ggzd
+%{__make}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+%py_comp $RPM_BUILD_ROOT%{_libdir}/ggz-python
+%py_ocomp $RPM_BUILD_ROOT%{_libdir}/ggz-python
+%py_comp $RPM_BUILD_ROOT%{py_sitedir}
+%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
+%py_postclean
+
+%find_lang ggzpython
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files -f ggzpython.lang
+%defattr(644,root,root,755)
+%doc AUTHORS ChangeLog NEWS QuickStart.GGZ README README.GGZ
+# games/clients
+%attr(755,root,root) %{_bindir}/escape-sdl
+%attr(755,root,root) %{_bindir}/ggzboard
+%attr(755,root,root) %{_bindir}/vibora
+%attr(755,root,root) %{_bindir}/xadrez-chines
+%attr(755,root,root) %{_libdir}/ggz/goclient
+%attr(755,root,root) %{_libdir}/ggz/goclient.helper
+%dir %{_libdir}/ggz-python
+%{_libdir}/ggz-python/common
+%{_libdir}/ggz-python/ggzboard
+%{_libdir}/ggz-python/xadrez-chines
+%{_datadir}/ggz/ggzboard
+%{_datadir}/ggz/vibora
+%{_datadir}/ggz/xadrez-chines
+%{_desktopdir}/escape-sdl.desktop
+%{_desktopdir}/ggzboard.desktop
+%{_desktopdir}/vibora.desktop
+%{_desktopdir}/xadrez-chines.desktop
+%{_mandir}/man6/escape-sdl.6*
+%{_mandir}/man6/ggzboard.6*
+%{_mandir}/man6/vibora.6*
+%{_mandir}/man6/xadrez-chines.6*
+# servers
+%dir %{_sysconfdir}/ggzd
+%dir %{_sysconfdir}/ggzd/games
+%{_sysconfdir}/ggzd/games/goserver.dsc
+%{_sysconfdir}/ggzd/games/server_checkers.dsc
+%{_sysconfdir}/ggzd/games/server_hnefatafl.dsc
+%{_sysconfdir}/ggzd/games/server_ludo.dsc
+%{_sysconfdir}/ggzd/games/xadrez-chines-server.dsc
+%dir %{_sysconfdir}/ggzd/rooms
+%{_sysconfdir}/ggzd/rooms/goserver.room
+%{_sysconfdir}/ggzd/rooms/server_checkers.room
+%{_sysconfdir}/ggzd/rooms/server_hnefatafl.room
+%{_sysconfdir}/ggzd/rooms/server_ludo.room
+%{_sysconfdir}/ggzd/rooms/xadrez-chines-server.room
+%attr(755,root,root) %{_libdir}/ggzd/goserver
+%attr(755,root,root) %{_libdir}/ggzd/server_checkers.py
+%attr(755,root,root) %{_libdir}/ggzd/server_hnefatafl.py
+%attr(755,root,root) %{_libdir}/ggzd/server_ludo.py
+%attr(755,root,root) %{_libdir}/ggzd/xadrez-chines-server
+# python-ggz*
+%attr(755,root,root) %{py_sitedir}/ggzchess.so
+%attr(755,root,root) %{py_sitedir}/ggzcoresimple.so
+%attr(755,root,root) %{py_sitedir}/ggzmod.so
+%attr(755,root,root) %{py_sitedir}/rsvgsdl.so
+%{py_sitedir}/ggzsettings.py[co]
+%{py_sitedir}/sdlnewstuff.py[co]
+%{py_sitedir}/GGZChess-0.1-py*.egg-info
+%{py_sitedir}/GGZCore-0.1-py*.egg-info
+%{py_sitedir}/GGZMod-0.3-py*.egg-info
+%{py_sitedir}/RSVGSDL-0.1-py*.egg-info
This page took 0.098878 seconds and 4 git commands to generate.