]> git.pld-linux.org Git - packages/ggz-python.git/blob - ggz-python.spec
- new, NFY, just saving work
[packages/ggz-python.git] / ggz-python.spec
1 # TODO:
2 # - register client *.dsc in /etc/ggz.modules
3 # - ggzdmod?
4 # - subpackages? (client/games, server, python-* with client/server modules?)
5 Summary:        GGZ Gaming Zone - Python libraries and Games
6 Summary(pl.UTF-8):      GGZ Gaming Zone - biblioteki i gry w Pythonie
7 Name:           ggz-python
8 Version:        0.0.14.1
9 Release:        0.1
10 License:        LGPL v2.1+
11 Group:          Applications/Games
12 Source0:        http://mirrors.dotsrc.org/ggzgamingzone/ggz/%{version}/%{name}-%{version}.tar.gz
13 # Source0-md5:  0103b0a6a95623109625212ccf1137ef
14 Patch0:         %{name}-rsvg.patch
15 Patch1:         %{name}-install.patch
16 URL:            http://www.ggzgamingzone.org/
17 BuildRequires:  autoconf >= 2.50
18 BuildRequires:  automake
19 BuildRequires:  ggz-client-libs-devel >= 0.0.14
20 BuildRequires:  libggz-devel >= 0.0.14
21 BuildRequires:  librsvg-devel >= 2.0
22 BuildRequires:  pkgconfig
23 BuildRequires:  rpm-pythonprov
24 BuildRequires:  rpmbuild(macros) >= 1.234
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 For people not liking C or C++, the GGZ Python package provides
29 everything they need to start hacking on GGZ.
30
31 Players will love the elegance and flexibility of games written in a
32 scripting language.
33
34 #%description -l pl.UTF-8
35
36 %prep
37 %setup -q
38 %patch0 -p1
39 %patch1 -p1
40
41 %build
42 %{__aclocal}
43 %{__autoconf}
44 %configure \
45         ggzd_confdir=%{_sysconfdir}/ggzd
46 %{__make}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %py_comp $RPM_BUILD_ROOT%{_libdir}/ggz-python
55 %py_ocomp $RPM_BUILD_ROOT%{_libdir}/ggz-python
56 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
57 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
58 %py_postclean
59
60 %find_lang ggzpython
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files -f ggzpython.lang
66 %defattr(644,root,root,755)
67 %doc AUTHORS ChangeLog NEWS QuickStart.GGZ README README.GGZ
68 # games/clients
69 %attr(755,root,root) %{_bindir}/escape-sdl
70 %attr(755,root,root) %{_bindir}/ggzboard
71 %attr(755,root,root) %{_bindir}/vibora
72 %attr(755,root,root) %{_bindir}/xadrez-chines
73 %attr(755,root,root) %{_libdir}/ggz/goclient
74 %attr(755,root,root) %{_libdir}/ggz/goclient.helper
75 %dir %{_libdir}/ggz-python
76 %{_libdir}/ggz-python/common
77 %{_libdir}/ggz-python/ggzboard
78 %{_libdir}/ggz-python/xadrez-chines
79 %{_datadir}/ggz/ggzboard
80 %{_datadir}/ggz/vibora
81 %{_datadir}/ggz/xadrez-chines
82 %{_desktopdir}/escape-sdl.desktop
83 %{_desktopdir}/ggzboard.desktop
84 %{_desktopdir}/vibora.desktop
85 %{_desktopdir}/xadrez-chines.desktop
86 %{_mandir}/man6/escape-sdl.6*
87 %{_mandir}/man6/ggzboard.6*
88 %{_mandir}/man6/vibora.6*
89 %{_mandir}/man6/xadrez-chines.6*
90 # servers
91 %dir %{_sysconfdir}/ggzd
92 %dir %{_sysconfdir}/ggzd/games
93 %{_sysconfdir}/ggzd/games/goserver.dsc
94 %{_sysconfdir}/ggzd/games/server_checkers.dsc
95 %{_sysconfdir}/ggzd/games/server_hnefatafl.dsc
96 %{_sysconfdir}/ggzd/games/server_ludo.dsc
97 %{_sysconfdir}/ggzd/games/xadrez-chines-server.dsc
98 %dir %{_sysconfdir}/ggzd/rooms
99 %{_sysconfdir}/ggzd/rooms/goserver.room
100 %{_sysconfdir}/ggzd/rooms/server_checkers.room
101 %{_sysconfdir}/ggzd/rooms/server_hnefatafl.room
102 %{_sysconfdir}/ggzd/rooms/server_ludo.room
103 %{_sysconfdir}/ggzd/rooms/xadrez-chines-server.room
104 %attr(755,root,root) %{_libdir}/ggzd/goserver
105 %attr(755,root,root) %{_libdir}/ggzd/server_checkers.py
106 %attr(755,root,root) %{_libdir}/ggzd/server_hnefatafl.py
107 %attr(755,root,root) %{_libdir}/ggzd/server_ludo.py
108 %attr(755,root,root) %{_libdir}/ggzd/xadrez-chines-server
109 # python-ggz*
110 %attr(755,root,root) %{py_sitedir}/ggzchess.so
111 %attr(755,root,root) %{py_sitedir}/ggzcoresimple.so
112 %attr(755,root,root) %{py_sitedir}/ggzmod.so
113 %attr(755,root,root) %{py_sitedir}/rsvgsdl.so
114 %{py_sitedir}/ggzsettings.py[co]
115 %{py_sitedir}/sdlnewstuff.py[co]
116 %{py_sitedir}/GGZChess-0.1-py*.egg-info
117 %{py_sitedir}/GGZCore-0.1-py*.egg-info
118 %{py_sitedir}/GGZMod-0.3-py*.egg-info
119 %{py_sitedir}/RSVGSDL-0.1-py*.egg-info
This page took 0.143025 seconds and 4 git commands to generate.