]> git.pld-linux.org Git - packages/ggz-java.git/blob - ggz-java.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/ggz-java.git] / ggz-java.spec
1 #
2 # Conditional build:
3 %bcond_without  javadoc         # don't build javadoc
4 #
5 %include        /usr/lib/rpm/macros.java
6 Summary:        Java core client for the GGZ Gaming Zone
7 Summary(pl.UTF-8):      Klient GGZ Gaming Zone w Javie
8 Name:           ggz-java
9 Version:        0.0.14.1
10 Release:        1
11 License:        LGPL v2.1+
12 Group:          Applications/Games
13 Source0:        http://mirrors.dotsrc.org/ggzgamingzone/ggz/%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  df1c433df4d310cb9ee90a7091bf2cf1
15 URL:            http://www.ggzgamingzone.org/
16 BuildRequires:  ant
17 BuildRequires:  jdk >= 1.4
18 BuildRequires:  jpackage-utils
19 BuildRequires:  rpm-javaprov
20 BuildRequires:  rpmbuild(macros) >= 1.300
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 The GGZ Java client is a port of the following C libraries:
26 - libggz
27 - ggz-client-libs 
28 - ggz-gtk-client (redeveloped from scratch)
29 - ggz-gtk-games/ggzcards (redeveloped from scratch)
30
31 %description -l pl.UTF-8
32 Klient GGZ w Javie to port nastÄ™pujÄ…cych bibliotek C:
33 - libggz
34 - ggz-client-libs
35 - ggz-gtk-client (utworzony od podstaw)
36 - ggz-gtk-games/ggzcards (utworzony od podstaw)
37
38 %package javadoc
39 Summary:        GGZ Java client API documentation
40 Summary(pl.UTF-8):      Dokumentacja API klienta GGZ w Javie
41 Group:          Documentation
42 Requires:       jpackage-utils
43
44 %description javadoc
45 GGZ Java client API documentation.
46
47 %description javadoc -l pl.UTF-8
48 Dokumentacja API klienta GGZ w Javie.
49
50 %prep
51 %setup -q
52
53 %build
54 export JAVA_HOME="%{java_home}"
55
56 %ant jar %{?with_javadoc:javadoc} \
57         -Dsvnant.unspec=true
58
59 # see Makefile
60 cp -p ggz-java-unspec.jar ggz-java-client.jar
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 %{__make} install \
66         DESTDIR=$RPM_BUILD_ROOT \
67         prefix=%{_prefix}
68
69 %if %{with javadoc}
70 install -d $RPM_BUILD_ROOT%{_javadocdir}
71 cp -a javadoc $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
72 ln -s %{name}-%{version} $RPM_BUILD_ROOT%{_javadocdir}/%{name} # ghost symlink
73 %endif
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %post javadoc
79 ln -nfs %{name}-%{version} %{_javadocdir}/%{name}
80
81 %files
82 %defattr(644,root,root,755)
83 %doc AUTHORS ChangeLog NEWS README.GGZ README.txt TODO.txt
84 %attr(755,root,root) %{_bindir}/ggz-java
85 %dir %{_datadir}/ggz/ggz-java
86 %{_datadir}/ggz/ggz-java/ggz-java-unspec.jar
87 %{_mandir}/man6/ggz-java.6*
88
89 %if %{with javadoc}
90 %files javadoc
91 %defattr(644,root,root,755)
92 %{_javadocdir}/%{name}-%{version}
93 %ghost %{_javadocdir}/%{name}
94 %endif
This page took 0.077229 seconds and 3 git commands to generate.