]> git.pld-linux.org Git - packages/ggz-community.git/blob - ggz-community.spec
- fixed Group
[packages/ggz-community.git] / ggz-community.spec
1 # TODO: php() Rs, setup stuff
2 Summary:        GGZ Community - web-based GGZ community platform
3 Summary(pl.UTF-8):      GGZ Community - platforma społecznościowa GGZ oparta na WWW
4 Name:           ggz-community
5 Version:        0.0.14.1
6 Release:        0.1
7 License:        GPL v2+
8 Group:          Applications/WWW
9 Source0:        http://mirrors.dotsrc.org/ggzgamingzone/ggz/%{version}/%{name}-%{version}.tar.gz
10 # Source0-md5:  414201494a0c2b027d07a5836d9f9508
11 URL:            http://www.ggzgamingzone.org/
12 Requires:       webserver(php)
13 BuildArch:      noarch
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %define         _webapps        /etc/webapps
17 %define         _webapp         %{name}
18 %define         _sysconfdir     %{_webapps}/%{_webapp}
19 %define         _appdir         %{_datadir}/%{_webapp}
20
21 %description
22 GGZ Community - web-based GGZ community platform.
23
24 %description -l pl.UTF-8
25 GGZ Community - platforma społecznościowa GGZ oparta na WWW.
26
27 %prep
28 %setup -q
29
30 cat > apache.conf <<'EOF'
31 Alias /%{name} %{_appdir}
32 <Directory %{_appdir}>
33         Allow from all
34 </Directory>
35 EOF
36
37 cat > lighttpd.conf <<'EOF'
38 alias.url += (
39         "/%{name}" => "%{_appdir}",
40 )
41 EOF
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_datadir}}
46
47 cp -a web $RPM_BUILD_ROOT%{_appdir}
48 cp -p apache.conf $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
49 cp -p apache.conf $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
50 cp -p lighttpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %triggerin -- apache1 < 1.3.37-3, apache1-base
56 %webapp_register apache %{_webapp}
57
58 %triggerun -- apache1 < 1.3.37-3, apache1-base
59 %webapp_unregister apache %{_webapp}
60
61 %triggerin -- apache < 2.2.0, apache-base
62 %webapp_register httpd %{_webapp}
63
64 %triggerun -- apache < 2.2.0, apache-base
65 %webapp_unregister httpd %{_webapp}
66
67 %triggerin -- lighttpd
68 %webapp_register lighttpd %{_webapp}
69
70 %triggerun -- lighttpd
71 %webapp_unregister lighttpd %{_webapp}
72
73 %files
74 %defattr(644,root,root,755)
75 %doc ChangeLog Community.features NEWS README README.GGZ
76 %dir %attr(750,root,http) %{_sysconfdir}
77 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
78 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
79 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
80 #%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.php
81 %{_appdir}
This page took 0.066592 seconds and 3 git commands to generate.