]> git.pld-linux.org Git - packages/gget.git/commitdiff
- new
authorMarcin Banasiak <marcin.banasiak@gmail.com>
Mon, 22 Dec 2008 14:09:04 +0000 (14:09 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    gget-desktop.patch -> 1.1
    gget-dont-hardcode-python-version.patch -> 1.1
    gget.spec -> 1.1

gget-desktop.patch [new file with mode: 0644]
gget-dont-hardcode-python-version.patch [new file with mode: 0644]
gget.spec [new file with mode: 0644]

diff --git a/gget-desktop.patch b/gget-desktop.patch
new file mode 100644 (file)
index 0000000..31ff1ce
--- /dev/null
@@ -0,0 +1,17 @@
+diff -urN gget-0.0.4/data/gget.desktop.in gget-0.0.4.new/data/gget.desktop.in
+--- gget-0.0.4/data/gget.desktop.in    2008-12-20 12:35:51.000000000 +0100
++++ gget-0.0.4.new/data/gget.desktop.in        2008-12-22 14:55:19.000000000 +0100
+@@ -1,6 +1,5 @@
+ [Desktop Entry]
+ Version=1.0
+-Encoding=UTF-8
+ _Name=GGet Download Manager
+ _GenericName=Download Manager
+ _Comment=Download files from the Internet
+@@ -9,5 +8,5 @@
+ StartupNotify=true
+ Terminal=false
+ Type=Application
+-Categories=GNOME;GTK;Application;Network;
++Categories=GNOME;GTK;Network;
+ MimeType=application/metalink+xml;
diff --git a/gget-dont-hardcode-python-version.patch b/gget-dont-hardcode-python-version.patch
new file mode 100644 (file)
index 0000000..8c3831f
--- /dev/null
@@ -0,0 +1,9 @@
+diff -urN gget-0.0.4/bin/gget.in gget-0.0.4.new/bin/gget.in
+--- gget-0.0.4/bin/gget.in     2008-12-20 12:35:51.000000000 +0100
++++ gget-0.0.4.new/bin/gget.in 2008-12-22 14:51:49.000000000 +0100
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python2.5
++#!/usr/bin/env python
+ # -*- coding: utf-8 -*-
+ # Copyright (C) 2008 Johan Svedberg <johan@svedberg.com>
diff --git a/gget.spec b/gget.spec
new file mode 100644 (file)
index 0000000..49d291e
--- /dev/null
+++ b/gget.spec
@@ -0,0 +1,114 @@
+#
+%define                epiphany_version        2.24
+#
+Summary:       Download manager for GNOME
+Summary(pl.UTF-8):     Zarządca pobierania plików dla GNOME
+Name:          gget
+Version:       0.0.4
+Release:       1
+License:       GPL v2+
+Group:         X11/Applications/Networking
+Source0:       http://ftp.gnome.org/pub/GNOME/sources/gget/0.0/%{name}-%{version}.tar.bz2
+# Source0-md5: fb997cac66287c18da74bb7b6d6a07e9
+Patch0:                %{name}-desktop.patch
+Patch1:                %{name}-dont-hardcode-python-version.patch
+URL:           http://live.gnome.org/GGet
+BuildRequires: GConf2-devel
+BuildRequires: autoconf
+BuildRequires: automake
+BuildRequires: epiphany-devel >= 2.24.0
+BuildRequires: gettext-devel
+BuildRequires: gtk+2-devel >= 2:2.12.0
+BuildRequires: intltool >= 0.33.0
+BuildRequires: libtool
+BuildRequires: pkgconfig
+BuildRequires: python >= 1:2.5
+BuildRequires: python-dbus-devel >= 0.82
+BuildRequires: python-devel >= 1:2.5
+BuildRequires: python-gnome-devel >= 2.16.0
+BuildRequires: python-gnome-extras-devel >= 2.14.2
+BuildRequires: python-pygtk-devel >= 2:2.12.0
+BuildRequires: python-pynotify-devel >= 0.1.1
+BuildRequires: rpmbuild(macros) >= 1.311
+Requires(post,postun): desktop-file-utils
+Requires(post,postun): gtk+2
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+GGet is a download manager for GNOME.
+
+%description -l pl.UTF-8
+GGet jest zarządcą pobierania plików dla GNOME.
+
+%package -n epiphany-extension-gget
+Summary:       Epiphany extension - GGet
+Summary(pl.UTF-8):     Rozszerzenie dla Epiphany - GGet
+Group:         X11/Applications/Networking
+Requires:      %{name} = %{version}-%{release}
+Requires:      epiphany >= 2.24
+
+%description -n epiphany-extension-gget
+Epiphany extension that uses GGet to download files.
+
+%description -n epiphany-extension-gget -l pl.UTF-8
+Rozszerzenie dla Epiphany wykorzystujące GGet do pobierania plików.
+
+%prep
+%setup -q
+%patch0 -p1
+%patch1 -p1
+
+%build
+%{__intltoolize}
+%{__libtoolize}
+%{__aclocal} -I m4
+%{__autoconf}
+%{__autoheader}
+%{__automake}
+%configure \
+       --disable-schemas-install
+%{__make}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+%py_postclean
+%py_postclean %{_libdir}/epiphany/%{epiphany_version}/extensions
+
+%find_lang %{name}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post
+%update_desktop_database
+%update_icon_cache hicolor
+%gconf_schema_install gget.schemas
+
+%preun
+%gconf_schema_uninstall gget.schemas
+
+%postun
+%update_desktop_database_postun
+%update_icon_cache hicolor
+
+%files -f %{name}.lang
+%defattr(644,root,root,755)
+%doc
+%attr(755,root,root) %{_bindir}/gget
+%{_desktopdir}/gget.desktop
+%{_datadir}/dbus-1/services/org.gnome.gget.service
+%{_datadir}/gget
+%{_iconsdir}/hicolor/*/*/*.png
+%{_iconsdir}/hicolor/*/*/*.svg
+%{_sysconfdir}/gconf/schemas/gget.schemas
+%dir %{py_sitescriptdir}/gget
+%{py_sitescriptdir}/gget/*.py[co]
+
+%files -n epiphany-extension-gget
+%defattr(644,root,root,755)
+%{_libdir}/epiphany/%{epiphany_version}/extensions/gget-epiphany.py[co]
+%{_libdir}/epiphany/%{epiphany_version}/extensions/gget.ephy-extension
This page took 0.07095 seconds and 4 git commands to generate.