]> git.pld-linux.org Git - packages/ggaoed.git/blob - ggaoed.spec
e556cdef71d4424b20f163cb56a4742252aa752e
[packages/ggaoed.git] / ggaoed.spec
1 Summary:        ggaoed - ATA over Ethernet target implementation for Linux
2 Name:           ggaoed
3 Version:        1.1
4 Release:        1
5 License:        GPL v2
6 Group:          Networking/Daemons
7 Source0:        http://ggaoed.googlecode.com/files/%{name}-%{version}.tar.gz
8 # Source0-md5:  9d46d1b274e96547bb93bc5360a1db54
9 Source1:        %{name}.init
10 Source2:        %{name}.sysconfig
11 Patch0:         %{name}-build.patch
12 URL:            http://code.google.com/p/ggaoed/
13 BuildRequires:  docbook2X >= 0.8
14 BuildRequires:  glib2-devel >= 2.12
15 BuildRequires:  libaio-devel >= 0.3.107
16 BuildRequires:  libatomic_ops >= 1.2
17 BuildRequires:  libblkid-devel
18 BuildRequires:  pkgconfig
19 Requires(post,preun):   /sbin/chkconfig
20 Requires:       rc-scripts
21 Requires:       uname(release) >= 2.6.31
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 ggaoed is an AoE (ATA over Ethernet) target implementation for Linux.
26 It utilizes Linux kernel AIO, memory mapped sockets and other Linux
27 features to provide the best performance.
28
29 %prep
30 %setup -q
31 %patch0 -p1
32
33 %build
34 %configure
35 %{__make}
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 install -d $RPM_BUILD_ROOT%{_sharedstatedir}/ggaoed
40
41 %{__make} install \
42         datarootdir=$RPM_BUILD_ROOT%{_datadir} \
43         sbindir=$RPM_BUILD_ROOT%{_sbindir} \
44         mandir=$RPM_BUILD_ROOT%{_mandir}
45
46 install -D ggaoed.conf.dist $RPM_BUILD_ROOT%{_sysconfdir}/ggaoed.conf
47 install -D %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/ggaoed
48 install -D %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/ggaoed
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %post
54 /sbin/chkconfig --add ggaoed
55 /sbin/chkconfig ggaoed off
56 %service ggaoed restart
57
58 %preun
59 if [ "$1" = "0" ]; then
60         /sbin/chkconfig --del ggaoed
61         %service ggaoed stop
62         # nuke config cache if uninstalling
63         rm -rf %{_sharedstatedir}/ggaoed/*
64 fi
65
66 %files
67 %defattr(644,root,root,755)
68 %doc NEWS README
69 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ggaoed.conf
70 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ggaoed
71 %attr(754,root,root) /etc/rc.d/init.d/ggaoed
72 %attr(755,root,root) %{_sbindir}/ggaoectl
73 %attr(755,root,root) %{_sbindir}/ggaoed
74 %{_mandir}/man5/ggaoed.conf.5*
75 %{_mandir}/man8/ggaoectl.8*
76 %{_mandir}/man8/ggaoed.8*
77 %dir %{_sharedstatedir}/ggaoed
This page took 0.0661 seconds and 2 git commands to generate.