]> git.pld-linux.org Git - packages/gg.git/commitdiff
- orphaned, outdated
authorJan Rękorajski <baggins@pld-linux.org>
Fri, 21 Apr 2006 23:40:37 +0000 (23:40 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    gg-ac_fix.patch -> 1.2
    gg-chat-status.patch -> 1.2
    gg-lupa.patch -> 1.2
    gg-save-window-size.patch -> 1.2

gg-ac_fix.patch [deleted file]
gg-chat-status.patch [deleted file]
gg-lupa.patch [deleted file]
gg-save-window-size.patch [deleted file]

diff --git a/gg-ac_fix.patch b/gg-ac_fix.patch
deleted file mode 100644 (file)
index f873703..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
---- configure.in~      Fri May 10 14:38:27 2002
-+++ configure.in       Sat Jun  1 14:14:23 2002
-@@ -37,6 +37,11 @@
- AM_CONDITIONAL(INSTALL_GNOME_STUFF, test yes = "$enable_gnome")
- AM_CONDITIONAL(INSTALL_GNOME_APPLET_STUFF, test yes = "$enable_panel")
-+
-+AM_CONDITIONAL(HAVE_ORBIT, [false])
-+AM_CONDITIONAL(HAVE_GNORBA, [false])
-+AM_CONDITIONAL(ADD_ARTS_SOURCES, [false])
-+AM_CONDITIONAL(HAVE_ESD, [false])
-
- if test "$enable_gnome" = yes ; then
-       have_gnome=no
diff --git a/gg-chat-status.patch b/gg-chat-status.patch
deleted file mode 100644 (file)
index 2a2644c..0000000
+++ /dev/null
@@ -1,97 +0,0 @@
-diff -urN orig/src/gg.c new/src/gg.c
---- orig/src/gg.c      Sat Jun  1 18:11:49 2002
-+++ new/src/gg.c       Sat Jun  1 18:10:47 2002
-@@ -400,6 +400,20 @@
-       return NULL;
- }
-+gchar *gg_get_status_as_string(guint uin)
-+{
-+      GGContact *kontakt = gg_get_contact_by_uin(uin);
-+
-+      if (kontakt->status==GG_STATUS_NOT_AVAILABLE)
-+              return "niedostêpny";
-+      else if (kontakt->status==GG_STATUS_AVAILABLE)
-+              return "dostêpny";
-+      else if (kontakt->status==GG_STATUS_AWAY)
-+              return "zajêty";
-+      else
-+              return "OKURWA";        
-+}
-+
- static
- void gg_log_msg(gint sess_uin, gint uin, gchar * nick, gchar * text)
- {
-@@ -486,8 +500,9 @@
-               if (kontakt->nick && *kontakt->nick) {
-                       title =
--                          g_strdup_printf("Rozmowa z %s (%d)",
--                                          kontakt->nick, m->sender);
-+                          g_strdup_printf("Rozmowa z %s (%d) - %s",
-+                                          kontakt->nick, m->sender,
-+                                              gg_get_status_as_string(kontakt->uin));
-               } else {
-                       title = g_strdup_printf("Rozmowa z %d", m->sender);
-               }
-diff -urN orig/src/gg.h new/src/gg.h
---- orig/src/gg.h      Sat Jun  1 18:11:49 2002
-+++ new/src/gg.h       Sat Jun  1 18:10:47 2002
-@@ -148,6 +148,8 @@
- GGContact *gg_get_contact_by_uin(guint uin);
-+gchar *gg_get_status_as_string(guint uin);
-+
- #define close_connection gg_close_connection
- void gg_close_connection(void);
-diff -urN orig/src/interface.c new/src/interface.c
---- orig/src/interface.c       Sat Jun  1 18:11:49 2002
-+++ new/src/interface.c        Sat Jun  1 18:10:47 2002
-@@ -1193,8 +1193,9 @@
-       nick = gg_get_nick_by_uin(sesja->uin);
-       title =
--          g_strdup_printf("Rozmowa z %s (%d)",
--                          (nick ? nick : ""), sesja->uin);
-+          g_strdup_printf("Rozmowa z %s (%d) - %s",
-+                          (nick ? nick : ""), sesja->uin,
-+                              gg_get_status_as_string(sesja->uin));
-       gtk_window_set_title(GTK_WINDOW(chat), _(title));
-       g_free(title);
-diff -urN orig/src/userstatus.c new/src/userstatus.c
---- orig/src/userstatus.c      Sat Jun  1 18:11:49 2002
-+++ new/src/userstatus.c       Sat Jun  1 18:10:47 2002
-@@ -129,7 +129,9 @@
-       GdkPixmap *pixmap;
-       GdkBitmap *mask;
-       GdkColormap *colormap;
-+      GGSession *sesja;
-       gchar *picname;
-+      gchar *title=NULL;
-       g_return_if_fail(kontakt != NULL);
-@@ -199,6 +201,20 @@
-       }
-       gtk_clist_sort(GTK_CLIST(lista));
-+      if((sesja=gg_find_session(kontakt->uin)))
-+      {
-+              if(sesja->chat_window)
-+              {
-+                      title=g_strdup_printf("Rozmowa z %s (%d) - %s",
-+                                      kontakt->nick, kontakt->uin,
-+                                      gg_get_status_as_string(kontakt->uin));
-+
-+                      gtk_window_set_title(GTK_WINDOW(sesja->chat_window), title);
-+
-+                      g_free(title);
-+              }
-+      }
-+
- #ifdef USE_DOCKAPP
-       wmgg_contact_change_status(nick, kontakt->status, prev_status);
- #endif 
diff --git a/gg-lupa.patch b/gg-lupa.patch
deleted file mode 100644 (file)
index 61b4c58..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-diff -urN gg-0.2.4.orig/src/callbacks.c gg-0.2.4/src/callbacks.c
---- gg-0.2.4.orig/src/callbacks.c      Sun Jul  7 14:30:35 2002
-+++ gg-0.2.4/src/callbacks.c   Wed Jul 17 11:34:02 2002
-@@ -759,9 +759,10 @@
- void on_search_unknown_clicked(GtkWidget * button, GGSession * sesja)
- {
-       GGSearch *s;
--      
--      gtk_widget_destroy(wyniki_szukaj);
--      
-+
-+      if (GTK_IS_WIDGET(wyniki_szukaj) && wyniki_szukaj != NULL)
-+              gtk_widget_destroy(wyniki_szukaj);
-+
-       s = g_new0(GGSearch, 1);
-       s->mode = 3;
-       s->uin = sesja->uin;
-
diff --git a/gg-save-window-size.patch b/gg-save-window-size.patch
deleted file mode 100644 (file)
index c25e320..0000000
+++ /dev/null
@@ -1,91 +0,0 @@
-diff -Nur gg-0.2.1.orig/src/gg-types.h gg-0.2.1/src/gg-types.h
---- gg-0.2.1.orig/src/gg-types.h       Thu Jan 10 00:53:44 2002
-+++ gg-0.2.1/src/gg-types.h    Thu Jan 17 17:10:00 2002
-@@ -45,6 +45,8 @@
-       gchar *proxy_host;
-       guint connect_on_start;
-       guint last_sysmsg;
-+      guint width;
-+      guint height;
- } GGConfig;
- typedef struct {
-diff -Nur gg-0.2.1.orig/src/gg.h gg-0.2.1/src/gg.h
---- gg-0.2.1.orig/src/gg.h     Mon Jan 14 22:43:05 2002
-+++ gg-0.2.1/src/gg.h  Thu Jan 17 17:09:25 2002
-@@ -160,6 +160,9 @@
- #define GG_SEARCH          0x0004
- #define GG_REGISTER      0x0005
-+#define GG_MIN_WIDTH   160
-+#define GG_MIN_HEIGHT  300
-+
- //unsigned int gg_hash_passwd(unsigned char *passwd, unsigned int seed);
- void gg_connect_to_server(void);
-diff -Nur gg-0.2.1.orig/src/interface.c gg-0.2.1/src/interface.c
---- gg-0.2.1.orig/src/interface.c      Mon Jan 14 22:49:11 2002
-+++ gg-0.2.1/src/interface.c   Thu Jan 17 17:11:24 2002
-@@ -145,7 +145,7 @@
-       window = gtk_window_new(GTK_WINDOW_TOPLEVEL);
- #endif
-       gtk_object_set_data(GTK_OBJECT(window), "window", window);
--      gtk_widget_set_usize(window, 160, 300);
-+      gtk_widget_set_usize(window, GG_MIN_WIDTH, GG_MIN_HEIGHT);
-       gtk_window_set_title(GTK_WINDOW(window), _(TITLE));
- #ifdef USE_APPLET
-@@ -452,6 +452,7 @@
-       gtk_window_add_accel_group(GTK_WINDOW(window), accel_group);
- #endif
-       window_set_icon(window, NULL, GG_ONLINE_MAIN);
-+      gtk_window_set_default_size (GTK_WINDOW (window), config.width, config.height);
-       return window;
- }
-diff -Nur gg-0.2.1.orig/src/main.c gg-0.2.1/src/main.c
---- gg-0.2.1.orig/src/main.c   Mon Jan 14 22:52:31 2002
-+++ gg-0.2.1/src/main.c        Thu Jan 17 17:14:37 2002
-@@ -259,6 +259,8 @@
-       config.proxy_port = 8080;
-       config.connect_on_start = 1;
-       config.last_sysmsg = 0;
-+      config.width = GG_MIN_WIDTH;
-+      config.height = GG_MIN_HEIGHT;
-       
-       path = g_strconcat(getenv("HOME"), "/.gg/config", NULL);
-@@ -353,6 +355,12 @@
-               if (g_strncasecmp(line, "last_sysmsg ", 12) == 0) {
-                       config.last_sysmsg = atoi(line + 12);
-               }
-+                if (g_strncasecmp(line, "width ", 6) == 0) {                    
-+                        config.width = atoi(line + 6);                          
-+                }                                                               
-+                if (g_strncasecmp(line, "height ", 7) == 0) {                   
-+                        config.height = atoi(line + 7);                         
-+                }     
-       }
- #ifdef DEBUG
-       printf("read_config(): config: %d ********\n", config.uin);
-@@ -366,6 +374,9 @@
-       gchar *path;
-       GList *tmp_ignore;
-+      config.width=window->allocation.width;
-+      config.height=window->allocation.height;
-+      
-       path = g_strconcat(getenv("HOME"), "/.gg/config", NULL);
-       fp = fopen(path, "w");
-@@ -407,7 +418,9 @@
-       fprintf(fp, "connect_on_start %d\n", config.connect_on_start);
-       fprintf(fp, "last_sysmsg %d\n", config.last_sysmsg);
--
-+      fprintf(fp, "width %d\n", config.width);
-+      fprintf(fp, "height %d\n", config.height);
-+      
-       tmp_ignore = ignore;
-       while (tmp_ignore) {
-               fprintf(fp, "ignore %d\n", *(guint *) tmp_ignore->data);
This page took 0.060562 seconds and 4 git commands to generate.