]> git.pld-linux.org Git - packages/gg.git/blobdiff - gg.spec
- my little patchy... should get into the mainstream gg rather soon
[packages/gg.git] / gg.spec
diff --git a/gg.spec b/gg.spec
index 1b42c5451fb8ffc90e16a42bea71fcab9251455d..07fc2dee5a8de24fc04be773000261513cd8ce51 100644 (file)
--- a/gg.spec
+++ b/gg.spec
@@ -1,4 +1,21 @@
-%define                _release        3
+#
+# Conditional build:
+#
+# _without_gnome
+# _without_gnome_applet
+# _without_kde
+# _without_wm_applet
+# _without_sound
+
+
+# This looks like overkill but some day we might have *everything* bconded :)
+%{!?_without_gnome:            %define _need_gnome     1}
+%{!?_without_gnome:         %define _need_esd   1}
+%{!?_without_gnome_applet:     %define _need_gnome     1}
+%{!?_without_gnome_applet:  %define _nees_esd   1}
+%{!?_without_kde:                      %define _need_arts      1}
+%{!?_without_wm_applet:                %define _need_esd       1}
+
 
 Summary:       GNU Gadu - free talking
 Summary(pl):   GNU Gadu - wolne gadanie
@@ -13,10 +30,14 @@ Source1:    %{name}.png
 Patch0:                %{name}-home_etc.patch
 Icon:          gg.xpm
 URL:           http://netkrab.slackware.pl/gg/
-BuildRequires: gtk+-devel > 1.2.8
-BuildRequires: esound-devel > 0.2.7
-BuildRequires: gnome-libs-devel
-BuildRequires: gnome-core-devel
+BuildRequires:                                 gtk+-devel > 1.2.8
+%{?_need_gnome:BuildRequires:  gnome-libs-devel}
+%{?_need_gnome:BuildRequires:  gnome-core-devel}
+%if %{!?_without_sound:1}%{?_without_sound:0}
+%{?_need_arts:BuildRequires:   arts-devel}
+%{?_need_esd:BuildRequires:            esound-devel > 0.2.7}
+%endif
+
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _prefix         /usr/X11R6
@@ -113,34 +134,46 @@ Klient Gadu-Gadu na licencji GNU/GPL. Wersja dla KDE.
 
 %build
 LDFLAGS=" -L%{_libdir} %{rpmldflags}"
+
+%if %{!?_without_gnome_applet:1}%{?_without_gnome_applet:0}
 %configure \
+       %{?_without_sound:--disable-esd} \
        --enable-gnome \
        --enable-panel
 %{__make}
 mv -f src/gg src/gg_applet
 %{__make} clean
+%endif
 
+%if %{!?_without_gnome:1}%{?_without_gnome:0}
 %configure \
+       %{?_without_sound:--disable-esd} \
        --enable-gnome
 %{__make}
 mv -f src/gg src/gg_gnome
 %{__make} clean
+%endif
 
+%if %{!?_without_wm_applet:1}%{?_without_wm_applet:0}
 %configure \
+       %{?_without_sound:--disable-esd} \
        --enable-dockapp
 %{__make}
 mv -f src/gg src/gg_wm
 %{__make} clean
+%endif
 
+%if %{!?_without_kde:1}%{?_without_kde:0}
 %configure \
        --enable-docklet \
-       --enable-arts \
+       %{!?_without_sound:--enable-arts} \
        --disable-esd
 %{__make}
 mv -f src/gg src/gg_kde
 %{__make} clean
+%endif
 
-%configure
+%configure %{?_without_sound:--disable-esd}
 %{__make}
 
 %install
@@ -148,10 +181,10 @@ rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_applnkdir}/Network/Communications,%{_pixmapsdir},%{_datadir}/applets/Network/}
 
 %{__make} install DESTDIR=$RPM_BUILD_ROOT
-install src/gg_applet $RPM_BUILD_ROOT%{_bindir}
-install src/gg_gnome $RPM_BUILD_ROOT%{_bindir}
-install src/gg_wm $RPM_BUILD_ROOT%{_bindir}
-install src/gg_kde $RPM_BUILD_ROOT%{_bindir}
+%{!?_without_gnome_applet:install src/gg_applet $RPM_BUILD_ROOT%{_bindir}}
+%{!?_without_gnome:install src/gg_gnome $RPM_BUILD_ROOT%{_bindir}}
+%{!?_without_wm_applet:install src/gg_wm $RPM_BUILD_ROOT%{_bindir}}
+%{!?_without_kde:install src/gg_kde $RPM_BUILD_ROOT%{_bindir}}
 
 sed -e 's/xpm$/png/' src/GnuGadu.desktop \
        > $RPM_BUILD_ROOT%{_applnkdir}/Network/Communications/GnuGadu.desktop
@@ -203,23 +236,31 @@ fi
 %{_applnkdir}/Network/Communications/GnuGadu.desktop
 %attr(755,root,root) %{_bindir}/gg
 
+%if %{!?_without_gnome:1}%{?_without_gnome:0}
 %files gnome
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/gg_gnome
 %{_applnkdir}/Network/Communications/GnuGadu.desktop
+%endif
 
+%if %{!?_without_gnome_applet:1}%{?_without_gnome_applet:0}
 %files gnome-applet
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/gg_applet
 %attr(755,root,root) %{_datadir}/applets/Network/GnuGadu.desktop
 %attr(755,root,root) %{_sysconfdir}/CORBA/servers/GnuGadu.gnorba
+%endif
 
+%if %{!?_without_wm_applet:1}%{?_without_wm_applet:0}
 %files wm-applet
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/gg_wm
 %attr(755,root,root) %{_datadir}/applets/Network/GnuGadu.desktop
+%endif
 
+%if %{!?_without_kde:1}%{?_without_kde:0}
 %files kde
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/gg_kde
 %attr(755,root,root) %{_datadir}/applets/Network/GnuGadu.desktop
+%endif
This page took 0.139363 seconds and 4 git commands to generate.